You can add a link to a web page, an email address, a sheet of the current document, or another file to your document.

Insert a link to a web page or email address

MyOffice Spreadsheet recognizes and makes active links that start with www, http, https, ftp, and email addresses.

Examples of the links:

www.website.ru

https://website.com

http://website.ru

ftp://192.100.0.0

mailto:user@domain.ru

user.name@domain.com

A link such as mailto:user@domain.ru may also contain a subject line, the text of the email, and email addresses for sending copy and blind copy. For example,
mailto:user@domain.ru?subject=This%20is%20the%20subject&cc= user2@domain.ru&body=This%20is%20the%20body.

To avoid errors when you click links, it is recommended to specify the protocol in the URL. For example, http://website.ru.

The link can be displayed in the document as follows:

URL: For example, http://www.website.ru.

Text: For example, link.

To add a link to your document as a URL, follow these steps:

1.Copy the link from the source.

2.Switch to the edit mode of the cell where you want to insert the link.

3.Insert the link and press Space or Enter.

To add a text link to a document, follow these steps:

1.Copy the link from the source.

2.Specify the place to insert the link in one of the following ways:

To link the entire text in a cell, select this cell.

To format a single word in the cell text as a link, place the cursor in the word or select the entire word.

To format a part of the text in a cell as a link, select the entire text part.

To insert a word or text with a link to an empty cell, select the cell or place the cursor in it.

3.Insert the link in one of the following ways:

In the Command menu, select Insert > Link.

On the Toolbar, in the Insert section, click t_more button. In the insert pane that appears, click the t_insert_hyperlink Link button.

Right-click to open the context menu and select the Insert Link command.

Press Ctrl+K.

4.In the Insert Link window, on the Web Page or File tab:

If the Address field is blank, paste a link into it. By default, the link copied from the source in the first step is automatically inserted into the Address field.

If the Text field is not filled in, enter the text that will be displayed instead of the link. By default, text from the selected cell or the text selected in the cell or the word on which the cursor is placed is automatically inserted into the Text field.

Click OK.

When you save an .ods document in .xlsx format in a cell that contains multiple links at the same time, only the first link remains functional.

Insert a link to a sheet of the current document

You can create links to other sheets to make it easier to navigate through the document. For example, you can create a list on the first sheet with links to the other sheets of the document.

A link to a sheet may contain:

Sheet name. For example, Sheet 2.

Any other text. For example, see on this sheet.

To create a link to another sheet, follow the steps below:

1.Specify the place to insert the link in one of the following ways:

To create a link with the sheet name, select an empty cell or, if the cell is not empty, place the cursor in the desired cell position.

To add a word or text with a link to an empty cell, select the cell or place the cursor in it.

To format all text contained in a cell as a link, select the cell.

To format a single word in the cell text as a link, place the cursor in the word or select the entire word.

To format a part of the text in a cell as a link, select the entire text part.

2.Insert the link in one of the following ways:

In the Command menu, select Insert > Link.

On the Toolbar, in the Insert section, click t_more button. In the insert pane that appears, click the t_insert_hyperlink Link button.

Right-click to open the context menu and select the Insert Link command.

Press Ctrl+K.

3.In the Insert Link window, select the Sheet in This Document tab.

4.In the Sheets list, select the sheet to which you want to create a link.

5.In the Text field:

If the field displays the sheet name and you want to create a link with the sheet name, leave the contents of the field unchanged.

If the field displays the sheet name but you want to specify the link text, enter the required text manually.

If the field is filled with text from the selected cell or text selected in the cell, or a word on which the cursor is positioned, edit this text if necessary or leave it unchanged.

6.Click OK.

When you save an .ods document in .xlsx format in a cell that contains multiple links at the same time, only the first link remains functional.

Insert a link to a file

You can insert a link to a file that is located on the current computer or in a network folder into your document. The link can reference a file of any format.

The link can be displayed in the document as follows:

Paths to the file. For example, C:\Users\User\Documents\File.xlsx (Windows) or /Users/User/Downloads/File.xlsx (Linux) .

Text: For example, link to the file. You can specify the text of the link either in the cell or in the link insertion window.

To add a link to a file in your document, follow these steps:

1.Specify the place to insert the link in one of the following ways:

To link the entire text in a cell, select this cell.

To format a single word in the cell text as a link, place the cursor in the word or select the entire word.

To format a part of the text in a cell as a link, select the entire text part.

To insert a word or text with a link to an empty cell, select the cell or place the cursor in it.

2.Insert the link in one of the following ways:

In the Command menu, select Insert > Link.

On the Toolbar, in the Insert section, click t_more button. In the insert pane that appears, click the t_insert_hyperlink Link button.

Right-click to open the context menu and select the Insert Link command.

Press Ctrl+K.

3.In the Insert Link window, on the Web Page or File tab, select the file to which you want to insert a link using one of the following methods:

Select a file from the Recent Files list. This list shows the 50 most recent files that were opened in MyOffice Spreadsheet, MyOffice Text and MyOffice Presentation applications.

The Recent Files list does not include files that have been opened from the Cloud. To insert a link to a file from the Cloud, copy the link address of the file in your browser and paste it into your document as a link to a web page.

Select the file using the File manager. To do this, click Choose File button.

4.If you want the link to be displayed as text and the Text field is not filled in, enter the required text. By default, text from the selected cell or the text selected in the cell or the word on which the cursor is placed is automatically inserted into the Text field.

5.Click OK.

When you save an .ods document in .xlsx format in a cell that contains multiple links at the same time, only the first link remains functional.

Follow the link

To follow the link, click it while holding down the Ctrl pressed.

Web links are opened in the default browser used in the OS.

Files are opened in MyOffice Spreadsheet, MyOffice Text and MyOffice Presentation applications. If the file format is not supported, the file is opened in the application that is used by default in the OS to work with files of the corresponding format.

When you click the link to an email address, it opens the default email client in your OS. This software automatically creates a new email, into which the data specified in the link is copied.

When you click a link to a sheet, the corresponding sheet of the current document is opened.

Copy a link

To copy a link, right-click it and in the Context menu, select Copy Link URL.

Edit a link

To edit a link, follow the steps below:

1.Specify a link to edit:

If a cell contains only a link, select that cell or place the cursor on the link, or select part of the link/the entire link.

If the cell contains more than just a link, place the cursor on the link or select part of the link/the entire link.

2.Open the link editing window in one of the following ways:

In the Command menu, select Insert > Link.

On the Toolbar, in the Insert section, click t_more button. In the insert pane that appears, click the t_insert_hyperlink Link button.

Right-click to open the context menu and select the Edit Link command.

Press Ctrl+K.

3.In the Edit Link window, make the desired changes.

4.Click OK.

Delete a link

The link can be deleted using the edit window or the context menu. The link is deleted without the text that contains it.

To delete a link using the edit window, follow these steps:

1.Specify the link to delete:

If a cell contains only a link, select that cell or place the cursor on the link, or select part of the link/the entire link.

If the cell contains more than just a link, place the cursor on the link or select part of the link/the entire link.

2.Open the link editing window in one of the following ways:

In the Command menu, select Insert > Link.

On the Toolbar, in the Insert section, click t_more button. In the insert pane that appears, click the t_insert_hyperlink Link button.

Right-click to open the context menu and select the Edit Link command.

Press Ctrl+K.

3.In the Edit Link window, click the Remove Link button.

To delete a link using the context menu, follow these steps:

1.Specify the link to delete as described above.

2.Right-click to open the context menu and run the Delete Link command.

To delete multiple links at the same time, follow these steps:

1.Select the cells that contain the link data.

2.Right-click to open the context menu and run the Delete Links command.

If you want to delete the link along with the text that contains it, follow these steps:

1.Specify the link to delete:

If a cell contains only a link, select that cell or switch to cell editing mode and select the entire link.

If the cell contains more than just a link, switch to the cell editing mode and select the entire link.

2.Press Delete or Backspace.

Keyboard shortcuts for moving between window elements

The table below shows the keyboard shortcuts you can use to quickly move between elements in the Insert/Edit Link window.

Action

Keyboard shortcut

Open the window

Ctrl+K

Go to the next window element

Tab

Go to the previous window element

Shift+Tab

Open the selected tab

Space

Click Select File or OK

Space

Click OK regardless of which window element is currently selected

Enter

Go to the next/previous file in the Recent Files list

and

Go to the first file in the Recent files list

Home

Go to the last file in the Recent files list

End

Select a file in the Recent files list

Space

Close the window

Esc

Was this helpful?
Yes
No
Previous
Remove duplicates
Next
Notes