Enter data in a cell

To enter or change data in a cell:

1.Activate the edit mode in one of the following ways:

Select an empty cell.

Double-click the cell you want to edit.

Select the cell you want to edit and go to the Formula bar.

2. Enter data into the cell.

3. Save the entered data in one of the following ways:

Press Enter.

Click fx_accept_icon on the right side of the Formula bar.

Select another cell on the spreadsheet.

Use a comma "," as a delimiter for numbers.

To undo the changes you have made, do one of the following while editing:

On the right side of the Formula bar, click fx_reject_icon.

Press Esc.

Automatically adjust cell width

When you enter a number in a cell, the width of this cell is automatically adjusted to fit the number.

Cells width is not adjusted in the following cases:

The width of the column containing the cell has been previously changed in the manual mode.

The cell format is Text.

The cell is filled with text.

Floating cell

The floating cell appears when you edit a cell and move through the current sheet of the spreadsheet. The cell displays the current data in the cell you were editing, so it is convenient to use when navigating through a large amount of data in the document.

Fill cells automatically

MyOffice Spreadsheet allows to automatically fill the adjacent cells. A single cell as well as a range of cells can be selected as a sample for filling.

If a single cell with a text or numeric value is selected as a reference, its content is copied to subsequent cells when it is autofilled.

If a cell with a formula is selected as a reference, the subsequent cells will be filled in with data sequences calculated using the formula specified in the cell. The values are automatically recalculated if the data in the formula cells change.

If a cell range is selected as a sample range, the subsequent cells are filled in according to the rules described below.

The filled cells will have the same format as the sample range.

To fill the cells automatically:

1.Enter data in one or multiple cells.

2.Select the cells.

3.Move the mouse pointer over the corner handle of the selected cell so that the pointer looks like hand.

4.Drag the corner autofill handle over the range of cells that you want to fill in. You can drag the corner autofill handle vertically or horizontally.

Fill cells automatically with arithmetic sequences

You can fill in cells with arithmetic sequences. This type of sequence adds the difference between the previous two to each of the subsequent values. For example, 1, 2, 3, 4.

To autofill cells with an arithmetic sequence:

1.Enter the first 2 range values in the adjacent cells to set the reference.

2.Select the resulting range.

3.Move the mouse pointer over the corner handle of the selected cell so that the pointer looks like hand.

4.Drag the corner fill handle over the range of cells that you want to fill in.

Fill cells automatically with geometric sequences

You can fill in cells with geometric sequence. In this sequence view, each of the following values is multiplied by the specified progression denominator. For example, 0.25, 0.5, 1, 2.

To autofill cells with a geometric sequence:

1.Enter the first 3 range values in the adjacent cells to set the reference.

2.Select the resulting range.

3.Move the mouse pointer over the corner handle of the selected cell so that the pointer looks like hand.

4.Drag the corner fill handle over the range of cells that you want to fill in.

Autofill cells with data sequences: basics

Cells can be filled automatically if two or more cells from the sample range contain the following data:

oA series of integers, fractions, or negative numbers.

oDates or time.

oText and a number (with or without the delimiter). For example, Text 1, Text 2 or Text1, Text3, Text5.

oAbbreviated (Jan-Dec) or full month names (January-December).

oAbbreviated (Mon-Sun) or full weekdays names (Monday-Sunday).

If there is a text cell in the reference range, it will be copied when the series is filled automatically, whereas other cells will follow the specified sequence.

If a text cell is located between cells in a series that have different formats, the text will be copied when filling automatically, and cells of different formats will follow different sequences.

Cells of General and Number formats (Number, Currency, Accounting, Fraction, Percentage, Scientific) are considered as one sequence.

Date and Time are unrelated formats and are considered as separate sequences.

When filling with dates, the sequence is calculated based on the actual calendar difference.

Insert current date and time

You can insert the current date or time anywhere in the document.

To insert the current date:

1.Place the pointer where you want to insert the current date.

2.Insert the date in one of the following ways:

In the Command menu, select Insert > Current Date.

On the Toolbar, select the Insert section and click t_more. In the opened insert pane, click t_insert_date Date.

To insert the current time:

1.Place the pointer where you want to insert the current time.

2.Insert the time in one of the following ways:

In the Command menu, select Insert > Current Time.

On the Toolbar, select the Insert section and click t_more . In the opened insert pane, click t_insert_time Time.

The inserted data is static, which means it is not updated when the actual date and time change.

When you use the Cut command, the selected content is removed from the selected cell or range and placed to the clipboard. When copying, the selected contents of the document do not change and their copies are placed to the clipboard.

The content copied or cut retains its formatting.

You can insert the data copied into MyOffice Spreadsheet, as well as into other applications, such as MyOffice Text.

To cut the content of the file:

1.Select the cell or range you want to cut the content from.

2.Run the Cut command in one of the following ways:

In the Command menu, click Edit > Cut.

On the Toolbar, select the Edit section and click t_edit_cut Cut.

Right-click the selected text and then click Cut on the shortcut menu.

Press Ctrl+X or Shift+Delete.

To copy the content of the file:

1.Select the cell or range you want to copy the content from.

2.Run the Copy command in one of the following ways:

In the Command menu, click Edit > Copy.

On the Toolbar, select the Edit section and click t_edit_copy Copy.

Right-click the selected text and then click Copy on the shortcut menu.

Press Ctrl+C or Ctrl+Insert.

Paste the content

Pre-copied or cut out data in the clipboard is available for inserting.

If a range of cells was copied or cut, the data will take the same size range when inserted.

Inserting data into non-empty cells or ranges deletes the previous data without warning.

You can paste data from the clipboard with or without saving the original formatting.

To insert the content while keeping its original formatting:

1.Place the pointer where you want to insert the content or select the text (object) you want to replace with data from the clipboard.

2.Paste the content in one of the following ways:

In the Command menu, select Edit > Paste.

On the Toolbar, select the Edit section and click t_edit_paste Paste.

On the Toolbar, select the Edit section and click the arrow to the right of the t_edit_paste Paste button. In the drop-down list, select the Paste command.

Right-click to open the context menu and click Paste.

Press Ctrl+V or Shift+Insert.

The following rules apply when pasting data without preserving the original formatting:

Only the text is pasted from the clipboard. For example, when you paste a shape with text or a hyperlink, only the text that these objects contain is pasted into the document.

If the copied or cut fragment contains images, they are not pasted into the document.

If the clipboard contains a formula, only the result of the formula is pasted.

To insert unformatted text, follow the steps below:

1.Place the pointer where you want to insert the content or select the text (object) you want to replace with data from the clipboard.

2.Paste the content in one of the following ways:

In the Command menu, select Edit > Paste Values Only.

On the Toolbar, select the Edit section and click the arrow to the right of the t_edit_paste Paste button. In the drop-down list, select the Paste Values Only command.

Right-click to open the context menu and click Paste Values Only.

Clipboard history

The clipboard history is available in MyOffice Spreadsheet. It can simultaneously store up to 10 copied or cut entries with any type of data, such as formulas, text, etc. Each next entry will take the place of the oldest one in the history.

The clipboard history works between MyOffice Spreadsheet and MyOffice Text and vice versa.

To display the clipboard history, press Ctrl+Shift+Z. By default, the clipboard history is positioned next to the selected cell. To reposition the window, drag it to another area of the sheet, holding down the left mouse button.

To navigate through the clipboard history, use the following guidelines:

To insert the selected entry from the clipboard history into a specified area in a document, left-click or use the Enter button.

To switch between the spreadsheet you are working on and the clipboard history, use the Tab button.

To navigate through the clipboard history, use the arrow keys (Up Arrow and Down Arrow).

Click wind_close in the window title bar to close the clipboard history.

Once closed, the clipboard history is not cleared. Data from the clipboard history is only deleted when exiting the MyOffice Spreadsheet.

Delete data

To delete the contents of a cell:

1.Select a cell or a range of cells that you want to clear.

2.Press Delete or Backspace.

Was the material useful?
Yes
No
Users found this material useful: 0 из 0