Работа со структурированными ссылками поддерживается только в таблицах, к которым применен табличный стиль форматирования в программе Excel (так называемых «умных» таблицах).

«Умные» таблицы имеют имя (по умолчанию – Таблица1, Таблица2 и т.д.) и состоят их следующих областей:

строка заголовка,

область данных,

строка итогов.

Использование структурированных ссылок

Формулы со структурированными ссылками оперируют не адресами ячеек и диапазонов ячеек, а именами таблицы и столбцов таблицы, а также названиями областей таблицы.

Ниже приведены примеры обычных и структурированных ссылок.

Описание

Обычная ссылка

Структурированная ссылка

Ссылка на диапазон ячеек столбца Продажи
таблицы Таблица1

=СУММ(B2:B8)

=СУММ(Таблица1[Продажи])

Ссылка на область данных таблицы Таблица2

=СУММ(A2:D8)

=СУММ(Таблица2[#Данные])

references_1       references_2

Структурированные ссылки могут использоваться как в таблице, так и за ее пределами.

Если формула со структурированной ссылкой расположена непосредственно в таблице, то указывать название таблицы в данной ссылке не нужно. Если имя таблицы по какой-либо причине указывается в ссылке, то оно автоматически удаляется при вводе формулы. Например, формула =СУММ(Таблица1[Продажи]) будет автоматически исправлена на =СУММ([Продажи]).

Если формула со структурированной ссылкой расположена за пределами таблицы, то указание имени таблицы является обязательным условием.

Чтобы узнать имя таблицы, выделите в ней любую ячейку. Имя таблицы отобразится на панели инструментов, в разделе Таблица.

Чтобы скопировать имя таблицы, выделите его щелчком мыши.

Синтаксис структурированных ссылок

Структурированные ссылки могут обращаться к следующим данным таблицы:

Указатель

Описание

#Все

Вся таблица, включая строку заголовка и строку итогов (при их наличии)

#Заголовки

Только строка заголовка

#Данные

Только строки данных

#Итого

Только строка итогов

@Имя столбца

ИЛИ

@

ИЛИ

#Эта строка

Ячейка на пересечении текущей строки и указанного столбца (неявное пересечение)

 

 

 

Указатель #Эта строка автоматически меняется на указатель @

Ниже приведены примеры структурированных ссылок.

 

Вся таблица

Только данные

Только заголовки

Только итоги

Таблица Таблица1

Таблица1[#Все]

Таблица1

 

Таблица1[#Данные]

Таблица1[#Заголовки]

Таблица1[#Итого]

Столбец N

Таблица1[[#Все],[N]]

Таблица1[N]

 

Таблица1[[#Данные],[N]]

Таблица1[[#Заголовки],[N]]

Таблица1[[#Итого],[N]]

Столбцы с N по M

Таблица1[[#Все],[N]:[M]]

Таблица1[[N]:[M]]

 

Таблица1[[#Данные],[N]:[M]]

Таблица1[[#Заголовки],[N]:[M]]

Таблица1[[#Итого],[N]:[M]]

Ввод структурированной ссылки в формулу

Ввод формул, которые содержат структурированные ссылки, осуществляется стандартными способами.

Чтобы указать в формуле название «умной» таблицы, выполните следующие действия:

1.Начните вводить название таблицы. В выпадающем списке отобразятся названия всех «умных» таблиц, которые содержатся в документе.

2.Выберите название требуемой таблицы с помощью мыши или клавиш клавиатуры:

Щелкните по названию таблицы левой кнопкой мыши.

Выделите название таблицы с помощью клавиш клавиатуры ↓ и ↑ и нажмите клавишу Enter.

Название таблицы подставится в формулу.

Чтобы ввести в формулу имя столбца или указатель на область данных таблицы (например, #Итого или @), выполните следующие действия:

1.Введите символ [ (левая квадратная скобка). В выпадающем списке отобразятся названия столбцов и указатели на области данных таблицы.

2.Выберите требуемый элемент списка с помощью мыши или клавиш клавиатуры:

Щелкните по строке элемента левой кнопкой мыши.

Выделите строку элемента с помощью клавиш клавиатуры ↓ и ↑ и нажмите клавишу Enter.

Выбранный элемент подставится в формулу.

Если указатель на область данных таблицы (например, [#Заголовки]) введен в формулу корректно, то он выделяется цветом, а в таблице подсвечивается диапазон, к которому он обращается (например, строка заголовка).

Управление «умными» таблицами

«Умные» таблицы отображаются в приложении «МойОфис Таблица» в том виде, в котором они были сохранены в приложении Excel. Например, если в Excel строка итогов была отключена, то в «МойОфис Таблица» таблица отображается без строки итогов. Включение и отключение областей таблицы, а также фильтрации в строке заголовка в приложении «МойОфис Таблица» не поддерживается.

При необходимости строку итогов можно создать вручную. Для этого введите формулу в любую ячейку строки, следующей за последней строкой таблицы.

При работе с «умной» таблицей можно выполнять следующие операции:

Редактировать названия столбцов. При этом названия столбцов автоматически обновляются в структурированных ссылках таблицы.

Вставлять строки и столбцы между существующими строками и столбцами (но не в конце таблицы).

Копировать листы с «умными» таблицами и вставлять их в тот же документ. Таблице, расположенной на копии листа, автоматически присваивается уникальное имя. Во всех структурированных ссылках имя таблицы-оригинала автоматически заменяется на имя таблицы-копии.

Вычисляемые столбцы

Если в таблицу необходимо добавить столбец, все ячейки которого содержат одну и ту же формулу, создайте вычисляемый столбец. Для создания вычисляемого столбца можно использовать любой столбец таблицы, который не содержит данных.

Чтобы сделать столбец вычисляемым, введите в любую ячейку данного столбца требуемую формулу и нажмите клавишу Enter.

Все ячейки столбца автоматически заполнятся введенной формулой.

Для вычисляемых столбцов действуют следующие правила:

Если формула редактируется в любой ячейке вычисляемого столбца, то аналогичное редактирование формулы автоматически осуществляется в остальных ячейках данного столбца.

Если часть данных в столбце удаляется или вместо формулы вводятся обычные данные, то столбец перестает быть вычисляемым (изменения в формулах перестают распространяться на весь столбец).

Если консистентность столбца восстанавливается вручную (то есть во всех ячейках снова содержится одна и та же формула), то столбец снова становится вычисляемым.

Авторасширение «умной» таблицы

Авторасширение «умной» таблицы выполняется при вводе данных в смежные ячейки, расположенные в столбце справа от «умной» таблицы. Если в таблице отсутствует строка итогов, то авторасширение также выполняется при вводе данных в смежные ячейки, расположенные в строке, следующей за последней строкой таблицы.

Данные могут вводиться следующими способами:

Вручную.

Если в смежный столбец вводится формула, то данный столбец становится вычисляемым.

Из буфера обмена. Авторасширение выполняется, если данные вставляются слева/снизу от таблицы или вставляются одновременно и в таблицу, и в смежные ячейки.

Путем автозаполнения ячеек, когда в качестве ячейки-образца выбирается одна или несколько ячеек «умной» таблицы.

Авторасширение выполняется, если:

в области авторасширения не содержатся данные;

вставляемые данные не накладываются на другую «умную» таблицу.

В текущей версии не поддерживается авторасширение «умных» таблиц при автозаполнении ячеек, если в качестве ячейки-образца выбрана ячейка таблицы со структурированной ссылкой.
Был ли материал полезным?
Да
Нет
Пользователи, считающие этот материал полезным: 0 из 0