Приложение: Таблица macOS

В формулах и функциях текущего документа можно ссылаться на данные из одного или нескольких внешних документов.

В этой версии приложения действуют следующие ограничения:

Текущий и внешний документы должны быть сохранены в формате XLSX, ODS или XODS.

Текущий и внешний документы должны быть локальными, то есть должны находиться непосредственно на вашем компьютере.

Поддерживается создание ссылок на ячейки и диапазоны ячеек внешнего документа. При этом не допускаются структурированные ссылки, а также ссылки на имена ячеек и диапазонов.

Ссылка, которая вводится вручную в ячейку с именем, должна быть абсолютной.

Ссылку на данные из внешнего документа можно создать одним из следующих способов:

открыть внешний документ и выделить требуемую ячейку или диапазон ячеек щелчком мыши;

ввести вручную, не открывая внешний документ.

Создать ссылку щелчком мыши

Чтобы в формуле или функции текущего документа создать ссылку на данные из внешнего документа щелчком мыши, выполните следующие действия:

1.Откройте документ, в котором будет содержаться формула или функция со ссылкой, и внешний документ, на данные которого требуется создать ссылку. Если внешний документ был открыт ранее, убедитесь, что в нем сохранены все внесенные изменения.

2.В текущем документе выделите ячейку, в которую нужно ввести формулу или функцию.

3.В строке формул или непосредственно в ячейке введите знак = и начните вводить формулу или функцию.

4.Перейдите к внешнему документу и выберите лист, на ячейку или диапазон ячеек которого требуется создать ссылку.

5.Выберите на листе требуемую ячейку или диапазон ячеек. В строке формул внешнего и текущего документа отобразится введенная формула или функция из текущего документа. При необходимости формулу/функцию можно редактировать как в текущем, так и во внешнем документе.

6.Перейдите в текущий документ, завершите ввод функции или формулы и нажмите кнопку fx_accept_icon в строке формул или нажмите клавишу enter Enter на клавиатуре.

Ввести ссылку вручную

Чтобы в формуле или функции текущего документа создать ссылку на данные из внешнего документа вручную, необходимо ввести строку вида 'путь[имя.расширение]Лист'!Ячейка, где:

путь – путь к внешнему документу, который может быть указан как:

oОтносительный путь – путь к внешнему документу, описываемый относительно базовой директории исходного документа. Пример: ../Subfolder/Внешний документ.xlsx.

oАбсолютный путь – путь к документу, описываемый от корня логического диска (корня установленной операционной системы). Пример: /Users/Username/Downloads/Subfolder/Внешний документ.xlsx.

oАбсолютный путь к внешнему документу с использованием схемы file (схема URI). Пример: file:///Users/Username/Downloads/Subfolder/Внешний документ.xlsx.

имя.расширение – имя и расширение внешнего файла. Например: Внешний документ.xlsx.

Лист – имя листа во внешнем документе. Например: Лист1.

Ячейка – адрес ячейки или диапазона ячеек во внешнем документе. Например: A1 или A1:A10.

Примеры

В данном примере документ document.xlsx, расположенный в базовой директории /Users/Username/Downloads/, ссылается на данные из внешнего документа external.xlsx, расположенного в той же директории.

Относительный путь к внешнему документу

../external.xlsx

Абсолютный путь к внешнему документу

/Users/Username/Downloads/external.xlsx

Абсолютный путь к внешнему документу с использованием схемы file (схема URI)

file:///Users/Username/Downloads/external.xlsx

Формула с относительной ссылкой

='[external.xlsx]Лист1'!A1+A1

Функция с абсолютной ссылкой

=СУММ('file:///Users/Username/Downloads/[external.xlsx]
Лист1'!A1:A10)

В данном примере документ document.xlsx, расположенный в базовой директории /Users/Username/Downloads/, ссылается на данные из внешнего документа external.xlsx, расположенного во вложенной директории /Users/Username/Downloads/Subfolder/.

Относительный путь к внешнему документу

../Subfolder/external.xlsx

Абсолютный путь к внешнему документу

/Users/Username/Downloads/Subfolder/external.xlsx

Абсолютный путь к внешнему документу с использованием схемы file (схема URI)

file:///Users/Username/Downloads/Subfolder/external.xlsx

Формула с относительной ссылкой

='Subfolder/[external.xlsx]Лист1'!A1+A1

Функция с абсолютной ссылкой

=СУММ('file:////Users/Username/Downloads/Subfolder/[external.xlsx]
Лист1'!A1:A10)

В данном примере документ document.xlsx, расположенный в базовой директории /Users/Username/Downloads/, ссылается на данные из внешнего документа external.xlsx, расположенного в другой директории – /Volumes/USB_flash/SomeFolder/.

Относительный путь к внешнему документу

/Volumes/USB_flash/SomeFolder/external.xlsx

Абсолютный путь к внешнему документу

/Volumes/USB_flash/SomeFolder/external.xlsx

Абсолютный путь к внешнему документу с использованием схемы file (схема URI)

file:///Volumes/USB_flash/SomeFolder/external.xlsx

Формула с относительной ссылкой

='../Volumes/USB_flash/SomeFolder/[external.xlsx]Лист1'!A1+A1

Функция с абсолютной ссылкой

='file:///Volumes/USB_flash/SomeFolder/[external.xlsx]
Лист1'!A1:A10)

Обновить данные

Так как данные во внешнем документе могут меняться, рекомендуется периодически обновлять ссылки на эти данные в текущем документе.

Чтобы обновить ссылки после открытия текущего документа, нажмите кнопку Обновить данные в строке уведомления «Связанные документы могли измениться. Обновите этот документ, чтобы получить последние данные». Данная строка отображается под панелью инструментов.

Приложение выполнит пересчет формул и функций с учетом новых значений из внешнего документа.

Если документ недоступен, то под панелью инструментов отобразится строка уведомления «Связанные документы недоступны. В таблице используются последние сохраненные данные». Нажмите в данной строке кнопку Закрыть.

Чтобы обновить данные при работе с документом, выполните одно из следующих действий:

Выберите пункт командного меню Данные > Обновить данные.

На панели инструментов, в разделе Данные нажмите кнопку t_data_refresh_data (Обновить данные).

Нажмите сочетание клавиш shift Shift+command_grey Cmd+F5.

Ошибка #REF! отображается в ячейках, если:

При создании ссылки указанный в ссылке внешний документ недоступен (или в нем не существует указанного листа), и для него нет сохраненных ранее значений.

При загрузке документа для указанного в ссылке внешнего документа нет сохраненных значений (данные не были получены при создании ссылки).

Был ли материал полезным?
Да
Нет
Предыдущее
Имена в формулах и функциях
Следующее
Структурированные ссылки