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LIST OF ABBREVIATIONS 

The abbreviations used herein are specified in Table 1. 

Table 1. Abbreviations and definitions 

Abbreviation Definition 

OS Operating system 

MyOffice Text MyOffice Text. Home Edition desktop application 

MyOffice Spreadsheet MyOffice Spreadsheet. Home Edition desktop application 

MyOffice Presentation MyOffice Presentation. Home Edition desktop application 

MyOffice software MyOffice Text, MyOffice Spreadsheet, MyOffice Presentation desktop 

applications 
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1 ABOUT 

1.1 General information 

MyOffice Spreadsheet is an editor for creating spreadsheets, running calculations, analyzing 

data, forming summary reports, and automating data processing using macro commands on Linux, 

Windows, and macOS operating systems. 

MyOffice Spreadsheet is included in the following suites: 

MyOffice Standard 3. Home Edition 

MyOffice for home 

 

For a detailed description of the application features, please refer to your product-specific 

Feature list. 

 

The application functionality may vary depending on the product and operating system. 

 

1.2 System requirements 

For a list of software and hardware requirements, please refer to your product's 

Installation Guide. 
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1.3 Limitations 

1.3.1 Supported file formats 

Table 2 and Table 3 contains a list of formats supported by MyOffice Spreadsheet. 

Table 2. Supported file formats in Windows/Linux 

If you want to... Supported file formats 

Open or import files .xls, .xlsx, .ods, .xods, .csv, .scsv, .tsv, .tab, .txt, .xlsm, .xlsb, .xots 

Save/export files .xlsx, .ods, .xods, .pdf, .pdf/a-1, .csv, .scsv, .tsv, .tab, .txt, .xlsb, .xots 

Table 3. Supported file formats in macOS 

If you want to... Supported file formats 

Open or import files .xlsx, .ods, .xods, .csv, .scsv, .tsv, .tab, .txt, .xlsm, .xots 

Save/export files .xlsx, .ods, .xods, .pdf, .pdf/a-1, .csv, .scsv, .tsv, .tab, .txt, .xots 

 

1.3.2 Supported interface languages 

‒ English 

‒ French 

‒ Russian 
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2 BEFORE YOU BEGIN 

2.1 Install the application 

For detailed description of installation of MyOffice Standard software, please refer to 

MyOffice Text, MyOffice Spreadsheet, MyOffice Presentation. Installation Guide. 

2.2 Open the application 

2.2.1 Open the application in Windows OS 

To open MyOffice Spreadsheet application installed from the Microsoft Store, click its 

shortcut in the OS main menu (see Figure 1). 

 

Figure 1. MyOffice icon in the main menu of Windows OS 

To open MyOffice Spreadsheet application installed from https://myoffice.ru/products/ofis-

dlya-doma/, click its shortcut on the desktop (see Figure 2) or in the OS main menu (see Figure 3). 
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Figure 2. MyOffice icon on Windows OS desktop 

 

Figure 3. MyOffice icon in the main menu of Windows OS 

2.2.2 Open the application in Linux OS 

To open MyOffice Spreadsheet in Linux, click its shortcut in the OS application menu  

(see Figure 4). 
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Figure 4. MyOffice software desktop shortcuts for Linux OS 

2.2.3 Open the application in macOS 

To open MyOffice Spreadsheet in macOS, click its icon in Launchpad (see Figure 5). 
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Figure 5. MyOffice Spreadsheet icon in Launchpad 

The first time you launch MyOffice Spreadsheet, the application shortcut is automatically 

added to the Dock. 
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2.3 License agreement 

The first time you launch MyOffice software, do the following: 

1. Make sure that in the Terms of Use and Privacy Policy window (see Figure 6), in the 

Region drop-down list, your region of residence is correctly selected. If necessary, select it 

manually from the drop-down list. 

2. Please carefully read the terms and conditions of the License Agreement and Privacy 

Policy. 

3. If you agree to the terms and conditions specified, please select the I accept the Terms 

of Use and Privacy Policy checkbox. 

4. If you agree with clauses 5–7 of the Privacy Policy, select the Allow to collect 

anonymous statistics on app usage to improve product quality checkbox. This 

checkbox is not displayed if Other is selected in the Region drop-down list. 

5. Click Get started. 

 

Figure 6. Terms of Use and Privacy Policy window 
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You can disable the collection of anonymous statistics in further work with the application 

if necessary. To do this, follow these steps: 

1. In the Help menu, click About (see Figure 7). 

 

Figure 7. About command menu option 

2. In the About window (see Figure 8), clear the Send anonymous statistics on app usage 

to improve product quality checkbox. 

3. Click Close. 

 

Figure 8. About window 
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2.4 Subscription activation 

If the license agreement is accepted (see the section above), the first time you launch 

MyOffice software, the subscription management window opens (see Figure 9), where you can: 

‒ Subscribe to use the product with a free 21-day period. 

‒ If the subscription was obtained via MyOffice partners, enter the code to activate the 

subscription on the current device. 

‒ If you subscribed at https://myoffice.ru/products/ofis-dlya-doma/, log in to your 

MyOffice account to activate the subscription on your current device. 

 

Figure 9. Subscription management window 

https://myoffice.ru/products/ofis-dlya-doma/
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You must have access to the Internet to subscribe and activate your subscription. 

Without activation, some functions in applications are not available and are labeled with 

 markers (see Figure 10) or  icons. 

 

Figure 10. Function is not available 

2.4.1 Subscribe 

To subscribe with a free 21-day period, in the Subscription Management window  

(see Figure 9), click Try for Free. 

If this window has been closed, in the Subscription menu, click Try for Free  

(see Figure 11). 

 

Figure 11. Subscription menu 

To subscribe, please follow the instructions on the website. 

To add the current device to a subscription, in the Subscription menu, select  

Log In to Account (see Figure 11). 

In the Log In window (see Figure 12), enter your account details and click Log In. 
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Figure 12. Log In window 

In the Choose a Subscription window (see Figure 13), select the subscription for the current 

device and click Continue with Subscription. 

 

Figure 13. Choose a Subscription 
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In the Trial period activated window (see Figure 14), click OK. 

 

Figure 14. Trial period activated window 

2.4.2 Enter activation code 

If you subscribed via MyOffice partners, add your current device to the subscription using an 

activation code. To do this, in the subscription management window (see Figure 9), click 

Activate Code. 

If this window has been closed, in the Subscription menu, click Activate Code  

(see Figure 11). 

In the Code Activation window (see Figure 15), enter the activation code and click Activate. 
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Figure 15. Code Activation window 

2.4.3 Log in to your account 

If you purchased a subscription at https://myoffice.ru/products/ofis-dlya-doma/, log in to your 

MyOffice account to activate the subscription on your current device. To do this, in the subscription 

management window (see Figure 9), click Activate Code. 

If this window has been closed, in the Subscription menu, click Log In to Account 

(see Figure 11). 

In the Log In window (see Figure 12), enter your account details and click Log In. 

In the Choose a Subscription window (see Figure 13), select the subscription for the current 

device and click Continue with Subscription. 

2.4.4 Subscription details 

To view subscription details, in the Subscription window, select My Subscription  

(see Figure 11). 

My Subscription window will open (see Figure 16). 

https://myoffice.ru/products/ofis-dlya-doma/
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Figure 16. My Subscription window 

2.5 Application update 

You can enable automatic checking for new software versions under the following 

conditions: 

‒ You installed MyOffice software from https://myoffice.ru. 

‒ You use the software on Windows or macOS. 

To automatically check for new versions, do the following: 

1. After the first launch of the MyOffice Text, MyOffice Spreadsheet and 

MyOffice Presentation applications, close them and reopen either of these applications. 

2. In the Application Update window (see Figure 17), click Check automatically. 

https://myoffice.ru/
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Figure 17. Application Update window 

If you want to disable the automatic search for new versions, click the Don't check button. 

You can also check for new versions manually. To do this, select Help > Check for Updates 

in the Command menu (see Figure 18). 

 

Figure 18. Check for Updates command menu option 

The steps to update the application are described in detail in MyOffice Text, 

MyOffice Spreadsheet, MyOffice Presentation desktop applications. Installation Guide. 
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3 INTERFACE OVERVIEW 

3.1 MyOffice Spreadsheet window 

The MyOffice Spreadsheet window consists of the following elements (see Figure 19): 

1. Command menu 

2. Toolbar 

3. Range field 

4. Formula bar 

5. Workspace 

6. Sidebar 

7. Sheet tabs 

8. Status bar 

 

Figure 19. Main window of MyOffice Spreadsheet 
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3.2 Command menu 

The Command menu (see Figure 20) contains the main commands for working with 

the application. 

 

Figure 20. Command menu 

To quickly run these commands, you can use: 

‒ Keyboard shortcuts (see Table 27 and Table 28) which are specified next to the 

commands in the Command menu. 

‒ Quick Actions box (see Section 3.10). 
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3.3 Toolbar 

The Toolbar (see Figure 21) contains tools for working with the content of the spreadsheet. 

 

Figure 21. Toolbar 

You can change the way the Toolbar is displayed as follows: 

‒ Select the Toolbar display mode or hide the Toolbar. 

‒ Hide or display the Toolbar titles section titles. 

‒ Customize the Favorites section. 

‒ Hide and display the Favorites section. 

3.3.1 Change the Toolbar display mode 

To change the Toolbar display mode, do the following: 

1. In the Command menu, select View > Toolbar (see Figure 22). 

 

Figure 22. View command menu 

2. In the sub-menu that opens, select the desired display mode: 

‒ Regular: Tools are arranged in two lines; the section titles are displayed. If necessary, 

the Toolbar section titles can be hidden (see Section 3.3.2). 

‒ Compact: Tools are arranged in one line; section titles are not displayed. 

‒ Hide Toolbar: The Toolbar is not displayed. 
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To quickly switch between the Regular and the Compact mode, use  

the  Collapse Toolbar (see Figure 23) /  Expand Toolbar (see Figure 24) buttons located in 

the right part of the Toolbar. 

 

Figure 23. Compact view button 

 

Figure 24. Regular view button 
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3.3.2 Hide or display section titles 

In MyOffice Spreadsheet, the Toolbar (see Figure 21) has several sections. Each section 

(except for the Favorites section) consists of various tools to perform the specific task. For example, 

the Number Format section contains tools to edit cell formats. 

The title of each section is displayed if the Toolbar display type is Regular 

(see Section 3.3.1). Toolbar titles can be hidden to optimize your workspace. To do this, do 

the following: 

1. In the View menu, select Toolbar (see Figure 22). 

2. In the sub-menu that opens, uncheck the Section Titles menu. 

To display the section titles, check the menu again. 

 

If the Toolbar is hidden or displayed in the compact form, the Section Titles menu is 

disabled. 

 

3.3.3 Hide or display sections content 

Toolbar sections can be collapsed automatically (when reducing/increasing the size of 

the main application window), or manually. 

To collapse a Toolbar section manually, hover the cursor over its right border and click 

the  button (see Figure 25). 

 

Figure 25. Section collapse button 

To display the tools of a hidden section, click it with the mouse (see Figure 26). 
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Figure 26. Section tools 

To collapse the section, click the  button (see Figure 27). 

 

Figure 27. Button to display section tools 
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3.3.4 Customize the Favorites 

You can add to the Favorites section of the Toolbar: 

‒ Frequently used toolbar buttons. 

‒ Buttons to run frequently used command menu options. 

‒ Buttons to run frequently used macros (see Section 4.15). 

You can add from 1 to 14 items to the Favorites. 

 

The content of the Favorites section is stored in the application settings on the current 

computer and is not transferred in the documents created on it. 

3.3.4.1 Add an item 

To add a Command menu item to Favorites, follow these steps: 

1. Run the add command in one of the following ways: 

‒ If the Favorites section is empty, click the  Add button in it (see Figure 28). 

 

Figure 28. Add button 

‒ If the Favorites section contains the added items, right-click anywhere in the section 

and run the Add Action context menu command (see Figure 29). 

 

Figure 29. Add Action command 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 36 

2. In the window that opens (see Figure 30), select the Command menu item that you want 

to add to Favorites. 

 

Figure 30. Window for adding Command menu items 

To add a button from the Toolbar to Favorites, right-click on it and run the Add to Favorites 

command (see Figure 31). 

 

Figure 31. Add to Favorites command 

 

Currently, it is not possible to add Toolbar buttons that are displayed after clicking  

the  button. 
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When added to Favorites, the button is not removed from the Toolbar section in which it 

is located. 

3.3.4.2 Add a button to run a macro command 

To add a button to the Favorites to run a macro, follow the steps below: 

1. On the Sidebar, click  Macros (see Figure 32). 

2. Hover the mouse cursor over the name of the desired macro and click  More. 

3. In the drop-down list, hover your mouse over the Add to Favorites option. 

4. In the pane that appears, choose the icon for the button to run the macro. 

 

Figure 32. Add to Favorites command 

The chosen button will be added to the Favorites section. 

When you hover the mouse cursor over the button, a tooltip will be displayed in the following 

format: Macro: <macro name>. When you click the button, the corresponding macro command 

will be run. 

The button to run the macro is displayed in all text documents on the current computer. 

If there is no corresponding macro in the document, the button is inactive and when you hover the 

mouse cursor over it, a tooltip will be displayed in the following format: Macro from another 

document: <macro name>. 
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3.3.4.3 Change the button to run a macro 

To change the button to run a macro, follow the steps below: 

1. On the Sidebar, click  Macros (see Figure 32). 

2. Hover the mouse cursor over the name of the desired macro and click  More. 

3. In the drop-down list, hover your mouse over the Change Icon option (see Figure 33). 

4. In the pane that appears, choose the new icon for the button to run the macro. 

 

Figure 33. Change Icon option 

3.3.4.4 Move an item 

To change the position of an item in the Favorites section, follow these steps: 

1. Right-click the item to open the context menu (see Figure 34). 

2. In the context menu, select the desired command: 

‒ Move to Beginning: Make the selected item the first in the section. 

‒ Move Left: Swap the selected and previous element. 

‒ Move Right: Swap the selected and subsequent element. 

‒ Move to End: Make the selected item the last in the section. 
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Figure 34. Commands to move an item 

3.3.4.5 Delete an item 

To delete a Command menu item from the Favorites section, right-click it and run 

the Remove from Favorites command (see Figure 34). 

To remove a Toolbar button from the Favorites section, follow these steps: 

1. Right-click it in the Favorites section or in the section from which it was added 

(see Figure 35). 

2. Run the Remove from Favorites context menu command. 

 

Figure 35. Remove from Favorites command 

To remove a button for a command menu option from the Favorites section, right-click it 

and run the Remove from Favorites option (see Figure 35). 

A button to run a macro can be removed from the Favorites section whether or not the macro 

is contained in the current document. Removal is carried out in the same way as removing a button 

to run a command menu option. 
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If the macro is contained in the current document, the button can also be removed using 

the macro pane: 

1. On the Sidebar, click  Macros. 

2. Hover the mouse cursor over the name of the desired macro and click  More. 

3. In the drop-down list, select the Remove from Favorites option (see Figure 36). 

 

Figure 36. Remove from Favorites option 

In addition, the button is removed from the Favorites section if the macro command 

corresponding to it is deleted from the document. 

3.3.4.6 Clear the section 

To remove all items from the Favorites section, right-click anywhere in the section and run 

the Clear context menu command (see Figure 34). 
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3.3.5 Hide or display the Favorites section 

By default, the Toolbar displays the Favorites section. 

To hide the section, do one of the following: 

‒ In the View menu, select Toolbar and in the sub-menu that opens uncheck the Favorites 

check box (see Figure 37). 

 

Figure 37. View menu 

‒ If the Favorites section is empty, hover your mouse over the  Add button and click  

in its upper-right corner (see Figure 38). 

 

Figure 38. Favorites section 

To display the section, re-select the Favorites check box in the Command menu. 

 

The Favorites check box is locked if the Toolbar is hidden. 
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3.4 Range field 

The range field allows to do the following: 

‒ Display the address (see Figure 39 and Section 4.6.3) or name 

(see Figure 40 and Section 4.6.9) of the selected cell or cell range. 

‒ Create new names of cells/cell ranges (see Section 4.6.9.1.1). 

 

Figure 39. Cell range address 

 

Figure 40. Cell range name 
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3.5 Formula bar 

The Formula bar displays the real contents of the selected cell.  

For example, A1 cell (see Figure 41) displays and contains number 1. A2 cell displays and contains 

the number 2. A3 cell displays the number 3 but contains a formula whose result is 3. 

 

Figure 41. A1 cell content on the Formula bar 

 

Figure 42. A2 cell content on the Formula bar 

 

Figure 43. A3 cell content on the Formula bar 
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3.6 Workspace 

The workspace (see Figure 44) is the active area of the sheet, within which user actions are 

performed. If necessary, the boundaries of the workspace can be expanded (see Section 4.3.1). 

 

Figure 44. Workspace 
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3.7 Sidebar 

The Sidebar displays the following buttons (see Figure 45): 

 

Figure 45. Sidebar 

‒  Find and Replace: Open the Find and Replace pane (see Section 4.4.6). 

‒  Insert Function: Open the Insert function pane (see Section 4.5.3). 

‒  Pivot Table: Open the pivot table settings pane (see Section 4.9). The button 

is displayed when a pivot table element is selected. 

‒  Macros: Open a pane to work with macros (see Section 4.15). This button 

is displayed if the file contains at least one macro. 

‒  Name Manager: Open the Name Manager (see Section 4.6.9). 

‒  Smart Table: Open the smart table customization pane (see Section 4.8). The button 

is displayed if a smart table element or the entire smart table is selected in the document. 

‒  All Validations: Open the pane for working with cells containing data validation 

(see Section 4.4.3). 
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‒  Recovered Files: Open the document backups pane (see Section 4.1.11). The button 

is displayed if there is at least one unsaved copy. 

‒  Manage Protection: Open the file protection management pane (see Section 4.16). 

‒  Feedback: Send feedback on the application. 
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3.8 Sheet tabs 

The Sheet tabs (see Figure 46 and Section 4.2) are provided for navigating through 

the spreadsheet sheets. 

 

Figure 46. Sheet tabs 
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3.9 Status bar 

The Status bar displays the following data and tools: 

‒ Icon of the selected formula recalculation mode (see Figure 47 and Section 4.6.4). 

‒ Automatic calculation values (see Section 4.5.2). 

‒ Tools to zoom in or out the active sheet (see Section 4.2.6). 

 

Figure 47. Status bar when working with local files 
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3.10 Quick Actions box 

The Quick Actions box (see Figure 48) allows you to quickly run various commands and 

perform actions in MyOffice Spreadsheet (see Section 3.2). 

To open the Quick Actions box, do one of the following: 

‒ In the Command menu, select Help > Quick Actions. 

‒ Press Ctrl+/ (OS Windows / OS Linux). In macOS, press ⌘ Cmd+/. 

 

Figure 48. Quick Actions box 
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Use one of the following methods to select the command from the list: 

‒ Scroll the list to the desired command using the mouse scroll wheel or the right vertical 

scroll bar. Confirm the command by clicking it or pressing Enter. 

‒ Start typing the command name in the search bar. When the desired command appears 

in the search results, select it using the mouse or keyboard keys: 

‒ Click the command line with the left mouse button. 

‒ Select the command line with the ↓ and ↑ keyboard keys and press Enter. 

 

Once the selection is made, the action is done, and the box closes automatically. To close 

the box without selecting an action, click anywhere outside this window and press Esc. 
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3.11 Application language 

The default language of the MyOffice Spreadsheet application is determined by the language 

of your operating system. You can change it manually if necessary. 

 

When you change the language of MyOffice Spreadsheet, the corresponding language is 

automatically selected for MyOffice Text and MyOffice Presentation. 

To change the application language, follow these steps: 

1. In the Command menu, select Tools > Change Language (see Figure 49). 

 

Figure 49. Tools command menu 
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2. In the window shown in Figure 50, select the desired application language from 

the drop-down list and click OK. 

 

Figure 50. Language selection window 

3. In the dialog box shown in Figure 51 click OK. 

 

Figure 51. Notification to restart the application 

4. Restart the application. To do this, close all the documents currently open in 

MyOffice Spreadsheet and open them again. 
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4 WORK WITH MYOFFICE SPREADSHEET 

4.1 Actions with files 

4.1.1 New file 

4.1.1.1 Create a file using File Explorer 

To quickly create a file using Windows File Explorer, do the following: 

1. Open the context menu by right-clicking on an empty area and click  

New >  New MyOffice Spreadsheet. 

2. Specify a name for the file. By default, the file is named New MyOffice Spreadsheet. 

3. To keep the name, click outside the file or press Enter. 

 

4.1.1.2 Create a file when opening the application 

A new file is created automatically when you open MyOffice Spreadsheet. 

4.1.1.3 Create a file while working in the application 

To create a new file while you work in MyOffice Spreadsheet, do one of the following: 

‒ In the Command menu, select File > New (see Figure 52). 

‒ Press Ctrl+N / ⌘Cmd+N. 

 

Figure 52. New menu 
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4.1.2 Save as template 

MyOffice Spreadsheet allows you to create templates in .xots format. These templates are 

convenient to use when preparing documents with the same content or formatting settings. 

To create a template, follow the steps below: 

1. Open the file that you want to use as a template (see Section 4.1.4). 

2. In the File menu, select Save as Template (see Figure 53). 

3. In the file manager window that appears, select the template name and location. 

Click Save. 

 

Figure 53. File menu 
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4.1.3 New from template 

MyOffice Spreadsheet allows you to work with templates in .xots, .ots and .xltx formats. 

When working in Windows and Linux, you can use templates in the following ways: 

‒ Configure automatic selection of a single template for all documents created in MyOffice 

Spreadsheet. To do this, the template needs to be placed in the MyOffice Standard.  

Home Edition installation folder. 

‒ Select templates when creating documents manually. In this case, you can use an 

unlimited number of templates located in any folders on the current computer. 

Configuring automatic template selection does not preclude you from manually selecting a 

template. 

Templates in .ots and .xltx format are only supported in automatic mode. 

4.1.3.1 Select a template manually 

To manually create a template-based file in .xots format, use one of the following methods: 

‒ In the file manager, double-click the template with the left mouse button. Some Linux 

operating systems require a single left-click.  

‒ Open MyOffice Spreadsheet and, in the File menu, select New from Template 

(see Figure 53). In the file manager window that opens, select the template on the basis 

of which you want to create a file and click Open. 

‒ Open MyOffice Spreadsheet and drag the template or its shortcut from the operating 

system file manager window to the open application window. 

The document created on the basis of the selected template will open. 
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4.1.3.2 Configure automatic template selection 

 

Configuration requires OS administrator rights. 

To configure automatic template selection, follow the steps below: 

1. Go to the MyOffice software installation folder. 

2. Place the template based on which you want to create documents in  

the Default Template folder. 

You can save several different templates in the Default Template folder. In this case, only 

one template of a suitable format will be used for MyOffice Spreadsheet and MyOffice Text 

applications, which comes first in the list. 

If the application cannot open the template, a new document is created with the standard 

default settings. The reasons may be as follows: 

‒ The template is not saved in the folder or is corrupted. 

‒ The template file format is not supported. 

‒ The “Hidden” attribute is set for the template in Windows. 

‒ The template is password protected in Linux. 

If a template file is corrupted, a banner with a corresponding notification is displayed in 

the document created on its basis. 

Please note the following specifics when working with templates: 

‒ If MyOffice software is installed in a user's private folder, other users can only manage 

templates if they have permissions to run or read files in that folder. 

‒ Templates that are large in size with many links can affect the application's performance. 

‒ When you update or recover MyOffice software, manually created templates are not 

deleted from the system. When MyOffice software is deleted, all downloaded templates 

are removed from the system. 

The access to manually created templates is blocked by default for other system users in 

the Alt Workstation 10 OS. If necessary, you can add additional access rights for other users to all 

templates or for a specific template using the following command: 

chmod a+r <template file> 
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Example: 

1. Go to the Default Template directory and run the command: 

chmod +x ./<TEMPLATE_NAME>.sh 

2. To verify that the permissions have changed, run the command: 

ls –lah 

All the other Linux systems set full permissions by default but can also be manually 

configured. 
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4.1.4 Open a file 

To open a file, use one of the following methods: 

‒ If MyOffice Spreadsheet is selected as the default application to open files of the 

appropriate format, double-click the file with the left mouse button. Some Linux 

operating systems require a single left-click to open a file. 

‒ Right-click the file. When working in Windows, run Open with context menu option 

and select MyOffice Spreadsheet in the opened list of applications. When working in 

macOS, run Open with context menu option and in the opened list of applications select 

the MyOffice Spreadsheet. When working in Linux, run Open in MyOffice 

Spreadsheet / Open with MyOffice Spreadsheet context menu option. 

‒ Open MyOffice Spreadsheet and follow the steps below: 

1. In the File menu, click Open (see Figure 53) or press Ctrl+O / ⌘ Cmd+O. 

2. In the File manager window that appears, select the desired file and click Open. 

‒ Open MyOffice Spreadsheet and drag the document or its shortcut from the operating 

system file manager window to the open application window. You can open up to 32 

files at a time by dragging and dropping them into the application window. 

The document will open on the sheet on which the last data save before closing was made. 

If this sheet has been renamed or deleted in another application, the document opens on the first 

sheet. 

4.1.4.1 File in .xls format 

 

Files in .xls format are not supported on macOS. 

When you open a file in .xls format, it is automatically converted to .xlsx format  

(see Figure 54). 
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Figure 54. Document was converted 

To save a file in .xlsx format, follow the steps described in Section 4.1.8. 
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4.1.4.2 File in .xlsb format 

 

Files in .xlsb format are not supported on macOS. 

When you open a file in .xlsb format, a copy of that file in a different format is opened 

(see Figure 55). 

 

Figure 55. File copy 

To save a copy of the file or replace the original .xlsb file with a copy, follow the steps described 

in Section 4.1.10. 
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4.1.4.3 View-only file 

If the Read only property is set for a file by the OS tools, then: 

‒ This file is opened in the View mode. 

‒ A notification “The document is view-only” is displayed on the Toolbar (see Figure 56). 

 

The file is opened in the edit mode if you work with it using the WebDAV protocol or if 

it has the .xlsm, .xls, or .xlsb extension. 

In the View mode, you cannot make changes to the document or change its formatting. 

If necessary, you can create a copy of this document that can be edited. To do this, click Edit a Copy 

on the Toolbar. 

 

Figure 56. Edit a Copy button 

A copy of the document will open in a new application window. To save the file copy, follow 

the steps described in Section 4.1.10. 

4.1.4.4 File being used by another application 

If a file is opened for editing in another application, then: 

‒ This file is opened in the View mode. 

‒ The Toolbar displays a notification that the document is opened in another application 

(see Figure 57). 

 

Figure 57. Document is in use by another application 
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The file is opened in the Edit mode if it has an .xlsm, .xls, or .xlsb extension or is opened 

in another application, but that application has not created a lock file. For example, a file 

downloaded from the Internet and opened in Microsoft Excel in the Protected View 

mode will open in the Edit mode. 

In the View mode, you cannot make changes to the document or change its formatting. 

To edit a document, do one of the following: 

‒ Finish working with the document in another application. Then, in MyOffice 

Spreadsheet, click Check Availability on the Toolbar. If working with a document in 

another application is not completed, the pop-up message “Document still in use” will 

be displayed (see Figure 58). If the work is completed, the document will switch to the 

Edit mode. 

 

Figure 58. Tooltip message 

‒ Create an editable copy of the document. To do this, in MyOffice Spreadsheet, on the 

Toolbar, click Edit a Copy. A copy of the document will open in a new application 

window. To save the file copy, follow the steps described in Section 4.1.10. 

4.1.4.5 File opened by another user 

When you try to open a local document opened by another user on the same computer, 

a dialog box is displayed (see Figure 59) that contains: 

‒ Information about the user who is currently working with this document. 

‒ Open a Copy button to create an editable copy of the document. 

‒ Close button to finish working with the document. 
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A file is opened in Edit mode if it has the extension .xlsm, .xls, .xlsb. In View mode, 

only .xlsb files are opened, the work with which is performed via WebDAV protocol. 

 

Figure 59. Dialog box 
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4.1.5 Convert a file 

MyOffice Spreadsheet allows you to import data from .csv, .scsv, .tsv, .tab, .txt files and 

display them in a spreadsheet. 

Follow these steps: 

1. Open the file you want to import (see Section 4.1.4). 

2. In the Convert window that appears (see Figure 60), specify the following parameters: 

‒ Character set: A text encoding format. 

‒ Delimiters: Characters separating the values. Each value is then placed in a separate 

cell. For example, if you select the semi-colon sign (;), the values like 1;1;1 will be 

placed into 3 cells. You can use the preset delimiter type from the list or specify it 

manually in the Another field. You can select multiple delimiters to use from the list. 

Only one character can be specified in the Another field. 

 

Only one character can be specified in the Another field. 

 

‒ String qualifier: A character that frames individual values so that they are placed in 

separate cells even if they contain a delimiter. For example, if a comma is specified 

as a delimiter and double quotes as a string qualifier, the fractional number "3.14" 

is placed into a single cell. 

‒ Fit Width to Content: An option to adjust the width of each column to automatically 

fit the widest entry in a column. If selected, the width of each column is 

automatically selected based on the content of the cell that contains the most data. 
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Figure 60. Import settings window 

3. Click OK. 

The delimiter-separated data contained in the file will be displayed in a new document in 

tabular form. 
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If you didn't select the Fit Width to Content option during the file import (see Figure 60), 

the "Fit column width to the contents?" pop-up message will appear briefly on the screen once 

the new file is opened (see Figure 61).  

 

Figure 61. Pop-up message 

Click Fit Width to fit the width to the content or Cancel to keep the default column width. 
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4.1.6 Recent files 

MyOffice Spreadsheet application saves a list of documents which the user has worked with 

recently. 

To open a file from the list, do the following: 

1. In the File menu, Recent Files (see Figure 79). 

 

Figure 62. File menu 

2. In the sub-menu that appears, select the desired file. 

 

If the list of recent files is out of date, delete it. To do this, in the File menu,  

select Recent Files > Clear. 
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4.1.7 Open with 

 

To configure the option in Windows and Linux, OS administrator rights are required. 

In Windows and Linux, you can open the edited file in another text editor directly from 

MyOffice Spreadsheet. In the File menu, select Open With to choose an editor for further work  

(see Figure 63). 

The list of programs available for selection is configured using the OpenWithList.ini config 

file. If this file contains no data or incorrect data, the File > Open with command is not displayed 

in the Command menu. 

 

Figure 63. File menu 

To add, change or delete a program from the list, follow these steps: 

1. Run the text editor installed in the operating system (for example Notepad in Windows) 

as an administrator. 

2. In a text editor, open the OpenWithList.ini file located in the <installation folder> > 

Resources directory, where <installation folder> is the  software installation folder. 

3. Change the file as needed. 

4. Save the file in UTF-8 encoding and restart the application to see the changes made. 

Keep the following data structure in the file (see the example below):  

‒ [section name] is the application from the MyOffice software bundle for which the list 

of applications is created: 

‒ [MyOffice Text Home Edition]: MyOffice Text 

‒ [MyOffice Spreadsheet Home Edition]: MyOffice Spreadsheet. 

‒ [ordinal number\appPath], where: 

‒ Ordinal number is the application sequence number in the list. 
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‒ appPath is the full path to the program executable file. The path should appear in 

quotation marks. In Windows, directory names should be separated using a slash (/) 

or a double backslash (\\) when specifying the path to a file. 

‒ [ordinal number\appTitle], where: 

‒ Ordinal number is the application sequence number in the list. 

‒ appTitle is the short name under which the program will be displayed in the list. The 

name should appear in quotation marks. If the name of the application is not specified 

in the configuration file, the list will display the title of its executable file without 

extension. 

An example of OpenWithList.ini file: 

[MyOffice Text Home Edition] 

1\appPath="C:/Program Files/LibreOffice/program/swriter.exe" 

1\appTitle="LibreOffice Writer" 

2\appPath="C:\\Program Files\\Microsoft Office 

15\\root\\Office15\\WINWORD.EXE" 

2\appTitle="Word" 

 

[MyOffice Spreadsheet Home Edition] 

1\appPath="C:/Program Files/LibreOffice/program/scalc.exe" 

1\appTitle="LibreOffice Calc" 

2\appPath="C:\\Program Files\\Microsoft Office 

15\\root\\Office15\\EXCEL.EXE" 

2\appTitle="Excel" 
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4.1.8 Send a file 

 

The Send File command is not available on macOS. 

 

In MyOffice Spreadsheet, you can email the file you are working on using the default 

desktop email client. 

To send a file via email, follow the steps below: 

1. Select Share > Send File (see Figure 64). 

 

Figure 64. Share menu 

2. In the new message window that appears, do the following: 

‒ In the To field, enter the recipient's email address. 

‒ In the Subject field, edit the subject (if required). 

‒ In the body of the message, type the text. 

3. Send the email. 
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4.1.9 Print a file 

4.1.9.1 Print a file without entering MyOffice Spreadsheet 

When working in Windows, you can print a document/group of documents without first 

opening it in MyOffice Spreadsheet. 

To do this, perform the following steps: 

1. Select the desired document/group in Windows Explorer. 

2. Open the context menu by right-clicking the mouse and run the Print command. 

Printing is performed on the last printer used by MyOffice Spreadsheet and MyOffice Text. 

If no printer was previously selected in those applications, the printer used is the one installed by 

default in Windows. 

During printing the following dialog boxes may be displayed: 

‒ For a large-sized document or group of documents: the print setup window. 

‒ For a document in which the only sheet has been deleted or all sheets have been hidden: 

The window with the notification that there is no data to print. 

‒ Notifications of damaged files and files with unsupported formats. 

4.1.9.2 Print a document from MyOffice Spreadsheet 

4.1.9.2.1 Select the print area 

You can print: 

‒ Selection: Specified manually, 

‒ Print area: Specified manually or selected automatically if a print area is specified for 

the document in a third-party editor. 

‒ Sheet: Selected automatically if no selection or no printable area is specified in 

the document. 
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4.1.9.2.1.1 Print a selection 

To print a selection, follow these steps:  

1. Select the cell, cell range, rows, or columns from which you want to print data. 

2. Open the context menu by right-clicking the selected cells or the titles/contents of the selected 

rows/columns. 

3. In the shortcut menu, select Print Selection. 

The Page Setup and Print will open (see Section 4.1.9.2.2).  
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4.1.9.2.1.2 Print an area 

If a print area is selected on a sheet using MyOffice Spreadsheet or a third-party editor, this 

print area will be automatically selected when printing the document.  

In Microsoft Excel, a print area is selected using the following commands:  

Page Layout > Print Area. In LibreOffice Calc, use Format > Print Ranges. 

 

To specify a print area in the MyOffice Spreadsheet application, follow these steps: 

1. Select the area you want to print on the sheet. 

2. In the Format menu, select Print area > Define print area (see Figure 65). 

 

 

The print area is specified separately for each sheet of the document. 

 

Figure 65. Define print area command menu option 
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The borders of the selected print area are highlighted in blue (see Figure 66). 

 

Figure 66. Print area borders 

If needed, you can hide this frame by doing the following: 

1. In the Format menu, select Print area (see Figure 67). 

2. Clear the Print area borders checkbox. 

 

Figure 67. Print area borders menu 

To display the frame, select the menu again. 
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To modify the print area (for example, if the selected area is not correct), follow these steps: 

1. In the Format menu, select Print area and click Clear print area (see Figure 67). 

2. Select the area once again as described above. 

To print the defined area, open the Page Setup and Print window in one of the following 

ways: 

‒ In the File menu, Page Setup and Print (see Figure 68). 

‒ Press Ctrl+P / ⌘Cmd+P. 

 

Figure 68. Page Setup and Print command menu option 

The Page Setup and Print will open (see Section 4.1.9.2.2). 
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4.1.9.2.1.3 Print the current sheet 

To print the current sheet, follow these steps: 

1. Make sure that a print area has not been set for this document (see Section 4.1.9.2.1.2). 

2. Open the Page Setup and Print window in one of the following ways: 

‒ In the Command menu, select File and then Page Setup and Print  

(see Figure 68). 

‒ On the Toolbar, select the File section and click the arrow to the right of 

the  Quick Print button. In the drop-down list, select Page Setup and Print  

(see Figure 69). 

 

Figure 69. Page Setup and Print command 

‒ Press Ctrl+P / ⌘Cmd+P. 

 

The Page Setup and Print will open (see Section 4.1.9.2.2). 
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4.1.9.2.2 Page Setup and Print window 

The opened Page Setup and Print window (see Figure 70) contains: 

‒ Print Setup pane 

‒ Preview pane 

 

 

If the sheet that you want to print is empty or the data resides in hidden rows or columns, 

the Page Setup and Print dialog box will not open. Instead, the following notification 

will appear on the screen: "No data to print. Please make sure you have at least one 

page with data to print". 
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4.1.9.2.2.1 Preview a document 

To control the preview, use the following buttons: 

‒  and  : Zoom in or out the preview section. 

‒ Fit: Set the default page zoom (100%). 

‒  and  : Move to the next or previous sheet. 

 

 

Zooming does not affect the print area. The tool is intended for a detailed preview of 

a document content before printing. 

 

You can resize the Page Setup and Print dialog box by dragging its borders. 

 

Figure 70. Page Setup and Print dialog box 
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4.1.9.2.2.2 Customize print settings 

In the print settings area, you can specify the parameters listed in Table 3. 

Table 4. Print settings 

Option Action 

Printer Select a printer to print the document. 

Printer Properties 

(Windows OS only). Open the printer settings window. The type 

and composition of the window parameters depend on the printer 

model selected in the field above.  

The settings specified in the printer settings window are 

automatically transferred to the corresponding fields of 

the Page Setup and Print window. 

Print in Grayscale 
Print the color text and images contained in the document in 

grayscale. 

Copies Set the number of copies you want to print. 

Collated / Uncollated 

Set the order in which pages are grouped during printing. Set 

the order in which pages are grouped during printing: 

− Collated: Print all pages grouped by copies (1,2,3 1,2,3 1,2,3). 

− Uncollated: Print pages grouped by page numbers (1,1,1 2,2,2 

3,3,3). 

Print Area 

Print Area (see Section 4.1.9.2.1): 

− Defined Area: Print the defined area. 

− Entire Sheet: Print the sheet displayed on the screen. 

− Selection: Print the selected area on a sheet. 

A field to enter the page 

numbers or ranges to be 

printed 

This field is used if you want to print individual pages or page 

ranges of the selected sheet/area/fragment. The pages to print can be 

specified as: 

− Individual page numbers. For example, 5, 10, 12. 

− Page ranges where the range values are denoted using the hyphen. 

For example, 1-8, 10-11. 

− Pages from the beginning of the sheet/area/fragment to 

the specified one are in the -<No.> format. For example, if -3 

is entered in the field, then pages 1-3 will be printed. 

− Pages from specified to the end of the sheet/area/fragment - in 

the <No.>- format. For example, if 3- is entered in the field and 

the sheet/area/fragment contains 6 pages, then pages 3-6 will be 

printed. 
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Option Action 

Range 

This field is not available when you want to print a selection 

(see Section 4.1.12.1.1). Select one of the following ranges: 

− All Pages: Print all the pages of the current sheet. 

− Odd Pages Only, Even Pages Only: Print the document on a printer 

that doesn't support automatic double-sided printing. You can print 

the front sides of all the pages, turn the printed pages over, put them 

back into the printer, and print on the back sides. 

Don't print blank pages 

Blank pages are the pages without data, cells, objects (diagrams, images, 

shapes), cells with borders (see Section 4.11.12) or filling 

(see Section 4.11.10). This is a default option. 

Checking/unchecking Do not print blank pages in the preview area 

hides/displays blank pages and the total number of pages is reduced or 

increased. 

If you want to print individual pages/range of pages of the selected 

sheet/area/fragment, make sure that the Do not print blank pages check 

box is selected first, and then specify the pages/range of pages to be 

printed, referring to the page numbering in the preview area. 

Duplex Printing 

Print on both sides of the paper: 

− None: Print on one side of the page only. 

− Long-Edge Binding: Print two sides of the page and flip the paper 

along the long edge. 

− Short-Edge Binding: Print two sides of the page and flip the paper 

along the short edge. 

Scale 

The settings under the Scale section depend on the option selected in 

the Print Area. 

Under the Current Sheet, the Scale contains the following settings: 

− Fit to Page Breaks: If page breaks are inserted into a sheet using 

Microsoft Excel or LibreOffice Calc spreadsheet editor, the sheet is 

broken into pages according to these breaks. If the document does not 

have page breaks, the spreadsheet will be automatically scaled to fit one 

printed page. 

 

If there are no page breaks on the sheet, selecting Fit to Page 

Breaks will print the entire contents on one page at a very 

small scale 

− Custom Scale: Change the sheet scale on the page by adjusting 

the percentage value. If there are page breaks on the sheet (see 

the description of the setting above) and you select the Custom 

Scale, printing will be performed taking these page breaks into 

account. 

 

If there are page breaks on the sheet (see the description 

of the settings above), then when you select the Custom 

Scale, printing will take these page breaks into account. 
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Option Action 

In the Print Area, under the Selection, the Scale contains 

the following settings: 

− Actual Size: Print the spreadsheet as is. 

− Fit to Page: Fit the selection to a printed page. 

− Fit to Width: Fit all columns of the selection to a printed page. 

− Fit to Height: Fit all rows of the selection to a printed page. 

 

Click Print to print the document or Cancel to close the window.  
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4.1.9.2.2.3 Page setup 

The Page Setup and Print dialog box contains the following page setup options  

(see Figure 71): 

 

Figure 71. Page setup 

‒ Orientation: Select Portrait (vertical) or Landscape (horizontal) page orientation. 

‒ Paper Size: Select paper size for printing. 

‒ Top Margin, Bottom margin, Left Margin, Right Margin: Set the distance between 

the page edges and the contents. 

You can save the current page setup for further printing. To save the setup and close 

the window, click Save. To print the document and save the setup, click Print. 

When printing a selection (see Section 4.1.9.2.1.1), the page setup is only applied to 

the selection and cannot be saved for further printing sessions.  
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4.1.9.2.3 Quick print 

MyOffice Spreadsheet allows you to quickly print a document without using the Page Setup 

and Print dialog box. 

The Quick Print feature: 

‒ Creates an instant printout and uses the default printing settings. 

‒ Selects the last printer used. The document will be printed using the printer you last used 

(if any) or the default printer. 

 

To print a document using the Quick Print feature, do one of the following: 

‒ On the Toolbar, select the File >  Quick Print (see Figure 72). 

‒ On the Toolbar, select the File section and click the arrow to the right of 

the  Quick Print button. In the drop-down list, select the Quick Print command. 

 

Figure 72. Quick Print button 
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4.1.10 Save a file 

4.1.10.1 Save as 

Use the Save As command to save a new file or create a copy of the current file. 

When saving files in .csv, .tsv, .tab, .scsv and .txt formats: 

‒ Only the current sheet of the source file with text data is saved in the file. Formatting 

settings, images, links and other data are not saved. 

‒ The ; (semicolon) character is used as a value separator in .csv, .tsv, .tab, and .csv files, 

and the tab character (Tab) is used in .txt files. 

When saving in .xlsb format: 

‒ Macros (see Section 4.15) are not saved in the file.  

‒ Empty cells are excluded from the sheets workspace (see Section 3.6). 

When saving in .pdf and .pdf/a-1 formats: 

‒ Links to websites remain functional. 

‒ Links to files and email addresses, links to location in the document (sheets, cells, cell 

ranges, named ranges) are not saved. 
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To save a new file or create a copy of the current file, follow these steps: 

1. Run the save command in one of the following ways: 

‒ In the File menu, click Save As (see Figure 73). 

 

Figure 73. Save and Save As command menu options 

‒ On the Toolbar, select the File section and click the arrow to the right of the  Save 

button. In the drop-down list, select Save As (see Figure 74). 

 

Figure 74. Save button 

‒ When working in Windows, press F12. When working in Linux, press Ctrl+Shift+S. 

In macOS, press ⇧ Shift+⌘ Cmd+S. 

2. In the Save As window, select a folder to save the file to, specify the name and file 

format, and click Save. 
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To save a file in .pdf or .pdf/a-1 format, you can also follow these steps: 

1. On the Toolbar, select the File section and click the arrow to the right of the  Quick 

Print button. In the drop-down list, select Export to PDF (see Figure 75). 

 

Figure 75. Export to PDF command 

2. In the file manager window, select the folder for export, specify the file name and format, 

and click Save. 

When you create a copy, the copy of the file becomes the document that you will be working 

on. 

4.1.10.2 Save 

To avoid data loss due to power failure or other system malfunction, it is recommended to 

save changes regularly. 

To save changes in the document you are working on, do one of the following: 

‒ In the File menu, select Save (see Figure 73). 

‒ On the Toolbar, select the File section and click  Save (see Figure 74). 

‒ On the Toolbar, select the File section and click the arrow to the right of 

the  Save button. In the drop-down list, select the Save As command (see Figure 74). 

‒ Press Ctrl+S / ⌘Cmd+S.  
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4.1.11 Autorecovery of documents 

Autorecovery is a feature that allows the user to recover documents working with which was 

completed incorrectly (for example, in case of power failure). 

To enable recovery, MyOffice Spreadsheet periodically saves backups of the documents 

being edited, including those that have never been saved by the user. If the application crashes, when 

the application is reopened, the user can save copies of documents as separate files or replace the 

original documents with copies. 

Backup copies of documents are saved for one month and then automatically deleted. 

4.1.11.1 Configure autorecovery of documents 

By default, MyOffice Spreadsheet backs up all documents you edit every 5 minutes. 

To change the settings, follow these steps: 

1. In the File menu, select Autorecovery > Autorecovery Settings (see Figure 76). 

 

Figure 76. Autorecovery Settings command menu option 

2. In the Autorecovery Settings window (see Figure 77): 

‒ To disable or enable saving document backups, clear or select the Save backup 

copies every checkbox. 

‒ To change the interval for saving document backups, specify it manually, using the 

switch, the ↓ and ↑ keyboard keys or the mouse wheel. The switching step is 

1 minute. 
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‒ If you want to disable saving backups for one or more documents currently open, 

check the boxes in the Don't save for following files list. This list does not show 

documents that have never been manually saved. 

‒ If you want to copy the path to the folder where the backed up copies of documents 

are stored, click the  button. 

3. Click Apply. 

 

Figure 77. Autorecovery Settings dialog box 

4.1.11.2 Document recovery 

If the work with documents was finished incorrectly, then when you re-enter the application, 

the dialog box shown in Figure 78 appears. Click Open in this dialog box. 

 

Figure 78. Dialog box 

Backed up copies of documents will open in new application windows. 
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To save copies, follow the steps below for each copy: 

1. Run the Save As command in one of the following ways: 

‒ In the notification bar that appears below the Toolbar, click Save As (see Figure 79). 

 

Figure 79. Save As button 

‒ In the File menu, click Save As (see Figure 80). 

 

Figure 80. Save As command menu option 

2. In the Save As window: 

‒ If you want to save the copy as a separate file, select the folder where you want to 

save it, specify the file type and name, and click Save. 

‒ If you want to replace the original file with a copy, select the file and click Save. 

If you want to delete a copy, click Delete in the notification bar below the Toolbar 

(see Figure 81). 
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Figure 81. Delete button 

4.1.11.3 Recovered Files pane 

If any backed up documents were not saved or deleted as described above, open 

the Recovered Files pane. 

To do this, proceed with one of the following: 

‒ In the File menu, select Autorecovery > Recovered Files (see Figure 82). 

 

Figure 82. Recovered Files command menu option 

‒ On the Sidebar, click  Recovered Files (see Figure 83). 
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Figure 83. Recovered Files button 

To open, save, or delete a document backup copy, follow the steps below: 

1. Hover the cursor over the name of the copy (see Figure 84) and click the  button. 

2. In the drop-down list, select the desired command. 

 

Figure 84. Copy Management Commands 

You can also open a document backup copy by double-clicking its name in the list. 

If you want to delete all copies of the documents, click Delete All (see Figure 85). 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 92 

 

Figure 85. Delete All button 
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4.1.12 Close a file 

Once you have finished working with a file, save it (see Section 4.1.7) and close 

the application window using one of the following tips: 

‒ In the File menu, click Close (see Figure 86). 

 

Figure 86. Close command menu option 

‒ Click  Close in the application window heading. 

‒ Press Alt+F4 / ⌘Cmd+Q. 
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4.2 Sheets 

4.2.1 Insert a sheet 

By default, a new spreadsheet created in MyOffice Spreadsheet contains one sheet. You can 

add as many sheets as you need manually. 

To insert a sheet, do one of the following: 

‒ In the Insert menu, click Sheet (see Figure 87). 

 

Figure 87. Insert menu 

‒ On the Toolbar, select the Insert section and click . In the insert pane that appears, 

click  Sheet (see Figure 88). 
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Figure 88. Sheet button 

‒ Click  button to the right of the sheet tabs (see Figure 89). 

 

Figure 89. Add sheet button 
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4.2.2 Rename a sheet 

By default, spreadsheet sheets are sequentially named as Sheet1, Sheet2, Sheet3, etc.  

To rename a sheet, perform the following actions: 

1. Right-click the tab of the sheet you want to rename. 

2. In the context menu, select Rename (see Figure 90). 

 

Figure 90. Context menu of a sheet 

3. In the opened window (see Figure 91), enter the name of a sheet or and click OK. 

 

Figure 91. Rename sheet 

Sheet name cannot: 

‒ Contain less than 1 and more than 31 characters. 

‒ Contain any of the following characters: (:), (\), (/), (?), (*), ([), (]). 

‒ Begin or end with a single quotation mark ('). 

‒ Repeat the name of the other sheet. 
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4.2.3 Hide or unhide a sheet 

To hide a sheet, do as follows: 

1. Right-click the tab of the sheet you want to hide. 

2. In the context menu, select Hide (see Figure 90). 

 

To unhide hidden sheets, perform the following actions: 

1. Right-click the tab of any displayed sheet. 

2. In the context menu, select Unhide All (see Figure 92). 

 

Figure 92. Context menu of a sheet 

4.2.4 Duplicate a sheet 

MyOffice Spreadsheet allows you to duplicate any sheet of a spreadsheet, that is, to create 

a copy of a sheet with all its contents. 

To duplicate a sheet, perform the following actions: 

1. Right-click the tab of the sheet you want to duplicate. 

2. In the context menu, select Duplicate (see Figure 92).  
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4.2.5 Change sheets order 

In MyOffice Spreadsheet, you can change the order of sheets in the current spreadsheet. 

To do this, follow the steps below: 

1. Select the sheet that you want to change in order. 

2. Click the left mouse button and drag the sheet to a new position on the sheet tabs. 

3. Release the left mouse button to fix the selected position of the sheet. 
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4.2.6 Zoom a sheet 

By default, zoom is 100% when creating a spreadsheet. If necessary, you can zoom it in or 

zoom out using the Command menu or the Status bar. 

To change the zoom using the Command menu, do as follows: 

1. In the View menu, select Zoom (see Figure 93). 

2. In the opened list, select the desired option: 

‒ Zoom In: Increase the current zoom by 10%. 

‒ Zoom Out: Decrease the current zoom by 10%. 

‒ Actual Size: Set the default zoom (100%). 

 

Figure 93. View menu 

To change the zoom using the Status bar (see Figure 94), do one of the following: 

‒ With the left mouse button pressed, move the slider to the right or left to zoom in or out, 

respectively. 

‒ Click to zoom in or  to zoom out. In each case, the zoom increment is 10 %. 

‒ Select the current zoom value with the cursor in the lower right corner, modify it and 

press Enter to confirm. 

‒ Press the arrow to the right of the current zoom value and select the zoom from the drop-

down list. 

 

Figure 94. Zooming tools 
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4.2.7 Hide or display zero values 

If a spreadsheet contains a lot of zero values, you might want to hide them to make you 

spreadsheet easier to read. The hidden zero values are not printed. 

To hide zero values on the sheet, proceed as follows: 

1. Right-click the sheet tab of the sheet containing the zero values that you want to hide. 

2. In the context menu of the sheet, select the Hide Zero Values check box  

(see Figure 95). 

 

Figure 95. Context menu of a sheet 

To display the previously hidden zero values on the sheet, proceed as follows: 

1. Right-click the sheet tab of the sheet containing the zero values that you want to display. 

2. In the context menu of the sheet, clear the Hide Zero Values check box. 

4.2.8 Delete a sheet 

To delete a sheet, perform the following actions: 

1. Right-click the tab of the sheet you want to delete. 

2. In the context menu, select Delete (see Figure 95). 

 

When you run the command, the sheet is deleted along with the data without warning. 

If you have deleted a sheet by mistake, undo the action (see Section 4.14.1.1). 
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4.3 Actions with cells, columns, and rows 

4.3.1 Expand the workspace 

All actions on the sheet are performed within the workspace (see Section 3.6). Documents 

created in MyOffice Spreadsheet have a default workspace of 26 columns and 300 rows. 

 

Documents created in MyOffice Spreadsheet application versions older than 3.2 have a 

default workspace of 10 columns and 20 rows on existing sheets. 

Workspace borders expand automatically if you insert more rows or columns than the current 

workspace has. 

To expand the workspace, do one of the following: 

‒ Double-click a cell in a row or column in the inactive area that you want to include in 

the workspace. 

‒ Right-click the row or column heading outside the workspace in the inactive area and 

select the Add rows: N or Add columns: N context menu (see Figure 96). 

 

Figure 96. Add rows 

‒ Select any cell in a row or column before the inactive area. To increase the workspace 

by one or more columns, use Tab. To increase the workspace by one or more rows, 

use Enter. 
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4.3.2 Select a cell range 

4.3.2.1 Select a custom cell range 

To select a custom range of cells, use one of the following methods: 

‒ Move the cursor to the first cell in the desired range. Hold down the left mouse button 

and drag the cursor to the last cell of the range. Release the left mouse button. 

‒ Select the first cell of the desired range. Hold Shift pressed and select the last cell of the 

range. 

You can select a range in any direction of rows or columns, 

Some cell range selection examples are shown on Figure 97–Figure 99. 

 

Figure 97. Select a horizontal cell range 

 

Figure 98. Select a vertical cell range 

 

Figure 99. Select a diagonal cell range 
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4.3.2.2 Select all cells in a spreadsheet 

To select all the cells that are in the workspace of the current sheet (see Section 4.2.1), 

do one of the following: 

‒ Move the mouse cursor to the upper left corner of the workspace so that the cursor looks 

like  and click the left mouse button. 

‒ In the Edit menu, click Select All (see Figure 100). 

 

Figure 100. Select a diagonal cell range 

‒ Press Ctrl+A / ⌘Cmd+A. 

 

If an element (image, shape, or diagram) is selected on the sheet, deselect the element 

before selecting all cells by using the Command menu or keyboard shortcut. 

 

When using these commands, only the cells on the active sheet are selected.  

Cells on the other sheets in the spreadsheet are not selected. 

When switching to another sheet, the range remains selected. 

4.3.2.3 Deselect cells 

To deselect a cell range, left-click any cell in a spreadsheet. 
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4.3.3 Resize cells 

It is possible to resize cells in one of the following ways: 

‒ By specifying the exact width and height of cells manually. 

‒ Automatically match the width and height of the cells to the content. 

To resize one or multiple cells, do the following: 

1. Select the cells. 

2. Open the Cell Size window in one of the following ways: 

‒ In the Table menu, select Cell Size (see Figure 101). 

 

Figure 101. Cell size command menu option 

‒ On the Toolbar, select the Cells section and click  Cell Size (see Figure 102). 

 

Figure 102. Cell Size button 

‒ Right-click the selected cells and run the context menu command Cell Size. 

3. In the Cell Size window (see Figure 103), do one of the following: 

‒ To specify the exact cell parameters, enter them in the Width and Height fields 

manually. 
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‒ To automatically match the width and height of the cells to the content, select Adjust 

automatically. 

4. Click OK. 

 

Figure 103. Cell Size window 
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4.3.4 Merge or split cells 

4.3.4.1 Merge cells 

You can merge any number of cells in the current spreadsheet. 

When merging multiple cells: 

‒ The selected range will merge into a single cell. 

‒ The merged cell will only display the contents of the upper-left cell of the selection. 

‒ When you merge multiple cells, the resulting cell will be formatted like the upper-left 

cell of the merged range. 

To merge cells, select them and do one of the following: 

‒ In the Table menu, select Merge Cells (see Figure 104). 

 

Figure 104. Merge Cells command menu option 
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‒ On the Toolbar, select the Cells section and click  Merge Cells (see Figure 105). 

 

Figure 105. Merge Cells button 

‒ Right-click the selected range of cells and choose Merge Cells context menu. 

‒ Press Ctrl+Alt+M / ⌥Option+⌘ Cmd+M. 
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4.3.4.2 Split cells 

MyOffice Spreadsheet allows you to split the previously merged cells. 

To split the cells, select the merged cell and do one of the following: 

‒ In the Table menu, select Unmerge Cells (see Figure 106). 

 

Figure 106. Split Cells command menu option 

‒ On the Toolbar of the Cells section, click  Unmerge Cells (see Figure 107). 

 

Figure 107. Split Cells button 

‒ Right-click the selected cell and select the Unmerge Cells option from the context 

menu. 

‒ Press Alt+Shift+M / ⌥ Option+⇧ Shift+M. 

The data contained in the merged cell will be placed in the upper-left cell of the resulting 

range. The resulting cells will be formatted like the merged cell.  
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4.3.5 Insert columns, rows or cells 

4.3.5.1 Insert columns 

To quickly insert one column, follow these steps: 

1. Select a cell or a column to the left or to the right of which you want to add a new column. 

2. Insert a column in one of the following ways: 

‒ In the Table menu, select Insert > Column to the Left / Column to the Right 

(see Figure 108). 

 

Figure 108. Column, row and cell insertion commands 

‒ On the Toolbar, in the Cells section (see Figure 109), click the arrow  to the right 

of  Insert Cell, Column, or Row button and select  Insert Column to the Left or 

 Insert Column to the Right. 

 

Figure 109. Column, row and cell insertion buttons 
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‒ Right-click the selected cell or the selected column header and choose Insert > 

Column to the Left / Column to the Right from the context menu. 

‒ To insert column to the left, press Alt+L / ⌥Option+L. To insert column to the right, 

press Alt+R / ⌥Option+R. 

To add several columns, follow these steps: 

1. Select the number of columns and cells horizontally equal to the number of columns to 

be inserted. 

2. Insert columns in one of the following ways: 

‒ In the Table menu, select Insert > Column to the Left / Column to the Right  

(see Figure 108). 

‒ On the Toolbar, in the Cells section (see Figure 109), click the arrow  to the right 

of Insert Cell, Column, or Row button and select  Insert Column to the Left or 

 Insert Column to the Right. 

‒ Right-click anywhere in the selected range and run Insert > Column to the Left or 

Column to the Right command from the context menu. 

‒ To insert columns to the left, press Alt+L / ⌥Option+L. To insert columns to 

the right, press Alt+R / ⌥Option+R. 

To double the number of columns on the sheet, do the following: 

1. Select any entire row on the sheet (see Section 4.3.6.1). 

2. Insert the columns in one of the ways described above. 
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4.3.5.2 Insert rows 

To quickly insert one row, follow these steps: 

1. Select a cell or row to the left or right of which you want to add a new row. 

2. Insert a row in one of the following ways: 

‒ In the Table menu, select Insert > Row Above or Row Below (see Figure 108). 

‒ On the Toolbar, in the Cells section (see Figure 109), click the arrow  to the right 

of Insert Cell, Column, or Row button and select  Insert Row Above or 

 Insert Row Below. 

‒ Right-click the selected cell or the selected row header and choose Insert >  

Row Above / Row Below from the context menu. 

‒ To insert a row above, press Alt+A / ⌥ Option+A. To insert a row below, press 

Alt+B / ⌥ Option+B. 

To add several rows, follow these steps: 

1. Select the number of rows and cells vertically equal to the number of rows to be inserted. 

2. Insert rows in one of the following ways: 

‒ In the Table menu, select Insert > Row Above or Row Below (see Figure 108). 

‒ On the Toolbar, in the Cells section (see Figure 109), click the arrow  to the right 

of Insert Cell, Column, or Row button and select  Insert Row Above or 

 Insert Row Below. 

‒ Right-click anywhere in the selected range and run Insert > Row Above or Row 

Below command from the context menu. 

‒ To insert rows above, press Alt+A / ⌥ Option+A. To insert rows below,  

press Alt+B / ⌥ Option+B. 

To double the number of rows on the sheet, do the following: 

1. Select any entire column on the sheet (see Section 4.3.6.1). 

2. Insert the rows in one of the ways described above. 
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4.3.5.3 Insert cells with shift 

To insert cells without replacing existing data, the shift cell insertion functions are used. The 

existing data is automatically shifted to the right or down, depending on the selected insertion option, 

by the number of cells to be inserted. All links and formulas that use the cells shifted as a result of 

the insertion are automatically updated. 

To add a single blank cell or a range of blank cells, follow these steps: 

1. Select the single cell or range above or to the left of which you want to add blank cells. 

The inserted range will be the same size as the selected range, and the cells will be 

inserted relative to the upper-left cell of the selected range. 

2. Insert cells in one of the following ways: 

‒ In the Table menu, select Insert > Cells and Shift Right / Cells and Shift Down 

(see Figure 108). 

‒ On the Toolbar, in the Cells section (see Figure 109), click the arrow  to the right 

of Insert Cell, Column, or Row and select  Insert Cells and Shift Right or 

 Insert Cells and Shift Down from the drop-down menu. 

‒ Right-click the selected cell or range and choose Insert > Cells and Shift Right / 

Cells and Shift Down from the context menu. 

To insert the copied cells with shift, follow the steps below: 

1. Copy the desired cells (see Section 4.14.2.1). 

2. Select the single cell or range above or to the left of which you want to insert the copied 

cells. When a range is selected, cells will be inserted relative to the upper-left cell of the 

range. 

3. Insert the copied cells in one of the following ways: 

‒ In the Table menu, select Insert Copied Cells > Shift Cells Right / Shift Cells 

Down (see Figure 110). 

 

Figure 110. Commands to insert copied cells 
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‒ On the Toolbar, in the Cells section (see Figure 111), click  Insert Copied Cells 

and select  Insert Copied Cells and Shift Right or  Insert Copied Cells and 

Shift Down from the drop-down menu. 

 

Figure 111. Buttons to insert copied cells 

‒ Right-click the selected cell or range and choose Insert Copied Cells >  

Shift Cells Right / Shift Cells Down from the context menu. 

The copied cells will be pasted with the original formatting intact. 

 

In the current version of MyOffice Spreadsheet, shift insertion is not available when 

working with a document in the View and Collaboration modes. 
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4.3.6 Select rows and columns 

4.3.6.1 Select a row or a column 

To select the entire row or column in spreadsheet, do one of the following: 

‒ Hold the cursor over a row or column heading until the cursor 

changes to an arrow (  or ). Left-click the heading. 

‒ Click any cell in the row or column you want to select. To select a row, 

press Shift+Space. To select a column, press Ctrl+Space / ⇧Shift+⌘Cmd+Space. 

 

To select all rows containing a merged cell (see Section 4.3.4.1), select the cell and press 

Shift+Space. 

To select all columns containing a merged cell (see Section 4.3.4.1), select the cell and press 

Ctrl+Space / ⇧Shift+⌘Cmd+Space. 
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4.3.6.2 Select a range of rows or columns 

To select a range of rows or columns, follow the steps below: 

1. Hold the cursor over the heading of the first row or column that you want to select. 

The cursor will change to an arrow (  or ). 

2. Press and hold the left mouse button and drag the cursor to the headings of the items 

to be selected. 

3. Release the left mouse button. 

 

To select a range of rows or columns not included in the workspace area, 

follow the steps below: 

1. Hold the cursor over the heading of the first row or column that you want to select. 

The cursor will change to an arrow (  or ). 

2. Left-click the heading to select it. 

3. Hold the cursor over the heading of the last row or column that you want to select. 

The cursor will change to an arrow (  or ). Click the heading while holding the Shift 

key pressed. 
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4.3.7 Hide rows and columns 

4.3.7.1 Hide a row or a column 

To hide rows or columns, perform the following actions: 

1. Select the entire row(s) or column(s) (see Section 4.3.5.1). 

2. To hide them, do one of the following: 

‒ In the Table menu, select Hide Column or Hide Row (see Figure 112). 

 

Figure 112. Table menu 

‒ Right-click the row or column heading and select the Hide Column  

or Hide Row command in the context menu. 

Hidden rows or columns are marked in the heading as shown (see Figure 113). 

 

Figure 113. Hidden rows 

Hidden rows and columns are not printed.  
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4.3.7.2 Unhide rows and columns 

To display a hidden column or row, follow these steps: 

1. Select two rows or columns (see Section 4.3.5.1) between which there is a hidden 

element. 

2. Run the item display command in one of the following ways: 

‒ In the Table menu, select Unhide Column/Unhide Row (see Figure 112). 

‒ Right-click on the headers of the selected columns/rows and run the Show Column 

or Show Row context menu command. 

 

After running the command, all rows/columns hidden under the marker are displayed. 
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4.3.8 Resize rows and columns 

You can modify the size of a row or a column in one of the following ways: 

‒ By moving the border of a cell of a row or column manually. 

‒ By automatically selecting the size of a row or column in accordance with the size of 

the contents. 

‒ By specifying the exact width of the column or height of the row. 

4.3.8.1 Resize a row or a column manually 

To change the size of a single column or row, follow these steps: 

1. Hover the cursor over the right border of the column header or the lower border of 

the row header so that the cursor takes the form of a two-sided arrow. 

2. Hold down the left mouse button and move the border to the desired position. 

3. Release the left mouse button to lock the selected position. 

To set the same size for multiple columns/rows, follow these steps: 

1. Select the columns/rows. 

2. Set the size for one column/row that you want to apply to all selected columns/rows. 

To do this, proceed as follows: 

‒ Move the cursor to the right border of the header of any column or to the lower 

border of the header of any row so that the cursor takes the form of a two-sided 

arrow. 

‒ Hold down the left mouse button and move the border to the desired position. 

‒ Release the mouse button to lock the selected position. 

 

For the selected columns/rows, the size specified for this column/row 

will be automatically set. 

To set the same size for all rows/columns in the workspace (see Section 3.6), select all cells 

of the sheet (see Section 4.3.2.2) and follow the same steps. 
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4.3.8.2 Autofit the width 

To automatically adjust the column width based on the content of the cell with the largest 

amount of data, do one of the following: 

‒ Hover the mouse cursor over the right border of the column header so that the cursor 

takes the form of a two-sided arrow and double-click. 

‒ Right-click the column header and run the context menu command Fit Width to 

Content. 

‒ Right-click the column header and run the Column Width context menu command. 

In the Column Width window (see Figure 114), select Adjust automatically and 

click OK. 

 

Figure 114. Column Width window 

To automatically adjust the row height based on the content of the cell with the largest 

amount of data, do one of the following: 

‒ Hover the mouse cursor over the lower border of the header so that the cursor takes 

the form of a two-way arrow and double-click. 

‒ Right-click the line header and run the Fit Height to Content context menu command. 

‒ Right-click the row header and run the Row Height context menu command.  

In the Row Height window (see Figure 115), select the value Adjust Automatically 

and click OK. 
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Figure 115. Row Height window 

To automatically adjust the width/height of several columns/rows, follow these steps: 

1. Select the required columns/rows. 

2. Autofit width/height in one of the following ways: 

‒ Hover the mouse cursor over the border between any two column/row headers in 

the selected range so that the cursor takes the form of a two-sided arrow. 

Double-click. 

‒ Right-click the header of any column/row in the selected range and run the context 

menu command Fit Width to Content or Fit Height to Content. 

‒ Right-click the header of any column/row in the selected range and run the context 

menu command Column Width or Row Height. In the window that opens 

(see Figure 114 and Figure 115), select Adjust automatically and click OK. 

 

For each column/row in the selected range, the width/height will be selected according to 

the contents of the cell with the largest amount of data. 
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4.3.8.3 Specify the exact size 

To specify the exact width for one/more columns or height for one/more rows, follow these 

steps: 

1. Select these columns or rows. 

2. Right-click the header of any column or row in the selected range and run the context 

menu command Column Width or Row Height. 

3. In the window that opens (see Figure 114 and Figure 115), specify the required 

Column Width or Row Height. 

4. Click OK. 

4.3.9 Freeze rows, columns, or area 

Freezing rows, columns or areas is useful if you are working with large amounts of data and 

often scroll through the window. You can freeze any range of columns and rows so that they are 

always visible when you move around the sheet. 

The frozen element is separated from other elements in the spreadsheet with a bold line. 

If you've already frozen rows or columns and want to freeze the new ones, the previous 

setting for the same item will be invalidated. 

In MyOffice Spreadsheet, you can freeze the following elements: 

‒ One or multiple columns (see Figure 116): As you scroll the sheet to the right, only 

the frozen columns are displayed. All the columns to the left are not displayed. 

 

Figure 116. Column B is frozen 
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‒ One or multiple rows (see Figure 117): As you scroll the sheet down, only the frozen 

rows are displayed. All the rows above are not displayed. 

 

Figure 117. Row 4 is frozen 

‒ Both rows and columns (see Figure 118): As you scroll the sheet to the right and down, 

only the frozen rows and columns are displayed. All the columns to the left and rows 

above are not displayed. 

 

Figure 118. Columns B and C and rows 3 and 4 are frozen 

‒ The area in a spreadsheet where A1 is the top left cell and the bottom right cell is 

specified by you. 
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Figure 119. Frozen area 
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4.3.9.1 Freeze columns or rows 

To freeze one or multiple rows or columns, follow these steps: 

1. Entirely select rows or columns you want to freeze or select any cells in these rows or 

columns. 

2. Freeze columns or rows in one of the following ways: 

‒ In the Table menu, select Freeze Selected Rows and Columns (see Figure 120). 

In the opened sub-menu, select Freeze Horizontally to freeze rows or Freeze 

Vertically to freeze columns. Or select the Toolbar of the Table section and press 

the arrow to the right of the  Freeze Selected Rows and Columns  

(see Figure 121). 

 

Figure 120. Freeze Selected Rows and Columns sub-menu 
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‒ On the Toolbar, select the Cells section and click  

the  Freeze Selected Rows and Columns button (see Figure 121). 

‒ On the Toolbar, select the Cells section and click the arrow to the right of 

the  Freeze Selected Rows and Columns button (see Figure 121). In the opened 

menu, select Freeze Horizontally to freeze rows or Freeze Vertically to freeze 

columns. 

 

Figure 121. Freeze button 
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4.3.9.2 Simultaneously freeze rows and columns 

To simultaneously freeze rows and columns, follow these steps: 

1. Select any number of cells located in rows or columns you want to freeze. 

2. Freeze rows and columns in one of the following ways: 

‒ On the Toolbar, select the Cells section and click 

the  Freeze Selected Rows and Columns button (see Figure 121). 

‒ On the Toolbar, select the Cells section and click the arrow to the right of 

the  Freeze Selected Rows and Columns button. In the opened window, select 

Freeze Selected Rows and Columns (see Figure 121). 

‒ Right-click the headings of the selected rows and columns and select 

Freeze Selected Rows and Columns in the context menu. 
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4.3.9.3 Freeze an area 

To freeze an area, follow these steps: 

1. Select a cell which will be the bottom right cell of the area. 

2. Freeze the area in one of the following ways: 

‒ On the Toolbar, select the Cells section and click 

the  Freeze Selected Rows and Columns button (see Figure 121). 

‒ On the Toolbar, select the Cells section and click the arrow to the right of 

the  Freeze Selected Rows and Columns button. In the opened window, select 

Freeze Selected Rows and Columns (see Figure 121). 

4.3.9.4 Unfreeze rows and columns 

To unfreeze rows and columns, do one of the following: 

‒ In the Table menu, select Freeze Selected Rows and Columns and then Unfreeze All 

(see Figure 120). 

‒ On the Toolbar, select the Cells section, click the arrow next to 

the  Freeze Selected Rows and Columns button and select the Unfreeze All option 

(see Figure 120) in the drop-down list. 

‒ Right-click the heading of a row or column and select and select the Unfreeze All option 

from the context menu. 
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4.3.10 Group rows or columns 

To group rows or columns of your choice, select them and do one of the following: 

1. In the Data menu, select Group Rows or Group Columns (see Figure 122). 

 

Figure 122. Data menu 

2. On the Toolbar, select the Cells section and click the  Group button  

(see Figure 123). 

3. On the Toolbar, select the Cells section and click the arrow to the right of the  Group 

button and select Group Rows or Group Columns. 

 

Figure 123. Group button 
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4. Right-click the heading of the selected rows or columns and select Group rows or 

Group columns from the context menu. 

If a range of cells is selected and not just rows or columns, then pressing the  Group 

button opens the Group window (see Figure 124), where you should choose which items you want 

to group. 

 

Figure 124. Group window 

The final row of each group is at the bottom of the group. The final column of the group is 

the rightmost column of the group. The heading of the final row and the final column is grayed out.  

You can create up to 7 levels of groups. 

If necessary, you can collapse or expand the data in the groups.  

Use the  or  outline symbols for this purpose.  

 

To clear the grouping, follow these steps: 

1. Select a range of cells for which you want to clear the grouping. 

2. Select the Data menu > Clear Grouping (see Figure 122). Or on the Toolbar, select 

the Cells section and click the arrow to the right of the  Group button and select 

Clear Grouping (see Figure 123). 

If you want to print the sheet that contains grouped columns or rows, these grouped elements 

will be printed as they are displayed on the screen. 
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4.3.11 Delete columns or rows 

4.3.11.1 Delete columns or rows 

To delete one or more columns or rows, use one of the following methods: 

1. Select the rows or columns or cells located in them. Then do one of the following: 

‒ In the Table menu, select Delete > Column / Row (see Figure 125). 

 

Figure 125. Commands to delete rows, columns and cells 

‒ On the Toolbar, in the Cells section (see Figure 126), click the arrow  to the right 

of Delete Cell, Column, or Row button and select  Delete Column  

or  Delete Row. 

 

Figure 126. Buttons to delete rows, columns and cells 
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‒ Right-click anywhere in the selected range and run Delete > Row / Column 

command from the context menu. 

2. Select these columns/rows in their entirety and press Ctrl+— / ⌘Cmd+—. 

 

If there is filtered data or manually hidden columns or rows, only visible columns or 

rows will be deleted with the following exceptions: 

‒ If you delete a column in its entirety, the cells from the hidden rows will be deleted 

along with it. 

‒ If you delete a row in its entirety, the cells from the hidden columns will be deleted 

along with it. 

4.3.11.2 Delete cells with shift 

When deleting cells with a shift, adjacent cells are automatically shifted left or up, depending 

on the selected delete option, by the number of cells to be deleted. All links and formulas that use 

the cells shifted as a result of the deletion are automatically updated. 

To delete a cell or range of cells with a shift, follow these steps: 

1. Select a single cell or a range. 

2. Do one of the following: 

‒ In the Table menu, select Delete > Cells and Shift Left / Cells and Shift Up 

(see Figure 125). 

‒ On the Toolbar, in the Cells section, click the arrow  to the right of Delete Cell, 

Column, or Row and select  Delete Cells and Shift Left or  Delete Cells and 

Shift Up from the drop-down menu (see Figure 126). 

‒ Right-click anywhere in the selected range and run the Delete > Cells and Shift Left 

/ Cells and Shift Up command from the context menu. 

 

In the current version of MyOffice Spreadsheet, shift deletion is not available when 

working with a document in the View and Collaboration modes. 
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4.4 Data 

4.4.1 Enter data 

4.4.1.1 Enter data in a cell 

To enter or change data in a cell, perform the following actions: 

1. Activate the edit mode in one of the following ways: 

 Select an empty cell. 

 Double-click the cell you want to edit. 

 Select the cell you want to edit and go to the Formula bar. 

2. Enter the necessary data into the cell. Use the comma sign (,) as the delimiter for 

numbers. 

3. Save the entered data in one of the following ways: 

 Press Enter. 

 Click  in the right side of the Formula bar (see Figure 127). 

 Select another cell on the spreadsheet. 

 

To undo the changes you have made, do one of the following while editing: 

 Click  in the right side of the Formula bar (see Figure 127). 

 Press Esc. 

 

Figure 127. Enter data and Cancel buttons 
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4.4.1.2 Automatically adjust cell width 

When you enter a number in a cell, the width of this cell is automatically adjusted to fit 

the number. 

Cells width is not adjusted in the following cases: 

‒ The width of the column containing the cell has been previously changed in the manual 

mode (see Section 4.3.8.1). 

‒ The cell format is Text (see Section 4.5.11). 

‒ The cell is filled with text. 

 

4.4.1.3 Floating cell 

The floating cell (see Figure 128) appears when you edit a cell and move through the current 

sheet of the spreadsheet. 

The cell displays the current data in the cell you were editing, so it is convenient to use when 

navigating through a large amount of data in the document. 

 

Figure 128. Floating cell 
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4.4.1.4 Fill cells automatically 

MyOffice Spreadsheet allows you to automatically fill the adjacent cells. A single cell as 

well as a range of cells can be selected as a sample for filling. 

If a single cell with a text or numeric value is selected as a reference, its content is copied to 

subsequent cells when it is autofilled. 

If a cell with a formula is selected as a reference, the subsequent cells will be filled in with 

data sequences calculated using the formula specified in the cell. The values are automatically 

recalculated if the data in the formula cells change. 

If a cell range is selected as a sample range, the subsequent cells are filled in according to 

the rules described below. 

The filled cells will have the same format as the sample range (see Section 4.5). 

To automatically fill the data, follow the steps below: 

1. Enter the desired data in one or more adjacent cells. 

2. Select the cells. 

3. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

4. Drag the corner autofill handle over the range of cells that you want to fill in. You can 

drag the corner autofill handle either vertically or horizontally. 

 

If the range of cells to be filled exceeds the workspace boundaries (see Section 4.3.1), 

the workspace expands automatically. 
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4.4.1.4.1 Fill cells automatically with arithmetic sequences 

In MyOffice Spreadsheet, you can fill cells with arithmetic sequences. This type of sequence 

adds the difference between the previous two to each of the subsequent values.  

For example, 1, 2, 3, 4... 

To autofill cells with a geometric sequence, follow the steps below: 

1. Enter the first 2 range values in the adjacent cells to set the reference. 

2. Select the resulting range containing the 2 cells. 

3. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

4. Drag the corner autofill handle over the range of cells that you want to fill in. You can 

drag the corner autofill handle either vertically or horizontally. 

4.4.1.4.2 Fill cells automatically with geometric sequences 

In MyOffice Spreadsheet, you can fill cells with geometric sequences. In this sequence view, 

each of the following values is multiplied by the specified progression denominator.  

For example, 0.25, 0.5, 1, 2... 

To autofill cells with a geometric sequence, follow the steps below: 

1. Enter the first 3 range values in the adjacent cells to set the reference. 

2. Select the resulting range. 

3. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

4. Drag the corner autofill handle over the range of cells that you want to fill in. You can 

drag the corner autofill handle either vertically or horizontally. 
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4.4.1.4.3 Reduce the data range 

If necessary, you can quickly reduce the range of data resulting from autofill. When the range 

is reduced, the data in the columns on the right or the rows on the bottom is deleted. 

To reduce the range, follow the steps below: 

1. Select the range of cells with the data resulting from the autofill. 

2. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

3. If you want to delete data in the columns on the right side of the autofill range, drag 

the corner handle to the left. If you want to delete data in the rows at the bottom, drag 

the corner handle upwards. 

4. Release the left mouse button. All data will be deleted from the columns or rows excluded 

from the range. 

4.4.1.4.4 Autofill cells: basics 

Cells can be filled automatically if two or more cells from the sample range contain 

the following data: 

‒ A series of integers, fractions, or negative numbers. 

‒ Dates or time. 

‒ Text and a number (with or without the delimiter). For example, Text 1, Text 2 or 

Text1, Text3, Text5. 

‒ Abbreviated (Jan-Dec) or full month names (January-December). 

‒ Abbreviated (Mon-Sun) or full weekdays names (Monday-Sunday). 

‒ Data validation conditions (see Section 4.4.3). 

‒ If the sample range contains cells of different formats, then, when autofilling a series, 

the cells repeat the formats and follow the sequences in the order corresponding to 

the sample range. 

‒ If there is a cell with text in the sample range, it will be copied when the series is 

autofilled, and the other cells will follow the specified sequence. 

‒ If a cell with text is located between cells in a series that have different formats, the text 

will be copied when autofilling, and cells of different formats will follow different 

sequences. 

‒ If the sample range contains a merged cell, an identical merged cell is automatically 

created in the autofill range that continues the specified data sequence. 
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‒ If a merged cell partially falls into the autofill range (also due to partial hiding), the 

merged cell will be split. 

‒ Cells of General and Number formats (Number, Currency, Accounting, Fraction, 

Percentage, Exponent) are considered as one sequence. 

‒ Date and Time are unrelated formats and are considered as separate sequences. 

‒ When autofilling dates, the sequence is calculated based on the actual calendar 

difference. 
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4.4.1.5 Text formatting of formulas and numbers 

In some cases, a formula or number that is entered into a cell needs to be retained in its 

original form. For example, display zero characters when entering the number 00056 or specify 

a formula without its further use. To do this, text formatting should be applied to the cell in which 

the number or formula is entered. 

The formatting is applied by using a single quotation mark (').  

The single quotation mark should be entered in a cell immediately before the formula or number to 

be recognized as text. For example: '=SUM(B1;C1) or '00056. 

The quotation mark is displayed: 

‒ On the formula bar, when you select a cell. 

‒ In the cell and on the formula bar, when you edit a cell. 

 

If you want to cancel text formatting, delete the quotation mark in the cell. 

.  
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4.4.2 Sort and filter 

With MyOffice Spreadsheet, you can sort and filter cells on the spreadsheet sheet 

you are working on. 

4.4.2.1 Define the Sort and Filter range 

To define the Sort and Filter range, follow these steps: 

1. Select the range of cells that will contain all the data to be sorted and filtered. 

 

The range cannot consist of one line. 

2. On the Toolbar, select the Data section and click  Sort and Filter (see Figure 129). 

 

Figure 129. Sort and Filter button 

The active Sort and Filter range on the sheet is as follows (see Figure 131): 

‒ Headings of rows and columns are highlighted in green. 

‒ A green frame appears around the range. 

The top line of the range marked with  is not included in the sorting and filtering process. 
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4.4.2.2 Automatic detection of the Sort and Filter range 

MyOffice Spreadsheet can detect the Sort and Filter range automatically if the cells 

adjacent to the selected one contain data. Data in adjacent cells can be of any format. 

To automatically detect the range, follow these steps: 

1. Select an empty cell bordering the range. 

2. On the Toolbar, select the Data section and click  Sort and Filter (see Figure 129). 

4.4.2.3 Sort 

When sorting, the selected values in the column are arranged in the ascending  

(from A to Z) or descending (from Z to A) order. 

If a sorting and filtering range is defined on the sheet and the user selects in the table: 

‒ A column or a cell: The entire sorting and filtering range is sorted by that column. 

‒ A range of cells in different columns: The sorting of the whole sorting and filtering range 

is performed by the leftmost column of the selected range. 

 

If the user selects a range of cells both inside and outside the sort and filter range, the data is 

sorted only in the sort and filter range according to the rule described above. 

If no sort and filter range is defined on the sheet and the user selects a range of cells, filtering 

is automatically enabled for that range and sorting is performed on the leftmost column of the range. 

To sort the data, follow these steps: 

1. Select the column or cell of the column you want to sort by. If a range is selected in the 

table, the data will be sorted by the leftmost column of the range. 

2. On the Toolbar, in the Data section, click the arrow to the right of the  button and 

select the Sort ascending / Sort descending command from the drop-down list 

(see Figure 130). 

 

Figure 130. Sort commands on the Toolbar 
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Or do the following: 

1. Click  in the upper cell of this column (see Figure 131). 

2. In the Sort and Filter window that opens, select a sorting method: 

‒ In Ascending Order: Sort the data in ascending order. 

‒ In Descending Order: Sort the data in descending order. 

 

Figure 131. Sort and Filter settings window 
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4.4.2.4 Filter 

Using filtering, you can hide or display cells with selected values or with selected fill color in a 

column. 

To filter the data, follow these steps: 

1. Click the  button in the upper cell of the column where you want to filter the data  

(see Figure 131). 

2. In the window that opens, clear the Select All checkbox. 

3. If necessary, you can adjust the width and/or height of the window: 

‒ To increase or decrease the window width, move its right border to the left or right. 

‒ To increase or decrease the window height, move its bottom border up or down. 

‒ To adjust the window width and height simultaneously, move its bottom right corner 

in the desired direction. 

4. Select the checkboxes next to the values you want to display in the column. 

5. If the list contains a large number of values, use the search bar: 

‒ Enter the value you want to find (in full or partially). For example, to find the number 

123, you can enter the numbers 12, 23 or 123 in the search bar. 

‒ In the search results, select the checkboxes next to the values you want to display in 

the column. 

‒ If necessary, repeat the steps to find and select other values. 

6. Click Apply. 
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To display all cells in a column again, reopen the Sort and Filter window and select  

the Select all checkbox. Or click Clear Filter. 

To filter cells by fill color, follow these steps: 

1. Click the  button in the upper cell of the column where you want to filter the data. 

2. In the window that opens, select “By color” filtering method (see Figure 132). Filtering 

by color is available only if there are cells with fill in the range. 

3. In the palette of colors available for filtering, select a fill color. 

4. Click Apply. 

 

Figure 132. Filtering by cell fill color 

To display all cells in a column again, reopen the Sort and Filter window and click Clear 

Filter. 

 

Only one filter type can be set for a column at a time.  

Also, if a multi-color filter has been applied in a third-party editor, such a filter will be 

ignored. 
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4.4.2.5 Copy and insert filtered data 

After filtering, only visible data is copied from the table. Hidden data is not copied. 

Copying and pasting data can be done using standard methods 

(see Section 4.14.2.1 and 4.14.2.2). The copied data can be pasted in any place of the current or 

other MyOffice Spreadsheet document. 

4.4.2.6 Refresh the filter 

If the values in the selected range have changed, you can reapply a filter to the data without 

reconfiguring the filter itself. Simply follow these steps: 

1. On the Toolbar, select the Data section and click the arrow to the right of 

the  Sort and Filter button (see Figure 133). 

2. Select the Refresh option from the drop-down menu. 

 

Figure 133. Refresh command 
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4.4.2.7 Finishing work with sorting and filtering range 

To finish working with the current sorting and filtering range, on the Toolbar, in 

the Data section, click  Sort and Filter (see Figure 129). 

 

When you finish working with a range, only the sorting results will be displayed in 

the spreadsheet. Filtering results will not be displayed. 

 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 146 

4.4.3 Data validation 

When creating documents such as fill-in forms, it is important to make the document easy to 

work with, ensure a consistent format and eliminate errors when entering information. For this 

purpose, MyOffice Spreadsheet application can be configured to validate the input data for selected 

cells. In such cells, the user can select a valid value from a drop-down list or enter a value directly 

into the cell. 

4.4.3.1 Add data validation 

Before creating the validation, you can create a list of valid values in advance, or you can 

enter these values in the Value Source field (see below) while creating the validation. 

To create a drop-down list with valid values, follow these steps: 

3. Select the cell or range of cells. 

4. Open the Data Validation dialog box in one of the following ways: 

‒ In the Data menu, select Data Validation (see Figure 134). 

 

Figure 134. Data Validation command menu option 
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‒ On the Toolbar, in the Data section, click  Data validation button  

(see Figure 135). 

 

Figure 135. Data Validation button on the Toolbar 

‒ On the Sidebar, click  All Validations and in the pane that appears, click 

Add Validation (see Figure 136). 

 

Figure 136. All Validations pane 

5. On the Options tab, in the Type of Data drop-down list, select List (see Figure 137). 
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Figure 137. Selection of a drop-down list 

6. If you want the cell to be required to be filled in on entry, uncheck the Ignore blank 

cells box. If the cell is not filled in, an error will be displayed. 

7. If you do not want to use the drop-down list, uncheck the Show value list box. In this 

case, the validation will be carried out after you enter a value directly into the cell, as 

described in the Section 4.4.3.6. 

8. In the Value Source field (see Figure 138), specify the values to create the list in one of 

the following ways: 

‒ Enter the values directly into the field, separating them with a semicolon. 

‒ Specify the cell range manually. 

‒ Click  Select Values, select the desired cells in the document, and click 

 Finish Selection. 

‒ Enter the name of the named range or a formula that results in a cell range. 
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Figure 138. Selection of the value source 

If you make an error when entering, follow the on-screen prompts. To clear all fields in 

the window and return the window to its default view, click Clear All at the bottom of 

the window (see Figure 138). 

 

The range of the data source is to belong to a single column or row. 

9. On the Input Message tab, you can enter the title and text of the tooltip with information 

about the rules of working with the field (see Figure 139). If you uncheck the Show when 

cell is selected box, the tooltip will not be displayed, but the title and text of the tooltip 

will be retained. 
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Figure 139. Input Message tab 

10. On the Error Message tab (see Figure 140), you can configure the behavior when invalid 

values are entered and the error text that explains to the user the cause of the error: 

‒ The Message Effect section is used to set the behavior when an invalid value is 

entered: Input prohibition option will not allow entering an invalid value into 

the cell, Warning option will display an error message but will allow entering 

a value. 

‒ You can enter your own title and description of the error in the Title and Message 

fields. If you leave the fields blank, the default text will be displayed. 
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Figure 140. Error message tab 

11. To complete adding the validation, click OK or press Enter. To cancel creating 

the condition, click Cancel button or press Esc. 

The values in the drop-down list are always up-to-date. For example, if there is a function 

result in the source and the function's arguments change, the corresponding value in the list is 

updated. 

The drop-down list displays the values as they appear in the source. In a cell, the display of the 

selected value is determined by the format of this cell (see Section 4.5). For example, if the drop‑down 

list contains dates, and the General or Text format is selected for the cell, then the selected date in the 

cell will be converted according to the format: the date 02.02.2020 will be displayed as the value 43863. 
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To validate data in Date format, a separate validation type is available. To create an input 

date validation for a cell, follow these steps: 

1. Select the cell or cell range for which the validation will be performed. 

2. Open the Data Validation dialog box in one of the following ways: 

‒ In the Data menu, select Data Validation (see Figure 134). 

‒ On the Toolbar, in the Data section, click  Data validation  

(see Figure 135). 

‒ On the Sidebar, click  All Validations and in the pane that appears, click 

Add Validation (see Figure 136). 

3. On the Options tab, in the Type of Data drop-down list, select Date (see Figure 141). 

 

Figure 141. Selection of validation by date 
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4. Check the Ignore blank cells box if you want the data validation cell to be left blank. 

With this option checked, the following input situations are possible depending on the 

selected Validation Criteria if the date fields refer to empty cells (see Table 5): 

Table 5. Errors when ignoring empty cells is enabled 

Criterion Start date End date Result 

Between Blank Filled in Error if the value is greater than the end 

date. 

Filled in Blank Error if the value is less than the start 

date. 

Not 

between 

Blank Filled in Error if the value is less than or equal 

to the end date. 

Filled in Blank Error if the value is greater than or 

equal to the start date. 

 

With this checkbox cleared, the following input situations are possible if date fields refer to 

empty cells (see Table 6). 

Table 6. Errors when ignoring empty cells is disabled 

Criterion Start date End date Result 

Between 

Blank Filled in 

Error if the value is greater than the 

end date. 

The cell being edited may be blank. 

Filled in Blank 

Error if the value is less than the 

start date. 

The cell being edited may be blank. 

Blank Blank 
Error. 

The cell being edited may be blank. 

Not between 

Blank Filled in 

Error if the value is less than the end 

date. 

The cell being edited may be blank. 

Filled in Blank 

Error if the value is greater than the 

start date. 

The cell being edited may be blank. 

Blank Blank 
No error. 

The cell being edited may be blank. 
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Criterion Start date End date Result 

Equal to Blank 
Error. 

The cell being edited may be blank. 

Not equal 

to 
Blank 

No error. 

The cell being edited may be blank. 

Greater 

than 
Blank 

No error. 

The cell being edited may be blank. 

Less that Blank 
Error. 

The cell being edited may be blank. 

Greater 

than or 

equal to 

Blank 

No error. 

The cell being edited may be blank. 

Less than 

or equal to 
Blank 

Error. 

The cell being edited may be blank. 

 

5. In the Validation Criteria drop-down list, select a validation condition (see Table 7). 

Table 7. Conditions for successful validation 

Criterion Prerequisite for successful validation 

Between The date shall be within the interval between the start date and the end date inclusive. 

Not 

between 

The date shall be beyond the interval between the start and end dates. 

Equal to The date shall coincide with the value in the Date field. 

Not equal to The date shall not coincide with the value in the Date field. 

Greater 

than 

The date shall be later than the date specified in the Date field. 

Less that The date shall be earlier than the date specified in the Date field. 

Greater 

than or 

equal to 

The date shall be later than or the same as the date specified in the Date field. 

Less than or 

equal to 

The date shall be earlier than or the same as the date specified in the Date field. 
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6. In the Start Date and End Date or Date fields, enter: 

‒ Date in any supported data display format. 

‒ Reference a cell or range, or select cells using the  Select Values button. The date 

in a cell can be specified directly, using a function or a reference to another cell. 

‒ Function (for example, =TODAY()+6). 

7. On the Input Message tab, you can enter the title and text of the tooltip with information 

about the rules of working with the field (see Figure 139). If you uncheck the Show when 

cell is selected box, the tooltip will not be displayed, but the title and text of the tooltip 

will be retained. 

8. On the Error Message tab (see Figure 140), you can configure the behavior when invalid 

values are entered and the error text that explains to the user the cause of the error: 

‒ The Message Effect section is used to set the behavior when an invalid value is 

entered: Input prohibition option will not allow entering an invalid value into the 

cell, Warning option will display an error message but will allow entering a value. 

‒ You can enter your own title and description of the error in the Title and Message 

fields. If you leave the fields blank, the default text will be displayed. 

9. To complete adding the validation, click OK or press Enter. To cancel creating the 

condition, click Cancel button or press Esc. 

 

When creating validation conditions, the following restrictions apply: 

‒ You cannot configure data validation for the header and total row of smart tables, pivot 

table cells, and cells that already contain other validations. 

‒ Data validation can only be configured for visible cells. 

MyOffice Spreadsheet also supports working with cells for which data validation is 

configured in third-party editors. 

 

Drop-down lists inserted as ActiveX are not supported. 
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4.4.3.2 Edit data validation 

You can edit data validation using the Data Validation dialog box or All Validations pane. 

To edit data validation using the Data Validation dialog box, follow these steps: 

1. Select the cells that contain the validations. 

2. Open the Data Validation dialog box in one of the following ways: 

‒ In the Data menu, select Data Validation (see Figure 134). 

‒ On the Toolbar, in the Data section, click  Data validation button  

(see Figure 135). 

‒ On the Sidebar, click  All Validations and in the pane that appears, click 

Add Validation (see Figure 136). 

3. Change the validation parameters in the dialog box. If the Apply to all cells with 

the same validation setting box is checked, the changes will be applied to all validations 

with the same condition. If the box is unchecked, a validation with new conditions will 

be created after editing. 

4. Click OK. 

To edit data validation using the All Validations pane, follow these steps: 

1. On the Sidebar, click  All Validations. 

2. In the opened list in the pane, find the validation. The cell with the selected validation 

will be highlighted on the sheet. 

3. Click  Edit in the line with the validation. 

4. Change the validation settings in the dialog box and click OK. 

4.4.3.3 Delete data validation 

You can delete data validation in one of the following ways: 

‒ Using the Data Validation dialog box. 

‒ Using the All validations pane. 

‒ Delete columns or rows with cells with validation (see Section 4.3.11). 

‒ Delete the sheet containing the cells with validation (see Section 4.2.8). 

‒ Apply autofill for cells without validation to cells with validation  

(see Section 4.4.1.4). 
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To delete data validation using the Data Validation dialog box, follow these steps: 

1. Select the cell or range of cells containing the validation. 

2. Open the Data Validation dialog box in one of the following ways: 

‒ In the Data menu, select Data Validation (see Figure 134). 

‒ On the Toolbar, in the Data section, click  Data validation button 

(see Figure 135). 

‒ On the Sidebar, click  All Validations and in the pane that appears, click 

Add Validation (see Figure 136). 

3. Click Clear All in the bottom of the dialog box. If you want to delete such validation 

from all cells, check the Apply to all cells with the same validation settings box. 

4. Click Save. 

To delete data validation using the All Validations pane, follow these steps: 

1. On the Sidebar, click  All Validations. 

2. In the opened list in the pane, find the validation. The cell with the selected validation 

will be highlighted on the sheet. 

3. Click  Delete in the line with the validation and confirm the deletion in the dialog box 

that appears. 

4.4.3.4 Actions with cells containing data validation 

You can drag one or more cells with data validation to autofill cells (see Section 4.4.1.4) on 

the left, right, bottom, or top. 

You can cut, copy and paste cells with data validation (see Section 4.14.2). 

When you merge cells (see Section 4.3.4.1), the data validation condition is saved only from 

the upper-left cell of the range. 

When you split cells (see Section 4.3.4.2): 

‒ The data validation condition is retained in the upper-left cell of the range if it was 

defined for that cell before the cells were merged. 

‒ The data validation condition is retained in each cell of the range if it has been defined 

for the merged cell. If the merged cell contained a drop-down list and a value was 

selected in it, it will only be retained in the upper-left cell of the range. 
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If a column or row that contains cells with data validation is selected on the sheet, the cells 

with data validation are copied to the new columns/rows when new columns or rows are pasted  

(see Section 4.3.5). 

4.4.3.5 Enter a date 

If a cell is configured to validate the specified date, in such a cell, you can enter: 

‒ Number. The application will automatically convert it to the appropriate date  

(see Section 4.5.4). For example, the number 1 will be converted to the date 12/31/1899. 

‒ The date in any supported data display format (see Section 4.5.7), including time 

indication. For example, 07/12/2023 10:30 AM. 

‒ Cell reference (for example, =B1). The date in a cell can be specified directly, using a 

function or a reference to another cell. 

‒ Function (for example, =TODAY()+6). The function can be of any kind. 

An error message (see Figure 143) is displayed if: 

‒ You enter a date, a cell reference, or a function that does not comply with the validation. 

‒ You enter text into the cell or Text format is selected for the cell (see Section 4.5.11). 

To enter a date in a cell, follow the steps below: 

1. Select the cell. A prompt for entering a date will be displayed above the cell, if it was 

created in a third-party editor (see Figure 142). 

 

Figure 142. Tooltip for entering a value 

2. Enter the date in one of the ways described above. 
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3. Press Enter or  button on the Formula bar. If the date is not entered as a reference or 

function, you can also click any other cell in the sheet or any column/row header. 

If the date satisfies the validation conditions, you will quit the cell editing mode. The Date 

format is applied to a cell if another format was selected for the cell before entering the value (with 

the exception of the Text format). 

If the date does not meet the validation conditions, then (see Figure 143): 

‒ The date is highlighted. 

‒ The cell remains in editing mode. 

‒ An error message is displayed. 

 

Figure 143. Error message 

To close the error message and enter the correct date, do one of the following: 

‒ Start entering the date. The error message will close automatically. 

‒ Close the error message by clicking the  button at the top of the message or by pressing 

Esc. Enter the date. 
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4.4.3.6 Enter a value in a cell with a drop-down list 

To enter a value in a cell with a drop-down list, follow these steps: 

1. Select the cell. A prompt for entering a value will be displayed above the cell if it was 

created in a third-party editor (see Figure 144). 

 

Figure 144. Tooltip for entering a value 

2. Do one of the following: 

‒ Expand the drop-down list (see Figure 145) and select the desired value. To work 

with the drop-down list, you can use the mouse or keyboard keys (see Table 8). 

 

Figure 145. Drop-down list 
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‒ Enter the value manually. The entered value must match character by character with 

the required value in the drop-down list. The case of characters is not taken into 

account when entering a value. Press Enter or click the  button on the Formula 

bar or click any other cell in the sheet/header of any column/row. 

If the value entered manually is incorrect, the drop-down list is automatically expanded. 

The "Invalid value" error is displayed at the top of the list (see Figure 146). 

 

Figure 146. Error message 

To edit the entered value, do one of the following: 

‒ Select the correct value from the drop-down list. 

‒ Start entering the correct value manually. The drop-down list will automatically close. 

‒ Close the drop-down list by clicking the  button at the top of it or press Esc. Enter the 

correct value manually. 

 

If the field is intended only for entering the value manually, the error message is 

displayed without a drop-down list. 
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The Table 8 lists the keyboard shortcuts that are used when working with the drop-down list. 

Table 8. Keyboard shortcuts 

Action Windows 

keyboard shortcuts 

macOS  

keyboard shortcuts 

Open the list Alt + ↓ ⌥Option + ↓ 

Select a value ↓ and ↑ ↓ and ↑ 

Apply value Enter Enter 

Select the first value of the list Home Fn + ← 

Select the last value of the list End Fn + → 

One screen down Page Down Fn + ↓ 

One screen up Page Up Fn + ↑ 

Close the list Esc Esc 

 

The commands One screen down and One screen up are used to quickly view long drop-

down lists. When running commands, the list scrolls to the next or previous items. 
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4.4.4 Remove duplicates 

If several users worked on one spreadsheet, or if it was created from several spreadsheets, it 

is very likely to contain repetitive data. These data can be removed from the table automatically 

using the Remove Duplicates command. 

The search for duplicates in a spreadsheet or a specified range is carried out line by line. 

An example is shown in the Figure 147: the rows that will be deleted if one column (left) or two 

columns (right) are selected for the search are highlighted in red. 

 

Figure 147. Example of selecting rows to delete 

When removing duplicates, only the first variant of the found matches is saved, the rest are 

deleted. 

Searching for and deleting duplicates is not carried out if: 

‒ The selected range contains: 

‒ An array formula. 

‒ Cells of the pivot table (see Section 4.9). 

‒ A smart table or a part of it. If the range contains only smart table cells, duplicates 

are searched and replaced. 

‒ Grouped columns or rows (see Section 4.3.10): to find duplicates, you need to clear 

the grouping. 

‒ Merged cells (see Section 4.3.4): to find duplicates, each cell in the range needs to 

occupy the same number of rows and columns. 
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‒ There is a “break” between the selected cells/rows/columns/ranges. For example, 

columns A and C are selected, but column B is not selected. 

‒ The document sheet is protected (see Section 4.16). 

If the selected range contains hidden (see Section 4.3.7.1) or filtered (see Section 4.4.2) rows 

or columns, the values in them are ignored when removing duplicates. After removing duplicates, 

hidden rows and columns remain hidden. In the cells of hidden rows, the values may change because 

the cell data is shifted upward after the duplicates are removed. 

If the selected range contains cells with data validation conditions (see Section 4.4.3) and 

the values in those cells are duplicates, not only the values but also the data validation conditions 

are deleted. 

To remove duplicates, follow the steps below: 

1. Select a range to search for and remove duplicates. 

 

If one cell is selected, but adjacent cells contain data that meet the duplicate 

search and removal conditions (see restrictions above), the application 

automatically expands the range to include the adjacent cells. 

 

2. Open the Remove Duplicates window using one of the following methods: 

‒ In the Command menu, select Data > Remove Duplicates (see Figure 148). 

 

Figure 148. Remove Duplicates Command menu option 
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‒ On the Toolbar, in the Data section, click  Remove Duplicates button 

(see Figure 149). 

 

Figure 149. Remove Duplicates button 

3. In the Remove Duplicates window (see Figure 150), check the With header row box, 

if the selected range contains a row with column names. This line will be excluded from 

the selected range. 

 

Figure 150. Remove Duplicates window 

4. Check the Expand automatically box if you want to include data adjacent to the selected 

range in the search range that meets the duplicate search and removal conditions (see 

the restrictions above). 

5. In the Columns area, select the columns that constitute the search key. In the example in 

the figure above, if you select one column, all repeating names of days of the week from 
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column “A” will be considered duplicates. If you select two columns, the duplicates will 

be the repeated combinations of “Day of the week” - “Employment” from columns “A” 

and “B”. 

6. Click OK. 

When duplicates are successfully deleted, a pop-up message will be displayed: “N duplicate 

values found and removed. M unique values remain.” 

If there are no duplicates in the selected range, a pop-up message “No duplicates found” will 

be displayed. 
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4.4.5 Links 

You can add a link to a web page, an email address, a place in the current document, or other 

file to a document. 

4.4.5.1 Insert a link to a web page or email address 

MyOffice Spreadsheet recognizes and makes active links that start with www, http, https, 

and email addresses. 

Examples of the links: 

‒ www.website.ru 

‒ https://website.com 

‒ http://website.ru 

‒ mailto:user@domain.ru 

‒ user.name@domain.com 

A link such as mailto:user@domain.ru may also contain a subject line, the text of the email, 

and email addresses for sending copy and blind copy. For example:  

mailto:user@domain.ru?subject=This%20is%20the%20subject&cc=user2@domain.ru&bod

y=This%20is%20the%20body. 

 

To avoid errors when you click links, it is recommended to specify the protocol in 

the URL. For example, http://website.ru. 

The link can be displayed in the document as follows: 

‒ URL: For example, http://www.website.ru. 

‒ Text: For example, link. 

To add a link to your document as a URL, do one of the following: 

‒ Enter the link manually and press Space or Enter. 

‒ Copy the link from the source. Switch to the cell edit mode, insert the link and press 

Space or Enter. 

‒ Copy the link from the source. Switch to the cell edit mode and press Ctrl+Shift+ V / 

⌘ Cmd+⇧ Shift+V. 
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To add a text link to a document, follow these steps: 

1. Copy the link from the source. 

2. Specify the place to insert the link in one of the following ways: 

‒ To link the entire text in a cell, select this cell. 

‒ To format a single word in the cell text as a link, place the cursor in the word or select 

the entire word. 

‒ To format a part of the text in a cell as a link, select the entire text part. 

‒ To insert a word or text with a link to an empty cell, select the cell or place the cursor 

in it. 

3. Insert the link in one of the following ways: 

‒ In the Insert menu, select Link (see Figure 151). 

 

Figure 151. Insert menu 

‒ On the Toolbar, in the Insert section, click  (see Figure 152). In the insert pane that 

appears, click  Link. 

‒ Right-click to open the context menu and run the Insert Link command. 

‒ Press Ctrl+K / ⌘ Cmd+K. 
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Figure 152. Insert pane 

4. In the Insert Link window, on the Web Page or File tab (see Figure 153): 

‒ If the URL field is not filled in, insert a link into it. By default, the link copied from 

the source during the first step is automatically inserted in the URL field. 

 

Figure 153. Insert Link window 
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‒ If the Text field is not filled in, enter the text that will be displayed instead of the link. 

By default, text from the selected cell or the text selected in the cell or the word on 

which the cursor is placed is automatically inserted into the Text field. 

‒ Click OK. 

 

When you save an .ods document in .xlsx format in a cell that contains multiple links at 

the same time, only the first link remains functional. 

4.4.5.2 Insert a link to a place in the document 

To help you navigate through particularly long documents, you can also create links to a 

specific place in the document, for example, to a cell, a range of cells, or a named range. 

A link to a place in a document may contain the following elements: 

‒ Sheet name. For example, Sheet 2. 

‒ Name of the sheet with the cell or range address. For example, 'Sheet 2'!A3:A6. 

‒ Name of the named range. For example, Range 1. 

‒ Any other text. For example, see here. 

To create a link to a place in the document, follow the steps below: 

1. Specify the place to insert the link in one of the following ways: 

‒ To create a link with the sheet name and cell address / range, select an empty cell or, 

if the cell is not empty, place the cursor in the desired cell position. 

‒ To add a word or text with a link to an empty cell, select the cell or place the cursor 

in it. 

‒ To format all text contained in a cell as a link, select the cell. 

‒ To format a single word in the cell text as a link, place the cursor in the word or select 

the entire word. 

‒ To format a part of the text in a cell as a link, select the entire text part. 

2. Insert the link in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 151). 

‒ On the Toolbar, in the Insert section, click . In the insertion pane that appears, 

click the Link button (see Figure 152). 

‒ Right-click to open the context menu and execute the Insert Link command. 
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‒ Press Ctrl+K / ⌘ Cmd + K. 

3. In the Insert Link window, select the Place in This Document tab (see Figure 154). 

 

Figure 154. Insert Link window. Place in This Document tab 

4. To insert a link to a sheet, make sure the Sheet radio button is selected (see ) and choose 

the desired sheet from the list. 

5. To insert a link to a cell or range in the Cell or Range field, enter the cell/range address 

manually. Or click  to select the required cells in the document itself, then click  

again to insert the address into the field. 

6. To insert a named range reference, click the Named range radio button and select 

the desired range from the list below (see Figure 155). 
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Figure 155. Insert a link to Named range 

7. In the Text field: 

‒ If the field displays the sheet name and the selected range and you want to create a 

link with the sheet name, leave the content of the field unchanged. 

‒ If the field displays the sheet name and the selected range but you want to specify 

the link text, enter the required text manually. 

‒ If the field is filled with text from the selected cell or text selected in the cell, or a 

word on which the cursor is positioned, edit this text if necessary or leave it 

unchanged. 

8. Click OK. 

 

When you save an .ods document in .xlsx format in a cell that contains multiple links at 

the same time, only the first link remains functional. 
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4.4.5.3 Insert a link to a file 

You can insert a link to a file that is located on the current computer or in a network folder 

into your document. The link can reference a file of any format. 

The link can be displayed in the document as follows: 

‒ Paths to the file. For example, C:\Users\User\Documents\File.xlsx (Windows) or 

/Users/User/Downloads/File.xlsx (Linux and macOS). 

‒ Text: For example, link to the file. You can specify the text of the link either in the cell 

or in the link insertion window. 

To add a link to a file in your document, follow these steps: 

1. Specify the place to insert the link in one of the following ways: 

‒ To link the entire text in a cell, select this cell. 

‒ To format a single word in the cell text as a link, place the cursor in the word or select 

the entire word. 

‒ To format a part of the text in a cell as a link, select the entire text part. 

‒ To insert a word or text with a link to an empty cell, select the cell or place the cursor 

in it. 

2. Insert the link in one of the following ways: 

‒ In the Insert menu, select Link (see Figure 156). 

 

Figure 156. Insert menu 
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‒ On the Toolbar, in the Insert section, click  (see Figure 157). In the insert pane that 

appears, click the Link button. 

 

Figure 157. Insert pane 

‒ Right-click to open the context menu and run the Insert Link command. 

‒ Press Ctrl+K / ⌘Cmd+K. 

3. In the Insert Link window, on the Web Page or File tab, (see Figure 158) select the file 

to which you want to insert a link using one of the following methods: 

‒ Select a file from the Recent Files list. This list displays the 50 most recent files that 

were opened in the MyOffice Spreadsheet, MyOffice Text, and MyOffice 

Presentation applications. 

‒ Select the file using the File manager. To do this, click Choose File. 
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Figure 158. Insert Link window 

4. If you want the link to be displayed as text and the Text field is not filled in, enter 

the required text. By default, text from the selected cell or the text selected in the cell or 

the word on which the cursor is placed is automatically inserted into the Text field. 

5. Click OK. 

 

When you save an .ods document in .xlsx format in a cell that contains multiple links at 

the same time, only the first link remains functional. 

4.4.5.4 Quick link insertion 

You can quickly add a link to a web page, email address, or file to the typed text. 

For quick insertion, the following types of links to local and network files are supported: 

‒ file:///C:\Users\User\Documents\File.xlsx 

‒ smb://192.168.1.1/Files/File.xlsx 

‒ ftp://Guest@127.0.0.1/share/FTP/File.xlsx 

‒ sftp://Guest@127.0.0.1/share/FTP/File.xlsx 
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The supported types of web page links and email addresses are described in the section 

above. 

To quickly add a link to typed text, follow these steps: 

1. Copy the link. 

2. Specify the place to insert the link in one of the following ways: 

‒ To link the entire text in a cell, select this cell. 

‒ To format a single word in the cell text as a link, place the cursor in the word or select 

the entire word. 

‒ To format a part of the text in a cell as a link, select the entire text part. 

3. Press Ctrl+Shift+V / ⌘ Cmd+⇧ Shift+V. 

4.4.5.5 Go to the link 

To follow the link, click it while holding down the Ctrl / ⌘Cmd pressed. 

Web links are opened in the default browser used in the OS. 

Files are opened in MyOffice Spreadsheet, MyOffice Text and MyOffice Presentation 

applications. If the file format is not supported, the file is opened in the application that is used by 

default in the OS to work with files of the corresponding format. 

When you click the link to an email address, it opens the default email client in your OS. 

This software automatically creates a new email, into which the data specified in the link is copied. 

When you click a link to a sheet, the corresponding sheet of the current document is opened. 

4.4.5.6 Copy a link 

To copy a link, right-click it and in the Context menu, select Copy Link URL. 

4.4.5.7 Edit a link 

To edit a link, follow the steps below: 

1. Specify a link to edit: 

‒ If a cell contains only a link, select that cell or place the cursor on the link, or select 

part of the link/the entire link. 

‒ If the cell contains more than just a link, place the cursor on the link or select part of 

the link/the entire link. 

2. Open the link editing window in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 156). 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 177 

‒ On the Toolbar, in the Insert section, click  (see Figure 157). In the insert pane that 

appears, click  Link. 

‒ Right-click to open the context menu and run the Edit Link command. 

‒ Press Ctrl+K / ⌘Cmd+K. 

3. In the Edit Link (see Figure 159) window, make the desired changes. 

4. Click OK. 

 

Figure 159. Edit Link window 

4.4.5.8 Delete a link 

The link can be deleted using the edit window or the context menu. The link is deleted 

without the text that contains it. 

To delete a link using the edit window, follow these steps: 

1. Specify the link to delete: 

‒ If a cell contains only a link, select that cell or place the cursor on the link, or select 

part of the link/the entire link. 

‒ If the cell contains more than just a link, place the cursor on the link or select part of 

the link/the entire link. 
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2. Open the link editing window in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 156). 

‒ On the Toolbar, in the Insert section, click  (see Figure 157). In the insert pane that 

appears, click  Link. 

‒ Right-click to open the context menu and run the Edit Link command. 

‒ Press Ctrl+K / ⌘ Cmd+K. 

3. In the Edit Link window (see Figure 159), click the Remove Link button. 

 

To delete a link using the context menu, follow these steps: 

1. Specify the link to delete as described above. 

2. Right-click to open the context menu and run the Delete Link command. 

To delete multiple links at the same time, follow these steps: 

1. Select the cells that contain the link data. 

2. Right-click to open the context menu and run the Delete Links command. 

If you want to delete the link along with the text that contains it, follow these steps: 

1. Specify the link to delete: 

‒ If a cell contains only a link, select that cell or switch to cell editing mode and select 

the entire link. 

‒ If the cell contains more than just a link, switch to the cell editing mode and select 

the entire link. 

2. Press Delete or Backspace. 
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4.4.5.9 Keyboard shortcuts for moving between window elements 

The Table 9 below shows the keyboard shortcuts you can use to quickly move between 

elements in the Insert/Edit Link window. 

Table 9. Keyboard shortcuts 

Action Windows / Linux  

keyboard shortcuts 

macOS  

keyboard shortcuts 

Open the window Ctrl+K ⌘ Cmd+K 

Go to the next window element Tab Tab 

Go to the previous window element Shift+Tab ⇧ Shift+Tab 

Open the selected tab Space Space 

Click Select File or OK Space Space 

Click OK regardless of which window element is 

currently selected 
Enter ⌅ Enter 

Go to the next/previous file in the Recent Files list ↓ and ↑ ↓ and ↑ 

Go to the first file in the Recent files list Home Fn + ← 

Go to the last file in the Recent files list End Fn + → 

Select a file in the Recent files list Space Space 

Close the window Esc Esc 

 

4.4.6 Notes 

You can add notes to the cells of a spreadsheet. Cells with notes are marked with a triangle 

in the top right corner of a cell (see Figure 160). 

 

Figure 160. Cell with a note 
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4.4.6.1 Add a note 

Each note is attached to one cell. The name of the user who created the note is automatically 

added to the note. 

To create a note, follow the steps below: 

1. Add a note using one of the following methods: 

‒ Left-click a cell to select it. In the Insert menu, select Note (see Figure 161). 

 

Figure 161. Insert menu 
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‒ Select the cell. On the Toolbar, select the Insert section and click . In the opened 

insert pane, select  Note (see Figure 162). 

 

Figure 162. Insert pane 

‒ Right-click a cell to select it and select Add Note in the context menu. 
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2. In the note window (see Figure 163): 

‒ Edit and format the username as needed. 

‒ Enter the note text. 

 

Figure 163. Notes window 

3. Press Esc or click outside the cell to finish and close the note. 

4.4.6.2 Edit or delete a note 

You can edit and delete both your own notes and those of other users in the document. 

To edit a note, use the following guidelines: 

1. Click the cell to open the note. 

2. Activate the edit mode in one of the following ways: 

‒ Right-click a cell and select Edit Note. The cursor will be set on the first paragraph 

of the note. 

‒ Place the cursor in the desired position manually. 

3. Edit the text of the note and, if necessary, the username. 

4. Press Esc or click outside the cell to finish and close the Note. 

To delete a note, right-click the cell containing the note and select Delete Note in 

the command menu. 
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4.4.7 Special characters 

Special characters are characters that are not present on the keyboard. This includes 

mathematical operators, dingbats, arrows, currency signs. Such symbols can be inserted using 

the special characters quick insert pane or the Special Characters window. 

4.4.7.1 Special characters quick insert pane 

To open the Special Characters quick insert pane, do one of the following: 

‒ On the Toolbar, in the Insert section (see Figure 164),  

click  Special Characters. 

 

Figure 164. Special Characters button 

‒ On the Toolbar, in the Insert section, click . In the insert pane that appears, hover 

the mouse cursor over the  Special Characters button (see Figure 165). 
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Figure 165. Insert pane 

To insert a special character, do one of the following: 

‒ Select a character from a set of preset characters. As you work with the application, 

the preset characters change to characters added to the document by the user using 

the Special Characters window (see Section 4.4.7.2). When the mouse cursor 

hovers over a character, the name of the font selected for it is displayed. 

 

When inserting, the font of the document text is applied to the character. 

However, if the font of the text does not support this character, then the font 

selected by the user is used. 

‒ Select Non-Breaking Space, Non-Breaking Hyphen, or En Dash if you want to 

insert the appropriate character. 
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4.4.7.2 Special characters window 

To open the Special Characters window, do one of the following: 

1. In the command menu, select Insert > Special Characters (see Figure 166). 

 

Figure 166. Special characters menu 

‒ On the Toolbar, in the Insert section, click  Special Characters button 

(see Figure 167). In the quick insert special characters pane, select More Characters. 

 

Figure 167. More Characters option 
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‒ On the Toolbar, in the Insert section, click  (see Figure 168). In the pane that appears, 

click the  Special Characters button. 

 

Figure 168. Special Characters button 

‒ On the Toolbar, in the Insert section, click  (see Figure 169). In the pane that appears, 

hover the mouse over the arrow to the right of the  Special Characters button. 

In the quick insert special characters pane, select More Characters. 
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Figure 169. More Characters option 

The Special Characters window (see Figure 170) contains the following tools: 
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Figure 170. Special Characters window 

‒ Drop-down list for selecting the font of the special character. 

‒ Drop-down list for selecting the group and category of the character. If the font does not 

support the characters of a category group or category, it is not displayed in the list. 

‒ Characters. By default, the first character of the selected category is highlighted. 

Categories are separated from each other by a line. 

‒ The name of the highlighted character. 

‒ The code of the selected character in the Unicode system. 

‒ The typeface of the selected character. 

‒ The font of the selected character. 

‒ Other typefaces of the selected character. 
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To insert a special character using the Special Characters window, follow these steps: 

1. Select the font of the special character. You can select it in the same way as you would 

select a font in the main application window (see Section 4.13.1). 

2. Select a character category. You can select it in the same way as selecting a special 

character font. 

3. Place the cursor in the position of the document where you want to insert the character. 

4. Insert the character in one of the following ways: 

‒ Select the character by double-clicking. 

‒ Select the character with one click and click Insert. 

‒ Select the character with one click and press Enter or Space. 

If you want the window to close automatically, check the Close window after inserting 

a character box. 

To close the Special Characters window manually, click Cancel or the  button in 

the window header. 
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4.4.8 Current date or time 

You can quickly insert the current date or time anywhere in a document.  

To insert the current date, follow these steps: 

1. Select the place where you want to insert the date. 

2. Run the insert command in one of the following ways: 

‒ In the Insert menu, select Current Date (see Figure 171). 

 

Figure 171. Insert menu 

‒ On the Toolbar, select the Insert section and click  (see Figure 172). 

In the displayed insert pane, click  Current Date. 
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Figure 172. Insert pane 

To insert the current time in the document: 

1. Place the cursor where you want to insert the current time. 

2. Run the insert command in one of the following ways: 

‒ In the Insert menu, select Current Time (see Figure 171). 

‒ On the Toolbar, select the Insert section and click  (see Figure 172).  

In the displayed insert pane, click  Current Time. 

 

The data inserted is static, that is will not be updated when the actual date and time change. 

4.4.9 Check grammar and spelling 

MyOffice Spreadsheet can automatically check texts in English and in Russian for grammar 

and spelling mistakes. 
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4.4.9.1 Check spelling 

To enable and disable and enable Check Spelling, in the Tools menu, select 

Spelling and Grammar and then Check Spelling (see Figure 173). 

Enabling or disabling Check Spelling is only applied to the current document and does not 

affect other opened documents. 

 

Figure 173. Tools menu 

Check spelling basics: 

‒ The spell-checking dictionary is automatically selected based on the language of the first 

character in the cell. 

‒ Words missing in the selected dictionary or misspelled words are underlined with a red 

wavy line. 

‒ Changing the contents of a document restarts spell-checking. 
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4.4.9.1.1 Correct errors 

If an error is found in a word, correct it. To do this, follow the steps below: 

1. Place the mouse cursor on the word or select the word that is underlined with a red wavy 

line (see Figure 174). 

2. Right-click the word directly in the cell or in the formula line. 

3. From the context menu, choose the correct spelling of the word. 

 

If there are no correct spellings for the selected word, the context menu displays 

No suggestions. 

 

 

Figure 174. Correct an error 
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4.4.9.1.2 Turn off the underline for spelling errors 

A word recognized as misspelled by the application is underlined with a red wavy line. 

To turn this option off for a particular word, add it in the Custom dictionary (see Section 4.4.5.2) 

or in the ignore list. 

To add a word in the ignore list, follow the steps below: 

1. Move the cursor over the misspelled word underlined with a red wavy line or select it. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Ignore (see Figure 174). 

 

Once finished, the red wavy underline disappears. If a word appears several times in 

the document, the changes are applied to all repetitions taking into account the case. Such changes 

are saved within one session. When the document is opened again, the Check Spelling is launched 

again. 

If you have added a word into the ignore list by mistake, you can get back to the previous 

step by selecting the Check Spelling option. Follow these steps: 

1. Move the cursor over the word or select the word. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Check Spelling. 
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4.4.9.2 Custom dictionary 

To exclude words such as proper names, abbreviations, or technical terms in a text from 

being considered misspelled, you can add them to the Custom Dictionary. 

Before you start, make sure that the Check Spelling is on (see Section 4.4.9.1). 

4.4.9.2.1 Adding words to the dictionary 

The Custom Dictionary allows you to add only individual words. You cannot add word 

combinations to the Custom Dictionary. 

Adding words is case-sensitive. If a word can start with a capital letter and with a lowercase 

letter, add the two spellings into the dictionary. 

 

To add a word to the Custom Dictionary directly from the text, follow the steps below: 

1. Move the cursor over the word that you want to add to the dictionary or select the word. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Add to Dictionary (see Figure 174). 

 

To add a new word directly to the Custom Dictionary, follow the steps below: 

1. In the Tools menu, select Custom Dictionary (see Figure 175). 

 

Figure 175. Tools menu 

2. In the Custom Dictionary dialog menu (see Figure 176), enter the word you want 

to add. 
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Figure 176. Custom Dictionary window 

3. Click  or press Enter. 

4. Click Done to finish and close the window. 
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4.4.9.2.2 Using third-party dictionaries 

To extend the vocabulary available in MyOffice Spreadsheet, you can use third-party 

dictionaries in .dic format. Simply follow these steps: 

1. In the Custom Dictionary dialog box, click Import (see Figure 176). 

2. In the opened file manager window, select a .dic file and click Open. 

 

When finished, the contents of the dictionary will appear in your dictionary. 
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4.4.9.2.3 Delete words from the dictionary 

If necessary, you can remove words previously added in the Custom Dictionary. 

To remove a word using the Custom Dictionary menu, follow the steps below: 

1. In the Tools menu, select Custom Dictionary (see Figure 187). 

2. In the Custom Dictionary dialog box (see Figure 177) place the cursor on the word you 

want to remove from the dictionary and click Remove. 

 

Figure 177. Custom Dictionary window 

3. Click Done to finish. 

 

To remove a word without using the Custom Dictionary window, follow the steps below: 

1. Place the cursor over the word you want to remove or select this word. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Remove from Dictionary. 
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4.4.9.3 Grammar checking 

To enable or disable grammar checking, in the Tools menu, select Spelling and Grammar 

and then Check grammar (see Figure 178). 

Enabling or disabling grammar checking applies to the current document and does not affect 

other opened documents. 

 

Figure 178. Tools menu 

Grammar checking basics: 

‒ The grammar checking language is selected automatically depending on the first letter 

of the cell. 

‒ The grammar checking is launched when the Space bar is pressed, or the Enter key is 

pressed, provided that the sentence is completed. 

‒ A sentence with a grammar mistake is underlined with a blue wavy line both in the cell 

and on the Formula bar. 

‒ Formulas and values are not checked. 
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4.4.10 Find and replace data 

 

If the document is opened in the View mode, only data search (without replacement) is 

available. 

To open the pane to find and replace data in a document, do one of the following: 

‒ In the Edit menu, select Find (see Figure 179). 

 

Figure 179. Edit menu 

‒ On the Sidebar, click  Find and Replace (see Figure 180). 

 

Figure 180. Find and Replace button 

‒ Press Ctrl+F or Ctrl+H / ⌘Cmd+F. 
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In the Find and Replace pane (see Figure 181), specify the parameters for searching and 

replacing data: 

1. Specify the data Search area: 

‒ Current sheet: Perform a search on the currently open sheet. 

‒ All Sheets: Perform a search through all sheets of the document. 

 

Figure 181. Search parameters 

2. If necessary, check the required Filters: 

‒ Match whole words only: Find only whole words/values, not data that is part of 

other words/values. 

‒ Match case when searching: Perform the search taking into account uppercase and 

lowercase letters in the text you are looking for. 

‒ Match case when replacing: Perform the replacement taking into account the 

uppercase and lowercase letters in the found text. Example: You need to replace the 

word agreement with the word contract in the text of the document. In this case, the 

word agreement can be written with both lowercase and uppercase letters  

(for example, at the beginning of a sentence). Check the box Match case when 

replacing so that the word agreement with a lowercase letter is replaced by the word 
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contract with a lowercase letter, and the word Agreement with a capital letter is 

replaced by the word Contract with a capital letter. 

 

Case is taken into account only for the first character in the found word. 

To find the data in the document, follow these steps: 

1. In the Find field, enter the data to search for (see Figure 182). 

2. Click the  button or press Enter. 

 

Figure 182. Data for search 

The matches found will be highlighted in the document (see Figure 183). 

Use the  buttons below the search and replace bars (see Figure 182) to navigate through 

the cells with matches found. The selected match will be highlighted in the document with 

a contrasting yellow color (see Figure 183). 

You can also navigate the Find and Replace pane using the keyboard as follows: 

‒ Press Tab to move to the next item in the pane. 

‒ To return to the previous pane item, press Shift+Tab. 

‒ To activate a control (click a button, select a checkbox), press Space. 

Search parameters (see Figure 181) can be changed while you are working with matches. 

The search results are updated automatically. 
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Figure 183. Matches found 

To replace matches found in the document, follow the steps below: 

1. In the Replace with bar (see Figure 182), enter the data to replace or leave the field blank 

if you want to delete the found match. 

2. Replace the matches with one of the following methods: 

‒ Click Replace to replace the highlighted match. 

‒ Click Replace All to replace all matches found simultaneously. 

 

You cannot replace a part of the found value or a part of the found result of a formula 

calculation. The value or the result of a formula calculation can only be replaced in its 

entirety. 

To close the Find and Replace pane, do one of the following: 

‒ At the top of the pane, click . 

‒ On the Sidebar, click  Find and Replace. 

‒ Press Esc. 
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4.4.11 Delete data 

4.4.11.1 Delete data using the command 

To delete the data, follow these steps: 

1. Specify the data to delete: 

‒ To delete a part of the data in a cell, switch to edit mode and select the required data. 

‒ To clear the content of one or more cells, select these cells. 

2. On the Toolbar, in the Edit section, click  Delete (see Figure 184). 

 

Figure 184. Delete button on the Toolbar 

 

In the case of filters applied or manually hidden columns or rows, only the 

content of visible cells is cleared. 

 

4.4.11.2 Delete data using the keyboard keys 

To delete one or more characters in a cell, use one of the following methods: 

‒ Place the cursor after the characters you want to delete. If you are working in Windows 

/ Linux, delete characters by pressing Backspace as many times as needed, if you are 

working in macOS, delete them by pressing Delete. 

‒ Place the cursor before the characters you want to delete. If you are working in Windows 

/ Linux, delete characters by pressing Delete as many times as needed, if you are working 

in macOS, delete them by successively using Fn+Delete shortcut. 

To delete a word or its part in a cell, do one of the following: 

‒ Place the cursor after a word or word part that you want to delete. When working in 

Windows / Linux, press Ctrl+Backspace, when working in macOS, use ⌘Cmd+Delete 

or ⌥Option+Delete shortcut. 
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‒ Place the cursor before a word or word part that you want to delete. When working in 

Windows / Linux, press Ctrl+Delete, when working in macOS, use  ⌘Cmd+Fn+Delete 

or ⌥Option+Fn+Delete shortcut. 

To delete some text in a cell, do the following: 

1. Select the desired text. 

2. When working in Windows / Linux OS, press Delete or Backspace, when working in 

macOS, press Delete or use Fn+Delete shortcut. 

To clear the content of the cell, do the following: 

1. Select the cell or range to be cleared of data. 

2. When working in Windows / Linux OS, press Delete or Backspace, when working in 

macOS, press Delete. 

 

 

In case filters are applied or columns or rows are manually hidden, only the contents of 

visible cells are cleared. 
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4.5 Number formats 

Different formats can be applied to the numbers that are contained in the cells. The formats 

affect how the numbers are displayed. For example, numbers can be represented as units of currency, 

percentages, fractions, time, or date. Some formats allow to configure how negative numbers are 

represented, divide groups of digits in numbers, and select the number of digits displayed after the 

decimal point. 

Number formats are important for correctly interpreting data in application operations, such 

as calculations in formulas. 

4.5.1 Define cell format 

By default, all cells are assigned the General format when documents are created. 

To change the format, do as follows: 

1. Select the required cell/range of cells or rows/columns you want to change the format of. 

2. Select the desired format from the drop-down list. On the Toolbar, in the Number 

Format section, click on the field that displays the name of the current format, and select 

the desired format from the drop-down list (see Figure 185). 

 

Figure 185. Define cell format 
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4.5.2 Open number format settings window 

Use the Number Format window to customize the display of data in cells for which 

the format Number, Currency, Accounting, Date and/or Time, and Percentage is selected. 

To customize the formats, follow these steps: 

1. Select the cell/range or rows/columns where you want to customize the data display. 

2. Open the number format settings window in one of the following ways: 

‒ In the Format menu, select Number Format (see Figure 186). 

 

Figure 186. Number Format command menu option 

‒ On the Toolbar, select the Number Format section, display the list of available 

formats and select Options (see Figure 185). 

‒ Right-click the selected cells or the titles/contents of the selected rows/columns to 

open the context menu. Select Number Format from the context menu. 

3. In the Number Format window, select the format you want to customize from the list 

to the left (see Figure 187). 
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Figure 187. Number Format window 

4. Specify the parameters for the format (see the description in the sections below). 

5. Click OK. 

To navigate through the Number Format window, use the Tab button (to move from left 

to right) or the Shift+Tab shortcut (to move from right to left). If a list is selected, use the ↓ and ↑ 

buttons to navigate through it. 
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4.5.3 General 

The General format is assigned to all cells by default when the sheet is created. The General 

format is universal, that is, it can be used in all formulas and functions. 

The following numbers in the General format are automatically displayed in scientific 

notation: 

‒ Prime numbers consisting of more than 11 characters. 

‒ Fractional numbers in which the integer part consists of more than 11 characters. 

Once this numbers are entered in the cell, they are displayed in the scientific notation. 

For fractional numbers in the General format, non-significant zeros in the fractional part are not 

displayed. 

4.5.4 Number 

The Number format is the main format for displaying numbers. 

The following parameters can be configured for the Number format: 

‒ Digit grouping separator display 

‒ Number of characters displayed after the dot (.) delimiter 

‒ Negative number presentation type 

4.5.4.1 Split the number into digit groups 

To make it easier to read large numbers, enable the display of the digit group separator. 

A comma is used as the separator character. For example, the number 123456.00 with a separator is 

displayed as 123,456.00. 

To separate groups of digits in numbers, follow these steps: 

1. Select the cell or range of cells that contain the required numbers. 

2. Run the command in one of the following ways: 

‒ On the Toolbar, in the Number Format section, click  Use Thousands Separator 

(see Figure 188). 
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Figure 188. Use Thousands Separator button 

‒ Open the number format settings window, select the Number format and select  

Use thousands separator (see Figure 190). 

‒ Press Ctrl+Shift+1. 

 If a format other than Number is applied to the selected cell, the following happens when 

the Use Thousands Separator option is selected: 

‒ Cell format changes to Number. 

‒ Digit groups are separated. 

‒ Number of decimal places increases/decreases to two (default value). 

 Use Thousands Separator button is always active. That means that before entering data 

into a cell, you can quickly apply the Number format to the cell and configure the display of the digit 

group separator. 

4.5.4.2 Change the number of decimal places  

The number of characters displayed in numbers after the decimal point can be reduced or 

increased. By default, two characters are displayed after the decimal point. 

To do this, follow these steps: 

1. Select the cell or range of cells that contain the required numbers. 

2. Configure the display in one of the following ways: 

‒ On the Toolbar, in the Number Format section, click  Decrease Decimals or 

 Increase Decimals (see Figure 189). 
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Figure 189. Decrease Decimals or Increase Decimals buttons 

‒ Open the number format settings window, select the Number format and specify the 

required Decimal Places using the counter (see Figure 190). 

 

Figure 190. Number format parameters 

When the number of characters decreases, the last visible digit is automatically rounded 

depending on the character to be hidden. Rounding is performed according to standard rules. 

If the General, Date, Time, Date and time, Fraction or Text format, clicking 

 Increase Decimals or  Decrease Decimals will result in the following: 

‒ Number format is applied to the cell. 

‒ Number of decimal places increases/decreases relatively to the default value of two 

decimal places. 
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The  Increase Decimals and  Decrease Decimals buttons are always active. 

That means that before entering data into a cell, you can quickly apply the Number format to the 

cell and adjust the number of characters that will be displayed in numbers after the decimal point. 

4.5.4.3 Customize negative number display style 

To customize negative number display style, follow these steps: 

1. Select the cell or range of cells that contain the required numbers. 

2. Open the number format settings window, select the Number format.  

In the Negative Numbers area, select the desired display format (see Figure 190). 

4.5.5 Currency 

The Currency format is used to display numbers with a currency sign or code, which 

corresponds to the system settings of your computer (see Figure 191). 

 

Figure 191. A number formatted as Currency 

To quickly convert a cell into the Currency format once the data is entered, perform  

the following actions: 

1. Select a cell or a range the format of which you want to change. 

2. On the Toolbar, select the Number Format section and click  Currency 

(see Figure 192). 

 

Figure 192. Currency button 
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Currency format is automatically assigned to a cell if you specify the currency code next to 

the number. For example, 23.00 USD or USD 23.00. A full list of supported currencies and their 

codes can be found in the Appendix 2. List of supported currencies section. 

 

If a cell is formatted as Text, entering the currency code will not affect the cell format. 

The following parameters can be set for the number in the Currency format: 

‒ Currency code and symbol to be entered next to the number 

‒ The number of characters displayed after the dot (.) delimiter 

‒ Negative number presentation type 

4.5.5.1 Select a currency code or symbol 

The default currency code or symbol can be changed. To do this, follow these steps: 

1. Select the cell or range of cells in which you want to change the currency code or symbol. 

2. Open the numeric format settings window, select the Currency format and select the 

required code or symbol from the Symbol drop-down list (see Figure 193). 

 

Figure 193. Currency format parameters 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 214 

4.5.5.2 Change the number of decimal places  

The number of characters displayed in numbers after the decimal point can be reduced or 

increased. By default, two characters are displayed after the decimal point. 

To do this, follow these steps: 

1. Select the cell or range of cells that contain the required numbers. 

2. Configure the display in one of the following ways: 

‒ On the Toolbar, in the Number Format section, click  Decrease Decimals or 

 Increase Decimals (see Figure 189). 

‒ Open the number format settings window, select the Currency format and specify 

the required Decimal Places using the counter (see Figure 193). 

When the number of characters decreases, the last visible digit is automatically rounded 

depending on the character to be hidden. Rounding is performed according to standard rules. 

4.5.5.3 Customize negative number display style 

To customize negative number display style, follow these steps: 

1. Select the cell or range of cells that contain the required numbers. 

2. Open the number format settings window, select the Currency format. In the Negative 

Numbers area, select the desired display format (see Figure 193). 

4.5.6 Accounting 

The Accounting cell format is applied to numbers used in accounting documents. 

In the Accounting format, the entered number is automatically supplemented with the currency code 

or symbol which corresponds to the system settings of your computer. 

When you enter numbers in the Accounting format: 

‒ 0 (zero) in cells is automatically replaced with a hyphen (-). 

‒ Negative numbers in cells are put in parentheses. 
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In the Formula bar and in the editing mode, zeros and negative numbers are displayed the 

way they were entered (see Figure 194). 

 

Figure 194. A negative number formatted as Accounting 

For the number in the Accounting format, you can enter the currency code or symbol 

displayed next to the number and specify the number of decimal places displayed after the dot (.) 

delimiter. 
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4.5.6.1 Select a currency code or symbol 

The default currency code or symbol can be changed. To do this, follow these steps: 

1. Select the cell or range of cells in which you want to change the currency code or symbol. 

2. Open the numeric format settings window, select the Accounting format and select the 

required code or symbol from the Symbol drop-down list (see Figure 195). 

 

Figure 195. Accounting format parameters 
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4.5.6.2 Change the number of decimal places  

The number of characters displayed in numbers after the decimal point can be reduced or 

increased. By default, two characters are displayed after the decimal point. 

To do this, follow these steps: 

1. Select the cell or range of cells that contain the required numbers. 

2. Configure the display in one of the following ways: 

‒ On the Toolbar, in the Number Format section, click  Decrease Decimals or 

 Increase Decimals (see Figure 189). 

‒ Open the number format settings window, select the Accounting format and specify 

the required Decimal Places using the counter (see Figure 195). 

When the number of characters decreases, the last visible digit is automatically rounded 

depending on the character to be hidden. Rounding is performed according to standard rules. 

4.5.7 Date, Time, and Date and Time 

If you enter a number in the Date, Time or Date and Time format in a cell, the cell is 

automatically assigned the Date, Time or Date and Time format respectively 

(see Figure 196 – Figure 198). 

 

Figure 196. A number formatted as Date 

 

Figure 197. A number formatted as Time 
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Figure 198. A number formatted as Date and Time 

The original number corresponds to all data in the Date and Time formats. Its starting point 

for all dates is December 30, 1899, whose original number is 0. For example, the original number 

for the date of January 1, 1900 is 2. 

The original number for data in the Date format will always be integer. To see this number, 

change the cell format to General or Number. 

The original number for data in the Time format will always be a number from the 0.0 to 

0.999988426 range. To see this number, change the cell format to Number. 

The original numbers are required in calculations. Otherwise cells with dates would be 

considered as text cells and could not act as arguments in formulas and functions. 

4.5.7.1 Change the date and/or time display format 

To change the date and/or time display format, follow the steps below: 

1. Select the desired cell or range of cells. 

2. Open the Number Format window, select the Date and Time format. 

3. Select the desired data display format (see Figure 199): 

‒ If the Date format is selected for the cell, select the date display format from the 

Date list and None from the Time list. 

‒ If the Time format is selected for the cell, select None in the Date list, and select the 

time display format in the Time list. 

‒ If you selected the Date and Time format for the cell, select the date display format 

from the Date list and the time display format from the Time list. 
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Figure 199. Parameters of Date, Time, Date and Time formats 

4.5.8 Percentage 

The Percentage format is used to display numbers as percentages. When applying the 

Percentage format, the entered number is multiplied by 100 and designated with a percent sign (%). 

The initial value is displayed in the Formula bar (see Figure 200). 

 

Figure 200. A number formatted as Percentage 

To convert a cell into the Percentage format quickly, do the following: 

1. Select a cell or a range the format of which you want to change. 

2. On the Toolbar, select the Number Format section (see Figure 201) and click  

  Percentage. 
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Figure 201. Percentage button 

4.5.8.1 Change the number of decimal places  

The number of characters displayed in numbers after the decimal point can be reduced or 

increased. By default, two characters are displayed after the decimal point. 

To do this, follow these steps: 

1. Select the cell or range of cells that contain the required numbers. 

2. Configure the display in one of the following ways: 

‒ On the Toolbar, in the Number Format section, click   Decrease Decimals or 

 Increase Decimals (see Figure 189). 

‒ Open the number format settings window, select the Percentage format and specify 

the required Decimal Places using the counter (see Figure 202). 

 

Figure 202. Percentage format parameters 
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When the number of characters decreases, the last visible digit is automatically rounded 

depending on the character to be hidden. Rounding is performed according to standard rules. 

4.5.9 Fraction 

The Fraction format is used to display fractional numbers as ordinary fractions, that is, the 

fractional part is replaced by a numerator and denominator (see Figure 203). 

In the Fraction format, the numerator and denominator are calculated in two ways: 

‒ Exact (for example, 0.5 = 1/2) 

‒ Approximately (for example, 1.6789 = 1 2/3) 

 

Figure 203. A number formatted as Fraction 
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4.5.10 Scientific 

The Scientific format is used to display large numbers  

in a short form. 

In the Scientific format, part of the entered number is replaced by E + n, where E denotes 

the scientific notation (the preceding number is multiplied by 10 to the power of n). For example, in 

the Scientific format the mass of the planet Earth (5,980,000,000,000,000,000,000,000 kg) is 

represented as 5.98E+24, which means 5.98 multiplied by 10 to the power of twenty-four. 

If the Scientific format is applied to a cell, the number in the cell is displayed in the scientific 

notation regardless of how many characters it contains. At the same time, numbers that contain up 

to and including 15 characters are displayed in their original form in the edit mode and in the 

Formula bar. 

A number in the Scientific format is displayed in a cell as follows (see Figure 204): 

‒ The integer part, always consisting of one digit. 

‒ The delimiter separating the integer and the fractional parts. 

‒ The fractional part, which by default consists of two digits. The number of digits in the 

fractional part can be decreased or increased as needed. 

‒ The power of 10 specified as E<exponent symbol><power>. 

 

Figure 204. A number formatted as Scientific 

To decrease or increase the number of digits in the fractional part of a number, do the 

following: 

1. Select the cell or range of cells that contain the required numbers. 

2. On the Toolbar, in the Number Format section, click   Decrease Decimals or 

 Increase Decimals (see Figure 189). 

When the number of characters decreases, the last visible digit is automatically rounded 

depending on the character to be hidden. Rounding is performed according to standard rules. 
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4.5.11 Text 

To make some numbers in MyOffice Spreadsheet look like text, use Text format instead of 

Number or General ones. 

Text format is designed to display and save data in a cell as it is entered. For example, credit 

card numbers or other numeric codes that contain 16 digits or more. 

In Text format, the data in the cell is aligned to the left. 
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4.6 Formulas and functions 

Formula: Any expression in a cell that starts with an equal sign (=).  

Formulas can contain functions, values, cell names, and operators. 

Function: A predefined formula in MyOffice Spreadsheet that needs arguments to calculate 

correctly. For a complete list of functions, see Appendix 1. Functions and their description. 

4.6.1 Formulas and functions basics 

‒ Formulas always begin with an equal sign (=). 

‒ The equal sign can be followed by functions, constants, cell references, operators, and 

other elements. 

‒ All opening and closing brackets must be in sync. 

‒ The mandatory arguments of functions must be specified. 

‒ The constants should not contain a dollar sign ($). 

 

In Windows, if "." is selected in the Customize Format window, in Decimal symbol 

field, use "," instead of ";" as the separator of values in functions in MyOffice Spreadsheet 

application. 

For CELL and INFO functions enter text parameters in English, enclosing them in double 

quotation marks and using the semicolon ";" delimiter. For example,  

=CELL("contents";A2), =INFO("system"). 
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4.6.2 Order of operations in a formula 

If a formula contains several operations, MyOffice Spreadsheet will perform calculations 

based on the following order of operations: 

‒ Operations enclosed in parentheses are performed first: 

‒ The order of operations depends on their priority (see Table 10). 

‒ Operations in the nested parentheses are performed first. 

‒ If a formula contains parentheses that are not essential in the calculation, they will be 

deleted automatically. For example, the formula =SUM(1+(2*5)+1) will be 

automatically transformed into =SUM(1+2*5+1). 

‒ Operations outside the parentheses are performed according to their precedence. 

‒ Operations with the same precedence are performed from left to right, except for 

the exponentiation (^), which is performed from right to left. Example: = 2^4^2 =2^16 

= 65,536 
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If you combine several operators in a single formula, MyOffice Spreadsheet performs 

the operations in the order shown in Table 10. 

Table 10. Operator precedence 

Priority Operator  Meaning 

1 : Range 

2  Space 

3 % Percentage 

4 + 

- 

 

Unary plus 

Unary minus 

Unary space 

5 ^ Exponentiation 

6 * 

/ 

Multiplication 

Division 

7 + 

- 

Addition 

Subtraction 

8 & Concatenation 

9  

= 

> 

< 

>= 

<= 

<> 

Comparison operators: 

Equal to 

Greater than 

Less than 

Greater than or equal to 

Less than or equal to 

Not equal to 

4.6.3 Referencing cells and cell ranges 

Referencing is linking to cells or ranges for further use in calculations. 

There are three types of references: 

‒ Relative: This type of references changes when copying or auto-filling. By default, all 

references in the editor are relative. 

‒ Absolute: This type of reference does not change when copying or auto-filling. 

Therefore, they should be used for formulas that have constant values, such as interest 

rates. 

‒ Mixed: This type of reference allows you to combine both absolute and relative 

references. For example, the B$5, D$12 reference the row number remains the same, but 

the column name may change. 
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4.6.3.1 A1 cell reference style 

The A1 reference style (see Table 11) is used in MyOffice Spreadsheet by default. 

In the A1 reference style, the cell address consists of a column letter name and a numeric 

row name. For example: A1, C12, G37, ND185 etc. 

When creating a sheet, the workspace contains: 

‒ 20 rows numbered from 1 to 20 

‒ 10 columns named from A to J 

When you expand the workspace, new columns continue single-letter naming followed by 

two-letter naming: AA, AB, AC, then BA, BB, BC, etc. 

If the two-letter combinations end, the columns will be given three-letter names. 

When you add rows to a table, the new items continue to be numbered. 

Table 11. Absolute and relative references in the A1 reference style 

Relative reference A1 

Absolute reference $A$1 (the column and row are not changed during copying) 

Mixed references $A1 (the column is not changed during copying) 

A$1 (the row is not changed during copying) 
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4.6.3.2 R1C1 cell reference style 

To enable the R1C1 reference style, in the View command menu, select R1C1  

(see Figure 205). 

 

Figure 205. View menu 

In the R1C1 style, both columns and rows are denoted by numbers (see Table 4).  

The address of a cell is determined using the formula RnCm, where: 

‒ R is a row character, and n is a row number. 

‒ C is a column character, and m is a column number. 

For example, the name of D5 cell in the R1C1 style is R5C4. 
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Table 12. Absolute and relative references in the R1C1 reference style 

Absolute reference R3C2 (an absolute reference to a cell at the intersection of row 3 and 

column 2) 

R3 (an absolute reference to row 3) 

C2 (an absolute reference to column 2) 

Relative reference RC (a relative reference to the current cell) 

R[-2] (a relative reference to the row located 2 rows above the current row) 

C[3] (a relative reference to the column located 3 columns to the right of 

the current column) 

Mixed references RC5 (a reference to a cell in the current row in column 5) 

RC[-5] (a reference to a cell located in the current row 5 columns to the left 

of the current cell) 

R3C[2] (a reference to a cell located in row 3, 2 columns to the right of 

the current cell) 

R[3]C[-2] (a reference to a cell located 3 rows below and 2 columns to 

the left of the current cell) 

R[-3]C[2] (a reference to a cell located 3 rows above and 2 columns to 

the right of the current cell) 

If a spreadsheet contains absolute references when switching from the A1 to 

R1C1 reference style, they will remain absolute afterwards. 
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4.6.3.3 Cell range reference 

The reference to a cell range is defined by referencing its two corner cells: 

‒ Starting cell: The upper-left cell of the range. 

‒ End cell: The lower-right cell of the range. 

 

The starting and end cells are separated by the colon (:) sign. For example: B4:D6  

(see Section 4.6.4). 

If the R1C1 style is selected for cells referencing, in some cases you do not need to use 

the (:) range operator. For instance, if you want to reference the range of all cells of one row, you 

can only specify a reference to this row (that is the R1 reference refers to the range of all cells of 

the first row). 
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4.6.4 Recalculation of formulas 

Calculation is the process of calculating formulas and then displaying the values of the 

results in cells. Formulas are usually recalculated automatically when the values in the cells on 

which they depend change. This is a standard procedure when opening/closing a file and editing it. 

If there are many formulas in a document, their automatic recalculation can make opening 

and working with the document difficult. To speed up work with such documents, 

MyOffice Spreadsheet provides a mode in which formula recalculation is done upon user request. 

Table 13. Recalculation modes 

Automatic recalculation mode Manual recalculation mode 

− When a user opens and saves a document, 

only the outdated formula values are 

recalculated. 

− When you work with a document, formulas 

are recalculated if the associated cells have 

been changed. 

− When you open a document and change the 

associated cells, no formulas are automatically 

recalculated. 

− When you work with a document, formulas are 

recalculated only when you carry out manual 

operations on the cells that contain them. 

− Manual recalculation of outdated formula values is 

available in the entire document, on the sheet, and in 

selected cells. 

− When saving a document, recalculation of outdated 

formula values is performed only if the Before 

Saving box is checked. 

Outdated values in formulas are irrelevant data that were calculated in the past but are no 

longer relevant. They may occur as a result of data entry errors, errors in formulas and functions, 

data type mismatches, changes in table structure, errors in macros, or synchronization problems. 

MyOffice Spreadsheet stores information about the presence of such cells within the file itself. 

When formulas are recalculated, references to data from external documents are not updated. 

To update them, follow the steps described in Section 4.6.10.3. 

4.6.4.1 Select formula recalculation mode 

By default, the automatic mode of formula recalculation is selected in the document. 

To switch the mode, do one of the following: 

1. Open the mode selection sub-menu in one of the following ways: 

‒ In the Command menu, select Data > Calculation Mode (see Figure 206). 
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Figure 206. Calculation mode sub-menu 

‒ On the Toolbar, in the Data section, click the button depicting the current 

recalculation mode. For example,  (see Figure 207). 

 

Figure 207. Recalculation modes 

2. In the sub-menu that opens, select the desired formula recalculation mode: Automatic 

or Manual. 
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The icon of the selected mode is displayed in the Status bar (see Figure 208). 

 

Figure 208. Status bar 

4.6.4.2 Recalculation of formulas in automatic mode 

In automatic mode, only outdated formula values are recalculated when opening a document. 

If you want to force recalculate all formulas in the document, press Ctrl+Shift+F9 / 

⇧ Shift+⌘ Cmd+F9. 

4.6.4.3 Recalculate formulas manually 

You can manually recalculate outdated formula values in the entire document, on an open 

sheet, or in selected cells. 

To recalculate outdated formula values in the entire document, do one of the following: 

‒ In the Command menu, select Data > Calculation Mode > Calculate > 

Whole Document (see Figure 209). 

 

Figure 209. Commands to recalculate outdated formula values manually 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 234 

‒ On the Toolbar, in the Data section, click the recalculation area selection button and 

select  Whole Document from the drop-down list (see Figure 210). 

 

Figure 210. Commands to recalculate outdated formula values manually 

‒ Press F9. 

To recalculate outdated formula values on a sheet currently open, do one of the following: 

‒ In the Command menu, select Data > Calculation Mode > Calculate > Calculate Sheet 

(see Figure 209). 

‒ On the Toolbar, in the Data section, click the recalculation area selection button and 

select  Calculate Sheet from the drop-down list (see Figure 210). 

‒ Right-click the sheet tab and run the Calculate Sheet command from the context menu 

(see Figure 211). 

 

Figure 211. Calculate Sheet command 
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‒ Press Shift+F9 / ⇧ Shift+F9. 

To recalculate outdated formula values in one or more selected cells, do one of the following: 

‒ In the Command menu, select Data > Calculation Mode > Calculate > Calculate 

Selected Cells (see Figure 209). 

‒ On the Toolbar, in the Data section, click the recalculation area selection button and 

select  Calculate Selected Cells from the drop-down list (see Figure 210). 

‒ Right-click the selected cells and choose Calculate Selected Cells command from 

the context menu. 
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4.6.4.4 Recalculate formulas when saving a document 

When the user saves the document, recalculation of outdated formula values is carried out if 

the Before Saving box is checked. 

In Automatic mode, the Before Saving box is always checked and locked. 

In Manual mode, the Before Saving box is checked by default. If you want to uncheck 

the box, do one of the following: 

‒ In the Command menu, select Data > Calculation Mode > Calculate and uncheck 

the Before Saving box (see Figure 212). 

 

Figure 212. Before Saving checkbox 

‒ On the Toolbar, in the Data section, click the recalculation area selection button and 

uncheck the Before Saving box (see Figure 213). 

 

Figure 213. Before Saving checkbox 
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4.6.5 Automatic calculation 

If you select a range of cells, MyOffice Spreadsheet automatically calculates 5 of the most 

used functions and displays the results in the Status bar (see Figure 214): 

‒ SUMM: Calculates the sum of all numbers in the selected range. 

‒ AVERAGE: Calculates the average value of all numbers in the selected range. 

‒ MIN: Displays the smallest value among all the numbers in the selected range. 

‒ MAX: Displays the highest value among all the numbers in the selected range. 

‒ COUNTA: Displays the number of values in the selected range. Numerical and text 

values are considered. 

To configure the list of available functions, follow these steps: 

1. In the Status bar, click the  button. 

2. In the opened list, check the boxes of the functions that will be displayed in 

the Status bar. 

 

Figure 214. Selecting the displayed functions 
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4.6.6 Enter functions 

For a complete list of functions in MyOffice Spreadsheet, see Appendix 1. Functions and 

their description. 

You can enter a function directly into a cell, on the Formula bar, or using the Insert function 

pane. 

To enter a function in a cell or using the Formula bar, follow these steps: 

1. Select the cell in which you want to enter a function. 

2. On the Formula bar or in the cell, type an equal sign (=). 

3. Start typing the name of the function to display a list of available functions  

(see Figure 215). 

 

Figure 215. List of functions 

4. Select the desired function from the list provided using the mouse or keyboard keys: 

‒ Select the function in the list by clicking it. 

‒ Select the function using the ↓ and ↑ buttons and press Enter. 
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5. Detailed information about the function is available. To display it, click the  button to 

the right of the function’s name in the tooltip box (see Figure 216). 

Move the tooltip box with the description with the left mouse button pressed. 

 

Figure 216. Description of a function 

6. Enter function arguments. 

 

MyOffice Spreadsheet allows you to define an entire column, a range of columns, 

an entire row, or a range of rows as an argument by selecting their headers as you 

enter the function. 

 

 

In Windows, if "." is selected in the Customize Format window, in Decimal 

symbol field, use "," instead of ";" as the separator of values in functions in 

MyOffice Spreadsheet application. 

7. To finish, click the  button on the Formula bar or press Enter. To cancel, click 

the  button on the Formula bar or press Esc. 
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To enter a function using the Insert function pane, follow these steps: 

1. Select the cell in which you want to enter a function. 

2. Expand the Insert function pane in one of the following ways: 

‒ In the Insert menu, select Function (see Figure 217). 

 

Figure 217. Insert menu 

‒ On the Formula bar, click  (see Figure 218). 

 

Figure 218. fx button 

‒ On the Toolbar, select the Insert section and click . In the displayed insert pane, 

select  Function (see Figure 219). 
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Figure 219. Insert menu 

‒ On the Sidebar, click the  Insert Function button (see Figure 219). 

‒ Press Shift+F3.  

3. Find the required function in one of the following ways: 

‒ Enter part of the function name/the whole name in the search field. Below is a list of 

functions that meet the search conditions. 

‒ Select the group that the function belongs to. For example, the SUM function is 

included in the Math & Trig group. 

‒ Find the function in one of the following groups: 

• All: Contains all the functions supported by MyOffice Spreadsheet. 

• Recent: Contains the last 10 functions entered by the user. 

• Most popular: Contains a fixed list of 10 frequently used functions. 
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Figure 220. Insert function pane 

4. Select the required function. 

5. If necessary, check out the function summary at the bottom of the Insert function pane. 

6. To insert a function into a cell, do one of the following: 

‒ Click Insert. 

‒ Select the function by double-clicking. 

‒ Press Enter. 

7. Enter the arguments of the function. 

 

In Windows, if "." is selected in the Customize Format window, in Decimal symbol 

field, use "," instead of ";" as the separator of values in functions in MyOffice Spreadsheet 

application. 

8. To finish entering the function, click the  button on the Formula bar or press Enter. 

To cancel entering a function, click the  button on the Formula bar or press Esc. 
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9. To close the Insert function pane, do one of the following: 

‒ In the Command menu, select Insert > Function (see Figure 217). 

‒ On the Formula bar, click  (see Figure 218). 

‒ On the Toolbar, in the Insert section, click . In the insert pane that appears, click 

the  Function button (see Figure 219). 

‒ On the Sidebar, click  Insert Function (see Figure 220). 

‒ Click the button  at the top of the Insert function pane (see Figure 220). 

‒ Press Shift+F3. 

 

When working with numeric data, you often need to carry out typical operations on it and 

output the result in a separate cell, for example, to calculate the sum or display the average value for 

selected columns or rows. For this purpose, it is convenient to use the Autosum operation. 

The operation allows you to use five popular data processing functions: SUM, MIN, MAX, 

AVERAGE, COUNT. 

Autosum recognizes the cell range with numeric data and substitutes it into the function. 

The cells selected before the operation will determine where the result of the calculation will be 

output and what range of data will be used. For example, to calculate the sum for a column, you can: 

‒ Select an empty cell below the column. The result will be inserted into this cell. 

‒ Select the entire column. The result will be inserted into the empty cell under the column 

closest to the range. 

‒ Select a cell range if you want to use only part of the cells in the calculation. The result 

will be inserted into the empty cell under the column closest to the range. 

It is important to take into account the following: 

‒ If the range contains several cells with the results of the same function, only such cells 

will be automatically included in the range. This is convenient when any subtotals have 

already been calculated in the column, and the final total will be their sum. 

‒ If an empty cell next to an area with numbers is selected, all numbers after the nearest 

cell with text, an empty cell, or a cell with the same function will automatically be 

included in the range (see Figure 221). 
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Figure 221. Examples of automatic range detection 

when selecting a single cell 

‒ If a cell range, column or row is selected, the function will include all data after the cell 

with the same function (see Figure 222). 

 

Figure 222. Example of automatic range detection 

when selecting a cell range 

 

To enter a function using the Autosum operation, follow the steps below: 

1. Select an empty cell next to the data, a column, row, or cell range. 

2. Run the Autosum operation in one of the following ways: 

‒ Click  Autosum in the Formula bar or in the Data section of the Toolbar  

(see Figure 223 and Figure 224). The SUM function will be used. If you want to use 

another function, click the arrow to the right of the  button and select the desired 

function from the drop-down list. 
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Figure 223. Autosum on the Formula bar 

 

Figure 224. Autosum on the Toolbar 

‒ In the Data menu, select Autosum (see Figure 225). 

 

Figure 225. Autosum in the Command menu 

‒ Press Alt+= / ⌥ Option+=. 
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When you select an operation from the Command menu, Quick Actions box, or by using 

a keyboard shortcut, only the SUM function can be used. 

3. If necessary, edit the function arguments or add additional ones to them. 

4. To finish entering the function, click the  button in the Formula bar or press Enter. 

To cancel entering a function, click the  button in the Formula bar or press Esc. 

 

Only visible cells of the range are included in the calculation. The maximum possible 

number of arguments when using Autosum is 255. 
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4.6.7 Replace a formula with its result 

For your convenience you can replace a formula or a part of a formula in a cell with its result. 

Simply follow these steps: 

1. Select the formula or a part of the formula directly in the cell or on the Formula bar. 

A tooltip appears above the selected part of the formula or above the formula itself, 

which contains the calculated value. 

2. Press Alt+F9 / ⌥Option+F9 to replace formula, fully or partially, with the calculated 

value. 

4.6.8 Copy and insert formulas 

If necessary, you can cut or copy formulas from one cell/row/column and paste the final 

value of these formulas into another cell/row/column without the formulas themselves. 

To cut or copy a formula, do the following: 

1. Select the cell, cell range, rows, or columns from which you want to cut or copy formulas. 

2. Copy a formula in the usual way (see Section 4.14.2.1). 

 

To insert the result of formula calculation without the original formatting: 

1. Select where you want to enter the resulting value of the formula. 

‒ If the clipboard contains data from a single cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column where you want to paste the contents of the first 

cell/row/column in the range. 

2. To insert the result of a formula calculation without the original formatting, do one of 

the following: 

‒ In the Edit menu, select Paste Values Only (see Figure 226). 
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Figure 226. Edit menu 
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‒ On the Toolbar, select the Edit section and click the arrow to the right of 

the  Paste button. In the drop-down list, select Paste Values Only  

(see Figure 227). 

 

Figure 227. Paste Values Only command 

‒ Open the context menu of the cell by right-clicking and run the Paste Values Only 

command. 

To insert the result of formulas calculation with the original formatting intact, do the 

following: 

1. Select the place where you want to paste the data: 

‒ If the clipboard contains data from a single cell/row/column, select the 

cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range or select the cell/row/column where you want to paste the contents of the first 

cell/row/column in the range. 

2. Paste the content in one of the following ways: 

‒ In the Edit menu, select Paste Values and Format (see Figure 226). 

‒ On the Toolbar, select the Edit section and click the arrow to the right of the  Paste 

button. In the drop-down list, select the Paste Values and Format command  

(see Figure 227). 

‒ Right-click the selected cells or the contents of the selected rows/columns to open 

the context menu and click Paste Values and Format. 

‒ Press Ctrl+Alt+V / ⌥Option+⌘Cmd+V. 
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4.6.9 Names in formulas and functions 

When you work with large data sets, you can give names to frequently used cells, cell ranges, 

constants, and formulas. Names are used in formulas and functions and make them easier to write 

and understand.  

For example, the function =SUM(Sales) is entered and understood more easily than 

the function =SUM(D2; D20). 

Names are divided into two types: 

‒ Defined: Names that the user manually assigned to cells, ranges, constants, and 

formulas. 

‒ Table: The names of tables that have tabular formatting style applied in Microsoft Excel 

(also called "smart" tables). Smart table names are automatically created in 

Microsoft Excel. 

 

In addition, names are varied by their area of application: 

‒ Global: Can be used on any spreadsheet sheet. 

‒ Local: Can be used only on the sheet on which they were set. 

 

The following interface elements are used to work with names: 

‒ Range field: The field is located to the left of the Formula bar (see Figure 228). You can 

expand the range field if necessary. To do this, move the cursor to the right border of 

the field so that it looks like a bidirectional arrow, and while keeping the left mouse 

button pressed, move the field boundary to the right. 

 

Figure 228. Range field 
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‒ Name Manager: It opens when you click the  Name Manager button on the Sidebar 

(see Figure 229). 

 

Figure 229. Name Manager 
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4.6.9.1 Define name 

The name may contain the following elements: 

‒ Letters 

‒ Digits (cannot be used at the beginning of the name) 

‒ Symbols: 

_ (underscore) 

\ (backslash) 

. (dot) (cannot be used at the beginning of the name) 

 

The name can be set using the range field (quick way) or using the Name Manager. 

4.6.9.1.1 Define name with range field 

You can use a range field to name a cell or a range of cells. The name specified using 

the range field is global. 

To specify a name using a range field, do the following: 

1. Select the cell or range of cells to specify a name. 

2. Enter a name in the range field. 

 

Figure 230. Create a name using the range field 

3.  To save the name, press Enter. If you want to delete the data you entered when creating 

the name, press Esc. 
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4.6.9.1.2 Define name using Name Manager 

You can use the Name Manager to name a cell, a range of cells, a constant, or a formula. 

To define a name using the Name Manager, do the following: 

1. If you want to name a cell or a range of cells, select them on the sheet. If you want to 

name a constant or formula, skip this step. 

2. Open the Name Manager in one of the following ways: 

‒ In the Data menu, select Define Name (see Figure 231). 

 

Figure 231. Define Name command menu command 

‒ Right-click the selected cell or cell range to open the context menu and run 

the Define Name command. 

‒ On the Sidebar, click the  Name Manager button. In the Name Manager, click 

Define Name (see Figure 232). 

 

Figure 232. Define Name button 
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3. In the Name Manager, specify the data to create the name (see Figure 233): 

‒ In the Name field, specify the name of the cell/range/constant/formula or leave 

the default name. The default name is [Name_n], where n is the ordinal number of 

the named item. 

 

Figure 233. Create a name using the Name Manger 

‒ If a name is created for a cell/range, a reference to the cell/range selected in 

the first step is automatically generated in the Reference field. If necessary, 

the reference can be edited manually, or you can select another cell/range on 

the sheet with the mouse so that the reference will be edited automatically. If a 

name is created for a constant or formula, enter the desired constant/formula 

manually in the Reference field. 
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References to cells and cell ranges are displayed as absolute by default. You 

can convert them to relative ones manually. 

‒ In the drop-down list specify where the name will be used: on all sheets of 

the spreadsheet or on a specific sheet. 

4. Click the Done button or press Enter. 

The created name appears in the Name Manager list (see Figure 234). 

 

Figure 234. Name created in the Name Manager 
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4.6.9.2 Find a name 

The name can be found using the range field or the Name Manager. 

 

The search is not case-sensitive. 

4.6.9.2.1 Find using the range field 

To quickly find a name, do the following: 

1. Click the range field. 

2. Start typing the desired name. The names that match the search conditions will appear in 

the drop-down list (see Figure 235). 

3. Select the desired name using the mouse or the keyboard keys: 

‒ Left-click the name with the mouse. 

‒ Select the name using the ↓ and ↑ keys and press Enter. 

 

Figure 235. Quick name search 

To view the entire list of names and select the desired name from it, follow these steps: 

1. Expand the entire list of names. To do this, in the range field, click the  button 

(see Figure 236). 

2. Select the desired name in the list using the mouse or the keyboard keys: 

‒ Left-click the name with the mouse. 

‒ Select the name using the ↓ and ↑ keys and press Enter. 
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Figure 236. Name list 

If the selected name belongs to a cell/range, that cell/range is highlighted in the spreadsheet. 

If the selected name belongs to a constant or formula, the Name Manager opens and 

automatically selects a line for that name. 

If the name of a cell/cell range/constant/formula is selected in the cell editing mode, it is 

entered in the cell as the value of the formula/function (see Section below). 
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4.6.9.2.2 Find using the Name Manager 

Open the Name Manager in one of the following ways: 

‒ On the Sidebar, click  Name Manager button (see Figure 237). 

 

Figure 237. Name Manager 

‒ In the range field, click  and select Manage Defined Names (see Figure 238). 

 

Figure 238. Manage Defined Names 
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The Name Manager displays a complete list of names that the current spreadsheet contains 

(see Figure 237). Use the search bar and filter/sorting tools to quickly search through the list. 

To search a name using the search bar, do the following: 

1. Set the cursor in the search bar. 

2. Start entering the desired name or a link/constant/formula to which the name has been 

assigned (see Figure 239). 

 

Figure 239. Search bar 

As you enter data for the search, the list of names will be reduced to values that match 

the search conditions. 

To filter the list, do the following: 

1. Click the All names field (see Figure 240). 

2. In the drop-down list, specify which name group should be displayed in the list: 

‒ Defined names: Names created manually by the user. 

‒ Table names: Smart table names. 

‒ Local: current sheet: The names which can be used on the currently opened sheet. 

‒ Global: all sheets: Names that can be used on any spreadsheet sheet. 
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Figure 240. All names field 
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To select the list sorting type, do the following: 

1. Click  (see Figure 241). 

2. Select the sorting type: 

‒ Name (A-Z): Sorting by the value specified in the Name field (in ascending order). 

‒ Name (Z-A): Sorting by the value specified in the Name field (in descending order). 

‒ Reference (A-Z): Sorting by the value specified in the Reference field (in ascending 

order). 

‒ Reference (Z-A): Sorting by the value specified in the Reference field 

(in descending order). 

 

Figure 241. Selecting the sorting type 

To see which cell/range corresponds to which name, select that name in the list. 

The cell/range will be highlighted in the spreadsheet. 

If the name of a cell/cell range/constant/formula is selected in the cell editing mode, it is 

entered in the cell as the value of the formula/function (see Section below). 
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4.6.9.3 Enter the name in a formula or function 

Formulas and functions that contain names of cells/cell ranges/constants/formulas are 

entered as usual. 

Names in formulas or functions can be entered as follows: 

‒ Manually 

‒ Using the range field 

‒ Using the Name Manager 

 

To enter the name manually, do the following: 

1. Start typing the name (see Figure 242). The drop-down list will display the names which 

correspond to the search parameters. 

2. Select the name using the mouse or the keyboard keys: 

‒ Left-click the name with the mouse. 

‒ Select the name using the ↓ and ↑ keys and press Enter. 

 

Figure 242. Enter names manually 

To enter a name using a range field, search for it as described in Section 4.6.9.2.1 

(see the example in Figure 243). 
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Figure 243. Entering name using the range field 

To enter the name using the Name Manager, do the following: 

1. Perform the name search as described in Section 4.6.9.2.2. 

2. Select a name with the mouse or keyboard keys (see Figure 244):  

‒ Select the name with a double-click. 

‒ Select the name with the ↓ and ↑ keys and press Enter. 

 

Figure 244. Enter name using Name Manager 

The selected name will be substituted in the formula/function. If the name belongs to 

a cell/range, the cell/range will be highlighted in the spreadsheet. 

 

If necessary, you can enter a local name from another sheet into a formula/function. To do 

this, select it in the range field or in the Name Manager or manually enter a reference 

like 'Sheet Name'!MyName. For example: 'Sheet2'!Name_8. 
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4.6.9.4 View name properties 

To view the name properties, do the following: 

1. Open the Name Manager in one of the following ways: 

‒ On the Sidebar, click  Name Manager button (see Figure 237). 

‒ In the range field, click  and run the Manage Defined Range command  

(see Figure 238). 

2. In the Name Manager, place the cursor on the desired name and click the  Expand 

button (see Figure 245). 

 

Figure 245. Expand button 

If the name belongs to a cell/range, the cell/range will be highlighted in the spreadsheet. 

The Name Manager displays the properties of the selected name (see Figure 246). The text 

in the Name and Reference fields can be copied if necessary. 

To hide the name properties, click Collapse. 
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Figure 246. Name properties 
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4.6.9.5 Delete a name 

You can delete names created manually. Deleting names of smart tables is not possible. 

To delete a name, do the following: 

1. Open the Name Manager in one of the following ways: 

‒ On the Sidebar, click  Name Manager button (see Figure 245). 

‒ In the range field, click the  button and run the Manage Defined Names command 

(see Figure 238). 

2. In the Name Manager, place the cursor on the desired name and click the  Expand 

button (see Figure 245). 

3. Click  Delete (see Figure 246). 
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4.6.10 Reference to data in another document 

In the formulas and functions of the current document, you can refer to data from one or 

more external documents. 

The following restrictions apply in this version of the application: 

‒ The current and external documents must be saved in .xlsx, .ods or .xods format. 

‒ The current and external documents must be local, that is, they must be stored directly 

on your computer. 

‒ The creation of references to cells and cell ranges of an external document is supported. 

The use of structured references (see Section 4.6.11), as well as references to cell names and 

ranges, is not allowed (see Section 4.6.9). 

‒ The reference that is entered manually into the cell with the name (see Section 4.6.9) 

must be absolute. 

You can create a reference to data from an external document in one of the following ways: 

‒ Open an external document and select the desired cell or range of cells with a mouse 

click. 

‒ Enter the reference manually without opening an external document. 

4.6.10.1 Create a reference with a mouse click 

To create a reference to data from an external document in a formula or function of 

the current document by clicking the mouse, follow these steps: 

1. Open a document that will contain a formula or function with a reference, and an external 

document to which data you want to create a reference. If the external document was 

opened earlier, make sure that all the changes you made are saved in it (see Section 4.1.8). 

2. In the current document, select the cell where you want to enter a formula or function. 

3. On the Formula bar or directly in the cell, enter the = sign and start typing the formula 

or function. 

4. Navigate to the external document and select the sheet whose cell or range of cells you 

want to refer to. 

5. Select the desired cell or range of cells on the sheet. The Formula bar of the external and 

current document displays the entered formula or function from the current document. 

If necessary, the formula/function can be edited both in the current and in an external 

document. 
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6. Go to the current document, finish entering the function or formula and click 

the  button on the Formula bar or press Enter. 

4.6.10.2 Enter the reference manually 

To manually create a reference to data from an external document in a formula or function of 

the current document, enter a string of the following type: 'path[name.extension]Sheet'!Cell where: 

‒ path: the path to the external document, which can be specified as: 

‒ Relative path: The path to the external document described relative to the base directory 

of the source document. Example: ../Subfolder/External document.xlsx. 

‒ Absolute path: The path to the document described from the root of the logical disk 

(the root of the installed operating system).  

Example: C:/Users/Username/Downloads/Subfolder/External document.xlsx. 

‒ The absolute path to the external document using the file scheme (URI scheme). Example: 

file:///C:/Users/Username/Downloads/Subfolder/External document.xlsx. 

‒ name.extension: The name and extension of the external file.  

For example: External document.xlsx. 

‒ Sheet: The name of the sheet in the external document. Example: Sheet1. 

‒ Cell: The address of a cell or range of cells in an external document. For example: A1 

or A1:A10. 

 

Examples for Windows OS 

In example below, the document document.xlsx located in the base directory 

C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

the same directory. 

Relative path to external 

document 

../external.xlsx 

Absolute path to 

external document 

C:/Users/Username/Downloads/external.xlsx 

The absolute path to the 

external document using 

the file scheme (URI 

scheme) 

file:///C:/Users/Username/Downloads/external.xlsx 

Formula with relative 

reference 

='[external.xlsx]Sheet 1'!A1+A1 

Function with absolute 

reference 

=SUM('file:///C:/Users/Username/Downloads/[external.xlsx]Sheet1'!A1:A10) 
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In example below, the document document.xlsx located in the base directory 

C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

a nested directory C:/Users/Username/Downloads/Subfolder/. 

Relative path to external document ../Subfolder/external.xlsx 

Absolute path to external document C:/Users/Username/Downloads/Subfolder/external.xlsx 

The absolute path to the external 

document using the file scheme (URI 

scheme) 

file:///C:/Users/Username/Downloads/Subfolder/external.xlsx 

Formula with relative reference ='Subfolder/[external.xlsx]Sheet1'!A1+A1 

Function with absolute reference =SUM('file:///C:/Users/Username/Downloads/Subfolder/ 

[external.xlsx]Sheet1'!A1:A10) 

In example below, the document document.xlsx located in the base directory 

C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

another directory – D:/Documents/SomeFolder/. 

Relative path to external document D:/Documents/SomeFolder/external.xlsx 

Absolute path to external document D:/Documents/SomeFolder/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///D:/Documents/SomeFolder/external.xlsx 

Formula with relative reference ='D:/Documents/SomeFolder/[external.xlsx 

]Sheet1'!A1+A1 

Function with absolute reference =SUM('file:///D:/Documents/SomeFolder/[external.xlsx] 

Sheet1'!A1:A10) 
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Examples for Linux and macOS 

In example below, the document document.xlsx located in the base directory 

/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

the same directory. 

Relative path to external document ../external.xlsx 

Absolute path to external document /Users/Username/Downloads/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///Users/Username/Downloads/external.xlsx 

Formula with relative reference ='[external.xlsx]Sheet 1'!A1+A1 

Function with absolute reference =SUM('file:///Users/Username/Downloads/ 

[external.xlsx]Sheet1'!A1:A10) 

In example below, the document document.xlsx located in the base directory 

/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

a nested directory /Users/Username/Downloads/Subfolder/. 

Relative path to external document ../Subfolder/external.xlsx 

Absolute path to external document /Users/Username/Downloads/Subfolder/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///Users/Username/Downloads/Subfolder/external.xlsx 

Formula with relative reference ='Subfolder/[external.xlsx]Sheet1'!A1+A1 

Function with absolute reference =SUM('file:////Users/Username/Downloads/Subfolder/ 

[external.xlsx]Sheet1'!A1:A10) 

In example below, the document document.xlsx located in the base directory 

/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

another directory, /Volumes/USB_flash/SomeFolder/. 

Relative path to external document /Volumes/USB_flash/SomeFolder/external.xlsx 

Absolute path to external document /Volumes/USB_flash/SomeFolder/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///Volumes/USB_flash/SomeFolder/external.xlsx 

Formula with relative reference ='../Volumes/USB_flash/SomeFolder/[external.xlsx] 

Sheet1'!A1+A1 

Function with absolute reference ='file:///Volumes/USB_flash/SomeFolder/[external.xlsx] 

Sheet1'!A1:A10) 
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4.6.10.3 Update data 

Since the data in the external document may change, it is recommended to periodically 

update the reference to this data in the current document. 

To update the references after opening the current document, click the Refresh Data button 

in the notification line “Linked documents might have changed. Refresh this document to get 

the latest data” (see Figure 247). This line is displayed under the Toolbar. 

The application will recalculate formulas and functions taking into account new values from 

an external document. 

 

Figure 247. Refresh Data button 

If the document is not available, the notification line "Linked documents are unavailable. 

The spreadsheet uses the last saved data." Click Close in this line (see Figure 248). 

 

Figure 248. Close button 

 

To update the data when working with a document, do one of the following: 

‒ In the Data menu, select Refresh Data (see Figure 249). 
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Figure 249. Refresh Data command menu option 

‒ On the Toolbar, in the Data section, click  Refresh Data (see Figure 250). 

 

Figure 250. Refresh Data button 

‒ Press Ctrl+Shift+F5 / ⇧Shift+⌘Cmd+F5. 

Data on external references are updated automatically when a new document reference is 

created or when an existing one is edited. In this case, the data is updated only for those documents 

that are specified in the created or edited formula. 
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Error #REF! displayed in cells if: 

− When creating a reference, the external document specified in the reference is 

unavailable (or the specified sheet does not exist in it), and there are no previously 

saved values for it. 

− When uploading a document, there are no saved values for the external document 

specified in the reference (the data was not received when creating the reference). 
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4.6.11 Structured references 

You can use structured references with tables (see Section 4.8). These are Microsoft Excel 

spreadsheets to which the table formatting is applied. 

By default, "smart" tables are named as Table 1, Table 2 etc., and consist of the following 

elements: 

‒ Heading line 

‒ Data area 

‒ Result line 

4.6.11.1 Use structured references 

Formulas with structured references do not operate with cells or range references, but with 

the names of the table and columns of the table, as well as the names of table areas (see Figure 251). 

 

Figure 251. Structured reference 

Examples of common and structured references can be found below. 

Table 14. Reference examples 

Description Regular 

reference 

Structured reference 

Reference to cell range of the Sales 

column in Table 1 

=MAX(B2:B8) =MAX(Table1[Sales]) 

Reference to the data area in Table 2 =MAX(A2:C8) =MAX(Table2[#Data]) 

 

 

Structured references can be used both in the table and outside of it. 
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If the formula with the structured reference is located directly in the table, you do not need 

to specify the name of the table in this reference. If the table name is specified in the link for any 

reason, it is automatically deleted when you enter the formula. For example, the formula 

=MAX(Table1[Sales]) will be automatically replaced with =MAX([Sales]). 

If a formula with a structured reference is located outside the table, the name of the table 

must be specified. 

4.6.11.2 Structured reference syntax 

Structured references can refer to the following table data: 

Table 15. References 

Reference Description 

#All The whole table, including the heading line and the result line (if any) 

#Headings The heading line only 

#Data Data lines only 

#Totals Result line only 

@Column name 

OR 

@ 

OR 

#This row 

Cell at the intersection of the current row and the specified column (implicit 

intersection). 

 

 

The #This row reference will automatically change to @. 

Examples of structured references can be found below. 

Table 16. Structural reference examples 

 Entire table Data only Headings only Results only 

Table 

Table1 

Table1[#All] Table1 

 

Table1[#Data] 

Table1[#Headings] Table1[#Totals] 

Column N Table1[[#All],

[N]] 

Table1[N] 

 

Table1[[#Data],[N]] 

Table1[[#Headings],

[N]] 

Table1[[#Totals],[N]] 

Columns 

from  

N to M 

Table1[[#All],

[N]:[M]] 

Table1[[N]:[M]] 

 

Table1[[#Data],[N]:[M]] 

Table1[[#Headings],

[N]:[M]] 

Table1[[#Totals],[N]:[M]] 
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4.6.11.3 Enter a structural reference in a formula 

Formulas that contain structured references are entered in standard ways. 

To specify the name of a "smart table" in a formula, follow these steps: 

1. Start typing the table title. A drop-down list will show the names of all "smart" tables 

that are contained in the document. 

 

Figure 252. List of “smart” tables 

 

2. Select the name of the desired table using the mouse or the keyboard: 

‒ Click the table title with the left mouse button. 

‒ Select the table title using the ↓ and ↑ keys and press Enter. 

The name of the table will be entered in the formula. 
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To enter the column name or a reference to the table area (for example, #Totals or @), 

do the following: 

1. Enter the [ (left square bracket) symbol. The drop-down list will display the column 

names and the references to the table areas. 

2. Select the desired element from the list using the mouse or the keyboard: 

‒ Left-click the element name with the mouse. 

‒ Select the element line using the ↓ and ↑ keys and press Enter. 

 

The selected element will be added to the formula. 

 

Figure 253. List of column names and data references 

If an argument (e.g., [#Headings]) is entered correctly into a formula, it is highlighted in 

color, and the table highlights the range to which it refers (for example, the heading line). 
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4.7 Calculation operators 

4.7.1 Arithmetic operators 

Arithmetic operators (see Table 17) perform basic operations with numbers in the Number, 

Date, and Time formats. 

If the value cannot be converted to a number, the operation will result in an error #VALUE!. 

Table 17. Arithmetic operators 

Operator Meaning Example 

+ Addition =6+7 

- Subtraction 

Negation 

=B12-B3 

-45 

* Multiplication =86*34 

/ Division =36/3 

^ Exponentiation =D8^2 

% Percentage 76% 

To calculate the root of a number, use the following formula: 

=M^(1/N) 

where M is the number you want to find the root of, and N is the root index. 

For example, this formula =36^(1/2) extracts the square root of 36. 
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4.7.2 Comparison operators 

Comparison operators (see Table 18) compare two values. You can compare any type of 

data, including numbers, dates, and character strings. 

The comparison result can either be: 

‒ TRUE: The expression is true. 

‒ FALSE: The expression is false. 

Table 18. Comparison operators 

Operator Meaning Example 

= Equal to =6=6 

> Greater than =9>17 

< Less than =A2<C3 

>= Greater than or equal to =0>=6 

<= Less than or equal to =P12<=7 

<> Not equal to =3<>4 
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4.7.3 Text concatenation operator 

The Text concatenation operator (see Table 19) combines data from text cells into one string. 

Table 19. Text concatenation operator 

Operator Description Example 

& Connects strings from two or more than 

two cells to produce one continuous 

sequence of characters 

Cells: A2 (My) and A3 

(Office) 

Formula: =A2&A3 

Result: MyOffice 

To combine data from 3 or more cells, use a text operator before each new cell address. 
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4.7.4 Reference operators 

Reference operators (see Table 20) describe references to cell ranges. Use these operators to 

refer to both the cells in the current sheet and cells in other sheets in the same spreadsheet. 

Table 20. Reference operators 

Operator Description Example 

: A range operator. 

Creates a reference to a range of cells. The 

operator is placed between the first and the last 

cell of the range. 

 

The operator can be used to combine cell 

ranges. In this case it returns the range between 

the upper left and lower right cells, including 

these cells. 

 

=SUM(B2:C4) 

(see Figure 203) 
 

=SUM(A1:B1:C4:D4) – in this 

example, the sum of all cells 

between and including A1 and D4 

is calculated. 

(see Figure 204) 

Space Intersection operator. 

Creates a reference to the cells located at 

the intersection of the specified ranges. 

 

=SUM(A2:C4 B2:D4) 

(see Figure 205) 

'sheetname'! Creates a reference to a cell or range of cells in 

another sheet of the current document. 

=SUM(B2+'Sheet2'!B2) 

 

=SUM(B2:C4+'Sheet2'!B2:C4) 

(see Figure 206) 

'sheetname 

n:sheetname m'! 

Creates a reference to the same cell on several 

sheets of the current document 

(a 3D reference). 

=SUM('January_2019: 

December_2019'!A1) – in this 

example, the sum of all A1 cells 

on all sheets within the specified 

range is calculated. 

When entering formulas, select the desired cell range (see Section 4.2.1) to avoid entering it 

manually. 
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Figure 254. Range operator 

 

Figure 255. Intersection operator 

 

Figure 256. Operator referencing cells on another sheet  
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4.8 Tables 

4.8.1 Create a table 

Tables are a range of cells that constitute a single object with its own name, internal structure 

(areas) and formatting style. 

Tables have a unique name within the document (by default, Table1, Table2, and so forth) 

and consist of the following areas: 

‒ Header row 

‒ Data area 

‒ Total row 

The table name, column and area names are used in structured references 

(see Section 4.6.11). 

When working with a table, you can perform the following operations: 

‒ Edit column names. Column names are automatically updated in the structured 

references of the table. If the name you enter already exists in the table, a sequence 

number will be automatically added to it, for example, the name “Date” will become 

“Date1”. 

‒ Insert rows and columns between the existing rows and columns (but not at the end of 

the table). 

‒ Copy tables within one document or from document to document, provided that both 

documents are open in MyOffice Spreadsheet. The copied table is automatically 

assigned a unique name. In all structured references, the name of the original table is 

automatically replaced with the name of the copied table. 

‒ Quickly customize the order of sorting and filtering of values in columns using 

automatically created filters in column headers. 

‒ Customize the table: Choose a design style from those available in the collection, include 

or exclude table areas (see Section 4.8.3). 

‒ Expand the range of the table by adding new data to adjacent cells (see Section 4.8.4). 

‒ Select the type of calculation in the total row (see Section 4.8.6). 

‒ Convert the table to a regular range of data (see Section 4.8.7). 

You can create a table only on the current sheet of the document if the sheet is not protected 

from changes and in Edit mode only. 
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When you select a cell range for a table, it is recommended that you consider the following 

constraints: 

‒ The selected range cannot overlap with another table or pivot table. 

‒ There should be at least one empty row between the selected range and the closest table, 

pivot table, merged cell, or other range containing filters. 

‒ The selected range should not contain any cells with filters, unless they are cells in the 

first row of the range. 

‒ If the first row of a range has filters, that range should not intersect or be part of another 

range with filters. 

To create a table, follow these steps: 

1. Select the cell or range of cells you want to convert to a table.  

2. Open the Create Table dialog box in one of the following ways: 

‒ In the Insert menu, select Table (see Figure 257). 

 

Figure 257. Table command menu option 

‒ On the Toolbar, in the Insert section, click  Table (see Figure 258). 

 

Figure 258. Table button on the Toolbar 
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‒ On the Toolbar, in the Insert section, click . In the insertion pane that appears, 

click  Table (see Figure 259). 

 

Figure 259. Table option in the insert pane 

‒ Press Ctrl+T / Cmd+T. 

‒ Select Table in Quick Actions box (see Section 3.10). 

3. If necessary, edit the range in the Value Source field. To do this, enter the address in the 

field directly or, by clicking  Select Values, select the desired cells in the document 

(see Figure 260). If you make an error when entering, follow the on-screen prompts. 

4. If necessary, edit the table name in the Name field (see Figure 260). 

 

The table name should be unique to the document, contain no spaces, and 

begin only with the letter or characters “_” or “\”. You cannot change the name 

once the table has been created. 

5. Clear the Include headers in the table checkbox if you do not want the cells in the first 

row of the selected range to be converted to table headers (see Figure 260). If you clear 

the check box, a new row will be created with automatically generated header names. 
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Figure 260. Create Table window 

6. Click OK. 

4.8.2 Open the table settings pane 

MyOffice Spreadsheet allows you to customize the parameters of the table using the settings 

pane. 

The pane automatically opens when you select any cell in the table and automatically closes 

when you select any cell outside the table (see Figure 261). 
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Figure 261. Smart Table pane 

You can also open and collapse the Table pane manually. 

To collapse the settings pane manually, do one of the following: 

‒ At the top of the pane, click  (see Figure 261). 

‒ On the Sidebar, click  Table (see Figure 261). 

‒ In the Data menu, click Table Settings (see Figure 262). 

 

Figure 262. Open the pane from the command menu 
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‒ On the Toolbar, in the Table section, click  Table Settings (see Figure 263). 

 

Figure 263. Open the pane from the Toolbar 

‒ Right-click any cell of the table and run the Table Settings command from the context 

menu (see Figure 264). 

 

Figure 264. Open the pane from the context menu 

You can open the settings pane manually using similar methods. 
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4.8.3 Table customization 

When working with several smart tables on the same sheet, you can distinguish them by 

applying different styles and formatting. Changing the style of a table is only possible for the entire 

table. 

To customize the appearance of the table, follow the steps below: 

1. In the Table pane, in the Table Style field, select one of the most recently used styles or 

click  to view all available styles in the collection (see Figure 261). The collection 

contains 60 styles and 1 additional style which is intended to reset the formatting.  

2. In the Display field, enable or disable the display of the header and total (see Figure 261). 

3. In the Alternate Colors field, enable or disable alternating dark and light shades for 

column and row colors (see Figure 261). 

 

Display and color alternation options affect both the appearance of the table 

and the styles in the collection. 

You can reset a style applied to a table in several ways (see Figure 265): 

‒ By selecting the style intended for formatting reset. This style is labeled with the word 

None in the Table Style field. 

‒ From the style collection window by clicking Clear at the bottom of this window. 

 

Figure 265. Clear button in the style collection  
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4.8.4 Automatic table expansion 

A table is automatically expanded when you enter data into adjacent cells in the column to 

the right of the table. If the table does not have a row of totals, auto-expansion is also performed 

when entering data into adjacent cells located in the row following the last row of the table. 

You can enter data in the following ways: 

‒ Manually. 

 

If you enter a formula in an adjacent column, that column becomes a calculated 

one (see Section 4.8.5). 

‒ From the clipboard. The automatic expansion is performed if data is inserted into 

adjacent cells to the right/bottom of the table or inserted into both the table and adjacent 

cells at the same time. 

‒ By means of cell autofill (see Section 4.4.1.4), when one or more cells of the table are 

selected as a reference cell. 

Automatic expansion is performed if: 

‒ The auto-expansion area does not contain any data. 

‒ The inserted data does not overlap with another table. 

 

The current version of the application does not support the automatic expansion of 

tables when autofilling cells (see Section 4.4.1.4) if a table cell with a structured 

reference is selected as a reference cell. 

4.8.5 Add a calculated column 

If you want to add a column where all cells contain the same formula to a table, create a 

calculated column. You can use any column in the table that does not contain data to create a 

calculated column. 

To convert a column to a calculated one, enter the desired formula in any cell in that column 

and press Enter. 

All cells in the column will automatically be filled with the formula you entered. 

The following rules apply to the calculated columns: 

‒ If you edit a formula in any cell of a calculated column, the same formula editing is 

automatically performed in the remaining cells of that column. 
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‒ If the data in a column is partially deleted or regular data is entered instead of a formula, 

the column ceases to be calculated (formula changes cease to apply to the whole 

column).  

‒ If the column consistency is restored manually (all cells contain the same formula again), 

the column becomes calculated again. 

4.8.6 Select the type of calculation in the total row 

In the total row of the table, you can select a different type of calculation for each column. 

To do this, follow these steps (see Figure 266): 

1. Select the cell in the total row under the desired column. 

2. Click the  button next to the selected cell. 

3. In the drop-down menu, select the desired function. The selected function together with 

the column are automatically substituted into the SUBTOTAL function, and the 

calculation result is displayed in the selected cell. 

4. If the required function is not in the list, select More functions and insert the required 

function in the standard way using the Insert Function pane. 

 

Figure 266. Select the calculation type in the totals 
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To clear a calculation from a cell in the total row, select the desired cell and do one of the 

following: 

1. Press Delete. 

2. Click the  button next to the selected cell and choose the None option from the drop-

down menu (see Figure 266). 

4.8.7 Convert a table to a regular range 

To convert a table to a regular range with data, follow these steps: 

1. Select the table cell or range of cells. 

2. Run the conversion command in one of the following ways: 

‒ In the Data menu, select Convert into Regular Range (see Figure 267). 

 

Figure 267. Convert Table into Regular Range option in the command menu 

‒ On the Toolbar, in the Table section, click  Convert Table into Regular Range 

(see Figure 268). 

 

Figure 268. Convert Table into Regular Range option in the Toolbar 
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‒ Open the context menu by right-clicking and run the Convert Table into Regular 

Range command. 

‒ Select Convert Table into Regular Range in Quick Actions box (see Section 3.10). 

3. In the Table window that opens, click Convert. 

 

When converting a table to a regular range, the autofilters in the table headers will be 

removed and any rows/columns hidden by grouping will be displayed. 

4.8.8 Delete a table 

To delete a table, follow these steps: 

1. Select the entire range or one/several cells from the range of the table. 

2. Delete it in one of the following ways: 

‒ In the Data menu, click Delete Table (see Figure 269). 

 

Figure 269. Delete a table via the command menu  

‒ On the Toolbar, in the Table section, click  Delete Table (see Figure 270). 
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Figure 270. Delete a table via the Toolbar 

‒ Right-click the selected cells to open the context menu and run the Delete Table 

command. 

‒ Select Delete Table in Quick Actions box (see Section 3.10). 

‒ If a range of cells is selected that includes cells of the table, press Delete. 
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4.9 Pivot tables 

4.9.1 Create a pivot table 

A pivot table is a tool that allows you to present data from an ordinary flat table in a form 

that is easy to analyze.  

Pivot tables allow you: 

‒ To quickly place data from the source table columns into the pivot table columns and 

rows and swap them around. 

‒ To perform calculations. 

‒ To filter data. 

 

To create a pivot table, create a source table first, which is a flat table with the required data. 

When preparing the source table, it is recommended to consider the following requirements: 

‒ The columns in the source table must have headings. 

‒ It is recommended to use data in one format within one column of the table 

(see Section 4.5). For example, only in General format or only in Date format. 

 

You can create a pivot table on a new sheet or on the sheet you are working on. 

To create a pivot table: 

1. Select one of the following elements required to create a pivot table: 

‒ A range of data in the source table which will be used as the basis of the future pivot 

table. The range of data should be selected with the column headings. 

‒ A single cell within the data range, or an empty cell adjacent to the range if you want 

to use the entire range. 

 

The range cannot consist of one line. The first range line cannot contain empty or 

merged cells. 
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‒ A cell on the sheet you are working on which should be inserted in the pivot table. 

This cell will become the upper left cell of the table. The selected cell should not 

contain any data. 

 

It is highly recommended to leave at least two blank lines above the pivot 

table for filters (see Section 4.9.3). 

2. Open the pivot table creating window in one of the following ways: 

‒ In the Command menu, select Insert > Pivot Table (see Figure 271). 

 

Figure 271. Pivot table command menu 

‒ On the Toolbar, in the Insert section (see Figure 272), click  Pivot Table. 

 

Figure 272. Pivot table button 

 

‒ On the Toolbar, in the Insert section, click  (see Figure 273). In the displayed 

insert pane, click  Pivot Table. 
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Figure 273. Insert pane 

3. In the Create Pivot Table window (see Figure 274), do the following: 

‒ If you selected a cell to insert the pivot table in the first step, specify the range of 

source table data from which to create the pivot table in the Data Source field. 

‒ If you selected a data range, a single cell within a range, or an adjacent blank cell in 

the first step, specify where the table will be inserted: 

• New sheet: Insert the table in a new sheet. The new sheet will be created 

automatically. By default, the new sheet will be named Pivot table <No.>, where 

No. is the number of the pivot table in the document you are working on. 

If needed, you can edit the sheet name. 

• Existing sheet: Insert the table on the sheet that is currently displayed on 

the screen. In the Specify a destination cell enter the cell address manually or 

click to select an empty cell in the workspace where you want the upper-left cell 

of the pivot table to be located. There must be at least two blank lines above 

the initial cell to place filters (see Section 4.9.3). 

4. Click OK. 
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Figure 274. Create Pivot Table window  
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4.9.2 Open the pivot table settings pane 

You can configure the pivot table by using the pane that contains the following tabs: 

‒ Constructor: Use this tab to select the structure (layout) of the pivot table. 

‒ Options: This tab contains the pivot table parameters. 

The pivot table settings pane opens automatically when you select any cell in the pivot table 

and collapses automatically when you select any cell outside the pivot table. 

 

The pivot table settings pane is unavailable if the sheet with the pivot table is protected 

from changes and the Work with pivot tables option is disabled in the Allowed actions 

list. 

You can also open and collapse the pivot table settings pane manually. 

To collapse the pane manually, do one of the following: 

‒ At the top of the pane, click . 

‒ On the Sidebar, click  Pivot Table. 

To open the pane manually, do the following: 

1. Select the entire range or one/several cells from the range of the pivot table. 

2. Open the pane in one of the following ways: 

‒ In the Data menu, click Pivot Table Settings (see Figure 275). 

 

Figure 275. Data menu 

‒ On the Toolbar, in the Pivot Table section, click  Pivot Table Settings 

(see Figure 276). 
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Figure 276. Settings button 

‒ On the Sidebar, click  Pivot Table (see Figure 277). 

 

Figure 277. Pivot table configuration pane 

‒ Right-click to open the context menu and run the Pivot Table Settings command. 
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4.9.3 Define the structure of the pivot table 

By default, a pivot table does not contain data because its structure is not defined 

(see Figure 278). To define the structure, use the Constructor tab in the pivot table settings pane 

(see Section 4.9.2). 

 

Figure 278. Pivot Table 

The Constructor tab includes the following sections: 

‒ Available Fields: This section includes the list of all selected columns of the initial table 

(the fields). To set the structure of the pivot table, add the fields from the Available 

Fields section to the Rows, Columns, Values, and Filters sections (see an example in 

the Figure 279). 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 302 

 

Figure 279. Pivot table example 

‒ Rows: Add the fields which will become the headings of the pivot table rows to this 

section (see Figure 280). 

 

Figure 280. Row names 

‒ Columns: Add the fields which will become the headings of the pivot table columns to 

this section (see Figure 281). 
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Figure 281. Column names 

‒ Values: Add the fields whose values will be used for calculations to this section 

(see Figure 282). 

 

Figure 282. Values 

‒ Filters: If necessary, add the fields that will be used to filter data in the pivot table to 

this section (see Figure 283). Filters allow you to set the level of detail of the data and 

change the way the table looks. 
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Figure 283. Filter 

4.9.3.1 Add fields 

Fields from the Available Fields section can be added to the Rows and Values sections 

manually or automatically. If fields are added automatically, they are allocated between the Rows 

and Values areas according to the data type: 

‒ If a field contains text values, it will be moved to the Rows section. 

‒ If a field contains numeric values, it will be moved to the Values section. 

To automatically distribute fields between the Rows and Values sections, follow these steps 

for each of these fields: 

1. In the Available Fields section, hover the cursor over the title of the field which needs 

to be moved to the Rows or Values sections (see Figure 284). 

2. Click  Add. 
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Figure 284. Add Button 

To add fields to the Rows and Values sections manually, drag and drop them into the 

appropriate sections while holding down the left mouse button, or do the following for each field: 

1. In the Available Fields section, hover the cursor over the field which needs to be moved 

to the Rows or Values sections (see Figure 285). 

2. Click  More. 

3. In the menu that appears, select the section in which you want to add the field. 

 

Figure 285. More button 
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Calculated fields created in a third-party application can only be moved to the Values 

section. 

Adding fields from the Available Fields section to other sections is done manually, similar 

to adding fields to the Rows and Values sections. 

4.9.3.2 Moving a field from one section to another 

Moving fields from one section to another is done manually, similar to adding fields from 

the Available Fields section to the other section in the Constructor (see Section 4.9.3.1). 

4.9.3.3 Change the field order in a section 

In any section other than the Available Fields section, you can change the order of the fields 

in the list. The position of the field in the list determines the position of the corresponding field in 

the pivot table. The arrangement of fields in the Columns and Rows areas also determines the 

parent-child hierarchy of fields in the table: a field lower in the list is a child of the parent field above 

it. The hierarchy determines how fields are grouped in the table. 

To change the position of a field relative to other fields in the list, drag it to the desired 

location in the list while holding down the left mouse button, or do the following: 

1. Hover the mouse cursor on the field and click  More (see Figure 286). 

 

Figure 286. More button 
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2. In the drop-down menu, select the desired command: 

‒ Move to Beginning: Move the field to the beginning of the list. 

‒ Move Up: Swap the selected field and the previous field. 

‒ Move Down: Swap the selected filed and the next field. 

‒ Move to End: Move the field to the end of the list. 

The drop-down menu commands depend on the position of the selected field in the list. 
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4.9.3.4 Rename a field 

You can rename any field in the pivot table if needed. 

 

You may not use formulas or functions as names or repeat existing field names in 

the pivot table. 

To rename a field, follow the steps below: 

1. Hover the mouse cursor on the field and click  More. 

2. From the drop-down menu, select Rename. 

3. In the Rename dialog box, specify the name of the field and click OK. 

The name of the field in the Constructor tab will change. When you hover the mouse cursor 

over a field, a tooltip with its current and original name will be displayed. 

4.9.3.5 Select value calculation functions 

For a field that is added to the Values area, you can select a function for the main calculation 

and a function for an additional calculation. 

The functions for the main calculation use data from the source table. Aggregating functions 

(summary functions in Excel) are used as such functions. Aggregating functions are used in statistics 

and data analytics to analyze and summarize information. Such functions include, for example, the 

sum, average, minimum and maximum values, and the number of elements for the selected data 

group. 

When adding a field to the Values area, the function for the main calculation is selected 

automatically as follows: 

‒ If a field contains numeric data, the Sum function is selected. 

‒ If a field contains text data, the Count function is selected. 

 

For calculated fields created in a third-party application, the Sum function is 

automatically selected. No other data calculation function is available. 

The additional calculation functions use data from the value area of the pivot table. These 

functions allow to reduce time and effort when analyzing data and building reports, without the need 

for the third-party spreadsheet editors or manual methods for applying additional calculations. 
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When adding a field to the Values area, the function for additional calculation is not used by 

default. It can be selected manually as described below. 

There are several ways to select the calculation function: 

‒ Using the settings pane of the pivot table. 

‒ Using the context menu of the pivot table cells. 

To select a function for the main calculation via the settings pane, follow these steps:  

1. Open the Constructor tab of the pivot table settings pane. 

2. In the Values area, in the Calculations field, expand the drop-down list of functions 

corresponding to this field (see Figure 287). 

3. Select the desired function from the drop-down list. 

 

Figure 287. Select the main calculation function on the Pivot Table pane 
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To select a function for the main calculation via the context menu, follow these steps: 

1. Select a cell or range of cells with calculated values in the pivot table. 

2. Open the context menu by right-clicking, point to the Calculations option and select 

desired function (see Figure 288). 

 

Figure 288. Selecting the main calculation function from the context menu 

To select a function for additional calculation via the settings pane, follow these steps: 

1. Open the Constructor tab of the pivot table settings pane. 

2. In the Values area, in the More field, expand the drop-down list of functions 

corresponding to this field (see Figure 289). 

3. Select the desired function from the drop-down list. 
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Figure 289. Select the additional calculation function on the Pivot Table pane 

To select a function for the additional calculation via the context menu, follow these steps: 

1. Select a cell or range of cells with calculated values in the pivot table. 

2. Open the context menu by right-clicking, point to the More calculations option and 

select desired function (see Figure 290). 
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Figure 290. Selecting the additional calculation function from the context menu 

If the function selected for additional calculation requires additional parameters, 

the More calculations window opens (see Figure 291), in which: 

‒ The Type field will indicate the function selected in the previous step. You can change 

it by selecting another function from the drop-down list. At the same time, if no 

additional parameters are required for the selected function, the Base field and Base 

value fields will become inactive. 

‒ The Base field field specifies a field (column) in the table that contains the initial values 

used for grouping and analyzing data and relative to which the calculation will be 

performed. Any field that is located in the Rows or Columns area on the Constructor 

tab of the pivot table settings pane can be selected as the base field. 

‒ In the Base value field, select the value that contains the Base field and relative to which 

the calculation will be performed.  When selecting Next value or Previous value, each 

value is compared with the one following it or preceding it, respectively. 
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Figure 291. More calculations window 

 

If the structure of the pivot table includes only fields in the Values area, then functions 

that require additional parameters are not available. 

Table 21. Functions for additional calculation 

Additional calculation Description 

% of Grand Total 
Calculates the value in the cell as a percentage of the total of 

all values in the pivot table. 

% of Column Total 
Calculates the value in the cell as a percentage of the total for 

the corresponding column. 

% of Row Total 
Calculates the value in the cell as a percentage of the total for 

the corresponding row. 

% of 
Calculates the value in the cell as a percentage of the selected 

base value in the corresponding base field. 

% of Parent Row Total 

Calculates the value in the child cell as a percentage of the 

value in the parent cell in the same column. 

This can be useful if more than one field is added to the row 

area of the pivot table to create a parent-child hierarchy. 

% of Parent Column Total 

Calculates the value in the child cell as a percentage of the 

value in the parent cell in the same row. 

This can be useful if more than one field has been added to the 

column area of the pivot table to create a parent-child 

hierarchy. 

% of Parent Total 
Calculates the value in the child cell as a percentage of the 

value in the parent cell in the corresponding base field. 
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Additional calculation Description 

Difference 
Calculates the difference between the value in the cell and the 

selected base value in the corresponding base field. 

Difference in % 
Calculates the percentage difference between the value in the 

cell and the selected base value in the corresponding base field 

To edit additional parameters of the function being used, open the More calculations 

window by clicking on the green text highlighted under the More calculations field drop-down list 

in the Values area of the pivot table constructor (see Figure 292). 

 

Figure 292. More calculations window opening 

To disable the function that is used for additional calculation, select the No calculations 

option when selecting a function, as described above.  

When working with pivot tables created in third-party editors, the following additional 

calculations are view only: 

‒ Index 

‒ Rank Largest to Smallest 

‒ Rank Smallest to Largest 

‒ Running Total in % 

‒ Running total 

When updating the pivot table, such additional calculations will be reset. 
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4.9.3.6 Delete a pivot table field 

To delete a field from any section of the pivot table, do one of the following: 

‒ Hover the mouse cursor over the title of this field and click  Remove (see Figure 293). 

 

Figure 293. Remove button 

‒ Hold down the left mouse button and drag the field from the current area to  

the Available Fields section. 

To delete a field from all areas of the pivot table to which it is added, do the following: 

1. In the Available Fields section, hover the cursor over the title of the field  

(see Figure 294). 

2. Click  Remove from Pivot Table. 

 

Figure 294. Remove from Pivot Table button 
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4.9.4 Customize the pivot table parameters 

To configure the pivot table parameters, use the Options tab in the Pivot Table Settings pane 

(see Figure 295). 

 

Figure 295. Options tab 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 317 

4.9.4.1 Edit data source 

If you want to edit the data source of the pivot table, follow these steps: 

1. Place the cursor in the Data Source box. The source table tab will open in the document 

and the value in the Data Source box will be available for editing (see Figure 296). 

The specified data range will be highlighted in the source table in color. 

 

Figure 296. Edit data source 

2. Edit the value in the Data Source field and click the  button or press Enter. 

4.9.4.2 Select the pivot table layout 

From the Pivot Table Layout drop-down list, you can select one of the following layouts: 

‒ Compact: Data for all fields in the Rows area is displayed in the first column of the 

pivot table in a hierarchical manner (see Figure 297). The greater the nesting level of a 

field in the Rows area, the greater the indentation of its data in the first column of the 

table. The Compact layout is used for pivot tables by default. 
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Figure 297. Compact layout 

‒ Tabular: Data of each field from the Rows area is displayed in a separate column. 

The column names correspond to the field names (see Figure 298). The column names 

correspond to the field names. 

 

Figure 298. Tabular layout 
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‒ Outline: Data of fields are arranged as in the Tabular layout, with each column 

displaying data one row lower than the previous one (see Figure 299). 

 

Figure 299. Outline layout 

4.9.4.3 Customize the display of grand totals 

By default, the last row of the pivot table displays column totals, and the last column displays 

row totals. 

To hide or redisplay column grand totals, use one of the following methods: 

‒ On the Options tab, in the Grand Totals section, uncheck or check the For columns 

box (see Figure 300). 
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Figure 300. Totals in table options 

‒ Right-click any cell in the pivot table to open the context menu and select Show Grand 

Totals (see Figure 301). In the sub-menu that opens, uncheck or check the For columns 

box. 

 

Figure 301. Enable/disable grand totals using the context menu 

To hide or redisplay row totals, use one of the following methods: 

‒ On the Options tab, in the Grand Totals section, uncheck or check the For rows box 

(see Figure 300). 

‒ Right-click any cell in the pivot table to open the context menu and select Show Grand 

Totals (see Figure 301). In the sub-menu that opens, uncheck or check the For rows 

box. 
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4.9.4.4 Customize the display of subtotals 

In the pivot table, you can: 

‒ Display/hide subtotals for each data group. 

‒ Change where subtotals are displayed if you selected Compact or Outline layout for the 

pivot table. In a table with the Tabular layout, subtotals are always displayed under the 

data group. 

To hide or display subtotals, in the Subtotals section, uncheck or check the Display box  

(see Figure 302). 

 

Figure 302. Subtotals section 

In the Location drop-down list (see Figure 302), select a location to display subtotals: 

‒ Under the group: A line of Header_group Total type is displayed under each data 

group (see Figure 303). 
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Figure 303. Subtotals under the group 

‒ In the group title: Subtotals are displayed in rows with data group titles 

(see Figure 304). 

 

Figure 304. Subtotals in the group title 
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4.9.4.5 Enable showing of cell details 

You can enable the display of cell details with values in the Cell Details section by selecting 

the Show on request checkbox (see Figure 305). 

 

Figure 305. Enable showing cell details on request 
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4.9.4.6 Edit captions 

In the Captions section, you can edit the names of some columns and rows of the pivot table, 

as well as specify the text that appears in empty cells or cells with errors. 

 

No formula or function may be used as a caption. 

The Captions section contains the following boxes: 

‒ Empty Cells: Text to display in empty cells of the pivot table. 

‒ Errors: Text to display in cells that contain errors in calculations. 

‒ Grand Total: The name of the row and column with the grand totals. 

‒ Values: This field is not used in the current version of the application. 

‒ Rows: The name of rows in the pivot table with a compact layout. 

‒ Columns: The name of columns in the pivot table with a compact layout. 

If there is no value in the field, enter a value manually and press Enter. 

If there is a value in the field, delete it manually or by clicking the  button. Then enter the 

desired value and press Enter. 

4.9.5 Collapse or expand the elements of pivot table 

You can change the level of detail in the pivot table by collapsing and expanding the content 

of grouped rows and columns. For example, in the table, you can collapse rows grouped by region 

of sale or by product group (see Figure 306). 

 

Figure 306. Example of grouping in the pivot table 
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In pivot tables created or edited in LibreOffice Calc, the row/column collapse/expand 

buttons and commands may be missing or may not work properly. 

To collapse or expand all grouped rows or columns in the pivot table, follow these steps: 

1. Open the context menu by right-clicking any cell in the pivot table and select Collapse 

or Expand. 

2. In the sub-menu that opens, select the desired command. 

To collapse or expand a single group of rows or columns in the pivot table, do one of the 

following: 

‒ To collapse a single row/column group, click the  button to the left of its header, to 

expand it, click the  button. 

‒ Open the context menu by right-clicking the cell with the row/column group header and 

select Collapse or Expand. 

4.9.6 View cell details 

If you want to understand what data was used to derive a value in a cell in the pivot table, 

you can view the cell details. You can view cells from the values area of the pivot table, including 

cells with totals and subtotals.  

You can view cell details in a pivot table in one of the following ways: 

‒ Double-click the cell with the value.  

‒ Right-click the cell with the value to open the context menu and select Show Details 

(see Figure 307). 
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Figure 307. Show Details command from the context menu 

As a result, a new sheet will be created. This sheet will generate a table with the data used to 

calculate the value in the cell of interest. Even though the data on the sheet can be edited, changing 

it will not affect the source data or the pivot table.  

The table on the new sheet inherits the style of the pivot table from which it was generated. 

You can change the style and areas of the table in the settings on the Sidebar. 

You cannot view cell details in the following cases: 

‒ For the pivot table, the details display setting in the Options tab of the Pivot Table 

Settings pane is disabled (see Section 4.9.4). 

‒ The pivot table data has not been refreshed since the document was opened (see Section 4.9.7). 

‒ The structure of the document is protected from changes (see Section 4.16). 

‒ The sheet with the pivot table is protected from changes, and the option Work with pivot 

tables is disabled in the Allowed actions list (see Section 4.16.1). 
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4.9.7 Refresh a pivot table 

A pivot table needs to be refreshed in the following cases: 

‒ When you work with the document, the data on which the pivot table was created has 

changed in the source table. 

‒ MyOffice Spreadsheet opens a document with a pivot table created in a third-party 

editor. 

‒ MyOffice Spreadsheet opens a document with a pivot table that contains irrelevant data. 

‒ You need to view the cell details (see Section 4.9.6). 

To refresh a pivot table, follow these steps: 

1. Select the entire range or one/several cells from the range of the pivot table. 

2. Refresh the table in one of the following ways: 

‒ In the Data menu, click Refresh Pivot Table (see Figure 308). 

 

Figure 308. Data menu 

‒ On the Toolbar, in the Pivot Table section, click  Refresh (see Figure 309). 

 

Figure 309. Update button 

‒ Right-click to open the context menu and run the Refresh Pivot Table command. 
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‒ If you created the pivot table in a third-party application, in the Pivot Table settings 

pane, on the Constructor tab, click the Update button, which is displayed below the 

message: ‟The source data has changed. Please update to load the latest data.”. 

‒ If the pivot table contains irrelevant data, in the Pivot Table settings pane, on the 

Constructor tab, click the Refresh button, which is displayed below the message: 

‟Data may be outdated. Please refresh the pivot table.” (see Figure 310). 

 

Figure 310. Update button 

 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 329 

4.9.8 Delete a pivot table 

To delete a pivot table, do the following: 

1. Select all the entire range or one or multiple cells from the pivot table range. 

2. Run the delete command in one of the following ways: 

‒ In the Command menu, select Data > Delete Pivot Table (see Figure 311). 

 

Figure 311. Data menu 

‒ On the Toolbar, in the Pivot Table section, click  Delete Pivot Table 

(see Figure 312). 

 

Figure 312. Delete Pivot Table button 

‒ Right-click the context menu and run the Delete Pivot Table command. 

‒ Press Delete. 
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4.10 Charts 

4.10.1 Insert a chart 

MyOffice Spreadsheet allows you to create and edit various charts. 

To create a chart, do the following: 

1. Select a range to be used to create a chart. 

2. Insert a chart in one of the following ways: 

‒ In the Insert menu, select Chart (see Figure 313). 

 

Figure 313. Insert menu 
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‒ On the Toolbar, select the Insert section and click  Chart (see Figure 314). 

 

Figure 314. Chart button 
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‒ On the Toolbar (see Figure 315), select the Insert section and click . 

In the displayed insert pane, click  Chart. 

 

Figure 315. Insert menu 

3. In the opened menu, select the desired chart type. 
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The new chart is placed in the middle of the visible area of a spreadsheet. 

The data used to create the chart are highlighted on the spreadsheet with the colors of 

the chart series (see Figure 316). 

 

Figure 316. Chart 
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4.10.2 Change chart type 

If you want to modify the type of the chart, select it first. On the Toolbar, select the Chart 

section and click the button which corresponds to the desired type of chart: 

‒  Column: Click this button to transform your chart into the Column chart or change 

the current type of the Column chart (see Figure 317). 

 

Figure 317. Column chart 

‒  Bar: Click this button to transform your chart into the Bar chart or change the current 

type of the Bar chart (see Figure 318). 

 

 

Figure 318. Bar chart 
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‒  Pie Chart: Click this button to transform your chart into the Pie Chart. 

‒  Area: Click this button to transform your chart into the Area chart or change 

the current type of the Area chart (see Figure 319). 

 

Figure 319. Area chart 
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To transform the current chart type to the Line chart or change the current Line chart type, 

click the  Line button and select the desired Line chart type from the drop-down list  

(see Figure 320).  

 

Figure 320. Line chart 
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4.10.3 Change data range 

You can change the data range used as the source data for your chart. The chart will be 

updated accordingly based on the new data range. 

To change a range, perform the following actions: 

1. Select the chart you want to edit. 

2. By holding down the left mouse button, move the corner marker of the data range that 

was used to build the chart. The range corner marker can be moved in any direction: 

right, left, up, down. 

3. Release the left mouse button to fix the new range. 

You can also modify values in the cells used as the source data for your chart. The chart will 

be updated accordingly based on the new data in the chart legend. 

4.10.4 Change chart size 

To resize a chart, left-click it and drag the sizing handle as needed (see Figure 321): 

‒ To change the height, use the top and bottom sizing handles. 

‒ To change the width, use the right and left sizing handles. 

‒ To change the height and width proportionally, use the corner sizing handles. 
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Figure 321. Resize a chart 

4.10.5 Move a chart 

The chart can be moved in the following ways: 

‒ Drag and drop by holding the left mouse button. 

‒ Move strictly vertically or horizontally with the ←, ↑, ↓, → keys on the keyboard. 

When you move the chart with ←, ↑, ↓, → keys, the chart movement step depends on 

the document scale: 

‒ If the scale is ≤ 200%, the step = 4 mm. 

‒ If the scale is > 200%, the step = 1 mm. 

To increase the step, move the chart using the ←, ↑, ↓ key while holding the Shift key 

pressed. In this case the movement step will be equal: 

‒ If the scale ≤ 200%, the step = 4 cm. 

‒ If the scale > 200%, the step = 1 cm. 
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4.10.6 Customize a chart 

To customize your chart, use the following guidelines: 

1. Select the chart you want to customize. 

2. Open the Chart Settings window in one of the following ways: 

‒ On the Toolbar, select the Chart section and click  Settings (see Figure 322). 

‒ Right-click the chart and select Chart Settings in the context menu. 

 

Figure 322. Settings button 

The opened Chart Settings displays the following menus (see Figure 323): 

 

Figure 323. Chart Settings window 
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‒ Range: Change the chart data range. 

‒ Title: Specify the chart title. 

‒ Data Series: Specify the way the initial data is plotted in a chart (by columns or rows). 

‒ Labels: Specify the position of chart labels (first column and/or first row). 
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4.10.7 Copy, cut or insert a chart 

You can copy or cut and paste a chart: 

‒ Within one MyOffice Spreadsheet document. 

‒ Into another MyOffice Spreadsheet document: the chart is inserted without the data 

it is based on. 

‒ Into MyOffice Text document or MyOffice Presentation: the chart is inserted as 

an image. 

You can cut, copy and paste using standard methods. 

4.10.8 Delete a chart 

To delete a chart, do the following: 

1. Select the chart. 

2. Run the delete command in one of the following ways: 

‒ On the Toolbar, in the Edit section, click  Delete (see Figure 324). 

 

Figure 324. Delete button 

‒ Right-click the chart and click Delete (see Figure 322). 

‒ Press Delete or Backspace. 
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4.11 Images 

You can insert the following images to a document: 

‒ From your computer. 

‒ From Google Chrome, Firefox, Internet Explorer, and Microsoft Edge browser. 

‒ From the text and spreadsheet editors that are a part of the Microsoft Office and 

LibreOffice suites. 

The supported image formats include .png, .bmp, .jpg, .jpeg, .jpe, .gif, .tiff, and .tif. 
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4.11.1 Insert an image 

4.11.1.1 Insert an image from your computer 

To insert an image from a computer, follow the steps below: 

1. Place your cursor where you want to insert the image. 

2. Insert an image in one of the following ways: 

‒ In the Insert menu, select Image (see Figure 325). 

 

Figure 325. Insert menu 

‒ On the Toolbar, select the Insert section (see Figure 326) and click  Image. 

 

Figure 326. Insert menu 
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‒ On the Toolbar, select the Insert section and click . In the displayed pane, click  Image 

(see Figure 327). 

 

Figure 327. Insert pane 

3. In the file manager window, select the image you want to insert and click Open. 
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4.11.1.2 Insert an image from the browser or another application 

To insert an image from the browser or another application, follow the steps below: 

1. Copy the image from the source. 

2. Place your cursor where you want to insert the image. 

3. Insert the image in one of the following ways: 

‒ In the Edit menu, select Paste (see Figure 328). 

 

Figure 328. Edit menu 

‒ On the Toolbar, select the Edit section and click  Paste. In the drop-down list, 

select Paste (see Figure 329). 

 

Figure 329. Paste button 

‒ Right-click and select Paste from the context menu. 

‒ Press Ctrl+V / ⌘Cmd+V. 
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4.11.2 Resize an image 

You can resize the image proportionally or according to your preferences. 

To resize an image proportionally, follow the steps below: 

1. Select the image you want to resize. 

2. Drag a corner handle while keeping the left mouse button pressed until the image is 

the size you want (see Figure 330). 

3. Release the left mouse button to fix the selected size. 

 

Figure 330. Resize an image proportionally 

To resize an image without keeping its proportions, follow the steps below: 

1. Select the image you want to resize. 

2. Drag a side handle while keeping the left mouse button pressed (see Figure 331): 

‒ To change the height of the image, move the top or bottom handle. 

‒ To change the width of the image, move the left or right handle. 

3. Release the left mouse button to fix the selected size. 

 

Figure 331. Resize an image without keeping its proportions 
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4.11.3 Move an image 

The image can be moved in the following ways: 

‒ Drag it by holding the left mouse button. 

‒ Move strictly vertically or horizontally with the ←, ↑, ↓, → keys. 

When you move the image with ←, ↑, ↓, → keys, the movement step depends on 

the document scale: 

‒ If the scale is ≤ 200%, the step = 4 mm. 

‒ If zoom is > 200%, the step = 1 mm. 

To increase a step, move the image with keys ←, ↑, ↓, →, holding Shift pressed. In this case 

the movement step will be equal to the following: 

‒ If scale is ≤ 200%, the step = 4 cm. 

‒ If scale > 200%, the step = 1 cm. 
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4.11.4 Save an image 

The image from the document can be saved on your computer. 

Follow these steps: 

1. Select an image. 

2. Run the save command in one of the following ways: 

‒ Select Format > Save Image (see Figure 332). 

 

Figure 332. Save Image Command menu option 

‒ Open the context menu by right-clicking and run the Save Image command. 

3. In the file manager window, select the folder to save the file to, specify the file name and 

click Save. 

 

The image is saved in the original size. 

 

If an image has been cropped in a document using a third-party application, it is saved 

in its original (pre-crop) form. 
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4.11.5 Delete an image 

To delete an image, do the following: 

1. Select the image that you want to delete. 

2. Delete the image in one of the following ways: 

‒ On the Toolbar, in the Edit section, click  Delete (see Figure 333). 

 

Figure 333. Delete Image button 

‒ Right-click the image and select Delete from the context menu. 

‒ Press Delete or Backspace. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 350 

4.12 Shapes 

You can add the following types of shapes to your documents: line, rectangle, ellipse, 

triangle, diamond, folded corner, star, heart, brackets, arrows, callouts, or text field. 

4.12.1 Insert a line 

To insert a line into a document, do the following: 

1. Open the Insert sub-menu using one of the following methods: 

‒ In the Insert menu, select Shape > Lines (see Figure 334). 

 

Figure 334. Insert menu 

‒ On the Toolbar, in the Insert section, click . In the insert pane that appears, hover 

the mouse cursor over the  Shape button (see Figure 335). 
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Figure 335. Insert pane 

2. In the sub-menu that opens, select the type of line to insert: line, arrow, double-sided 

arrow. The cursor will look like a crosshair . 

3. If needed, select the arrow type (see Section 4.12.10). 

4. Add a line in one of the following ways: 

‒ Click the left mouse button on the place where the line start point should be located. 

A line with a length of 4.24 cm and an angle of 45° will be added to the document. 

‒ Hold down the left mouse button and draw a line in the desired location of 

the document. To finish drawing, release the left mouse button. 

5. If needed, edit the length and the angle of the line (see Section 4.12.9). 
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4.12.2 Insert a shape 

To insert a shape, do the following: 

1. Select the position on the sheet where you want to insert a shape. 

2. Display the list of shapes in one of the following ways: 

‒ In the Insert menu, select Shape (see Figure 334). 

‒ On the Toolbar, select the Insert section and click . In the displayed pane, 

click  Shape (see Figure 335). 

3. In the opened sub-menu, select the desired shape. 

You can add text or a link to a shape. 

Follow these steps: 

1. Double-click the shape to enter the editing mode. 

2. Add text or a link to the shape (see Figure 336): 

‒ Enter the text manually. The text can be formatted in the same manner as you would 

format the main text in the document. 

 

Figure 336. Entering text 

‒ Add a link to the shape as described in Section 4.4.5.1. 

3. Click anywhere outside the shape to leave the editing mode. 

 

Editing mode is not currently supported for shapes turned at a custom angle in third-

party spreadsheet editors. 
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4.12.3 Insert a text box 

A text box is framed text that can be moved and placed anywhere on the current sheet. 

To insert a text box, do the following: 

1. Select the place on the sheet where you want to insert a text box. 

2. Select the insert command in one of the following ways: 

‒ In the Insert menu, select Text Box (see Figure 337). 

 

Figure 337. Insert command menu 

‒ On the Toolbar, select the Insert section and click  (see Figure 338). 

In the displayed pane, click  Text Box. 

 

Figure 338. Text Box button 

3. Enter the desired text in the text box. If necessary, you can add a link to the text 

(see Section 4.4.3.1). Formatting the text in the text field is similar to formatting 

the main text of the document. 

4. To deselect a text box, click anywhere on the sheet outside the text box.  
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4.12.4 Fill a shape 

You can fill the inner area of a shape, except lines, with colors or images. 

4.12.4.1 Fill a shape with color 

To fill a shape with color, follow these steps: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. To fill the shape with the last color used to fill it earlier, on the Toolbar, in the Shape 

section, click the  Fill Color button (see Figure 339). 

 

Figure 339. Fill Color button and color selection pane 

3. To fill the shape with a different color, click the arrow to the right of the  Fill Color 

button. 

4. In the color selection pane that opens, specify the fill color of the shape in one of the 

following ways: 

‒ Choose a color from one of the color sets provided. 

‒ Specify the color code manually. 

‒ Copy the color with an eyedropper. 
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4.12.4.1.1 Choose a color from the color sets provided 

The following colors sets are available in the color selection pane (see Figure 339): 

‒ Theme Colors: This block contains the color palette of the current document's theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The Recent Colors set is displayed if you have selected 

at least one color. 

 

Hovering the mouse cursor over any color displays the value of that color in the RGB color 

model. For example, RGB 192,80,77. 

Left-click a color to select it. 

The color will be added to the Recent Colors set and checked. The color selection pane will 

close. The shape will be filled with the selected color. 

4.12.4.1.2 Specify the color code manually 

If you do not find the appropriate color in the listed color sets, specify the color code 

manually: 

1. Click More Colors (see Figure 339). 

2. In the Select Color window (see Figure 340) that appears, specify the desired color as a 

HEX code or in RGB format. 

3. Click OK. 

 

Figure 340. Select Color window 
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The manually specified color will be added to the Recent Colors set (see Figure 339) and 

checked. The color selection pane will close. The shape will be filled with the selected color. 

4.12.4.1.3 Copy the color with an eyedropper 

You can use the eyedropper to simultaneously copy a color from a text or object located in 

the main window's workspace (see Section 3.6) and filling the shape with this color. 

To copy a color using the eyedropper, follow these steps: 

1. Click  Eyedropper (see Figure 339). The color selection pane will close, and 

the cursor will look like a crosshair for color selection. 

2. Hover the cursor over the color you want to fill the shape with. For more accurate color 

selection, refer to the area to the right of the cursor. It displays the color of the pixel that 

the cursor is currently hovering over. 

3. Left-click the color. 

The shape will be filled with the specified color, and the cursor returns to its standard 

appearance. The specified color is added to the Recent Colors set (see Figure 339) and checked in 

the color selection pane. 

If you want to disable the eyedropper without selecting a color, press Esc. 
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4.12.4.2 Filling a shape with image 

To fill a shape with an image, follow these steps: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, select the Shape section and click the arrow to the right of 

the  Fill Color button (see Figure 341). 

3. In the color selection pane, in the Image block, click Choose. 

 

Figure 341. Choose button 

4. In the File manager window, select the desired image and click Open. 
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4.12.4.3 Remove the fill color 

To remove the shape fill, follow the steps below: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, select the Shape section and click the arrow to the right of 

the  Fill Color button (see Figure 342). 

3. In the color selection pane, click No Fill. 

 

Figure 342. No Fill button 
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4.12.5 Shape outline 

You can define the color, thickness, and outline type for the shape. 

4.12.5.1 Set shape outline 

To select the color of the shape outline, follow the steps below: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, select the Shape section and click the arrow to the right of the 

 Outline button (see Figure 343). 

3. In the color selection pane that opens, specify the color of the shape outline in one of the 

following ways: 

‒ Choose a color from one of the color sets provided. 

‒ Specify the color code manually. 

‒ Copy the color with an eyedropper. 

 

Figure 343. Outline button and color selection pane 
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4.12.5.1.1 Choose a color from the color sets provided 

The following colors sets are available in the color selection pane (see Figure 343): 

‒ Theme Colors: This block contains the color palette of the current document's theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The Recent Colors set is displayed if you have selected 

at least one color. 

 

Hovering the mouse cursor over any color displays the value of that color in the RGB color 

model. For example, RGB 192,80,77. 

Left-click a color to select it. 

The color will be added to the Recent Colors set and checked. The color selection pane will 

close. The shape outline will be colored in the selected color. 

4.12.5.1.2 Specify the color code manually 

If you do not find the appropriate color in the listed color sets, specify the color code 

manually: 

1. Click More Colors (see Figure 343). 

2. In the Select Color window (see Figure 344) that appears, specify the desired color as a 

HEX code or in RGB format. 

3. Click OK. 

 

Figure 344. Select Color window 
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The manually specified color will be added to the Recent Colors set (see Figure 343) and 

checked. The color selection pane will close. The shape outline will be colored in the selected color. 

4.12.5.1.3 Copy the color with an eyedropper 

You can use the eyedropper to simultaneously copy a color from a text or object located in 

the main window's workspace (see Section 3.6) and apply that color to the shape outline. 

To copy a color using the eyedropper, follow these steps: 

1. Click  Eyedropper (see Figure 343). The color selection pane will close, and the 

cursor will look like a crosshair for color selection. 

2. Hover the cursor over the color you want to color the shape outline. For more accurate 

color selection, refer to the area to the right of the cursor. It displays the color of the pixel 

that the cursor is currently hovering over. 

3. Left-click the color. 

The shape outline is colored in the selected color, and the cursor returns to its standard 

appearance. The specified color is added to the Recent Colors (see Figure 343) set and checked in 

the color selection pane. 

If you want to disable the eyedropper without selecting a color, press Esc. 

4.12.5.2 Select the thickness and line type of the shape outline 

To specify the thickness and type of a line for a shape outline, follow the steps below: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, select the Shape section and click the arrow to the right of the 

 Outline button (see Figure 343). 

3. In the Line Weight field, select the desired outline thickness manually or using the 

buttons. 

4. Select the outline line type from the preset values. 
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4.12.5.3 Apply outline settings of the previous shape 

To quickly apply the previous shape's outline settings to a shape, follow these steps: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, in the Shape section, click  Outline (see Figure 345). 

 

Figure 345. Outline button 

4.12.5.4 Delete shape outline 

To delete the outline of a shape, follow the steps below: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, select the Shape section and click the arrow to the right of the 

 Outline button (see Figure 346). 

3. In the color selection pane, click No Outline. 

 

Figure 346. No Outline button 
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4.12.6 Line style 

You can define the color, thickness, and outline type for the line. 

4.12.6.1 Select a line color 

To select a line color, follow these steps: 

1. Select the line. 

2. On the Toolbar, select the Line section and click the arrow to the right of 

the  Line Style button (see Figure 347). 

3. In the color selection pane that opens, specify the line color in one of the following ways: 

‒ Choose a color from one of the color sets provided. 

‒ Specify the color code manually. 

‒ Copy the color with an eyedropper. 

 

Figure 347. Line Style button and color selection pane 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 364 

4.12.6.1.1 Choose a color from the color sets provided 

The following colors sets are available in the color selection pane (see Figure 347): 

‒ Theme Colors: This block contains the color palette of the current document's theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The Recent Colors set is displayed if you have selected 

at least one color. 

 

Hovering the mouse cursor over any color displays the value of that color in the RGB color 

model. For example, RGB 192,80,77. 

Left-click a color to select it. 

The color will be added to the Recent Colors set and checked. The color selection pane will 

close. The line will be colored in the selected color. 

4.12.6.1.2 Specify the color code manually 

If you do not find the appropriate color in the listed color sets, specify the color code manually: 

1. Click More Colors (see Figure 347). 

2. In the Select Color window (see Figure 348) that appears, specify the desired color as a 

HEX code or in RGB format. 

3. Click OK. 

 

Figure 348. Select Color window 
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The manually specified color will be added to the Recent Colors set (see Figure 347) and 

checked. The color selection pane will close. The line will be colored in the selected color. 

4.12.6.1.3 Copy the color with an eyedropper 

You can use the eyedropper to simultaneously copy a color from a text or object located in 

the main window's workspace (see Section 3.6) and apply that color to the line outline. 

To copy a color using the eyedropper, follow these steps: 

1. Click  Eyedropper (see Figure 347). The color selection pane will close, and the 

cursor will look like a crosshair for color selection. 

2. Hover the cursor over the color you want to color the line. For more accurate color 

selection, refer to the area to the right of the cursor. It displays the color of the pixel that 

the cursor is currently hovering over. 

3. Left-click the color. 

The line is colored in the selected color, and the cursor returns to its standard appearance. 

The specified color is added to the Recent Colors set (see Figure 347) and checked in the color 

selection pane. 

If you want to disable the eyedropper without selecting a color, press Esc. 

4.12.6.2 Select the thickness and line type 

To specify the line thickness and type, follow these steps: 

1. Select the line. 

2. On the Toolbar, select the Line section and click the arrow to the right of 

the  Line Style button (see Figure 347). 

3. In the Line Weight section, select the desired line thickness manually or using 

the buttons. 

4. Select the line type from the preset values. 
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4.12.6.3 Apply the style of the previous line 

To quickly apply a previous line style to a line, follow these steps: 

1. Select the line. 

2. On the Toolbar, in the Line section, click  Line Style (see Figure 349). 

 

Figure 349. Line Style button 

4.12.6.4 Delete the line style 

If necessary, you can delete the line style settings. To do this, follow these steps: 

1. Select the line. 

2. On the Toolbar, select the Line section and click the arrow to the right of  

the  Line Style button (see Figure 347). 

3. In the color selection pane, click No Outline. 
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4.12.7 Resize a shape 

You can resize the height and the width of a shape proportionally or according to your 

preferences. 

To resize a shape proportionally, follow the steps below: 

1. Select the shape you want to resize. 

2. Drag a corner handle while keeping the left mouse button pressed until the shape is 

the size you want (see Figure 350). 

3. Release the left mouse button to fix the selected size. 

 

Figure 350. Resize a shape proportionally 
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To resize a shape without keeping its proportions, follow the steps below: 

1. Select the shape you want to resize. 

2. Drag a side handle while keeping the left mouse button (see Figure 351): 

‒ To change the height of the shape, move the top or bottom handle. 

‒ To change the width of the shape, move the left or right handle. 

3. Release the left mouse button to fix the selected size. 

 

Figure 351. Resize a shape without keeping its proportions 
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4.12.8 Fit shape size to text 

You can fit the shape height to match the text inside this shape. 

To do this: 

1. Select the shape. 

2. On the Toolbar, select the Shape section (see Figure 352) and click  Autofit. 

The button will change to . 

 

Figure 352. Autofit button 

To cancel the autofit, perform the same procedure once again. 
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4.12.9 Change line length and angle 

To change the length or angle of a line, follow these steps: 

1. Select the line. 

2. Move the cursor over a line start or end marker so that the cursor appears as follows . 

3. Hold down the left mouse button and drag the marker to the desired location. 

4. Release the left mouse button. 

If necessary, you can stop moving the marker by pressing Esc. The marker will return to its 

original position. 

 

4.12.10 Select arrow type 

You can select the tip type for the beginning and end of the line. The selection can be made either 

before drawing the line (see Section 4.12.1) or when editing the drawn line. 

To select the arrow type, do the following: 

1. On the Toolbar, in the Line section, click  Arrow Type (see Figure 353). 

 

Figure 353. Arrow Type button 

2. Select the left and/or right tip type from the drop-down list. If you want to remove 

previously selected tips, select the left and/or right tip type  None in the first line of 

the drop-down list. 

3. Click the  Arrow Type button once again to close the drop-down list. 
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4.12.11 Move a shape 

The shape can be moved in the following ways: 

‒ Drag the shape by holding the left mouse button. 

‒ Move the shape strictly vertically or horizontally with the ←, ↑, ↓, → keys on 

the keyboard. 

When you move a shape with ←, ↑, ↓, → keys, the movement step depends on the document 

scale: 

‒ If the scale is ≤ 200%, the step = 4 mm. 

‒ If the scale is > 200%, the step = 1 mm. 

To increase a step, move the figure with keys ←, ↑, ↓, →, holding the Shift key pressed. 

In this case the movement step will be as follows: 

‒ If the scale is ≤ 200%, the step = 4 cm. 

‒ If the scale is > 200%, the step = 1 cm.  
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4.12.12 Delete a shape 

To delete a shape, follow these steps: 

1. Select the shape you want to delete. 

2. Delete the shape using one of the following methods: 

‒ On the Toolbar, select the Edit section and click  Delete (see Figure 354). 

 

Figure 354. Delete button 

‒ Right-click the shape and select Delete from the context menu. 

‒ Press Delete or Backspace. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 373 

4.13 Format spreadsheets 

When files are created, the standard formatting is applied to their elements. To change 

the default formatting, select the respective commands and run them. If you want to modify 

the existing file, you need to select the fragment you want to apply the new formatting to first. 

4.13.1 Font 

By default, when creating a document in MyOffice Spreadsheet, the XO Thames font is used. 

To quickly change the font, follow these steps: 

1. Specify the text for which you want to change the font: 

‒ To change the font for all the text located in a cell, select this cell. 

‒ To change the font for a text fragment located in a cell, switch to the cell editing 

mode and select this fragment. 

‒ To change the font in one word, switch to the cell editing mode and place the cursor 

on this word or select it entirely. 

2. On the Toolbar, in the Font section (see Figure 355), click on the field with the name of 

the current font. 

3. Start typing the name of the desired font. The drop-down list will display a list of fonts 

that match the search criteria. 

4. Select the desired font using the mouse or keyboard keys: 

‒ Left-click the font name. 

‒ Select the font name using the keyboard keys ↓ and ↑ and press Enter. 

 

Figure 355. Font search 

To select a font from the full list of fonts, follow these steps: 

1. Specify the text for which you want to change the font as described above. 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 374 

2. On the Toolbar, in the Font section, click the arrow  to the right of the name of 

the current font (see Figure 356). 

3. In the drop-down list, select the desired font using the mouse or keyboard keys: 

‒ Left-click the font name. 

‒ Select the font name using the keyboard keys ↓ and ↑ and press Enter. 

 

Figure 356. Full list of fonts 

 

It is recommended to use the fonts of the XO family in order to preserve the formatting of 

the document when it is opened in other operating systems. 
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4.13.2 Font size 

To change the font size, do as follows: 

1. On the Toolbar, select the Font section and click the arrow  to the right of the current 

font name (see Figure 357). 

2. In the opened list, select the desired font size. 

 

Figure 357. Selecting the font size 

You can also type in any size you want. Simply follow these steps: 

1. On the Toolbar, select the Font section and select the current font size. 

2. Enter the desired size. Use a dot (.) as the delimiter for fractional value. 

For example, 21.5 

3. Press Enter. 
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To increase the font size by one point, follow the steps below: 

‒ In the Format menu, select Font and then select Increase Font Size (see Figure 358). 

 

Figure 358. Increase and Decrease Font Size options 

‒ On the Toolbar, select the Font section (see Figure 359) and click 

 Increase Font Size. 

 

Figure 359. Buttons to increase and decrease the font size 

To decrease the font size by one point, follow the steps below: 

‒ In the Format menu, select Font and then select Decrease Font Size (see Figure 358). 

‒ On the Toolbar, select the Font section and click  Decrease Font Size  

(see Figure 359). 
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4.13.3 Text formatting 

Text formatting within a cell in MyOffice Spreadsheet allows you to distinguish different 

parts of your text and make the data on your spreadsheets more visible. 

The table below shows the text formatting options with the corresponding commands and 

toolbar buttons. 

Table 22. Text formatting 

Text formatting Command menu Toolbar button, 

Font section 

Keyboard 

shortcut 

(Windows/Linux) 

Keyboard 

shortcut 

(macOS) 

Bold Format > Font > 

Bold 
 

Ctrl+B ⌘Ctrl+B 

Italic Format > Font > 

Italic 
 Ctrl+I ⌘Ctrl+I 

Underline Format > Font > 

Underline  
Ctrl+U ⌘Ctrl+U 

ALL CAPS Format > Font > 

All Caps 
 Ctrl+Shift+A ⇧Shift+⌘Cmd+A 

 

Strikethrough 
Format > Font > 

Strikethrough  – – 

Subscript sign Format > Font > 

Subscript 
 

> 
 

   
 

Ctrl+= ⌘Cmd+= 

 

Superscript sign Format > Font > 

Superscript 
 

> 
 

 

Ctrl+Shift+= ⇧Shift+⌘Cmd+= 
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4.13.4 Font color 

To change the font color of text, follow these steps: 

1. Specify the text for which you want to change the font color: 

‒ To change the font color for all the text located in a cell, select that cell or select all 

text in that cell. 

‒ To change the font color for a text fragment located in a cell, switch to the cell editing 

mode and select this fragment. 

‒ To change the font color in one word, switch to the cell editing mode and place the 

cursor on this word or select it entirely. 

2. To select the last color that was applied to the font, on the Toolbar, select the Font section and 

click  Text Color (see Figure 360). 

3. To select a different font color, click the arrow to the right of the  Text Color button. 

 

Figure 360. Text Color button and color selection pane 
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4. In the color selection pane that opens, specify the font color in one of the following ways: 

‒ Choose a color from one of the color sets provided. 

‒ Specify the color code manually. 

‒ Copy the color with an eyedropper. 

4.13.4.1 Choose a color from the color sets provided 

The following colors sets are available in the color selection pane (see Figure 360): 

‒ Theme Colors: This block contains the color palette of the current document's theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The Recent Colors set is displayed if you have selected 

at least one color. 

Hovering the mouse cursor over any color displays the value of that color in the RGB color 

model. For example, RGB 192,80,77. 

Left-click a color to select it. 

The color will be added to the Recent Colors set and checked. The color selection pane will 

close. The font of the text will be colored in the selected color. 

4.13.4.2 Specify the color code manually 

If you do not find the appropriate color in the listed color sets, specify the color code 

manually: 

1. Click More Colors (see Figure 360). 

2. In the Select Color window (see Figure 361) that appears, specify the desired color as a 

HEX code or in RGB format. 

3. Click OK. 

The manually specified color will be added to the Recent Colors set (see Figure 360) and 

checked. The color selection pane will close. The font of the text will be colored in the selected 

color. 
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Figure 361. Select Color window 

4.13.4.3 Copy the color with an eyedropper 

You can use the eyedropper to simultaneously copy a color from a text or object located in 

the main window's workspace (see Section 3.6) and apply that color to the font of the selected text. 

 

The eyedropper is disabled when working with notes (see Section 4.4.6). 

To copy a color using the eyedropper, follow these steps: 

1. Click  Eyedropper (see Figure 360). The color selection pane will close, and the 

cursor will look like a crosshair for color selection. 

2. Hover the cursor over the color you want to apply to the selected text. For more accurate 

color selection, refer to the area to the right of the cursor. It displays the color of the pixel 

that the cursor is currently hovering over. 

3. Left-click the color. 

The font of the selected text is colored in the specified color, and the cursor returns to its 

standard appearance. The specified color is added to the Recent Colors set (see Figure 360) and 

checked in the color selection pane. 

If you want to disable the eyedropper without selecting a color, press Esc. 
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4.13.5 Highlight color 

When you are working on a document, you can highlight certain portions of text in different 

colors (as if they were highlighted with a marker) to make them more prominent against the rest of 

the document. 

To highlight text in color, do the following 

1. Specify the desired text: 

‒ To color the entire text in a cell, select the cell. 

‒ To color a piece of text located in a cell, switch to the cell editing mode and select 

that piece of text. 

‒ To color a single word, switch to cell editing mode and place the cursor on that word 

or select the entire word. 

2. To select the last color you used to highlight text earlier, on the Toolbar, in the Font 

section, click  Highlight Color (see Figure 362). 

3. To select a different color for text highlighting, on the Toolbar, in the Font section, click 

the arrow to the right of  Highlight Color. 

 

Figure 362. Highlight color selection 

4. Select the desired color in the provided palette or in the Recent Colors section. This 

block is displayed if at least one color from the palette was previously used to highlight 

text. The block can display a total of one to eight of the most recently used colors. 
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The selected color will be checked, and the text will be highlighted in this color. 

To remove the highlighting of the text, perform the following actions: 

1. Select the text that you want to remove highlighting from. 

2. On the Toolbar, select the Font section and click the arrow to the right of 

the  Highlight Color button (see Figure 362). 

3. In the window that opens, select No Color. 
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4.13.6 Alignment 

Data in cells can be aligned horizontally and vertically. 

To align data horizontally, use one of the commands described in the table below. 

Table 23. Horizontal alignment 

Position in cell Command menu Toolbar button, 

Alignment 

section 

Keyboard 

shortcut 

(Windows/Linux) 

Keyboard 

shortcut 

(macOS) 

Align left Format > Alignment > 

Left 
 Ctrl+L ⌘Ctrl+L 

Center Format > Alignment > 

Center 
 Ctrl+E ⌘Ctrl+E 

Align right Format > Alignment > 

Right 
 Ctrl+R ⌘Ctrl+R 

Justify Format > Alignment > 

Justify 
 Ctrl+J ⌘Ctrl+J 

To align data vertically, use one of the commands described in the table below: 

Table 24. Vertical alignment 

Position in cell Command menu Toolbar button in 

the Alignment 

section 

Align to Top Format > Alignment > Top  

Align to Middle Format > Alignment > Middle  

Align to Bottom Format > Alignment > Bottom  
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4.13.7 Rotate text 

Text in cells can be rotated by any angle ranging from –90 to 90 degrees. 

You can specify the rotation angle using the Command menu or the Toolbar. 

 

To specify the rotation angle using the Command menu, do as follows: 

1. Select the row/column or the cell/cell range you want to rotate the text in. 

2. In the Command menu, select Format and then Text rotation (see Figure 363). 

 

Figure 363. Format menu 
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3. In the opened sub-menu, do the following: 

‒ To rotate the text, select the desired rotation angle from the list of preset values. 

‒ To position the text vertically, run the Vertical Text command. 

 

To rotate text or change the orientation of text using the Toolbar, follow these steps: 

1. Select the row/column, cell range, or cell in which the desired text is located. 

2. On the Toolbar, in the Alignment section, click  Rotate Text (see Figure 364). 

 

Figure 364. Rotate Text button 

3. In the opened sub-menu, do the following: 

‒ To rotate the text by 45° or 90° to the left or right, run the corresponding command. 

‒ To specify a different angle of rotation, enter the desired value manually in 

the Custom Angle field or click the  button and select a value from the drop-down 

list. 

‒ To position the text vertically, select Vertical Text. 

 

The rotation or orientation applies to all text in a cell. You cannot have multiple pieces 

of text with different rotation angles or orientations in the same cell. 
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To return to the default text display (horizontal position, 0° angle), follow these steps: 

1. Select the row/column, cell range, or cell in which the desired text is located. 

2. Run the command in one of the following ways: 

‒ In the Format menu, select Rotate Text > None (0°) (see Figure 363). 

‒ On the Toolbar, in the Alignment section, click  Rotate Text. In the opened 

sub-menu, select None (0°) (see Figure 364). 
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4.13.8 Wrap text 

In MyOffice Spreadsheet, you can wrap text within cells to make it easier to view and edit. 

By default, the text in a cell is on one line. If the cell contains a large piece of text, specify 

that the text in that cell should be word-for-word. The application will place the text on multiple 

lines, taking into account the width of the column in which the cell is located. If you change 

the width of the column, the text in the cell will be moved again. 

To wrap text, do the following: 

1. Select the row/column, cell range, or cell in which you want to wrap text. 

2. Run the Wrap Text command in one of the following ways: 

‒ In the Table menu, select Wrap Text (see Figure 365). 

 

Figure 365. Wrap Text command menu option 
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‒ On the Toolbar, select the Alignment section and click  Wrap Text  

(see Figure 366). 

 

Figure 366. Alignment section 

To unwrap the text, run one of above commands again. 
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4.13.9 Character spacing 

The character spacing is a distance between the characters in the text. You can choose 

between Condensed, Normal and Expanded character spacing. 

The examples of various character spacings are shown in Figure 367. 

 

Figure 367. Character spacing examples 

The type of character spacing can be selected using the Command menu or the Toolbar. 

 

To change the character spacing using the Command menu, follow these steps: 

1. Select the text or cell in which you want to change the character spacing: 

‒ If you want to change the character spacing for a single word, select or place 

the cursor in the word. 

‒ If you want to change the character spacing for part of the text in a cell, select 

the text. 

‒ If you want to change the character spacing for text located in one or more cells, 

select those cells. 

‒ If the character spacing needs to be changed for text located in one or more 

rows/columns, select the rows/columns.  

2. In the Format menu, select Font > Character Spacing (see Figure 368). 

3. In the opened sub-menu, select the desired character spacing type. 
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Figure 368. Format menu 

To change the character spacing using the Toolbar, do the following: 

1. Select the text or cells where you want to change the character spacing as described 

above. 

2. In the Toolbar, select the Font section and click the  button (see Figure 369). 

3. Select the desired character spacing type: 

 : Condensed 

 : Normal 

 : Expanded 

 

Figure 369. Select the character spacing 
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4.13.10 Cell fill color 

4.13.10.1 Add the fill color to table cells 

To fill cells with color, follow these steps: 

1. Select the cell or range of cells whose fill color you want to change. 

2. To color cells with the last color used for the cells fill earlier, on the Toolbar, in the Font 

section, click  Fill Color (see Figure 370). 

3. To fill the cells with a different color, click the arrow to the right of the  Fill Color 

button. 

4. In the color selection pane that opens, specify the cells fill color in one of the following 

ways: 

‒ Choose a color from one of the color sets provided. 

‒ Specify the color code manually. 

‒ Copy the color with an eyedropper. 

 

Figure 370. Fill Color button and color selection pane 
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4.13.10.1.1 Choose a color from the color sets provided 

The following colors sets are available in the color selection pane (see Figure 370): 

‒ Theme Colors: This block contains the color palette of the current document's theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The Recent Colors set is displayed if you have selected 

at least one color. 

Hovering the mouse cursor over any color displays the value of that color in the RGB color 

model. For example, RGB 192,80,77. 

Left-click a color to select it. 

The color will be added to the Recent Colors set and checked. The color selection pane will 

close. The cells will be colored in the selected color. 

4.13.10.1.2 Specify the color code manually 

If you do not find the appropriate color in the listed color sets, specify the color code manually: 

1. Click More Colors (see Figure 370). 

2. In the Select Color window (see Figure 371) that appears, specify the desired color as 

a HEX code or in RGB format. 

3. Click OK. 

 

Figure 371. Select Color window 
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The manually specified color will be added to the Recent Colors set (see Figure 370) and 

checked. The color selection pane will close. The cells will be colored in the selected color. 

4.13.10.1.3 Copy the color with an eyedropper 

You can use the eyedropper to simultaneously copy a color from a text or object located in 

the main window's workspace (see Section 3.6) and filling the cells with this color. 

To copy a color using the eyedropper, follow these steps: 

1. Click  Eyedropper (see Figure 370). The color selection pane will close, and the 

cursor will look like a crosshair for color selection. 

2. Hover the cursor over the color in which you want to color the cells. For more accurate 

color selection, refer to the area to the right of the cursor. It displays the color of the pixel 

that the cursor is currently hovering over. 

3. Left-click the color. 

The cells are colored in the selected color, and the cursor returns to its standard appearance. 

The specified color is added to the Recent Colors set (see Figure 370) and checked in the color 

selection pane. 

If you want to disable the eyedropper without selecting a color, press Esc. 

4.13.10.2 Remove the fill color 

To remove the cell fill, follow the steps below: 

1. Select the cell or cell range you want to cancel the fill. 

2. On the Toolbar, in the Font section, click the arrow to the right of the  Fill Color 

button (see Figure 370). 

3. In the window that appears, click No Fill. 
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4.13.11 Cell borders 

4.13.11.1 Change border parameters 

By default, when you create a document, there are no borders between cells. The grid visible 

on the sheet conventionally separates cells one from another to make working with data easier and 

is not displayed when printing. 

To add borders to cells or change settings previously applied to borders, follow these steps: 

1. Select the desired cell or range of cells. 

2. On the Toolbar, select the Font section and click the arrow to the right of  

the   Cell Borders button (see Figure 372). 

 

Figure 372. Border settings pane 
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3. In the border settings pane that opens, in the first settings block, specify the position of 

the borders for which you want to change the parameters. 

4. In the second block of settings, select the type of line to be applied to the specified 

borders. 

5. In the third block of settings, specify the line color using one of the following methods: 

‒ Choose a color from one of the color sets provided. 

‒ Specify the color code manually. 

‒ Copy the color with an eyedropper. 

4.13.11.1.1 Choose a color from the color sets provided 

The following colors sets are available in the border settings pane (see Figure 372): 

‒ Theme Colors: This block contains the color palette of the current document's theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The Recent Colors set is displayed if you have selected 

at least one color. 

Hovering the mouse cursor over any color displays the value of that color in the RGB color 

model. For example, RGB 192,80,77. 

Left-click a color to select it. 

The color will be added to the Recent Colors set and checked. The cell borders will be 

colored in the selected color. 

To close the border parameters pane, do one of the following: 

‒ On the Toolbar, select the Font section and click the arrow to the right of 

the   Cell Borders button (see Figure 372). 

‒ Click a blank area of the document outside the border settings pane. 
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4.13.11.1.2 Specify the color code manually 

If you do not find the appropriate color in the listed color sets, specify the color code 

manually: 

1. Click More Colors (see Figure 372). 

2. In the Select Color window (see Figure 373) that appears, specify the desired color as 

a HEX code or in RGB format. 

3. Click OK. 

 

Figure 373. Select Color window 

The manually specified color will be added to the Recent Colors set (see Figure 372) and 

checked. The border settings pane will close. The cell borders will be colored in the selected color. 

4.13.11.1.3 Copy the color with an eyedropper 

You can use the eyedropper to simultaneously copy a color from a text or object located in 

the main window's workspace (see Section 3.6) and apply that color to the cell borders. 

To copy a color using the eyedropper, follow these steps: 

1. Click  Eyedropper (see Figure 372). The border settings pane will close, and the 

cursor will look like a crosshair for color selection. 

2. Hover the cursor over the color in which you want to color the cell borders. For more 

accurate color selection, refer to the area to the right of the cursor. It displays the color 

of the pixel that the cursor is currently hovering over. 

3. Left-click the color. 
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The cell borders are colored in the selected color, and the cursor returns to its standard 

appearance. The specified color is added to the Recent Colors set (see Figure 372) and checked in 

the border settings pane. 

If you want to disable the eyedropper without selecting a color, press Esc. 

4.13.11.2 Apply the last selected border style 

To quickly apply the last selected border style to a cell or range of cells, follow these steps: 

1. Select the desired cell or range of cells. 

2. On the Toolbar, in the Font section, click  Cell Borders (see Figure 374). 

 

Figure 374. Button to apply previous table border style 

4.13.11.3 Delete borders 

To delete specified cell or cell range borders, follow the steps below: 

1. Select the desired cell or range of cells. 

2. On the Toolbar, select the Font section and click the arrow to the right of 

the   Cell Borders button (see Figure 375). 

3. In the border settings pane that opens: 

‒ In the first block of settings, specify where you want the borders to be deleted. 

‒ In the second block of settings, select No Borders. 

4. To close the border parameters pane, do one of the following: 

‒ On the Toolbar, select the Font section and click the arrow to the right of 

the   Cell Borders button. 

‒ Click a blank area of the sheet outside the border settings pane. 
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Figure 375. Remove borders 

4.13.12 Copy and insert formatting 

In MyOffice Spreadsheet, you can copy the formatting from one part of a document to 

another. The formatting copied can be applied: 

‒ Once (to one text fragment) 

‒ Multiple time (to multiple text fragment one by one) 

The formatting copied to the clipboard can also be used in MyOffice Text. 
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4.13.12.1 Formatting basics 

Depending on the selected item, you can format: 

‒ Paragraph 

‒ Text 

‒ Paragraph and text 

‒ Cell 

Table 25 specifies how the formatting is copied and applied. 
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Table 25. Formatting basics 

When you copy When you insert Result 

The cursor is positioned, or 

the entire paragraph 

(paragraphs) is selected 

The cursor is positioned 
Formats the paragraph or the first 

selected paragraph 

A paragraph is partially selected Formats the text 

The entire paragraph 

(paragraphs) is selected 
Formats the paragraph and text 

Several paragraphs are partially 

selected 
Formats the paragraph 

A paragraph is partially 

selected 

The cursor is positioned No formatting 

A paragraph is partially selected 

Formats the text from the first 

selected character 

The entire paragraph 

(paragraphs) is selected 

Several paragraphs are partially 

selected 

The cursor is positioned 

A spreadsheet cell is selected 

Formats the paragraph and text in 

the selected cell 

A paragraph is partially 

selected 
Formats the text in the selected cell 

The entire paragraph 

(paragraphs) is selected (up to 

the paragraph sign) 

Formats the paragraph and text 

A spreadsheet cell is selected 

A spreadsheet cell is selected 
Formats the cell, paragraph, and 

text 

The cursor is positioned Formats the paragraph 

A paragraph is partially selected Formats the text 

The entire paragraph 

(paragraphs) is selected 
Formats the paragraph and text 

Several paragraphs are partially 

selected 
Formats the paragraph 

A row or column is selected 
Formats the cell, paragraph, and 

text 

A row or column is selected A row or column is selected 

Formats the cell, paragraph, and 

text from the upper left cell in 

the copied row or column. 

Formats the row or column 
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4.13.12.2 Copy and insert formatting 

You can copy the formatting using: 

‒ Command menu 

‒ Keyboard shortcut 

‒ The  button on the Toolbar. 

 

To copy the formatting using the command menu or a keyboard shortcut, perform 

the following actions: 

1. Select the part of the document you want to copy the formatting from 

(see the Table above). 

2. Copy the formatting using one of the following methods: 

‒ In the Edit menu, select Copy Formatting (see Figure 376). 

 

Figure 376. Edit menu 

‒ Press Ctrl+Shift+C / ⇧Shift+⌘Cmd+C. 

3. To apply the formatting to one part of the document, do the following: 

‒ Select the part of the document you want to copy the formatting to 

(see the Table above). 

‒ In the Edit menu, select Paste Formatting (see Figure 376) or press Ctrl+Shift+V / 

⇧Shift+⌘Cmd+V. 
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4. To apply the formatting to multiple elements in the document, select these elements one 

by one and apply the formatting as described above. 

 

To format one element of a document using the  Copy Formatting button, follow these 

steps: 

1. Select the part of the document you want to copy the formatting from 

(see the Table above). 

2. On the Toolbar, select the Edit section and double-click the  Copy Formatting button 

(see Figure 377).  

3. Select the part of the document you want to copy the formatting to (see the Table above). 

 

Figure 377. Edit menu 

To format multiple elements of a document using the  Copy Formatting button, follow 

these steps: 

1. Select the part of the document you want to copy the formatting from  

(see the table above). 

2. On the Toolbar, select the Edit section and double-click the  Copy Formatting button. 

The button will change to . 

3. Select the parts of the document you want to copy the formatting to one by one 

(see the Table above) and apply the formatting. 

 

To exit the multiple elements formatting mode, do one of the following: 

‒ On the Toolbar, select the Edit section and click the  button. The button will change 

to . 

‒ Press Esc. 
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4.13.12.3 Formatting history 

Formatting copied to the clipboard history is saved and can be applied later. 

To open the formatting history, follow these steps: 

1. On the Toolbar, select the Edit section and click the arrow to the right of 

the  Copy Formatting button. 

2. In the opened drop-down list, select the format you want (see Figure 378). The most 

recent formatting is on the top of the list. 

3. Select the part of the document you want to copy the formatting to as described in 

Section 4.11.12.1. 

 

Figure 378. Recent formatting 
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4.14 Edit content 

4.14.1 Undo and redo 

4.14.1.1 Undo the last action 

You can undo the last action performed on the content of a document. 

To do this, use one of the following methods: 

‒ In the Edit menu, select Undo (see Figure 379). 

 

Figure 379. Edit menu 

‒ On the Toolbar, in the Edit section, click  Undo (see Figure 380). 

 

Figure 380. Undo and Redo buttons 

‒ When working on Windows / Linux, press Ctrl+Z or Alt+Backspace, when working on 

macOS, press ⌘Cmd+Z. 

To undo several recent actions, run the undo command several times. 
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4.14.1.2 Redo the result of the undone action 

The undone action can be redone if necessary. 

To do this, use one of the following methods: 

‒ In the Command menu, select Edit > Redo (see Figure 379). 

‒ On the Toolbar, in the Edit section, click  Redo (see Figure 381). 

‒ When working on Windows/Linux, press Ctrl+Y / Ctrl+Shift+Z / 

Shift+Alt+Backspace. When working on macOS, press ⌘ Cmd+Y. 

To redo the last few undone actions, run the redo command several times. 
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4.14.2 Clipboard 

4.14.2.1 Cut or copy data 

When you use the Cut command, the selected content is removed from the document and 

placed to the clipboard. When copying, the selected contents of the document do not change, and 

their copies are placed to the clipboard. 

The content copied or cut retains its formatting. 

You can insert the data copied or cut into MyOffice Spreadsheet, as well as into other 

applications, such as MyOffice Text. 

 

If you want to cut or copy data that contains an object (such as a shape or image), cut, or 

copy the data and the object separately. To retain existing data, use shift cell insertion  

(see Section 4.3.5.3). 

To cut data, follow these steps: 

1. Select the object you want to cut, or the cell, cell range, rows, or columns you want to 

cut the content from. 

2. Run the cutting command in one of the following ways: 

‒ In the Edit menu, select Cut (see Figure 379). 

‒ On the Toolbar, select the Edit section and click  Cut (see Figure 381). 

 

Figure 381. Cut and Copy buttons 

‒ Right-click the selected object, cells, or the titles/contents of the selected 

rows/columns to open the context menu. Run the Cut context menu command. 

‒ Press Ctrl+X or Shift+Delete (Windows OS). In macOS, press ⌘Cmd+X. 

 

The first cell for rows is the leftmost cell, for columns is the top cell, and for ranges 

is the leftmost top cell. 
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To copy data, follow these steps: 

1. Select the object you want to copy, or the cell, cell range, rows, or columns you want to 

copy the content from. 

2. Select the copy command in one of the following ways: 

‒ In the Edit menu, select Copy (see Figure 379). 

‒ On the Toolbar, select the Edit section and click the  Copy (see Figure 381). 

‒ Right-click the selected object, cells, or the titles/contents of the selected 

rows/columns to open the context menu. Run the Copy context menu command. 

‒ Press Ctrl+C or Ctrl+Insert (Windows OS or Linux). In macOS, press ⌘ Cmd+C. 

 

The copied cells, rows, or columns are highlighted by a dashed line frame. The frame 

automatically disappears when the copied data is pasted again. 

If you want to remove the dotted frame manually, press Esc. 
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4.14.2.2 Paste the last cut or copied data 

Pre-copied or cut out data in the clipboard is available for inserting. If you have copied or 

cut a range of cells/rows or columns, the inserted data will be of the same size. 

 

Inserting data into non-empty cells or ranges deletes the previous data without warning. 

You can paste data from the clipboard with or without saving the original formatting. 

To insert the content while keeping its original formatting: 

1. Place the cursor where you want to insert the data: 

‒ If the clipboard contains data from a single cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column where you want to paste the contents of the first 

cell/row/column in the range. 

‒ If the clipboard contains an object, select the cell to align the upper left corner of 

the object to. 

2. Paste the content in one of the following ways: 

‒ Select Edit > Paste (see Figure 379). 

‒ On the Toolbar, select the Edit section and click  Paste (see Figure 382). 

‒ On the Toolbar, select the Edit section and click the arrow to the right of 

the  Paste button. In the drop-down list, select the Paste command  

(see Figure 382). 

 

Figure 382. Paste button 
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‒ Open the context menu by right-clicking the selected cells or the titles/content of 

the selected rows/columns. Run the Paste context menu command. 

‒ Press Ctrl+V or Shift+Insert (Windows OS or Linux). In macOS, press ⌘Cmd+V. 

The following rules apply when pasting data without preserving the original formatting: 

‒ Only the text is pasted from the clipboard. For example, when you paste a shape with 

text or a link, only the text that these objects contain is pasted into the document. 

‒ If the clipboard contains a formula, only the result of the formula is pasted 

(see Section 4.6.8). 

 

To insert the data without the original formatting, follow these steps: 

1.  Specify where you want to paste the data: 

‒ If the clipboard contains data from a single cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column where you want to paste the contents of the first 

cell/row/column in the range. 

 

The first cell for rows is the leftmost cell, for columns is the top cell, and for 

ranges is the leftmost top cell. 

‒ If the clipboard contains a text object, select the cell into which you want to paste 

the text. 

2. Run the paste command in one of the following ways: 

‒ In the Edit menu, select Paste Values Only (see Figure 383). 
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Figure 383. Edit menu 

‒ On the Toolbar, select the Edit section and click the arrow to the right of  

the  Paste button. In the drop-down list, select the Paste Values Only command 

(see Figure 382). 

‒ Right-click the selected cells or the content of the selected rows or columns to open 

the context menu. In the context menu, select Paste Values Only. 
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4.14.2.3 Insert data from the clipboard history 

The clipboard history is available in MyOffice Spreadsheet. It can simultaneously store up 

to ten copied or cut entries. Each next entry will take the place of the oldest one in the history. 

The clipboard history works between MyOffice Spreadsheet and MyOffice Text and vice 

versa. 

Data from the expanded clipboard is pasted with the original formatting intact. 

4.14.2.3.1 Insert data 

To insert data from the clipboard history, do the following: 

1. Specify where you want to insert the data: 

‒ If the clipboard contains data from the same cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column in which to paste the contents of the first 

cell/row/column in the range. 

 

The first cell for rows is the leftmost cell, for columns is the top cell, and for 

ranges is the leftmost top cell. 

‒ If the clipboard contains an object, select the cell to align the upper left corner of the 

object to. 

2. Open the clipboard history in one of the following ways: 

‒ In the Edit menu, select Paste from Clipboard (see Figure 384). 

 

Figure 384. Data in the clipboard history 
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‒ Open the context menu by right-clicking the selected cells or the titles/content of 

the selected rows/columns. Select the Paste from Clipboard context menu 

command. 

3. In the opened sub-menu, select the data you want to paste. 

 

For convenience, the contents of the clipboard can be opened in a separate window.  

To do this, perform one of the following actions: 

‒ In the Command menu, select Edit > Paste from Clipboard > Clipboard History 

(see Figure 385). 

‒ Open the context menu by right-clicking any cell or any row/column headers/contents. 

Run the context menu command Paste from Clipboard > Clipboard History. 

‒ Press Ctrl+Alt+Shift+V (Windows) or Win+V (Linux). When working in macOS, 

press ⌥Option+⇧Shift+⌘Cmd+V. 

 

Figure 385. Clipboard history commands 

By default, the clipboard history window (see Figure 386) is positioned next to 

the highlighted or last highlighted cell (for example, if a column is highlighted). To change the 

window's position, drag it by the title bar while holding down the left mouse button. 
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Figure 386. Clipboard history 

How to navigate the clipboard history: 

‒ To move through the clipboard entries, use the ↓ and ↑ keys. 

‒ To paste the selected entry from the clipboard to the specified place of the document, 

click the left mouse button or press the Enter key. 

‒ To switch between the document and the clipboard history, use the Tab key. 

 

To close the clipboard history window, click the  button in its header. 

4.14.2.3.2 Clear clipboard history 

To clear the history of the clipboard history, follow these steps: 

1. Open the clipboard history sub-menu in one of the following ways: 

‒ In the Edit menu, select Paste from Clipboard (see Figure 383). 

‒ Open the context menu by right-clicking any cell or any row/column 

headers/contents. Select the Paste from Clipboard context menu command. 

2. In the opened sub-menu, click Clear. 
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4.15 Macros 

Macros are small programs that help to automate lengthy or frequently repeated operations 

in a document. MyOffice Spreadsheet macros are written in Lua programming language. 

Saving macros is only available within the current document. If you want to use similar 

macros in another document, create them directly in the other document. 

4.15.1 Create a macro 

You can create a macro in one of the following ways: 

‒ Record a sequence of actions that a macro should consist of. 

‒ Enter the macro code manually. 

To record a macro, do the following: 

1. Start recording in one of the following ways: 

‒ In the Tools menu, select Macros > Record Macro (Beta) (see Figure 387). 

 

Figure 387. Tools menu 

‒ If there is at least one macro in the document, click  Macros on the Sidebar.  

In the Macro pane, click the  button to the right of the New Macro button.  

In the drop-down list, select Record Macro (beta) (see Figure 388). 
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Figure 388. Start recording in the Macro pane 

2. Perform a sequence of actions that a macro should consist of. 

 

In the current version of the application, not all user actions are available for recording. 

When you perform an action that cannot be recorded, the message “Action cannot be 

recorded” pops up on the screen. 

3. Complete the recording in one of the following ways: 

‒ In the Tools menu, select Macros > Stop Recording (see Figure 389). 

 

Figure 389. Stop Recording command menu option 

‒ If there is at least one macro in the document, click  Macros on the Sidebar.  

In the Macro pane, click the  button to the right of the New Macro button.  

In the drop-down list, select Stop Recording (see Figure 390). 
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Figure 390. Stop recording command in the Macro pane 

‒ In the Status bar, click  Stop Recording (see Figure 391). 

 

Figure 391. Stop Recording button 

4. In the opened dialog box (see Figure 392), specify the macro name and click OK. 

 

Figure 392. New Macro dialog box 

If the macros has been successfully saved, the following pop-up message will be displayed 

on the screen: “"Macro_name" macro saved”. 
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To enter the code of a macro manually: 

1. Create a new macro using one of the following methods: 

‒ In the Tools menu, select Macros > Macro Editor (see Figure 387). In the Macro 

Editor window, click  (see Figure 393). 

 

Figure 393. Button for creating a  macro in the Editor 

‒ If there is at least one macro in the document, click  Macros on the Sidebar.  

In the Macros pane, click New Macro (see Figure 394). 

 

Figure 394. Macro creation button in the Macros pane 
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2. Enter a name for the macro or leave the default name (see Figure 395). To save the name, 

press Enter or click anywhere in the Macro Editor. 

 

Figure 395. Entering macro name 

3. Enter the code of the macro (see Figure 396). 

 

Figure 396. Entering macro code 
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The code of the macro will be saved automatically. 

When you add the first macro to your document, the  Macros button appears on 

the Sidebar (see Figure 397). This button is displayed as long as there is at least one macro in 

the document.  

 

Figure 397. Macro pane 

Click  Macros to open Macros pane. 

To close the Macros pane, click the  button at the top of the pane, or click  Macros 

button on the Sidebar again. 

4.15.1.1 Find a macro 

If your document contains a large number of macros, follow the steps below to quickly find 

the required macro: 

1. On the Sidebar, click  Macros (see Figure 397). 

2. In the Macros pane, enter a part of the name or the whole name of the required macro in 

the search bar (see Figure 398). 

The list of macros will display macros whose names match the specified search results. 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 420 

 

Figure 398. Macro search 

4.15.2 Run a macro 

You can run a macro using the Macro Editor or the Macro pane. You can also create buttons 

in the Favorites section of the Toolbar to quickly run frequently used macros (see Section 3.3.4.1). 

To run a macro using the Macro Editor, follow the steps below: 

1. Open the Macro Editor in one of the following ways: 

‒ In the Tools menu, select Macro > Macro Editor (see Figure 387). 

‒ On the Sidebar, click  Macros. In the Macro pane, click the  button to the right 

of the New Macro button. In the drop-down list, select Open Editor  

(see Figure 399). 

 

Figure 399. Open Editor command in the pane 

2. In the Macro Editor window, select the desired macro from the list (see Figure 400). 

3. Click  Run. 
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Figure 400. Run button 

Information about the macro run result will be displayed in the Output area (see Figure 401). 

 

Figure 401. Macro run result 
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To run a macro using the Macros pane, follow the steps below: 

1. On the Sidebar, click  Macros (see Figure 402). 

 

Figure 402. Run button 

2. Run a macro in one of the following ways: 

‒ In the Macros pane, hover the mouse cursor over the name of the macro and 

click  Run (see Figure 402). 

‒ Double-click to select the macro line. 

4.15.3 Edit a macro 

To edit a macro, follow these steps: 

1. Select a macro in one of the following ways: 

‒ In the Tools menu, select Macro > Macro Editor (see Figure 387).  

In the Macro Editor window, select the desired macro in the list. 

‒ On the Sidebar, click  Macros (see Figure 403). In the Macros pane, hover 

the mouse cursor over the name of the required macro and click  More.  

In the drop-down list, select Edit. 
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Figure 403. Open the editor window from the pane 

2. In the Macro Editor window, make the necessary changes to the macro code. 

Changes to the macro code are saved automatically. 

4.15.4 Debug a macro 

Before you run the macro debugger, set the debugger breakpoints in the macro code.  

To do this, proceed as follows: 

1. Select the required macro in one of the following ways: 

‒ In the Tools menu, select Macro > Macro Editor (see Figure 387).  

In the Macro Editor window, select the desired macro in the list. 

‒ On the Sidebar, click  Macros. In the Macro pane, click the  button to the right 

of the New Macro button. In the drop-down list, select Open Editor  

(see Figure 399). In the Macro Editor window, select the desired macro in the list. 

‒ On the Sidebar, click  Macros (see Figure 403). In the Macros pane, hover 

the mouse cursor over the name of the required macro and click  More.  

In the drop-down list, select Edit. 

2. In the Macro Editor window, select the desired macro from the list (see Figure 404). 

3. Set the first debugger breakpoint. To do this, click to the right of the line number where 

you want to toggle a breakpoint. The breakpoint will be marked with the  icon. 

4. Toggle other breakpoints by repeating these actions. 
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Figure 404. Breakpoint 

To delete a breakpoint, click it with the mouse. 

 

To debug a macro, follow the steps below: 

1. Click  Eyedropper (see Figure 405). The macro debugging process will start.  

If the macro code contains breakpoints, the debugging process will stop at the line that 

contains the first breakpoint. If there are no breakpoints, the debugging process will stop 

at the first line of the macro. 
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Figure 405. Debug button 

2. To control the debugging steps, use the following buttons (see Figure 406): 

  Step Into: Perform one debugging step or step into the body of the function, if there 

is one in the current debugging position. 

  Step Over: Perform one debugging step without stepping into the body of 

the function. 

  Step Out: Continue running the macro until leaving the function where the debugger 

is at the current position. 

During debugging, the following areas are displayed in the Macro Editor window: 

‒ In progress: This area will display messages while debugging. 

‒ Calls Stack: The calls stack area. 

‒ Variables: This area displays the values of local and global variables available at 

the current step of macro running. If the displayed variable is a table or an array, you can 

view its detailed contents by clicking  to the left of the variable name. 
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Figure 406. Debug a macro 

Debugging is terminated when the end of the macro is reached. 

To interrupt the debugging process, click  Stop Macro. 

4.15.5 Delete a macro 

To delete a macro, follow these steps: 

1. Select a macro in one of the following ways: 

‒ In the Tools menu, select Macro > Macro Editor (see Figure 387).  

In the Macro Editor window, select the desired macro in the list. 

‒ On the Sidebar, click  Macros. In the Macro pane, click the  button to the right 

of the New Macro button. In the drop-down list, select Open Editor  

(see Figure 399). In the Macro Editor window, select the desired macro in the list. 

‒ On the Sidebar, click  Macros (see Figure 403). In the Macros pane, hover 

the mouse cursor over the name of the required macro and click  More. In the 

drop-down list, select Edit. 

2. In the Macro Editor window, click . 
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Figure 407. Button to delete a macro 

3. In the window that opens, confirm the deletion of the macro. 

4.15.6 View VBA macro code 

In MyOffice Text, you cannot run VBA macros created in Excel. But you can view the code 

of the VBA macros contained in the document and rewrite them in Lua language. 

 

VBA macros saved in “This spreadsheet” are available for viewing. 

To view and rewrite the VBA macro code, follow these steps: 

1. Open an .xlsm or .xlsb document. 

2. Select the Lua macro with the name of the VBA module that contains the required VBA 

macro. For example, if the VBA macro Macro1 is contained in the VBA module 

Module1, select the Lua macro Module1. To select a Lua macro, do one of the 

following: 

‒ In the Tools menu, select Macro > Macro Editor (see Figure 387).  

In the Macro Editor window (see Figure 408), select the required Lua macro. 
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Figure 408. Macro Editor 

‒ On the Sidebar, click  Macros. In the Macro pane, click the  button to the right 

of the New Macro button. In the drop-down list, select Open Editor  

(see Figure 399). In the Macro Editor window, select the required Lua macro. 

‒ On the Sidebar, click  Macros (see Figure 403). In the Macros pane, hover the 

mouse cursor over the name of the required Lua macro and click  More. In the 

drop-down list, select Edit. The Macro Editor window will display the code of the 

VBA macros that are contained in the corresponding VBA module (see Figure 408). 

3. Rewrite the code of the required VBA macro in the Lua language. 

4. Close the Macro Editor window. 

5. Save the document in .xlsx format using the Save As command (see Section 4.1.10.1). 

Changes made are not saved in the original .xlsm or .xlsb document. 
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4.16 Protect content from changes 

MyOffice Spreadsheet allows to protect the following elements: 

‒ Sheet: Users will not be able to edit all or protected sheet cells. 

‒ Document structure: Users will not be able to add, delete, move, rename, duplicate, hide 

sheets or display hidden sheets. 

4.16.1 Protect a sheet 

You can protect all or selected cells on the sheet from changes in the workspace 

(see Section 3.6). By default, MyOffice Spreadsheet protects all cells. 

To protect the contents of a sheet, follow these steps: 

1. Click the sheet tab with the mouse. 

2. Open the Manage Protection pane in one of the following ways: 

‒ In the Data menu, select Manage Protection > Protect Sheet (see Figure 409). 

 

Figure 409. Protect Sheet menu 
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‒ Right-click the sheet tab and run the Protect Sheet context menu command 

(see Figure 410). 

 

Figure 410. Context menu of a sheet 

3. If you want to protect all cells of the workspace, do not uncheck the Locked for changes 

box on the Sheet tab (see Figure 411). 

4. If you need to specify the cells that users will be able to edit after installing protecting 

the sheet: 

‒ Select these cells. 

‒ Uncheck the Locked for changes box. 

5. If you want users to see only the result of the formula calculation in the protected cells 

and on the Formula bar: 

‒ Select these cells. 

‒ Check the Formulas not displayed box. 
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Figure 411. Manage Protection pane 

6. Expand the Allowed actions section (see Figure 412) and specify what actions users are 

allowed to perform with protected cells. 
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Figure 412. Allowed action section 

7. If you need to set a password to remove protection from the sheet, expand the section 

Password (optional) (see Figure 413), enter the password and confirm it. 

8. Click Protect Sheet. 
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Figure 413. Password (optional) section 

9. Close the Manage Protection pane in one of the following ways: 

‒ At the top of the pane, click  (see Figure 415). 

‒ On the Sidebar, click  Manage Protection (see Figure 415). 

 

When working with a file in Microsoft Excel and LibreOffice Calc applications, sheet 

protection settings are not applied to cells located outside the workspace (see Section 3.6). 

4.16.2 Protect the document structure 

To protect the document structure, follow these steps: 

1. Open the Manage Protection pane. To do this, in the Data menu, select  

Manage Protection > Protect the document structure (see Figure 414). 

 

Figure 414. Protect Sheet menu 
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2. In the Manage Protection pane, select the Spreadsheet Structure tab (see Figure 415): 

‒ If necessary, set a password to unprotect the document structure. 

‒ Click Protect Structure. 

3. Close the Manage Protection pane in one of the following ways: 

‒ In the upper part of the pane, click . 

‒ On the Sidebar, click  Manage Protection. 

 

Figure 415. Manage Protection pane 
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4.16.3 Unprotect a sheet 

If the sheet is protected from editing, the sheet tab displays the  icon (see Figure 416) 

is displayed on the sheet tab. You may need to enter a password to unprotect the sheet. 

 

Figure 416. Sheet protected from editing 

To remove protection from a sheet, do the following: 

1. Click the sheet tab. 

2. Open the Manage Protection pane in of the following ways: 

‒ In the Data menu, select Manage Protection > Unprotect Sheet (see Figure 417). 

 

Figure 417. Unprotect Spreadsheet menu  
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‒ Right-click the sheet tab and use the Unprotect Sheet context menu command 

(see Figure 418). 

 

Figure 418. Context menu of the sheet 

3. In the Manage Protection pane, select the Sheet tab and do the following: 

‒ If the sheet is password-protected, enter the password, and click Unprotect 

(see Figure 419). 

 

Figure 419. Manage Protection pane 
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‒ If the sheet is not password-protected, click the Unprotect button  

(see Figure 420). 

4. To close the Manage Protection pane, do one of the following: 

‒ In the upper part of the pane, click . 

‒ On the Sidebar, click  Manage Protection. 

 

Figure 420. Unprotect sheet 
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4.16.4 Unprotect file structure 

If the document structure is protected from editing, an icon  is displayed to the right of 

the sheet tabs (see Figure 421). You may be required to enter a password to remove the protection. 

 

Figure 421. Data command menu 

To remove protection from the document structure, do the following: 

1. Open the Manage Protection pane. To do this, in the Data menu, select  

Manage Protection > Unprotect Sheet (see Figure 421). 

 

Figure 422. Sheet command menu 

2. In the Manage Protection pane, select the Spreadsheet Structure pane and 

do the following: 

‒ If the document structure is password-protected, enter the password, and 

click Unprotect (see Figure 423). 
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Figure 423. Manage Protection pane 

‒ If the document structure is not password-protected, click Unprotect  

(see Figure 424). 

3. To close the Manage Protection pane, do one of the following: 

‒ In the upper part of the pane, click . 

‒ On the Sidebar, click  Manage Protection. 
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Figure 424. Unprotect spreadsheet structure  
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APPENDIX 1. FUNCTIONS AND THEIR DESCRIPTION 

Function Description 

Financial 

COUPPCD(settlement, maturity, 

frequency, [day_count_convention]) 

Returns the numeric date value of the last coupon date before 

the settlement date of a security. 

DOLLARDE(fractional_price, unit) 
Converts a dollar value expressed as a fraction into a decimal 

number. 

DOLLARFR(decimal_price, unit) 
Converts a dollar value expressed as a decimal number into a 

fractional number. 

IRR(cashflow_amounts, [rate_guess]) 
Calculates the internal rate of return on an investment based on 

regular cash flows which include both payments and incomes. 

NPV(discount, cashflow1, [cashflow2, ...]) 

Returns the numeric value which is the net present value of an 

investment depending on a series of periodic cash flows and a 

discount rate. 

PMT(rate, number_of_payments, 

present_value, [future_value], 

[end_or_beginning]) 

Returns the periodic payment for an annuity based on constant 

periodic payments and a constant interest rate. 

PV(rate, number_of_periods, 

payment_per_period, [future_value], 

[end_or_beginning]) 

Returns the present value of an investment based on periodic 

payments and a constant interest rate. 

Time and date 

DATE(year, month, day) Creates a date from the specified year, month, and day. 

DATEVALUE(date_string) 
Transforms the provided date string in a known format to a 

numeric date value. 

DAY(date) 
Returns the day of the month that a specific date falls on, in 

numeric format. 

EDATE(start_date; months) 
Returns the numeric value of a date which falls a specified 

number of months before or after another date. 

EDATE(start_date; months) 
Returns the date representing the last day of the month which 

falls a specified number of months before or after another date. 

HOUR(time) Extracts the hour component from a given time value. 

ISOWEEKNUM(date) Returns the ISO week number (from 1 to 54) for a given date. 

MINUTE(time) Extracts the minute component from a given time value. 

MONTH(date) 
Returns the month of the year the specific date falls in, in 

numeric format. 

NOW() Returns the current date and time as a timestamp value. 

TODAY() Returns the current date in number format. 

YEAR(date) Returns the year specified by a given date. 

Math and trigonometry 

ABS(value) 
Returns the absolute value of a number. The result of calculation 

is always a positive number. 
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Function Description 

ACOS(value) 
Calculates the arccosine, that is the inverse cosine of a given 

number, and returns an angle expressed in radians. 

ACOSH(value) Calculates the inverse hyperbolic cosine for a number. 

ACOT(value) 

Calculates the arccotangent, that is the inverse cotangent of a 

given number, and returns an angle, in radians, between 0 (zero) 

and π. 

ASIN(value) 
Calculates the arcsine, that is the inverse sine of a given number, 

and returns an angle expressed in radians. 

ATAN(value) 
Calculates the arctangent, that is the inverse tangent of a given 

number, and returns an angle, in radians, between -Pi/2 and Pi/2. 

ATAN2(x, y) 

Returns the arctangent of an angle between the x-axis and a 

segment starting from the origin (0,0) and ending at a specific 

point defined by the coordinate pair (x,y). The resulted value is 

expressed in radians. 

ATANH(value) Calculates the inverse hyperbolic tangent for a number. 

COSH(value) Calculates the hyperbolic cosine for a real number. 

COTH(angle) Calculates the hyperbolic cotangent of a number. 

CSC(angle) 
Calculates the cosecant of a number and returns the result in 

radians. 

CSCH(angle) 
Calculates the hyperbolic cosecant of a number and returns 

the result in radians. 

DEGREES(angle) 
Converts an angle value in radians to the equivalent value in 

degrees. 

EXP(exponent) Returns the e number (~2.718) raised to a supplied power. 

FACTDOUBLE(value) Returns the double factorial of a number. 

INT(value) Rounds a number down to the nearest integer. 

LN(value) 
Returns the logarithm of a number to base e (~2.718) which is 

known as the natural logarithm. 

LOG(value, [base]) Returns the logarithm of a number with respect to a given base. 

LOG10(value) Returns the base-10 logarithm of a given number. 

PI() Returns the pi value rounded to 14 decimal places. 

POWER(base, exponent) Returns the result of raising a number to a power. 

PRODUCT(factor1, [factor2, ...]) Returns the product of supplied arguments. 

QUOTIENT(dividend, divisor) 
Divides a number by another one and returns a value without a 

reminder. 

RAND() 
Returns a random decimal number between 0 and 1, excluding 

the boundary values. 

ROUND(value, places) 
Rounds a number to a certain number of digits according to 

standard rounding rules. 

ROUNDDOWN(value, places) Rounds a number down to a certain number of decimal places. 

ROUNDUP(value, places) Rounds a number up to a certain number of digits. 
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Function Description 

SEC(angle) Returns the secant of an angle, in radians. 

SECH(angle) Returns the hyperbolic secant of an angle. 

SINH(value) Returns the hyperbolic sine of a number. 

SQRT(value) Returns the positive square root of a number. 

SQRTPI(value) 
Returns the square root of the pi constant (3.14159265358979) 

multiplied by a given number. 

SUBTOTAL(function_code, range1, 

[range2, ...]) 

Uses another function (SUMM, PRODUCT, etc.) to calculate 

the subtotal for a set of numbers. 

For more details, see Section  

SUBTOTAL function. 

SUBTOTAL(function_code, range1, 

[range2, ...]) 

Uses another function to calculate a subtotal for a vertical range 

of cells. 

SUM(value 1, [value 2; ...]) Returns the result of adding series of numbers, and/or cells. 

SUMIF(range, criterion, [sum_range]) Returns the sum of a range of values matching a certain criterion. 

SUMIFS(sum_range, criteria_range1, 

criterion1, [criteria_range2, criterion2, ...]) 

Returns the sum of a range of values matching multiple criteria. 

SUMPRODUCT(array1, [array2, ...]) 
Multiplies ranges or arrays together and returns the sum of 

products. 

SUMSQ(value1, [value2, ...]) Returns the sum of the squares of numbers. 

TANH(value) Returns the hyperbolic tangent of a number. 

Statistical 

AVERAGE(value1, [value2, ...]) Returns the average of numbers in a dataset, ignoring text. 

COUNT(value1, [value2, ...]) Returns the count of numeric values in a supplied dataset. 

COUNTA(value1, [value2, ...]) 
Looks through a given dataset and returns the number of cells 

containing any type of information. 

COUNTBLANK(range) 
Returns the count of empty and blank cells in a given range or 

array. 

COUNTIF(range, criterion) Returns the number of times cell values meet a certain criterion. 

COUNTIFS(criteria_range1, criterion1, 

[criteria_range2, criterion2, ...]) 

Returns the number of cells that meet multiple criteria. 

F.DIST(x, freedom_degrees1, 

freedom_degrees2, cumulative) 

Calculates the left-tailed F probability distribution (degree of 

diversity) for two data sets with a given x. 

F.DIST.RT(x, freedom_degrees1, 

freedom_degrees2) 

Calculates the right-tailed F probability distribution (degree of 

diversity) for two data sets with a given x. 

FISHER(value) Returns the Fisher transformation for a given value. 

LARGE(data, n) 

Arranges a given numeric dataset in descending order and returns 

a value depending on its relative position where the largest value 

takes the first position. 

LINEST(known_data_y, [known_data_x], 

[calculate_b], [stats]) 

Calculates parameters of the linear trend based on the least-

squares method. 

MAX(value1, [value2, ...]) Retrieves the maximum number from a numeric dataset. 
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Function Description 

MIN(value1, [value2, ...]) Retrieves the minimum number from a numeric dataset. 

NORM.DIST(x, mean, standard_deviation, 

cumulative) 

Returns the normal distribution function for the specified values 

of the arithmetic mean and the standard deviation. 

RANK.EQ(value, data, [is_ascending]) 

Arranges numeric values in ascending or descending order and 

determines the rank position of a specified value in a dataset. For 

duplicate values, a rank of the first value is assigned. 

SMALL(data, n) 

Arranges a given numeric dataset in ascending order and returns a 

value based on its relative position where the smallest value takes 

the first position. 

STDEV.S(value1, [value2, ...]) Calculates the standard deviation based on a sample. 

VAR(value1, [value2, ...]) Calculates the variance based on a given sample. 

VARA(value1, [value2, ...]) 
Calculates the variance based on a sample, treating text values as 

0 (zero). 

VARPA(value1, [value2, ...]) 
Analyzes data in a range and returns the variance of that data 

range. Text and logical values are considered. 

Lookup and reference 

ADDRESS(row, column, 

[absolute_relative_mode], 

[use_a1_notation], [sheet]) 

Returns the cell location in a spreadsheet based on specified row 

and column numbers. 

AREAS(reference) 
Returns the number of areas in a reference or a range. An area is 

considered as a separate cell reference or a range of cells. 

CHOOSE(index, choice1, [choice2, ...]) Retrieves the value from a dataset based on its position number. 

COLUMN([cell_reference]) Returns the column number of a specified cell. 

COLUMNS(range) Returns the count of columns in a range or an array. 

HLOOKUP(search_key, range, index, 

[match_type]) 

Evaluates the first row of a range for a search value and returns a 

value which is located in a different row but in the same column. 

HYPERLINK(url, [link_label]) Creates a link in a cell of a spreadsheet. 

INDEX(reference, [row], [column]) 
Returns the element of an array or range, specified by its row and 

column position. 

INDIRECT(cell_reference_as_string, 

[is_A1_notation]) 

Returns the content of the reference which can be a cell or a 

string. 

LOOKUP(search_key, search_range, 

[result_range]) (1) 

 

LOOKUP(search_key, search_result_array) 

(2) 

Looks through a row or a column for a key and returns the cell 

value in a result range located in the same position as a search 

row or column. 

 

Looks through multiple rows or columns for a key and returns a 

value of the cell located in the correspondent position of the same 

search rows or columns. To search for a key across a single row 

or column, specify the result_range value as the third argument. 

MATCH(search_key, range, [search_type]) 

Allows finding a specified item in the defined range of cells by a 

desired search type. The function returns the item index (that is a 

position number of the item in an array), not the item itself. 
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Function Description 

OFFSET(cell_reference, offset_rows, 

offset_columns, [height], [width]) 

Returns a cell or a range of cells shifted by a specified number of 

rows and columns from the initial cell reference. 

ROW([cell_reference]) Returns the number of the row where a cell is specified. 

ROWS(range) Returns the count of rows in a range or an array. 

VLOOKUP(search_key, range, index, 

[match_type]) 

Searches down the first column of a range for the first matching 

key and returns the corresponding value from another column. 

Database 

DSUM(database, field, criteria) 
Calculates the sum of database values matching the specified 

criteria. 

Text 

ASC (string) 

Converts a text encoded in a double byte character set (DBCS) to 

a text in a single byte character set (SBCS). In the spreadsheet 

editor, the function is only used for the backward compatibility 

with documents containing text encoded in DBCS. 

CLEAN(text) Removes non-printable characters from a given string. 

CODE(string) 
Returns the Unicode numeric value of the first character in a 

given string. 

CONCATENATE(string1, [string2, ...]) Joins separate entries into a single string. 

DBCS(string) 

Converts a text from ASCII to DBCS and backwards. In 

the spreadsheet editor, the function is only used for the backward 

compatibility with documents containing text encoded in either 

ASCII or DBCS. 

EXACT(string1, string2) 
Checks whether two strings are identical and, if so, returns 

TRUE. 

FIND(search_for, text_to_search, 

[starting_at]) 

Returns the position at which a string is first found within text 

(case sensitive). 

FINDB(search_for, text_to_search, 

[starting_at]) 

Returns the position at which a string is first found within text 

counting double letters as two characters. 

JIS(string) 

Converts a text from ASCII to DBCS and backwards. In 

the spreadsheet editor, the function is only used for the backward 

compatibility with documents containing text encoded in either 

ASCII or DBCS. 

LEFT(string, [number_of_characters]) Returns a substring from the beginning of a specified string. 

LEFTB(string, [number_of_characters]) 
Returns a substring from the beginning of a specified string based 

on the supplied number of characters. 

LEN(text) Returns the length of the specified string. 

LENB(text) Returns the count of characters in the supplied string. 

LOWER(text) 
Finds uppercase letters in a given string to convert them to 

lowercase. 

MID(string, starting_at, extract_length) Returns a segment of a string. 

MIDB(string, starting_at, extract_length) 
Returns a segment of a string based on the specified number of 

bites. 
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Function Description 

PROPER(text_to_capitalize) Capitalizes the first letter of every word in a specified string. 

RIGHT(string, [number_of_characters]) Returns the rightmost character or characters of a given string. 

RIGHTB(string, [number_of_characters]) 
Returns the rightmost character or characters of a given string 

based on the specified number of bites. 

SEARCH(search_for, text_to_search, 

[starting_at]) 

Returns the starting position of a string within a text. 

SEARCHB(search_for, text_to_search, 

[starting_at]) 

Returns the position at which a string is first found within text 

counting double letters as two characters. 

SUBSTITUTE(text_to_search, search_for, 

replace_with, [occurrence_number]) 

Replaces a specific string with another one in a text. 

TEXT(value, format) 
Converts a numeric value into a text value according to a 

specified format. 

TRIM(text) 
Removes all spaces in the specified string, except the single 

spaces between words. 

UNICODE(string) 
Returns the Unicode numeric value of the first character in 

a given string. 

UPPER(text) Converts all lowercase letters in a specified string to uppercase. 

Logic 

AND(logical_expression1, 

[logical_expression2, ...]) 

Returns TRUE if all the supplied tests are successful, and FALSE 

if at least one fails. 

FALSE() Returns the FALSE logical value. 

IF(logical_expression, value_if_true, 

[value_if_false]) 

Returns one value if the result of a logical test is TRUE and 

another if it is FALSE. 

IFERROR(value, value_if_error) 
Returns the first argument if it is not an error value, and 

the second argument if a given value is an error. 

IFNA(value, value_if_na) 
Returns the first argument if it is not #N/A, otherwise, returns 

the second argument. 

OR(logical_expression1, 

[logical_expression2, ...]) 

Returns TRUE if any of the specified logical tests is successful, 

and FALSE if all logical tests fail. 

SWITCH(expression, value1, result1, 

[value2, result2, ...], [default]) 

 

Evaluates a list of expressions and returns the value 

corresponding to the first expression in the list. 

TRUE() Returns the TRUE logical value. 

Information 

CELL(info_type, [reference]) Returns the requested data about a particular cell. 

INFO(info_type) 
Returns the requested information relating to the user’s operating 

system and the data processing environment. 

ISBLANK(value) 
Checks whether a referenced cell is empty, and if so, returns 

the TRUE logical value. 

ISERR(value) Returns TRUE if a given value is an error other than #N/A. 

ISERROR(value) Returns TRUE if a given value is an error. 
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Function Description 

ISEVEN(value) 
Checks whether a value is an even number and, if so, returns 

TRUE. 

ISLOGICAL(value) 
Checks whether a value is either FALSE or TRUE and returns 

TRUE on any of them. 

ISNA(value) 
Checks whether a value is the #N/A error and, if so, returns 

TRUE. 

ISNUMBER(value) Checks whether a given value is a number. 

ISODD(value) 
Checks whether a value is an odd number and, if so, returns 

TRUE. 

ISREF(value) Returns TRUE if a supplied value is a valid cell reference. 

ISTEXT(value) Checks whether a given value is textual. 

NA() Returns the #N/A error which stands for "value is not available". 

Engineering 

COMPLEX(real_number, 

imaginary_number, [suffix]) 

Creates a complex number based on specified real and imaginary 

components. 

IMABS(complex_number) 

 

Returns the absolute value of a complex number. 
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SUBTOTAL function 

Syntax 

SUBTOTAL(function_code, range1, [range2, ...]) 

Description 

Uses another function (SUMM, PRODUCT, etc.) to calculate the subtotal for a set of 

numbers. 

Function_code: The numeric code of the function to be used to calculate the subtotal  

(see Table 26). Use codes 1-11 to include manually hidden cells in the count, or 101-111 to exclude 

them. Cells hidden using a filter are always excluded. 

Table 26. Numeric codes 

Function_code 

(Include hidden values) 

Function_code 

(Exclude hidden values) 
Function 

1 101 AVERAGE 

2 102 COUNT 

3 103 COUNTA 

4 104 MAX 

5 105 MIN 

6 106 PRODUCT 

7 107 STDEV 

8 108 STDEVP 

9 109 SUM 

10 110 VAR 

11 111 VARP 

 

range1: The first range or array over which to calculate a subtotal. 

[range2; …]: Additional ranges or arrays over which to calculate subtotals. This parameter 

is optional. 
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Example: 

=SUBTOTAL(9, B2:B5): Calculate the sum of values in cells B2:B5, considering 

the values in the cells hidden manually. 

=SUBTOTAL(109, B2:B5): Calculate the sum of values in cells B2:B5, without 

considering the values in the cells hidden manually. 

 

Figure 425. Function use examples 

 

Figure 426. Function use examples 
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APPENDIX 2. LIST OF SUPPORTED CURRENCIES 

Currency name Currency code 

Azerbaijani manat AZN 

Armenian dram AMD 

Belarusian ruble BYN 

Bulgarian lev BGN 

Brazilian real BRL 

Won KRW 

Hryvnia UAH 

Danish krone DKK 

US dollar USD 

Euro EUR 

Zloty PLN 

Yen JPY 

Indian rupee INR 

Moldovan leu MDL 

Turkmenistan new manat TMT 

Norwegian krone NOK 

Russian ruble RUB 

Romanian leu RON 

Rand ZAR 

Som KGS 

Somoni TJS 

Tenge KZT 

Turkish lira TRY 

Uzbekistani som UZS 

Forint HUF 

Pound sterling GBP 

Czech koruna CZK 

Swedish krona SEK 

Swiss franc CHF 

Yuan Renminbi CNY 
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APPENDIX 3. KEYBOARD SHORTCUTS 

This appendix contains the keyboard shortcuts used in Windows OS, Linux OS  

(see Table 27) and macOS (see Table 28). 

 

On laptops, some keys are multifunctional. For example: F1–F12, Home, End, PgUp, 

PgDn. When pressing these keys in MyOffice Spreadsheet, you need to hold Fn down at 

the same time. 

Table 27. OS Windows and OS Linux shortcuts 

Keyboard shortcuts Command or action 

Edit the content 

Ctrl+X 

Shift+Delete 
Cut 

Ctrl+C 

Ctrl+Insert 
Copy 

Ctrl+V 

Shift+Insert 
Insert 

Ctrl+Alt+V Insert values and format 

Ctrl+S Save 

F12 (Windows) 

Ctrl+Shift+S (Linux) 
Save as 

Ctrl+Z Cancel the last action 

Ctrl+Y 

Ctrl+Shift+Z 

Shift+Alt+Backspace 

Repeat the result of the canceled action 

Ctrl+Alt+Shift+V (Windows) 

Win+V (Linux) 
Open the clipboard history 

Backspace Delete one character to the left of the cursor 

Delete Delete one character to the right of the cursor 

Ctrl+Backspace Delete part of a word or the entire word to the left of the cursor 

Ctrl+Delete 
Delete part of a word or the entire word to the right of the 

cursor 

Alt+Enter Begin a new paragraph 

Ctrl+Shift+Space Insert a non-breaking space 

Ctrl+Shift+ – Insert a non-breaking hyphen 

Ctrl+Num – Insert an en dash 
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Keyboard shortcuts Command or action 

Ctrl+Alt+Num – Insert an em dash 

Content formatting 

Ctrl+B Bold 

Ctrl+I Italic 

Ctrl+U Underline 

Ctrl+Shift+= Superscript 

Ctrl+= Subscript 

Ctrl+Shift+A All caps 

Ctrl+Shift+C Copy formatting 

Ctrl+Shift+V Apply formatting 

Ctrl+L Align the cell content to the left 

Ctrl+E Center the cell content 

Ctrl+R Align the cell content to the right 

Ctrl+J Justify the cell content 

Move throughout the workspace  

Page Up One screen up 

Page Down One screen down 

Ctrl+Home Go to the first workspace cell (A1 cell) 

Ctrl+End Go to the last workspace cell 

Ctrl+Up Arrow Go to the first cell of the column  

Ctrl+Down Arrow Go to the last cell of the column in the workspace 

Ctrl+Left Arrow Go to the first cell of the row  

Ctrl+Right Arrow Go to the last cell of the column in the workspace 

Actions with cells, rows, and columns 

F2 Switch to cell editing mode 

Alt+A Select a row upwards 

Alt+B Select a row downwards 

Alt+L Insert a column to the left 

Alt+R Insert a column to the right 

Ctrl+Alt+M Merge cells 

Alt+Shift+M Split cells 

Ctrl+– Delete a row or a column 

Select cells, rows, and columns 

Arrow Up Select the cell upwards 

Arrow Down Select the cell downwards 

Tab or Right Arrow Select the next cell 
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Keyboard shortcuts Command or action 

Left Arrow Select the previous cell 

Home Select the cell at the beginning of the row 

End Select the cell at the end of the row 

Shift+Space Select a row 

Ctrl+Space Select a column 

Ctrl+Shift+Home 
Create a selection area from the selected cell to the first cell of 

the workspace (cell A1) 

Ctrl+Shift+ End 
Create a selection area from the selected cell to the last cell of 

the workspace 

Ctrl+Shift+End Select an area from the selected cell to the last cell in the 

workspace 

Ctrl+Shift+Up Arrow Select an area from the selected cell to the first cell in the 

column 

Ctrl+Shift+Down Arrow Select an area from the selected cell to the last cell of the 

column in the workspace 

Ctrl+Shift+Left Arrow Select an area from the selected cell to the first cell in the row 

Ctrl+A 
Select all cells in the sheet workspace 

 

Shift+Arrow Up Expand the selection by one cell upwards 

Shift+Arrow Down Expand the selection by one cell downwards 

Select text in the edited cell* 

Shift+Left Arrow Select one character to the left of the cursor 

Shift+Right Arrow Select one character to the right of the cursor 

Ctrl+ Shift+Left Arrow Select one word to the left of the cursor 

Ctrl+ Shift+Right Arrow Select one word to the right of the cursor 

Shift+Home Select the content from the cursor to the beginning of the line 

Shift+End Select the content from the cursor to the end of the line 

Ctrl+ Shift+Arrow Up Extend the selection to the beginning of the paragraph 

Ctrl+ Shift+Arrow Down Extend the selection to the end of the paragraph 

Shift+Arrow Up Expand the selection by one row/cell upwards 

Shift+Arrow Down Expand the selection by one row/cell downwards 

Double-click the left mouse button Select a word 

Triple-click the left mouse button Select a paragraph 

Click the left mouse button and move 

the cursor upwards 
Select the text upwards 

Click the left mouse button and move 

the cursor downwards 
Select the text downwards 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select the cell 

by double-clicking or pressing F2. 
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Keyboard shortcuts Command or action 

Move within the text in the edited cell* 

Left Arrow Move one character to the left 

Right Arrow Move one character to the right 

Ctrl+Left Arrow Move one word to the left 

Ctrl+Right Arrow Move one word to the right 

Arrow Up Move one line up 

Arrow Down Move one line down 

Ctrl+Arrow Up Go to the beginning of the previous paragraph 

Ctrl+Arrow Down Go to the beginning of the next paragraph 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select the cell 

by double-clicking or pressing F2. 

Work with formulas and functions 

Alt+F9 
Replace the formula (entirely or partially) with its calculated 

value 

Alt+= 
Quick insertion of the SUM function with automatic definition 

of arguments 

F9 Recalculate formulas in the entire document 

Shift+F9 Recalculate formulas on the sheet 

Ctrl+Shift+F9 Force recalculate formulas 

Ctrl+Shift+F5 Update references to data in external documents 

Other keyboard shortcuts 

Ctrl+N Create a file 

Ctrl+O Open a file 

Ctrl+P 
Open the window for previewing and setting page and printing 

parameters of the document 

Ctrl+0 (zero) Set the actual page scale (100%) 

Ctrl+K Insert a link 

Ctrl+Shift+V Insert a link from the clipboard 

Ctrl+Shift+1 Split the number into digit groups 

Ctrl+F 

Ctrl+H 
Open the search pane 

Ctrl+T Open the window to create a table 

Shift+F3 Open the Inset function pane 

Ctrl+/ Open the Quick action box 

F1 Open the Help 

Click the right mouse button Open the context menu of the selected element 

Alt+Space Open the context menu of the active application window 
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Keyboard shortcuts Command or action 

Alt+F4 Close the active application window 
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Table 28. Keyboard shortcuts in macOS 

Keyboard shortcuts Command or action 

Edit the content 

⌘ Cmd + X Cut 

⌘ Cmd + C Copy 

⌘ Cmd + V Insert 

⌥ Option + ⌘ Cmd + V Insert values and format 

⌘ Cmd + S Save 

⇧ Shift + ⌘ Cmd + S Save as 

⌘ Cmd + Z Cancel the last action 

⌘ Cmd + Y Repeat the result of the canceled action 

⌥ Option + ⇧ Shift + ⌘ Cmd + Z Open the clipboard history 

Delete Delete one character to the left of the cursor 

Fn + Delete Delete one character to the right of the cursor 

⌘ Cmd + Delete 

⌥ Option + Delete 

Delete part of a word or the entire word to the left of the 

cursor 

⌘ Cmd + Fn + Delete 

⌥ Option + Fn + Delete 

Delete part of a word or the entire word to the right of the 

cursor 

⌥ Option + ⌅ Enter Begin a new paragraph 

⌥ Option + ⇧ Shift + Space Insert a non-breaking space 

⌘ Cmd + ⇧ Shift + – Insert a non-breaking hyphen 

⌥ Option + – Insert an en dash 

⌥ Option + ⇧ Shift + – Insert an em dash 

Content formatting 

⌘ Cmd + B Bold 

⌘ Cmd + I Italic 

⌘ Cmd + U Underline 

⇧ Shift + ⌘ Cmd + = Superscript 

⌘ Cmd + = Subscript 

⇧ Shift + ⌘ Cmd + A All caps 

⇧ Shift + ⌘ Cmd + C Copy formatting 

⇧ Shift + ⌘ Cmd + V Apply formatting 

⌘ Cmd + L Align the cell content to the left 

⌘ Cmd + E Center the cell content 

⌘ Cmd + R Align the cell content to the right 

⌘ Cmd + J 
Justify the cell content 
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Keyboard shortcuts Command or action 

Move within the workspace 

Fn + Arrow Up One screen up 

Fn + Arrow Down One screen down 

Fn + ⌘ Cmd + Left Arrow Go to the first workspace cell (A1 cell) 

Fn + ⌘ Cmd + Right Arrow Go to the last workspace cell 

⌘ Cmd+Up Arrow Go to the first cell of the column  

⌘ Cmd+Down Arrow Go to the last cell of the column in the workspace 

⌘ Cmd+Left Arrow Go to the first cell of the row  

⌘ Cmd+Right Arrow Go to the last cell of the column in the workspace 

Actions with cells, rows, and columns 

Fn + F2 Switch to cell editing mode 

⌥ Option + A Select a row upwards 

⌥ Option + B Select a row downwards 

⌥ Option + L Insert a column to the left 

⌥ Option + R Insert a column to the right 

⌥ Option + ⌘ Cmd + M Merge cells 

⌥ Option + ⇧ Shift + M Split cells 

⌘ Cmd + – Delete a row or a column 

Select cells, rows, and columns 

Arrow Up Select the cell upwards 

Arrow Down Select the cell downwards 

Tab or Right Arrow Select the next cell 

Left Arrow Select the previous cell 

Fn + Left Arrow Select the cell at the beginning of the row 

Fn + Right Arrow Select the cell at the end of the row 

⇧ Shift +Space Select a row 

⇧ Shift + ⌘ Cmd + Space Select a column 

⇧ Shift + Fn + ⌘ Cmd + Left Arrow 
Create a selection area from the selected cell to the first cell 

of the workspace (cell A1) 

⇧ Shift + Fn + ⌘ Cmd + Right Arrow 
Create a selection area from the selected cell to the last cell 

of the workspace 

⇧ Shift+⌘ Cmd+Up Arrow Select an area from the selected cell to the first cell in 

the column 

⇧ Shift+⌘ Cmd+Down Arrow Select an area from the selected cell to the last cell of 

the column in the workspace 

⇧ Shift+⌘ Cmd+Left Arrow Select an area from the selected cell to the first cell in 

the row 
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Keyboard shortcuts Command or action 

⇧ Shift+⌘ Cmd+Right Arrow Select an area from the selected cell to the last cell of 

the row in the workspace 

⌘ Cmd + A Select all cells in the sheet workspace 

⇧ Shift + Arrow Up Expand the selection by one cell upwards 

⇧ Shift + Arrow Down Expand the selection by one cell downwards 

Select text in the edited cell* 

⇧ Shift + Left Arrow Select one character to the left of the cursor 

⇧ Shift + Right Arrow Select one character to the right of the cursor 

⇧ Shift + ⌘ Cmd + Left Arrow Select one word to the left of the cursor 

⇧ Shift + ⌘ Cmd + Right Arrow Select one word to the right of the cursor 

Fn +⇧ Shift + Left Arrow 
Select the content from the cursor to the beginning of 

the line 

Fn +⇧ Shift + Right Arrow Select the content from the cursor to the end of the line 

⇧ Shift + ⌃ Ctrl + ⌘ Cmd + Arrow Up Extend the selection to the beginning of the paragraph 

⇧ Shift + ⌃ Ctrl + ⌘ Cmd + Arrow Down  Extend the selection to the end of the paragraph 

⇧ Shift + Arrow Up Expand the selection by one table row/cell upwards 

⇧ Shift + Arrow Down Expand the selection by one row/cell downwards 

Double-click the left mouse button Select a word 

Triple-click the left mouse button Select a paragraph 

Click the left mouse button and move 

the cursor upwards 
Select the text upwards 

Click the left mouse button and move 

the cursor downwards 
Select the text downwards 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select 

the cell by double-clicking or pressing F2. 

Move within the text in the edited cell* 

Left Arrow Move one character to the left 

Right Arrow Move one character to the right 

⌘ Cmd + Left Arrow Move one word to the left 

⌘ Cmd + Right Arrow Move one word to the right 

Arrow Up Move one line up 

Arrow Down Move one line down 

⌘ Cmd + Arrow Up Go to the beginning of the previous paragraph 

⌘ Cmd + Arrow Down Go to the beginning of the next paragraph 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select 

the cell by double-clicking or pressing F2. 

Work with formulas and functions 

⌥ Option + F9 Replace the formula (entirely or partially) with its calculated 

value 
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Keyboard shortcuts Command or action 

⌥ Option + = 
Quick insertion of the SUM function with automatic 

definition of arguments 

 
F9 Recalculate formulas in the entire document 

⇧ Shift + F9 Recalculate formulas on the sheet 

⇧ Shift + ⌘ Cmd + F9 Force recalculate formulas 

⇧ Shift + ⌘ Cmd + F5 Update references to data in external documents 

Other keyboard shortcuts 

⌘ Cmd + N Create a file 

⌘ Cmd + O Open a file 

⌘ Cmd + P 
Open the window for previewing and setting page and 

printing parameters of the document 

⌘ Cmd + 0 (zero) Set the actual page scale (100%) 

⌘ Cmd + K Insert a link 

⌘ Cmd + ⇧ Shift + V Insert a link from the clipboard 

⌘ Cmd + ⇧ Shift + 1 Split the number into digit groups 

⌘ Cmd + F Open the search pane 

⌘ Cmd + T Open the window to create a table 

⌘ Cmd + / Open the Quick action box 

Fn + F1 Open the Help 

Click the right mouse button Open the context menu of the selected element 

⌘ Cmd + Q Close the active application window 

 


