
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

User Guide 

 
© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 



 

 

All product names, logos, and trademarks referred to in this document shall belong to their 

owners. 

The trademark "MyOffice" and «МойОфис» belong to New Cloud Technologies Ltd.  

Nothing in these terms shall be construed under any circumstances as direct or indirect 

provision of a license or right to use the trademarks, logos or service marks used herein.  

Any unauthorized use of these trademarks, logos, or service marks without the written permission 

of their owner is strictly prohibited. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 3 

TABLE OF CONTENTS 

1 About ............................................................................................................................................ 14 

1.1 General information ............................................................................................................... 14 

1.2 System requirements .............................................................................................................. 14 

1.3 Limitations ............................................................................................................................. 15 

1.3.1 Supported file formats ........................................................................................................ 15 

1.3.2 Supported interface languages ............................................................................................ 15 

2 Before you begin .......................................................................................................................... 16 

2.1 Install the application ............................................................................................................. 16 

2.2 Launch the application ........................................................................................................... 19 

2.3 License agreement ................................................................................................................. 20 

2.4 MyOffice Education software update .................................................................................... 21 

3 Interface overview ....................................................................................................................... 22 

3.1 MyOffice Spreadsheet window .............................................................................................. 22 

3.2 Command menu ..................................................................................................................... 23 

3.2.1 File menu ............................................................................................................................ 23 

3.2.2 Edit menu ........................................................................................................................... 26 

3.2.3 Insert menu ......................................................................................................................... 28 

3.2.4 Format menu ....................................................................................................................... 30 

3.2.5 Table menu ......................................................................................................................... 34 

3.2.6 Data menu ........................................................................................................................... 36 

3.2.7 Tools menu ......................................................................................................................... 37 

3.2.8 View menu ......................................................................................................................... 38 

3.2.9 Share menu ......................................................................................................................... 39 

3.2.10 Extensions menu ............................................................................................................... 40 

3.2.11 Help menu ........................................................................................................................ 41 

3.3 Toolbar ................................................................................................................................... 42 

3.3.1 Hide or display Toolbar sections ........................................................................................ 42 

3.3.2 Hide or display sections content ......................................................................................... 43 

3.3.3 Hide or display the Favorites section ................................................................................. 45 

3.3.4 Change the Toolbar display mode ...................................................................................... 46 

3.3.5 Toolbar sections ................................................................................................................. 47 

3.3.5.1 The Favorites section ............................................................................................... 47 

3.3.5.1.1 Add an item ....................................................................................................... 47 

3.3.5.1.2 Move an item .................................................................................................... 49 

3.3.5.1.3 Delete an item ................................................................................................... 49 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 4 

3.3.5.1.4 Clear the section ................................................................................................ 50 

3.3.5.2 File section ............................................................................................................... 51 

3.3.5.3 Edit section............................................................................................................... 53 

3.3.5.4 Font section .............................................................................................................. 55 

3.3.5.5 Alignment section .................................................................................................... 58 

3.3.5.6 Number Format section............................................................................................ 60 

3.3.5.7 Cells section ............................................................................................................. 61 

3.3.5.8 Data section .............................................................................................................. 65 

3.3.5.9 Insert section ............................................................................................................ 66 

3.3.5.10 Pivot Table section ................................................................................................. 68 

3.3.5.11 Chart section .......................................................................................................... 69 

3.3.5.12 Image section ......................................................................................................... 72 

3.3.5.13 Shape section ......................................................................................................... 73 

3.3.5.14 Line section ............................................................................................................ 75 

3.3.5.15 Table section .......................................................................................................... 77 

3.4 Range field ............................................................................................................................. 78 

3.5 Formula bar ............................................................................................................................ 79 

3.6 Workspace .............................................................................................................................. 80 

3.7 Sidebar ................................................................................................................................... 81 

3.8 Sheet tabs ............................................................................................................................... 83 

3.9 Status bar ................................................................................................................................ 84 

3.10 Quick Actions box ............................................................................................................... 85 

3.11 Application language ........................................................................................................... 87 

4 Work with MyOffice Spreadsheet ............................................................................................. 89 

4.1 Actions with files ................................................................................................................... 89 

4.1.1 Create a new file ................................................................................................................. 89 

4.1.1.1 Create a file using File Explorer .............................................................................. 89 

4.1.1.2 Create a file when opening the application .............................................................. 89 

4.1.1.3 Create a file while working in the application ......................................................... 89 

4.1.2 Create a template from a file .............................................................................................. 90 

4.1.3 Create a file from a template .............................................................................................. 91 

4.1.4 Open a file .......................................................................................................................... 92 

4.1.4.1 Open a file in .xls format ......................................................................................... 92 

4.1.4.2 Open read-only files ................................................................................................. 93 

4.1.4.3 Open files used by another application or user .......................................................... 93 

4.1.5 Open a recent file ............................................................................................................... 95 

4.1.6 Open a file in another application ...................................................................................... 96 

4.1.7 Save a file ........................................................................................................................... 97 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 5 

4.1.7.1 Save as ..................................................................................................................... 97 

4.1.7.2 Save .......................................................................................................................... 97 

4.1.7.3 Auto-save and restore a file ..................................................................................... 98 

4.1.8 Send a file via email ........................................................................................................... 99 

4.1.9 Import a file ...................................................................................................................... 100 

4.1.10 Export a file .................................................................................................................... 103 

4.1.11 Print a file ....................................................................................................................... 106 

4.1.11.1 Print a file without entering MyOffice Spreadsheet ............................................ 106 

4.1.11.2 Print a document from MyOffice Spreadsheet .................................................... 106 

4.1.11.2.1 Select the print area ....................................................................................... 106 

4.1.11.2.2 Page Setup and Print window ....................................................................... 112 

4.1.11.2.3 Quick print .................................................................................................... 118 

4.1.12 Close a file ...................................................................................................................... 119 

4.2 Sheets ................................................................................................................................... 120 

4.2.1 Insert a sheet ..................................................................................................................... 120 

4.2.2 Rename a sheet ................................................................................................................. 122 

4.2.3 Hide or unhide a sheet ...................................................................................................... 123 

4.2.4 Duplicate a sheet .............................................................................................................. 123 

4.2.5 Change sheets order .......................................................................................................... 124 

4.2.6 Zoom a sheet .................................................................................................................... 125 

4.2.7 Hide or display zero values .............................................................................................. 126 

4.2.8 Delete a sheet .................................................................................................................... 126 

4.3 Actions with cells, columns, and rows ................................................................................. 127 

4.3.1 Expand the workspace ...................................................................................................... 127 

4.3.2 Select a cell range ............................................................................................................. 128 

4.3.2.1 Select a custom cell range ...................................................................................... 128 

4.3.2.2 Select all cells in a spreadsheet .............................................................................. 129 

4.3.2.3 Deselect cells ......................................................................................................... 129 

4.3.3 Resize cells ....................................................................................................................... 130 

4.3.4 Merge or split cells ........................................................................................................... 132 

4.3.4.1 Merge cells ............................................................................................................. 132 

4.3.4.2 Split cells ................................................................................................................ 134 

4.3.5 Insert rows and columns ................................................................................................... 135 

4.3.5.1 Insert columns ........................................................................................................ 135 

4.3.5.2 Insert rows .............................................................................................................. 137 

4.3.6 Select rows and columns .................................................................................................. 139 

4.3.6.1 Select a row or a column ........................................................................................ 139 

4.3.6.2 Select a range of rows or columns ......................................................................... 140 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 6 

4.3.7 Hide rows and columns .................................................................................................... 141 

4.3.7.1 Hide a row or a column .......................................................................................... 141 

4.3.7.2 Unhide rows and columns ...................................................................................... 142 

4.3.8 Resize rows and columns ................................................................................................. 143 

4.3.8.1 Resize a row or a column manually ....................................................................... 143 

4.3.8.2 Autofit the width .................................................................................................... 144 

4.3.8.3 Specify the exact size ............................................................................................. 146 

4.3.9 Freeze rows, columns, or area .......................................................................................... 146 

4.3.9.1 Freeze columns or rows ......................................................................................... 149 

4.3.9.2 Simultaneously freeze rows and columns .............................................................. 151 

4.3.9.3 Freeze an area ........................................................................................................ 152 

4.3.9.4 Unfreeze rows and columns ................................................................................... 152 

4.3.10 Group rows or columns .................................................................................................. 153 

4.3.11 Delete columns or rows .................................................................................................. 155 

4.4 Data ...................................................................................................................................... 156 

4.4.1 Enter data .......................................................................................................................... 156 

4.4.1.1 Enter data in a cell.................................................................................................. 156 

4.4.1.2 Automatically adjust cell width ............................................................................. 157 

4.4.1.3 Floating cell ........................................................................................................... 157 

4.4.1.4 Fill cells automatically ........................................................................................... 158 

4.4.1.4.1 Fill cells automatically with arithmetic sequences ......................................... 159 

4.4.1.4.2 Fill cells automatically with geometric sequences .......................................... 159 

4.4.1.4.3 Reduce the data range ..................................................................................... 160 

4.4.1.4.4 Autofill cells: basics ........................................................................................ 160 

4.4.1.5 Text formatting of formulas and numbers ............................................................. 162 

4.4.2 Sort and filter .................................................................................................................... 163 

4.4.2.1 Define the Sort and Filter range ............................................................................. 163 

4.4.2.2 Automatic detection of the Sort and Filter range ................................................... 164 

4.4.2.3 Sort ......................................................................................................................... 164 

4.4.2.4 Filter ....................................................................................................................... 165 

4.4.2.5 Copy and insert filtered data .................................................................................. 166 

4.4.2.6 Refresh the filter .................................................................................................... 166 

4.4.2.7 Finishing work with sorting and filtering range .................................................... 167 

4.4.3 Number formats ................................................................................................................ 168 

4.4.3.1 Types of number formats ....................................................................................... 168 

4.4.3.1.1 General ............................................................................................................ 168 

4.4.3.1.2 Number ........................................................................................................... 169 

4.4.3.1.3 Currency .......................................................................................................... 170 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 7 

4.4.3.1.4 Accounting ...................................................................................................... 172 

4.4.3.1.5 Date, Time or Date and Time ......................................................................... 173 

4.4.3.1.6 Percentage ....................................................................................................... 174 

4.4.3.1.7 Fraction ........................................................................................................... 175 

4.4.3.1.8 Scientific ......................................................................................................... 176 

4.4.3.1.9 Text ................................................................................................................. 177 

4.4.3.2 Identify cell format ................................................................................................ 178 

4.4.3.3 Number format settings.......................................................................................... 179 

4.4.3.3.1 Number format settings ................................................................................... 180 

4.4.3.3.2 Currency format settings ................................................................................. 181 

4.4.3.3.3 Accounting format settings ............................................................................. 182 

4.4.3.3.4 Date, Time or Date and Time format settings ................................................. 183 

4.4.3.3.5 Percentage format settings .............................................................................. 184 

4.4.3.4 Increase and decrease decimals ............................................................................. 185 

4.4.4 Check data ........................................................................................................................ 186 

4.4.4.1 Information about working with drop-down lists .................................................. 186 

4.4.4.2 Enter a date ............................................................................................................ 187 

4.4.4.3 Enter a value in a cell with a drop-down list ......................................................... 189 

4.4.5 Remove duplicates ........................................................................................................... 192 

4.4.6 Links ................................................................................................................................. 196 

4.4.6.1 Insert a link to a web page or email address .......................................................... 196 

4.4.6.2 Insert a link to a sheet of the current document ..................................................... 199 

4.4.6.3 Insert a link to a file ............................................................................................... 200 

4.4.6.4 Go to the link ......................................................................................................... 203 

4.4.6.5 Copy a link ............................................................................................................. 204 

4.4.6.6 Edit a link ............................................................................................................... 204 

4.4.6.7 Delete a link ........................................................................................................... 205 

4.4.6.8 Keyboard shortcuts for moving between window elements .................................. 206 

4.4.7 Notes ................................................................................................................................. 206 

4.4.7.1 Add a note .............................................................................................................. 207 

4.4.7.2 Edit or delete a note ............................................................................................... 209 

4.4.8 Special characters ............................................................................................................. 210 

4.4.8.1 Special characters quick insert pane ...................................................................... 210 

4.4.8.2 Special characters window ..................................................................................... 213 

4.4.9 Current date or time .......................................................................................................... 217 

4.4.10 Check grammar and spelling .......................................................................................... 218 

4.4.10.1 Check spelling ...................................................................................................... 219 

4.4.10.1.1 Correct errors ................................................................................................ 220 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 8 

4.4.10.1.2 Turn off the underline for spelling errors ..................................................... 221 

4.4.10.2 Custom dictionary ................................................................................................ 222 

4.4.10.2.1 Adding words to the dictionary ..................................................................... 222 

4.4.10.2.2 Using third-party dictionaries ....................................................................... 224 

4.4.10.2.3 Delete words from the dictionary ................................................................. 225 

4.4.10.3 Grammar checking ............................................................................................... 226 

4.4.11 Find and replace data ...................................................................................................... 227 

4.4.12 Delete data ...................................................................................................................... 231 

4.5 Formulas and functions ........................................................................................................ 232 

4.5.1 Formulas and functions basics ......................................................................................... 232 

4.5.2 Order of operations in a formula ...................................................................................... 233 

4.5.3 Referencing cells and cell ranges ..................................................................................... 234 

4.5.3.1 A1 cell reference style ........................................................................................... 235 

4.5.3.2 R1C1 cell reference style ....................................................................................... 236 

4.5.3.3 Cell range reference ............................................................................................... 238 

4.5.4 Recalculation of formulas ................................................................................................ 239 

4.5.5 Automatic calculation ....................................................................................................... 240 

4.5.6 Enter functions ................................................................................................................. 241 

4.5.7 Replace a formula with its result ...................................................................................... 246 

4.5.8 Copy and insert formulas ................................................................................................. 246 

4.5.9 Names in formulas and functions ..................................................................................... 249 

4.5.9.1 Define name ........................................................................................................... 251 

4.5.9.1.1 Define name with range field .......................................................................... 251 

4.5.9.1.2 Define name using Name Manager ................................................................. 252 

4.5.9.2 Find a name ............................................................................................................ 255 

4.5.9.2.1 Find using the range field ............................................................................... 255 

4.5.9.2.2 Find using the Name Manager ........................................................................ 257 

4.5.9.3 Enter the name in a formula or function ................................................................ 261 

4.5.9.4 View name properties ............................................................................................ 263 

4.5.9.5 Delete a name ......................................................................................................... 265 

4.5.10 Reference to data in another document .......................................................................... 266 

4.5.10.1 Create a reference with a mouse click ................................................................. 266 

4.5.10.2 Enter the reference manually ............................................................................... 267 

4.5.10.3 Update data .......................................................................................................... 270 

4.5.11 Structured references ...................................................................................................... 272 

4.5.11.1 Use structured references ..................................................................................... 272 

4.5.11.2 Structured reference syntax .................................................................................. 273 

4.5.11.3 Enter a structural reference in a formula .............................................................. 274 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 9 

4.5.11.4 Work with “smart” tables..................................................................................... 276 

4.5.11.5 Calculated columns .............................................................................................. 277 

4.5.11.6 Automatic expansion of “smart” tables ............................................................... 278 

4.6 Calculation operators ........................................................................................................... 279 

4.6.1 Arithmetic operators ......................................................................................................... 279 

4.6.2 Comparison operators ....................................................................................................... 280 

4.6.3 Text concatenation operator ............................................................................................. 281 

4.6.4 Reference operators .......................................................................................................... 282 

4.7 Pivot tables ........................................................................................................................... 284 

4.7.1 Create a pivot table ........................................................................................................... 284 

4.7.2 Customize a pivot table .................................................................................................... 288 

4.7.2.1 Open the pivot table settings pane ......................................................................... 289 

4.7.2.2 Configure a pivot table ........................................................................................... 290 

4.7.2.2.1 Add fields ........................................................................................................ 294 

4.7.2.2.2 Move a field from one section to another ....................................................... 296 

4.7.2.2.3 Change the field order in a section ................................................................. 297 

4.7.2.2.4 Edit the function in the Values section ........................................................... 298 

4.7.2.2.5 Delete a pivot table field ................................................................................. 299 

4.7.2.2.6 Edit data source ............................................................................................... 300 

4.7.3 Refresh a pivot table ......................................................................................................... 301 

4.7.4 Delete a pivot table ........................................................................................................... 303 

4.8 Charts ................................................................................................................................... 304 

4.8.1 Insert a chart ..................................................................................................................... 304 

4.8.2 Change chart type ............................................................................................................. 308 

4.8.3 Change data range ............................................................................................................ 311 

4.8.4 Change chart size .............................................................................................................. 311 

4.8.5 Move a chart ..................................................................................................................... 312 

4.8.6 Customize a chart ............................................................................................................. 313 

4.8.7 Copy, cut or insert a chart ................................................................................................ 315 

4.8.8 Delete a chart .................................................................................................................... 315 

4.9 Images .................................................................................................................................. 316 

4.9.1 Insert an image ................................................................................................................. 317 

4.9.1.1 Insert an image from your computer ...................................................................... 317 

4.9.1.2 Insert an image from the browser or another application ...................................... 319 

4.9.2 Resize an image ................................................................................................................ 320 

4.9.3 Move an image ................................................................................................................. 321 

4.9.4 Save an image ................................................................................................................... 322 

4.9.5 Delete an image ................................................................................................................ 323 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 10 

4.10 Shapes ................................................................................................................................ 324 

4.10.1 Insert a line ..................................................................................................................... 324 

4.10.2 Insert a shape .................................................................................................................. 326 

4.10.3 Insert a text box .............................................................................................................. 327 

4.10.4 Fill a shape ...................................................................................................................... 328 

4.10.4.1 Fill a shape with color .......................................................................................... 328 

4.10.4.2 Fill a shape with image ........................................................................................ 329 

4.10.4.3 Remove the fill ..................................................................................................... 330 

4.10.5 Shape outline .................................................................................................................. 330 

4.10.5.1 Set shape outline .................................................................................................. 330 

4.10.5.2 Remove shape outline .......................................................................................... 333 

4.10.6 Line style ........................................................................................................................ 333 

4.10.6.1 Set the line style ................................................................................................... 333 

4.10.6.2 Delete the line style .............................................................................................. 335 

4.10.7 Resize a shape ................................................................................................................ 337 

4.10.8 Fit shape size to text ....................................................................................................... 339 

4.10.9 Change line length and angle ......................................................................................... 340 

4.10.10 Select arrow type .......................................................................................................... 340 

4.10.11 Move a shape ................................................................................................................ 341 

4.10.12 Delete a shape ............................................................................................................... 342 

4.11 Format spreadsheets ........................................................................................................... 343 

4.11.1 Font ................................................................................................................................. 343 

4.11.2 Font size ......................................................................................................................... 345 

4.11.3 Text formatting ............................................................................................................... 347 

4.11.4 Font color ....................................................................................................................... 348 

4.11.5 Highlight color ............................................................................................................... 350 

4.11.6 Alignment ....................................................................................................................... 352 

4.11.7 Rotate text ....................................................................................................................... 353 

4.11.8 Wrap text ........................................................................................................................ 356 

4.11.9 Character spacing ........................................................................................................... 358 

4.11.10 Cell background color .................................................................................................. 360 

4.11.10.1 Cell fill color ...................................................................................................... 360 

4.11.10.2 Remove cell background.................................................................................... 361 

4.11.11 Cell borders .................................................................................................................. 362 

4.11.11.1 Cell border parameters ....................................................................................... 362 

4.11.11.2 Remove cell borders .......................................................................................... 364 

4.11.12 Copy and insert formatting ........................................................................................... 365 

4.11.12.1 Formatting basics ............................................................................................... 366 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 11 

4.11.12.2 Copy and insert formatting ................................................................................ 368 

4.11.12.3 Formatting history .............................................................................................. 370 

4.12 Edit content ........................................................................................................................ 371 

4.12.1 Undo and redo actions .................................................................................................... 371 

4.12.1.1 Undo the last action ............................................................................................. 371 

4.12.1.2 Redo the result of the undone action .................................................................... 372 

4.12.2 Clipboard ........................................................................................................................ 373 

4.12.2.1 Cut or copy data ................................................................................................... 373 

4.12.2.2 Paste the last cut or copied data ........................................................................... 375 

4.12.2.3 Insert data from the clipboard history .................................................................. 378 

4.12.2.3.1 Insert data ...................................................................................................... 378 

4.12.2.3.2 Clear clipboard history .................................................................................. 380 

4.13 Cloud actions ..................................................................................................................... 381 

4.13.1 Enter the Cloud ............................................................................................................... 383 

4.13.2 Open a file ...................................................................................................................... 385 

4.13.3 Create a local copy ......................................................................................................... 388 

4.13.4 Create a file or folder ...................................................................................................... 390 

4.13.5 Upload a file ................................................................................................................... 392 

4.13.6 Download a file or folder ............................................................................................... 393 

4.13.7 Delete a file .................................................................................................................... 395 

4.13.8 Restore a file or folder .................................................................................................... 397 

4.13.9 Shared access to files ...................................................................................................... 398 

4.13.9.1 Share a file ........................................................................................................... 398 

4.13.9.2 Change sharing settings ....................................................................................... 401 

4.13.9.3 Revoke access to files .......................................................................................... 402 

4.13.10 Revoke access to files ................................................................................................... 402 

4.13.11 Exit the Cloud ............................................................................................................... 404 

4.14 Automation tools ................................................................................................................ 405 

4.14.1 Macros ............................................................................................................................ 405 

4.14.1.1 Create a macro ..................................................................................................... 406 

4.14.1.2 Find a macro ........................................................................................................ 412 

4.14.1.3 Run a macro ......................................................................................................... 413 

4.14.1.4 Edit a macro ......................................................................................................... 417 

4.14.1.5 Debug a macro ..................................................................................................... 418 

4.14.1.6 Delete a macro ..................................................................................................... 423 

4.14.1.7 View VBA macro code ........................................................................................ 424 

4.14.2 Extensions ...................................................................................................................... 427 

4.14.2.1 Install an extension .............................................................................................. 427 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 12 

4.14.2.2 Run an extension .................................................................................................. 432 

4.14.2.3 Enable or disable an extension ............................................................................. 433 

4.14.2.4 Update an extension ............................................................................................. 435 

4.14.2.5 Remove an extension ........................................................................................... 439 

4.15 Protect a file ....................................................................................................................... 440 

4.15.1 Protect a file with a password ......................................................................................... 440 

4.15.1.1 Set a password...................................................................................................... 441 

4.15.1.2 Change the password ........................................................................................... 443 

4.15.1.3 Remove the password .......................................................................................... 446 

4.15.1.4 Open a password-protected document ................................................................. 447 

4.15.2 Protect content from changes ......................................................................................... 448 

4.15.2.1 Protect a sheet ...................................................................................................... 448 

4.15.2.2 Protect the document structure............................................................................. 452 

4.15.2.3 Unprotect a sheet.................................................................................................. 454 

4.15.2.4 Unprotect file structure ........................................................................................ 457 

4.16 Links to educational resources ........................................................................................... 460 

Appendix 1. Functions and their description ............................................................................ 461 

SUBTOTAL function ................................................................................................................ 468 

Appendix 2. List of supported currencies .................................................................................. 470 

Appendix 3. Keyboard shortcuts ................................................................................................ 471 

 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 13 

LIST OF ABBREVIATIONS 

The abbreviations used herein are specified in Table 1. 

Table 1. Abbreviations and definitions 

Abbreviation Definition 

OS Operating system 
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1 ABOUT 

1.1 General information 

MyOffice Spreadsheet is an editor for creating spreadsheets, running calculations, analyzing 

data, forming summary reports, and automating data processing using macro commands on Linux, 

Windows, and macOS operating systems. 

MyOffice Spreadsheet is included in the following suites: 

‒ MyOffice Professional 2 

‒ MyOffice Standard 2 

‒ MyOffice Education 

 

For a detailed description of the application features, please refer to your product-specific 

Feature list. 

 

The application functionality may vary depending on the product and operating system. 

 

1.2 System requirements 

For a list of software and hardware requirements, please refer to your product's 

Installation Guide. 
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1.3 Limitations 

1.3.1 Supported file formats 

Table 2 contains a list of formats supported by MyOffice Spreadsheet. 

Table 2. Supported file formats 

If you want to... Supported file formats 

Open or import files .xls, .xlsx, .ods, .xods, .csv, .scsv, .tsv, .tab, .txt, .xlsm, .xots 

Save files .xlsx, .ods,. xods 

Export files .pdf, .pdf/a-1, .csv, .tab, .scsv, .tsv, .txt, .xots 

 

 

 

Opening/importing .xls files is not available on macOS. 

1.3.2 Supported interface languages 

‒ English 

‒ French 

‒ Russian 
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2 BEFORE YOU BEGIN 

2.1 Install the application 

The installation procedure for MyOffice solutions is described in the document 

MyOffice Text, MyOffice Spreadsheet, MyOffice Presentation desktop applications. Installation 

Guide. 

If you installed MyOffice solutions on Windows OS according to the procedure described in 

Section 2.2 of the above-mentioned document and you see the shortcuts shown on Figure 1 and 

Figure 2 on your desktop and in the main menu of the OS, that means you’ve successfully installed 

MyOffice Spreadsheet: 

 

Figure 1. MyOffice desktop shortcuts for Windows OS 

 

Figure 2. MyOffice Start menu shortcuts for Windows OS 
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MyOffice software for Linux is considered installed if, as a result of the actions described 

in Section 2.3 of the above-mentioned document, the OS applications menu displays the shortcuts 

shown in Figure 3. 

 

Figure 3. MyOffice desktop shortcuts for Linux OS 
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MyOffice for macOS is considered installed is considered installed if, as a result of 

the actions described in Section 2.4 of the above-mentioned document the Launchpad displays 

the icons shown in Figure 4: 

 

Figure 4. Applications icons in Launchpad 
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2.2 Launch the application 

To launch MyOffice Spreadsheet, double-click its icon or shortcut. 
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2.3 License agreement 

When you run MyOffice software for the first time, carefully read the terms of 

the License Agreement and Privacy Policy (see Figure 5). If you agree with the terms, click Accept. 

 

Figure 5. Terms of Use and Privacy Policy window 
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2.4 MyOffice Education software update 

To ensure timely update of MyOffice Education software on Windows, it is recommended 

to enable automatic checking for new versions. 

To automatically check for new versions, do the following: 

1. After the first launch of MyOffice Text and/or MyOffice Spreadsheet applications, close 

them and open any of these applications again. 

2. In the Application Update window (see Figure 6), click Check automatically. 

 

Figure 6. Application Update window 

If you want to disable the automatic search for new versions, click Don't check. 

You can also check for new versions manually. To do this, in the command menu, select 

Help > Check for Updates (see Section 3.2.11). 

For detailed steps to update the product, please refer to MyOffice Text, MyOffice Spreadsheet, 

MyOffice Presentation desktop applications. Installation Guide. 
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3 INTERFACE OVERVIEW 

3.1 MyOffice Spreadsheet window 

The MyOffice Spreadsheet window consists of the following elements (see Figure 7): 

1. Command menu 

2. Toolbar 

3. Range field 

4. Formula bar 

5. Workspace 

6. Sidebar 

7. Sheet tabs 

8. Status bar 

  

Figure 7. Main window of MyOffice Spreadsheet 
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3.2 Command menu 

3.2.1 File menu 

The File menu contains the following commands (see Figure 8): 

 

Figure 8. File menu 

1. New: Create a new file (see Section 4.1.1). 

2. New from Template: Create a new file using a template file (.xots file) from your 

computer or removable media connected to your computer (see Section 4.1.3). 

3. Open: Open an existing file by indicating its location on your computer or removable 

media connected to your computer (see Section 4.1.4). 

4. Open in Cloud: Open a document from the Cloud in the collaborative editing mode  

(see Section 4.13.2). 

5. Open With: Open the current document in another spreadsheet editor 

(see Section 4.1.6). 

6. Recent Files: Open or clear a list of recently opened files (see Section 4.1.5). 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 24 

7. Cloud Actions (see Figure 9): 

‒ Log in: Log in to the Cloud (see Section 4.13.1). 

‒ Download: Save files from the Cloud to the user’s computer  

(see Section 4.13.6). 

‒ File Upload: Upload a file to the Cloud to the user’s computer  

(see Section 4.13.5). 

 

Figure 9. Cloud Actions sub-menu 

8. Save1F: Save a file in the default folder without changing its name or location 

(see Section 4.1.7). 

9. Save As: Save a file and change its name, extension, or path, if needed 

(see Section 4.1.7). 

 

The Save and Save As commands are not displayed in cloud files, since 

documents are saved automatically when working in the Cloud. 

 

10. Create Local Copy: Create a copy of the file being edited in the Cloud on the user's 

computer (see Section 4.13.3). When working with local files this command menu item 

is not displayed. 

11. Export To: Export a file in a format supported by MyOffice applications (.pdf, .pdf/a-1, 

.csv, .tsv, .tab, .scsv) and change its name, extension, or path, if needed  

(see Section 4.1.10). 

12. Save as Template: Save the current document as a .xots template and use it when you 

want to create similar documents in the future (see Section 4.1.2). 

13. Set Password: Set a password to protect a document (see Section 4.1.11.1). 
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14. Digital Signature: This functionality is intended for use only on the territory of 

the Russian Federation. 

15. Page Setup and Print: Set up layout and print options of a page  

(see Section 4.1.12). 

16. Close: Close the active application window (see Section 4.1.13). 
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3.2.2 Edit menu 

The Edit menu contains the following commands (see Figure 10): 

 

Figure 10. Edit menu 

1. Undo: Undo the last action performed in the document (see Section 4.12.1.1). 

2. Redo: Redo the result of the last undone action (see Section 4.12.1.2). 

3. Cut: Put the selected data to the OS clipboard and remove it from the spreadsheet 

(see Section 4.4.1.5). 

4. Copy: Put the selected data to the OS clipboard without removing it from 

the spreadsheet (see Section 4.4.1.5). 

5. Paste: Paste the data from the OS clipboard while keeping its original formatting 

(see Section 4.4.1.6). 

6. Paste Values and Format: Paste the content of the OS clipboard without saving 

the original formatting (see Section 4.5.8). 

7. Paste Values Only: Paste the OS clipboard data without keeping its original formatting 

(see Section 4.11.12.2). 

8. Paste from Clipboard: Paste the data from the clipboard (see Section 4.12.2.3). 

9. Copy Formatting: Copy the formatting of the selected text to the OS clipboard 

(see Section 4.11.12.2). 
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10. Paste Formatting: Apply the formatting from the OS clipboard to the selected text 

(see Section 4.11.12.2). 

11. Select All: Select all cells of a spreadsheet (see Section 4.2.2.2). 

12. Find: Find or replace the specified text throughout the document (see Section 4.4.6).  
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3.2.3 Insert menu 

The Insert menu contains the following commands (see Figure 11): 

1. Image: Insert an image in a spreadsheet (see Section 4.9.1). 

2. Text Box: Insert a text box in a spreadsheet (see Section 4.10.2) 

3. Shape: Insert a shape in a spreadsheet (see Section 4.10.1). 

 

Figure 11. Insert menu 

4. Chart: Insert a chart in a spreadsheet (see Figure 12 and Section 4.8). 

 

Figure 12. Chart sub-menu 
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5. Pivot Table: Insert a pivot table (see Section 4.7.1). 

6. Function: Insert a function (see Section 4.5.6). 

7. Special Characters: Insert a special character (see Section 4.4.7). 

8. Link: Insert a link (see Section 4.4.6). 

9. Note: Write a comment and add it to a selected cell (see Section 4.4.7.1). 

10.  Sheet: Insert a new sheet in a spreadsheet (see Section 4.2.1). 

11. Current Date: Insert the current date in the text (see Section 4.4.9). 

12. Current Time: Insert the current time in the text (see Section 4.4.9). 
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3.2.4 Format menu 

The Format menu contains the following commands (see Figure 13): 

 

Figure 13. Format menu 

1. Font: Select the font style and size (see Section 4.11.2 and 4.11.3) and the character 

spacing (see Section 4.11.9). Selecting the Font menu displays a sub-menu with 

the following items (see Figure 14): 

 

Figure 14. Font sub-menu 

‒ Bold: Change the font style in the selected cell for bold. 

‒ Italic: Change the font style in the selected cell for italic. 

‒ Underline: Change the font style in the selected cell for underline. 

‒ Decrease Font Size: Decrease the font size by one point. 
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‒ Increase Font Size: Increase the font size by one point. 

‒ Strikethrough: Change the font style in the selected cell for strikethrough. 

‒ Superscript: Convert the selected text into superscript. 

‒ Subscript: Convert the selected text into subscript. 

‒ All Caps: Capitalize all letters in the selected text. 

‒ Character Spacing: Select the character spacing you want to apply to your text 

(condensed, normal, or expanded). 

2. Alignment: Align the selected text (see Section 4.11.6). Selecting the Alignment menu 

displays a sub-menu with the following items (see Figure 15): 

 

Figure 15. Alignment sub-menu 

‒ Align Text Left: Align the content of the selected cell to the left. 

‒ Center Text: Align the content of the selected cell to the center. 

‒ Align Text Right: Align the content of the selected cell to the right. 

‒ Justify Text: Fit the content of the selected cell to the cell's width. 

‒ Align Text to Top: Align the content of the selected cell to the top of the cell. 

‒ Align Text to Middle: Align the content of the selected cell to the middle of the cell. 

‒ Align Text to Bottom: Align the content of the selected cell to the bottom of 

the cell. 
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3. Rotate Text: Rotate text in a cell at an angle ranging from -90 to 90 degrees or place it 

vertically (see Figure 16 and Section 4.11.7).  

 

Figure 16. Text rotation sub-menu 

4. Number Format: Open the number format settings window (see Section 4.4.2.4). 
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5. Print Area: Specify the sheet area to print (see Section 4.1.12.1.2). Selecting this 

command opens a sub-menu with the following commands (see Figure 16): 

 

Figure 17. Print area sub-menu 

‒ Print area borders: Hide or display the borders of the printable area. The command 

is active if the current sheet has a defined printable area. 

‒ Define print area: Set the area selected on the sheet as the print area. 

‒ Clear print area: Cancel the Define print area command. The command is active 

if the print area is set for the current sheet. 

6. Save Image: Save an image on the computer (see Section 4.9.4). 
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3.2.5 Table menu 

The Table menu contains the following commands (see Figure 18): 

 

Figure 18. Table menu 

1. Insert Row Above: Insert a new row above the selected row  

(see Section 4.2.5.7). 

2. Insert Row Below: Insert a new row below the selected row (see Section 4.2.5.7). 

3. Insert Column to the Left: Insert a new column to the left of the selected column 

(see Section 4.2.5.6). 

4. Insert Column to the Right: Insert a new column to the right of the selected column 

(see Section 4.2.5.6). 

5. Delete Row: Delete the selected row (see Section 4.3.11). 

6. Delete Column: Delete the selected column (see Section 4.3.11). 

7. Hide Row: Hide the selected row (see Section 4.3.7.1). 

8. Unhide Row: Unhide a previously hidden row (see Section 4.3.7.2). 
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9. Hide Column: Hide the selected column (see Section 4.3.7.1). 

10. Unhide Column: Unhide a previously hidden column (see Section 4.2.5.5). 

11. Merge Cells: Merge the selected cells into one cell (see Section 4.2.3.1). 

12. Split Cells: Split previously merged cells to return them to the original layout 

(see Section 4.2.3.2). 

13. Cell Size: Change the size of the selected cells (see Section 4.3.3). 

14. Wrap Text: Enable or disable word wrapping inside the selected cell or cell group 

(see Section 4.11.7). 

15. Freeze Selected Rows and Columns: Selecting this menu displays a sub-menu with 

the following items (see Figure 18): 

‒ Freeze Horizontally: Freeze the selected rows (see Section 4.2.5.8.1). 

‒ Freeze Vertically: Freeze the selected columns (see Section 4.2.5.8.1). 

‒ Unfreeze All: Unfreeze all rows, columns, and areas (see Section 4.2.5.8.4). 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 36 

3.2.6 Data menu 

The Data menu contains the following commands (see Figure 19): 

 

Figure 19. Data menu 

1. Define Name: Assign a name to a cell, range, constant or formula (see Section 4.5.9.1). 

2. Manage Protection: Protect or unprotect the selected sheet or document structure from 

changes (see Section 4.15.2). 

3. Refresh Pivot Table: Refresh a pivot table (see Section 4.7.3). 

4. Pivot Table Settings: Open the pivot table settings pane (see Section 4.7.2). 

5. Delete Pivot Table: Delete a pivot table (see Section 4.7.4). 

6. Group Rows: Group the selected rows (see Section 4.3.10). 

7. Group Columns: Group the selected columns (see Section 4.3.10). 

8. Clear Grouping: Delete the grouping of the selected rows or columns  

(see Section 4.3.10). 

9. Remove Duplicates: Delete repetitive data (see Section 4.4.5). 

10. Force Calculate: Recalculate formulas in .xlsx format document (see Section 4.5.4). 

11. Refresh Data: Update references to data in external documents (see Section 4.5.10.3). 
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3.2.7 Tools menu 

The Tools menu contains the following commands (see Figure 20): 

 

Figure 20. Tools menu 

1. Spelling & Grammar: Enable spell (see Section 4.4.5.1) or grammar check 

(see Section 4.4.5.3). 

2. Custom Dictionary: Open a custom dictionary (see Section 4.4.5.2). 

3. Change Language: Change the application language (see Section 3.11). 

4. Macros: Opening this menu will open a sub-menu with the following commands 

(see Figure 21): 

‒ Macro Editor: Open the macro editor (see Section 4.14.1). 

‒ Record Macro (beta): Record a macro (see Section 4.14.1.1). 

 

Figure 21. Macros sub-menu 
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3.2.8 View menu 

The View menu contains the following commands (see Figure 22): 

 

Figure 22. View menu 

1. Zoom: Adjust page zoom settings (see Section 4.3.6). 

2. R1C1: Use the R1C1 reference style (see Section 4.2.4.2). 

3. Toolbar: Display or hide the names of the Toolbar sections (see Section 3.3).  

Selecting this menu will open a sub-menu with the following commands  

(see Figure 23): 

 

Figure 23. Toolbar sub-menu 

‒ Regular: Display the standard Toolbar. 

‒ Compact: Display the compact Toolbar. 

‒ Hide Toolbar: Hide the Toolbar. 

‒ Section Titles: Display or hide the Toolbar section titles. 

‒ Favorites: Hide or display the Favorites section. 
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3.2.9 Share menu 

The Share menu contains the following commands (see Figure 24): 

 

Figure 24. Share menu 

1. Sharing Settings: Configure the access to the files in the Cloud (see Section 4.13.9). 

2. Send File: Send the file being edited by email (see Section 4.1.8). This command is not 

available in macOS. 

 

The Cloud and collaborative editing functions are available with the MyOffice 

Professional / MyOffice Private Cloud server part. 
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3.2.10 Extensions menu 

The Extensions menu contains (see Figure 25 and Section 4.13.2): 

 

Figure 25. Extensions menu 

1. A list of installed extensions. 

2. The Extension manager sub-menu: Open the Extension manager window. 

For more details, see Section 4.13.2. 
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3.2.11 Help menu 

The Help menu contains the following commands (see Figure 26): 

 

Figure 26. Help menu 

1. Help: Access help materials on the spreadsheet editor. 

2. Quick Actions: Open the Quick Actions box (see Section 3.8). 

3. Check for Updates: Check if any updates are available for MyOffice Education 

application (for more information, refer to MyOffice Text, MyOffice Spreadsheet, 

MyOffice Presentation Desktop Applications. Installation Guide). 

4. About: Display information about the program (see Figure 27). 

 

Figure 27. About window 
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3.3 Toolbar 

In MyOffice Spreadsheet, you can change the way the Toolbar is displayed: 

‒ By hiding or displaying the titles and the content of the Toolbar sections. 

‒ By displaying or hiding the Favorites sections. 

‒ By selecting the Toolbar display mode or by hiding the Toolbar. 

 

3.3.1 Hide or display Toolbar sections 

In MyOffice Spreadsheet, the Toolbar (see Figure 28) has several sections. Each section 

(except Favorites) consists of various tools to perform the specific task. For example, the Number 

section contains tools to edit cell formats. 

 

Figure 28. Toolbar 

The title of each section is displayed if the Toolbar display type is Regular 

(see Section 3.3.4). Toolbar titles can be hidden to optimize your workspace. To do this, do 

the following: 

1. Select View > Toolbar (see Figure 29). 

2. In the sub-menu that opens, uncheck the Section Titles menu. 

 

Figure 29. View command menu 

To display the section titles, check the menu again. 
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If the Toolbar is hidden or displayed in the compact form, the Section Titles menu is 

disabled. 

 

3.3.2 Hide or display sections content 

Toolbar sections can be collapsed automatically (when reducing/increasing the size of 

the main application window), or manually. 

To collapse a Toolbar section manually, hover the cursor over its right border and click 

the  button (see Figure 30). 

 

Figure 30. Section collapse button 
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To display the tools of a hidden section, click it with the mouse (see Figure 31). 

 

Figure 31. Section tools 

To collapse the section, click the  button (see Figure 32). 

 

Figure 32. Button to display section tools 
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3.3.3 Hide or display the Favorites section 

By default, the Toolbar displays the Favorites section. 

To hide the section, do one of the following: 

‒ In the Command menu, select View > Toolbar and in the sub-menu that opens uncheck 

the Favorites check box (see Figure 33). 

 

Figure 33. View menu 

‒ If the Favorites section is empty, hover your mouse over the  Add button and click  

in its upper-right corner (see Figure 34). 

 

Figure 34. Favorites section 

To display the section, re-select the Favorites check box in the Command menu. 

 

The Favorites check box is locked if the Toolbar is hidden. 
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3.3.4 Change the Toolbar display mode 

To change the Toolbar display mode, do the following: 

1. In the Command menu, select View > Toolbar. 

2. In the sub-menu that opens, select the desired display mode: 

‒ Regular: Tools are arranged in two lines; the section titles are displayed. If necessary, 

the toolbar section titles can be hidden (see Section 3.3.1). 

‒ Compact: Tools are arranged in one line; section titles are not displayed. 

‒ Hide Toolbar: The Toolbar is not displayed. 

 

To quickly switch between the Regular and the Compact mode, use  

the  Collapse Toolbar (see Figure 35) /  Expand Toolbar (see Figure 36) buttons located in 

the right part of the Toolbar. 

 

Figure 35. Compact view button 

 

Figure 36. Regular view button 
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3.3.5 Toolbar sections 

3.3.5.1 The Favorites section 

As a rule, when working with an application, certain Command menu items and Toolbar 

buttons are used more often than others. These items can be added to the Favorites section of 

the Toolbar so that they are always at hand. 

3.3.5.1.1 Add an item 

You can add from 1 to 14 items to Favorites. 

To add a Command menu item to Favorites, follow these steps: 

1. Run the add command in one of the following ways: 

‒ If the Favorites section is empty, click the  Add button in it (see Figure 37). 

 

Figure 37. Add button 

‒ If the Favorites section contains the added items, right-click anywhere in the section 

and run the Add Action context menu command (see Figure 38). 

 

Figure 38. Add Action command 

2. In the window that opens (see Figure 39), select the Command menu item that you want 

to add to Favorites. 
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Figure 39. Window for adding Command menu items 

To add a button from the Toolbar to Favorites, right-click on it and run the Add to Favorites 

command (see Figure 40). 

 

Figure 40. Add to Favorites command 
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Currently, it is not possible to add Toolbar buttons that are displayed after clicking  

the  button. 

When added to Favorites, the button is not removed from the Toolbar section in which it 

is located. 

3.3.5.1.2 Move an item 

To change the position of an item in the Favorites section, follow these steps: 

1. Right-click the item to open the context menu (see Figure 41). 

2. In the context menu, select the desired command: 

‒ Move to Beginning: Make the selected item the first in the section. 

‒ Move Left: Swap the selected and previous element. 

‒ Move Right: Swap the selected and subsequent element. 

‒ Move to End: Make the selected item the last in the section. 

 

Figure 41. Commands to move an item 

3.3.5.1.3 Delete an item 

To delete a Command menu item from the Favorites section, right-click it and run 

the Remove from Favorites command (see Figure 41). 
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To remove a Toolbar button from the Favorites section, follow these steps: 

1. Right-click it in the Favorites section or in the section from which it was added 

(see Figure 42). 

2. Run the Remove from Favorites context menu command. 

 

Figure 42. Remove from Favorites command 

3.3.5.1.4 Clear the section 

To remove all items from the Favorites section, right-click anywhere in the section and run 

the Clear context menu command (see Figure 41). 
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3.3.5.2 File section 

The File section contains the following buttons (see Figure 43): 

 

Figure 43. File section 

1.  Save: Save changes in the current file. Clicking the arrow to the right of the button 

will open a drop-down list with the following commands (see Figure 

44 and Section 4.1.7): 

 

Figure 44. Save commands 

‒ Save: Save changes in the current document. 

‒ Save as: Save a new file or create a copy of the current file. 
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2.  Quick Print: Print a document using the default settings. Clicking the button 

to the right of the button will open a drop-down list with the following commands  

(see Figure 45): 

 

Figure 45. Print command 

‒ Quick Print: Print the document using the default settings 

(see Section 4.1.12.3). 

‒ Page Setting and Print: Configure the settings and print the document 

(see Section 4.1.12.2). 

‒ Export to PDF: Save the file in the PDF or PDF/A-1 format 

(see Section 4.1.10). 
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3.3.5.3 Edit section 

The Edit section contains the following buttons (see Figure 46): 

 

Figure 46. Edit section 

1.  Cut: Place the selected data to the OS clipboard and delete it from the document 

(see Section 4.4.1.5). 

2.  Copy: Place the selected data to the OS clipboard without deleting it from 

the document (see Section 4.4.1.5). 

3.  Paste: Paste the data from the OS clipboard while preserving the original formatting. 

Clicking the arrow to the right of the button opens a drop-down list with the following 

commands (see Figure 47): 

 

Figure 47. Paste commands 
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‒ Paste: Paste the OS clipboard data and keep the original formatting 

(see Section 4.4.1.6). 

‒ Paste Values and Format: Insert the result of formula calculation while preserving 

the original formatting (see Section 4.5.6). 

‒ Paste Values Only: Insert data from the OS clipboard without saving the original 

formatting (see Section 4.4.1.7). 

4.  Undo: Undo the last action performed in the document (see Section 4.12.1.1). 

5.   Redo: Redo the result of the last undone action (see Section 4.12.1.2) 

6.  Copy Formatting: Copy the formatting of the selected text fragment to the OS 

clipboard. Clicking the arrow to the right of the button opens a drop-down list with 

the previously copied formatting (see Figure 48 and Section 4.11.12.3): 

 

Figure 48. Formatting copied earlier 
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3.3.5.4 Font section 

The Font section contains the following tools (see Figure 49): 

 

Figure 49. Font section 

1. : Apply the selected font to the selected text (see Section 4.11.1). 

2. : Change the font size of the selected text according to the new value selected 

(see Section 4.11.2). 

3.  Decrease Font Size: Decrease the font size of the selected text by one point 

(see Section 4.11.2). 

4.  Increase Font Size: Increase the font size of the selected text by one point 

(see Section 4.11.2). 

5.  Bold: Change the font style of the selected text for bold (see Section 4.11.3). 

6.  Italic: Change the font style in the selected text for italic (see Section 4.11.3). 

7.  Underline: Change the font style in the selected text for underline 

(see Section 4.11.3). 

8.  All Caps: CAPITALIZE all letters in the selected text (see Section 4.11.3). 

9.  Strikethrough: Change the font style in the selected cell for strikethrough 

(see Section 4.11.3). 
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10.  Other Formatting Options: If selected, this menu displays a sub-menu containing 

the following options (see Figure 50 and Section 4.11.3): 

‒  Subscript: Convert the selected text into subscript. 

‒  Superscript: Convert the selected text into superscript. 

 

Figure 50. Other Formatting Options button 

‒  Condensed: Set the condensed character spacing for the selected text. 

‒  Normal: Set the normal character spacing for the selected text. 

‒  Expanded: Set the expanded character spacing for the selected text. 

 

11.  Font Color: Apply the selected font color to the selected text  

(see Figure 51 and Section 4.11.4). 

 

Figure 51. Font color 
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12.  Highlight Color: Highlight the selected text with the selected color as if you were 

using a highlighter pen (see Figure 52 and Section 4.11.5). 

 

Figure 52. Text highlight color  
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3.3.5.5 Alignment section 

The Alignment section contains the following buttons (see Figure 53): 

 

Figure 53. Alignment section 

1.  Align Text Left: Align the content of the selected cell to the left (see Section 4.11.6). 

2.  Center Text: Align the content of the selected cell to the center (see Section 4.11.6). 

3.  Align Text Right: Align the content of the selected cell to the right 

(see Section 4.11.6). 

4.  Justify Text: Fit the content of the selected cell to the cell's width 

(see Section 4.11.6). 

5.   Align Text to Top: Align the content of the selected cell to the top of the cell 

(see Section 4.11.6). 

6.   Align Text to Middle: Align the content of the selected cell to the middle of the cell 

(see Section 4.11.6). 

7.   Align Text to Bottom: Align the content of the selected cell to the bottom of the cell 

(see Section 4.11.6). 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 59 

8.  Rotate text: Rotate the text in the cell at an angle from -90 to 90 degrees or place 

it vertically (see Figure 54 and Section 4.11.7). 

 

Figure 54. Rotate text button 

9.  Wrap Text: Enable word wrapping inside the selected cell to fit its width 

(see Section 4.11.8). 
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3.3.5.6 Number Format section 

The Number Format section contains the following buttons (see Figure 55): 

 

Figure 55. Number Format section 

1.  Number Format: Select the format for the selected cells  

(see Section 4.4.3.2). 

2.  Currency: Display the content of the selected cells in the Currency format 

(see Section 4.4.3.1.3). 

3.  Percentage: Display the content of the selected cells in the Percentage format 

(see Section 4.4.3.1.6). 

4.  Decrease Decimals: Decrease the number of characters displayed after 

the dot (.) delimiter in decimal numbers in the selected cells (see Section 4.4.3.4). 

5.  Increase Decimals: Increase the number of characters displayed 

after the dot (.) delimiter in decimal numbers in the selected cells (see Section 4.4.3.4). 
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3.3.5.7 Cells section 

The Cells section contains the following buttons (see Figure 56): 

 

Figure 56. Cells section 

1.   Cell Background Color: Select the color to fill the selected cell  

(see Figure 57 and Section 4.11.10). 

 

Figure 57. Fill Color button 

2.  Merge Cells: Merge or split the selected cells (see Section 4.3.4). 
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3. : Customize cell or range borders (displayed or hidden, line type and color)  

(see Figure 58 and Section 4.11.11). 

 

Figure 58. Customizing cell borders 

4.  Cell Size: Change the size of the selected cells (see Section 4.3.3). 

5.  Insert Row Above: Insert a new row above the selected row (see Section 4.3.5.2). 

6.  Insert Row Below: Insert a new row below the selected row (see Section 4.3.5.2). 

7.  Insert Column to the Left: Insert a new column to the left of the selected column 

(see Section 4.3.5.1). 
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8.  Insert Column to the Right: Insert a new column to the right of the selected column 

(see Section 4.3.5.1). 

9.  Delete Column: Delete the selected column (see Section 4.3.11). 

10.  Delete Row: Delete the selected row (see Section 4.3.11). 

11.  Freeze Selected Rows and Columns: Lock or unlock rows or columns in place. 

Clicking this button will display a sub-menu containing the following options 

(see Figure 59 and Section 4.3.9): 

 

Figure 59. Manage frozen elements 

‒ Freeze Horizontally: Freeze the selected rows. 

‒ Freeze Vertically: Freeze the selected columns. 

‒ Freeze Selected Rows and Columns: Freeze both the selected rows and columns. 

‒ Freeze Area: Freeze the area where A1 is the top left cell and the bottom right cell 

is specified by you. 

‒ Unfreeze All: Unfreeze all rows and columns. 
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12.  Group: Group the selected rows or columns.  

Clicking the arrow to the right of this button will display a sub-menu containing 

the following options (see Figure 60 and Section 4.3.10): 

 

Figure 60. Grouping 

‒ Group Rows: Group the selected rows. 

‒ Group Columns: Group the selected columns. 

‒ Clear Grouping: Cancel grouping of all rows and columns. 
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3.3.5.8 Data section 

The Data section contains the following buttons (see Figure 61): 

 

Figure 61. Data section 

1.  Sort and Filter: Allows to identify the range of data for sorting and filtering 

(see Section 4.4.2). 

2.  Remove Duplicates: Delete repetitive data (see Section 4.4.5). 

3.  Refresh Data: Update references to data in external documents  

(see Section 4.5.10.3). 
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3.3.5.9 Insert section 

The Insert section contains the following buttons (see Figure 62):  

 

Figure 62. Insert section 

1.  Chart: Insert a chart (see Section 4.8.1). 

2.  Pivot Table: Insert a pivot table (see Section 4.7.1). 

3.  Image: Insert an image (see Section 4.9.1). 

4.  Special Characters: Insert a special character (see Section 4.4.8). 

5.  Insert: Clicking this button opens the insert pane, which contains the following 

buttons (see Figure 63): 

 

Figure 63. Insert pane 
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‒  Image: Insert an image (see Section 4.9.1). 

‒  Text Box: Insert a text box (see Section 4.10.3). 

‒  Shape: Insert a shape (see Section 4.10.2). 

‒  Chart: Insert a chart (see Section 4.8.1). 

‒  Pivot Table: Insert a pivot table (see Section 4.7.1). 

‒  Function: Insert a function (see Section 4.5.6). 

‒  Special Characters: Insert a special character (see Section 4.4.8). 

‒  Link: Insert a link (see Section 4.4.6). 

‒  Note: Insert a written note to the selected cells (see Section 4.4.7.1). 

‒  Sheet: Insert a new sheet into the document (see Section 4.2.1). 

‒  Current Date: Insert the current date (see Section 4.4.9). 

‒  Current Time: Insert the current time (see Section 4.4.9). 
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3.3.5.10 Pivot Table section 

If you select a pivot table or one or multiple cells of the pivot table range in your document 

(see Section 4.7), the Toolbar will display the Pivot Table section with the following buttons  

(see Figure 64): 

 

Figure 64. Pivot Table section 

1.  Refresh: Update a pivot table (see Section 4.7.3). 

2.  Settings: Open the pivot table settings pane (see Section 4.7.2). 

3.  Delete Pivot Table: Delete a pivot table (see Section 4.7.4). 
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3.3.5.11 Chart section 

If you select a chart in the document, (see Section 4.8), the Toolbar will display the Chart 

section which contains the following buttons (see Figure 65): 

 

Figure 65. Chart section 

1.  Column Chart: Select your preferred type of the column chart (see Figure 66): 

 

Figure 66. Column chart 
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2.  Bar Chart: Select your preferred type of the bar chart 

(see Figure 67): 

 

Figure 67. Bar chart 

3.  Pie Chart: Create a pie chart. 

4.  Line Chart: Select your preferred type of the line chart (see Figure 68): 

 

Figure 68. Line chart 
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5.  Area Chart: Select you preferred type of the area chart (see Figure 69): 

 

Figure 69. Line chart 

1.  Settings: Open the Chart settings menu for the selected chart type. 

2.   Delete: Delete the selected chart. 
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3.3.5.12 Image section 

If you select an image in the document, (see Section 4.9), the Toolbar will display 

the Image section (see Figure 70). 

The section contains the  Delete Image button (see Section 4.9.5). 

 

Figure 70. Image section 
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3.3.5.13 Shape section 

If you select a shape in the document (see Section 4.10), the Toolbar will display 

the Shape section (see Figure 71). 

 

The Shape section contains the following buttons: 

 

Figure 71. Shape section 

1.  Fill Color: Fill the shape with a color or image (see Figure 72 and Section 4.10.4). 

 

Figure 72. Fill Color button 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 74 

2.  Outline: Define the color, thickness, and type of the shape outline 

(see Figure 73 and Section 4.10.5). 

 

Figure 73. Outline button 

3.  Autofit: Fit the shape height to match the text in the shape (see Section 4.10.8). 

4.  Delete Shape: Delete the shape (see Section 4.10.12). 
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3.3.5.14 Line section 

When you insert or select a line, the Toolbar displays the Line section, which contains 

the following tools (see Figure 74): 

 

Figure 74. Line section 

1.  Arrow Type: Select the type of line tips (see Figure 75 and Section 4.10.10). 

 

Figure 75. Arrow Type button 
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2.  Outline: Configure the color, thickness and type of line 

(see Figure 76 and Section 4.10.6). 

 

Figure 76. Outline button 

3.  Delete Line: delete a line (see Section 4.10.12). 
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3.3.5.15 Table section 

If a smart table element or the whole smart table is selected in the document 

(see Section 4.5.7), the Toolbar displays the Table section (see Figure 77). 

This section displays the name of the smart table. 

 

Figure 77. Table section 
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3.4 Range field 

The range field allows to do the following: 

‒ Display the address (see Figure 78 and Section 4.5.3) or name 

(see Figure 79 and Section 4.5.9) of the selected cell or cell range. 

‒ Create new names of cells/cell ranges (see Section 4.5.9.1.1). 

 

Figure 78. Cell range address 

 

Figure 79. Cell range name 
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3.5 Formula bar 

The Formula bar displays the real contents of the selected cell.  

For example, A1 cell (see Figure 80) displays and contains number 1. A2 cell displays and contains 

the number 2. A3 cell displays the number 3 but contains a formula whose result is 3. 

 

Figure 80. A1 cell content on the Formula bar 

 

Figure 81. A2 cell content on the Formula bar 

 

Figure 82. A3 cell content on the Formula bar 
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3.6 Workspace 

The workspace (see Figure 83) is the active area of the sheet, within which user actions are 

performed. If necessary, the boundaries of the workspace can be expanded (see Section 4.3.1). 

 

Figure 83. Sidebar 
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3.7 Sidebar 

The Sidebar displays the following buttons (see Figure 84): 

 

Figure 84. Sidebar 

‒  Education: Open the educational resource links pane (see Section 4.16). The button 

is displayed when you work with the MyOffice Spreadsheet application included in 

MyOffice Education suite. 

‒  Find and Replace: Open the Find and Replace pane (see Section 4.4.6). 

‒  Insert Function: Open the Insert function pane (see Section 4.5.3). 

‒  Pivot Table: Open the pivot table settings pane (see Section 4.7). The button 

is displayed when a pivot table element is selected. 
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‒  Macros: Open a pane to work with macros (see Section 4.13.1). This button 

is displayed if the file contains at least one macro. 

‒  Name Manager: Open the Name Manager (see Section 4.5.9). 

‒  Manage Protection: Open the file protection management pane (see Section 4.15.2). 

 

Avatars of collaborators are displayed on the Sidebar (see Section 4.12.2) if the document 

is opened from the Cloud and is being worked on by multiple users simultaneously. 

 

The Cloud and collaborative editing functions are available with the MyOffice 

Professional / MyOffice Private Cloud server part. 
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3.8 Sheet tabs 

The Sheet tabs (see Figure 85) allow for quick navigation between spreadsheet sheets. 

For more information, see Section 4.2. 

 

Figure 85. Sheet tabs 
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3.9 Status bar 

The Status bar displays the following data and tools (see Figure 86): 

‒ Server connection status indicator: Displayed if a document located in the Cloud 

is opened in the application (see Section 4.12.2) 

‒ Document access permission level: Displayed if a document located in the Cloud storage 

is opened in the application and the user is not the author of this document  

(see Section 4.13.2) 

‒ Automatic calculation values (see Section 4.5.2). 

‒ Tools to zoom in or out the active sheet (see Section 4.2.6). 

 

Figure 86. Status bar 

 

The Cloud and collaborative editing functions are available with the MyOffice 

Professional / MyOffice Private Cloud server part. 
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3.10 Quick Actions box 

The Quick Actions box (see Figure 87) allows you to quickly run various commands and 

perform actions in MyOffice Spreadsheet (see Section 3.2). 

To open the Quick Actions box, do one of the following: 

‒ In the Command menu, select Help > Quick Actions. 

‒ Press Ctrl+/ (OS Windows / OS Linux). In macOS, press ⌘Cmd+/. 

 

Figure 87. Quick Actions box 
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Use one of the following methods to select the command from the list: 

‒ Scroll the list to the desired command using the mouse scroll wheel or the right vertical 

scroll bar. Confirm the command by clicking it or pressing Enter. 

‒ Start typing the command name in the search bar. When the desired command appears 

in the search results, select it using the mouse or keyboard keys: 

‒ Click the command line with the left mouse button. 

‒ Select the command line with the ↓ and ↑ keyboard keys and press Enter. 

 

Once the selection is made, the action is done, and the box closes automatically. To close 

the box without selecting an action, click anywhere outside this window and press Esc. 
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3.11 Application language 

The default language of the MyOffice Spreadsheet application is determined by the language 

of your operating system. You can change it manually if necessary. 

 

When you change the language of MyOffice Spreadsheet, the corresponding language is 

automatically selected for MyOffice Text and MyOffice Presentation. 

To change the application language, follow these steps: 

1. In the Command menu, select Tools > Change Language (see Figure 88). 

 

Figure 88. Tools command menu 
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2. In the window shown in Figure 89, select the desired application language from 

the drop-down list and click OK. 

 

Figure 89. Language selection window 

3. In the dialog box shown in Figure 90 click OK. 

 

Figure 90. Notification to restart the application 

4. Restart the application. To do this, close all the documents currently open in 

MyOffice Spreadsheet and open them again. 
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4 WORK WITH MYOFFICE SPREADSHEET 

4.1 Actions with files 

4.1.1 Create a new file 

4.1.1.1 Create a file using File Explorer 

To quickly create a file using Windows File Explorer, do the following: 

1. Open the context menu by right-clicking on an empty area and click  

New >  New MyOffice Spreadsheet. 

2. Specify a name for the file. By default, the file is named New MyOffice Spreadsheet. 

3. To keep the name, click outside the file or press Enter. 

 

4.1.1.2 Create a file when opening the application 

A new file is created automatically when you open MyOffice Spreadsheet. 

4.1.1.3 Create a file while working in the application 

To create a new file while you work in MyOffice Spreadsheet, do one of the following: 

‒ In the Command menu, select File > New (see Figure 91). 

‒ Press Ctrl+N / ⌘Cmd+N. 

 

Figure 91. New menu 
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4.1.2 Create a template from a file 

A template file fully duplicates the original file and is used as a reference for creating other 

files. Templates are convenient to use if you need to create several documents which share the same 

contents or formatting settings. 

To create a template, follow the steps below: 

1. Open the file that you want to use as a template (see Section 4.1.4). 

2. Select File > Save as Template (see Figure 92). 

3. In the file manager window that appears, select the template name and location. 

Click Save. 

 

Figure 92. File menu 
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4.1.3 Create a file from a template 

To create a file from a template, follow the steps below: 

1. Double-click the template you want to use in the file manager. 

2. Select File > New from Template (see Figure 92). In the file manager, select 

the template you want to use for your file and click Open. 

This will create a new document ready for editing. 
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4.1.4 Open a file 

To open a file, do one of the following: 

‒ Double-click the file using the left mouse button. 

‒ Open MyOffice Spreadsheet. Do the following: 

1. Select File > Open (see Figure 92). Or press Ctrl+O / ⌘Cmd+O. 

2. In the file manager, select the file you want to open and click Open. 

 

The document opens on the sheet where data was last saved before closing. If this sheet has 

been renamed or deleted in another application, the document opens on the first sheet of 

the spreadsheet. 

4.1.4.1 Open a file in .xls format 

When you open a file in .xls format, it is automatically converted to .xlsx format. 

An information bar will be displayed below the Toolbar with an appropriate notification: 

“Document was automatically converted to a newer format”. Click Close in this line 

(see Figure 93). 

 

Figure 93. Close button 

To save a file in .xlsx format, follow the steps described in Section 4.1.7. 
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4.1.4.2 Open read-only files 

If the Read only property is set for a file by the OS tools, then: 

‒ This file is opened in the View mode. 

‒ A notification “You can only view this document” is displayed on the Toolbar 

(see Figure 94). 

 

If you work with files using the WebDav protocol, read-only files are opened in the Edit 

mode. 

In the View mode, you cannot make changes to the document or change its formatting. 

If necessary, you can create a copy of this document that can be edited. To do this, click Edit a Copy 

on the Toolbar. 

 

Figure 94. Edit Copy button 

A copy of the document will open in a new application window. To save the file copy, follow 

the steps described in Section 4.1.7. 

4.1.4.3 Open files used by another application or user 

If a file is opened for editing in another application or by another user: 

‒ This file is opened in the View mode. 

‒ A notification “Document is not available for editing because it is in use by another 

application or user” is displayed on the Toolbar (see Figure 95). 
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Figure 95. Document is in use by another application or user 

 

The file is opened in the Edit mode if it is opened in another application, but no lock file 

has been created by that application. For example: a file downloaded from the Internet 

and opened in Excel in the Protected View mode will open in the Edit mode. 

In the View mode, you cannot make changes to the document or change its formatting.  

To edit a document, make sure the file is not open in another application. If it is open, close it and 

open it in MyOffice Spreadsheet application. 

If the document is opened by another user, wait for the other user to finish working with 

the document or create an editable copy of the document: 

‒ To check whether another user has finished working with the document or not, click 

Check Availability on the Toolbar. If the work is not completed, the pop-up message 

“Document is still in use” will be displayed (see Figure 96). If the work is completed, 

the document will switch to the Edit mode. 

 

Figure 96. Tooltip message 

‒ To create an editable copy of the document, click Edit a Copy on the Toolbar. A copy 

of the document will open in a new application window. To save the file copy, follow 

the steps described in Section 4.1.7. 
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4.1.5 Open a recent file 

MyOffice Spreadsheet application saves a list of documents which the user has worked with 

recently. This list contains both local files and files that were opened from the Cloud storage  

(see Section 4.14). The latter are marked in the list by the cloud. 

 

The Cloud and collaborative editing functions are available with the MyOffice 

Professional / MyOffice Private Cloud server part. 

 

To open a file from the list, do the following: 

1. Select File > Recent Files (see Figure 79). 

 

Figure 97. File menu 

2. In the sub-menu that appears, select the desired file. 

 

If the list of recent files is out of date, delete it. To do this, in the Command menu,  

select File > Recent Files > Clear. 
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4.1.6 Open a file in another application 

You can open the files you are working on in another spreadsheet application directly from 

MyOffice Spreadsheet. To select the application that you want to use, in the File menu, 

select Open With (see Figure 98). 

 

 

This menu item is not available on macOS. 

 

Figure 98. File menu 

A list of available applications is created manually using the OpenWithList.ini 

configuration file (for more details, see MyOffice Text, MyOffice Spreadsheet, 

MyOffice Presentation desktop applications. Installation Guide). 

The Open With command is not displayed if the configuration file does not contain data or 

if the data is incorrect. 

Clicking the Open With command in the File menu will close the file in 

MyOffice Spreadsheet and open it in the application of your choice. If there are any unsaved 

changes in the file when you close it, MyOffice Spreadsheet will suggest saving them. 
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4.1.7 Save a file 

4.1.7.1 Save as 

To save a new file or create a copy of the file you are working on, follow the steps below: 

1. Run the saving command in one of the following ways: 

‒ In the File menu, click Save as (see Figure 98). 

‒ On the Toolbar, select the File section and click the arrow to the right of the  Save 

button. In the drop-down list, select the Save As command (see Figure 99). 

‒ Press F12 for Microsoft Windows or Ctrl+Shift+S for Linux. In macOS, 

press ⇧Shift+⌘Cmd+S. 

2. In the Save As dialog box, pick or browse the folder to save the file. Enter a file name in 

the File name box and select its format in the Save as type box. Click Save. 

 

When you Save As a new file, it becomes the document you are working on. 

 

Figure 99. Save button 

4.1.7.2 Save 

To avoid data loss due to power failure or other system malfunction, it is recommended to 

save changes regularly. 

To save changes in the document you are working on, do one of the following: 

‒ Select File > Save (see Figure 98). 

‒ On the Toolbar, select the File section and click the arrow to the right of 

the  Save button. In the drop-down list, select the Save As command (see Figure 99). 

‒ Press Ctrl+S / ⌘Cmd+S.  
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4.1.7.3 Auto-save and restore a file 

Auto-save a document every 5 minutes after it has been saved once manually. 

If your device crashes and then the document is open again, the application automatically 

restores the data that was contained in the document at the time of its last auto-save. 

Save the restored file manually. To do this: 

1. Click OK in the dialog box shown in Figure 100. 

 

Figure 100. Dialog box 

2. Save the recovered document using the Save As command (see Section 4.1.7.1). 
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4.1.8 Send a file via email 

 

The Send File command is not available on macOS. 

 

In MyOffice Spreadsheet, you can email the file you are working on using the default 

desktop email client. 

To send a file via email, follow the steps below: 

1. Select Share > Send File (see Figure 101). 

 

Figure 101. Share menu 

2. In the new message window that appears, do the following: 

‒ In the To field, enter the recipient's email address. 

‒ In the Subject field, edit the subject (if required). 

‒ In the body of the message, type the text. 

3. Send the email. 
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4.1.9 Import a file 

MyOffice Spreadsheet allows you to import data from .csv, .scsv, .tsv, .tab, .txt files and 

display them in a spreadsheet. 

Follow these steps: 

1. Open the file you want to import (see Section 4.1.4). 

2. In the pop-up window that appears (see Figure 102), specify the following parameters: 

‒ Character set: A text encoding format. 

‒ Delimiters: Characters separating the values. Each value is then placed in a separate 

cell. For example, if you select the semi-colon sign (;), the values like 1;1;1 will be 

placed into 3 cells. You can use the preset delimiter type from the list or specify it 

manually in the Another field. You can select multiple delimiters to use from the list. 

Only one character can be specified in the Another field. 

 

Only one character can be specified in the Another field. 

 

‒ String qualifier: A character that frames individual values so that they are placed in 

separate cells even if they contain a delimiter. For example, if a comma is specified 

as a delimiter and double quotes as a string qualifier, the fractional number "3.14" 

is placed into a single cell. 

‒ Fit Width to Content: An option to adjust the width of each column to automatically 

fit the widest entry in a column. If selected, the width of each column is 

automatically selected based on the content of the cell that contains the most data. 

3. Click OK. 
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Figure 102. Import settings window 

The delimiter-separated data contained in the file will be displayed in a new document in 

tabular form. 
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If you didn't select the Fit Width to Content option during the file import (see Figure 73), 

the "Fit column width to the contents?" pop-up message will appear briefly on the screen once 

the new file is opened (see Figure 103).  

Click Fit Width to fit the width to the content or Cancel to keep the default column width. 

 

Figure 103. Pop-up message 

You can save the resulting file in .xlsx, .xods, or .ods formats in the usual way 

(see Section 4.1.7). 
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4.1.10 Export a file 

MyOffice Spreadsheet allows you to export files to the following formats: 

‒ .pdf 

‒ .pdf/a-1 

‒ .csv 

‒ .tsv, .tab, .scsv 

‒ .txt 

As a result of exporting to .pdf and .pdf/a-1 formats, all sheets of the source file will be 

included in the saved file. 

When exporting files to the .csv, .tsv, .tab, .scsv, and .txt formats: 

‒ The file stores only the current sheet of the source file with text data. Formatting settings, 

images, links, and other data are not saved. 

‒ The .csv, .tsv, .tab and .scsv files use the semicolon (;) character as a value delimiter, 

and the Tab character is used in .txt files. 
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To export a file to .pdf or .pdf/a-1, do the following steps: 

1. Run the export command in one of the following ways: 

‒ Select File > Export To (see Figure 104). 

 

Figure 104. File menu 

‒ On the Toolbar, select the File section and click the arrow to the right of 

the  Quick Print button. In the drop-down list, select Export to PDF  

(see Figure 105). 

 

Figure 105. Export to PDF 

2. In the file manager window, select the folder where you want to export the file, specify 

file name, and format and click Save.  

 

To save a file in the .csv, .tsv, .tab, .scsv or .txt format: 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 105 

1. In the File menu, select Export To (see Figure 105). 

2. In the file manager window, select the folder where you want to export the file, specify 

file name, and format and click Save.  
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4.1.11 Print a file 

4.1.11.1 Print a file without entering MyOffice Spreadsheet 

When working in Windows, you can print a document/group of documents without first 

opening it in MyOffice Spreadsheet. 

To do this, perform the following steps: 

1. Select the desired document/group in Windows Explorer. 

2. Open the context menu by right-clicking the mouse and run the Print command. 

Printing is performed on the last printer used by MyOffice Spreadsheet and MyOffice Text. 

If no printer was previously selected in those applications, the printer used is the one installed by 

default in Windows. 

During printing the following dialog boxes may be displayed: 

‒ For a large-sized document or group of documents: the print setup window. 

‒ For a password-protected document (see Section 4.15.1): The password input window. 

‒ For a document in which the only sheet has been deleted or all sheets have been hidden: 

The window with the notification that there is no data to print. 

‒ Notifications of damaged files and files with unsupported formats. 

4.1.11.2 Print a document from MyOffice Spreadsheet 

4.1.11.2.1 Select the print area 

You can print: 

‒ Selection: Specified manually, 

‒ Print area: Specified manually or selected automatically if a print area is specified for 

the document in a third-party editor. 

‒ Sheet: Selected automatically if no selection or no printable area is specified in 

the document. 
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4.1.11.2.1.1 Print a selection 

To print a selection, follow these steps:  

1. Select the cell, cell range, rows, or columns from which you want to print data. 

2. Open the context menu by right-clicking the selected cells or the titles/contents of the selected 

rows/columns. 

3. In the shortcut menu, select Print Selection. 

The Page Setup and Print will open (see Section 4.1.11.2.2).  
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4.1.11.2.1.2 Print an area 

If a print area is selected on a sheet using MyOffice Spreadsheet or a third-party editor, this 

print area will be automatically selected when printing the document.  

In Microsoft Excel, a print area is selected using the following commands:  

Page Layout > Print Area. In LibreOffice Calc, use Format > Print Ranges. 

 

To specify a print area in the MyOffice Spreadsheet application, follow these steps: 

1. Select the area you want to print on the sheet. 

2. In the Format menu, select Print area > Define print area (see Figure 106). 

 

 

The print area is specified separately for each sheet of the document. 

 

Figure 106. Define print area command 
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The borders of the selected print area are highlighted in blue (see Figure 107). 

 

Figure 107. Print area borders 

If needed, you can hide this frame by doing the following: 

1. Click Format > Print area (see Figure 108). 

2. Uncheck the Print area borders option. 

 

Figure 108. Print area borders menu 

To display the frame, select the menu again. 
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To modify the print area (for example, if the selected area is not correct), follow these steps: 

1. In the Format menu, select Print area and click Clear print area (see Figure 108). 

2. Select the area once again as described above. 

To print the defined area, open the Page Setup and Print window in one of the following 

ways: 

‒ Select File > Page Setup and Print (see Figure 109). 

‒ Press Ctrl+P / ⌘Cmd+P. 

 

Figure 109. File menu 

The Page Setup and Print will open (see Section 4.1.12.2). 
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4.1.11.2.1.3 Print the current sheet 

To print the current sheet, follow these steps: 

1. Make sure that a print area has not been set for this document (see Section 4.1.11.2.1.2). 

2. Open the Page Setup and Print window in one of the following ways: 

‒ In the Command menu, select File and then Page Setup and Print  

(see Figure 109). 

‒ On the Toolbar, select the File section and click the arrow to the right of 

the  Quick Print button. In the drop-down list, select Page Setup and Print  

(see Figure 110). 

 

Figure 110. Page Setup and Print command 

‒ Press Ctrl+P / ⌘Cmd+P. 

 

The Page Setup and Print will open (see Section 4.1.11.2.2). 
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4.1.11.2.2 Page Setup and Print window 

The opened Page Setup and Print window (see Figure 111) contains: 

‒ Print Setup pane 

‒ Preview pane 

 

 

If the sheet that you want to print is empty or the data resides in hidden rows or columns, 

the Page Setup and Print dialog box will not open. Instead, the following notification 

will appear on the screen: "No data to print. Please make sure you have at least one 

page with data to print". 
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4.1.11.2.2.1 Preview a document 

To control the preview, use the following buttons: 

‒  and  : Zoom in or out the preview section. 

‒ Fit: Set the default page zoom (100%). 

‒  and  : Move to the next or previous sheet. 

 

 

Zooming does not affect the print area. The tool is intended for a detailed preview of 

a document content before printing. 

 

You can resize the Page Setup and Print dialog box by dragging its borders. 

 

Figure 111. Page Setup and Print dialog box 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 114 

4.1.11.2.2.2 Customize print settings 

In the print settings area, you can specify the parameters listed in Table 3. 

Table 3. Print settings 

Option Action 

Printer Select a printer to print the document. 

Printer Properties 

(Windows OS only). Open the printer settings window. The type 

and composition of the window parameters depend on the printer 

model selected in the field above.  

The settings specified in the printer settings window are 

automatically transferred to the corresponding fields of 

the Page Setup and Print window. 

Print in Grayscale 
Print the color text and images contained in the document in 

grayscale. 

Copies Set the number of copies you want to print. 

Collated / Uncollated 

Set the order in which pages are grouped during printing. Set 

the order in which pages are grouped during printing: 

− Collated: Print all pages grouped by copies (1,2,3 1,2,3 1,2,3). 

− Uncollated: Print pages grouped by page numbers (1,1,1 2,2,2 

3,3,3). 

Print Area 

Print Area (see Section 4.1.11.2.1): 

− Defined Area: Print the defined area. 

− Entire Sheet: Print the sheet displayed on the screen. 

− Selection: Print the selected area on a sheet. 

A field to enter the page 

numbers or ranges to be 

printed 

This field is used if you want to print individual pages or page 

ranges of the selected sheet/area/fragment. The pages to print can be 

specified as: 

− Individual page numbers. For example, 5, 10, 12. 

− Page ranges where the range values are denoted using the hyphen. 

For example, 1-8, 10-11. 

− Pages from the beginning of the sheet/area/fragment to 

the specified one are in the -<No.> format. For example, if -3 

is entered in the field, then pages 1-3 will be printed. 

− Pages from specified to the end of the sheet/area/fragment - in 

the <No.>- format. For example, if 3- is entered in the field and 

the sheet/area/fragment contains 6 pages, then pages 3-6 will be 

printed. 
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Option Action 

Range 

This field is not available when you want to print a selection 

(see Section 4.1.12.1.1). Select one of the following ranges: 

− All Pages: Print all the pages of the current sheet. 

− Odd Pages Only, Even Pages Only: Print the document on a printer 

that doesn't support automatic double-sided printing. You can print 

the front sides of all the pages, turn the printed pages over, put them 

back into the printer, and print on the back sides. 

Don't print blank pages 

Blank pages are the pages without data, cells, objects (diagrams, images, 

shapes), cells with borders (see Section 4.11.12) or filling 

(see Section 4.11.10). This is a default option. 

Checking/unchecking Do not print blank pages in the preview area 

hides/displays blank pages and the total number of pages is reduced or 

increased. 

If you want to print individual pages/range of pages of the selected 

sheet/area/fragment, make sure that the Do not print blank pages check 

box is selected first, and then specify the pages/range of pages to be 

printed, referring to the page numbering in the preview area. 

Duplex Printing 

Print on both sides of the paper: 

− None: Print on one side of the page only. 

− Long-Edge Binding: Print two sides of the page and flip the paper 

along the long edge. 

− Short-Edge Binding: Print two sides of the page and flip the paper 

along the short edge. 

Scale 

The settings under the Scale section depend on the option selected in 

the Print Area. 

Under the Current Sheet, the Scale contains the following settings: 

− Fit to Page Breaks: If page breaks are inserted into a sheet using 

Microsoft Excel or LibreOffice Calc spreadsheet editor, the sheet is 

broken into pages according to these breaks. If the document does not 

have page breaks, the spreadsheet will be automatically scaled to fit one 

printed page. 

 

If there are no page breaks on the sheet, selecting Fit to Page 

Breaks will print the entire contents on one page at a very 

small scale 

− Custom Scale: Change the sheet scale on the page by adjusting 

the percentage value. If there are page breaks on the sheet (see 

the description of the setting above) and you select the Custom 

Scale, printing will be performed taking these page breaks into 

account. 

 

If there are page breaks on the sheet (see the description 

of the settings above), then when you select the Custom 

Scale, printing will take these page breaks into account. 
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Option Action 

In the Print Area, under the Selection, the Scale contains 

the following settings: 

− Actual Size: Print the spreadsheet as is. 

− Fit to Page: Fit the selection to a printed page. 

− Fit to Width: Fit all columns of the selection to a printed page. 

− Fit to Height: Fit all rows of the selection to a printed page. 

 

Click Print to print the document or Cancel to close the window.  
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4.1.11.2.2.3 Page setup 

The Page Setup and Print dialog box contains the following page setup options  

(see Figure 112): 

‒ Orientation: Select Portrait (vertical) or Landscape (horizontal) page orientation. 

‒ Paper Size: Select paper size for printing. 

‒ Top Margin, Bottom margin, Left Margin, Right Margin: Set the distance between 

the page edges and the contents. 

You can save the current page setup for further printing. To save the setup and close 

the window, click Save. To print the document and save the setup, click Print. 

When printing a selection (see Section 4.1.11.2.1.1), the page setup is only applied to 

the selection and cannot be saved for further printing sessions.  

 

Figure 112. Page setup 
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4.1.11.2.3 Quick print 

MyOffice Spreadsheet allows you to quickly print a document without using the Page Setup 

and Print dialog box. 

The Quick Print feature: 

‒ Creates an instant printout and uses the default printing settings. 

‒ Selects the last printer used. The document will be printed using the printer you last used 

(if any) or the default printer. 

 

To print a document using the Quick Print feature, do one of the following: 

‒ On the Toolbar, select the File >  Quick Print (see Figure 113). 

‒ On the Toolbar, select the File section and click the arrow to the right of 

the  Quick Print button. In the drop-down list, select the Quick Print command. 

 

Figure 113. Quick Print button 
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4.1.12 Close a file 

Once you have finished working with a file, save it (see Section 4.1.7) and close 

the application window using one of the following tips: 

‒ In the File menu, click Close (see Figure 114). 

 

Figure 114. File menu 

‒ Click  Close in the application window heading. 

‒ Press Alt+F4 / ⌘Cmd+Q. 
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4.2 Sheets 

4.2.1 Insert a sheet 

By default, a new spreadsheet created in MyOffice Spreadsheet contains one sheet. You can 

add as many sheets as you need manually. 

To insert a sheet, do one of the following: 

‒ In the Insert menu, click Sheet (see Figure 115). 

 

Figure 115. Insert menu 

‒ On the Toolbar, select the Insert section and click . In the insert pane that appears, 

click  Sheet (see Figure 116). 
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Figure 116. Sheet button 

‒ Click the  button to the right of the sheet tabs (see Figure 117). 

 

Figure 117. Add sheet button 
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4.2.2 Rename a sheet 

By default, spreadsheet sheets are sequentially named as Sheet1, Sheet2, Sheet3, etc.  

To rename a sheet, perform the following actions: 

1. Right-click the tab of the sheet you want to rename. 

2. In the context menu, select Rename (see Figure 118). 

 

Figure 118. Context menu of a sheet 

3. In the opened window (see Figure 119), enter the name of a sheet or and click OK. 

 

Figure 119. Rename sheet 

Sheet name cannot: 

‒ Contain less than 1 and more than 31 characters. 

‒ Contain any of the following characters: (:), (\), (/), (?), (*), ([), (]). 

‒ Begin or end with a single quotation mark ('). 

‒ Repeat the name of the other sheet. 
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4.2.3 Hide or unhide a sheet 

To hide a sheet, do as follows: 

1. Right-click the tab of the sheet you want to hide. 

2. In the context menu, select Hide (see Figure 118). 

 

To unhide hidden sheets, perform the following actions: 

1. Right-click the tab of any displayed sheet. 

2. In the context menu, select Unhide All (see Figure 120). 

 

Figure 120. Context menu of a sheet 

4.2.4 Duplicate a sheet 

MyOffice Spreadsheet allows you to duplicate any sheet of a spreadsheet, that is, to create 

a copy of a sheet with all its contents. 

To duplicate a sheet, perform the following actions: 

1. Right-click the tab of the sheet you want to duplicate. 

2. In the context menu, select Duplicate (see Figure 120).  
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4.2.5 Change sheets order 

In MyOffice Spreadsheet, you can change the order of sheets in the current spreadsheet. 

To do this, follow the steps below: 

1. Select the sheet that you want to change in order. 

2. Click the left mouse button and drag the sheet to a new position on the sheet tabs. 

3. Release the left mouse button to fix the selected position of the sheet. 
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4.2.6 Zoom a sheet 

By default, zoom is 100% when creating a spreadsheet. If necessary, you can zoom it in or 

zoom out using the Command menu or the Status bar. 

To change the zoom using the Command menu, do as follows: 

1. In the View menu, select Zoom (see Figure 121). 

2. In the opened list, select the desired option: 

‒ Zoom In: Increase the current zoom by 10%. 

‒ Zoom Out: Decrease the current zoom by 10%. 

‒ Actual Size: Set the default zoom (100%). 

 

Figure 121. View menu 

To change the zoom using the Status bar (see Figure 122), do one of the following: 

‒ With the left mouse button pressed, move the slider to the right or left to zoom in or out, 

respectively. 

‒ Click to zoom in or  to zoom out. In each case, the zoom increment is 10 %. 

‒ Select the current zoom value with the cursor in the lower right corner, modify it and 

press Enter to confirm. 

‒ Press the arrow to the right of the current zoom value and select the zoom from the drop-

down list. 

 

Figure 122. Zooming tools 
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4.2.7 Hide or display zero values 

If a spreadsheet contains a lot of zero values, you might want to hide them to make you 

spreadsheet easier to read. The hidden zero values are not printed. 

To hide zero values on the sheet, proceed as follows: 

1. Right-click the sheet tab of the sheet containing the zero values that you want to hide. 

2. In the context menu of the sheet, select the Hide Zero Values check box  

(see Figure 123). 

 

Figure 123. Context menu of a sheet 

To display the previously hidden zero values on the sheet, proceed as follows: 

1. Right-click the sheet tab of the sheet containing the zero values that you want to display. 

2. In the context menu of the sheet, clear the Hide Zero Values check box. 

4.2.8 Delete a sheet 

To delete a sheet, perform the following actions: 

1. Right-click the tab of the sheet you want to delete. 

2. In the context menu, select Delete (see Figure 123). 

 

When you run the command, the sheet is deleted along with the data without warning. 

If you have deleted a sheet by mistake, undo the action (see Section 4.12.1.1). 
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4.3 Actions with cells, columns, and rows 

4.3.1 Expand the workspace 

All actions on the sheet are performed within the workspace (see Section 3.6). 

By default, the workspace in a new sheet consists of 10 columns and 20 rows. 

Workspace borders expand automatically if you insert more rows or columns than the current 

workspace has. 

To expand the workspace, do one of the following: 

‒ Double-click a cell in a row or column in the inactive area that you want to include in 

the workspace. 

‒ Right-click the row or column heading outside the workspace in the inactive area and 

select the Add rows: N or Add columns: N context menu (see Figure 124). 

 

Figure 124. Add rows 

‒ Select any cell in a row or column before the inactive area. To increase the workspace 

by one or more columns, use Tab. To increase the workspace by one or more rows, 

use Enter. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 128 

4.3.2 Select a cell range 

4.3.2.1 Select a custom cell range 

To select a custom range of cells, use one of the following methods: 

‒ Move the cursor to the first cell in the desired range. Hold down the left mouse button 

and drag the cursor to the last cell of the range. Release the left mouse button. 

‒ Select the first cell of the desired range. Hold Shift pressed and select the last cell of the 

range. 

You can select a range in any direction of rows or columns, 

Some cell range selection examples are shown on Figure 125–Figure 127. 

 

Figure 125. Select a horizontal cell range 

 

Figure 126. Select a vertical cell range 

 

Figure 127. Select a diagonal cell range 
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4.3.2.2 Select all cells in a spreadsheet 

To select all the cells that are in the workspace of the current sheet (see Section 4.2.1), 

do one of the following: 

‒ Move the mouse cursor to the upper left corner of the workspace so that the cursor looks 

like  and click the left mouse button. 

‒ In the Edit menu, click Select All (see Figure 128). 

 

Figure 128. Select a diagonal cell range 

‒ Press Ctrl+A / ⌘Cmd+A. 

 

If an element (image, shape, or diagram) is selected on the sheet, deselect the element 

before selecting all cells by using the Command menu or keyboard shortcut. 

 

When using these commands, only the cells on the active sheet are selected.  

Cells on the other sheets in the spreadsheet are not selected. 

When switching to another sheet, the range remains selected. 

4.3.2.3 Deselect cells 

To deselect a cell range, left-click any cell in a spreadsheet. 
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4.3.3 Resize cells 

It is possible to resize cells in one of the following ways: 

‒ By specifying the exact width and height of cells manually. 

‒ Automatically match the width and height of the cells to the content. 

To resize one or multiple cells, do the following: 

1. Select the cells. 

2. Open the Cell Size window in one of the following ways: 

‒ In the Command menu, select Table > Cell Size (see Figure 129). 

 

Figure 129. Table command menu 

‒ On the Toolbar, select the Cells section and click  Cell Size (see Figure 130). 

 

Figure 130. Cells Size button 

‒ Right-click the selected cells and run the context menu command Cell Size. 
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3. In the Cell Size window (see Figure 131), do one of the following: 

‒ To specify the exact cell parameters, enter them in the Width and Height fields 

manually. 

‒ To automatically match the width and height of the cells to the content, select Adjust 

automatically. 

4. Click OK. 

 

Figure 131. Cell Size window 
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4.3.4 Merge or split cells 

4.3.4.1 Merge cells 

You can merge any number of cells in the current spreadsheet. 

When merging multiple cells: 

‒ The selected range will merge into a single cell. 

‒ The merged cell will only display the contents of the upper-left cell of the selection. 

‒ When you merge multiple cells, the resulting cell will be formatted like the upper-left 

cell of the merged range. 

To merge cells, select them and do one of the following: 

‒ In the Table menu, select Merge Cells (see Figure 132). 

 

Figure 132. Table menu 
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‒ On the Toolbar, select the Cells section and click  Merge Cells (see Figure 133). 

 

Figure 133. Merge Cells button 

‒ Right-click the selected range of cells and choose Merge Cells context menu. 

‒ Press Ctrl+Alt+M / ⌥Option+⌘Cmd+M. 
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4.3.4.2 Split cells 

MyOffice Spreadsheet allows you to split the previously merged cells. 

To split the cells, select the merged cell and do one of the following: 

‒ In the Table menu, select Split Cells (see Figure 134). 

  

Figure 134. Table command menu 

‒ On the Toolbar of the Cells section, click  Split Cells (see Figure 135). 

 

Figure 135. Split Cells button 

‒ Right-click the selected cell and select the Split Cells option from the context menu. 

‒ Press Alt+Shift+M / ⌥Option+⇧Shift+M. 

The data contained in the merged cell will be placed in the upper-left cell of the resulting 

range. The resulting cells will be formatted like the merged cell. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 135 

4.3.5 Insert rows and columns 

4.3.5.1 Insert columns 

To quickly add one column, perform the following actions: 

1. Select a cell or a column to the left or to the right of which you want to add a new column. 

2. Insert a column in one of the following ways: 

‒ In the Table menu, select Insert Column to the Left or 

Insert Column to the Right (see Figure 136). 

 

Figure 136. Table menu 

‒ On the Toolbar, select the Cells section and click  Insert Column to the Left or 

 Insert Column to the Right (see Figure 137). 

 

Figure 137. Buttons to insert columns 

‒ Right-click the selected cell or heading of the selected column and select 

the Insert Column to the Left or Insert Column to the Right command from 

the context menu. 

‒ To insert column to the left, press Alt+L / ⌥Option+L. To insert column to 

the right, press Alt+R / ⌥Option+R. 
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To add several columns, perform the following actions: 

1. Select the number of columns and cells horizontally equal to the number of columns to 

be inserted. 

2. Insert the columns in one of the following ways: 

‒ In the Table menu, select Insert Column to the Left or 

Insert Column to the Right (see Figure 136). 

‒ On the Toolbar, select the Cells section and click  Insert Column to the Left or 

 Insert Column to the Right (see Figure 137). 

‒ Right-click anywhere the selected range and select the Insert Column to the Left 

or Insert Column to the Right command from the context menu. 

‒ To insert columns to the left, press Alt+L / ⌥Option+L. To insert columns to 

the right, press Alt+R / ⌥Option+R. 

 

To double the number of columns on the sheet, perform the following actions: 

1. Select any entire row on the sheet (see Section 4.3.5.1). 

2. Insert the columns in one of the following ways: 

‒ Right-click the column heading area and select the Insert Column to the Left or 

Insert Column to the Right command from the context menu. 

‒ To insert columns to the left, press Alt+L / ⌥Option+L. To insert columns to 

the right, press Alt+R / ⌥Option+R. 
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4.3.5.2 Insert rows 

To quickly add one row, perform the following actions: 

1. Select a cell or a row to the left or to the right of which you want to add a new row. 

2. Insert the row in one of the following ways: 

‒ In the Table menu, select Insert Row Above or Insert Row Below command menu 

item (see Figure 138). 

 

Figure 138. Table menu 

‒ On the Toolbar, select the Cells section and click the  Insert Row Above or 

 Insert Row Below button (see Figure 139). 

 

Figure 139. Buttons to insert rows 

 

‒ Right-click anywhere on the selected range and select the Insert Row Above or 

Insert Row Below command from the context menu. 

‒ To insert rows above, press Alt+A / ⌥Option+A. To insert rows below,  

press Alt+B / ⌥Option+B. 
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To add several rows, perform the following actions: 

1. Select the number of rows and cells vertically equal to the number of rows to be inserted. 

2. Insert rows in one of the ways: 

‒ In the Table menu, select Insert Row Above or Insert Row Below command menu 

item (see Figure 138). 

‒ On the Toolbar of the Cells section, click  Insert Row Above or  

 Insert Row Below (see Figure 139). 

‒ Right-click anywhere on the selected range and select the Insert Row Above or 

Insert Row Below command from the context menu. 

‒ To insert rows above, press Alt+A / ⌥Option+A. To insert rows below, press 

Alt+B / ⌥Option+B. 

To double the number of rows on the sheet, perform the following actions: 

1. Select any entire column on the sheet (see Section 4.2.5.1). 

2. Insert rows in one of the ways: 

‒ Right-click the row heading area and select the Insert Row Above or 

Insert Row Below command from the context menu. 

‒ To insert rows above, press Alt+A / ⌥Option+A. To insert rows below, press 

Alt+B / ⌥Option+B. 
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4.3.6 Select rows and columns 

4.3.6.1 Select a row or a column 

To select the entire row or column in spreadsheet, do one of the following: 

‒ Hold the cursor over a row or column heading until the cursor 

changes to an arrow (  or ). Left-click the heading. 

‒ Click any cell in the row or column you want to select. To select a row, 

press Shift+Space. To select a column, press Ctrl+Space / ⇧Shift+⌘Cmd+Space. 

 

To select all rows containing a merged cell (see Section 4.3.4.1), select the cell and press 

Shift+Space. 

To select all columns containing a merged cell (see Section 4.3.4.1), select the cell and press 

Ctrl+Space / ⇧Shift+⌘Cmd+Space. 
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4.3.6.2 Select a range of rows or columns 

To select a range of rows or columns, follow the steps below: 

1. Hold the cursor over the heading of the first row or column that you want to select. 

The cursor will change to an arrow (  or ). 

2. Press and hold the left mouse button and drag the cursor to the headings of the items 

to be selected. 

3. Release the left mouse button. 

 

To select a range of rows or columns not included in the workspace area, 

follow the steps below: 

1. Hold the cursor over the heading of the first row or column that you want to select. 

The cursor will change to an arrow (  or ). 

2. Left-click the heading to select it. 

3. Hold the cursor over the heading of the last row or column that you want to select. 

The cursor will change to an arrow (  or ). Click the heading while holding the Shift 

key pressed. 
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4.3.7 Hide rows and columns 

4.3.7.1 Hide a row or a column 

To hide rows or columns, perform the following actions: 

1. Select the entire row(s) or column(s) (see Section 4.3.5.1). 

2. To hide them, do one of the following: 

‒ In the Table menu, select Hide Column or Hide Row (see Figure 140). 

 

Figure 140. Table menu 

‒ Right-click the row or column heading and select the Hide Column  

or Hide Row command in the context menu. 

Hidden rows or columns are marked in the heading as shown (see Figure 141). 

 

Figure 141. Hidden rows 

Hidden rows and columns are not printed.  
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4.3.7.2 Unhide rows and columns 

To display a hidden column or row, follow these steps: 

1. Select two rows or columns (see Section 4.3.5.1) between which there is a hidden 

element. 

2. Run the item display command in one of the following ways: 

‒ Select the Command menu item Table > Unhide Column/Unhide Row  

(see Figure 140). 

‒ Right-click on the headers of the selected columns/rows and run the Show Column 

or Show Row context menu command. 

 

After running the command, all rows/columns hidden under the marker are displayed. 
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4.3.8 Resize rows and columns 

You can modify the size of a row or a column in one of the following ways: 

‒ By moving the border of a cell of a row or column manually. 

‒ By automatically selecting the size of a row or column in accordance with the size of 

the contents. 

‒ By specifying the exact width of the column or height of the row. 

4.3.8.1 Resize a row or a column manually 

To change the size of a single column or row, follow these steps: 

1. Hover the cursor over the right border of the column header or the lower border of 

the row header so that the cursor takes the form of a two-sided arrow. 

2. Hold down the left mouse button and move the border to the desired position. 

3. Release the left mouse button to lock the selected position. 

To set the same size for multiple columns/rows, follow these steps: 

1. Select the columns/rows. 

2. Set the size for one column/row that you want to apply to all selected columns/rows. 

To do this, proceed as follows: 

‒ Move the cursor to the right border of the header of any column or to the lower 

border of the header of any row so that the cursor takes the form of a two-sided 

arrow. 

‒ Hold down the left mouse button and move the border to the desired position. 

‒ Release the mouse button to lock the selected position. 

 

For the selected columns/rows, the size specified for this column/row 

will be automatically set. 

To set the same size for all rows/columns in the workspace (see Section 3.6), select all cells 

of the sheet (see Section 4.3.2.2) and follow the same steps. 
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4.3.8.2 Autofit the width 

To automatically adjust the column width based on the content of the cell with the largest 

amount of data, do one of the following: 

‒ Hover the mouse cursor over the right border of the column header so that the cursor 

takes the form of a two-sided arrow and double-click. 

‒ Right-click the column header and run the context menu command Fit Width to 

Content. 

‒ Right-click the column header and run the Column Width context menu command. 

In the Column Width window (see Figure 142), select Adjust automatically and 

click OK. 

 

Figure 142. Column Width window 

To automatically adjust the row height based on the content of the cell with the largest 

amount of data, do one of the following: 

‒ Hover the mouse cursor over the lower border of the header so that the cursor takes 

the form of a two-way arrow and double-click. 

‒ Right-click the line header and run the Fit Height to Content context menu command. 

‒ Right-click the row header and run the Row Height context menu command.  

In the Row Height window (see Figure 143), select the value Adjust Automatically 

and click OK. 
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Figure 143. Row Height window 

To automatically adjust the width/height of several columns/rows, follow these steps: 

1. Select the required columns/rows. 

2. Autofit width/height in one of the following ways: 

‒ Hover the mouse cursor over the border between any two column/row headers in 

the selected range so that the cursor takes the form of a two-sided arrow. 

Double-click. 

‒ Right-click the header of any column/row in the selected range and run the context 

menu command Fit Width to Content or Fit Height to Content. 

‒ Right-click the header of any column/row in the selected range and run the context 

menu command Column Width or Row Height. In the window that opens 

(see Figure 142 and Figure 143), select Adjust automatically and click OK. 

 

For each column/row in the selected range, the width/height will be selected according to 

the contents of the cell with the largest amount of data. 
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4.3.8.3 Specify the exact size 

To specify the exact width for one/more columns or height for one/more rows, follow these 

steps: 

1. Select these columns or rows. 

2. Right-click the header of any column or row in the selected range and run the context 

menu command Column Width or Row Height. 

3. In the window that opens (see Figure 142 and Figure 143), specify the required 

Column Width or Row Height. 

4. Click OK. 

4.3.9 Freeze rows, columns, or area 

Freezing rows, columns or areas is useful if you are working with large amounts of data and 

often scroll through the window. You can freeze any range of columns and rows so that they are 

always visible when you move around the sheet. 

The frozen element is separated from other elements in the spreadsheet with a bold line. 

If you've already frozen rows or columns and want to freeze the new ones, the previous 

setting for the same item will be invalidated. 

In MyOffice Spreadsheet, you can freeze the following elements: 

‒ One or multiple columns (see Figure 144): As you scroll the sheet to the right, only 

the frozen columns are displayed. All the columns to the left are not displayed. 

 

Figure 144. Column B is frozen 
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‒ One or multiple rows (see Figure 145): As you scroll the sheet down, only the frozen 

rows are displayed. All the rows above are not displayed. 

 

Figure 145. Row 4 is frozen 

‒ Both rows and columns (see Figure 146): As you scroll the sheet to the right and down, 

only the frozen rows and columns are displayed. All the columns to the left and rows 

above are not displayed. 

 

Figure 146. Columns B and C and rows 3 and 4 are frozen 

‒ The area in a spreadsheet where A1 is the top left cell and the bottom right cell is 

specified by you. 
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Figure 147. Frozen area 
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4.3.9.1 Freeze columns or rows 

To freeze one or multiple rows or columns, follow these steps: 

1. Entirely select rows or columns you want to freeze or select any cells in these rows or 

columns. 

2. Freeze columns or rows in one of the following ways: 

‒ In the Table menu, select Freeze Selected Rows and Columns (see Figure 148). 

In the opened sub-menu, select Freeze Horizontally to freeze rows or Freeze 

Vertically to freeze columns. Or select the Toolbar of the Table section and press 

the arrow to the right of the  Freeze Selected Rows and Columns  

(see Figure 149). 

 

Figure 148. Table menu 
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‒ On the Toolbar, select the Cells section and click  

the  Freeze Selected Rows and Columns button (see Figure 149). 

‒ On the Toolbar, select the Cells section and click the arrow to the right of 

the  Freeze Selected Rows and Columns button (see Figure 149). In the opened 

menu, select Freeze Horizontally to freeze rows or Freeze Vertically to freeze 

columns. 

 

Figure 149. Freeze button 
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4.3.9.2 Simultaneously freeze rows and columns 

To simultaneously freeze rows and columns, follow these steps: 

1. Select any number of cells located in rows or columns you want to freeze. 

2. Freeze rows and columns in one of the following ways: 

‒ On the Toolbar, select the Cells section and click 

the  Freeze Selected Rows and Columns button (see Figure 149). 

‒ On the Toolbar, select the Cells section and click the arrow to the right of 

the  Freeze Selected Rows and Columns button. In the opened window, select 

Freeze Selected Rows and Columns (see Figure 149). 

‒ Right-click the headings of the selected rows and columns and select 

Freeze Selected Rows and Columns in the context menu. 
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4.3.9.3 Freeze an area 

To freeze an area, follow these steps: 

1. Select a cell which will be the bottom right cell of the area. 

2. Freeze the area in one of the following ways: 

‒ On the Toolbar, select the Cells section and click 

the  Freeze Selected Rows and Columns button (see Figure 149). 

‒ On the Toolbar, select the Cells section and click the arrow to the right of 

the  Freeze Selected Rows and Columns button. In the opened window, select 

Freeze Selected Rows and Columns (see Figure 149). 

4.3.9.4 Unfreeze rows and columns 

To unfreeze rows and columns, do one of the following: 

‒ In the Table menu, select Freeze Selected Rows and Columns and then Unfreeze All 

(see Figure 148). 

‒ On the Toolbar, select the Cells section, click the arrow next to 

the  Freeze Selected Rows and Columns button and select the Unfreeze All option 

(see Figure 148) in the drop-down list. 

‒ Right-click the heading of a row or column and select and select the Unfreeze All option 

from the context menu. 
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4.3.10 Group rows or columns 

To group rows or columns of your choice, select them and do one of the following: 

1. In the Data menu, select Group Rows or Group Columns (see Figure 150). 

 

Figure 150. Data menu 

2. On the Toolbar, select the Cells section and click the  Group button  

(see Figure 151). 

3. On the Toolbar, select the Cells section and click the arrow to the right of the  Group 

button and select Group Rows or Group Columns. 

 

Figure 151. Group button 

4. Right-click the heading of the selected rows or columns and select Group rows or 

Group columns from the context menu. 
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If a range of cells is selected and not just rows or columns, then pressing the  Group 

button opens the Group window (see Figure 152), where you should choose which items you want 

to group. 

 

Figure 152. Group window 

The final row of each group is at the bottom of the group. The final column of the group is 

the rightmost column of the group. The heading of the final row and the final column is grayed out.  

You can create up to 7 levels of groups. 

If necessary, you can collapse or expand the data in the groups.  

Use the  or  outline symbols for this purpose.  

 

To clear the grouping, follow these steps: 

1. Select a range of cells for which you want to clear the grouping. 

2. Select the Data menu > Clear Grouping (see Figure 150). Or on the Toolbar, select 

the Cells section and click the arrow to the right of the  Group button and select 

Clear Grouping (see Figure 151). 

If you want to print the sheet that contains grouped columns or rows, these grouped elements 

will be printed as they are displayed on the screen. 
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4.3.11 Delete columns or rows 

To delete one or more rows or columns, use one of the following methods: 

1. Select rows or columns you want to delete, or cells located within them.  

Do one of the following: 

‒ In the Table menu, select Delete Column or Delete Row (see Figure 153). 

 

Figure 153. Table menu 

‒ On the Toolbar, select the Cells section and click the  Delete Column or 

  Delete Row button (see Figure 154). 

 

 

Figure 154. Buttons to delete columns or rows 

‒ Right-click anywhere in the selected range and use the Delete Column or  

Delete Row context menu command. 

2. Select these columns/rows as a whole and press Ctrl+- / ⌘Cmd+-. 
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4.4 Data 

4.4.1 Enter data 

4.4.1.1 Enter data in a cell 

To enter or change data in a cell, perform the following actions: 

1. Activate the edit mode in one of the following ways: 

 Select an empty cell. 

 Double-click the cell you want to edit. 

 Select the cell you want to edit and go to the Formula bar. 

2. Enter the necessary data into the cell. Use the comma sign (,) as the delimiter for 

numbers. 

3. Save the entered data in one of the following ways: 

 Press Enter. 

 Click  in the right side of the Formula bar (see Figure 155). 

 Select another cell on the spreadsheet. 

 

To undo the changes you have made, do one of the following while editing: 

 Click  in the right side of the Formula bar (see Figure 155). 

 Press Esc. 

 

Figure 155. Enter data and Cancel buttons 
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4.4.1.2 Automatically adjust cell width 

When you enter a number in a cell, the width of this cell is automatically adjusted to fit 

the number. 

Cells width is not adjusted in the following cases: 

‒ The width of the column containing the cell has been previously changed in the manual 

mode (see Section 4.3.8.1). 

‒ The cell format is Text (see Section 4.4.3.1.9). 

‒ The cell is filled with text. 

 

4.4.1.3 Floating cell 

The floating cell (see Figure 156) appears when you edit a cell and move through the current 

sheet of the spreadsheet. 

The cell displays the current data in the cell you were editing, so it is convenient to use when 

navigating through a large amount of data in the document. 

 

Figure 156. Floating cell 
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4.4.1.4 Fill cells automatically 

MyOffice Spreadsheet allows you to automatically fill the adjacent cells. A single cell as 

well as a range of cells can be selected as a sample for filling. 

If a single cell with a text or numeric value is selected as a reference, its content is copied to 

subsequent cells when it is autofilled. 

If a cell with a formula is selected as a reference, the subsequent cells will be filled in with 

data sequences calculated using the formula specified in the cell. The values are automatically 

recalculated if the data in the formula cells change. 

If a cell range is selected as a sample range, the subsequent cells are filled in according to 

the rules described below. 

The filled cells will have the same format as the sample range (see Section 4.4.3). 

To automatically fill the data, follow the steps below: 

1. Enter the desired data in one or more adjacent cells. 

2. Select the cells. 

3. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

4. Drag the corner autofill handle over the range of cells that you want to fill in. You can 

drag the corner autofill handle either vertically or horizontally. 

 

If the range of cells to be filled exceeds the workspace boundaries (see Section 4.3.1), 

the workspace expands automatically. 
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4.4.1.4.1 Fill cells automatically with arithmetic sequences 

In MyOffice Spreadsheet, you can fill cells with arithmetic sequences. This type of sequence 

adds the difference between the previous two to each of the subsequent values.  

For example, 1, 2, 3, 4... 

To autofill cells with a geometric sequence, follow the steps below: 

1. Enter the first 2 range values in the adjacent cells to set the reference. 

2. Select the resulting range containing the 2 cells. 

3. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

4. Drag the corner autofill handle over the range of cells that you want to fill in. You can 

drag the corner autofill handle either vertically or horizontally. 

4.4.1.4.2 Fill cells automatically with geometric sequences 

In MyOffice Spreadsheet, you can fill cells with geometric sequences. In this sequence view, 

each of the following values is multiplied by the specified progression denominator.  

For example, 0.25, 0.5, 1, 2... 

To autofill cells with a geometric sequence, follow the steps below: 

1. Enter the first 3 range values in the adjacent cells to set the reference. 

2. Select the resulting range. 

3. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

4. Drag the corner autofill handle over the range of cells that you want to fill in. You can 

drag the corner autofill handle either vertically or horizontally. 
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4.4.1.4.3 Reduce the data range 

If necessary, you can quickly reduce the range of data resulting from autofill. When the range 

is reduced, the data in the columns on the right or the rows on the bottom is deleted. 

To reduce the range, follow the steps below: 

1. Select the range of cells with the data resulting from the autofill. 

2. Move the mouse cursor over the corner handle of the selected cell so that the cursor looks 

like . 

3. If you want to delete data in the columns on the right side of the autofill range, drag 

the corner handle to the left. If you want to delete data in the rows at the bottom, drag 

the corner handle upwards. 

4. Release the left mouse button. All data will be deleted from the columns or rows excluded 

from the range. 

4.4.1.4.4 Autofill cells: basics 

Cells can be filled automatically if two or more cells from the sample range contain 

the following data: 

‒ A series of integers, fractions, or negative numbers. 

‒ Dates or time. 

‒ Text and a number (with or without the delimiter). For example, Text 1, Text 2 or 

Text1, Text3, Text5. 

‒ Abbreviated (Jan-Dec) or full month names (January-December). 

‒ Abbreviated (Mon-Sun) or full weekdays names (Monday-Sunday). 

‒ If the sample range contains cells of different formats, then, when autofilling a series, 

the cells repeat the formats and follow the sequences in the order corresponding to 

the sample range. 

‒ If there is a cell with text in the sample range, it will be copied when the series is 

autofilled, and the other cells will follow the specified sequence. 

‒ If a cell with text is located between cells in a series that have different formats, the text 

will be copied when autofilling, and cells of different formats will follow different 

sequences. 

‒ If the sample range contains a merged cell, an identical merged cell is automatically 

created in the autofill range that continues the specified data sequence. 

‒ If a merged cell partially falls into the autofill range (also due to partial hiding), the 

merged cell will be split. 
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‒ Cells of General and Number formats (Number, Currency, Accounting, Fraction, 

Percentage, Exponent) are considered as one sequence. 

‒ Date and Time are unrelated formats and are considered as separate sequences. 

‒ When autofilling dates, the sequence is calculated based on the actual calendar 

difference. 
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4.4.1.5 Text formatting of formulas and numbers 

In some cases, a formula or number that is entered into a cell needs to be retained in its 

original form. For example, display zero characters when entering the number 00056 or specify 

a formula without its further use. To do this, text formatting should be applied to the cell in which 

the number or formula is entered. 

The formatting is applied by using a single quotation mark (').  

The single quotation mark should be entered in a cell immediately before the formula or number to 

be recognized as text. For example: '=SUM(B1;C1) or '00056. 

The quotation mark is displayed: 

‒ On the formula bar, when you select a cell. 

‒ In the cell and on the formula bar, when you edit a cell. 

 

If you want to cancel text formatting, delete the quotation mark in the cell. 

.  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 163 

4.4.2 Sort and filter 

With MyOffice Spreadsheet, you can sort and filter data on the spreadsheet sheet 

you are working on. 

4.4.2.1 Define the Sort and Filter range 

To define the Sort and Filter range, follow these steps: 

1. Select the range of cells that will contain all the data to be sorted and filtered. 

 

The top line of the range, marked , is not involved in the filtering and sorting 

process. The range cannot consist of one line. 

2. On the Toolbar, select the Data section and click the  Sort and Filter button 

(see Figure 157). 

 

Figure 157. Sort and Filter button 

The active Sort and Filter range on the sheet is as follows (see Figure 158): 

‒ Headings of rows and columns are highlighted in green. 

‒ A green frame appears around the range. 
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4.4.2.2 Automatic detection of the Sort and Filter range 

MyOffice Spreadsheet can detect the Sort and Filter range automatically if the cells 

adjacent to the selected one contain data. Data in adjacent cells can be of any format. 

To automatically detect the range, follow these steps: 

1. Select an empty cell bordering the range. 

2. On the Toolbar, select the Data section and click  Sort and Filter (see Figure 157). 

4.4.2.3 Sort 

When sorting, the selected values in the column are arranged in the ascending  

(from A to Z) or descending (from Z to A) order. 

To sort data in a column, follow these steps: 

1. Click the  button in the upper cell of the column (see Figure 158). 

2. In the opened sort and filter settings window, select the sorting mode: 

‒ Ascending: Sort the data in ascending order. 

‒ Descending: Sort the data in descending order. 

 

Figure 158. Sort and Filter settings dialog box 
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4.4.2.4 Filter 

Using filtering, you can hide or unhide the selected values in the column. 

To filter data, follow these steps: 

1. Click the  button in the upper cell of the column to be filtered (see Figure 158). 

2. In the opened sort and filter window, uncheck the Clear All box. 

3. If necessary, adjust the width and/or height of the window: 

‒ To increase/decrease the window width, move its right border to the right/left. 

‒ To increase/decrease the window height, move its lower border down/up. 

‒ To adjust the window width and height simultaneously, move its bottom right corner 

in the desired direction. 

4. Check the boxes with values to be displayed in the column. 

5. If there are too many values on the list, use the search field: 

‒ Enter the value you want to find (in full or partially). For example, to find the number 

123, you can enter the numbers 12, 23 or 123 in the search field. 

‒ Check the values to be displayed in the column in the search results. 

‒ To find and check other values, repeat the procedure. 

6. Click OK. 

To display all the data in the column, open the Sort and Filter window once again and check 

the Select All box. 
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4.4.2.5 Copy and insert filtered data 

After filtering, only visible data is copied from the table. Hidden data is not copied. 

Copying and pasting data can be done using standard methods 

(see Section 4.12.2.1 and 4.12.2.2). The copied data can be pasted in any place of the current or 

other MyOffice Spreadsheet document. 

4.4.2.6 Refresh the filter 

If the values in the selected range have changed, you can reapply a filter to the data without 

reconfiguring the filter itself. Simply follow these steps: 

1. On the Toolbar, select the Data section and click the arrow to the right of 

the  Sort and Filter button (see Figure 159). 

2. Select the Refresh option from the drop-down menu. 

 

Figure 159. Refresh command 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 167 

4.4.2.7 Finishing work with sorting and filtering range 

To finish working with the current sorting and filtering range, on the Toolbar, in 

the Data section, click  Sort and Filter (see Figure 160). 

 

Figure 160. Sort and Filter button 

 

When you finish working with a range, only the sorting results will be displayed in 

the spreadsheet. Filtering results will not be displayed. 
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4.4.3 Number formats 

Different formats can be applied to the numbers that are contained in the cells. The formats 

affect how the numbers are displayed. For example, numbers can be represented as units of money, 

percentages or fractions, time, or date. Also, some formats allow you to customize the type of 

representation of negative numbers, divide groups of digits in numbers, and select the number of 

digits displayed after the decimal point. 

Numeric formats are important for correctly interpreting data in application operations, such 

as calculations in formulas. 

4.4.3.1 Types of number formats 

4.4.3.1.1 General 

The General format is assigned to all cells by default when the sheet is created. The General 

format is universal, that is it can be used in all formulas and functions. 

The following numbers in the General format are automatically displayed in scientific 

notation: 

‒ Prime numbers consisting of more than 11 characters. 

‒ Fractional numbers in which the integer part consists of more than 11 characters. 

 

Once these numbers are entered in the cell, they are displayed in scientific notation. 

For fractional numbers in the General format, non-significant zeros in the fractional part are 

not displayed. 
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4.4.3.1.2 Number 

The main entry format for numbers. 

The following parameters can be set for the Number format: 

‒ Displaying numbers with a thousand separator. 

‒ The number of characters displayed after the dot (.) delimiter. 

‒ Negative number presentation type. 

 

These parameters can be set using the number format setting window (see Section 4.4.3.3). 

You can also set the number of characters displayed after the dot (.) delimiter using the buttons on 

the Toolbar (see Section 4.4.3.4). 
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4.4.3.1.3 Currency 

The Currency format is used to display monetary values which are supplemented by default 

with a currency sign or code corresponding to the system settings of your computer (see Figure 161). 

The currency sign used by default can be modified. 

 

Figure 161. Example of a number in the Currency format 

To quickly convert a cell into the Currency format, perform the following actions: 

1. Select a cell or a range the format of which you want to change. 

2. On the Toolbar, select the Number Format section and click  Currency 

(see Figure 162). 

 

Figure 162. Currency button 

A cell is automatically formatted as Currency if you specify the currency code next to 

the number. For example, 23.00 USD or USD 23.00. For the full list of supported currencies and 

their codes, see Appendix 2. List of supported currencies. 

 

If a cell is formatted as Text, entering the currency code will not affect the cell format. 

 

If you select Text format for a cell, when you enter a currency code, the format of the cell 

does not change. 
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The following parameters can be set for the number in the Currency format: 

‒ Currency code and symbol to be entered next to the number. 

‒ The number of characters displayed after the dot (.) delimiter. 

‒ Negative number presentation type. 

These parameters can be set using the number format setting window (see Section 4.4.3.3). 

You can also set the number of characters displayed after the dot (.) delimiter using the buttons on 

the Toolbar (see Section 4.4.2.4).  
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4.4.3.1.4 Accounting 

The Accounting cell format is applied to numbers used in accounting documents. 

In the Accounting format, the entered number is supplemented automatically with the currency 

name which corresponds to the system settings of your computer. 

When you enter numbers in the Accounting format: 

1. 0 (zero) in cells is automatically replaced with a hyphen (-). 

2. Negative numbers in cells are put in parentheses. 

 

On the Formula bar and in the editing mode, zeros and negative numbers are displayed 

the way they were entered (see Figure 163). 

 

Figure 163. Negative number formatted as Accounting 

For the number in the Accounting format, you can the currency code or symbol displayed 

next to the number and specify the number of decimal places displayed after the dot (.) delimiter. 

 

These parameters can be set using the number format setting window (see Section 4.4.3.3). 

You can also set the number of characters displayed after the dot (.) delimiter using the buttons on 

the Toolbar (see Section 4.4.2.4). 
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4.4.3.1.5 Date, Time or Date and Time 

If you enter a number in the Date, Time or Date and Time format in a cell, the cell is 

automatically assigned the Date, Time or Date and Time format, respectively  

(see Figure 161-Figure 166). 

If necessary, date and/or time display format can be changed using the number format setting 

window (see Section 4.4.3.3). 

 

Figure 164. Number formatted as Date 

 

Figure 165. Number formatted as Time 

 

Figure 166. Number formatted as Date and Time 

The original number corresponds to all data in the Date and Time formats.  

Its starting point for all dates is December 30, 1899, whose original number is 0.  

For example, the original number for the date of January 1, 1990 is 2. 

The original number for data in the Date format will always be integer.  

To see this number, change the cell format to General or Number. 

The original number for data in the Time format will always be integer from the range of 

from 0.0 to 0.999988426. To see this number, change the cell format to Number. 

The original number is required in calculations. Otherwise, cells with dates and time would 

be considered as text cells and could not act as arguments in formulas and functions. 
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4.4.3.1.6 Percentage 

This format is used to display numbers as percentages.  

When applying the Percentage format, the entered number is multiplied by 100 and designated with 

a percent sign (%). The initial value is displayed in the cell and supplemented with a % sign. 

 

Figure 167. Number formatted as Percentage 

To quickly convert a cell into the Percentage format, perform the following actions: 

1. Select a cell or a range the format of which you want to change. 

2. On the Toolbar, select the Number Format section and click  Percentage 

(see Figure 168). 

 

Figure 168. Percentage button 

For the numbers in the Percentage format, you can set the number of characters displayed 

after the dot (.) delimiter using the number format setting window (see Section 4.4.3.3) or 

the buttons on the Toolbar (see Section 4.4.2.4). 
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4.4.3.1.7 Fraction 

This format is used to display fractional numbers as ordinary fractions, that is the fractional 

part is replaced by a numerator and denominator (see Figure 169). 

 

Figure 169. Number formatted as Fraction 

In the Fraction format, the numerator and denominator are calculated in two ways: 

‒ Exact (for example, 0.5 = 1/2) 

‒ Approximately (for example, 1.6789 = 1 2/3) 
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4.4.3.1.8 Scientific 

The Scientific format is used to display large numbers in a short form.  

In the Scientific format, part of the entered number is replaced by E + n, where E denotes 

the scientific notation (the preceding number is multiplied by 10 to the power of n). For example, in 

the Scientific format the mass of the planet Earth (5,980,000,000,000,000,000,000,000 kg) is 

represented as 5.98E+24, which means 5.98 multiplied by 10 to the power of twenty-four. 

 

If the Scientific format is applied to a cell, the number in the cell is displayed in the scientific 

notation regardless of how many characters it contains. At the same time, numbers that contain up 

to and including 15 characters are displayed in their original form in the edit mode and on 

the Formula bar. 

 

A number in the Scientific format is displayed in a cell as follows (see Figure 170): 

‒ The integer part, always consisting of one number. 

‒ Delimiter of the integer and fractional parts. 

‒ Fractional part, consisting of two digits by default. If necessary, the number of characters 

after the delimiter can be increased or decreased (see Section 4.4.2.5). 

‒ Powers of 10 expressed as E<index of power sign><index of power>. 

 

Figure 170. Number formatted as Scientific 
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4.4.3.1.9 Text 

In the Text format, the entered data is not transformed and is displayed in the same way in 

a cell and on the Formula bar. 

Compared to the General format, data in the Text format is not considered in the calculation 

process, even if there is a number inside the cell. This format is useful when you want to exclude 

some numbers from an argument array. 
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4.4.3.2 Identify cell format 

By default, all cells are assigned the General format when documents are created. 

To modify the format, do as follows: 

1. Select a cell/range or rows/columns you want to modify the format of. 

2. On the Toolbar, select the Number section and click the field displaying the current 

format. Select the desired format from the drop-down list (see Figure 171).  

 

Figure 171. Identifying cell format 
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4.4.3.3 Number format settings 

If necessary, you can set the way the data in the cells formatted as Number, Currency, 

Accounting, Date and/or Time, and Percentage are displayed. 

To customize the formats, follow these steps: 

1. Select the cell/range or rows/columns in which you want to adjust the data display. 

2. Open the number format settings window in one of the following ways: 

‒ In the Format menu, select Number format (see Figure 172). 

 

Figure 172. Number Format Command menu option 

‒ On the Toolbar, select the Number Format section and display the list of available 

formats and select Advanced settings (see Figure 171). 

‒ Open the context menu by right-clicking the selected cells or the titles/content of 

the selected rows/columns. Run the Number Format context menu command. 

3. In the Number format window, select the format you want to customize from the list 

to the left (see Figure 173). 

4. Specify the parameters for the format (see the description below). 

5. Click OK. 

 

To navigate through the Number format window, use Tab (to move from left to right) or 

Shift+Tab (to move from right to left). If a list is selected, use the ↓ and ↑ buttons to navigate 

through it. 
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4.4.3.3.1 Number format settings 

You can set the following parameters for the Number format (see Figure 173): 

‒ Use thousands separator: If this box is checked, groups of digits in numbers are 

separated by a comma. For example, the number 123456.00 is displayed as 123,456.00. 

‒ Decimal places: With this option you can increase or decrease the number of decimal 

places displayed after the dot (.) delimiter. You can also set the number of characters 

displayed after the dot (.) delimiter using the buttons on the Toolbar 

(see Section 4.4.2.5). 

‒ Negative numbers: Select the way negative numbers formatted as Number are 

displayed. 

 

Figure 173. Number format window  
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4.4.3.3.2 Currency format settings 

You can set the following parameters for the Currency format (see Figure 174): 

‒ Symbol: Currency code or symbol used next to the numbers formatted as Currency. 

‒ Decimal places: With this option you can increase or decrease the number of decimal 

places displayed after the dot (.) delimiter. You can also set the number of characters 

displayed after the dot (.) delimiter using the buttons on the Toolbar 

(see Section 4.4.2.5). 

‒ Negative numbers: Select the way negative numbers formatted as Currency are 

displayed. 

 

Figure 174. Currency format settings 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 182 

4.4.3.3.3 Accounting format settings 

You can set the following parameters for the Accounting format (see Figure 175): 

‒ Symbol: Currency code or symbol used next to the numbers formatted as Accounting. 

‒ Decimal places: With this option you can increase or decrease the number of decimal 

places displayed after the dot (.) delimiter. You can also set the number of characters 

displayed after the dot (.) delimiter using the buttons on the Toolbar 

(see Section 4.4.2.5). 

 

Figure 175. Accounting format settings 
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4.4.3.3.4 Date, Time or Date and Time format settings 

You can set the following parameters for the cells formatted as Date, Time, and 

Date and Time (see Figure 176): 

‒ To display the Date, select the format from the Date list. In the Time list, select None. 

‒ To display the Time, in the Date list select None. In the Time list, select the format you 

want to apply. 

‒ To display Date and Time, select the formats you want to use both in the Date and Time 

lists. 

 

Figure 176. Date, Time or Date and Time format settings 
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4.4.3.3.5 Percentage format settings 

You can set the following parameters for the cells formatted as Percentage: 

Decimal places: With this option (see Figure 177), you can increase or decrease the number 

of decimal places displayed after the dot (.) delimiter. 

You can also set the number of characters displayed after the dot (.) delimiter using 

the buttons on the Toolbar (see Section 4.4.3.4). 

 

Figure 177. Percentage format settings 
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4.4.3.4 Increase and decrease decimals 

For the numbers in the Number, Currency, Accounting, Percentage, and Scientific format 

it is possible to increase or decrease the number of characters displayed after the delimiter. 

When decreasing the decimals, the last visible decimal is automatically rounded up or down 

depending on the nearest value. Standard number rounding rules are applied. 

You can adjust the number of decimals displayed after the dot (.) delimiter using 

the following tools: 

‒ Number format settings window (not available for the Scientific format) (see 4.4.3.3). 

‒ Toolbar buttons. 

To increase or decrease the number of characters after the delimiter using the Toolbar, 

follow the steps below: 

1. Select a cell or a cell range containing the numbers you want to modify. 

2. To increase the number of characters after the delimiter, on the Toolbar, select 

the Number Format section and click  Increase Decimals (see Figure 178). 

To decrease the number of characters after the delimiter click  Decrease Decimals. 

 

Figure 178. Increase Decimals and Decrease Decimals buttons 
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4.4.4 Check data 

MyOffice Spreadsheet application supports working with cells for which input date 

validation or selection of an acceptable value from a drop-down list is configured in third-party 

editors. 

The following limitations currently apply: 

‒ The data source for the drop-down list or the validation conditions for the date cannot be 

changed. 

‒ The prompt specified in a third-party editor cannot be changed. 

‒ Error messages created in third-party editors are not supported. 

‒ Drop-down lists inserted as a control or ActiveX are not supported. 

‒ When you merge cells (see Section 4.3.4.1), the data validation conditions are saved only 

from the upper-left cell of the range. When cells are split (see Section 4.3.4.2), the data 

validation conditions are saved in the upper-left cell of the range if they were set for that 

cell before the cells were merged. 

4.4.4.1 Information about working with drop-down lists 

The data source for the drop-down list can be edited in the following ways: 

‒ Edit values. 

‒ Add values within a range: When adding values to a range, a named range, a smart table, 

the values are added to the drop-down list according to their place in the range. 

‒ Delete values partially or completely: If one or more values are deleted, values are 

displayed in their place in the drop-down list (an empty cell), if all values are deleted, 

the drop-down list becomes empty. 

The values of the drop-down list are always up-to-date. For example, if there is a function 

result in the source and the function's arguments change, the corresponding value in the list is 

updated. 

The drop-down list displays the values as they appear in the source. In a cell, the display of 

the selected value is determined by the format of this cell (see Section 4.4.3). For example, if the 

drop-down list contains dates, and the General or Text format is selected for the cell, then the 

selected date in the cell will be converted according to the format: the date 02.02.2020 will be 

displayed as the value 43863. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 187 

4.4.4.2 Enter a date 

If a cell is configured to validate the specified date, in such a cell, you can enter: 

‒ Number. The application will automatically convert it to the appropriate date  

(see Section 4.4.3.1.5). For example, the number 1 will be converted to the date 

12/31/1899. 

‒ The date in any supported data display format (see Section 4.4.3.3), including time 

indication. For example, 07/12/2023 10:30 AM. 

‒ Cell reference (for example, =B1). The date in a cell can be specified directly, using a 

function or a reference to another cell. 

‒ Function (for example, =TODAY()+6). The function can be of any kind. 

An error message (see Figure 180) is displayed if: 

‒ You enter a date, a cell reference, or a function that does not comply with the validation. 

‒ You enter text into the cell or Text format is selected for the cell (see Section 4.4.3.1.9). 

To enter a date in a cell, follow the steps below: 

1. Select the cell. A prompt for entering a date will be displayed above the cell, if it was 

created in a third-party editor (see Figure 179). 

 

Figure 179. Tooltip for entering a value 

2. Enter the date in one of the ways described above. 

3. Press Enter or  button on the Formula bar. If the date is not entered as a reference or 

function, you can also click any other cell in the sheet or any column/row header. 
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If the date satisfies the validation conditions, you will quit the cell editing mode. The Date 

format is applied to a cell if another format was selected for the cell before entering the value (with 

the exception of the Text format). 

If the date does not meet the validation conditions, then (see Figure 180): 

‒ The date is highlighted. 

‒ The cell remains in editing mode. 

‒ An error message is displayed. 

 

Figure 180. Error message 

To close the error message and enter the correct date, do one of the following: 

‒ Start entering the date. The error message will close automatically. 

‒ Close the error message by clicking the  button at the top of the message or by pressing 

Esc. Enter the date. 
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4.4.4.3 Enter a value in a cell with a drop-down list 

To enter a value in a cell with a drop-down list, follow these steps: 

1. Select the cell. A prompt for entering a value will be displayed above the cell if it was 

created in a third-party editor (see Figure 181). 

 

Figure 181. Tooltip for entering a value 

2. Do one of the following: 

‒ Expand the drop-down list (see Figure 182) and select the desired value. To work 

with the drop-down list, you can use the mouse or keyboard keys (see Table 4). 

 

Figure 182. Drop-down list 
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‒ Enter the value manually. The entered value must match character by character with 

the required value in the drop-down list. The case of characters is not taken into 

account when entering a value. Press Enter or click the  button on the Formula 

bar or click any other cell in the sheet/header of any column/row. 

If the value entered manually is incorrect, the drop-down list is automatically expanded. 

The "Invalid value" error is displayed at the top of the list (see Figure 183). 

 

Figure 183. Error message 

To edit the entered value, do one of the following: 

‒ Select the correct value from the drop-down list. 

‒ Start entering the correct value manually. The drop-down list will automatically close. 

‒ Close the drop-down list by clicking the  button at the top of it or press Esc. Enter the 

correct value manually. 

 

If the field is intended only for entering the value manually, the error message is 

displayed without a drop-down list. 
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The Table 4 lists the keyboard shortcuts that are used when working with the drop-down list. 

Table 4. Keyboard shortcuts 

Action Windows / Linux  

keyboard shortcuts 

macOS  

keyboard shortcuts 

Open the list Alt + ↓ ⌥Option + ↓ 

Select a value ↓ and ↑ ↓ and ↑ 

Apply value Enter Enter 

Select the first value of the list Home Fn + ← 

Select the last value of the list End Fn + → 

One screen down Page Down Fn + ↓ 

One screen up Page Up Fn + ↑ 

Close the list Esc Esc 

 

The commands One screen down and One screen up are used to quickly view long drop-

down lists. When running commands, the list scrolls to the next or previous items. 
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4.4.5 Remove duplicates 

If several users worked on one spreadsheet, or if it was created from several spreadsheets, it 

is very likely to contain repetitive data. These data can be removed from the table automatically 

using the Remove Duplicates command. 

The search for duplicates in a spreadsheet or a specified range is carried out line by line. 

An example is shown in the Figure 184: the rows that will be deleted if one column (left) or two 

columns (right) are selected for the search are highlighted in red. 

 

Figure 184. Example of selecting rows to delete 

When removing duplicates, only the first variant of the found matches is saved, the rest are 

deleted. 

Searching for and deleting duplicates is not carried out if: 

‒ The selected range contains: 

‒ An array formula. 

‒ Cells of the pivot table (see Section 4.7). 

‒ A smart table or a part of it. If the range contains only smart table cells, duplicates 

are searched and replaced. 

‒ Grouped columns or rows (see Section 4.3.10): to find duplicates, you need to clear 

the grouping. 

‒ Merged cells (see Section 4.3.4): to find duplicates, each cell in the range needs to 

occupy the same number of rows and columns. 
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‒ There is a “break” between the selected cells/rows/columns/ranges. For example, 

columns A and C are selected, but column B is not selected. 

‒ The document sheet is protected (see Section 4.15.2). 

If the selected range contains hidden (see Section 4.3.7.1) or filtered (see Section 4.4.2) rows 

or columns, the values in them are ignored when removing duplicates. After removing duplicates, 

hidden rows and columns remain hidden. In the cells of hidden rows, the values may change because 

the cell data is shifted upward after the duplicates are removed. 

To remove duplicates, follow the steps below: 

1. Select a range to search for and remove duplicates. 

 

If one cell is selected, but adjacent cells contain data that meet the duplicate 

search and removal conditions (see restrictions above), the application 

automatically expands the range to include the adjacent cells. 

 

2. Open the Remove Duplicates window using one of the following methods: 

‒ In the Command menu, select Data > Remove Duplicates (see Figure 185). 

 

Figure 185. Remove Duplicates Command menu option 
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‒ On the Toolbar, in the Data section, click  Remove Duplicates button 

(see Figure 186). 

 

Figure 186. Remove Duplicates button 

3. In the Remove Duplicates window (see Figure 187), check the With header row box, 

if the selected range contains a row with column names. This line will be excluded from 

the selected range. 

 

Figure 187. Remove Duplicates window 

4. Check the Expand automatically box if you want to include data adjacent to the selected 

range in the search range that meets the duplicate search and removal conditions (see 

the restrictions above). 

5. In the Columns area, if necessary, uncheck the columns that you want to exclude from 

the selected range. 

6. Click OK. 
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When duplicates are successfully deleted, a pop-up message will be displayed: “N duplicate 

values found and removed. M unique values remain.” 

If there are no duplicates in the selected range, a pop-up message “No duplicates found” will 

be displayed. 
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4.4.6 Links 

You can add a link to a web page, an email address, a sheet of the current document, or 

another file to your document. 

4.4.6.1 Insert a link to a web page or email address 

MyOffice Spreadsheet recognizes and makes active links that start with www, http, https, 

ftp, and email addresses. 

Examples of the links: 

‒ www.website.ru 

‒ https://website.com 

‒ http://website.ru 

‒ ftp://192.100.0.0 

‒ mailto:user@domain.ru 

‒ user.name@domain.com 

A link such as mailto:user@domain.ru may also contain a subject line, the text of the email, 

and email addresses for sending copy and blind copy. For example:  

mailto:user@domain.ru?subject=This%20is%20the%20subject&cc=user2@domain.ru&bod

y=This%20is%20the%20body. 

 

To avoid errors when you click links, it is recommended to specify the protocol in 

the URL. For example, http://website.ru. 

The link can be displayed in the document as follows: 

‒ URL: For example, http://www.website.ru. 

‒ Text: For example, link. 

To add a link to your document as a URL, follow these steps: 

1. Copy the link from the source. 

2. Switch to the edit mode of the cell where you want to insert the link. 

3. Insert the link and press Space or Enter. 
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To add a text link to a document, follow these steps: 

1. Copy the link from the source. 

2. Specify the place to insert the link in one of the following ways: 

‒ To link the entire text in a cell, select this cell. 

‒ To format a single word in the cell text as a link, place the cursor in the word or select 

the entire word. 

‒ To format a part of the text in a cell as a link, select the entire text part. 

‒ To insert a word or text with a link to an empty cell, select the cell or place the cursor 

in it. 

3. Insert the link in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 188). 

 

Figure 188. Insert menu 

‒ On the Toolbar, in the Insert section, click  (see Figure 189). In the insert pane that 

appears, click  Link. 

‒ Right-click to open the context menu and run the Insert Link command. 

‒ Press Ctrl+K / ⌘ Cmd+K. 
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Figure 189. Insert pane 

4. In the Insert Link window, on the Web Page or File tab (see Figure 190): 

‒ If the URL field is not filled in, insert a link into it. By default, the link copied from 

the source during the first step is automatically inserted in the URL field. 

 

Figure 190. Insert Link window 
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‒ If the Text field is not filled in, enter the text that will be displayed instead of the link. 

By default, text from the selected cell or the text selected in the cell or the word on 

which the cursor is placed is automatically inserted into the Text field. 

‒ Click OK. 

 

When you save an .ods document in .xlsx format in a cell that contains multiple links at 

the same time, only the first link remains functional. 

4.4.6.2 Insert a link to a sheet of the current document 

You can create links to other sheets to make it easier to navigate through the document. 

For example, you can create a list on the first sheet with links to the other sheets of the document. 

A link to a sheet may contain: 

‒ Sheet name. For example, Sheet 2. 

‒ Any other text. For example, see on this sheet. 

To create a link to another sheet, follow the steps below: 

1. Specify the place to insert the link in one of the following ways: 

‒ To create a link with the sheet name, select an empty cell or, if the cell is not empty, 

place the cursor in the desired cell position. 

‒ To add a word or text with a link to an empty cell, select the cell or place the cursor 

in it. 

‒ To format all text contained in a cell as a link, select the cell. 

‒ To format a single word in the cell text as a link, place the cursor in the word or select 

the entire word. 

‒ To format a part of the text in a cell as a link, select the entire text part. 

2. Insert the link in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 188). 

‒ On the Toolbar, in the Insert section, click  (see Figure 189). In the insert pane that 

appears, click  Link. 

‒ Right-click to open the context menu and run the Insert Link command. 

‒ Press Ctrl+K / ⌘Cmd+K. 

3. In the Insert Link window (see Figure 191), select the Sheet in This Document tab. 

4. In the Sheets list, select the sheet to which you want to create a link. 
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5. In the Text field: 

‒ If the field displays the sheet name and you want to create a link with the sheet name, 

leave the contents of the field unchanged. 

‒ If the field displays the sheet name but you want to specify the link text, enter the 

required text manually. 

‒ If the field is filled with text from the selected cell or text selected in the cell, or a 

word on which the cursor is positioned, edit this text if necessary or leave it 

unchanged. 

6. Click OK. 

 

Figure 191. Insert Link window 

 

When you save an .ods document in .xlsx format in a cell that contains multiple links at 

the same time, only the first link remains functional. 

4.4.6.3 Insert a link to a file 

You can insert a link to a file that is located on the current computer or in a network folder 

into your document. The link can reference a file of any format. 

The link can be displayed in the document as follows: 
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‒ Paths to the file. For example, C:\Users\User\Documents\File.xlsx (Windows) or 

/Users/User/Downloads/File.xlsx (Linux and macOS). 

‒ Text: For example, link to the file. You can specify the text of the link either in the cell 

or in the link insertion window. 

To add a link to a file in your document, follow these steps: 

1. Specify the place to insert the link in one of the following ways: 

‒ To link the entire text in a cell, select this cell. 

‒ To format a single word in the cell text as a link, place the cursor in the word or select 

the entire word. 

‒ To format a part of the text in a cell as a link, select the entire text part. 

‒ To insert a word or text with a link to an empty cell, select the cell or place the cursor 

in it. 

2. Insert the link in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 192). 

 

Figure 192. Insert menu 

‒ On the Toolbar, in the Insert section, click  (see Figure 193). In the insert pane that 

appears, click the Link button. 
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Figure 193. Insert pane 

‒ Right-click to open the context menu and run the Insert Link command. 

‒ Press Ctrl+K / ⌘Cmd+K. 

3. In the Insert Link window, on the Web Page or File tab, (see Figure 194) select the file 

to which you want to insert a link using one of the following methods: 

‒ Select a file from the Recent Files list. This list displays the 50 most recent files that 

were opened in the MyOffice Spreadsheet, MyOffice Text, and MyOffice 

Presentation applications. 

 

The Recent Files list does not include files that have been opened from the Cloud 

(see Section 4.13.2). To insert a link to a file from the Cloud, copy the link address of 

the file in your browser and paste it into your document as a link to a web page 

(see Section 4.4.6.1). 

‒ Select the file using the File manager. To do this, click Choose File. 
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Figure 194. Insert Link window 

4. If you want the link to be displayed as text and the Text field is not filled in, enter 

the required text. By default, text from the selected cell or the text selected in the cell or 

the word on which the cursor is placed is automatically inserted into the Text field. 

5. Click OK. 

 

When you save an .ods document in .xlsx format in a cell that contains multiple links at 

the same time, only the first link remains functional. 

4.4.6.4 Go to the link 

To follow the link, click it while holding down the Ctrl / ⌘Cmd pressed. 

Web links are opened in the default browser used in the OS. 

Files are opened in MyOffice Spreadsheet, MyOffice Text and MyOffice Presentation 

applications. If the file format is not supported, the file is opened in the application that is used by 

default in the OS to work with files of the corresponding format. 

When you click the link to an email address, it opens the default email client in your OS. 

This software automatically creates a new email, into which the data specified in the link is copied. 

When you click a link to a sheet, the corresponding sheet of the current document is opened. 
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4.4.6.5 Copy a link 

To copy a link, right-click it and in the Context menu, select Copy Link URL. 

4.4.6.6 Edit a link 

To edit a link, follow the steps below: 

1. Specify a link to edit: 

‒ If a cell contains only a link, select that cell or place the cursor on the link, or select 

part of the link/the entire link. 

‒ If the cell contains more than just a link, place the cursor on the link or select part of 

the link/the entire link. 

2. Open the link editing window in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 192). 

‒ On the Toolbar, in the Insert section, click  (see Figure 193). In the insert pane that 

appears, click the Link button. 

‒ Right-click to open the context menu and run the Edit Link command. 

‒ Press Ctrl+K / ⌘Cmd+K. 

3. In the Edit Link (see Figure 195) window, make the desired changes. 

4. Click OK. 

 

Figure 195. Edit Link window 
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4.4.6.7 Delete a link 

The link can be deleted using the edit window or the context menu. The link is deleted 

without the text that contains it. 

To delete a link using the edit window, follow these steps: 

1. Specify the link to delete: 

‒ If a cell contains only a link, select that cell or place the cursor on the link, or select 

part of the link/the entire link. 

‒ If the cell contains more than just a link, place the cursor on the link or select part of 

the link/the entire link. 

2. Open the link editing window in one of the following ways: 

‒ In the Command menu, select Insert > Link (see Figure 192). 

‒ On the Toolbar, in the Insert section, click  (see Figure 193). In the insert pane that 

appears, click  Link. 

‒ Right-click to open the context menu and run the Edit Link command. 

‒ Press Ctrl+K / ⌘ Cmd+K. 

3. In the Edit Link window (see Figure 195), click the Remove Link button. 

 

To delete a link using the context menu, follow these steps: 

1. Specify the link to delete as described above. 

2. Right-click to open the context menu and run the Delete Link command. 

To delete multiple links at the same time, follow these steps: 

1. Select the cells that contain the link data. 

2. Right-click to open the context menu and run the Delete Links command. 

If you want to delete the link along with the text that contains it, follow these steps: 

1. Specify the link to delete: 

‒ If a cell contains only a link, select that cell or switch to cell editing mode and select 

the entire link. 

‒ If the cell contains more than just a link, switch to the cell editing mode and select 

the entire link. 

2. Press Delete or Backspace. 
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4.4.6.8 Keyboard shortcuts for moving between window elements 

The Table 5 below shows the keyboard shortcuts you can use to quickly move between 

elements in the Insert/Edit Link window. 

Table 5. Keyboard shortcuts 

Action Windows / Linux  

keyboard shortcuts 

macOS  

keyboard shortcuts 

Open the window Ctrl+K ⌘ Cmd+K 

Go to the next pane element Tab Tab 

Go to the previous pane element Shift+Tab ⇧ Shift+Tab 

Open the selected tab Space Space 

Click Select File or OK Space Space 

Click OK regardless of which window element is 

currently selected 
Enter ⌅ Enter 

Go to the next/previous file in the Recent Files list ↓ and ↑ ↓ and ↑ 

Go to the first file in the Recent files list Home Fn + ← 

Go to the last file in the Recent files list End Fn + → 

Select a file in the Recent files list Space Space 

Close the window Esc Esc 

 

4.4.7 Notes 

You can add notes to the cells of a spreadsheet. When you edit a document in collaboration 

(see Section 4.12.2), you can share comments with colleagues using notes without affecting 

the content of the document. Cells with notes are marked with a triangle in the top right corner of 

a cell (see Figure 196). 

 

Figure 196. Cell with a note 
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4.4.7.1 Add a note 

Each note is attached to one cell. The name of the user who created the note is automatically 

added to the note. 

To create a note, follow the steps below: 

1. Add a note using one of the following methods: 

‒ Left-click a cell to select it. In the Insert menu, select Note (see Figure 197). 

 

Figure 197. Insert menu 
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‒ Select the cell. On the Toolbar, select the Insert section and click . In the opened 

insert pane, select  Note (see Figure 198). 

 

Figure 198. Insert pane 

‒ Right-click a cell to select it and select Add Note in the context menu. 
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2. In the note window (see Figure 199): 

‒ Edit and format the username as needed. 

‒ Enter the note text. 

 

Figure 199. Notes window 

3. Press Esc or click outside the cell to finish and close the note. 

4.4.7.2 Edit or delete a note 

You can edit and delete both your own notes and those of other users in the document. 

To edit a note, use the following guidelines: 

1. Click the cell to open the note. 

2. Activate the edit mode in one of the following ways: 

‒ Right-click a cell and select Edit Note. The cursor will be set on the first paragraph 

of the note. 

‒ Place the cursor in the desired position manually. 

3. Edit the text of the note and, if necessary, the username. 

4. Press Esc or click outside the cell to finish and close the Note. 

To delete a note, right-click the cell containing the note and select Delete Note in 

the command menu. 
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4.4.8 Special characters 

Special characters are characters that are not present on the keyboard. This includes 

mathematical operators, dingbats, arrows, currency signs. Such symbols can be inserted using 

the special characters quick insert pane or the Special Characters window. 

4.4.8.1 Special characters quick insert pane 

To open the Special Characters quick insert pane, do one of the following: 

‒ On the Toolbar, in the Insert section (see Figure 200),  

click  Special Characters. 

 

Figure 200. Special Characters button 

‒ On the Toolbar, in the Insert section, click . In the insert pane that appears, hover 

the mouse cursor over the  Special Characters button (see Figure 201). 
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Figure 201. Insert pane 
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To insert a special character, do one of the following: 

‒ Select a character from a set of preset characters. As you work with the application, 

the preset characters change to characters added to the document by the user using 

the Special Characters window (see Section 4.5.2). When the mouse cursor hovers 

over a character, the name of the font selected for it is displayed. 

 

When inserting, the font of the document text is applied to the character. 

However, if the font of the text does not support this character, then the font 

selected by the user is used. 

‒ Select Non-Breaking Space, Non-Breaking Hyphen, or En Dash if you want to 

insert the appropriate character. 
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4.4.8.2 Special characters window 

To open the Special Characters window, do one of the following: 

1. In the command menu, select Insert > Special Characters (see Figure 202). 

 

Figure 202. Special characters menu 

‒ On the Toolbar, in the Insert section, click  Special Characters button 

(see Figure 203). In the quick insert special characters pane, select More Characters. 

 

Figure 203. More Characters option 

‒ On the Toolbar, in the Insert section, click  (see Figure 204). In the pane that appears, 

click the  Special Characters button. 
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Figure 204. Special Characters button 

‒ On the Toolbar, in the Insert section, click  (see Figure 205). In the pane that appears, 

hover the mouse over the arrow to the right of the  Special Characters button. 

In the quick insert special characters pane, select More Characters. 

 

Figure 205. More Characters option 

The Special Characters window (see Figure 206) contains the following tools: 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 215 

 

Figure 206. Special Characters window 

‒ Drop-down list for selecting the font of the special character. 

‒ Drop-down list for selecting the group and category of the character. If the font does not 

support the characters of a category group or category, it is not displayed in the list. 

‒ Characters. By default, the first character of the selected category is highlighted. 

Categories are separated from each other by a line. 

‒ The name of the highlighted character. 

‒ The code of the selected character in the Unicode system. 

‒ The typeface of the selected character. 

‒ The font of the selected character. 

‒ Other typefaces of the selected character. 
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To insert a special character using the Special Characters window, follow these steps: 

1. Select the font of the special character. You can select it in the same way as you would 

select a font in the main application window (see Section 4.11.1). 

2. Select a character category. You can select it in the same way as selecting a special 

character font. 

3. Place the cursor in the position of the document where you want to insert the character. 

4. Insert the character in one of the following ways: 

‒ Select the character by double-clicking. 

‒ Select the character with one click and click Insert. 

‒ Select the character with one click and press Enter or Space. 

If you want the window to close automatically, check the Close window after inserting 

a character box. 

To close the Special Characters window manually, click Cancel or the  button in 

the window header. 

To insert a character from the Special Characters window, follow these steps: 

1. Place the cursor in the place of the document where you want to insert the character. 

2. Insert the character in one of the following ways: 

‒ Select the character by double-clicking. 

‒ Select the character with one click and click Insert. 

‒ Select a character with one mouse click and press Enter or Space. 
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4.4.9 Current date or time 

You can quickly insert the current date or time anywhere in a document.  

To insert the current date, follow these steps: 

1. Select the place where you want to insert the date. 

2. Run the insert command in one of the following ways: 

‒ In the Insert menu, select Current Date (see Figure 207). 

 

Figure 207. Insert menu 

‒ On the Toolbar, select the Insert section and click  (see Figure 208). 

In the displayed insert pane, click  Current Date. 
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Figure 208. Insert pane 

To insert the current time in the document: 

1. Place the cursor where you want to insert the current time. 

2. Run the insert command in one of the following ways: 

‒ In the Insert menu, select Current Time (see Figure 207). 

‒ On the Toolbar, select the Insert section and click  (see Figure 208).  

In the displayed insert pane, click  Current Time. 

 

The data inserted is static, that is will not be updated when the actual date and time change. 

4.4.10 Check grammar and spelling 

MyOffice Spreadsheet can automatically check texts in English and in Russian for grammar 

and spelling mistakes. 
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4.4.10.1 Check spelling 

To enable and disable and enable Check Spelling, in the Tools menu, select 

Spelling and Grammar and then Check Spelling (see Figure 209). 

Enabling or disabling Check Spelling is only applied to the current document and does not 

affect other opened documents. 

 

Figure 209. Tools menu 

Check spelling basics: 

‒ The spell-checking dictionary is automatically selected based on the language of the first 

character in the cell. 

‒ Words missing in the selected dictionary or misspelled words are underlined with a red 

wavy line. 

‒ Changing the contents of a document restarts spell-checking. 
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4.4.10.1.1 Correct errors 

If an error is found in a word, correct it. To do this, follow the steps below: 

1. Place the mouse cursor on the word or select the word that is underlined with a red wavy 

line (see Figure 210). 

2. Right-click the word directly in the cell or in the formula line. 

3. From the context menu, choose the correct spelling of the word. 

 

If there are no correct spellings for the selected word, the context menu displays 

No suggestions. 

 

 

Figure 210. Correct an error 
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4.4.10.1.2 Turn off the underline for spelling errors 

A word recognized as misspelled by the application is underlined with a red wavy line. 

To turn this option off for a particular word, add it in the Custom dictionary (see Section 4.4.5.2) 

or in the ignore list. 

To add a word in the ignore list, follow the steps below: 

1. Move the cursor over the misspelled word underlined with a red wavy line or select it. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Ignore (see Figure 210). 

 

Once finished, the red wavy underline disappears. If a word appears several times in 

the document, the changes are applied to all repetitions taking into account the case. Such changes 

are saved within one session. When the document is opened again, the Check Spelling is launched 

again. 

If you have added a word into the ignore list by mistake, you can get back to the previous 

step by selecting the Check Spelling option. Follow these steps: 

1. Move the cursor over the word or select the word. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Check Spelling. 
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4.4.10.2 Custom dictionary 

To exclude words such as proper names, abbreviations, or technical terms in a text from 

being considered misspelled, you can add them to the Custom Dictionary. 

Before you start, make sure that the Check Spelling is on (see Section 4.4.10.1). 

4.4.10.2.1 Adding words to the dictionary 

The Custom Dictionary allows you to add only individual words. You cannot add word 

combinations to the Custom Dictionary. 

Adding words is case-sensitive. If a word can start with a capital letter and with a lowercase 

letter, add the two spellings into the dictionary. 

 

To add a word to the Custom Dictionary directly from the text, follow the steps below: 

1. Move the cursor over the word that you want to add to the dictionary or select the word. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Add to Dictionary (see Figure 210). 

 

To add a new word directly to the Custom Dictionary, follow the steps below: 

1. In the Tools menu, select Custom Dictionary (see Figure 211). 

 

Figure 211. Tools menu 

2. In the Custom Dictionary dialog menu (see Figure 212), enter the word you want 

to add. 
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Figure 212. Custom Dictionary window 

3. Click  or press Enter. 

4. Click Done to finish and close the window. 
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4.4.10.2.2 Using third-party dictionaries 

To extend the vocabulary available in MyOffice Spreadsheet, you can use third-party 

dictionaries in .dic format. Simply follow these steps: 

1. In the Custom Dictionary dialog box, click Import (see Figure 212). 

2. In the opened file manager window, select a .dic file and click Open. 

 

When finished, the contents of the dictionary will appear in your dictionary. 
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4.4.10.2.3 Delete words from the dictionary 

If necessary, you can remove words previously added in the Custom Dictionary. 

To remove a word using the Custom Dictionary menu, follow the steps below: 

1. In the Tools menu, select Custom Dictionary (see Figure 187). 

2. In the Custom Dictionary dialog box (see Figure 213) place the cursor on the word you 

want to remove from the dictionary and click Remove. 

 

Figure 213. Custom Dictionary window 

3. Click Done to finish. 

 

To remove a word without using the Custom Dictionary window, follow the steps below: 

1. Place the cursor over the word you want to remove or select this word. 

2. Right-click the word directly in the cell or on the Formula bar. 

3. In the context menu, select Remove from Dictionary. 
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4.4.10.3 Grammar checking 

To enable or disable grammar checking, in the Tools menu, select Spelling and Grammar 

and then Check grammar (see Figure 214). 

Enabling or disabling grammar checking applies to the current document and does not affect 

other opened documents. 

 

Figure 214. Tools menu 

Grammar checking basics: 

‒ The grammar checking language is selected automatically depending on the first letter 

of the cell. 

‒ The grammar checking is launched when the Space bar is pressed, or the Enter key is 

pressed, provided that the sentence is completed. 

‒ A sentence with a grammar mistake is underlined with a blue wavy line both in the cell 

and on the Formula bar. 

‒ Formulas and values are not checked. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 227 

4.4.11 Find and replace data 

 

If the document is opened in the View mode, only data search (without replacement) is 

available. 

To open the pane to find and replace data in a document, do one of the following: 

‒ In the Command menu, select Edit > Find (see Figure 215). 

 

Figure 215. Edit menu 

‒ On the Sidebar, click  Find and Replace (see Figure 216). 

 

Figure 216. Find and Replace button 

‒ Press Ctrl+F or Ctrl+H / ⌘Cmd+F. 
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In the Find and Replace pane (see Figure 217), specify the parameters for searching and 

replacing data: 

1. Specify the data Search area: 

‒ Current sheet: Perform a search on the currently open sheet. 

‒ All Sheets: Perform a search through all sheets of the document. 

 

Figure 217. Search parameters 

2. If necessary, check the required Filters: 

‒ Match whole words only: Find only whole words/values, not data that is part of 

other words/values. 

‒ Match case when searching: Perform the search taking into account uppercase and 

lowercase letters in the text you are looking for. 

‒ Match case when replacing: Perform the replacement taking into account the 

uppercase and lowercase letters in the found text. Example: You need to replace the 

word agreement with the word contract in the text of the document. In this case, the 

word agreement can be written with both lowercase and uppercase letters  
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(for example, at the beginning of a sentence). Check the box Match case when 

replacing so that the word agreement with a lowercase letter is replaced by the word 

contract with a lowercase letter, and the word Agreement with a capital letter is 

replaced by the word Contract with a capital letter. 

 

Case is taken into account only for the first character in the found word. 

To find the data in the document, follow these steps: 

1. In the Find field, enter the data to search for (see Figure 218). 

2. Click the  button or press Enter. 

 

Figure 218. Data for search 

The matches found will be highlighted in the document (see Figure 219). 

Use the  buttons below the search and replace bars (see Figure 218) to navigate through 

the cells with matches found. The selected match will be highlighted in the document with 

a contrasting yellow color (see Figure 219). 

Search parameters (see Figure 217) can be changed while you are working with matches. 

The search results are updated automatically. 
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Figure 219. Matches found 

To replace matches found in the document, follow the steps below: 

1. In the Replace with bar (see Figure 218), enter the data to replace or leave the field blank 

if you want to delete the found match. 

2. Replace the matches with one of the following methods: 

‒ Click Replace to replace the highlighted match. 

‒ Click Replace All to replace all matches found simultaneously. 

 

You cannot replace a part of the found value or a part of the found result of a formula 

calculation. The value or the result of a formula calculation can only be replaced in its 

entirety. 

To close the Find and Replace pane, do one of the following: 

‒ At the top of the pane, click . 

‒ On the Sidebar, click  Find and Replace. 

‒ Press Esc. 
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4.4.12 Delete data 

To delete one or more characters in a cell, use one of the following methods: 

‒ Place the cursor after the characters you want to delete. If you are working in Windows 

/ Linux, delete characters by pressing Backspace as many times as needed, if you are 

working in macOS, delete them by pressing Delete. 

‒ Place the cursor before the characters you want to delete. If you are working in Windows 

/ Linux, delete characters by pressing Delete as many times as needed, if you are working 

in macOS, delete them by successively using Fn+Delete shortcut. 

To delete a word or its part in a cell, do one of the following: 

‒ Place the cursor after a word or word part that you want to delete. When working in 

Windows / Linux, press Ctrl+Backspace, when working in macOS, use ⌘Cmd+Delete 

or ⌥Option+Delete shortcut. 

‒ Place the cursor before a word or word part that you want to delete. When working in 

Windows / Linux, press Ctrl+Delete, when working in macOS, use  ⌘Cmd+Fn+Delete 

or ⌥Option+Fn+Delete shortcut. 

To delete some text in a cell, do the following: 

1. Select the desired text. 

1. When working in Windows / Linux OS, press Delete or Backspace, when working in 

macOS, press Delete or use Fn+Delete shortcut. 

To clear the content of the cell, do the following: 

1. Select the cell or range to be cleared of data. 

2. When working in Windows / Linux OS, press Delete or Backspace, when working in 

macOS, press Delete. 
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4.5 Formulas and functions 

Formula: Any expression in a cell that starts with an equal sign (=).  

Formulas can contain functions, values, cell names, and operators. 

Function: A predefined formula in MyOffice Spreadsheet that needs arguments to calculate 

correctly. For a complete list of functions, see Appendix 1. Functions and their description. 

4.5.1 Formulas and functions basics 

‒ Formulas always begin with an equal sign (=). 

‒ The equal sign can be followed by functions, constants, cell references, operators, and 

other elements. 

‒ All opening and closing brackets must be in sync. 

‒ The mandatory arguments of functions must be specified. 

‒ The constants should not contain a dollar sign ($). 

 

In Microsoft Windows, if "." is selected in the Customize Format window, in Decimal 

symbol field, use "," instead of ";" as the separator of values in functions in 

MyOffice Spreadsheet application. 

For CELL and INFO functions enter text parameters in English, enclosing them in double 

quotation marks and using the semicolon ";" delimiter. For example,  

=CELL("contents";A2), =INFO("system"). 
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4.5.2 Order of operations in a formula 

If a formula contains several operations, MyOffice Spreadsheet will perform calculations 

based on the following order of operations: 

‒ Operations enclosed in parentheses are performed first: 

‒ The order of operations depends on their priority (see Table 6). 

‒ Operations in the nested parentheses are performed first. 

‒ If a formula contains parentheses that are not essential in the calculation, they will be 

deleted automatically. For example, the formula =SUM(1+(2*5)+1) will be 

automatically transformed into =SUM(1+2*5+1). 

‒ Operations outside the parentheses are performed according to their precedence. 

‒ Operations with the same precedence are performed from left to right, except for 

the exponentiation (^), which is performed from right to left. Example: = 2^4^2 =2^16 

= 65,536 
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If you combine several operators in a single formula, MyOffice Spreadsheet performs 

the operations in the order shown in Table 6. 

Table 6. Operator precedence 

Priority Operator  Meaning 

1 : Range 

2  Space 

3 % Percentage 

4 + 

- 

 

Unary plus 

Unary minus 

Unary space 

5 ^ Exponentiation 

6 * 

/ 

Multiplication 

Division 

7 + 

- 

Addition 

Subtraction 

8 & Concatenation 

9  

= 

> 

< 

>= 

<= 

<> 

Comparison operators: 

Equal to 

Greater than 

Less than 

Greater than or equal to 

Less than or equal to 

Not equal to 

4.5.3 Referencing cells and cell ranges 

Referencing is linking to cells or ranges for further use in calculations. 

There are three types of references: 

‒ Relative: This type of references changes when copying or auto-filling. By default, all 

references in the editor are relative. 

‒ Absolute: This type of reference does not change when copying or auto-filling. 

Therefore, they should be used for formulas that have constant values, such as interest 

rates. 

‒ Mixed: This type of reference allows you to combine both absolute and relative 

references. For example, the B$5, D$12 reference the row number remains the same, but 

the column name may change. 
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4.5.3.1 A1 cell reference style 

The A1 reference style (see Table 7) is used in MyOffice Spreadsheet by default. 

In the A1 reference style, the cell address consists of a column letter name and a numeric 

row name. For example: A1, C12, G37, ND185 etc. 

When creating a sheet, the workspace contains: 

‒ 20 rows numbered from 1 to 20 

‒ 10 columns named from A to J 

When you expand the workspace, new columns continue single-letter naming followed by 

two-letter naming: AA, AB, AC, then BA, BB, BC, etc. 

If the two-letter combinations end, the columns will be given three-letter names. 

When you add rows to a table, the new items continue to be numbered. 

Table 7. Absolute and relative references in the A1 reference style 

Relative reference A1 

Absolute reference $A$1 (the column and row are not changed during copying) 

Mixed references $A1 (the column is not changed during copying) 

A$1 (the row is not changed during copying) 
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4.5.3.2 R1C1 cell reference style 

To enable the R1C1 reference style, in the View command menu, select R1C1  

(see Figure 220). 

 

Figure 220. View menu 

In the R1C1 style, both columns and rows are denoted by numbers (see Table 4).  

The address of a cell is determined using the formula RnCm, where: 

‒ R – row character, and n – row number. 

‒ C – column character, and m – column number. 

For example, the name of D5 cell in the R1C1 style is R5C4. 
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Table 8. Absolute and relative references in the R1C1 reference style 

Absolute reference R3C2 (an absolute reference to a cell at the intersection of row 3 and 

column 2) 

R3 (an absolute reference to row 3) 

C2 (an absolute reference to column 2) 

Relative reference RC (a relative reference to the current cell) 

R[-2] (a relative reference to the row located 2 rows above the current row) 

C[3] (a relative reference to the column located 3 columns to the right of 

the current column) 

Mixed references RC5 (a reference to a cell in the current row in column 5) 

RC[-5] (a reference to a cell located in the current row 5 columns to the left 

of the current cell) 

R3C[2] (a reference to a cell located in row 3, 2 columns to the right of 

the current cell) 

R[3]C[-2] (a reference to a cell located 3 rows below and 2 columns to 

the left of the current cell) 

R[-3]C[2] (a reference to a cell located 3 rows above and 2 columns to 

the right of the current cell) 

If a spreadsheet contains absolute references when switching from the A1 to 

R1C1 reference style, they will remain absolute afterwards. 
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4.5.3.3 Cell range reference 

The reference to a cell range is defined by referencing its two corner cells: 

‒ Starting cell: The upper-left cell of the range. 

‒ End cell: The lower-right cell of the range. 

 

The starting and end cells are separated by the colon (:) sign. For example: B4:D6  

(see Section 4.6.4). 

If the R1C1 style is selected for cells referencing, in some cases you do not need to use 

the (:) range operator. For instance, if you want to reference the range of all cells of one row, you 

can only specify a reference to this row (that is the R1 reference refers to the range of all cells of 

the first row). 
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4.5.4 Recalculation of formulas 

When you open a document in .xlsx format, the values of cells with formulas are not 

automatically recalculated by default. The cells contain already existing formula calculation results 

from the file cache. 

If you want to force a formula recalculation, follow one of the steps below: 

‒ In the Command menu, select Data > Force Calculate (see Figure 221). 

 

Figure 221. Force Calculate Command menu option 

‒ Press Ctrl+Shift+F9 / ⇧ Shift+⌘ Cmd+F9. 
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4.5.5 Automatic calculation 

If you select a range of cells, MyOffice Spreadsheet automatically calculates 5 of the most 

used functions and displays the results in the Status bar (see Figure 222): 

‒ SUMM: Calculates the sum of all numbers in the selected range. 

‒ AVERAGE: Calculates the average value of all numbers in the selected range. 

‒ MIN: Displays the smallest value among all the numbers in the selected range. 

‒ MAX: Displays the highest value among all the numbers in the selected range. 

‒ COUNTA: Displays the number of values in the selected range. Numerical and text 

values are considered. 

 

 

To configure the list of available functions, follow these steps: 

1. In the Status bar, press the  button. 

2. In the opened list, check the boxes of the functions that will be displayed in 

the Status bar. 

 

Figure 222. Selecting the displayed functions 
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4.5.6 Enter functions 

For a complete list of functions in MyOffice Spreadsheet, see Appendix 1. Functions and 

their description. 

You can enter a function directly into a cell, on the Formula bar, or using the Insert function 

pane. 

To enter a function in a cell or using the Formula bar, follow these steps: 

1. Select the cell in which you want to enter a function. 

2. On the Formula bar or in the cell, type an equal sign (=). 

3. Start typing the name of the function to display a list of available functions  

(see Figure 223). 

4. Select the desired function from the list provided using the mouse or keyboard keys: 

‒ Select the function in the list by clicking it. 

‒ Select the function using the ↓ and ↑ buttons and press Enter. 

 

Figure 223. List of functions  
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5. Detailed information about the function is available. To display it, click the  button to 

the right of the function’s name in the tooltip box (see Figure 224). 

Move the tooltip box with the description with the left mouse button pressed. 

 

Figure 224. Description of a function 

6. Enter function arguments. 

 

In Microsoft Windows, if "." is selected in the Customize Format window, in Decimal 

symbol field, use "," instead of ";" as the separator of values in functions in 

MyOffice Spreadsheet application. 

7. To finish, click the  button on the Formula bar or press Enter. To cancel, click 

the  button on the Formula bar or press Esc. 

 

To enter a function using the Insert function pane, follow these steps: 

1. Select the cell in which you want to enter a function. 

2. Expand the Insert function pane in one of the following ways: 

‒ In the Insert menu, select Function (see Figure 225). 

 

Figure 225. Insert menu  
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‒ On the Formula bar, click  (see Figure 226). 

 

Figure 226. fx button 

‒ On the Toolbar, select the Insert section and click . In the displayed insert pane, 

select  Function (see Figure 227). 

 

Figure 227. Insert menu 

‒ On the Sidebar, click the  Insert Function button (see Figure 227). 

‒ Press Shift+F3.  

3. Find the required function in one of the following ways: 

‒ Enter part of the function name/the whole name in the search field. Below is a list of 

functions that meet the search conditions. 

‒ Select the group that the function belongs to. For example, the SUM function is 

included in the Math & Trig group. 

‒ Find the function in one of the following groups: 

• All: Contains all the functions supported by MyOffice Spreadsheet. 

• Recent: Contains the last 10 functions entered by the user. 
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• Most popular: Contains a fixed list of 10 frequently used functions. 

 

Figure 228. Insert function pane 

4. Select the required function. 

5. If necessary, check out the function summary at the bottom of the Insert function pane. 

6. To insert a function into a cell, do one of the following: 

‒ Click Insert. 

‒ Select the function by double-clicking. 

‒ Press Enter. 

7. Enter the arguments of the function. 
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In Microsoft Windows, if "." is selected in the Customize Format window, in Decimal 

symbol field, use "," instead of ";" as the separator of values in functions in 

MyOffice Spreadsheet application. 

8. To finish entering the function, press the button  on the Formula bar or press Enter. 

To cancel entering a function, press the button  on the Formula bar or press Esc. 

9. To close the Insert function pane, do one of the following: 

‒ In the Command menu, select Insert > Function (see Figure 225). 

‒ On the Formula bar, click  (see Figure 226). 

‒ On the Toolbar, in the Insert section, click . In the insert pane that appears, click 

the  Function button (see Figure 227). 

‒ On the Sidebar, click  Insert Function (see Figure 228). 

‒ Click the button  at the top of the Insert function pane (see Figure 228). 

‒ Press Shift+F3. 
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4.5.7 Replace a formula with its result 

For your convenience you can replace a formula or a part of a formula in a cell with its result. 

Simply follow these steps: 

1. Select the formula or a part of the formula directly in the cell or on the Formula bar. 

A tooltip appears above the selected part of the formula or above the formula itself, 

which contains the calculated value. 

2. Press the F9 key to replace formula, fully or partially, with the calculated value. 

4.5.8 Copy and insert formulas 

If necessary, you can cut or copy formulas from one cell/row/column and paste the final 

value of these formulas into another cell/row/column without the formulas themselves. 

To cut or copy a formula, do the following: 

1. Select the cell, cell range, rows, or columns from which you want to cut or copy formulas. 

2. Copy a formula in the usual way (see Section 4.12.2.1). 

 

To insert the result of formula calculation without the original formatting: 

1. Select where you want to enter the resulting value of the formula. 

‒ If the clipboard contains data from a single cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column where you want to paste the contents of the first 

cell/row/column in the range. 

2. To insert the result of a formula calculation without the original formatting, do one of 

the following: 

‒ In the Edit menu, select Paste Values Only (see Figure 229). 
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Figure 229. Edit menu 
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‒ On the Toolbar, select the Edit section and click the arrow to the right of 

the  Paste button. In the drop-down list, select Paste Values Only  

(see Figure 230). 

 

Figure 230. Paste Values Only command 

‒ Open the context menu of the cell by right-clicking and run the Paste Values Only 

command. 

To paste the result of a formula calculation while preserving the original formatting, do one 

of the following: 

‒ Select the Edit > Paste Values and Format Command menu item (see Figure 229). 

‒ On the Toolbar, under Edit, click the arrow to the right of the  Paste button and 

choose Paste Values and Format from the drop-down list (see Figure 205). 

‒ Open the context menu of the cell by right-clicking and run 

the Paste Values and Format command. 

‒ Press Ctrl+Alt+V / ⌥Option+⌘Cmd+V. 
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4.5.9 Names in formulas and functions 

When you work with large data sets, you can give names to frequently used cells, cell ranges, 

constants, and formulas. Names are used in formulas and functions and make them easier to write 

and understand.  

For example, the function =SUM(Sales) is entered and understood more easily than 

the function =SUM(D2; D20). 

Names are divided into two types: 

‒ Defined: Names that the user manually assigned to cells, ranges, constants, and 

formulas. 

‒ Table: The names of tables that have tabular formatting style applied in Microsoft Excel 

(also called "smart" tables). Smart table names are automatically created in 

Microsoft Excel. 

 

In addition, names are varied by their area of application: 

‒ Global: Can be used on any spreadsheet sheet. 

‒ Local: Can be used only on the sheet on which they were set. 

 

The following interface elements are used to work with names: 

‒ Range field: The field is located to the left of the Formula bar (see Figure 231). You can 

expand the range field if necessary. To do this, move the cursor to the right border of 

the field so that it looks like a bidirectional arrow, and while keeping the left mouse 

button pressed, move the field boundary to the right. 

 

Figure 231. Range field 
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‒ Name Manager: It opens when you click the  Name Manager button on the Sidebar 

(see Figure 232). 

 

Figure 232. Name Manager 
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4.5.9.1 Define name 

The name may contain the following elements: 

‒ Letters 

‒ Digits (cannot be used at the beginning of the name) 

‒ Symbols 

‒ _ (underscore) 

‒ \ (backslash) 

‒ . (dot) (cannot be used at the beginning of the name) 

 

The name can be set using the range field (quick way) or using the Name Manager. 

4.5.9.1.1 Define name with range field 

You can use a range field to name a cell or a range of cells. The name specified using 

the range field is global. 

To specify a name using a range field, do the following: 

1. Select the cell or range of cells to specify a name. 

2. Enter a name in the range field. 

 

Figure 233. Create a name using the range field 

3.  To save the name, press Enter. If you want to delete the data you entered when creating 

the name, press Esc. 
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4.5.9.1.2 Define name using Name Manager 

You can use the Name Manager to name a cell, a range of cells, a constant, or a formula. 

To define a name using the Name Manager, do the following: 

1. If you want to name a cell or a range of cells, select them on the sheet. If you want to 

name a constant or formula, skip this step. 

2. Open the Name Manager in one of the following ways: 

‒ In the Command menu, select Data > Define Name (see Figure 234). 

 

Figure 234. Define Name command menu command 

‒ Right-click the selected cell or cell range to open the context menu and run 

the Define Name command. 

‒ On the Sidebar, click the  Name Manager button. In the Name Manager, click 

Define Name (see Figure 235). 

 

Figure 235. Define Name button 
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3. In the Name Manager, specify the data to create the name (see Figure 236): 

‒ In the Name field, specify the name of the cell/range/constant/formula or leave 

the default name. The default name is [Name_n], where n is the ordinal number of 

the named item. 

 

Figure 236. Create a name using the Name Manger 

‒ If a name is created for a cell/range, a reference to the cell/range selected in 

the first step is automatically generated in the Reference field. If necessary, 

the reference can be edited manually, or you can select another cell/range on 

the sheet with the mouse so that the reference will be edited automatically. If a 

name is created for a constant or formula, enter the desired constant/formula 

manually in the Reference field. 

 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 254 

 

References to cells and cell ranges are displayed as absolute by default. You 

can convert them to relative ones manually. 

‒ In the drop-down list specify where the name will be used: on all sheets of 

the spreadsheet or on a specific sheet. 

4. Click the Done button or press Enter. 

The created name appears in the Name Manager list (see Figure 237). 

 

Figure 237. Name created in the Name Manager 
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4.5.9.2 Find a name 

The name can be found using the range field or the Name Manager. 

 

The search is not case-sensitive. 

4.5.9.2.1 Find using the range field 

To quickly find a name, do the following: 

1. Click the range field. 

2. Start typing the desired name. The names that match the search conditions will appear in 

the drop-down list (see Figure 238). 

3. Select the desired name using the mouse or the keyboard keys: 

‒ Left-click the name with the mouse. 

‒ Select the name using the ↓ and ↑ keys and press Enter. 

 

Figure 238. Quick name search 

To view the entire list of names and select the desired name from it, follow these steps: 

1. Expand the entire list of names. To do this, in the range field, click the  button 

(see Figure 239). 

2. Select the desired name in the list using the mouse or the keyboard keys: 

‒ Left-click the name with the mouse. 

‒ Select the name using the ↓ and ↑ keys and press Enter. 
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Figure 239. Name list 

If the selected name belongs to a cell/range, that cell/range is highlighted in the spreadsheet. 

If the selected name belongs to a constant or formula, the Name Manager opens and 

automatically selects a line for that name. 

If the name of a cell/cell range/constant/formula is selected in the cell editing mode, it is 

entered in the cell as the value of the formula/function (see Section below). 
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4.5.9.2.2 Find using the Name Manager 

Open the Name Manager in one of the following ways: 

‒ On the Sidebar, click  Name Manager button (see Figure 240). 

 

Figure 240. Name Manager 

‒ In the range field, click  and select Manage Defined Names (see Figure 241). 
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Figure 241. Manage Defined Names 

The Name Manager displays a complete list of names that the current spreadsheet contains 

(see Figure 240). Use the search bar and filter/sorting tools to quickly search through the list. 

To search a name using the search bar, do the following: 

1. Set the cursor in the search bar. 

2. Start entering the desired name or a link/constant/formula to which the name has been 

assigned (see Figure 242). 

 

Figure 242. Search bar 
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As you enter data for the search, the list of names will be reduced to values that match 

the search conditions. 

To filter the list, do the following: 

1. Click the All names field (see Figure 243). 

2. In the drop-down list, specify which name group should be displayed in the list: 

‒ Defined names: Names created manually by the user. 

‒ Table names: Smart table names. 

‒ Local: current sheet: The names which can be used on the currently opened sheet. 

‒ Global: all sheets: Names that can be used on any spreadsheet sheet. 

 

Figure 243. All names field 
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To select the list sorting type, do the following: 

1. Click  (see Figure 244). 

2. Select the sorting type: 

‒ Name (A-Z): Sorting by the value specified in the Name field (in ascending order). 

‒ Name (Z-A): Sorting by the value specified in the Name field (in descending order). 

‒ Reference (A-Z): Sorting by the value specified in the Reference field (in ascending 

order). 

‒ Reference (Z-A): Sorting by the value specified in the Reference field 

(in descending order). 

 

Figure 244. Selecting the sorting type 

To see which cell/range corresponds to which name, select that name in the list. 

The cell/range will be highlighted in the spreadsheet. 

If the name of a cell/cell range/constant/formula is selected in the cell editing mode, it is 

entered in the cell as the value of the formula/function (see Section below). 
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4.5.9.3 Enter the name in a formula or function 

Formulas and functions that contain names of cells/cell ranges/constants/formulas are 

entered as usual. 

Names in formulas or functions can be entered as follows: 

‒ Manually 

‒ Using the range field 

‒ Using the Name Manager 

 

To enter the name manually, do the following: 

1. Start typing the name (see Figure 245). The drop-down list will display the names which 

correspond to the search parameters. 

2. Select the name using the mouse or the keyboard keys: 

‒ Left-click the name with the mouse. 

‒ Select the name using the ↓ and ↑ keys and press Enter. 

 

Figure 245. Enter names manually 

To enter a name using a range field, search for it as described in Section 4.5.9.2.1 

(see the example in Figure 246). 
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Figure 246. Entering name using the range field 

To enter the name using the Name Manager, do the following: 

1. Perform the name search as described in Section 4.5.9.2.2. 

2. Select a name with the mouse or keyboard keys (see Figure 247):  

‒ Select the name with a double-click. 

‒ Select the name with the ↓ and ↑ keys and press Enter. 

 

Figure 247. Enter name using Name Manager 

The selected name will be substituted in the formula/function. If the name belongs to 

a cell/range, the cell/range will be highlighted in the spreadsheet. 

 

If necessary, you can enter a local name from another sheet into a formula/function. To do 

this, select it in the range field or in the Name Manager or manually enter a reference 

like 'Sheet Name'!MyName. For example: 'Sheet2'!Name_8. 
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4.5.9.4 View name properties 

To view the name properties, do the following: 

1. Open the Name Manager in one of the following ways: 

‒ On the Sidebar, click  Name Manager button (see Figure 248). 

‒ In the range field, click  and run the Manage Defined Range command  

(see Figure 248). 

 

Figure 248. Manage Defined Names command 

2. In the Name Manager, place the cursor on the desired name and click the  Expand 

button (see Figure 249). 

 

Figure 249. Expand button 

If the name belongs to a cell/range, the cell/range will be highlighted in the spreadsheet. 
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The Name Manager displays the properties of the selected name (see Figure 250). The text 

in the Name and Reference fields can be copied if necessary. 

To hide the name properties, click Collapse. 

 

Figure 250. Name properties 
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4.5.9.5 Delete a name 

You can delete names created manually. Deleting names of smart tables is not possible. 

To delete a name, do the following: 

1. Open the Name Manager in one of the following ways: 

‒ On the Sidebar, click  Name Manager button (see Figure 249). 

‒ In the range field, click the  button and run the Manage Defined Names command 

(see Figure 248). 

2. In the Name Manager, place the cursor on the desired name and click the  Expand 

button (see Figure 249). 

3. Click  Delete (see Figure 250). 
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4.5.10 Reference to data in another document 

In the formulas and functions of the current document, you can refer to data from one or 

more external documents. 

The following restrictions apply in this version of the application: 

‒ The current and external documents must be saved in .xlsx, .ods or .xods format. 

‒ The current and external documents must be local, that is, they must be stored directly 

on your computer. 

‒ The creation of references to cells and cell ranges of an external document is supported. 

The use of structured references (see Section 4.5.11), as well as references to cell names and 

ranges, is not allowed (see Section 4.5.9). 

‒ The reference that is entered manually into the cell with the name (see Section 4.5.9) 

must be absolute. 

You can create a reference to data from an external document in one of the following ways: 

‒ Open an external document and select the desired cell or range of cells with a mouse 

click. 

‒ Enter the reference manually without opening an external document. 

4.5.10.1 Create a reference with a mouse click 

To create a reference to data from an external document in a formula or function of 

the current document by clicking the mouse, follow these steps: 

1. Open a document that will contain a formula or function with a reference, and an external 

document to which data you want to create a reference. If the external document was 

opened earlier, make sure that all the changes you made are saved in it (see Section 4.1.7). 

2. In the current document, select the cell where you want to enter a formula or function. 

3. On the Formula bar or directly in the cell, enter the = sign and start typing the formula 

or function. 

4. Navigate to the external document and select the sheet whose cell or range of cells you 

want to refer to. 

5. Select the desired cell or range of cells on the sheet. The Formula bar of the external and 

current document displays the entered formula or function from the current document. 

If necessary, the formula/function can be edited both in the current and in an external 

document. 
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6. Go to the current document, finish entering the function or formula and click 

the  button on the Formula bar or press Enter. 

4.5.10.2 Enter the reference manually 

To manually create a reference to data from an external document in a formula or function of 

the current document, enter a string of the following type: 'path[name.extension]Sheet'!Cell where: 

‒ path: the path to the external document, which can be specified as: 

‒ Relative path: The path to the external document described relative to the base directory 

of the source document. Example: ../Subfolder/External document.xlsx. 

‒ Absolute path: The path to the document described from the root of the logical disk 

(the root of the installed operating system).  

Example: C:/Users/Username/Downloads/Subfolder/External document.xlsx. 

‒ The absolute path to the external document using the file scheme (URI scheme). Example: 

file:///C:/Users/Username/Downloads/Subfolder/External document.xlsx. 

‒ name.extension: The name and extension of the external file.  

For example: External document.xlsx. 

‒ Sheet: The name of the sheet in the external document. Example: Sheet1. 

‒ Cell: The address of a cell or range of cells in an external document. For example: A1 

or A1:A10. 

 

Examples for Microsoft Windows OS 

In example below, the document document.xlsx located in the base directory 

C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

the same directory. 

Relative path to external 

document 

../external.xlsx 

Absolute path to 

external document 

C:/Users/Username/Downloads/external.xlsx 

The absolute path to the 

external document using 

the file scheme (URI 

scheme) 

file:///C:/Users/Username/Downloads/external.xlsx 

Formula with relative 

reference 

='[external.xlsx]Sheet 1'!A1+A1 

Function with absolute 

reference 

=SUM('file:///C:/Users/Username/Downloads/[external.xlsx]Sheet1'!A1:A10) 
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In example below, the document document.xlsx located in the base directory 

C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

a nested directory C:/Users/Username/Downloads/Subfolder/. 

Relative path to external document ../Subfolder/external.xlsx 

Absolute path to external document C:/Users/Username/Downloads/Subfolder/external.xlsx 

The absolute path to the external 

document using the file scheme (URI 

scheme) 

file:///C:/Users/Username/Downloads/Subfolder/external.xlsx 

Formula with relative reference ='Subfolder/[external.xlsx]Sheet1'!A1+A1 

Function with absolute reference =SUM('file:///C:/Users/Username/Downloads/Subfolder/ 

[external.xlsx]Sheet1'!A1:A10) 

In example below, the document document.xlsx located in the base directory 

C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

another directory – D:/Documents/SomeFolder/. 

Relative path to external document D:/Documents/SomeFolder/external.xlsx 

Absolute path to external document D:/Documents/SomeFolder/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///D:/Documents/SomeFolder/external.xlsx 

Formula with relative reference ='D:/Documents/SomeFolder/[external.xlsx 

]Sheet1'!A1+A1 

Function with absolute reference =SUM('file:///D:/Documents/SomeFolder/[external.xlsx] 

Sheet1'!A1:A10) 
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Examples for Linux and macOS 

In example below, the document document.xlsx located in the base directory 

/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

the same directory. 

Relative path to external document ../external.xlsx 

Absolute path to external document /Users/Username/Downloads/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///Users/Username/Downloads/external.xlsx 

Formula with relative reference ='[external.xlsx]Sheet 1'!A1+A1 

Function with absolute reference =SUM('file:///Users/Username/Downloads/ 

[external.xlsx]Sheet1'!A1:A10) 

In example below, the document document.xlsx located in the base directory 

/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

a nested directory /Users/Username/Downloads/Subfolder/. 

Relative path to external document ../Subfolder/external.xlsx 

Absolute path to external document /Users/Username/Downloads/Subfolder/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///Users/Username/Downloads/Subfolder/external.xlsx 

Formula with relative reference ='Subfolder/[external.xlsx]Sheet1'!A1+A1 

Function with absolute reference =SUM('file:////Users/Username/Downloads/Subfolder/ 

[external.xlsx]Sheet1'!A1:A10) 

In example below, the document document.xlsx located in the base directory 

/Users/Username/Downloads/ refers to data from an external document external.xlsx located in 

another directory, /Volumes/USB_flash/SomeFolder/. 

Relative path to external document /Volumes/USB_flash/SomeFolder/external.xlsx 

Absolute path to external document /Volumes/USB_flash/SomeFolder/external.xlsx 

The absolute path to the external document 

using the file scheme (URI scheme) 

file:///Volumes/USB_flash/SomeFolder/external.xlsx 

Formula with relative reference ='../Volumes/USB_flash/SomeFolder/[external.xlsx] 

Sheet1'!A1+A1 

Function with absolute reference ='file:///Volumes/USB_flash/SomeFolder/[external.xlsx] 

Sheet1'!A1:A10) 
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4.5.10.3 Update data 

Since the data in the external document may change, it is recommended to periodically 

update the reference to this data in the current document. 

To update the references after opening the current document, click the Refresh Data button 

in the notification line “Linked documents might have changed. Refresh this document to get 

the latest data” (see Figure 251). This line is displayed under the Toolbar. 

The application will recalculate formulas and functions taking into account new values from 

an external document. 

 

Figure 251. Refresh Data button 

If the document is not available, the notification line "Linked documents are unavailable. 

The spreadsheet uses the last saved data." Click Close in this line (see Figure 252). 

 

Figure 252. Close button 

To update the data when working with a document, do one of the following: 

‒ In the Command menu, select Data > Refresh Data (see Figure 253). 
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Figure 253. Data menu 

‒ On the Toolbar, in the Data section, click  Refresh Data button (see Figure 254). 

 

Figure 254. Refresh Data button 

‒ Press Ctrl+Shift+F5 / ⇧Shift+⌘Cmd+F5. 

 

Error #REF! displayed in cells if: 

− When creating a reference, the external document specified in the reference is 

unavailable (or the specified sheet does not exist in it), and there are no previously 

saved values for it. 

− When uploading a document, there are no saved values for the external document 

specified in the reference (the data was not received when creating the reference). 
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4.5.11 Structured references 

You can use structured references with the so-called "smart" tables. These are 

Microsoft Excel spreadsheets to which the table formatting is applied. 

By default, "smart" tables are named as Table 1, Table 2 etc., and consist of the following 

elements: 

‒ Heading line 

‒ Data area 

‒ Result line 

4.5.11.1 Use structured references 

Formulas with structured references do not operate with cells or range references, but with 

the names of the table and columns of the table, as well as the names of table areas. 

Below are examples of common and structured references. 

Table 9. Reference examples 

Description Regular 

reference 

Structured reference 

Reference to cell range of the Sales 

column in Table 1 

=SUM(B2:B8) =SUM(Table1[Sales]) 

Reference to the data area in Table 2 =SUM(A2:C8) =SUM(Table2[#Data]) 

 

Figure 255. Structured reference 

Structured references can be used both in the table and outside of it. 
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If the formula with the structured reference is located directly in the table, you do not need 

to specify the name of the table in this reference. If the table name is specified in the link for any 

reason, it is automatically deleted when you enter the formula. For example, the formula 

=SUM(Table1[Sales]) will be automatically replaced with =SUM([Sales]). 

If a formula with a structured reference is located outside the table, the name of the table 

must be specified. 

To find out the name of a table, select any cell in it. The table name will appear on 

the Toolbar, under the Table section (see Figure 256). 

To copy a table name, select it by clicking it. 

 

Figure 256. Table name 

 

4.5.11.2 Structured reference syntax 

Structured references can refer to the following table data: 

Table 10. References 

Reference Description 

#All The whole table, including the heading line and the result line (if any) 

#Headings The heading line only 

#Data Data lines only 

#Totals Result line only 

@Column name 

OR 

@ 

OR 

#This row 

Cell at the intersection of the current row and the specified column (implicit 

intersection). 

 

 

 

The #This row reference will automatically change to @. 

Examples of structured references can be found below. 
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Table 11. Structural reference examples 

 Entire table Data only Headings only Results only 

Table 

Table1 

Table1[#All] Table1 

 

Table1[#Data] 

Table1[#Headings] Table1[#Totals] 

Column N Table1[[#All],

[N]] 

Table1[N] 

 

Table1[[#Data],[N]] 

Table1[[#Headings],

[N]] 

Table1[[#Totals],[N]] 

Columns 

from  

N to M 

Table1[[#All],

[N]:[M]] 

Table1[[N]:[M]] 

 

Table1[[#Data],[N]:[M]] 

Table1[[#Headings],

[N]:[M]] 

Table1[[#Totals],[N]:[M]] 

4.5.11.3 Enter a structural reference in a formula 

Formulas that contain structured references are entered in standard ways. 

To specify the name of a "smart table" in a formula, follow these steps: 

1. Start typing the table title. A drop-down list will show the names of all "smart" tables 

that are contained in the document. 

 

Figure 257. List of “smart” tables 

 

2. Select the name of the desired table using the mouse or the keyboard: 

‒ Click the table title with the left mouse button. 

‒ Select the table title using the ↓ and ↑ keys and press Enter. 

The name of the table will be entered in the formula. 
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To enter the column name or a reference to the table area (for example, #Totals or @), 

do the following: 

1. Enter the [ (left square bracket) symbol. The drop-down list will display the column 

names and the references to the table areas. 

2. Select the desired element from the list using the mouse or the keyboard: 

‒ Left-click the element name with the mouse. 

‒ Select the element line using the ↓ and ↑ keys and press Enter. 

 

The selected element will be added to the formula. 

 

Figure 258. List of column names and data references 

If an argument (e.g., [#Headings]) is entered correctly into a formula, it is highlighted in 

color, and the table highlights the range to which it refers (for example, the heading line). 
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4.5.11.4 Work with “smart” tables 

"Smart" tables are displayed in the MyOffice Spreadsheet app the same way they were saved 

in Microsoft Excel. For example, if the result line was disabled in Microsoft Excel, MyOffice 

Spreadsheet displays the table without the result line. Enabling or disabling table areas and filtering 

using the headings is not supported in MyOffice Spreadsheet. 

When working with a smart table, you can perform the following operations:  

‒ Edit column names. Column names are automatically updated in the structured references of 

the table. 

‒ Insert rows and columns between existing rows and columns (but not at the end of the table). 

‒ Copy smart tables and paste them into the same document. Copied tables are automatically 

given a unique name. In all structured references, the name of the original table is 

automatically replaced by the name of the copied table. 
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4.5.11.5 Calculated columns 

If you want to add a column where all cells contain the same formula to a table, create 

a calculated column. You can use any column in the table that does not contain data to create 

a calculated column. 

To make a column calculated, type the desired formula in any cell of that column and press 

Enter. 

All cells in the column will automatically be filled with the formula you entered. 

The following rules apply to the calculated columns: 

‒ If you edit a formula in any cell of a calculated column, the same formula editing is 

automatically performed in the remaining cells of that column. 

‒ If the data in a column is partially deleted or regular data is entered instead of a formula, 

the column ceases to be calculated (formula changes cease to apply to the whole 

column).  

‒ If the column consistency is restored manually (all cells contain the same formula again), 

the column becomes calculated again. 
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4.5.11.6 Automatic expansion of “smart” tables 

"Smart" tables are automatically expanded when you enter data in adjacent cells located in 

the column to the right of the "smart" table. If there is no result line in the table, auto-expansion is 

also performed when you enter data in the adjacent cells located in the row following the last table 

row. 

Data can be entered: 

‒ Manually. If a formula is entered in an adjacent column, that column becomes calculated 

(see Section 4.5.11.5). 

‒ From the clipboard. The automatic expansion is performed when data is inserted to 

the left/bottom of the table or when data is inserted simultaneously in both the table and 

adjacent cells. 

‒ By means of automatic filling of the cells (see Section 4.4.1.4) where the reference cell 

is one or multiple cells of the "smart table". 

 

The automatic expansion of "smart" tables has the following limitations: 

‒ The automatic expansion area should not contain any data. 

‒ The data inserted does not overlap with another "smart" table. 

 

The current version of the application does not support the automatic expansion of smart 

tables when autofilling cells (see Section 4.4.1.4): 

‒ If a table cell with a structured reference is selected as a reference cell. 

‒ If a cell in the table heading line is selected as a reference cell. 
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4.6 Calculation operators 

4.6.1 Arithmetic operators 

Arithmetic operators (see Table 12) perform basic operations with numbers in the Number, 

Date, and Time formats. 

If the value cannot be converted to a number, the operation will result in an error #VALUE!. 

Table 12. Arithmetic operators 

Operator Meaning Example 

+ Addition =6+7 

- Subtraction 

Negation 

=B12-B3 

-45 

* Multiplication =86*34 

/ Division =36/3 

^ Exponentiation =D8^2 

% Percentage 76% 

To calculate the root of a number, use the following formula: 

=M^(1/N) 

where M is the number you want to find the root of, and N is the root index. 

For example, this formula =36^(1/2) extracts the square root of 36. 
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4.6.2 Comparison operators 

Comparison operators (see Table 13) compare two values. You can compare any type of 

data, including numbers, dates, and character strings. 

The comparison result can either be: 

‒ TRUE: The expression is true. 

‒ FALSE: The expression is false. 

Table 13. Comparison operators 

Operator Meaning Example 

= Equal to =6=6 

> Greater than =9>17 

< Less than =A2<C3 

>= Greater than or equal to =0>=6 

<= Less than or equal to =P12<=7 

<> Not equal to =3<>4 
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4.6.3 Text concatenation operator 

The Text concatenation operator (see Table 14) combines data from text cells into one string. 

Table 14. Text concatenation operator 

Operator Description Example 

& Connects strings from two or more than 

two cells to produce one continuous 

sequence of characters 

Cells: A2 (My) and A3 

(Office) 

Formula: =A2&A3 

Result: MyOffice 

To combine data from 3 or more cells, use a text operator before each new cell address. 
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4.6.4 Reference operators 

Reference operators (see Table 15) describe references to cell ranges. Use these operators to 

refer to both the cells in the current sheet and cells in other sheets in the same spreadsheet. 

Table 15. Reference operators 

Operator Description Example 

: A range operator. 

Creates a reference to a range of cells. The 

operator is placed between the first and the last 

cell of the range. 

 

The operator can be used to combine cell 

ranges. In this case it returns the range between 

the upper left and lower right cells, including 

these cells. 

 

=SUM(B2:C4) 

(see Figure 203) 
 

=SUM(A1:B1:C4:D4) – in this 

example, the sum of all cells 

between and including A1 and D4 

is calculated. 

(see Figure 204) 

Space Intersection operator. 

Creates a reference to the cells located at 

the intersection of the specified ranges. 

 

=SUM(A2:C4 B2:D4) 

(see Figure 205) 

'sheetname'! Creates a reference to a cell or range of cells in 

another sheet of the current document. 

=SUM(B2+'Sheet2'!B2) 

 

=SUM(B2:C4+'Sheet2'!B2:C4) 

(see Figure 206) 

'sheetname 

n:sheetname m'! 

Creates a reference to the same cell on several 

sheets of the current document 

(a 3D reference). 

=SUM('January_2019: 

December_2019'!A1) – in this 

example, the sum of all A1 cells 

on all sheets within the specified 

range is calculated. 

When entering formulas, select the desired cell range (see Section 4.2.1) to avoid entering it 

manually. 
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Figure 259. Range operator 

 

Figure 260. Intersection operator 

 

Figure 261. Operator referencing cells on another sheet  
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4.7 Pivot tables 

4.7.1 Create a pivot table 

A pivot table is a tool that allows you to present data from an ordinary flat table in a form 

that is easy to analyze.  

Pivot tables allow you: 

‒ To quickly place data from the source table columns into the pivot table columns and 

rows and swap them around. 

‒ To perform calculations. 

‒ To filter data. 

 

To create a pivot table, create a source table first, which is a flat table with the required data.  

When preparing the source table, it is recommended to consider the following requirements: 

‒ The columns in the source table must have headings. 

‒ It is recommended to use data in one format within one column of the table 

(see Section 4.4.3). For example, only in General format or only in Date format. 

 

You can create a pivot table on a new sheet or on the sheet you are working on. 

To create a pivot table: 

1. Select one of the following elements required to create a pivot table: 

‒ A range of data in the source table which will be used as the basis of the future pivot 

table. The range of data should be selected with the column headings.  

 

The range cannot consist of one line. The first range line cannot contain empty 

cells. 
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‒ A cell on the sheet you are working on which should be inserted in the pivot table. 

This cell will become the upper left cell of the table. The selected cell should not 

contain any data. 

 

It is highly recommended to leave at least two blank lines above the pivot 

table for filters (see Section 4.7.2.2). 

 

2. Open the pivot table creating window in one of the following ways: 

‒ In the Command menu, select Insert > Pivot Table (see Figure 262). 

 

Figure 262. Pivot table command menu 

‒ On the Toolbar, in the Insert section (see Figure 263), click the  Pivot Table. 

 

Figure 263. Pivot table button 
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‒ On the Toolbar, in the Insert section, click  (see Figure 265). In the displayed 

insert pane, click the  Pivot Table. 

 

Figure 264. Insert pane 

3. In the Create Pivot Table window (see Figure 265), do the following: 

‒ If you selected a cell to insert the pivot table in the first step, specify the range of 

source table data from which to create the pivot table in the Data Source field. 

‒ If a data range was selected in the first step, specify where the table will be inserted: 

• New sheet: Insert the table in a new sheet. The new sheet will be created 

automatically. By default, the new sheet will be named Pivot table <No.>, where 

No. is the number of the pivot table in the document you are working on. 

If needed, you can edit the sheet name. 

• Existing sheet: Insert the table on the sheet that is currently displayed on 

the screen. In the Specify a destination cell box, enter the address of the cell 

where you want the top left cell of the pivot table to be located. There must be at 

least two blank lines above the initial cell to place filters (see Section 4.7.2.2). 

4. Click OK. 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 287 

 

Figure 265. Create Pivot Table window  
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4.7.2 Customize a pivot table 

You can customize your pivot table using the pivot table configuration pane 

(see Figure 266). This pane includes the following tabs: 

‒ Constructor: Use this tab to select the structure (visual aspect) of the pivot table. 

‒ Options: This tab contains the pivot table parameters. In this version of the application, 

this tab is view only. 

 

Figure 266. Pivot table configuration pane 
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4.7.2.1 Open the pivot table settings pane  

 

The pivot table settings pane opens automatically when you select any cell in the pivot table 

and collapses automatically when you select any cell outside of the pivot table. 

You can also open and collapse the pivot table settings pane manually. 

If you close the settings pane manually, the pane will not open or close automatically until 

the next time you open the application. 

To collapse the pane manually, do one of the following: 

‒ In the upper part of the pane, click  (see Figure 266). 

‒ On the Sidebar, click  Pivot Table (see Figure 266). 

 

To open the pane manually, do the following: 

1. Select the entire range or one or multiple cells of the pivot table range. 

2. Open the pane in one of the following ways: 

‒ In the Command menu, select Data > Pivot Table Settings (see Figure 266). 

 

Figure 267. Data command menu 

‒ On the Toolbar, select the Pivot Table section and click  Setting 

(see Figure 268). 

 

Figure 268. Settings button 

‒ On the Sidebar, click the  Pivot Table button (see Figure 267). 

‒ Right-click the context menu and select Pivot Table Settings.  
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4.7.2.2 Configure a pivot table 

By default, a pivot table does not contain data because its structure is not defined  

To define the pivot table structure, use the Constructor on the pivot table configuration pane 

(see Figure 269). 

 

Figure 269. Pivot table 
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The Constructor tab includes the following sections: 

‒ Available Fields: This section includes the list of all selected columns of the initial table 

(hereinafter, the fields). To set the structure of the pivot table, add the fields from 

the Available Fields section to the Rows, Columns, Values, and Filters sections 

(see the example on Figure 270). 

 

Figure 270. Pivot table example 
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‒ Rows: Add the fields which will become the headings of the pivot table rows to this 

section (see Figure 271). 

 

Figure 271. Row labels 

‒ Columns: Add the fields which will become the headings of the pivot table columns 

to this section (see Figure 272). 

 

Figure 272. Column names 
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‒ Values: Add the fields whose values will be used for calculations to this section 

(see Figure 273). 

 

Figure 273. Values 

‒ Filters: If necessary, add the fields that will be used to filter data in the pivot table to 

this section. Filters allows you to set the specific level of data display and change 

the appearance of the table. 

 

Figure 274. Filter 
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4.7.2.2.1 Add fields 

Fields from the Available Fields section can be added to the Rows and Values sections 

manually or automatically. If fields are added automatically, they are allocated between the Rows 

and Values areas according to the data type: 

‒ If the field contains text values, it will be moved to the Rows section. 

‒ If the field contains numeric values, it will be moved to the Values section. 

 

To automatically distribute fields between the Rows and Values sections, perform 

the following steps for each of these fields: 

1. In the Available Fields section, hover the cursor over the title of the field which needs 

to be moved to the Rows or Values sections (see Figure 275) 

2. Click  Add. 

 

Figure 275. Add button 
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To add fields to the Rows and Values sections manually, drag and drop them into 

the appropriate sections while holding down the left mouse button, or do the following for each 

field: 

1. In the Available Fields section, hover the cursor over the field which needs to be moved to 

the Rows or Values sections (see Figure 276). 

2. Click  More. 

3. In the menu that appears, select the section in which you want to add the field. 

 

 

Figure 276. More button 

 

Calculated fields created in a third-party application can only be moved to the Values 

area. 

Adding fields from the Available Fields section to other sections is done manually, similar 

to adding fields to the Rows and Values sections. 
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4.7.2.2.2 Move a field from one section to another 

Moving fields from one section to another is done manually, similar to adding fields from 

the Available Fields section to the other section in the Constructor (see Section 4.7.2.2.1). 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 297 

4.7.2.2.3 Change the field order in a section 

In any section other than the Available Fields section, you can change the order of the fields 

in the list. The position of the field in the list determines the position of the corresponding field in 

the pivot table. 

To change the position of a field relative to other fields in the list, drag it to the desired 

location in the list while holding down the left mouse button, or perform the following steps: 

 

1. Hover the mouse cursor on the field and click  More (see Figure 277). 

 

Figure 277. More button 

2. In the drop-down menu, select the desired command: 

‒ Move to Beginning: Move the field to the beginning of the list. 

‒ Move Up: Swap the selected and previous field. 

‒ Move Down: Swap the selected and next field. 

‒ Move to End: Move the field to the end of the list. 

 

The drop-down menu commands depend on the position of the selected field in the list. 
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4.7.2.2.4 Edit the function in the Values section 

The function for data calculation for a field added to the Values section is selected 

automatically. 

‒ If the field contains numeric data, the Sum function is selected. 

‒ If the field contains text data, the Count function is selected. 

 

To use another function for the data in this field: 

1. In the Values section, expand the drop-down list of functions available for this field 

(see Figure 278). 

2. Select the desired function from the drop-down list. 

 

Figure 278. List of functions 

 

For calculated fields created in a third-party application, the Sum function is 

automatically selected. Selecting another data calculation function is not available. 
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4.7.2.2.5 Delete a pivot table field 

To delete a field from any section of the pivot table, do one of the following: 

‒ Hover the mouse cursor over the title of this field and click  Remove  

(see Figure 279). 

 

Figure 279. Remove button 

‒ Hold down the left mouse button and drag the field from the current area to 

the Available Fields section. 

 

To remove a field from all areas of the pivot table to which it is added: 

1. In the Available Fields section, hover the cursor over the title of the field 

(see Figure 280). 

2. Click  Remove from Pivot Table. 

 

Figure 280. Remove from Pivot Table button 
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4.7.2.2.6 Edit data source 

If you need to edit the pivot table data source, do the following: 

1. In the pivot table settings pane, select the Options tab (see Figure 281). 

2. Place the cursor on the Data Source field. The tab containing the initial table will open. 

The value in the Data Source box will become available for editing. The specified data 

range will be highlighted in color in the initial table. 

3. Edit the value in the Data Source box and click the  button or press Enter. 

 

Figure 281. Options tab 
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4.7.3 Refresh a pivot table 

A pivot table needs to be updated in the following cases: 

‒ When working with the document in the source table and the data based on which 

the pivot table was created has changed. 

‒ When you open a document created using third-party editors which contains a pivot table 

in MyOffice Spreadsheet. 

 

This version of the application does not retain the formatting of pivot tables created in 

third-party editors. 

 

To update a pivot table: 

1. Select the entire range or one or multiple cells of the pivot table range. 

2. Update the pivot table in one of the following ways: 

‒ In the Command menu, select Data > Refresh Pivot Table (see Figure 282). 

 

Figure 282. Refresh button 

‒ On the Toolbar, select the Pivot Table section and click  Refresh  

(see Figure 283). 

 

Figure 283. Refresh button 
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‒ Right-click the context menu and select Refresh Pivot Table. 

‒ If the pivot table was created in a third-party application, in the pivot table 

configuration pane, (see Figure 284). 

 

Figure 284. Update button 

This version of the application has the following limitations when updating pivot tables 

created in third-party editors: 

‒ Collapsing and expanding the pivot table levels is not supported. When you update 

a table, all collapsed levels are automatically expanded. 

‒ The use of calculated elements is not supported. 
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4.7.4 Delete a pivot table 

To delete a pivot table, do the following: 

1. Select all the entire range or one or multiple cells from the pivot table range. 

2. Run the delete command in one of the following ways: 

‒ In the Command menu, select Data > Delete Pivot Table (see Figure 285). 

 

Figure 285. Data menu 

‒ On the Toolbar, in the Pivot Table section, click  Delete Pivot Table 

(see Figure 286). 

  

Figure 286. Delete Pivot Table button 

‒ Right-click the context menu and run the Delete Pivot Table command. 

‒ Press Delete. 
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4.8 Charts 

4.8.1 Insert a chart 

MyOffice Spreadsheet allows you to create and edit various charts. 

To create a chart, do the following: 

1. Select a range to be used to create a chart. 

2. Insert a chart in one of the following ways: 

‒ In the Insert menu, select Chart (see Figure 287). 

 

Figure 287. Insert menu 
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‒ On the Toolbar, select the Insert section and click  Chart (see Figure 288). 

 

Figure 288. Chart button 
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‒ On the Toolbar (see Figure 289), select the Insert section and click . 

In the displayed insert pane, click  Chart. 

 

Figure 289. Insert menu 

3. In the opened menu, select the desired chart type. 
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The new chart is placed in the middle of the visible area of a spreadsheet. 

The data used to create the chart are highlighted on the spreadsheet with the colors of 

the chart series (see Figure 290). 

 

Figure 290. Chart 
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4.8.2 Change chart type 

If you want to modify the type of the chart, select it first. On the Toolbar, select the Chart 

section and click the button which corresponds to the desired type of chart: 

‒  Column: Click this button to transform your chart into the Column chart or change 

the current type of the Column chart (see Figure 291). 

 

Figure 291. Column chart 

‒  Bar: Click this button to transform your chart into the Bar chart or change the current 

type of the Bar chart (see Figure 292). 

 

 

Figure 292. Bar chart 
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‒  Pie Chart: Click this button to transform your chart into the Pie Chart. 

‒  Area: Click this button to transform your chart into the Area chart or change 

the current type of the Area chart (see Figure 293). 

 

Figure 293. Area chart 
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To transform the current chart type to the Line chart or change the current Line chart type, 

click the  Line button and select the desired Line chart type from the drop-down list  

(see Figure 294).  

 

Figure 294. Line chart 
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4.8.3 Change data range 

You can change the data range used as the source data for your chart. The chart will be 

updated accordingly based on the new data range. 

To change a range, perform the following actions: 

1. Select the chart you want to edit. 

2. By holding down the left mouse button, move the corner marker of the data range that 

was used to build the chart. The range corner marker can be moved in any direction: 

right, left, up, down. 

3. Release the left mouse button to fix the new range. 

You can also modify values in the cells used as the source data for your chart. The chart will 

be updated accordingly based on the new data in the chart legend. 

4.8.4 Change chart size 

To resize a chart, left-click it and drag the sizing handle as needed (see Figure 295): 

‒ To change the height, use the top and bottom sizing handles. 

‒ To change the width, use the right and left sizing handles. 

‒ To change the height and width proportionally, use the corner sizing handles. 
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Figure 295. Resize a chart 

4.8.5 Move a chart 

The chart can be moved in the following ways: 

‒ Drag and drop by holding the left mouse button. 

‒ Move strictly vertically or horizontally with the ←, ↑, ↓, → keys on the keyboard. 

When you move the chart with ←, ↑, ↓, → keys, the chart movement step depends on 

the document scale: 

‒ If the scale is ≤ 200%, the step = 4 mm. 

‒ If the scale is > 200%, the step = 1 mm. 

To increase the step, move the chart using the ←, ↑, ↓ key while holding the Shift key 

pressed. In this case the movement step will be equal: 

‒ If the scale ≤ 200%, the step = 4 cm. 

‒ If the scale > 200%, the step = 1 cm. 
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4.8.6 Customize a chart 

To customize your chart, use the following guidelines: 

1. Select the chart you want to customize. 

2. Open the Chart Settings window in one of the following ways: 

‒ On the Toolbar, select the Chart section and click  Settings (see Figure 296). 

‒ Right-click the chart and select Chart Settings in the context menu. 

 

Figure 296. Settings button 

The opened Chart Settings displays the following menus (see Figure 297): 

 

Figure 297. Chart Settings window 
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‒ Range: Change the chart data range. 

‒ Title: Specify the chart title. 

‒ Data Series: Specify the way the initial data is plotted in a chart (by columns or rows). 

‒ Labels: Specify the position of chart labels (first column and/or first row). 
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4.8.7 Copy, cut or insert a chart 

You can copy or cut and paste a chart: 

‒ Within one MyOffice Spreadsheet document. 

‒ Into another MyOffice Spreadsheet document: the chart is inserted without the data 

it is based on. 

‒ Into MyOffice Text document or MyOffice Presentation: the chart is inserted as 

an image. 

You can cut, copy and paste using standard methods. 

4.8.8 Delete a chart 

To delete a chart, do the following: 

1. Select the chart. 

2. Delete a chart in one of the following ways: 

‒ On the Toolbar, select the Chart section and click  Delete (see Figure 298). 

 

Figure 298. Delete button 

‒ Right-click the chart and click Delete Chart (see Figure 296). 

‒ Press Delete or Backspace. 
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4.9 Images 

You can insert the following images to a document: 

‒ From your computer. 

‒ From Google Chrome, Firefox, Internet Explorer, and Microsoft Edge browser. 

‒ From the text and spreadsheet editors that are a part of the Microsoft Office and 

LibreOffice suites. 

The supported image formats include .png, .bmp, .jpg, .jpeg, .jpe, .gif, .tiff, and .tif. 
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4.9.1 Insert an image 

4.9.1.1 Insert an image from your computer 

To insert an image from a computer, follow the steps below: 

1. Place your cursor where you want to insert the image. 

2. Insert an image in one of the following ways: 

‒ In the Insert menu, select Image (see Figure 299). 

 

Figure 299. Insert menu 

‒ On the Toolbar, select the Insert section (see Figure 300) and click the  Image button. 

 

Figure 300. Insert menu 
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‒ On the Toolbar, select the Insert section and click . In the displayed pane, click  Image 

(see Figure 301). 

 

Figure 301. Insert pane 

3. In the file manager window, select the image you want to insert and click Open. 
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4.9.1.2 Insert an image from the browser or another application 

To insert an image from the browser or another application, follow the steps below: 

1. Copy the image from the source. 

2. Place your cursor where you want to insert the image. 

3. Insert the image in one of the following ways: 

‒ In the Edit menu, select Paste (see Figure 302). 

 

Figure 302. Edit menu 

‒ On the Toolbar, select the Edit section and click  Paste. In the drop-down list, 

select Paste (see Figure 303). 

 

Figure 303. Paste button 

‒ Right-click and select Paste from the context menu. 

‒ Press Ctrl+V / ⌘Cmd+V. 
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4.9.2 Resize an image 

You can resize the image proportionally or according to your preferences. 

To resize an image proportionally, follow the steps below: 

1. Select the image you want to resize. 

2. Drag a corner handle while keeping the left mouse button pressed until the image is 

the size you want (see Figure 304). 

3. Release the left mouse button to fix the selected size. 

 

Figure 304. Resize an image proportionally 

To resize an image without keeping its proportions, follow the steps below: 

1. Select the image you want to resize. 

2. Drag a side handle while keeping the left mouse button pressed: 

‒ To change the height of the image, move the top or bottom handle. 

‒ To change the width of the image, move the left or right handle. 

3. Release the left mouse button to fix the selected size. 

 

Figure 305. Resize an image without keeping its proportions 
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4.9.3 Move an image 

The image can be moved in the following ways: 

‒ Drag it by holding the left mouse button. 

‒ Move strictly vertically or horizontally with the ←, ↑, ↓, → keys. 

When you move the image with ←, ↑, ↓, → keys, the movement step depends on 

the document scale: 

‒ If the scale is ≤ 200%, the step = 4 mm. 

‒ If zoom is > 200%, the step = 1 mm. 

To increase a step, move the image with keys ←, ↑, ↓, →, holding the Shift key pressed. 

In this case the movement step will be equal to the following: 

‒ If scale is ≤ 200%, the step = 4 cm. 

‒ If scale > 200%, the step = 1 cm. 
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4.9.4 Save an image 

The image from the document can be saved on your computer. 

Follow these steps: 

1. Select an image. 

2. Run the save command in one of the following ways: 

‒ Select Format > Save Image (see Figure 306). 

 

Figure 306. Save Image Command menu option 

‒ Open the context menu by right-clicking and run the Save Image command. 

3. In the file manager window, select the folder to save the file to, specify the file name and 

click Save. 

 

The image is saved in the original size. 

 

If an image has been cropped in a document using a third-party application, it is saved 

in its original (pre-crop) form. 
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4.9.5 Delete an image 

To delete an image, do the following: 

1. Select the image that you want to delete. 

2. Select a command to delete an image in one of the following ways: 

‒ On the Toolbar, under the Image section (see Figure 307), click  Delete Image. 

 

Figure 307. Delete Image button 

‒ Right-click the image and select Delete Image from the context menu. 

‒ Press Delete or Backspace. 
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4.10 Shapes 

You can add the following types of shapes to your documents: line, rectangle, ellipse, 

triangle, diamond, folded corner, star, heart, brackets, arrows, callouts, or text field. 

4.10.1 Insert a line 

To insert a line into a document, do the following: 

1. Open the Insert sub-menu using one of the following methods: 

‒ In the Command menu, select Insert > Shape > Lines (see Figure 308). 

 

Figure 308. Insert menu 

‒ On the Toolbar, in the Insert section, click . In the insert pane that appears, hover 

the mouse cursor over the  Shape button (see Figure 309). 
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Figure 309. Insert pane 

2. In the sub-menu that opens, select the type of line to insert: line, arrow, double-sided 

arrow. The cursor will look like a crosshair . 

3. If needed, select the arrow type (see Section 4.10.10). 

4. Add a line in one of the following ways: 

‒ Click the left mouse button on the place where the line start point should be located. 

A line with a length of 4.24 cm and an angle of 45° will be added to the document. 

‒ Hold down the left mouse button and draw a line in the desired location of 

the document. To finish drawing, release the left mouse button. 

5. If needed, edit the length and the angle of the line (see Section 4.10.9). 
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4.10.2 Insert a shape 

To insert a shape, do the following: 

1. Select the position on the sheet where you want to insert a shape. 

2. Display the list of shapes in one of the following ways: 

‒ In the Insert menu, select Shape (see Figure 308). 

‒ On the Toolbar, select the Insert section and click . In the displayed pane, 

click  Shape (see Figure 309). 

3. In the opened sub-menu, select the desired shape. 

You can add text or a link to a shape. 

Follow these steps: 

1. Double-click the shape to enter the editing mode. 

2. Add text or a link to the shape: 

‒ Enter the text manually. The text can be formatted in the same manner as you would 

format the main text in the document. 

 

Figure 310. Entering text 

‒ Add a link to the shape as described in Section 4.4.6.1. 

3. Click anywhere outside the shape to leave the editing mode. 

 

Editing mode is not currently supported for shapes turned at a custom angle in third-

party spreadsheet editors. 
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4.10.3 Insert a text box 

A text box is framed text that can be moved and placed anywhere on the current sheet. 

To insert a text box, do the following: 

1. Select the place on the sheet where you want to insert a text box. 

2. Select the insert command in one of the following ways: 

‒ In the Insert menu, select Text Box (see Figure 311). 

 

Figure 311. Insert command menu 

‒ On the Toolbar, select the Insert section and click  (see Figure 312). 

In the displayed pane, click  Text Box. 

 

Figure 312. Text Box button 

3. Enter the desired text in the text box. If necessary, you can add a link to the text 

(see Section 4.4.3.1). Formatting the text in the text field is similar to formatting 

the main text of the document. 

4. To deselect a text box, click anywhere on the sheet outside the text box.  
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4.10.4 Fill a shape 

You can fill the inner area of any shape, except lines, with colors or images. 

4.10.4.1 Fill a shape with color 

To fill a shape with color, do the following: 

1. Select the shape with a single mouse click or double-click the shape to switch to edit 

mode. 

2. To fill the shape with the last color that was used for the fill earlier, on the Toolbar, in 

the Shape section, click the Fill Color button (see Figure 313). 

3. To fill the shape with another color, click the arrow to the right of the  Fill Color 

button. 

 

Figure 313. Fill Color button  
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4. Select the desired color in one of the following ways: 

‒ Theme Colors: This block contains the color palette of the current document's 

theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The block is displayed if you have selected at least 

one color. 

5. If there is no matching color in the blocks listed above, you can define it manually. 

To do this, click More Colors button. In the Select Color window (see Figure 314) that 

appears, specify the desired color as a HEX code or in RGB format and click OK. 

 

Figure 314. Select Color window 

The selected color will be checked, and the shape will be filled with this color. 

4.10.4.2 Fill a shape with image 

To fill a shape with an image, do the following: 

1. Select the shape with a single mouse click or double-click the shape to switch to edit 

mode. 

2. On the Toolbar, in the Shape section, click the arrow to the right of the  Fill Color 

button (see Figure 313). 

3. In the opened window, in the Image section, click the Choose button. 

4. Select the desired image in the file manager window and click Open. 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 330 

4.10.4.3 Remove the fill 

To remove a shape fill, do the following: 

1. Select the shape with a single mouse click or double-click the shape to switch to edit 

mode. 

2. On the Toolbar, in the Shape section, click the arrow to the right of the  Fill Color 

button (see Figure 315). 

3. In the opened window, click the No Fill button. 

 

Figure 315. No Fill button 

 

4.10.5 Shape outline 

4.10.5.1 Set shape outline 

You can define the color, thickness, and outline type for the shape. 

To set the outline color of a shape, follow the steps below: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, select the Shape section and click the arrow to the right of 

the  Outline button (see Figure 316). 

3. Select the desired color in one of the following blocks: 

‒ Theme Colors: This block contains the color palette of the current document's 

theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 
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‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The block is displayed if you have selected at least 

one color. 

 

Figure 316. Outline button 

4. If there is no matching color in the blocks listed above, you can define it manually. 

To do this, click More Colors button. In the Select Color window that appears  

(see Figure 317), specify the desired color as a HEX code or in RGB format and click 

OK. 
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Figure 317. Select Color window 

The selected color will be checked, and the outline of the shape will be filled with that color. 

To specify the thickness and type of a line for a shape outline, follow the steps below: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, select the Shape section and click the arrow to the right of 

the  Outline button (see Figure 316). 

3. In the Line Weight field, select the desired outline thickness manually or using 

the buttons. 

4. Select the outline line type from the preset values. 

To quickly apply the previous shape's outline settings to a shape, follow these steps: 

1. Single-click to select a shape or double-click to select a shape to enter its editing mode. 

2. On the Toolbar, in the Shape section, click  Outline (see Figure 316). 
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4.10.5.2 Remove shape outline 

To remove the shape outline, do the following: 

1. Select the shape with a single mouse click or double-click the shape to switch to edit 

mode. 

2. On the Toolbar, in the Shape section, click the arrow to the right of the  Outline 

button (see Figure 318). 

3. In the opened window, click the No Outline button. 

 

Figure 318. No Outline button 

 

4.10.6 Line style 

4.10.6.1 Set the line style 

You can define the color, thickness, and outline type for the line. 

To specify the line color, follow the steps below: 

1. Select the line. 

2. On the Toolbar, select the Line section and click the arrow to the right of 

the  Outline button (see Figure 319). 

3. Select the desired color in one of the following blocks: 

‒ Theme Colors: This block contains the color palette of the current document's 

theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 
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‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The block is displayed if you have selected at least 

one color. 

 

Figure 319. Outline button 

4. If there is no matching color in the blocks listed above, you can define it manually. 

To do this, More Colors. In the Select Color window that appears (see Figure 320), 

specify the desired color as a HEX code or in RGB format and click OK. 
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Figure 320. Select Color window 

The selected color will be checked, and the line will be filled with that color. 

To specify the line thickness and type, follow these steps: 

1. Select the line. 

2. On the Toolbar, select the Line section and click the arrow to the right of  

the  Outline button (see Figure 319). 

3. In the Line Weight section, select the desired line thickness manually or using the 

buttons. 

4. Select the line type from the preset values. 

To quickly apply a previous line style to a line, follow these steps: 

1. Select the line. 

2. On the Toolbar, in the Line section, click  Outline (see Figure 319). 

4.10.6.2 Delete the line style 

If necessary, you can delete the line style settings. To do this, follow these steps: 

1. Select the line. 

2. On the Toolbar, select the Line section and click the arrow to the right of the  Outline 

button (see Figure 321). 

3. In the window that appears, click No Outline. 
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Figure 321. No Outline button 
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4.10.7 Resize a shape 

You can resize the height and the width of a shape proportionally or according to your 

preferences. 

To resize a shape proportionally, follow the steps below: 

1. Select the shape you want to resize. 

2. Drag a corner handle while keeping the left mouse button pressed until the shape is 

the size you want (see Figure 322). 

3. Release the left mouse button to fix the selected size. 

 

Figure 322. Resize a shape proportionally 
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To resize a shape without keeping its proportions, follow the steps below: 

1. Select the shape you want to resize. 

2. Drag a side handle while keeping the left mouse button (see Figure 323): 

‒ To change the height of the shape, move the top or bottom handle. 

‒ To change the width of the shape, move the left or right handle. 

3. Release the left mouse button to fix the selected size. 

 

Figure 323. Resize a shape without keeping its proportions 
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4.10.8 Fit shape size to text 

You can fit the shape height to match the text inside this shape. 

To do this: 

1. Select the shape. 

2. On the Toolbar, select the Shape section (see Figure 324) and click  Autofit. 

The button will change to . 

 

Figure 324. Autofit button 

To cancel the autofit, perform the same procedure once again. 
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4.10.9 Change line length and angle 

To change the length or angle of a line, follow these steps: 

1. Select the line. 

2. Move the cursor over a line start or end marker so that the cursor appears as follows . 

3. Hold down the left mouse button and drag the marker to the desired location. 

4. Release the left mouse button. 

If necessary, you can stop moving the marker by pressing Esc. The marker will return to its 

original position. 

 

4.10.10 Select arrow type 

You can select the tip type for the beginning and end of the line. The selection can be made either 

before drawing the line (see Section 4.10.1) or when editing the drawn line. 

To select the arrow type, do the following: 

1. On the Toolbar, in the Line section, click  Arrow Type (see Figure 325). 

2. Select the left and/or right tip type from the drop-down list. If you want to remove 

previously selected tips, select the left and/or right tip type  None in the first line of 

the drop-down list. 

3. Click the  Arrow Type button once again to close the drop-down list. 

 

Figure 325. Arrow Type button 
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4.10.11 Move a shape 

The shape can be moved in the following ways: 

‒ Drag the shape by holding the left mouse button. 

‒ Move the shape strictly vertically or horizontally with the ←, ↑, ↓, → keys on 

the keyboard. 

When you move a shape with ←, ↑, ↓, → keys, the movement step depends on the document 

scale: 

‒ If the scale is ≤ 200%, the step = 4 mm. 

‒ If the scale is > 200%, the step = 1 mm. 

To increase a step, move the figure with keys ←, ↑, ↓, →, holding the Shift key pressed. 

In this case the movement step will be as follows: 

‒ If the scale is ≤ 200%, the step = 4 cm. 

‒ If the scale is > 200%, the step = 1 cm.  
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4.10.12 Delete a shape 

To delete a shape, follow these steps: 

1. Select the shape you want to delete. 

2. Delete the shape using one of the following methods: 

‒ If you selected a line, on the Toolbar, select the Line section and 

click  Delete Line (see Figure 326). If you want to delete a shape other than 

the line, on the Toolbar, select the Shape section, click  Delete Shape  

(see Figure 327). 

 

Figure 326. Delete Line button 

 

Figure 327. Delete Shape button 

‒ Right-click the shape and select Delete Line/Delete Shape in the context menu. 

‒ Press Delete or Backspace. 
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4.11 Format spreadsheets 

When files are created, the standard formatting is applied to their elements. To change 

the default formatting, select the respective commands and run them. If you want to modify 

the existing file, you need to select the fragment you want to apply the new formatting to first. 

4.11.1 Font 

By default, when creating a document in MyOffice Spreadsheet, the XO Thames font is used. 

To quickly change the font, follow these steps: 

1. Specify the text for which you want to change the font: 

‒ To change the font for all the text located in a cell, select this cell. 

‒ To change the font for a text fragment located in a cell, switch to the cell editing 

mode and select this fragment. 

‒ To change the font in one word, switch to the cell editing mode and place the cursor 

on this word or select it entirely. 

2. On the Toolbar, in the Font section (see Figure 328), click on the field with the name of 

the current font. 

3. Start typing the name of the desired font. The drop-down list will display a list of fonts 

that match the search criteria. 

4. Select the desired font using the mouse or keyboard keys: 

‒ Left-click the font name. 

‒ Select the font name using the keyboard keys ↓ and ↑ and press Enter. 

 

Figure 328. Font search 

To select a font from the full list of fonts, follow these steps: 

1. Specify the text for which you want to change the font as described above. 

2. On the Toolbar, in the Font section, click the arrow  to the right of the name of 

the current font (see Figure 329). 
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3. In the drop-down list, select the desired font using the mouse or keyboard keys: 

‒ Left-click the font name. 

‒ Select the font name using the keyboard keys ↓ and ↑ and press Enter. 

 

Figure 329. Full list of fonts 

 

It is recommended to use the fonts of the XO family in order to preserve the formatting of 

the document when it is opened in other operating systems. 
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4.11.2 Font size 

To change the font size, do as follows: 

1. On the Toolbar, select the Font section and click the arrow  to the right of the current 

font name (see Figure 330). 

2. In the opened list, select the desired font size. 

 

Figure 330. Selecting the font size 

You can also type in any size you want. Simply follow these steps: 

1. On the Toolbar, select the Font section and select the current font size. 

2. Enter the desired size. Use a dot (.) as the delimiter for fractional value. 

For example, 21.5 

3. Press Enter. 
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To increase the font size by one point, follow the steps below: 

‒ In the Format menu, select Font and then select Increase Font Size (see Figure 331). 

 

Figure 331. Increase and Decrease Font Size options 

‒ On the Toolbar, select the Font section (see Figure 332) and click 

 Increase Font Size. 

 

Figure 332. Buttons to increase and decrease the font size 

To decrease the font size by one point, follow the steps below: 

‒ In the Format menu, select Font and then select Decrease Font Size (see Figure 331). 

‒ On the Toolbar, select the Font section and click  Decrease Font Size  

(see Figure 332). 
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4.11.3 Text formatting 

Text formatting within a cell in MyOffice Spreadsheet allows you to distinguish different 

parts of your text and make the data on your spreadsheets more visible. 

The table below shows the text formatting options with the corresponding commands and 

toolbar buttons. 

Table 16. Text formatting 

Text formatting Command menu Toolbar button, 

Font section 

Keyboard 

shortcut 

(Windows/Linux) 

Keyboard 

shortcut 

(macOS) 

Bold Format > Font > 

Bold 
 

Ctrl+B ⌘Ctrl+B 

Italic Format > Font > 

Italic 
 Ctrl+I ⌘Ctrl+I 

Underline Format > Font > 

Underline  
Ctrl+U ⌘Ctrl+U 

ALL CAPS Format > Font > 

All Caps 
 Ctrl+Shift+A ⇧Shift+⌘Cmd+A 

 

Strikethrough 
Format > Font > 

Strikethrough  – – 

Subscript sign Format > Font > 

Subscript 
 

> 
 

   
 

Ctrl+= ⌘Cmd+= 

 

Superscript sign Format > Font > 

Superscript 
 

> 
 

 

Ctrl+Shift+= ⇧Shift+⌘Cmd+= 
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4.11.4 Font color 

To change the color of the font in the text, follow these steps: 

1. Specify the text for which you want to change the color: 

‒ To change the font color for all text in a cell, select the cell. 

‒ To change the font color for a piece of text located in a cell, switch to the cell edit 

mode and select that piece of text. 

‒ To change the font color in a word, switch to the cell editing mode and place 

the cursor on that word or select it in its entirety. 

2. To select the last color applied to the font before, on the Toolbar, select the Font section 

and click  Font Color (see Figure 333). 

3. To select a different color for the font, click the arrow to the right of the  Font Color 

button. 

 

Figure 333. Text Color button 
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4. Select the desired color in one of the following blocks: 

‒ Theme Colors: This block contains the color palette of the current document's 

theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The block is displayed if you have selected at least 

one color. 

5. If there is no matching color in the blocks listed above, you can define it manually. 

To do this, click More Colors button. In the Select Color window that opens, specify 

the desired color as a HEX code or in RGB format and click OK (see Figure 334). 

 

Figure 334. Select Color window 

To quickly apply the last used color to the text, follow these steps: 

1. Select the desired text as described above. 

2. On the Toolbar, select the Font section and click  Text Color (see Figure 333). 
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4.11.5 Highlight color 

When you are working on a document, you can highlight certain portions of text in different 

colors (as if they were highlighted with a marker) to make them more prominent against the rest of 

the document. 

To highlight text in color, do the following 

1. Specify the desired text: 

‒ To color the entire text in a cell, select the cell. 

‒ To color a piece of text located in a cell, switch to the cell editing mode and select 

that piece of text. 

‒ To color a single word, switch to cell editing mode and place the cursor on that word 

or select the entire word. 

2. To select the last color you used to highlight text earlier, on the Toolbar, in the Font 

section, click  Highlight Color (see Figure 335). 

3. To select a different color for text highlighting, on the Toolbar, in the Font section, click 

the arrow to the right of  Highlight Color. 

 

Figure 335. Highlight color selection 

4. Select the desired color in the provided palette or in the Recent Colors section. This 

block is displayed if at least one color from the palette was previously used to highlight 

text. The block can display a total of one to eight of the most recently used colors. 
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The selected color will be checked, and the text will be highlighted in this color. 

To remove the highlighting of the text, perform the following actions: 

1. Select the text that you want to remove highlighting from. 

2. On the Toolbar, select the Font section and click the arrow to the right of 

the  Highlight Color button (see Figure 335). 

3. In the window that opens, select No Color. 
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4.11.6 Alignment 

Data in cells can be aligned horizontally and vertically. 

To align data horizontally, use one of the commands described in the table below. 

Table 17. Horizontal alignment 

Position in cell Command menu Toolbar button, 

Alignment 

section 

Keyboard 

shortcut 

(Windows/Linux) 

Keyboard 

shortcut 

(macOS) 

Align left Format > Alignment > 

Align Text Left 
 Ctrl+L ⌘Ctrl+L 

Center Format > Alignment > 

Center Text 
 Ctrl+E ⌘Ctrl+E 

Align right Format > Alignment > 

Align Text Right 
 Ctrl+R ⌘Ctrl+R 

Justify Format > Alignment > 

Justify Text 
 Ctrl+J ⌘Ctrl+J 

To align data vertically, use one of the commands described in the table below: 

Table 18. Vertical alignment 

Position in cell Command menu Toolbar button in 

the Alignment 

section 

Top align Format > Alignment > Align Text To Top  

Center Format > Alignment > Align Text To Middle  

Bottom align Format > Alignment > Align Text To Bottom  
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4.11.7 Rotate text 

Text in cells can be rotated by any angle ranging from –90 to 90 degrees. 

You can specify the rotation angle using the Command menu or the Toolbar. 

 

To specify the rotation angle using the Command menu, do as follows: 

1. Select the row/column or the cell/cell range you want to rotate the text in. 

2. In the Command menu, select Format and then Text rotation (see Figure 336). 

 

Figure 336. Format menu 
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3. In the opened sub-menu, do the following: 

‒ To rotate the text, select the desired rotation angle from the list of preset values. 

‒ To position the text vertically, run the Vertical Text command. 

 

To rotate text or change the orientation of text using the Toolbar, follow these steps: 

1. Select the row/column, cell range, or cell in which the desired text is located. 

2. On the Toolbar, in the Alignment section, click  Rotate Text (see Figure 337). 

 

Figure 337. Rotate Text button 

1. In the opened sub-menu, do the following: 

‒ To rotate the text by 45° or 90° to the left or right, run the corresponding command. 

‒ To specify a different angle of rotation, enter the desired value manually in 

the Custom Angle field or click the  button and select a value from the drop-down 

list. 

‒ To position the text vertically, select Vertical Text. 

 

The rotation or orientation applies to all text in a cell. You cannot have multiple pieces 

of text with different rotation angles or orientations in the same cell. 
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To return to the default text display (horizontal position, 0° angle), follow these steps: 

1. Select the row/column, cell range, or cell in which the desired text is located. 

2. Run the command in one of the following ways: 

‒ In the Command menu, select Format > Rotate Text > None (0°) (see Figure 336). 

‒ On the Toolbar, in the Alignment section, click  Rotate Text. In the opened 

sub-menu, select None (0°) (see Figure 337). 
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4.11.8 Wrap text 

In MyOffice Spreadsheet, you can wrap text within cells to make it easier to view and edit. 

By default, the text in a cell is on one line. If the cell contains a large piece of text, specify 

that the text in that cell should be word-for-word. The application will place the text on multiple 

lines, taking into account the width of the column in which the cell is located. If you change 

the width of the column, the text in the cell will be moved again. 

To wrap text, do the following: 

1. Select the row/column, cell range, or cell in which you want to wrap text. 

2. Run the Wrap Text command in one of the following ways: 

‒ In the Table menu, select Wrap Text (see Figure 338). 

 

Figure 338. Table menu 
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‒ On the Toolbar, select the Alignment section and click  Wrap Text  

(see Figure 339). 

 

Figure 339. Alignment section 

To unwrap the text, run one of above commands again. 
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4.11.9 Character spacing 

The character spacing is a distance between the characters in the text. You can choose 

between Condensed, Normal and Expanded character spacing. 

The examples of various character spacings are shown in Figure 340. 

 

Figure 340. Character spacing examples 

The type of character spacing can be selected using the Command menu or the Toolbar. 

 

To change the character spacing using the Command menu, follow these steps: 

1. Select the text or cell in which you want to change the character spacing: 

‒ If you want to change the character spacing for a single word, select or place 

the cursor in the word. 

‒ If you want to change the character spacing for part of the text in a cell, select 

the text. 

‒ If you want to change the character spacing for text located in one or more cells, 

select those cells. 

‒ If the character spacing needs to be changed for text located in one or more 

rows/columns, select the rows/columns.  

2. In the Format menu, select Font > Character Spacing (see Figure 341). 

3. In the opened sub-menu, select the desired character spacing type. 
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Figure 341. Format menu 

To change the character spacing using the Toolbar, do the following: 

1. Select the text or cells where you want to change the character spacing as described 

above. 

2. In the Toolbar, select the Font section and click the  button (see Figure 342). 

3. Select the desired character spacing type: 

 : Condensed 

 : Normal 

 : Expanded 

 

Figure 342. Select the character spacing 
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4.11.10 Cell background color 

4.11.10.1 Cell fill color 

To fill cells with color, follow these steps: 

1. Select the cell or range of cells whose color you want to change. 

2. To color the cells in the last color that was used for filling earlier, on the Toolbar, in 

the Cells section, click  Cell Background Color (see Figure 343). 

3. To color the cells in a different color, click the arrow to the right of the button 

 Cell Background Color. 

 

Figure 343. Cell Background Color button 

4. Select the desired color in one of the following blocks: 

‒ Theme Colors: This block contains the color palette of the current document's 

theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 
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‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. The block is displayed if you have selected at least 

one color. 

5. If there is no matching color in the blocks listed above, you can define it manually. 

To do this, More Colors. In the Select Color window that appears (see Figure 344), 

specify the desired color as a HEX code or in RGB format and click OK. 

 

Figure 344. Select Color window 

The selected color will be checked, and the selected cells will be filled with that color. 

4.11.10.2 Remove cell background 

To remove the background of the cells, do the following: 

1. Select the cells you want to remove the background of. 

2. On the Toolbar, in the Cells section, click the arrow to the right of  

the  Cell Background Color button. 

3. Under the palette that expands, click No Color. 
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4.11.11 Cell borders 

4.11.11.1 Cell border parameters 

By default, when you create a document, there are no borders between cells. The grid, visible 

on the sheet, conditionally separates cells from each other to make working with data easier and 

is not displayed when printing. 

To add borders to cells, or to change settings previously applied to borders, follow these 

steps: 

1. Select the cell or range of cells whose borders need to be changed. 

2. On the Toolbar, in the Cells section, click the arrow to the right of the  button. 

3. In the window that opens, in the first block of settings, specify the position of the borders 

you need to change the parameters of. 

 

Figure 345. Border settings window 
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4. In the second block of settings, select the type of line to be applied to the specified 

borders. 

5. In the third block of settings, select a line color from one of the following groups: 

‒ Theme Colors: This block contains the color palette of the current document's 

theme. 

‒ Standard Colors: This block contains the colors that users most often choose when 

formatting a document. 

‒ Recent Colors: This block contains up to the last ten colors that you selected when 

formatting the document earlier. 

6. If there is no matching color in the sections listed above, you can define it manually. 

To do this, click More Colors button. In the Select Color window (see Figure 346) that 

appears, specify the desired color as a HEX code or in RGB format and click OK. 

 

Figure 346. Select Color window 

7. To close the border parameters window, do one of the following: 

‒ On the Toolbar, in the Table section, click the arrow to the right of the  button 

(see Figure 345). 

‒ Click a blank area of the document outside the window. 

To quickly apply the last selected border style to a cell or range of cells, follow these steps: 

1. Select the desired cell or range of cells. 

2. On the Toolbar, in the Cells section, click the  button (see Figure 345). 
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4.11.11.2 Remove cell borders 

To remove borders around a cell or range of cells, follow these steps: 

1. Select the cell or range of cells. 

2. On the Toolbar, select the Cells section and click the arrow to the right of 

the  All Borders button (see Figure 345). 

3. In the opened menu, set the necessary parameters: 

‒ In the first settings section, specify which borders should be removed. 

‒ In the second settings section, select No borders. 

4. To close the border parameters window, do one of the following: 

‒ On the Toolbar, in the Table section, click the arrow to the right of the  button  

(see Figure 345). 

‒ Click a blank area of the document outside the window. 
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4.11.12 Copy and insert formatting 

In MyOffice Spreadsheet, you can copy the formatting from one part of a document to 

another. The formatting copied can be applied: 

‒ Once (to one text fragment) 

‒ Multiple time (to multiple text fragment one by one) 

The formatting copied to the clipboard can also be used in MyOffice Text. 
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4.11.12.1 Formatting basics 

Depending on the selected item, you can format: 

‒ Paragraph 

‒ Text 

‒ Paragraph and text 

‒ Cell 

Table 19 specifies how the formatting is copied and applied. 
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Table 19. Formatting basics 

When you copy When you insert Result 

The cursor is positioned, or 

the entire paragraph 

(paragraphs) is selected 

The cursor is positioned 
Formats the paragraph or the first 

selected paragraph 

A paragraph is partially selected Formats the text 

The entire paragraph 

(paragraphs) is selected 
Formats the paragraph and text 

Several paragraphs are partially 

selected 
Formats the paragraph 

A paragraph is partially 

selected 

The cursor is positioned No formatting 

A paragraph is partially selected 

Formats the text from the first 

selected character 

The entire paragraph 

(paragraphs) is selected 

Several paragraphs are partially 

selected 

The cursor is positioned 

A spreadsheet cell is selected 

Formats the paragraph and text in 

the selected cell 

A paragraph is partially 

selected 
Formats the text in the selected cell 

The entire paragraph 

(paragraphs) is selected (up to 

the paragraph sign) 

Formats the paragraph and text 

A spreadsheet cell is selected 

A spreadsheet cell is selected 
Formats the cell, paragraph, and 

text 

The cursor is positioned Formats the paragraph 

A paragraph is partially selected Formats the text 

The entire paragraph 

(paragraphs) is selected 
Formats the paragraph and text 

Several paragraphs are partially 

selected 
Formats the paragraph 

A row or column is selected 
Formats the cell, paragraph, and 

text 

A row or column is selected A row or column is selected 

Formats the cell, paragraph, and 

text from the upper left cell in 

the copied row or column. 

Formats the row or column 
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4.11.12.2 Copy and insert formatting 

You can copy the formatting using: 

‒ Command menu 

‒ Keyboard shortcut 

‒ The  button on the Toolbar. 

 

To copy the formatting using the command menu or a keyboard shortcut, perform 

the following actions: 

1. Select the part of the document you want to copy the formatting from 

(see the Table above). 

2. Copy the formatting using one of the following methods: 

‒ In the Edit menu, select Copy Formatting (see Figure 347). 

 

Figure 347. Edit menu 

‒ Press Ctrl+Shift+C / ⇧Shift+⌘Cmd+C. 

3. To apply the formatting to one part of the document, do the following: 

‒ Select the part of the document you want to copy the formatting to 

(see the Table above). 

‒ In the Edit menu, select Paste Formatting (see Figure 347) or press Ctrl+Shift+V / 

⇧Shift+⌘Cmd+V. 
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4. To apply the formatting to multiple elements in the document, select these elements one 

by one and apply the formatting as described above. 

 

To format one element of a document using the  Copy Formatting button, follow these 

steps: 

1. Select the part of the document you want to copy the formatting from 

(see the Table above). 

2. On the Toolbar, select the Edit section and double-click the  Copy Formatting button 

(see Figure 348).  

3. Select the part of the document you want to copy the formatting to (see the Table above). 

 

Figure 348. Edit menu 

To format multiple elements of a document using the  Copy Formatting button, follow 

these steps: 

1. Select the part of the document you want to copy the formatting from (see the table 

above). 

2. On the Toolbar, select the Edit section and double-click the  Copy Formatting button. 

The button will change to . 

3. Select the parts of the document you want to copy the formatting to one by one 

(see the Table above) and apply the formatting. 

 

To exit the multiple elements formatting mode, follow these steps: 

1. On the Toolbar, select the Edit section and click the  button. The button will change 

to . 

2. Press Esc. 
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4.11.12.3 Formatting history 

Formatting copied to the clipboard history is saved and can be applied later. 

To open the formatting history, follow these steps: 

1. On the Toolbar, select the Edit section and click the arrow to the right of 

the  Copy Formatting button. 

2. In the opened drop-down list, select the format you want (see Figure 349). The most 

recent formatting is on the top of the list. 

3. Select the part of the document you want to copy the formatting to as described in 

Section 4.11.12.1. 

 

Figure 349. Recent formatting 
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4.12 Edit content 

4.12.1 Undo and redo actions 

4.12.1.1 Undo the last action 

You can undo the last action performed on the content of a document. 

To do this, use one of the following methods: 

‒ In the Command menu, select Edit > Undo (see Figure 350). 

 

Figure 350. Edit menu 

‒ On the Toolbar, in the Edit section, click  Undo (see Figure 351). 

 

Figure 351. Undo and Redo buttons 

‒ When working on Windows / Linux, press Ctrl+Z or Alt+Backspace, when working on 

macOS, press ⌘Cmd+Z. 

To undo several recent actions, run the undo command several times. 
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4.12.1.2 Redo the result of the undone action 

The undone action can be redone if necessary. 

To do this, use one of the following methods: 

‒ In the Command menu, select Edit > Redo (see Figure 350). 

‒ On the Toolbar, in the Edit section, click  Redo (see Figure 352). 

‒ When working on Windows/Linux, press Ctrl+Y / Ctrl+Shift+Z / 

Shift+Alt+Backspace. When working on macOS, press ⌘ Cmd+Y. 

To redo the last few undone actions, run the redo command several times. 
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4.12.2 Clipboard 

4.12.2.1 Cut or copy data 

When you use the Cut command, the selected content is removed from the document and 

placed to the clipboard. When copying, the selected contents of the document do not change, and 

their copies are placed to the clipboard. 

The content copied or cut retains its formatting. 

You can insert the data copied or cut into MyOffice Spreadsheet, as well as into other 

applications, such as MyOffice Text. 

 

If you want to cut or copy data that contains an object (such as a shape or image), cut, or 

copy the data and the object separately. 

To cut data, follow these steps: 

1. Select the object you want to cut, or the cell, cell range, rows, or columns you want to 

cut the content from. 

2. Run the cutting command in one of the following ways: 

‒ In the Edit menu, select Cut (see Figure 350). 

‒ On the Toolbar, select the Edit section and click  Cut (see Figure 352). 

 

Figure 352. Cut and Copy buttons 

‒ Right-click the selected object, cells, or the titles/contents of the selected 

rows/columns to open the context menu. Run the Cut context menu command. 

‒ Press Ctrl+X or Shift+Delete (Windows OS). In macOS, press ⌘Cmd+X. 

 

To copy data, follow these steps: 

1. Select the object you want to copy, or the cell, cell range, rows, or columns you want to 

copy the content from. 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 374 

2. Select the copy command in one of the following ways: 

‒ In the Edit menu, select Copy (see Figure 350). 

‒ On the Toolbar, select the Edit section and click the  Copy (see Figure 352). 

‒ Right-click the selected object, cells, or the titles/contents of the selected 

rows/columns to open the context menu. Run the Copy context menu command. 

‒ Press Ctrl+C or Ctrl+Insert (Windows OS or Linux). In macOS, press ⌘Cmd+C. 

 

The copied cells, rows, or columns are highlighted by a dashed line frame. The frame 

automatically disappears when the copied data is pasted again. 

If you want to remove the dotted frame manually, press the Esc key. 
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4.12.2.2 Paste the last cut or copied data 

Pre-copied or cut out data in the clipboard is available for inserting. If you have copied or 

cut a range of cells/rows or columns, the inserted data will be of the same size. 

 

Inserting data into non-empty cells or ranges deletes the previous data without warning. 

You can paste data from the clipboard with or without saving the original formatting. 

To insert the content while keeping its original formatting: 

1. Place the cursor where you want to insert the data: 

‒ If the clipboard contains data from a single cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column where you want to paste the contents of the first 

cell/row/column in the range. 

‒ If the clipboard contains an object, select the cell to align the upper left corner of 

the object to. 

2. Paste the content in one of the following ways: 

‒ Select Edit > Paste (see Figure 350). 

‒ On the Toolbar, select the Edit section and click  Paste (see Figure 353). 

‒ On the Toolbar, select the Edit section and click the arrow to the right of 

the  Paste button. In the drop-down list, select the Paste command  

(see Figure 353). 

 

Figure 353. Paste button 
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‒ Open the context menu by right-clicking the selected cells or the titles/content of 

the selected rows/columns. Run the Paste context menu command. 

‒ Press Ctrl+V or Shift+Insert (Windows OS or Linux). In macOS, press ⌘Cmd+V. 

The following rules apply when pasting data without preserving the original formatting: 

‒ Only the text is pasted from the clipboard. For example, when you paste a shape with 

text or a link, only the text that these objects contain is pasted into the document. 

‒ If the clipboard contains a formula, only the result of the formula is pasted 

(see Section 4.5.8). 

 

To insert the data without the original formatting, follow these steps: 

1.  Specify where you want to paste the data: 

‒ If the clipboard contains data from a single cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column where you want to paste the contents of the first 

cell/row/column in the range. 

‒ If the clipboard contains a text object, select the cell into which you want to paste 

the text. 

2. Run the paste command in one of the following ways: 

‒ Select Edit > Paste Values Only (see Figure 354). 

 

Figure 354. Edit menu 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 377 

‒ On the Toolbar, select the Edit section and click the arrow to the right of  

the  Paste button. In the drop-down list, select the Paste Values Only command 

(see Figure 353). 

‒ Right-click the selected cells or the content of the selected rows or columns to open 

the context menu. In the context menu, select Paste Values Only. 
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4.12.2.3 Insert data from the clipboard history 

The clipboard history is available in MyOffice Spreadsheet. It can simultaneously store up 

to ten copied or cut entries. Each next entry will take the place of the oldest one in the history. 

The clipboard history works between MyOffice Spreadsheet and MyOffice Text and vice 

versa. 

Data from the expanded clipboard is pasted with the original formatting intact. 

4.12.2.3.1 Insert data 

To insert data from the clipboard history, do the following: 

1. Specify where you want to insert the data: 

‒ If the clipboard contains data from the same cell/row/column, select 

the cell/row/column where you want to paste the data. 

‒ If the clipboard contains a range of cells/rows/columns, select the appropriate size 

range, or select the cell/row/column in which to paste the contents of the first 

cell/row/column in the range. 

‒ If the clipboard contains an object, select the cell to align the upper left corner of the 

object to. 

2. Open the clipboard history in one of the following ways: 

‒ In the Command menu, select Edit > Paste from Clipboard  

(see Figure 355). 

 

Figure 355. Data in the clipboard history 
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‒ Open the context menu by right-clicking the selected cells or the titles/content of 

the selected rows/columns. Select the Paste from Clipboard context menu 

command. 

3. In the opened sub-menu, select the data you want to paste. 

 

For convenience, the contents of the clipboard can be opened in a separate window.  

To do this, perform one of the following actions: 

‒ In the Command menu, select Edit > Paste from Clipboard > Clipboard History 

(see Figure 356). 

‒ Open the context menu by right-clicking any cell or any row/column headers/contents. 

Run the context menu command Paste from Clipboard > Clipboard History. 

‒ Press Ctrl+Alt+Shift+V / ⌥Option+⇧Shift+⌘Cmd+V. 

 

Figure 356. Clipboard history commands 

By default, the clipboard history window (see Figure 357) is positioned next to 

the highlighted or last highlighted cell (for example, if a column is highlighted). To change the 

window's position, drag it by the title bar while holding down the left mouse button. 
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Figure 357. Clipboard history 

How to navigate the clipboard history: 

‒ To move through the clipboard entries, use the ↓ and ↑ keys. 

‒ To paste the selected entry from the clipboard to the specified place of the document, 

click the left mouse button or press the Enter key. 

‒ To switch between the document and the clipboard history, use the Tab key. 

‒ To close the clipboard history window, click the  button in its header. 

4.12.2.3.2 Clear clipboard history 

To clear the history of the clipboard history, follow these steps: 

1. Open the clipboard history sub-menu in one of the following ways: 

‒ In the Command menu, select Edit > Paste from Clipboard  

(see Figure 354). 

‒ Open the context menu by right-clicking any cell or any row/column 

headers/contents. Select the Paste from Clipboard context menu command. 

2. In the opened sub-menu, click Clear. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 381 

4.13 Cloud actions 

 

The Cloud and collaborative editing functions are available with the MyOffice 

Professional / MyOffice Private Cloud server part. 

 

In MyOffice Spreadsheet, you can work in the Cloud5F and take advantage of the following 

features: 

‒ Collaborate on .xods files and track changes in real time. 

‒ Download, upload, and save the following file types: 

‒ Archives 

‒ Texts 

‒ Spreadsheets 

‒ PDF files 

‒ Presentations 

‒ Templates 

‒ Images 

‒ Audio and video files 

To start working in the Cloud, you need to log in (see Section 4.12.1). 

In the Cloud, you can access the following folders (see Figure 358): 

 

Figure 358. The Cloud 
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‒ My Documents: The folders and files created (see Section 4.12.4) or uploaded 

(see Section 4.12.5) by the user. 

‒ Shared: The folders and the files created by other users and shared with you 

(see Section 4.13.9.1). 

‒ Common folders: The folders and files shared by one or several groups or all employees 

of the company. 

‒ Flagged: The folders and files flagged as important by the user. 

 

You can only flag the folder or file as important by using the MyOffice 

Documents web application. 

‒ Recent Files: List of recent documents that the user has opened from the Cloud 

(see Section 4.13.2). 

‒ Trash: The files deleted by the user (see Section 4.13.7). 

If several users simultaneously collaborate on a .xods file in the Cloud, the avatars of 

collaborators will be displayed on the Sidebar (see Figure 359). You can display a tooltip with user's 

name by mousing over the user's avatar. 

Changes made to the document are displayed in real time. 

 

Figure 359. Collaboration 
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4.13.1 Enter the Cloud 

To log in to your Cloud account, follow the steps below: 

1. In the File menu, select Cloud Actions and then Log In to Cloud (see Figure 360). 

 

Figure 360. File menu 
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2. In the opened Log In to Cloud window (see Figure 361), enter your login credentials: 

 

Figure 361. Log In to Cloud window 

‒ In the Login box, enter the email address that you used when registering with 

MyOffice. 

‒ In the Password box, enter the password that you used when registering with 

MyOffice. 

‒ The Server box will be filled in automatically with your company's server 

parameters.  

3. Click Log In to enter your account. 

 

When you reopen the application, you will be logged in automatically if your login 

credentials are valid and the authentication server is reachable. 
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4.13.2 Open a file 

Once logged in, you can open and edit .xods files from your company's Cloud. 

To open a file from the Cloud, proceed with the following: 

1. In the File menu, select Open in Cloud (see Figure 362) or press Ctrl+Shift+O / 

⇧Shift+⌘Cmd+O. 

 

Figure 362. File menu 

2. In the opened file manager window (see Figure 363), select the section on the left 

containing the file you want to open.  

3. Select the file. 

 

If the Author or Owner of the selected file is deleted from the system by 

the administrator, a mark (inactive) is displayed to the right of his/her name. 

Deleting a user does not affect the levels of access to the document that he/she 

has previously granted to other users (see Section 4.13.9.1). 

 

4. Click OK to open it. 
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Figure 363. File manager of the Cloud 

The file will open in a new window. 

If a file created by another user is selected, the Status bar displays the access level granted 

by the author of the document: View, Edit or Manage (see Section 4.12.9). An example is shown 

in Figure 364. 

 

Figure 364. File access level  
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In the View mode, you cannot make changes to the document or change its formatting. 

If necessary, you can create an editable copy of this document. To do this, click 

the Edit a Cloud Copy button on the Toolbar (see Figure 365). 

 

 

Figure 365. Edit a Cloud Copy button 

A copy of the document is created in the root folder of the Cloud storage (see Figure 363). 

It is automatically assigned the name Copy <original name (n)>, where (n) is the copy number. 

When a copy is created, the original document is automatically closed, and a copy of the document 

is opened. 

In the View and Manage mode, you can access the document without restrictions. 

All changes will be automatically saved into the Cloud. 

If you do not perform any actions on a document for a long time, the session is automatically 

terminated. A dialog box appears on the screen (see Figure 366), which you can use to start a new 

session with this document or select another document to work with. If you want to close 

the document, click the  button in the dialog box. 

 

Figure 366. Dialog box  
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4.13.3 Create a local copy 

To avoid losing data when working in the Cloud in MyOffice Spreadsheet, you can create a 

local copy of your file. 

If an error occurs while working with a file located in the Cloud (for example, the connection 

to the server is interrupted), a dialog box is displayed, which allows you to save a local copy of 

the file (for an example, see Figure 367). 

Click the Create Local Copy button in this dialog box. 

In the file manager window that opens, specify the folder in which to save the file, file name 

and type, and click Save. 

 

Figure 367. Dialog box 

A local copy of the file can also be created manually at any time.  

1. In the File menu, select Create Local Copy (see Figure 368). 

2. In the opened file manager window, specify the folder where you want to save the file, 

file name, and type.  

3. Click Save. 
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Figure 368. File menu 
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4.13.4 Create a file or folder 

You can create files or folders directly from MyOffice Spreadsheet. 

To create a file or folder, follow these steps: 

1. In the File menu, select Open in Cloud (see Figure 368) or press  

Ctrl+Shift+O / ⇧Shift+⌘Cmd+O. 

2. In the file manager of the Cloud (see Figure 363), select the section where you want to 

create a file or folder. 

 

You can create folders and files in My Documents and public folders that you can edit. 

3. To create a folder, click New Folder. To create a file, click New File. 

 

Figure 369. File manager of the Cloud 

4. In the opened window (see Figure 370), enter the name of a file or folder and click OK. 
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Figure 370. New File in Cloud window 

File or folder name should meet the following requirements: 

‒ Can contain up to 255 characters 

‒ Can contain (~), (`), (!), (@), (#), ($), (%), (^), (&), (,), (_), (+), (-), (=), ({ }), ([]), (;), ('), 

(,), (.) 

‒ Cannot begin with a dot (.) 

The new file or folder will be displayed in the selected folder. The new files are always 

created in the .xods format. 

To exit the file manager (see Figure 369), click OK. 
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4.13.5 Upload a file 

You can upload individual text, audio, video, and other files, or multiple files to the Cloud6F. 

Folder upload is not supported. 

 

The maximum allowable file download size is configured on the server.  

If an error occurs due to the file size exceeding the limitation, contact your system 

administrator. 

 

To upload a file or a group of files to the Cloud, do the following: 

1. In the File menu, select Cloud Actions and then File Upload (see Figure 371). 

 

Figure 371. File menu 

2. In the opened file manager window, select the files you want to add to the Cloud. 

3. Click Upload. 

You can continue working in the Cloud while uploading the files and minimize the upload 

window, if needed (see Figure 372). 
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Figure 372. File upload 

By default, the files are uploaded to the root folder of My documents cloud storage. 

To see all files stored in the Cloud, use the download function. For more details, see 

Section 4.12.6. 

4.13.6 Download a file or folder 

You can download files and folders from the Cloud to your computer. 

Follow these steps: 

1. In the File menu, select Cloud Actions and then Download (see Figure 371). 

2. In the file manager window (see Figure 373), select the section to the left containing 

the file or folder you want to download. The contents of the section will be displayed on 

the right side. 
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Figure 373. File manager 

3. You can filter file types. Expand the All Files drop-down list and select the file type you 

want to display in the section. 

4. Select a file or folder that you want to download from the Cloud. 

5. In the Path box, specify the folder in which you want to save the selected file or folder. 

6. If you want to open the file upon download, check the Open upon completion box. 

7. Click OK. 

 

If the folder path entered in the Path box is incorrect, the OK button will be inactive. 

 

If you select a folder, it will be downloaded as a ZIP archive. Unpack it using file archiving 

software. 
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4.13.7 Delete a file 

Files in the Cloud can be deleted by their authors or owners. 

Author: The user who created the file.  

Owner: The author of the folder containing the file. 

If you as the author of a file created it in your folder, you are also the owner of this file. But 

if you have created a file in a folder created by another user, this user becomes the owner of the file.  

To delete a file from the Cloud, do the following: 

1. In the File menu, select Open in Cloud and then Download. Alternatively, in the File 

menu, select Cloud Actions and then Download (see Figure 371). 

2. In the file manager of the Cloud, right-click the file and select Delete (see Figure 374). 

 

Figure 374. Delete command 

 

If the file is stored in a folder created by another user, it will be moved to the Trash 

folder of the folder's owner and will not be displayed in the Trash folder of the file 

author. 
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If needed, you can restore files from the Trash folder (see Section 4.12.8) or delete them 

permanently. 

 

To permanently delete a file from the Cloud, do the following: 

1. In the file manager of the Cloud, select the Trash folder (see Figure 375).  

2. In the list of files, right-click the file you want to delete and select  

Delete Permanently. 

 

Figure 375. Delete a file from the Trash 
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4.13.8 Restore a file or folder 

To restore a file or folder from the Trash folder, do the following: 

1. Open the Trash folder (see Figure 375). 

2. Right-click the folder or file and select Restore. 

If the Trash folder contains a folder, you can restore it entirely or select individual files from 

this folder. In either case files will be restored to their original location. 
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4.13.9 Shared access to files 

4.13.9.1 Share a file 

You can collaborate on .xods files created in the Cloud. Access is provided for sharing, 

editing and/or managing file permissions. 

To share access to a file, proceed with the following: 

1. Open the file in the Cloud (see Section 4.12.2). 

2. In the Share menu, select Sharing Settings (see Figure 376). 

 

Figure 376. Share menu 

3. In the opened window (see Figure 367), specify the users you want to share the file with 

in one of the following methods: 

‒ Enter the name and email address of each user manually. 

‒ Click the  Choose contacts button and select the users one by one. 

 

Figure 377. Share menu 
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4. Specify the access level for the selected users on the right side of the address book 

(see Figure 378): 

‒ View: Users can view the document, the comments to the document, and download 

the document. 

‒ Edit: Users are entitled to View the document and have the possibility to edit 

the document. 

‒ Manage: Users are entitled to View and Edit the document and to manage the access 

right settings, such as providing the access rights to the new users and change 

the access rights of the existing users. 

‒ Access Denied: Block the user access to the document. 

 

Figure 378. Selecting the access level 

5. If you want to notify all users about changes in the file sharing settings, check the Notify 

by email box. 

 

You cannot use the Notify by email option if: 

‒ The email address is invalid. 

‒ File sharing settings have been changed. 

‒ Access to file is denied. 

‒ Access rights are provided to a group but not to individual users. 
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6. Click the Add button (see Figure 379) to add the selected users to the list of users with 

access to the file (see Figure 380). 

 

Figure 379. Add button 

7. Click Close button to close the Sharing Settings window. 

 

Figure 380. List of users 
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4.13.9.2 Change sharing settings 

A user with the Manage access level can change share settings for other users except 

the Owner of the file. 

 

If the Owner of the file is deleted from the system by the administrator, a mark 

(inactive) is displayed to the right of his/her name. 

To do this, follow the steps below: 

1. Open the file in the Cloud (see Section 4.13.2). 

2. In the Share menu, select Sharing Settings (see Figure 381). 

 

Figure 381. Share menu 

3. In the opened window (see Figure 382), specify the sharing settings for the individual 

users using the drop-down lists next to their names. 

4. Click the Close button. 

 

Figure 382. Change access level 
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4.13.9.3 Revoke access to files 

A user with the Manage access level can revoke access rights from other users except 

the Owner of the file. 

 

If the Owner of the file is deleted from the system by the administrator, a mark 

(inactive) is displayed to the right of his/her name. 

To do this, follow the steps below: 

1. Open the file in the Cloud (see Section 4.12.2). 

2. In the Share menu, select Sharing Settings (see Figure 381). 

3. In the opened window (see Figure 382), click  Revoke permission next to the names 

of the users you want to revoke the permission from. 

4. Click the Close button. 

4.13.10 Revoke access to files 

Users of the Cloud can share files with other users (see Section 4.12.9). 

Once the access to a file is provided, it will be displayed under the Shared section of 

the Cloud. If you do not want to have access to a file, the file will be deleted from the list. 

To revoke your own access to a file, follow these steps: 

1. In the File menu, select Open in Cloud (see Figure 383). 

 

Figure 383. File menu 
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2. In the file manager of the Cloud, select Shared (see Figure 384). 

 

Figure 384. Revoke access 

3. Revoke your own access by using one of the following methods: 

‒ Right-click the file to select it and choose Revoke Access. 

‒ Left-click the file and press the Delete key. 

4. In the Revoke Access pop-up window, click OK (see Figure 297). 

 

Figure 385. Revoke Access window 
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4.13.11 Exit the Cloud 

Don't forget to close all the files opened in the Cloud before leaving the Cloud. 

To leave the Cloud, do the following: 

1. In the File menu, select Cloud Actions > Log Out of Cloud (see Figure 386). 

 

Figure 386. Log out window 

2. In the Log Out of Cloud window (see Figure 387), click Log out. 

 

Figure 387. Log Out of Cloud window 
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4.14 Automation tools 

4.14.1 Macros 

A macro is a set of actions that automate repeated or time-consuming tasks in a text 

document.  

MyOffice Spreadsheet macros are written in Lua programming language. 

Macros are most used for the following purposes: 

‒ Adding a formula to a cell. 

‒ Adding text to a cell. 

‒ Find and replace items throughout the text. 

‒ Delete text. 

Macro commands can only be saved within the current document. If you want to use similar 

macro commands in another document, create them directly in the other document.  
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4.14.1.1 Create a macro 

You can create a macro in one of the following ways: 

1. Record a sequence of actions that a macro command should consist of. 

2. Enter the macro text manually. 

 

To record a macro, do the following: 

1. In the Tools command menu, select Macros > Record Macro (beta)  

(see Figure 388). 

2. Run the sequence of actions that a macro command should consist of. 

 

In the current version of the application, not all user actions are available for recording. 

When you perform an action that cannot be recorded, the "Action cannot be recorded" 

message pops up on the screen. 

 

Figure 388. Record Macro command (beta) 

3. Finish the recording process in one of the following ways: 

‒ In the Tools command menu, select Macros > Stop Recording (beta)  

(see Figure 389). 

 

Figure 389. Stop Recording command  
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‒ On the Status bar, click the  Stop Recording button (see Figure 390). 

 

Figure 390. Stop Recording button 

4. In the opened dialog box (see Figure 391), specify the macro name and click the OK 

button. 

 

Figure 391. Dialog box 

If the macro has been successfully saved, the following pop-up message will be displayed 

on the screen: “"Macro_name" macro saved.” 
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To enter the macro text manually, do the following: 

1. In the Tools command menu, select Macros > Macro Editor (beta) (see Figure 388). 

2. In the Macro Editor window, click the  button (see Figure 396). 

 

Figure 392. Macro Editor command 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 409 

3. Enter the macro name or keep the default name (see Figure 397). To keep the name, 

press the Enter key or click anywhere on the macro editor area with the mouse. 

 

Figure 393. Entering the macro name 

4. Enter the macro script (see Figure 394). 
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Figure 394. Entering the macro script 

The script will be saved automatically. 
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When a macro has been added to a document, the Sidebar will display the  Macros button 

(see Figure 399). Clicking this button opens the Macro pane where you can perform the following 

actions: 

‒ Find a macro (see Section 4.14.1.2) 

‒ Run a macro (see Section 4.14.1.3) 

‒ Open the Macro Editor (see Section 4.14.1.1). 

 

Figure 395. Macro pane 

To close the Macro Editor pane, click the  button above the search line, or click 

the  Macros button on the Sidebar once again. 

The  Macros button is displayed on the Sidebar if the document contains at least one 

macro. 
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4.14.1.2 Find a macro 

If a file contains multiple macros and that you need to find a specific macro, do the following: 

1. On the Sidebar, click  Macros (see Figure 396). 

2. In the macros pane, specify the macro title in full or partially. 

The list of macros will display the macros matching the search request. 

 

Figure 396. Search the macro 
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4.14.1.3 Run a macro 

You can run a macro command using the macro editor or the Macro pane. 

To run a macro command using the macro editor, follow these steps: 

1. In the Command menu, click Tools > Macros > Edit Macros (see Figure 397). 

 

Figure 397. Macro Editor menu 

 

2. In the Edit Macros window that appears, select the macro from the list  

(see Figure 398). 

3. Click Run. 
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Figure 398. Run button 

 

The results are displayed in the Output pane (see Figure 399). 
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Figure 399. Macro results 
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To run a macro using the Macro pane: 

1. On the Sidebar, click  Macros (see Figure 400). 

 

Figure 400. Macro pane 

2. Run the macro in one of the following ways: 

‒ In the Macro pane, place the cursor over the macro title and click  Run  

(see Figure 400). 

‒ Select the line of the macro by double-clicking it. 

  



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 417 

4.14.1.4 Edit a macro 

To edit a macro, do the following: 

1. Open the window where you can edit a macro in one of the following ways: 

‒ In the Command menu, click Tools > Macros > Macro Editor (see Figure 401). 

 

Figure 401. Tools command menu 

 

‒ On the Sidebar, click  Macros (see Figure 402). In the macro pane, place 

the cursor over the title of the macro that you want to edit and click  Edit. 

 

Figure 402. Macro pane 

2. In the Edit Macros window, select the desired macros from the list (see Figure 398). 

3. Make the changes to the script. 

 

All changes made to the script are saved automatically.  
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4.14.1.5 Debug a macro 

Before you start the macro debugger, set the debugger breakpoints in the macro text. 

To do this: 

1. Open the macro editing window in one of the following ways: 

‒ In the Command menu, click Tools > Edit Macros (see Figure 401). 

‒ On the Sidebar, click  Macros (see Figure 402).  

2. In the Macros Editor window, select the desired macro from the list (see Figure 403). 

In the Macro pane, hover your mouse over the name of the macro command you want to 

edit and click  Edit. 

3. Set the first debugger breakpoint. To do this, click to the right of the line number where you 

want to create a breakpoint. The breakpoint will be marked with the  icon. 

4. Set other breakpoints by repeating these actions. 

To delete a breakpoint, click it with the mouse. 
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Figure 403. Breakpoint 

To debug a macro, do the following: 

1. Click  Debug (see Figure 404). The macro debugging process will begin. If the text of a 

macro contains breakpoints, the debugging process will stop on the line that contains 

the first breakpoint. If there are no breakpoints, the debugging process will stop at the first 

line of the macro. 
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Figure 404. Debug button 
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To manage the debugging steps, use the following buttons (see Figure 405): 

 : Perform one debugging step or step into the body of the function if there is one in 

the current debugging position. 

 : Perform one debugging step without stepping into the body of the function. 

 : Continue executing the macro until leaving the function where the debugger is at 

the current position. 

 

While debugging, the Macros Editor window displays the following areas: 

‒ In progress: This window will display messages while debugging. 

‒ Calls Stack: The calls stack window. 

‒ Variables: This window displays the values of local and global variables available at 

the current macro step. If the displayed variable is a table or an array, you can view its 

detailed contents by clicking the button to the left of the variable name. 
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Figure 405. Debug a macro 

 

The debugging process ends once the end of the macro has been reached. 

To interrupt the debugging process, click the  Break script button. 
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4.14.1.6 Delete a macro 

To delete a macro: 

1. Open the macro editing window in one of the following ways: 

‒ In the Command menu, click Tools > Edit Macros (see Figure 406). 

 

Figure 406. Tools menu 

‒ On the Sidebar, click  Macros (see Figure 407). In the macro pane, place 

the cursor over the title of the macro that you want to delete and click  Edit. 

 

Figure 407. Macro pane 

 

2. In the Macros Editor window, select the desired macro from the list (see Figure 408). 

3. Click the  button. 
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Figure 408. Delete a macro 

4. In the opened window, confirm that you want to delete the macro. 

4.14.1.7 View VBA macro code 

In MyOffice Spreadsheet application, you cannot run VBA macros created in 

Microsoft Excel. However, you can view the code of VBA macros contained in the document and 

rewrite them in Lua. 

 

You can only view VBA macros saved in This spreadsheet. 

To view and rewrite the VBA macro code, follow these steps: 

1. Open the .xlsm file. 

2. Select the Lua macro with the name of the VBA module that contains the desired VBA 

macro. For example, if VBA macro Macro1 is contained in VBA module Module1, 

select Lua macro Module1. To select the Lua macro, do one of the following: 

‒ In the Command menu, select Tools > Macros > Macro Editor  

(see Figure 406). In the Edit Macros window (see Figure 411), select the desired 

Lua macros. 
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Figure 409. Edit Macros window 

‒ On the Sidebar, click  Macros (see Figure 410). In the Macro pane, place 

the cursor on the desired Lua macro and click  Edit. 

 

Figure 410. Macro pane 
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The Edit Macros pane will display the VBA macros code in the respective VBA module 

(see Figure 409). 

3. Rewrite the code of the desired VBA macros in Lua language. 

4. Close the macro editor window. 

5. Save the file in the .xlsx format using the Save as command  

(see Section 4.1.7.1) 

The changes made will not be saved in the initial .xlsm file. 
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4.14.2 Extensions 

Extension modules are typically created by third-party developers and extend 

the functionality of the spreadsheet editor. 

To use an extension, do the following: 

1. Get the .mox extension file from the developer. 

2. Install the extension. 

3. Run the extension using the MyOffice Spreadsheet command menu. 

 

When you update editors, all extensions from untrusted developers and extensions with 

invalid certificates are automatically disabled. If you trust the source from which you 

obtained these extensions, enable them manually as described below. 

 

4.14.2.1 Install an extension 

The extension files can be stored at any location on your computer. 

To install an extension, perform the following actions: 

1. In the Extensions menu, select Extension manager (see Figure 411). 

 

Figure 411. Extensions menu 

2. In the Extension manager window, click the Install button (see Figure 412). 
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Figure 412. Extension manager window 

3. In the file manager window, select the extension file. 
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4. Read the text in the Install Extension window (see Figure 413). If the window displays 

the message, which reads "This extension is ready to be installed. Do you want to 

continue?", it means that the author of the extension is a verified developer, and 

the extension is signed by a valid certificate. To see information about the developer's 

certificate, click Show details. To continue installing the add-in, click the Continue 

button. 

 

We strongly recommend that you should not install extensions received from 

unverified developers or extensions with an invalid certificate. Installing such 

extensions can harm your computer. 

 

 

Figure 413. Install Extension window 

5. In the End User License Agreement window (see Figure 414), read the License 

Agreement. If you agree to the terms of use of the software set forth in this document, 

click the Accept button. 
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Figure 414. End User License Agreement window 
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The Extension manager window will display the extension (see Figure 415). To see 

the detailed information on the installed extension, click About next to the extension. 

 

Figure 415. Extension information 

If the installation is successful, the Installed status is displayed next to the Extension. 

To enable an extension, follow the steps described in Section 4.13.2.2. 

If the version of the extension is incompatible with the version of the spreadsheet editor, 

the “  Incompatible version" message will be displayed in the extension string. 

If the extension files contain errors, the following message will appear next to the extension: 

“  Corrupt extension". 

To find out more about the error, proceed as follows: 

‒ Click the Details button in the extension string. 

‒ Click the extension string. In the opened dialog box, click the Details button. 
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4.14.2.2 Run an extension 

After the successful installation of the extension, it will appear in the Extensions menu 

(see Figure 416). 

To run the extension, in the Extensions menu, select the extension folder name and then 

the extension name. 

 

Figure 416. Extensions command 
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4.14.2.3 Enable or disable an extension 

Once installed, all the extensions are enabled by default. 

If an extension is enabled, it will appear in the Extensions menu (see Figure 416). 

If an extension is disabled, it will not appear in the Extensions menu. 

To disable an extension, perform the following actions: 

1. In the Extensions menu, select Extension manager (see Figure 417). 

 

Figure 417. Extensions menu 

2. In the Extension manager window, select Disable next to the extension name 

(see Figure 418). 

 

Figure 418. Disable an extension 

3. Close the Extension manager window. 

 

The extension will no longer be displayed in the Extensions menu. 
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To re-enable a disabled extension, follow the steps below: 

1. In the Extensions menu, select Extension manager (see Figure 417). 

2. In the Extension manager window, select Enable next to the extension name 

(see Figure 419). 

 

Figure 419. Enable an extension 

3. Close the Extension manager window. 

 

The extension will be displayed in the Extensions menu. 
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4.14.2.4 Update an extension 

The extension files can be stored in any folder on your computer. 

To update an extension, perform the following actions: 

1. In the Extensions menu, select Extension manager (see Figure 420). 

 

Figure 420. Extensions menu 

2. In the Extension manager window, click the Install button (see Figure 421). 

 

Figure 421. Install button 

3. In the file manager window, select the file of the new extension version. 
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4. Read the text in the Install Extension window (see Figure 371). If the window displays 

the message, which reads ""This extension is ready to be installed. Do you want to 

continue?", it means that the author of the extension is a verified developer, and 

the extension is signed by a valid certificate. To see information about the developer's 

certificate, click Show details. To continue installing the add-in, click the Continue 

button. 

 

We strongly recommend that you should not install extensions received from 

unverified developers or extensions with an invalid certificate. Installing such 

extensions can harm your computer. 

 

 

Figure 422. Install Extension window 

5. In the End User License Agreement window (see Figure 423), read  

the License Agreement. If you agree to the terms of use of the software set forth in this 

document, click the Accept button. 
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Figure 423. End User License Agreement window  
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If the update is successful, the Updated status is displayed next to the extension  

(see Figure 424). 

 

Figure 424. Updated extension 
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4.14.2.5 Remove an extension 

To remove an extension, perform the following actions: 

1. In the Extensions menu, select Extension manager (see Figure 420). 

2. In the Extensions manager menu, click the  button next to the extension you want to 

remove (see Figure 425). 

 

Figure 425. Remove an extension 

3. In the dialog box with the message "Are you sure you want to remove this extension?", 

click OK (see Figure 426). 

 

Figure 426. Dialog box 

4. Close the Extension manager window. 

 

The extension will no longer be displayed in the Extensions menu. 
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4.15 Protect a file 

4.15.1 Protect a file with a password 

If you want to restrict user access to a document, you can protect it with a password. The 

password is requested when opening the document. 

 

The current version of the application has the following limitations: 

‒ When exporting a file (see Section 4.1.10), the password is automatically deleted. 

‒ Working in password-protected files in the Cloud is not supported 

(see Section 4.12.2). 

‒ XOR-encrypted files created in third-party editors are currently not supported. 

 

If a document is password protected in a third-party application, you can work with it in 

the same way you would work with a document protected with a password in MyOffice Spreadsheet. 
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4.15.1.1 Set a password 

To protect a document with a password, do the following steps: 

1. Open the document you want to protect with a password. 

2. In the File menu, click Set Password (see Figure 427). 

 

Figure 427. File menu 
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3. In the Set Password window that appears (see Figure 428), enter the password and 

confirm it. 

For security reasons, the password entered is displayed as markers.  

To display password characters, click the  button in the right end of the input box. 

4. Click OK. 

 

Figure 428. Set Password window 

Once the data entered has been successfully verified, you will be notified correspondingly. 

Save the document to apply changes. 

The next time the document is opened, you will be asked to enter the password. 
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4.15.1.2 Change the password 

To change the password, follow the steps below: 

1. Open the document that you want to change the password for. 

2. In the File menu, click Manage Password (see Figure 429). 

 

Figure 429. File menu 
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3. In the Manage Password pop-up window that appears (see Figure 430), click 

Change Password. 

 

Figure 430. Manage Password window 
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4. In the Change Password pop-up window that appears (see Figure 431), enter the current 

password, a new password, and confirm the new password. 

For security reasons, the password entered is displayed as markers.  

To display password characters, click the  button in the right end of the input box. 

5. Click Done. 

 

Figure 431. Change Password window 

Once the data entered has been successfully verified, you will be notified correspondingly. 

Save the document to apply the changes. 
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4.15.1.3 Remove the password 

To remove the password, follow the steps below: 

1. Open the document that you want to remove the password from. 

2. In the File menu, click Manage Password (see Figure 429). 

3. In the Manage Password pop-up window that appears, click Remove Password 

(see Figure 430 ). 

4. In the Remove Password pop-up window that appears (see Figure 432), enter 

the current password and click Done. 

 

Figure 432. Remove Password window 
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4.15.1.4 Open a password-protected document 

When you open a password-protected document, a window for entering the password will 

appear on the screen (see Figure 433). Enter the password and click OK. 

If the password is correct, the document will open in MyOffice Spreadsheet. 

If you enter a wrong password, you will get a "The password is incorrect” notification.  

Click the  button to display the password you have entered and check it carefully.  

Try again. 

The number of attempts to enter a password for opening a document is not limited. 

 

Figure 433. Document is Protected window 
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4.15.2 Protect content from changes 

MyOffice Spreadsheet allows to protect the following elements: 

‒ Sheet: Users will not be able to edit all or protected sheet cells. 

‒ Document structure: Users will not be able to add, delete, move, rename, duplicate, hide 

sheets or display hidden sheets. 

4.15.2.1 Protect a sheet 

You can protect all or selected cells on the sheet from changes in the workspace 

(see Section 3.6). By default, MyOffice Spreadsheet protects all cells. 

To protect the contents of a sheet, follow these steps: 

1. Click the sheet tab with the mouse. 

2. Open the Manage Protection pane in one of the following ways: 

‒ In the Command menu, select Data > Manage Protection > Protect Sheet 

(see Figure 434). 

 

Figure 434. Protect Sheet menu 
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‒ Right-click the sheet tab and run the Protect Sheet context menu command 

(see Figure 435). 

 

Figure 435. Context menu of a sheet 

3. If you want to protect all cells of the workspace, do not uncheck the Locked for changes 

box on the Sheet tab (see Figure 436). 

4. If you need to specify the cells that users will be able to edit after installing protecting 

the sheet: 

‒ Select these cells. 

‒ Uncheck the Locked for changes box. 

5. If you want users to see only the result of the formula calculation in the protected cells 

and on the Formula bar: 

‒ Select these cells. 

‒ Check the Formulas not displayed box. 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 450 

 

Figure 436. Manage Protection pane 

6. Expand the Allowed actions section (see Figure 437) and specify what actions users are 

allowed to perform with protected cells. 



 

 

© New Cloud Technologies Ltd., 2013–2024. All rights reserved. 451 

 

Figure 437. Allowed action section 

7. If you need to set a password to remove protection from the sheet, expand the section 

Password (optional) (see Figure 438), enter the password and confirm it. 

8. Click Protect Sheet. 
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Figure 438. Password (optional) section 

9. Close the Manage Protection pane in one of the following ways: 

‒ At the top of the pane, click  (see Figure 440). 

‒ On the Sidebar, click  Manage Protection (see Figure 440). 

 

When working with a file in Microsoft Excel and LibreOffice Calc applications, sheet 

protection settings are not applied to cells located outside the workspace (see Section 3.6). 

4.15.2.2 Protect the document structure 

To protect the document structure, follow these steps: 

1. Open the Manage Protection pane. To do this, in the Command menu, select Data > 

Manage Protection > Protect the document structure (see Figure 439). 

 

Figure 439. Protect Sheet menu 
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2. In the Manage Protection pane, select the Spreadsheet Structure tab (see Figure 440): 

‒ If necessary, set a password to unprotect the document structure. 

‒ Click Protect Structure. 

3. Close the Manage Protection pane in one of the following ways: 

‒ In the upper part of the pane, click . 

‒ On the Sidebar, click  Manage Protection. 

 

Figure 440. Manage Protection pane 
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4.15.2.3 Unprotect a sheet 

If the sheet is protected from editing, the sheet tab displays the  icon (see Figure 441) is 

displayed on the sheet tab. You may need to enter a password to unprotect the sheet. 

 

Figure 441. Sheet protected from editing 

To remove protection from a sheet, do the following: 

1. Click the sheet tab. 

2. Open the Manage Protection pane in of the following ways: 

‒ In the Command menu, select Data > Manage Protection > Unprotect Sheet 

(see Figure 442). 

 

Figure 442. Unprotect Spreadsheet menu 
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‒ Right-click the sheet tab and use the Unprotect Sheet context menu command 

(see Figure 443). 

 

Figure 443. Context menu of the sheet 

3. In the Manage Protection pane, select the Sheet tab and do the following: 

‒ If the sheet is password-protected, enter the password, and click Unprotect 

(see Figure 444). 

 

Figure 444. Manage Protection pane 
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‒ If the sheet is not password-protected, click the Unprotect button  

(see Figure 445). 

4. To close the Manage Protection pane, do one of the following: 

‒ In the upper part of the pane, click . 

‒ On the Sidebar, click  Manage Protection. 

 

Figure 445. Unprotected sheet 
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4.15.2.4 Unprotect file structure 

If the document structure is protected from editing, an icon  is displayed to the right of 

the sheet tabs (see Figure 446). You may be required to enter a password to remove the protection. 

 

Figure 446. Data command menu 

To remove protection from the document structure, do the following: 

1. Open the Manage Protection pane. To do this, in the Command menu, select 

Data > Manage Protection > Unprotect Sheet (see Figure 446). 

 

Figure 447. Sheet command menu 

2. In the Manage Protection pane, select the Spreadsheet Structure pane and 

do the following: 

‒ If the document structure is password-protected, enter the password, and click 

the Unprotect button (see Figure 448). 
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Figure 448. Manage Protection pane 

‒ If the document structure is not password-protected, click the Unprotect button 

(see Figure 449). 

3. To close the Manage Protection pane, do one of the following: 

‒ In the upper part of the pane, click . 

‒ On the Sidebar, click  Manage Protection. 
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Figure 449. Unprotected spreadsheet structure  
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4.16 Links to educational resources 

The MyOffice Spreadsheet application as part of the MyOffice Education package contains 

a link pane for quickly navigating to various educational resources (see Figure 450). The list of links 

in the Education pane is editable and configurable by the system administrator. 

To open the Education pane, click the  Education button on the Sidebar. To click a link 

from the list, click it with your mouse. The link will open in the default OS browser. 

 

Figure 450. Education pane 
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APPENDIX 1. FUNCTIONS AND THEIR DESCRIPTION 

Function Description 

Financial 

COUPPCD(settlement, maturity, 

frequency, [day_count_convention]) 

Returns the numeric date value of the last coupon date before 

the settlement date of a security. 

DOLLARDE(fractional_price, unit) 
Converts a dollar value expressed as a fraction into a decimal 

number. 

DOLLARFR(decimal_price, unit) 
Converts a dollar value expressed as a decimal number into a 

fractional number. 

IRR(cashflow_amounts, [rate_guess]) 
Calculates the internal rate of return on an investment based on 

regular cash flows which include both payments and incomes. 

NPV(discount, cashflow1, [cashflow2, ...]) 

Returns the numeric value which is the net present value of an 

investment depending on a series of periodic cash flows and a 

discount rate. 

PMT(rate, number_of_payments, 

present_value, [future_value], 

[end_or_beginning]) 

Returns the periodic payment for an annuity based on constant 

periodic payments and a constant interest rate. 

PV(rate, number_of_periods, 

payment_per_period, [future_value], 

[end_or_beginning]) 

Returns the present value of an investment based on periodic 

payments and a constant interest rate. 

Time and date 

DATE(year, month, day) Creates a date from the specified year, month, and day. 

DATEVALUE(date_string) 
Transforms the provided date string in a known format to a 

numeric date value. 

DAY(date) 
Returns the day of the month that a specific date falls on, in 

numeric format. 

EDATE(start_date; months) 
Returns the numeric value of a date which falls a specified 

number of months before or after another date. 

EDATE(start_date; months) 
Returns the date representing the last day of the month which 

falls a specified number of months before or after another date. 

HOUR(time) Extracts the hour component from a given time value. 

ISOWEEKNUM(date) Returns the ISO week number (from 1 to 54) for a given date. 

MINUTE(time) Extracts the minute component from a given time value. 

MONTH(date) 
Returns the month of the year the specific date falls in, in 

numeric format. 

NOW() Returns the current date and time as a timestamp value. 

TODAY() Returns the current date in number format. 

YEAR(date) Returns the year specified by a given date. 

Math and trigonometry 

ABS(value) 
Returns the absolute value of a number. The result of calculation 

is always a positive number. 
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Function Description 

ACOS(value) 
Calculates the arccosine, that is the inverse cosine of a given 

number, and returns an angle expressed in radians. 

ACOSH(value) Calculates the inverse hyperbolic cosine for a number. 

ACOT(value) 

Calculates the arccotangent, that is the inverse cotangent of a 

given number, and returns an angle, in radians, between 0 (zero) 

and π. 

ASIN(value) 
Calculates the arcsine, that is the inverse sine of a given number, 

and returns an angle expressed in radians. 

ATAN(value) 
Calculates the arctangent, that is the inverse tangent of a given 

number, and returns an angle, in radians, between -Pi/2 and Pi/2. 

ATAN2(x, y) 

Returns the arctangent of an angle between the x-axis and a 

segment starting from the origin (0,0) and ending at a specific 

point defined by the coordinate pair (x,y). The resulted value is 

expressed in radians. 

ATANH(value) Calculates the inverse hyperbolic tangent for a number. 

COSH(value) Calculates the hyperbolic cosine for a real number. 

COTH(angle) Calculates the hyperbolic cotangent of a number. 

CSC(angle) 
Calculates the cosecant of a number and returns the result in 

radians. 

CSCH(angle) 
Calculates the hyperbolic cosecant of a number and returns 

the result in radians. 

DEGREES(angle) 
Converts an angle value in radians to the equivalent value in 

degrees. 

EXP(exponent) Returns the e number (~2.718) raised to a supplied power. 

FACTDOUBLE(value) Returns the double factorial of a number. 

INT(value) Rounds a number down to the nearest integer. 

LN(value) 
Returns the logarithm of a number to base e (~2.718) which is 

known as the natural logarithm. 

LOG(value, [base]) Returns the logarithm of a number with respect to a given base. 

LOG10(value) Returns the base-10 logarithm of a given number. 

PI() Returns the pi value rounded to 14 decimal places. 

POWER(base, exponent) Returns the result of raising a number to a power. 

PRODUCT(factor1, [factor2, ...]) Returns the product of supplied arguments. 

QUOTIENT(dividend, divisor) 
Divides a number by another one and returns a value without a 

reminder. 

RAND() 
Returns a random decimal number between 0 and 1, excluding 

the boundary values. 

ROUND(value, places) 
Rounds a number to a certain number of digits according to 

standard rounding rules. 

ROUNDDOWN(value, places) Rounds a number down to a certain number of decimal places. 

ROUNDUP(value, places) Rounds a number up to a certain number of digits. 
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Function Description 

SEC(angle) Returns the secant of an angle, in radians. 

SECH(angle) Returns the hyperbolic secant of an angle. 

SINH(value) Returns the hyperbolic sine of a number. 

SQRT(value) Returns the positive square root of a number. 

SQRTPI(value) 
Returns the square root of the pi constant (3.14159265358979) 

multiplied by a given number. 

SUBTOTAL(function_code, range1, 

[range2, ...]) 

Uses another function (SUMM, PRODUCT, etc.) to calculate 

the subtotal for a set of numbers. 

For more details, see Section  

SUBTOTAL function. 

SUBTOTAL(function_code, range1, 

[range2, ...]) 

Uses another function to calculate a subtotal for a vertical range 

of cells. 

SUM(value 1, [value 2; ...]) Returns the result of adding series of numbers, and/or cells. 

SUMIF(range, criterion, [sum_range]) Returns the sum of a range of values matching a certain criterion. 

SUMIFS(sum_range, criteria_range1, 

criterion1, [criteria_range2, criterion2, ...]) 

Returns the sum of a range of values matching multiple criteria. 

SUMPRODUCT(array1, [array2, ...]) 
Multiplies ranges or arrays together and returns the sum of 

products. 

SUMSQ(value1, [value2, ...]) Returns the sum of the squares of numbers. 

TANH(value) Returns the hyperbolic tangent of a number. 

Statistical 

AVERAGE(value1, [value2, ...]) Returns the average of numbers in a dataset, ignoring text. 

COUNT(value1, [value2, ...]) Returns the count of numeric values in a supplied dataset. 

COUNTA(value1, [value2, ...]) 
Looks through a given dataset and returns the number of cells 

containing any type of information. 

COUNTBLANK(range) 
Returns the count of empty and blank cells in a given range or 

array. 

COUNTIF(range, criterion) Returns the number of times cell values meet a certain criterion. 

COUNTIFS(criteria_range1, criterion1, 

[criteria_range2, criterion2, ...]) 

Returns the number of cells that meet multiple criteria. 

F.DIST(x, freedom_degrees1, 

freedom_degrees2, cumulative) 

Calculates the left-tailed F probability distribution (degree of 

diversity) for two data sets with a given x. 

F.DIST.RT(x, freedom_degrees1, 

freedom_degrees2) 

Calculates the right-tailed F probability distribution (degree of 

diversity) for two data sets with a given x. 

FISHER(value) Returns the Fisher transformation for a given value. 

LARGE(data, n) 

Arranges a given numeric dataset in descending order and returns 

a value depending on its relative position where the largest value 

takes the first position. 

LINEST(known_data_y, [known_data_x], 

[calculate_b], [stats]) 

Calculates parameters of the linear trend based on the least-

squares method. 

MAX(value1, [value2, ...]) Retrieves the maximum number from a numeric dataset. 
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Function Description 

MIN(value1, [value2, ...]) Retrieves the minimum number from a numeric dataset. 

NORM.DIST(x, mean, standard_deviation, 

cumulative) 

Returns the normal distribution function for the specified values 

of the arithmetic mean and the standard deviation. 

RANK.EQ(value, data, [is_ascending]) 

Arranges numeric values in ascending or descending order and 

determines the rank position of a specified value in a dataset. For 

duplicate values, a rank of the first value is assigned. 

SMALL(data, n) 

Arranges a given numeric dataset in ascending order and returns a 

value based on its relative position where the smallest value takes 

the first position. 

STDEV.S(value1, [value2, ...]) Calculates the standard deviation based on a sample. 

VAR(value1, [value2, ...]) Calculates the variance based on a given sample. 

VARA(value1, [value2, ...]) 
Calculates the variance based on a sample, treating text values as 

0 (zero). 

VARPA(value1, [value2, ...]) 
Analyzes data in a range and returns the variance of that data 

range. Text and logical values are considered. 

Lookup and reference 

ADDRESS(row, column, 

[absolute_relative_mode], 

[use_a1_notation], [sheet]) 

Returns the cell location in a spreadsheet based on specified row 

and column numbers. 

AREAS(reference) 
Returns the number of areas in a reference or a range. An area is 

considered as a separate cell reference or a range of cells. 

CHOOSE(index, choice1, [choice2, ...]) Retrieves the value from a dataset based on its position number. 

COLUMN([cell_reference]) Returns the column number of a specified cell. 

COLUMNS(range) Returns the count of columns in a range or an array. 

HLOOKUP(search_key, range, index, 

[match_type]) 

Evaluates the first row of a range for a search value and returns a 

value which is located in a different row but in the same column. 

HYPERLINK(url, [link_label]) Creates a link in a cell of a spreadsheet. 

INDEX(reference, [row], [column]) 
Returns the element of an array or range, specified by its row and 

column position. 

INDIRECT(cell_reference_as_string, 

[is_A1_notation]) 

Returns the content of the reference which can be a cell or a 

string. 

LOOKUP(search_key, search_range, 

[result_range]) (1) 

 

LOOKUP(search_key, search_result_array) 

(2) 

Looks through a row or a column for a key and returns the cell 

value in a result range located in the same position as a search 

row or column. 

 

Looks through multiple rows or columns for a key and returns a 

value of the cell located in the correspondent position of the same 

search rows or columns. To search for a key across a single row 

or column, specify the result_range value as the third argument. 

MATCH(search_key, range, [search_type]) 

Allows finding a specified item in the defined range of cells by a 

desired search type. The function returns the item index (that is a 

position number of the item in an array), not the item itself. 
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Function Description 

OFFSET(cell_reference, offset_rows, 

offset_columns, [height], [width]) 

Returns a cell or a range of cells shifted by a specified number of 

rows and columns from the initial cell reference. 

ROW([cell_reference]) Returns the number of the row where a cell is specified. 

ROWS(range) Returns the count of rows in a range or an array. 

VLOOKUP(search_key, range, index, 

[match_type]) 

Searches down the first column of a range for the first matching 

key and returns the corresponding value from another column. 

Database 

DSUM(database, field, criteria) 
Calculates the sum of database values matching the specified 

criteria. 

Text 

ASC (string) 

Converts a text encoded in a double byte character set (DBCS) to 

a text in a single byte character set (SBCS). In the spreadsheet 

editor, the function is only used for the backward compatibility 

with documents containing text encoded in DBCS. 

CLEAN(text) Removes non-printable characters from a given string. 

CODE(string) 
Returns the Unicode numeric value of the first character in a 

given string. 

CONCATENATE(string1, [string2, ...]) Joins separate entries into a single string. 

DBCS(string) 

Converts a text from ASCII to DBCS and backwards. In 

the spreadsheet editor, the function is only used for the backward 

compatibility with documents containing text encoded in either 

ASCII or DBCS. 

EXACT(string1, string2) 
Checks whether two strings are identical and, if so, returns 

TRUE. 

FIND(search_for, text_to_search, 

[starting_at]) 

Returns the position at which a string is first found within text 

(case sensitive). 

FINDB(search_for, text_to_search, 

[starting_at]) 

Returns the position at which a string is first found within text 

counting double letters as two characters. 

JIS(string) 

Converts a text from ASCII to DBCS and backwards. In 

the spreadsheet editor, the function is only used for the backward 

compatibility with documents containing text encoded in either 

ASCII or DBCS. 

LEFT(string, [number_of_characters]) Returns a substring from the beginning of a specified string. 

LEFTB(string, [number_of_characters]) 
Returns a substring from the beginning of a specified string based 

on the supplied number of characters. 

LEN(text) Returns the length of the specified string. 

LENB(text) Returns the count of characters in the supplied string. 

LOWER(text) 
Finds uppercase letters in a given string to convert them to 

lowercase. 

MID(string, starting_at, extract_length) Returns a segment of a string. 

MIDB(string, starting_at, extract_length) 
Returns a segment of a string based on the specified number of 

bites. 
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Function Description 

PROPER(text_to_capitalize) Capitalizes the first letter of every word in a specified string. 

RIGHT(string, [number_of_characters]) Returns the rightmost character or characters of a given string. 

RIGHTB(string, [number_of_characters]) 
Returns the rightmost character or characters of a given string 

based on the specified number of bites. 

SEARCH(search_for, text_to_search, 

[starting_at]) 

Returns the starting position of a string within a text. 

SEARCHB(search_for, text_to_search, 

[starting_at]) 

Returns the position at which a string is first found within text 

counting double letters as two characters. 

SUBSTITUTE(text_to_search, search_for, 

replace_with, [occurrence_number]) 

Replaces a specific string with another one in a text. 

TEXT(value, format) 
Converts a numeric value into a text value according to a 

specified format. 

TRIM(text) 
Removes all spaces in the specified string, except the single 

spaces between words. 

UNICODE(string) 
Returns the Unicode numeric value of the first character in 

a given string. 

UPPER(text) Converts all lowercase letters in a specified string to uppercase. 

Logic 

AND(logical_expression1, 

[logical_expression2, ...]) 

Returns TRUE if all the supplied tests are successful, and FALSE 

if at least one fails. 

FALSE() Returns the FALSE logical value. 

IF(logical_expression, value_if_true, 

[value_if_false]) 

Returns one value if the result of a logical test is TRUE and 

another if it is FALSE. 

IFERROR(value, value_if_error) 
Returns the first argument if it is not an error value, and 

the second argument if a given value is an error. 

IFNA(value, value_if_na) 
Returns the first argument if it is not #N/A, otherwise, returns 

the second argument. 

OR(logical_expression1, 

[logical_expression2, ...]) 

Returns TRUE if any of the specified logical tests is successful, 

and FALSE if all logical tests fail. 

SWITCH(expression, value1, result1, 

[value2, result2, ...], [default]) 

 

Evaluates a list of expressions and returns the value 

corresponding to the first expression in the list. 

TRUE() Returns the TRUE logical value. 

Information 

CELL(info_type, [reference]) Returns the requested data about a particular cell. 

INFO(info_type) 
Returns the requested information relating to the user’s operating 

system and the data processing environment. 

ISBLANK(value) 
Checks whether a referenced cell is empty, and if so, returns 

the TRUE logical value. 

ISERR(value) Returns TRUE if a given value is an error other than #N/A. 

ISERROR(value) Returns TRUE if a given value is an error. 
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Function Description 

ISEVEN(value) 
Checks whether a value is an even number and, if so, returns 

TRUE. 

ISLOGICAL(value) 
Checks whether a value is either FALSE or TRUE and returns 

TRUE on any of them. 

ISNA(value) 
Checks whether a value is the #N/A error and, if so, returns 

TRUE. 

ISNUMBER(value) Checks whether a given value is a number. 

ISODD(value) 
Checks whether a value is an odd number and, if so, returns 

TRUE. 

ISREF(value) Returns TRUE if a supplied value is a valid cell reference. 

ISTEXT(value) Checks whether a given value is textual. 

NA() Returns the #N/A error which stands for "value is not available". 

Engineering 

COMPLEX(real_number, 

imaginary_number, [suffix]) 

Creates a complex number based on specified real and imaginary 

components. 

IMABS(complex_number) 

 

Returns the absolute value of a complex number. 
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SUBTOTAL function 

Syntax 

SUBTOTAL(function_code, range1, [range2, ...]) 

Description 

Uses another function (SUMM, PRODUCT, etc.) to calculate the subtotal for a set of 

numbers. 

Function_code: The numeric code of the function to be used to calculate the subtotal  

(see Table 20). Use codes 1-11 to include manually hidden cells in the count, or 101-111 to exclude 

them. Cells hidden using a filter are always excluded. 

Table 20. Numeric codes 

Function_code 

(Include hidden values) 

Function_code 

(Exclude hidden values) 
Function 

1 101 AVERAGE 

2 102 COUNT 

3 103 COUNTA 

4 104 MAX 

5 105 MIN 

6 106 PRODUCT 

7 107 STDEV 

8 108 STDEVP 

9 109 SUM 

10 110 VAR 

11 111 VARP 

 

range1: The first range or array over which to calculate a subtotal. 

[range2; …]: Additional ranges or arrays over which to calculate subtotals. This parameter 

is optional. 
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Example: 

=SUBTOTAL(9, B2:B5): Calculate the sum of values in cells B2:B5, considering 

the values in the cells hidden manually. 

=SUBTOTAL(109, B2:B5): Calculate the sum of values in cells B2:B5, without 

considering the values in the cells hidden manually. 

 

Figure 451. Function use examples 

 

Figure 452. Function use examples 
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APPENDIX 2. LIST OF SUPPORTED CURRENCIES 

Currency name Currency code 

Azerbaijani manat AZN 

Armenian dram AMD 

Belarusian ruble BYN 

Bulgarian lev BGN 

Brazilian real BRL 

Won KRW 

Hryvnia UAH 

Danish krone DKK 

US dollar USD 

Euro EUR 

Zloty PLN 

Yen JPY 

Indian rupee INR 

Moldovan leu MDL 

Turkmenistan new manat TMT 

Norwegian krone NOK 

Russian ruble RUB 

Romanian leu RON 

Rand ZAR 

Som KGS 

Somoni TJS 

Tenge KZT 

Turkish lira TRY 

Uzbekistani som UZS 

Forint HUF 

Pound sterling GBP 

Czech koruna CZK 

Swedish krona SEK 

Swiss franc CHF 

Yuan Renminbi CNY 
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APPENDIX 3. KEYBOARD SHORTCUTS 

This appendix contains the keyboard shortcuts used in Windows OS, Linux OS  

(see Table 21) and macOS (see Table 22). 

 

On laptops, some keys are multifunctional. For example: F1–F12, Home, End, PgUp, 

PgDn. When pressing these keys in MyOffice Spreadsheet, you need to hold Fn down at 

the same time. 

Table 21. OS Windows and OS Linux shortcuts 

Keyboard shortcuts Command or action 

Edit the content 

Ctrl+X 

Shift+Delete 
Cut 

Ctrl+C 

Ctrl+Insert 
Copy 

Ctrl+V 

Shift+Insert 
Insert 

Ctrl+Alt+V Insert values and format 

Ctrl+S Save 

F12 (Microsoft Windows) 

Ctrl+Shift+S (Linux) 
Save as 

Ctrl+Z Cancel the last action 

Ctrl+Y Repeat the result of the canceled action 

Ctrl+Alt+Shift+Z Open the clipboard history 

Backspace Delete one character to the left of the cursor 

Delete Delete one character to the right of the cursor 

Ctrl+Backspace 
Delete part of a word or the entire word to the left of the 

cursor 

Ctrl+Delete 
Delete part of a word or the entire word to the right of the 

cursor 

Alt+Enter Begin a new paragraph 

Ctrl+Shift+Space Insert a non-breaking space 

Ctrl+Shift+ – Insert a non-breaking hyphen 

Ctrl+Num – Insert an en dash 

Ctrl+Alt+Num – Insert an em dash 
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Keyboard shortcuts Command or action 

F9 
Replace a part of a formula/formula itself with the calculated 

value 

Ctrl+Shift+F9 Recalculate formulas 

Content formatting 

Ctrl+B Bold 

Ctrl+I Italic 

Ctrl+U Underline 

Ctrl+Shift+= Superscript 

Ctrl+= Subscript 

Ctrl+Shift+A All caps 

Ctrl+Shift+C Copy formatting 

Ctrl+Shift+V Apply formatting 

Ctrl+L Align text to the left 

Ctrl+E Center the text 

Ctrl+R Align text to the right 

Ctrl+J Justify the text 

Move throughout the workspace  

Page Up One screen up 

Page Down One screen down 

Ctrl+Home Go to the first workspace cell (A1 cell) 

Ctrl+End Go to the last workspace cell 

Actions with cells, rows, and columns 

F2 Switch to cell editing mode 

Alt+A Select a row upwards 

Alt+B Select a row downwards 

Alt+L Insert a column to the left 

Alt+R Insert a column to the right 

Ctrl+Alt+M Merge cells 

Alt+Shift+M Split cells 

Ctrl+– Delete a row or a column 

Select cells, rows, and columns 

Arrow Up Select the cell upwards 

Arrow Down Select the cell downwards 

Tab or Right Arrow Select the next cell 

Left Arrow Select the previous cell 

Home Select the cell at the beginning of the row 
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Keyboard shortcuts Command or action 

End Select the cell at the end of the row 

Shift+Space Select a row 

Ctrl+Space Select a column 

Ctrl+Shift+Home 
Create a selection area from the selected cell to the first cell 

of the workspace (cell A1) 

Ctrl+Shift+ End 
Create a selection area from the selected cell to the last cell of 

the workspace 

Ctrl+A 
Select all cells in the sheet workspace 

 

Shift+Arrow Up Expand the selection by one cell upwards 

Shift+Arrow Down Expand the selection by one cell downwards 

Select text in the edited cell* 

Shift+Left Arrow Select one character to the left of the cursor 

Shift+Right Arrow Select one character to the right of the cursor 

Ctrl+ Shift+Left Arrow Select one word to the left of the cursor 

Ctrl+ Shift+Right Arrow Select one word to the right of the cursor 

Shift+Home Select the content from the cursor to the beginning of the line 

Shift+End Select the content from the cursor to the end of the line 

Ctrl+ Shift+Arrow Up Extend the selection to the beginning of the paragraph 

Ctrl+ Shift+Arrow Down Extend the selection to the end of the paragraph 

Shift+Arrow Up Expand the selection by one row/cell upwards 

Shift+Arrow Down Expand the selection by one row/cell downwards 

Double-click the left mouse button Select a word 

Triple-click the left mouse button Select a paragraph 

Click the left mouse button and move 

the cursor upwards 
Select the text upwards 

Click the left mouse button and move 

the cursor downwards 
Select the text downwards 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select 

the cell by double-clicking or pressing F2. 

Move within the text in the edited cell* 

Left Arrow Move one character to the left 

Right Arrow Move one character to the right 

Ctrl+Left Arrow Move one word to the left 

Ctrl+Right Arrow Move one word to the right 

Arrow Up Move one line up 

Arrow Down Move one line down 

Ctrl+Arrow Up Go to the beginning of the previous paragraph 
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Keyboard shortcuts Command or action 

Ctrl+Arrow Down Go to the beginning of the next paragraph 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select 

the cell by double-clicking or pressing F2. 

Other keyboard shortcuts 

Ctrl+N Create a file 

Ctrl+O Open a file 

Ctrl+Shift+O Open a file in the Cloud 

Ctrl+P 
Open the window for previewing and setting page and 

printing parameters of the document 

Ctrl+0 (zero) Set the actual page scale (100%) 

Ctrl+Shift+F5 Update references to data in external documents 

Ctrl+K Insert a link 

Ctrl+F 

Ctrl+H 
Open the search pane 

Shift+F3 Open the Inset function pane 

Ctrl+/ Open the Quick action box 

F1 Open the Help 

Click the right mouse button Open the context menu of the selected element 

Alt+Space Open the context menu of the active application window 

Alt+F4 Close the active application window 
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Table 22. Keyboard shortcuts in macOS 

Keyboard shortcuts Command or action 

Edit the content 

⌘ Cmd + X Cut 

⌘ Cmd + C Copy 

⌘ Cmd + V Insert 

⌥ Option + ⌘ Cmd + V Insert values and format 

⌘ Cmd + S Save 

⇧ Shift + ⌘ Cmd + S Save as 

⌘ Cmd + Z Cancel the last action 

⌘ Cmd + Y Repeat the result of the canceled action 

⌥ Option + ⇧ Shift + ⌘ Cmd + Z Open the clipboard history 

Delete Delete one character to the left of the cursor 

Fn + Delete Delete one character to the right of the cursor 

⌘ Cmd + Delete 

⌥ Option + Delete 

Delete part of a word or the entire word to the left of the 

cursor 

⌘ Cmd + Fn + Delete 

⌥ Option + Fn + Delete 

Delete part of a word or the entire word to the right of the 

cursor 

⌥ Option + ⌅ Enter Begin a new paragraph 

⌥ Option + ⇧ Shift + Space Insert a non-breaking space 

⌘ Cmd + ⇧ Shift + – Insert a non-breaking hyphen 

⌥ Option + – Insert an en dash 

⌥ Option + ⇧ Shift + – Insert an em dash 

F9 
Replace a part of a formula/formula itself with 

the calculated value 

⇧ Shift+⌘ Cmd+F9 Recalculate formulas 

Content formatting 

⌘ Cmd + B Bold 

⌘ Cmd + I Italic 

⌘ Cmd + U Underline 

⇧ Shift + ⌘ Cmd + = Superscript 

⌘ Cmd + = Subscript 

⇧ Shift + ⌘ Cmd + A All caps 

⇧ Shift + ⌘ Cmd + C Copy formatting 

⇧ Shift + ⌘ Cmd + V Apply formatting 

⌘ Cmd + L Align text to the left 

⌘ Cmd + E Center the text 
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Keyboard shortcuts Command or action 

⌘ Cmd + R Align text to the right 

⌘ Cmd + J Justify the text 

Move within the workspace 

Fn + Arrow Up One screen up 

Fn + Arrow Down One screen down 

Fn + ⌘ Cmd + Left Arrow Go to the first workspace cell (A1 cell) 

Fn + ⌘ Cmd + Right Arrow Go to the last workspace cell 

Actions with cells, rows, and columns 

Fn + F2 Switch to cell editing mode 

⌥ Option + A Select a row upwards 

⌥ Option + B Select a row downwards 

⌥ Option + L Insert a column to the left 

⌥ Option + R Insert a column to the right 

⌥ Option + ⌘ Cmd + M Merge cells 

⌥ Option + ⇧ Shift + M Split cells 

⌘ Cmd + – Delete a row or a column 

Select cells, rows, and columns 

Arrow Up Select the cell upwards 

Arrow Down Select the cell downwards 

Tab or Right Arrow Select the next cell 

Left Arrow Select the previous cell 

Fn + Left Arrow Select the cell at the beginning of the row 

Fn + Right Arrow Select the cell at the end of the row 

⇧ Shift +Space Select a row 

⇧ Shift + ⌘ Cmd + Space Select a column 

⇧ Shift + Fn + ⌘ Cmd + Left Arrow 
Create a selection area from the selected cell to the first cell 

of the workspace (cell A1) 

⇧ Shift + Fn + ⌘ Cmd + Left Arrow 
Create a selection area from the selected cell to the last cell 

of the workspace 

⌘ Cmd + A Select all cells in the sheet workspace 

⇧ Shift + Arrow Up Expand the selection by one cell upwards 

⇧ Shift + Arrow Down Expand the selection by one cell downwards 

Select text in the edited cell* 

⇧ Shift + Left Arrow Select one character to the left of the cursor 

⇧ Shift + Right Arrow Select one character to the right of the cursor 

⇧ Shift + ⌘ Cmd + Left Arrow Select one word to the left of the cursor 
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Keyboard shortcuts Command or action 

⇧ Shift + ⌘ Cmd + Right Arrow Select one word to the right of the cursor 

Fn +⇧ Shift + Left Arrow 
Select the content from the cursor to the beginning of 

the line 

Fn +⇧ Shift + Right Arrow Select the content from the cursor to the end of the line 

⇧ Shift + ⌃ Ctrl + ⌘ Cmd + Arrow Up Extend the selection to the beginning of the paragraph 

⇧ Shift + ⌃ Ctrl + ⌘ Cmd + Arrow Down  Extend the selection to the end of the paragraph 

⇧ Shift + Arrow Up Expand the selection by one table row/cell upwards 

⇧ Shift + Arrow Down Expand the selection by one row/cell downwards 

Double-click the left mouse button Select a word 

Triple-click the left mouse button Select a paragraph 

Click the left mouse button and move 

the cursor upwards 
Select the text upwards 

Click the left mouse button and move 

the cursor downwards 
Select the text downwards 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select 

the cell by double-clicking or pressing F2. 

Move within the text in the edited cell* 

Left Arrow Move one character to the left 

Right Arrow Move one character to the right 

⌘ Cmd + Left Arrow Move one word to the left 

⌘ Cmd + Right Arrow Move one word to the right 

Arrow Up Move one line up 

Arrow Down Move one line down 

⌘ Cmd + Arrow Up Go to the beginning of the previous paragraph 

⌘ Cmd + Arrow Down Go to the beginning of the next paragraph 

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select 

the cell by double-clicking or pressing F2. 

Other keyboard shortcuts 

⌘ Cmd + N Create a file 

⌘ Cmd + O Open a file 

⇧ Shift + ⌘ Cmd + O Open a file in the Cloud 

⌘ Cmd + P 
Open the window for previewing and setting page and 

printing parameters of the document 

⌘ Cmd + 0 (zero) Set the actual page scale (100%) 

⇧ Shift + ⌘ Cmd + F5 Update references to data in external documents 

⌘ Cmd + K Insert a link 

⌘ Cmd + F Open the search pane 

⌘ Cmd + / Open the Quick action box 
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Keyboard shortcuts Command or action 

Fn + F1 Open the Help 

Click the right mouse button Open the context menu of the selected element 

⌘ Cmd + Q Close the active application window 

 


