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LIST OF ABBREVIATIONS

The abbreviations used in this User Guide are specified in Table 1.

Table 1. Abbreviations and definitions

Abbreviation Definition

0S Operating system

MyOffice Text MyOffice Text. Home Edition desktop application

MyOffice Spreadsheet MyOffice Spreadsheet. Home Edition desktop application

MyOffice Presentation MyOffice Presentation. Home Edition desktop application

MyOffice Standard. MyOffice Text, MyOffice Spreadsheet, MyOffice Presentation desktop
Home Edition software applications

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 11



MyOffice

1 ABOUT

1.1 General information

MyOffice Text is an editor for quick and easy creation and formatting of text documents of
any complexity on Windows and macOS operating systems.
For a detailed description of the application features, please refer to your product-specific

Feature list.
1.2 System requirements

For a list of software and hardware requirements, please refer to your product's

Installation Guide.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 12
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1.3 Limitations

1.3.1 Supported file formats

The list of formats supported by MyOffice Text is given in Table 2 and Table 3.

Table 2. Supported file formats in Windows

Action Supported formats
Open/import files .doc, .docx, .rtf, .odt, .xodt, .txt, .docm, .mht, .mhtml, .html, .htm, .xhtml,
Xott
Save file .docx, .odt, .xodt
Export files .pdf, .pdf/a-1, .rtf, .txt, .xott
Table 3. Supported file formats in macOS
Action Supported formats
Open/import files .docx, .odt, .xodt, .txt, .docm, .xott
Save file .docx, .odt, .xodt
Export files .pdf, .pdf/a-1, .xott

1.3.2 Supported interface languages

— English
— French

— Russian

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 13
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2 BEFORE YOU BEGIN

2.1 Installation

For detailed description of installation of MyOffice Standard. Home Edition software, please

refer to MyOffice Standard. Home Edition. Installation Guide.
2.2 Open the application
2.2.1 Open the application in Windows OS

To open MyOffice Text application installed from the Microsoft Store, click its shortcut in

the OS main menu (see Figure 1).

a MyOffice Text Home Edition

o
Ii MyOffice Spreadsheet Home Edition

] MyOffice Presentation Home Edition

L [type here to search ﬂ

Figure 1. MyOffice icon in the main menu of Windows OS

To open MyOffice Text application installed from https://myoffice.ru/products/ofis-dlya-

doma/, click its shortcut on the desktop (see Figure 2) or in the OS main menu (see Figure 3).

| ~— ——

| “—

Ry 2
wyOiifles  WiyOiifies

(= OWSOTEa Tt e

ﬂ L Type here to search

Figure 2. MyOffice icon on Windows OS desktop
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B MyOffice Standard. Home Edition

| MyOffice Presentation. Home Edition

@
l.i MyOffice Spreadsheet. Home Edition

E MyOffice Text. Home Edition

|-‘§-1- Uninstall MyOffice Standard. Home...

Figure 3. MyOffice icon in the main menu of Windows OS

L Type here to search

2.2.2 Open the application in macOS

To open MyOffice Text in macOS, click the MyOffice Standard. Home Edition icon in
Launchpad (see Figure 4).

PBO="OR0

Figure 4. MyOffice Standard. Home Edition icon in Launchpad

The start page will open (see Figure 5) where you can perform the following actions:

— Open MyOffice Text application. Once launched, the application automatically creates a
text file (see Section 4.1.1).

— Open MyOffice Spreadsheet application. Once launched, the application automatically
creates a spreadsheet file.

— Open MyOffice Presentation application. Once launched, the application automatically

creates a presentation file.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 15
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® ® Welcome to MyOffice Standard. Home Edition

—
o+

MyOffice Standard. Home Edition

===  MyOffice Text. Home Edition

MyOffice Spreadsheet. Home Edition

il
! Il MyOffice Presentation. Home Edition

Figure 5. Starting page

The first time you start MyOffice Text, MyOffice Spreadsheet and MyOffice Presentation,

the applications shortcuts are automatically added to the Dock.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.
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2.3 License agreement

The first time you launch MyOffice Standard. Home Edition, do the following:

1. Make sure that in the Terms of Use and Privacy Policy window (see Figure 6), in the Region
drop-down list, your region of residence is correctly selected. If necessary, select it manually
from the drop-down list.

2. Please carefully read the terms and conditions of the License Agreement and Privacy
Policy.

3. If you agree to the terms and conditions specified, please select the I accept the Terms of
Use and Privacy Policy checkbox.

4. Ifyou agree with clauses 5-7 of the Privacy Policy, select the Allow to collect anonymous
statistics on app usage to improve product quality checkbox. This checkbox is not
displayed if Other is selected in the Region drop-down list.

5. Click Get started.

= Terms of Use and Privacy Policy x

F— ~ Welcome to MyOffice!

Specify your region of residence so the Terms of Use meet the requirements
of your country.

Region

B Russia v

MyOffice Standard. Home Edition
End User License Agreement

This license agreement (the "License Agreement")
sets forth the terms and conditions of use of the
home edition of MyOffice Standard computer
software (the "Software") and is concluded between
You and New Cloud Technologies Ltd., which is the
Rightholder of the Software.

Allow to collect anonymous statistics on app usage to improve
product quality.

| accept the Terms of Use and Privacy Policy.

Get started Cancel

Figure 6. Terms of Use and Privacy Policy window

You can disable the collection of anonymous statistics in further work with the application if

necessary. To do this, follow these steps:

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 17
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1. In the Help menu, click About (see Figure 7).

Help F1
Quick Actions Ctrl+f
Check for Updates...
About...

Figure 7. About command menu option

2. In the About window (see Figure 8), clear the Send anonymous statistics on app usage

to improve product quality checkbox.
3. Click Close.

About

MyOffice® Text

Build 165 for Windows

|

My Office Standard. Home Edition
Version 3.1H

Terms of Use
Privacy Paolicy

Legal Notices

Data collection:

Send anonymous statistics on app usage
to improve product quality.

0 New Cloud Technologies Ltd,, 2013-2024

Close

Figure 8. About window

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.
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2.4 Product activation

If you have accepted the License Agreement (see the section above), the product activation
window opens the first time you launch MyOffice Standard. Home Edition software (see Figure 10).
You can use this window to subscribe to use the product and enter the activation code.

Without activation, some functions in applications are not available and are labeled with

markers ® (see Figure 9) or icons £3.

File Edit Insert Format Tools View Share Subsq
+ v X, 0O 6B v &
Add @ v (r_‘: {._'\’ Q

Favorites File Edit

Figure 9. Function is not available

If you have an activation code, in the product activation window (see Figure 10), click

I Have an Activation Code.

r . .
| More features with MyOffice for home X
P ‘l - - -
.\ |-F subscription
Unlock all the features of MyOffice apps for working with texts,
spreadsheets, and presentations on your computer and smartphone.
lZ] Changes and comments L Enhanced slide show
Markup changes, leave comments, filter your Capture your audience's attention with eye- catching
collaborator's comments pointers and the ability to highlight objects on the
screen
[ﬁ Spreadsheet protection ch Formula calculation modes
Protect sheets, and the structure of your Choose between automatic and manual calculation
spreadsheet
L) CSV format support ED Document comparison
Work with spreadsheets in the convenient format Helps quickly identify what has changed in the new
with the option to select delimiters version of the file

Learn more about the subscription

Try for Free

| Have an Activation Code

Figure 10. Product activation window
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If this window has been closed, in the Subscription menu, click Activate Code

(see Figure 11).

Subscription Help

Try for Free
Activate Code

Figure 11. Subscription menu

In the Code Activation window (see Figure 12), enter the activation code and click Activate.

Code Activation X

Enter activation code

© Activating a new code will cancel any remaining days of your
current subscription or trial period.

Where can | find the code? A%

Figure 12. Code Activation window

If you don't have an activation code, you can subscribe with a free 21-day period. To do this,
in the product activation window (see Figure 10), click Try for Free. If this window has been closed,
in the Subscription menu, click Try for Free (see Figure 11).

Please follow the instructions on the website to subscribe. After subscribing, an email with
an activation code will be sent to the email address you specified.

To activate the product, in the Subscription menu, click Activate Code (see Figure 11).

In the Code Activation window (see Figure 12), enter the activation code and click Activate.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 20
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2.5 Application update

To ensure timely update of MyOffice Standard. Home Edition software installed from

https://myoffice.ru/products/ofis-dlya-doma/, it is recommended to enable automatic checking for

new versions.
To automatically check for new versions, do the following:
1. After the first launch of the MyOffice Text, MyOffice Spreadsheet and
MyOffice Presentation applications, close them and reopen either of these applications.

2. In the Application Update window (see Figure 13), click Check automatically.

| Check for updates automatically?

I
[__ LD Should we check for updates automatically? You can always
check for updates manually from the menu.

|Check automaticallyl Don't check

Figure 13. Application Update window
If you want to disable the automatic search for new versions, click the Don't check button.

You can also check for new versions manually. To do this, select Help > Check for Updates

in the Command menu (see Figure 14).

Help F1
Quick Actions Ctrl+/
Check for Updates...
About...

Figure 14. Check for Updates command menu option

The steps to update the application are described in detail in MyOffice Standard.

Home Edition. Installation Guide document.
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3 INTERFACE OVERVIEW

3.1 MyOffice Text window

MyOffice Text window has the following elements (see Figure 15):
Command menu

Toolbar

Workspace

Sidebar

Status bar

AN A

Command menu Toolbar
| ]

= New Document|1 - MyOffice Standard. Home Edition - a X

File Edit Inset Format Tools Wiew Share Subscription Help

=] v w | w X 1 P v X0 Thames ~ M w AT A+ = +
B @ e - - l:l AaBbCcL O
S S~ — & B T U AB - i- v £ o . Morrma
Favorites File Edit Font Paragraph Styles Insert ~
2 1 o 14 16 - 18 ~
Q
' Sidebar ————®
Workspace
b
Page 1 of 1 ’ - - + 00% v
|
Status bar

Figure 15. Main window of MyOffice Text
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3.2 Command menu

The Command menu (see Figure 16) contains the main commands for working with

the application.

= New Document 1 - MyOffice Standard. Home Edition

File Edit Insert Format Tools View Share Subscription

Figure 16. Command menu

To quickly run these commands, you can use:
— Keyboard shortcuts (see Table 13 and Table 14) which are specified next to the commands
in the Command menu.

— Quick Actions box (see Section 3.7).
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3.3 Toolbar

The Toolbar (see Figure 17) contains tools for working with the document content.

<
i

a5

AaBbCc | AaBbC: AaBbCc AaBbCcL ...
4| nNermal Heading 1 Heading 2 Heading 3

it
Jitl
m

Paragraph s

E- 8o 2 -

tyles

Figure 17. Toolbar

MyOffice Text allows you to change the way the Toolbar looks:
— Select the Toolbar display mode or hide the Toolbar.
— Hide or display the Toolbar section titles.

— Customize the Favorites section.

— Hide and display the Favorites section.

3.3.1 Change the Toolbar display mode

To change the Toolbar display mode:

1. Inthe Command menu, select View > Toolbar (see Figure 18).

View Share Subscription Help

~  Ruler Ctrl+Shift+R -
W 14 | A
MNon-Printable Characters
AR e A o
Presentation View -
Zoom » 9 )
Toolbar b & Regular
Compact
Hide Toolbar

v Section Titles

v Favorites

Figure 18. View menu

2. In the sub-menu that opens, select the desired display mode:

Regular: Tools are arranged in two lines; the section titles are displayed. If necessary,

the Toolbar section titles can be hidden (see Section 3.3.2).

Compact: Tools are arranged in one line; section titles are not displayed.

— Hide Toolbar: The Toolbar is not displayed.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 24
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To quickly switch between the Regular and the Compact mode, use the -~ Compact Toolbar

(see Figure 19) and ~ Regular Toolbar buttons located in the right part of the Toolbar.

AaBbCcl AaBbCcD .. [jv @ v E]

Heading 1 Heading 2

Insert

Figure 19. Compact Toolbar button

[

5 g @ =8 -

Figure 20. Regular Toolbar button

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.
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3.3.2 Hide or display section titles

The Toolbar of MyOffice Text (see Figure 17) consists of sections. Each section (except
Favorites section) contains a group of tools designed to perform a specific task. For example,
the Styles section contains tools for working with text styles.

The title of each section is displayed if the Toolbar display type is Regular
(see Section 3.3.1). To optimize the workspace, the section names on the Toolbar can be hidden.

To hide the Toolbar sections, follow these steps:

1. In the View menu, click Toolbar (see Figure 18).

2. In the sub-menu that opens, uncheck the Section Titles menu.

To display the section titles, check the menu again.

If the Toolbar is hidden or displayed in the compact form, the Section Titles menu is

disabled.
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3.3.3 Hide or display sections content

Toolbar sections can be collapsed automatically when reducing or increasing the size of
the main application window, or manually. To collapse a Toolbar section manually, hover the cursor

over its right border and click * Collapse (see Figure 21).

File Edit Insert Format Tools View

Share Subscription Help

+ v X 0O B~ & XO Thames vl 14 v AT AT
Add & v 9 C ©C ‘B I UMT - Av £~
Favorites File Edit Font

Figure 21. Collapse button

To display the tools in the hidden section, click it with the mouse (see Figure 22):

File Edit Insert Format Tools View

Share  Subscription Help

+ 2 ~ ‘x) XO Thames v (14 v AT AT
Add @ W aoe B I g AE] ? oos ﬁ W 5;) W

Favorites File Edit Font
\):f |-—_|_ ﬁ - % 2 1 : 1 2

Figure 22. Section tools

To expand the section, click * Expand (see Figure 23).

File Edit Insert Format Tools

View Share Subscription Help

+ ERY CX) XO Thames v 14 v AT At
Add @ W aee ' B I 9 AE} _'T— see ﬁ W 5:) W
Favorites File Edit Font

Figure 23. Expand button
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3.3.4 Customize the Favorites section

As a rule, when working with an application, certain Command menu items and Toolbar
buttons are used more often than others. These items can be added to the Favorites section of

the Toolbar so that they are always at hand.

3.3.4.1 Add an item

You can add from 1 to 14 items to Favorites.
To add a Command menu item to Favorites, follow these steps:
1. Run the add command in one of the following ways:

— If the Favorites section is empty, click < Add in it (see Figure 24).

File Edit Insert Format Tools View

+ ) v % I
Add |\ = o C
Favarites File Edit

Figure 24. Add Button

— If the Favorites section contains the added items, right-click anywhere in the section

and run the Add Action context menu command (see Figure 25).

File Edit Insert Format Tools View  Share

N v | X v &
pdN =@y D C “
Favaorites Favorites .
Add Action

Figure 25. Add Action command
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2. In the window that opens (see Figure 26), select the Command menu item that you want

to add to Favorites.

File Edit Insert Format Tools Wiew Share Subscription

_|_ v (><;. XO Thames ~
Ad
‘ firdactior... ‘

Favori
New

New from Template...

o

Open...

B9

Save

7

Export To...

il

Quick Print

(V8 )
HILH

Page Setup

4 & Print...

w

6 (__) Undo
, ( Redo

Figure 26. Window for adding Command menu items

To add a button from the Toolbar to Favorites, right-click on it and run the Add to Favorites

command (see Figure 27).

;¥+ i w T v
- AaBbCc
qf Y| Mormal

Add to Favorites |I

|
|
il
]
Q{

& v EF:: w =

Paragraph

Figure 27. Add to Favorites command
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Currently, it is not possible to add Toolbar buttons that are displayed after clicking
the === button.

When added to Favorites, the button is not removed from the Toolbar section in which it is

located.

3.3.4.2 Move an item

To change the position of an item in the Favorites section, follow these steps:
1. Right-click the item to open the context menu (see Figure 28).
2. In the context menu, select the desired command:

— Move to Beginning: Make the selected item the first in the section.

— Move Left: Swap the selected and previous element.

— Move Right: Swap the selected and subsequent element.

— Move to End: Make the selected item the last in the section.

File Edit Insert Format Tools View  Share

C O R A X P Q

Q [ Action
= v

Favorites Move to Beginning
Move Left
Move Right
Move to End

Remove from Favorites

Favorites
2 Add Action

Clear

Figure 28. Commands for moving an element
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3.3.4.3 Delete an item

To delete a Command menu item from the Favorites section, right-click it and run
the Remove from Favorites command (see Figure 28).

To remove a Toolbar button from the Faverites section, follow these steps:
1.

Right-click it in the Favorites section or in the section from which it was added
(see Figure 29).

2. Run the Remove from Favorites context menu command.

AT AT = v

1 1.— [— 1
- .- T - P

Remove from Favorites

TR T O Ty

i
i
|

Figure 29. Delete from Favorites command

3.3.4.4 Clear the section

To remove all items from the Favorites section, right-click anywhere in the section and run
the Clear context menu command (see Figure 28).
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3.3.5 Hide or display the Favorites section

By default, the Toolbar displays the Faveorites section.
To hide the section, do one of the following:
— In the Command menu, select View > Toolbar and in the sub-menu that opens uncheck

Favorites (see Figure 30).

View Share Subscription Help
~  Ruler Ctrl+Shift+R

w 14 | w A_

MNon-Printable Characters
AR - A o

Presentation View -
Zoom » 9 10
Toolbar » & Regular

Compact

Hide Toolbar

~  Section Titles

+ Favorites

Figure 30. View menu

— If the Favorites section is empty, hover your mouse over the <+ Add button and click in

its upper-right corner (see Figure 31).

File Edit Insert Format Tools View

x =

o v & I

Add = D
Favorites File Edit

Figure 31. Favorites section

To display the section, re-select the Favorites check box in the Command menu.

If the Toolbar is hidden, the Favorites check box is disabled.
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3.4 Workspace

The Workspace displays the current sheet of the document (see Figure 32).

= New Document 1 - MyOffice Standard. Home Edition O x
File Edit Insert Format Tools View Help
B By B~ X BOon XO Thames v v AT AT . a
E AaBbCcl .
Ly By 90 BT UA « Av &v . | Nom
Favorites File Edit Font Paragraph Styles Insert ~
L} >
2 1 = 1 6 7 8 9 10 1 12 13 14 15 16 IT‘, 18 ~
1
1
3
4
5
6
v
Page 1 of 1 - * 100% v

Figure 32. Workspace
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3.5 Sidebar

The Sidebar displays the following buttons (see Figure 33):

AaBbCcl @ ...

Mormal

Styles Insert -~

- =
- 8 ~

Q

" ® + 100% v

Figure 33. Sidebar

~ . Find and Replace: Open the Find and Replace pane (see Section 4.2.8)
- @ Macros: Open the Macros pane (see Section 4.13). This button is displayed if a

document contains at least one macro.

- [% Recovered Files: Open the document backups pane (see Section 4.1.11). The button

is displayed if there is at least one unsaved copy.

— @ Header or @ Footer: Open the header and footer settings (see Section 4.10.2).

The button is displayed when a header or a footer is selected.

()
— = Feedback: Send feedback on the application.
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3.6 Status bar

The Status bar displays the following elements (see Figure 34):
— The current page number and the total number of pages in the document.

— Tools to zoom in or out the document (see Section 4.11.2).

Page 1 of 1 - ® +

Figure 34. Status bar
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3.7 Quick Actions box

MyOffice Text displays the Quick Actions box (see Figure 35). This box allows for fast
execution of commands and application of text formatting styles.

To open the box, do one of the following:

— Select Quick Actions in the Help menu.

—  Press the Ctrl+/ keyboard shortcut (Windows OS) or $sCmd+/ (macOS).

The Quick Actions box contains:
— The list of commands available in the Command menu (see Section 3.2).

— The list of standard and customized text formatting styles (see Section 4.3.2).

MNew

New from Template...
Open...

Save

Save As...

Autorecovery Settings

Export To...
Quick Print
Page Setup

Print...

Figure 35. Quick Actions box
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Use one of the following methods to select a command/style from the list:

— Scroll the list to the desired command/style using the mouse scroll wheel or the right
vertical scroll bar. Confirm the command/style by clicking it or pressing Enter.

— Start typing the command/style name in the search bar. When the desired command/style
appears in the search results, select it using the mouse or keyboard keys:
— Click the command/style line with the left mouse button.

— Select the command/style line with the | and 1 keyboard keys and press Enter.

Once the selection is made, the action is done, or the style is applied, and the box closes
automatically. To close the box without selecting an action or style, click anywhere outside this

window or press Esc.
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3.8 Application language

The default language of the MyOffice Text application is determined by the language of your

operating system. You can change it manually if necessary.

When you change the language of MyOffice Text, the corresponding language is
automatically selected for MyOffice Spreadsheet and MyOffice Presentation.

To change the application language, follow these steps:

1. Inthe Command menu, select Tools > Change Language (see Figure 36).

Tools WView Share Subscription Help

Dizsplay Changes and Comments » I
Spelling and Grammar L
Custom Dictionary

Change Language...

Macro Editor ‘

Compare with... (beta)

Figure 36. Change Language command menu option

2. In the window shown in Figure 37, select the desired application language from

the drop-down list and click OK.

Language Change x

Choose language:

System Default (English) w

OK Cancel

Figure 37. Language Change window

3. In the dialog box shown in Figure 38, click OK.
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Language Change et

o The change will take effect after
restarting the app

Figure 38. Notification that the application must be restarted

4. Restart the application. To do this, close all the documents currently open in

MyOffice Text open them again.
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4 WORK WITH MYOFFICE TEXT

4.1 Actions with files

4.1.1 Create a new file

4.1.1.1 Create a file using File Explorer

To quickly create a file in Windows Explorer, follow the steps below:

1.

Right-click an  empty area to open  thecontext  menu, select
New > & MyOffice Document.
Specify a name for the file. By default, the file is named New MyOffice Document.

To save the name, click outside the name or press Enter.

4.1.1.2 Create a file when opening the application

A new file is created automatically when you open MyOffice Text.

4.1.1.3 Create a file while working in the application

To create a new file while working in the application, do one of the following:

1.

In the File menu, select New (see Figure 39).

2. Press Ctrl+N / $8Cmd+N.

File Edit Insert Format Tools View

[ MNew Ctrl+M

Mew from Template...

[ Open.. Ctrl+0

Figure 39. File menu
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4.1.2 Create a template from a file

A template file fully duplicates the original file and is used as a reference for creating other
files. Templates are convenient to use if you need to create several documents which share the same
content or formatting settings.

To create a template, follow the steps below:

1. Open the file that you want to use as a template (see Section 4.1.4).

2. In the File menu, click Save as Template (see Figure 40).

3. In the file manager window that appears, select the template name and location.

Click Save.

File Edit Insert Format Tools View

[ New Ctrl+N

Mew from Template...

[ Open.. Ctrl+O

Recent Files L4

) Save Ctrl+S
Save As... F12

Autorecovery »

Export To...
Save as Template...

Figure 40. File menu

4.1.3 Create a file from a template

To create a file from a template, follow one of the steps below:
— Double-click the template you want to use in the file manager.
— In the File menu, click New from Template (see Figure 40). In the file manager, select

the template you want to use for your file and click Open.

This will create a new document that can be edited.
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4.1.4 Open a file

To open a file, do one of the following:

— Double-click the file using the left mouse button.

— When working on macOS, open the Home page (see Section 2.2.2) and follow the steps
below:
1. Click Open File.
2. Inthe File manager window that appears, select the desired file and click Open.

— Open MyOffice Text. Proceed as follows:
1. Inthe File menu, click Open (see Figure 40) or press Ctrl+0O / Cmd+0O.
2. In the file manager, select the file you want to open and click Open.

— Open MyOffice Text and drag the document or its shortcut from the operating system file
manager window to the open application window. You can open up to 32 files at a time

by dragging and dropping them into the application window.

4.1.4.1 File in .doc format

Files in .doc format are not supported on macOS.

When you open a file in .doc format, it is automatically converted to .docx format.
An information bar will be displayed below the Toolbar with an appropriate notification: “Document

was automatically converted to a newer format”. Click OK in this line (see Figure 41).

File Edit Insert Format Tocls View Share Subscription Help

C O Q- v X O @~ & Calibri vl 1 v AT AT Tr
= 8. 9 € B I U~ Av &~
Favorites File Edit Font Paragraph Styles Insert -~
(D) Document was automatically converted to a newer format
~
Q

Figure 41. Close button

To save a file in .docx format, follow the steps described in Section 4.1.7.
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4.1.4.2 Read-only file

If the Read only property is set for a file by the OS tools, then:
— This file is opened in the View mode.
— A notification “You can only view this document” is displayed on the Toolbar

(see Figure 42).

If you work with files using the WebDAYV protocol, read-only files are opened in the Edit

mode.

In the View mode, you cannot make changes to the document or change its formatting.
If necessary, you can create a copy of this document that can be edited. To do this, click Edit a Copy

on the Toolbar.

File Edit Insert Format Tools View Share Subscription Help

& v You can only view this document Edit a Copy

A

Q

Figure 42. Edit Copy button

A copy of the document will open in a new application window. To save the file copy, follow

the steps described in Section 4.1.7.

4.1.4.3 File being used by another application

If the file is opened for editing in another application, then:
— This file is opened in the View mode.
— The Toolbar displays a notification that the document is open in another application

(see Figure 43).

= Browser comparison [Edited] - MyOffice Standard. Home Edition - [} X

File Edit Insert Format Tools View Share Subscription Help

S~ Document is not available for editing because it is in use by another application or user  Check Availability Edit a Copy

-~

Q

Figure 43. File is in use by another application
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The file is opened in the Edit mode if it is opened in another application, but no lock file

has been created by that application.

In the View mode, you cannot make changes to the document or change its formatting.

To edit a document, do one of the following:

— Finish working with the document in another application. Then, in MyOffice Text, click
Check Availability on the Toolbar (see Figure 44). If working with a document in another
application is not completed, the pop-up message “Document still in use” will be

displayed. If the work is completed, the document will switch to the Edit mode.

= Browser comparison [Edited] - MyOffice Standard. Home Edition — O X

File Edit Insert Format Tools View Share Subscription Help

(= Document is not available for editing because it is in use by another application or user  Check Availability Edit a Copy

~

Document is still in use

Figure 44. Pop-up message

— Create an editable copy of the document. To do this, in MyOffice Text, on the Toolbar,
click Edit a Copy. A copy of the document will open in a new application window.

To save the file copy, follow the steps described in Section 4.1.7.
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4.1.4.4 File opened by another user

When you try to open a local document opened by another user on the same computer, a dialog
box is displayed (see Figure 45) that contains:

— Information about the user who is currently working with this document.

— Open a Copy button to create an editable copy of the document.

— Close button to finish working with the document.

Open File X

o To avoid losing the changes
made by another user, please

consider opening a copy of the
file.

About the user:

Elena Smirnova, working since
DESKTOP-LSMEQKK, 07.06.2024
12:32:19

Open a Copy Close

Figure 45. Dialog box
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4.1.5 Recent files

MyOffice Text automatically keeps the list of the last files opened in the application.

To open a recent file from the list, proceed as follows:

1. Inthe File menu, select Recent Files (see Figure 46).

File Edit Insert Format Tools Wiew Share Subscription Help

O New Cri+N IC IE v f% XO Thames
Mew from Template... . 6_)
Open... Ctrl+O

E pen o Font
Open With... 4 - : 3 3 4
Recent Files » [} Choose abrowser.docx

= Browser comparison.docx

= Save Ctrl+S & P
Save As... F12 Clear
Autorecovery 4 ‘

Figure 46. Recent Files

2. In the drop-down list of recent files that opens, select the file you want to open.

To clear the Recent Files list, in the File menu, select Recent Files and click Clear.

4.1.6 Open with

You can open the files you are working on in another text editing application directly from
MyOffice Text. To select the application that you want to use, in the File menu, select Open With

(see Figure 47).

This menu item is not available on macOS.
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File Edit Insert Format Tools View Share Subscription H

[ New Ctrl+N B v &

Mew from Template...

[= Open.. Ctrl+0
Open With... » LibreOffice Writer
Recent Files » Word
£ Save Ctrl+5S
Save As... F12
Autorecovery r

Figure 47. Available applications

A list of available applications is created manually using the OpenWithList.ini configuration
file (for more details, see MyOffice Standard. Home Edition Installation Guide).
The Open With command is not displayed if the configuration file does not contain data or if

the data is incorrect.
Clicking the Open With command in the File menu will close the file in MyOffice Text and
open it in the application of your choice. If there are any unsaved changes in the file when you close

it, MyOffice Text will suggest saving them.
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4.1.7 Send a file via email
The Send File command is not available on macOS.

In MyOffice Text, you can email the file you are working on using the default desktop email

client.
To send a file via email, follow the steps below:

1. Inthe Share menu, click Send File (see Figure 48).

Share  Subscription

Send File... L

Figure 48. Share menu

2. In the new message window that appears, do the following:
— Inthe To field, enter the recipient's email address.
— In the Subject field, edit the subject (if required).
— In the body of the message, type the text.

3. Send the email.

Once the message is sent, you will be redirected to MyOffice Text application where you can

continue working on your file.
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4.1.8 Print a document

4.1.8.1 Print a document without entering MyOffice Text

When working in Windows, you can print a document/group of documents without having to
open them first in MyOffice Text.

To do this, proceed as follows:

1. Select the document or group of documents in Windows Explorer.

2. Open the context menu by right-clicking and run the Print command.

The document is printed on the last printer used by MyOffice Text and MyOffice Spreadsheet
applications. If a printer is not previously selected in these applications, it is printed on the printer set
in Windows OS by default.

The following dialog boxes may be displayed while printing:

— For big files or a group of documents, the window for preparing documents for printing

will be displayed.

— Notifications of damaged files and files with unsupported formats will be displayed.
4.1.8.2 Print a document from MyOffice Text

4.1.8.2.1 Select the print area

You can print:
— The selected part of a document.

— The entire document or its individual pages.
To print the selection, do the following:

1. Select the text that you want to print.

2. Right-click the selection with the right mouse button and then click Print Selection.
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To print a document / pages of a document, do one of the following:

— Select File > Print from the Command menu (see Figure 49).

File Edit Insert Format Tools View

[ New Ctrl+N

New from Template...

[~ Open... Ctrl+0
Open With... »

Recent Files 4

Save Ctrl+S
Save As... F12

Autorecovery »

Export To...

Save as Template...

Page Setup Ctrl+Shift+P
= Print... Ctrl+P
Close

Figure 49. Print command menu option

— On the Toolbar, select File, click the arrow to the right of the 4 Quick Print button and

select the Print command from the drop-down list (see Figure 50).

File Edit Insert Format Tools View
+ . v O)(O XQ
Add = : B

Favaorites Font
Quick Print

=
=% Print.. l/\\_‘5

Export to PDF

Page Setup

Figure 50. Print command

— Press Ctrl+P / Cmd+P.
The Print Settings window opens, where you can see how the document will look on paper

and specify print settings.
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4.1.8.2.2 Customize print settings

The Print Settings window (see Figure 51) contains:
—  Print Settings pane

— Preview pane

Print Settings pane Preview pane
& print Settings
Printer: b
Microsoft Print to PDF v
Printer PI’OpEl'(IGS The defash Lasguage of the MyOffice Text agplication & determined by the langvage of

your opesating system. You can change It manually o necessary.
Print in Grayscale

@Whywwhmdﬂyoﬂnrﬁﬂ.hmmh

A MyOffice and MyOffice Presessation
Copies:
To change the application legge, follow these steps:
1 : Collated 123123123 v~ 1. I the Command menu, select Tools > Change Language (see Figure 2.
" R
Print Area: Range: Diplay Changes anc Commmnts.  *
Speling and Gramne
D Entire Document v All Pages v S
B
Mac Edaor
eq. 1-3,37 Compars win_ e
Figure 29, Clunge Lasguage comanand mesw ogeion
mp|€x Print ting' 2 In the window shown In Figue 30, sefect the desired application language from
the dropdown list and click OK.
None v

Language Charge

« =

Figure 30 Language Change window

Print Cancel

Figure 51. Print Settings window

The Preview pane contains the following functions:

1. - and : Zoom in or out the preview section.
2. Fit: Set the default page zoom (100%).

3. and K : Move to the next or previous document page.

® Zoom settings in the Preview pane do not affect the print area. The tool is intended for a

detailed preview of a document content before printing.
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In the print settings pane, you can specify the parameters listed in Table 4.

Table 4. Print Settings

Option

Action

Printer

Select a printer from the drop-down list.

Printer properties
(Windows OS only)

Open the printer settings window. The type and composition of the window
parameters depend on the printer model selected in the field above.

The settings specified in the printer settings window are automatically
transferred to the corresponding fields of the Print Settings window.
Settings that are not supported by the printer are not available in

the Print Settings window.

Print in Grayscale

Print the color text and images contained in the document in grayscale.

Copies

Set the number of copies you want to print.

Collated / Uncollated

The option is available when the number of copies is more than one. Set
the order in which pages are grouped during printing:

— Collated: Print all pages grouped by copies (1,2,3 1,2,3 1,2,3).
— Uncollated: Print pages grouped by page numbers (1,1,1 2,2,2 3,3,3).

Print Area

Select the print area.
— Entire Document: Print all the pages of the document.
— Current Page: Print the page displayed on the screen.

— Selection: This option is only available when you select some text in
your document.

— Page Range: Print the selected pages. The required page numbers or/and
page ranges are listed in the field below. They can be specified as:

e Individual page numbers. For example: 5,10,12.
e The print range separated by a dash (-). For example: For 1-8, 10-11.

e Pages from the beginning of the document to the specific page
specified as - <Ne.>. For example, if you type -3, then pages 1-3 will
be printed.

e Pages from the specific page to the end of the document specified as
<No.>-.
For example, if you type 3- and the document consists of 6 pages,
then pages 3-6 will be printed.

Page Range

Print the selected pages. The Range check box is enabled when
the Entire Document option is selected in the Print Area box. Select one
of the following ranges:

— All Pages: Print all the pages of the current document.

— Odd Pages Only, Even Pages Only: Print the document on a printer
that doesn't support automatic double-sided printing.
You can print the front sides of all the pages, turn the printed pages over,
put them back into the printer, and print on the back sides.
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Option

Action

Duplex Printing

— None: Print on only one side of the page.

— Long-Edge Binding: Print two sides of the page and flip the paper

along the long edge.

— Short-Edge Binding: Print two sides of the page and flip the paper

along the short edge.

To print the document with the set parameters, click Print.

Or click Cancel to cancel printing and close the window.
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4.1.8.2.3 Quick print

MyOffice Text allows you to quickly print a document without using the Print Settings
dialog box.

The Quick Print feature:
— Creates an instant printout and uses the default printing settings.

— Selects the last printer used. The document will be printed using the printer you last used

(if any) or the default printer.

To quick print the document, do one of the following:

— On the Toolbar, select theFile section and click = Quick Print
(see Figure 52).

— On the Toolbar, select the File section and click the arrow to theright of

the = Quick Print button. In the drop-down list, select Quick Print.

File Edit Insert Format Tools View Share

+ - v P @ - é
Add |§% S &
Favaorites -
= Quick Print
& Print...
Export to PDF
= Page Setup

Figure 52. Quick Print command
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4.1.9 Save a file

4.1.9.1 Save as

To save a new file or create a copy of the file you are working on, follow the steps below:
1. Run the Save command in one of the following ways:

— In the File menu, click Save as (see Figure 53).

File Edit Insert Format Tools View

[ New Ctrl+N

New from Template...

[ Open.. Ctrl+0
Open With... ’
Recent Files »

) Save Ctrl+S
Save As.. F12
Autorecovery »

Figure 53. Save and Save As command menu options

— On the Toolbar, select the File section and click the arrow to the right of the I Save

button. In the drop-down list, select Save as (see Figure 54).

File Edit Insert Format Tools WView Sh

+ BY xco-
) .

Add i
h

Favarites

Save

Save As...

Figure 54. Save button

— If your OS is Windows, press F12. If you use macOS, press {I Shift+: Cmd+S.In
the Save as window, select the folder where you want to save the file, specify

the name and the type of the file or copy. Click Save.

When you create a copy of a file, it becomes the document you are working on.
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4.1.9.2 Save

To avoid data loss due to technical failures, it is recommended to save files regularly.

To save changes in the current file, do one of the following:

— In the File menu, click Il Save (see Figure 53).

— On the Toolbar, select the File section and click I Save (see Figure 54).

— On the Toolbar, select the File section and click the arrow
the [l Save button (see Figure 54). In the drop-down list, select Save.
—  Press Ctrl+S / £«Cmd+S.
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4.1.10 Export a file

MyOffice Text allows you to export files to the following formats:
— .pdf

— .pdf/a-1

- .xt

— tf

Exporting files in .txt and .rtf formats is not available in macOS.

To save the file in .pdf or .pdf/a-1 format:
1. Run the export command in one of the following ways:

— In the File menu, click Export To (see Figure 55).

File Edit Insert Format Tools View

[ New Ctrl+N

New from Template...

[~ Open... Ctrl+0
Open With... ’

Recent Files r

= Save Ctrl+S
Save As... F12

Autorecovery »

Export To...

Save as Template...

Figure 55. Export command menu option
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— On the Toolbar, select the File section and click the arrow to theright of

the (= Quick Print button. In the drop-down list, select Export to PDF.

File Edit Insert Format Tools View

+ . v X X0
Add |@9 B

Favaorites Font

= Quick Print

& Print...

Export to POF %

= Page Setup

Figure 56. Export to PDF

2. Inthe file manager window that appears, select the folder for export and specify file name

and format. Click Save.

Specifics of exporting to .pdf and .pdf/a-1 formats:

— Links to websites remain functional in the exported file.
— Table of contents, links to files and email addresses, cross-references to bookmarks,

headings and numbered lists, and footnotes are not exported.

To save the file in .txt or .rtf format:
1. In the File menu, click Export To (see Figure 55).
2. Inthe file manager window that appears, select the folder for export and specify file name

and format. Click Save.
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4.1.11 Autorecovery of documents

By default, when working in MyOffice Text, copies of the documents being edited are
autosaved, including documents that have never been saved by the user. If the application crashes,
when the application is reopened, the user can save the backed up documents as separate files or
replace the original documents with copies.

Backup copies of documents are saved for one month and then automatically deleted.

4.1.11.1 Configure autorecovery of documents

By default, autorecovery of documents is enabled. The data for auto-recovery is saved every
5 minutes.

To change the settings, follow these steps:

1. In the Command menu, select File > Autorecovery > Autorecovery Settings

(see Figure 57).

File Edit Insert Format Tools View Share Subscription Help

M New Ctrl+N D ey & YO
New from Template... _
- & B

[= Open.. Ctrl+0O
Font

Open With... >

Recent Files >

[ Save Ctrl+S
Save As... F12

Autorecovery 4 Autorecovery Settings

Recovered Files

Export To... .

Figure 57. Autorecovery Settings command menu option

3. Inthe Autorecovery Settings window (see Figure 58):
— To disable or enable autorecovery of documents, uncheck or check the Save data for
recovery every box.
— To change the interval for saving document backups, specify it manually, using the
switch, the | and 1 keyboard keys or the mouse wheel. The switching step is 1 minute.
— If you want to disable saving backups for one or more documents currently open,
check the boxes in the Don't save for following files list. This list does not show

documents that have never been manually saved.
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— If you want to copy the path to the folder where the backed up copies of documents

are stored, click the 'Ll button.
4. Click Apply.

Autorecovery Settings
Save data for recovery every | 5 min

Don't save for following files:
v/ Browser comparison.docx [Current]

Choose a browser.docx

Location:

C:/Users/user/AppData/Local/New Cloud Technologies Ltd/MyOffice/MyOffice
Text/Restore

Apply Cancel

Figure 58. Autorecovery Settings dialog box

4.1.11.2 Document recovery

If the work with documents was finished incorrectly, then when you re-enter the application,

the dialog box shown in Figure 59 appears. Click Open in this dialog box.

Autorecovery *

Files you were working on have
been restored

Changes in these documents were not saved due to
the app crash. Open the files?

m Don't Open

Figure 59. Dialog box

Backed up copies of documents will open in new application windows.
To save copies, follow the steps below for each copy:

1. Run the Save As command in one of the following ways:
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— In the notification bar that appears below the Toolbar, click Save As (see Figure 60).

File Edit Insert Format Tools View Share Subscription Help
=
This file was automatically recovered. Save itto keep the data. Delete

~

Q

Figure 60. Save As button

— In the File menu, click Save As (see Figure 61).

File Edit Insert Format Tools View

M New Ctrl+N
New from Template...

[~ Open.. Ctrl+O
Open With... ’
Recent Files ’

Save Ctrl+S
Save As... F12

Figure 61. Save As command menu option

2. Inthe Save As window:
— If you want to save the copy as a separate file, select the folder where you want to save
it, specify the file type and name, and click Save.

— If you want to replace the original file with a copy, select the file and click Save.

If you want to delete a copy, click Delete in the notification bar below the Toolbar

(see Figure 60).

4.1.11.3 Recovered Files pane

If any backed up documents were not saved or deleted as described above, open
the Recovered Files pane.
To do this, proceed with one of the following:

— In the Command menu, select File > Autorecovery > Recovered Files (see Figure 62).
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File

Edit Insert
MNew

Mew from Template...

Open...
Open With...

Recent Files

Save
Save As...

Autorecovery

Export To...

Format

Tools

Ctrl+N

Ctrl+0O

Ctrl+5
F12

View Share Subscription Help
D 6 v & X0
>
r & B

Font

o

»

» Autorecovery Settings

Recovered Files
r

Figure 62. Recovered Files command menu option

— On the Sidebar, click [% Recovered Files (see Figure 63).

Subscription Help

Paragraph

It

Styles

Insert

Q
El

Figure 63. Recovered Files button

To open, save, or delete a document backup copy, follow the steps below:

1. Hover the cursor over the name of the copy (see Figure 64) and click the

2. In the drop-down list, select the desired command.
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Insert A

O

> Recovered Files

A These files were recovered after the app @
crash and will be stored for 30 days from
the recovery date, To keep your data, save
the necessary files.

Delete All

12:31 AM Browser comparison.docx

12:24 AM MyOffice .

Save As...

Delete

Figure 64. Copy Management Commands

You can also open a document backup copy by double-clicking its name in the list.

If you want to delete all copies of the documents, click Delete All (see Figure 65).

=» Recovered Files Q

Ah These files were recovered after the app @
crash and will be stored for 30 days from
the recovery date. To keep your data, save
the necessary files.

Delete All

12:31 AM Browser comparison.docx

12:24 AWM MyOffice Text Home Edition.ur...

Figure 65. Delete All button
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4.1.12 Close a file

Once you've finished working with a file, save it (see Section 4.1.7) and close the application

window using one of the following tips:

— In the File menu, click Close (see Figure 66).

File Edit Insert Format Tools View
(N New Ctrl+N

New from Template...

[= Open.. Ctrl+O
Open With... »

Recent Files 4

& Save Ctrl+S
Save As... F12

Autorecovery r

Export To...

Save as Template...

Page Setup Ctrl+Shift+P
= Print... Ctrl+P
Close

Figure 66. Close command menu option

— Click x Close in the application window heading.
—  Press Alt+F4 / s Cmd+Q.
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4.2 Text

4.2.1 Enter text

Use a keyboard to enter a text to the document workspace. The entered text can be edited,
deleted, formatted, or saved at any time.

The Normal style (see Section 4.3.2) is applied to the text in all new documents and has
the following settings:

— Font: XO Thames

— Font size: 14

— Alignment: Justify Text

— Line spacing: Single

— First line indent: 0

— Spacing before a paragraph: 0

— Spacing after a paragraph: 0

— Left indent: 0

— Right indent: 0

4.2.1.1 Automatically replace hyphen with an en dash

When typing text, a hyphen sign is usually used in those places where the rules of the English
language require a dash, the dash sign being absent on the keyboard. Therefore, the application
automatically  replaces thehyphen (-) with an en dash (=) if you enter
text_Space_hyphen_Space_text_Space/Enter/Tab.

If you want to cancel automatic replacement, run the Cancel command (see Section 4.9.1.1).

4.2.1.2 Automatically replace quotation marks

If the text is entered in Russian or French, straight quotation marks ("") are automatically
replaced by chevrons («»).
If you want to cancel automatic replacement of the left or right quotations mark, run the Undo

command after entering them (see Section 4.9.1.1).
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4.2.2 Footnote

A footnote is a reference or explanatory information for a word or paragraph of a text.

A distinction is made between footnotes and endnotes. Regular footnotes are placed at
the bottom of the page, and endnotes are placed at the end of the section or the document.

A footnote consists of the following elements (see Figure 67):

— A footnote mark placed immediately after the word or paragraph to which it refers.

— The footnote number and text placed at the bottom of the page, section or the document,

below the separator bar following the main text.

The following actions are not available for footnotes:
— Find and replace data
— Check spelling

— Add comments

This sentence contains a footnote.!

! A footnote consists of two linked parts, a reference mark and the corresponding text of the note.
26

Page 1 of 1 - ® +

Figure 67. Regular footnote example
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4.2.2.1 Insert a footnote

The following rules apply in the current version of MyOffice Text:

— For regular footnotes, end-to-end numbering is supported throughout the document. For
endnotes, either end-to-end numbering or section numbering is supported, if it is
configured in a third-party text editor.

— Arabic numerals are used for regular footnotes. Endnotes are numbered using the format
i, ii, iii, ... or the format selected when working with the document in a third-party text
editor, if this format is supported in MyOffice Text.

— By default, endnotes are displayed at the end of the document. End-of-section display is

supported if it is configured in a third-party text editor.

Footnotes may not be added to any objects other than tables, comments, and footers.

To insert a footnote, perform the following actions:
1. Specify the place to insert a footnote in one of the following ways:
— Place the cursor where you want to insert a footnote.
— Select the text where you want a footnote to appear.
— Place the cursor in the cell of the table where you want to insert a footnote.
— Select a range of cells for which you want to add a note. The footnote appears after
the last character of the lower right cell.
2. Insert a footnote in one of the following ways:

— In the Insert menu, click Footnote (see Figure 68).
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View Share Subscription Help
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b & B I U AB
Font
Ctrl+Enter
3
3
Ctrl+K
» ae Footnote Ctrl+Alt+F
[i] Endnote Ctrl+Alt+E

Figure 68. Insert menu

On the Toolbar, select the Insert section and click the “** button. In the insert pane

;
that opens, place the cursor in the A Footnote menu. In the sub-menu that opens,

select the desired type of footnote (see Figure 69).
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Figure 69. Insert pane

— Press Ctrl+Alt+F / —~Option+% Cmd+F to insert a regular footnote or
Ctrl+Alt+E / ~ Option+% Cmd+E to insert an endnote.

3. A footnote symbol will appear at the specified location in the document and a footnote
number will appear at the bottom of the page, section, or document. Enter the footnote text
after the footnote number.

If the document contains no other footnotes, the normal footnote is assigned the number 1 and

the endnote is assigned the letter i when inserted.

If the document contains regular footnotes, the regular footnote is assigned a sequential

number corresponding to its position relative to other regular footnotes.

If the document contains endnotes, the following applies:

— The footnote format of the current document is applied.

— Endnotes are assigned a serial number corresponding to its position in relation to other

endnotes.
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4.2.2.2 Go to a footnote

When you hover over a footnote symbol in the main text of the document, a pop-up window

with the footnote text is displayed (see Figure 70).

office software suite that serves as a
platform for collaborative editing,
document storage, communication,and
mailing systems on virtually any desktop
or mobile device

Ctrl + Click to follow link

Figure 70. Insert pane

Press Ctrl / ¢Cmd and click the footnote mark to go to a footnote. The cursor automatically

moves to the footnote text at the end of the page, section, or document.

4.2.2.3 Copy, cut, and insert a footnote

Footnotes can be copied, cut and pasted (see Section 4.9.2) within a single document or

between MyOffice Text documents.

Footnotes may not be inserted in any objects other than tables, comments, headers and

footers.

It is possible to cut, copy, and insert:
— Text with a note

— A note without text. To do this, cut or copy the footnote character.

The same numbering rules apply when inserting cut or copied footnotes as when inserting

new footnotes.
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4.2.2.4 Edit and format the footnote

You can edit and format the footnote text the same way as you edit or format the main text of

a document.

4.2.2.5 Remove the footnote

To remove a footnote, do one of the following:

1. Remove the footnote mark in the main body of thetext. The number and text of
the footnote at the end of the page, section or document will be deleted automatically.

2. Select the text in the footnote or place the cursor anywhere on footnote at the end of
the page, section or document. Right-click the selected text, and then click Delete
Footnote in the shortcut menu. The footnote mark in the body of the text will be deleted
automatically.

When you remove a footnote, the numbering of the remaining footnotes is automatically

updated.
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4.2.3 Links

You can add a link to a web page, email address, or file in the text of a document.

4.2.3.1 Insert a link to a web page or email address

MyOffice Text recognizes and makes active links that start with www, http, https, and email

addresses.

and

Here are the examples of the links:
www.website.ru
https://website.com
http://website.ru
mailto:user@domain.ru

user.name@domain.com

A link such as mailto:user@domain.ru may also contain a subject line, the text of the email,

email  addresses for sending copy and blind copy. For example,

mailto:user@domain.ru?subject=This % 20is % 20the % 20subject& cc=user2@domain.ru&bod
y=This %20is % 20the%20body.

To avoid errors when you click and follow a link, it is recommended to specify the

protocol in the URL. For example, http://website.com.

In MyOffice Text, links can be displayed as follows:
— URL: http://www.website.com
— Text: Link

To add a link to your document as a URL, do one of the following:

— Type the link using the keyboard and press Space or Enter.

— Copy the link from the source, paste it into the desired location in the document and
press Space or Enter.

— Copy the link from the source, place the cursor at the desired location in the document and

press Ctrl+Shift+V/ {t Shift+s Cmd+V.
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To insert a link as text, follow the steps below:
1. Copy the link from the source.
2. Specify where you want to insert a link in one of the following ways:

— To format a word as a link, place the cursor in the word or select the entire word.
To link a typed text piece, select the entire text piece.

— To add a word or text fragment with a link to a document that has not yet been typed,
place the cursor at the desired location in the document. If you want to insert a word
or text piece with a link into an empty table cell, select the cell or place the cursor in
it.

3. Perform the insert link command in one of the following ways:

— In the Insert menu, click Link (see Figure 71).

Insert Format Tools View  Share
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Text Box
Shape 4

QHE

Table...

Equation...

| @ B

Special Characters...

1

Page Break Ctrl+Enter

||'[

Section Break
Page Numbers »

Header and Footer »

0 #

Table of Contents

Link... Ctrl+K

Cross-Reference...

o 4 S

Bookmark...
4B Footnote ’

=] Comment

=] Current Date
(D Current Time

Figure 71. Link command menu option
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— On the Toolbar, select the Insert section and click the “= button (see Figure 72).

In the insert pane that appears, click ¢*’ Link.

Y Vs |
AaBbCcDd @ ... v @ v E -

Normal

Styles @ Image... A
15 16 17 o—s
Text Box
(Y Shape > Q
EH Table... >
@ Equation...
Special Characters... ?
e Page Break
*=  Section Break

)

Page Numbers... >

40

Header and Footer >

Table of Contents

Link...

N

::.] Cross-Reference...

Figure 72. Insert pane

— Right-click to open the context menu and run the Insert Link command.
— Press Ctrl+K / sCmd+K.
4. In the Insert Link window (see Figure 103):
— If the URL field is blank, paste the link into it. By default, the link copied from

the source in the first step is automatically substituted in the URL field.
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— If the Text field is not filled in, enter the text that will be displayed instead of the link.
By default, the Text field is automatically filled with the word on which the cursor is

positioned, the selected word, or the selected text fragment.

— Click OK.

Insert Link X

Text:

MyOffice X

Address:

https://myofﬁce.ru/| X Choose File...
Recent Files:

ﬂ Mew Document 1.docx

Figure 73. Insert Link
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4.2.3.2 Insert a link to a file

You can insert a link to a file that is located on the current computer or in a network folder
into your document. The link can reference a file of any format.

The link can be displayed in the document as follows:

— Paths to the file. For example, C:\Users\User\Documents\File.docx (Windows) or

/Users/User/Downloads/File.docx (macOS).

— Text: For example, link to the file. You can specify the link text either in the document

text or in the link insertion window.

To add a link to a file in your document, follow these steps:
1. Specify the place to insert the link in one of the following ways:

— To format a typed word as a link, place the cursor in the word or select the entire word.
To format a typed text fragment as a link, select the whole text fragment.

— To add a word or text fragment with a link to a document that has not yet been typed,
place the cursor at the desired location in the document. If you want to insert a word
or a text fragment with a link into an empty table cell, select the cell or place the cursor
in it.

2. Insert the link in one of the following ways:

— In the Command menu, select Insert > Link (see Figure 74).

Insert Format Tools View  Share

Image...

Text Box

Y ¥
& H

Shape »

Table...

Equation...

B e H

Special Characters...

1C

Page Break Ctrl+Enter

Section Break

[

Page Numbers 4

Header and Footer »

m o #

Table of Contents

Link... Ctrl+K

oS

Cross-Reference...

Figure 74. Link command menu option
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— On the Toolbar, in the Insert section, click === (see Figure 75). In the insert pane that

appears, click ¢*? Link.

AaBbCcL AaBbCc AaBbCcL .. %v @ v L_]

MNarmal Heading 1 Heading 2

Styles
13 14 15 16 17 18

Table... >

Equation...

e H @O

Special Characters... >

aC

Page Break

||'|:

Section Break

Page Numbers... >
@ Header and Footer >
=:  Table of Contents

&  Link..

_EJ Cross- Reference...

Figure 75. Insert pane

— Right-click to open the context menu and run the Insert Link command.
— Press Ctrl+K / 8Cmd+K.
3. In the Insert Link window (see Figure 76), select the file you want to insert a link to in
one of the following ways:
— Select a file from the Recent Files list. This list displays the 50 most recent files that
were opened in the MyOffice Text, MyOffice Spreadsheet, and MyOffice Presentation
applications.

— Select the file using the File manager. To do this, click Choose File.
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Insert Link *

Text

Link to the file X

Address:

Choose File...

Recent Files

MNew Document 1.docx

QK Cancel

Figure 76. Insert Link window

4. If you want the link to be displayed as text and the Text field is not filled in, enter the
required text. By default, the Text field is automatically filled with the word on which the
cursor is placed, the selected word, or the selected text fragment.

5. Click OK.

4.2.3.3 Quick link insertion

You can quickly add a link to a web page, email address, or file to the typed text.

For quick insertion, the following types of links to local and network files are supported:
— file:///C:/Users/User/Documents/File.docx

— smb://192.168.1.1/Files/File.docx

—  ftp://Guest@127.0.0.1/share/FTP/File.docx

—  sftp://Guest@127.0.0.1/share/FTP/File.docx

The supported types of web page links and email addresses are described in Section 4.2.3.1.
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To quickly add a link to typed text, follow these steps:

1. Copy the link.

2. To format a typed word as a link, place the cursor in the word or select the entire word.
To format a typed text fragment as a link, select the whole text fragment.

3. Press Ctrl+Shift+V / {iShift+3Cmd+V.

4.2.3.4 Follow a link

To follow the link, do one of the following:
— Click it while holding down Ctrl / ¢ Cmd pressed.

— Place the cursor on the link and press Enter.

Web links are opened in the default browser used in the OS.

Files are opened in MyOffice Text, MyOffice Spreadsheet and MyOffice Presentation
applications. If the file format is not supported, the file is opened in the application that is used by
default in the OS to work with files of the corresponding format.

When you click the link to an email address, it opens the default email client in your OS. This

software automatically creates a new email, into which the data specified in the link is copied.

4.2.3.5 Copy a link

To copy a link, click it with the right mouse button and select the Copy Link URL context

menu command.

4.2.3.6 Edit a link

To edit a link, follow the steps below:
1. Place the cursor on the link or select part of the link/the entire link.
2. Open the link editing window in one of the following ways:
— In the Command menu, select Insert and click Link (see Figure 74).
— On the Toolbar, select the Insert section and click the *= button (see Figure 75).
In the insert pane that appears, click ¢’ Link.
— Right-click to open the context menu and run the Edit Link command.

—  Press Ctrl+K / 3 Cmd+K.
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3. Inthe Edit Link window (see Figure 77), make the required changes to the link text and
address.

4. Click OK.

Edit Link >

Text:

MyOffice X

Address:

https://myofﬁce.ru/en{i X Choose File...

Recent Files:

[ New Document T.docx

Remove Link Cancel

Figure 77. Edit Link window
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4.2.3.7 Delete a link

You can delete a link using the editing window or the context menu. The link is deleted
without the text that contains it.
To delete a link using the edit window, follow the steps below:
1. Place the pointer on the link or select the link partially or entirely.
2. Open the link editing window in one of the following ways:
— In the Command menu, select Insert > Link (see Figure 74).
— On the Toolbar, in the Insert section, click the === button (see Figure 75). In the displayed
insert pane, click ¢%/ Link.
— Right-click to open the context menu and run the Edit Link command.
—  Press Ctrl+K / 8Cmd+K.
3. Inthe Edit Link window (see Figure 77), click Remove Link.

To delete a link using the context menu, follow the steps below:
1. Place the cursor on the link or select part of the link/the entire link.

2. Right-click to open the context menu and run the Delete Link command.

To delete multiple links at the same time, follow the steps below:
1. Select the text fragment that contains the given links.

2. Right-click to open the context menu and run the Delete Links command.

If you want to delete a link along with the text that contains it, delete it as plain text

(see Section 4.2.10).
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4.2.3.8 Keyboard shortcuts for moving between window elements

The Table 5 below shows the keyboard shortcuts you can use to quickly move between

elements in the Insert/Edit Link window.

Table 5. Keyboard shortcuts

Action Windows macOS
keyboard shortcuts keyboard shortcuts

Open the window Ctrl+K % Cmd+K
Go to the next window element Tab Tab
Go to the previous window element Shift+Tab f Shift+Tab
Click Select File or OK Space Space
Click OK regardless of which window element is _
currently selected Enter ~ Enter
Go to the next/previous file in the Recent Files list | and 1 l and 1
Go to the first file in the Recent files list Home Fn + «
Go to the last file in the Recent files list End Fn+ —
Select a file in the Recent files list Space Space
Close the window Esc Esc

4.2.4 Cross-reference

A cross-reference is a reference to an element in another part of the document. In

MyOffice Text you can create a cross-reference to the following items:

heading

(see Section 4.10.6.1), numbered list item (see Section 4.3.9) or bookmark (see Section 4.2.5).

The current version of the application does not allow for working with cross-references to

the unsupported items (footnotes, endnotes, images, tables, or formulas) created using third-party

editors.

4.2.4.1 Insert a cross-reference

To insert a cross-reference, do the following:

1. Place the cursor where you want to insert a cross-reference.

2. Open the cross-reference window in one of the following ways:

— In the Command menu, select Insert > Cross-reference (see Figure 78).

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

82




MyOffice

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

Insert Format Tools

BEE QHI

)

oo o a

Qy

Image...
Text Box

Shape

Table...
Equation...

Special Characters...

Page Break
Section Break
Page Numbers
Header and Footer

Table of Contents

Link...
Cross-Reference...
Bookmark...

Footnote

View Share

Ctrl+Enter

Ctrl+K

Figure 78. Insert menu

— On the Toolbar, select the Insert section and click the “** button (see Figure 79).

— In the displayed insert pane, click = Cross-reference.
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Figure 79. Insert pane
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3. In the Cross-reference window (see Figure 80), select the Reference Type drop-down
list and select the elements to which the reference will lead: Heading, Numbered List or
Bookmark. If you want to add a cross-reference to a system bookmark
(see Section 4.2.5.3), in the lower part of the window, check the Show system bookmark

box.

Cross-Reference X

Reference Type:

Heading v
Refer to

Heading 1

Heading 2

Heading 3
Insert reference to:

Heading Text v

Figure 80. Cross-reference window
4. In the Refer to box, select the specific element you want the reference to refer to. This

box will contain the list of all elements of the reference type selected during the previous

step. The list will be generated automatically.
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5. In the Insert reference to drop-down list, specify the numeric or text value of
the cross-reference. The list of values depends on the previously selected element type.

Table 6. Cross-reference meaning

Element Meaning

Heading — Heading Text: Heading text.

— Page Number: The number of the page where the selected heading is
located.

— Heading Number (no context): A short number of the heading which
is an item of a multilevel list. Example: The reference to heading 1.c.ii
will look like ii.

— Heading Number (full context): A full number of the heading which is
an item of a multilevel list. Example: 1.c.ii.

— Above/Below: The word “above” if the heading is above the cross-
reference, or “below” if the heading is located below the cross-
reference. The position of the heading is identified automatically.

Numbered List — Page Number: The number of the page where the selected list item is
located.

— Item Number (no context): A short number of the multilevel list item.
Example: 1.c.ii item will be presented as ii.

— Item Number (full context): A full number of the multilevel list item.
Example: 1.c.ii.

— Item Text: The text of the list item.

— Above/Below: The word “above” if the item list is above the cross-
reference, or “below” if the item list is located below the cross-
reference. The position of the item list is identified automatically.

Bookmark — Bookmark Text: The text fragment where the bookmark has been set.
This value can only be selected for the bookmarks in the selected text
but not where the cursor is positioned.

— Page Number: The number of the page where the selected bookmark is
located.

— Item Number (no context): A short number of the multilevel list item
where the bookmark is positioned. Example: 1.c.ii item will be
presented as ii.

— Item Number (full context): A full number of the multilevel list item
where the bookmark is positioned. Example: 1.c.ii.

— Above/Below: The word “above” if the bookmark is above the cross-
reference, or “below” if the bookmark is located below the cross-
reference. The position of the bookmark is identified automatically.

6. Click Insert.
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If a cross-reference is incorrect, the # symbol will be displayed instead.

To insert other cross-references, repeat the procedure.
You can continue to work with the main application window while you enter the cross-

reference parameters. To close the Cross-reference window, click the X button in the window title.

4.2.4.2 Go to a cross-reference

To go to a cross-reference, click it by holding the Ctrl / sCmd.

4.2.4.3 Update a cross-reference

Cross-references are updated automatically.
4.2.4.4 Modify a cross-reference
To modify the existing cross-reference, deleted it as described in the Delete a cross-reference

section and add a new cross-reference as described in the Insert a cross-reference section.

4.2.4.5 Delete a cross-reference

To delete a cross-reference, select it by clicking it with the mouse and press Delete.
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4.2.5 Bookmarks

In MyOffice Text, you can use the bookmarks the same way you use them when reading
a paper book. Bookmarks allow you to quickly get back to specific parts of your document.

Bookmarks can be added to text, tables, and their elements (rows, columns, cells), images,

headers, and footers.

4.2.5.1 Insert a bookmark

To insert a bookmark into the document, do the following:

1. Place the cursor where you want to insert the bookmark or select the element where you
want to add it.

2. Insert the bookmark in one of the following ways:

— In the Insert menu, select Bookmark (see Figure 81).

Insert Format Tools View Share
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Text Box
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Page Break Ctrl+Enter

[

Section Break
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Header and Footer 4

m o #

Table of Contents

Link... Ctrl+K

S5

Cross-Reference...

Bookmark...

el

Figure 81. Insert menu

— On the Toolbar, select the Insert section and click the “== button (see Figure 82).

In the insert pane that opens, click ... Bookmark.
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Figure 82. Insert pane
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3. In the Bookmarks window (see Figure 83), specify the bookmark title. Don’t use

the existing bookmark titles.

Bookmarks X

‘ Bookmark 1 X ’

Sort by:

O Name Location

Show system bookmarks

Cancel

Figure 83. Bookmarks window
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4, Click the button or press Enter (see Figure 84). The bookmark will be added to
the list (see Figure 85).

Bookmarks X

Bookmark Title

Sort by:

O Name Location

Bookmark 1

Show system bookmarks

Cancel

Figure 84. Bookmark is added

5. Close the Bookmarks window. To do this, click Cancel or the % button in the window

heading.

Follow the same procedure to add new bookmarks into the text.
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4.2.5.2 Display bookmarks

To display bookmarks in a document (see Figure 85), display non-printable characters

(see Section 4.3.1).

This-sentence-contains-a-bookmark.q

Figure 85. Bookmarks window

4.2.5.3 Show system bookmarks

When a cross-reference (see Section 4.2.4) is created to a heading or numbered list in a
document, a system bookmark is automatically created. For example, if a cross-reference is created
to Heading 1, Heading 1 becomes a system bookmark. System bookmarks are marked in
the document with non-printable symbols similar to regular bookmarksT T

To see the entire list of system bookmarks, do the following:

1. Open the Bookmarks window in one of the following ways:

— In the Command menu, select Insert > Bookmark (see Figure 81).
— On the Toolbar, in the Insert section, click === (see Figure 87). In the displayed insert

pane, click ... Bookmark.

2. In the Bookmarks window (see Figure 82), check the Show system bookmarks box.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 91



MyOffice

Bookmarks X

Bookmark Title

Sort by:

O Name Location

System bookmark 1
System bookmark 2

System bookmark 3

Show system bookmarks

Cancel

Figure 86. Bookmarks window

System bookmarks are displayed in the same list as manually set bookmarks. Work with

system bookmarks is performed in the same way as with regular bookmarks.
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4.2.5.4 Go to a bookmark

To go to a bookmark in the document, do one of the following:

1. In the Insert menu, select Bookmark (see Figure 81).

2. On the Toolbar, select the Insert section and click the **button (see Figure 82).

In the insert pane that opens, click ... Bookmark.

The Bookmarks window will open containing the list of bookmarks (see Figure 87).

Bookmarks in the list can be sorted in the following ways:

— Name: Sorting bookmarks alphabetically (from A to Z). This option is selected by default.

— Location: Sorting bookmarks depending on their location in the document (from top to

bottom).

Select the bookmark title in the list. The cursor will move where the bookmark is set.

Bookmarks X

Sort by:

O Name Location

_System bookmark 1
_System bookmark 2

_System bookmark 3

Show system bookmarks

Cancel

Figure 87. Bookmarks window
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4.2.5.5 Rename a bookmark

To rename a bookmark:
1. Open the Bookmarks window in one of the following ways:
— In the Insert menu, select Bookmark (see Figure 81).
— On the Toolbar, select the Insert section and click the **= button (see Figure 82).
In the insert pane that opens, click ... Bookmark.
2. In the Bookmarks dialog box (see Figure 88), place the cursor on the bookmark that you

want to rename and click ¢ Edit bookmark.

The name of the system bookmark (see Section 4.2.5.3) must begin with

[T 1]

the underscore character “ ”.

Bookmarks X

Bookmark Title

Sort by:

O Name Location

Bookmark 1
Baokmark 2 & W

Bookmark 3

Show system bookmarks

Cancel
Figure 88. Rename a bookmark

3. Edit the bookmark name and press the Enter key.
4. Close the Bookmarks window. To do this, click Cancel or the  button in the window

title.
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4.2.5.6 Delete a bookmark

To delete a bookmark, in the Insert menu, click Bookmark (see Figure 81).
In the Bookmarks dialog box (see Figure 89), place the cursor on the bookmark you want to

delete and click T,

To delete a bookmark, do the following:
1. Open the Bookmarks window in one of the following ways:
— In the Insert menu, select Bookmark (see Figure 81).
— On the Toolbar, select the Insert section and click the == button (see Figure 82).
In the insert pane that opens, click |.. Bookmark.
2. Inthe Bookmarks dialog box (see Figure 89), place the cursor on the bookmark you want

to delete and click I Delete bookmark.

Bookmark Title

Sort by:

O Name Location

Bookmark 1 72|
Bookmark 2

Bookmark 3

Show system bookmarks

Cancel

Figure 89. Delete a bookmark

3. Close the Bookmarks window. To do this, click Cancel or the: button in

the window title.
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4.2.6 Special characters

Special characters are characters that cannot be found on the keyboard. For example, math
operators, dingbats, and currency signs. Such symbols can be inserted using the special characters

quick insert pane or the Special Characters window.

4.2.6.1 Special characters quick insert pane
To open the special characters quick insert pane, do one of the following:

— On the Toolbar, in the Insert section, click ﬂ Special Characters (see Figure 90).

. A A
AaBbCcDd @ ... @v @ v% E o

C|'|' Normal
Styles © ® P % u vV 8

E] 14 15 16 ‘\7‘,
Y, % — m Y ° A
# = = - x = >
Non-Breaking Space Ctrl+Shift+Space
Non-Breaking Hyphen Ctrl+Shift+(-)
En Dash Ctrl+Num(-)

More Characters...

Figure 90. Special characters quick insert pane

— On the Toolbar, in the Insert section, click -=-. In the pane that appears, hover the mouse

cursor over the arrow to the right of the |>2) Special Characters button (see Figure 91).
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= v = v 1 v
AaBbCcDd | ... @v @ v |:|
= W = 5= _‘E[ v C|'|' Normal -
Paragraph Styles @ Image... ™~
9 10 1 12 13 14 15 16 17 Text Box
('5] Shape > Q
BH Table... >
@ Equation...
Q Special Characters... >
© ® P % unu V 8 P
= Page Break
Yo % — wm Y ° A Mo
= Section Break
# = + - X < =
Page Numbers... b
. ) @ Header and Footer >
Non-Breaking Space Ctrl+Shift+Space
= Table of Contents
Non-Breaking Hyphen Ctrl+Shift+(-)
En Dash Ctrl+Num(-) 7 Link..
::J Cross-Reference...
More Characters...
m Bookmark...

Figure 91. Special characters quick insert pane

To insert a special character, do one of the following:

— Select a character from the set of preset characters. As you work with the application,
the preset characters change to characters added by the user to the document using
the Special Characters window (see Section 4.2.6.2). When the mouse cursor hovers

over a character, the name of the font selected for it is displayed.

When inserting, the font of the document text is applied to the character.
However, if the font of the text does not support this character, then the font

selected by the user is used.

— Select Non-breaking Space, Non-Breaking Hyphen, or En Dash if you want to insert

the appropriate character.
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4.2.6.2 Special Characters window

To open the Special Characters window, do one of the following:

— In the Command menu, select Insert > Special Characters (see Figure 92).

Insert Format Tools View Share

Image...
Text Box

Shape 4

Table...

Equation...

DeH QHI

Special Characters...

1C

Page Break Ctrl+Enter

Figure 92. Special Characters menu

— On the Toolbar, in the Insert section, click @ Special Characters (see Figure 93).

In the special characters quick insert pane, select More Characters.

Y U 000 |
AaBbCcDd ... @v @ vlk E] -

C|'|' Normal
Styles © ® P %o u \[ 8
13 14 15 16 17 —

Yoo % — m Y ° A
# = + - X < b
Non-Breaking Space Ctrl+Shift+Space
Non-Breaking Hyphen Ctrl+Shift+(-)
En Dash Ctrl+Num(-)

More Characters...

Figure 93. More Characters menu

— Onthe Toolbar, in the Insert section, click --- (see Figure 94). In the pane that appears, click

Special Characters.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 98



MyOffice

- A A
AaBbCcDd | ...  FHe B4 [@Q)v [ -

Normal
Styles @ Image... A~
" ° \ Text Box
(5] Shape > Q
EH Table... >
@ Equation...
Special Characters... >

Figure 94. Special Characters button

— Onthe Toolbar, in the Insert section, click ==« (see Figure 98). In the pane that appears, hover
the mouse cursor over thearrow to theright of the|®]Special Characters button.

In the special characters quick insert pane, click More Characters.

— v = v T1 v
AaBbCcDd @ ... @v @ v E]
=y E = EHey q | Mo v
Paragraph Styles @ Image... ~
9 10 1 12 13 14 15 16 17 —
Text Box
(J_)_J Shape > Q
[==) Table... >
@ Equation...
Q Special Characters... >
© ® P % p vV 8 P
= Page Break
v % — m Y ° A oo
= Section Break
# = + - x < 2
Page Numbers... >
. . @ Header and Footer >
Non-Breaking Space Ctrl+Shift+Space
. ) =:  Table of Contents
Non-Breaking Hyphen Ctrl+Shift+(-)
En Dash Ctrl+Num(-) & Link..
= Cross-Reference...
More Characters...
[ Bookmark...

Figure 95. More Characters menu
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The Special Characters window (see Figure 98) contains the following tools:

Special Characters X
XO Thames v Latin-1 Supplement v NO-BREAK SPACE
. Unicode: U+00AQ

i ¢ £ o ¥ | § ©
- ® 0 28

TR A S S
% ¢« A A A A A A E C
EEEE T I I 1T PN

O Tha

O 0000 x o UUTU
U Y b a a a a a a
® ¢ e e ¢ é i1 1 1 1
A = A A A X = ~ v
Close window after inserting a character Cancel

Figure 96. Special Characters window

— Drop-down list for selecting the font of the special character.

— Drop-down list for selecting the group and category of the character. If the font does not
support the characters of a category group or category, it is not displayed in the list.

— Characters. By default, the first character of the selected category is highlighted.
Categories are separated from each other by a line.

— The name of the highlighted character.

— The code of the selected character in the Unicode system.

— The typeface of the selected character.

— The font of the selected character.

—  Other typefaces of the selected character.
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To insert a character from the Special Characters window, follow these steps:
1. Select the font of the special character. The selection is similar to the font selection in
the main application window (see Section 4.3.3).
2. Select a character category. You can select it in the same way as selecting a special
character font.
3. Place the cursor in the position of the document where you want to insert the character.
4. Insert the character in one of the following ways:
— Select the character by double-clicking.
— Select the character with one click and click Insert.

— Select a character with one mouse click and press Enter or Space.

If you want the window to close automatically, check the Close window after inserting

a character box.

To close the Special Characters window manually, click Cancel or the X button in

the window header.
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4.2.7 Current date or time

You can quickly insert the current date or time anywhere in a document, except for headers

and footers. Follow these steps:

To insert the current date:
1. Place the cursor in the place of the document where you want to insert the current date.
2. Insert the date in one of the following ways:

— In the Insert menu, select Current Date (see Figure 97).

Insert Format Tools View Share

Image...
Text Box

Shape 4

Table...

Equation...

BOHE QH®

Special Characters...

Mt JC

Page Break Ctrl+Enter

Section Break
Page Numbers 4

Header and Footer »

m m #

Table of Contents

Link... Ctrl+K
Cross-Reference...

Bookmark...

Footnote 4

Comment

Current Date

QO UWaa il

Current Time

Figure 97. Insert menu
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© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

AaBbCcDd

Normal

Styles

In the displayed insert pane, click [5] Current Date.

B B @ 5,

~

| 1EXT BOX

6] Shape

[2z2] Table...

@ Equation...

Special Characters...

’H Page Break

"= Section Break

Page Numbers...

@ Header and Footer

=: Table of Contents

& Link..

j:(] Cross-Reference...

[J Bookmark...

AR Footnote

B Comment

Current Date

@ Current Time

Figure 98. Insert pane

On the Toolbar, select the Insert section and click the **= button (see Figure 98).
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To insert the current time:
1. Place the cursor in the place of the document where you want to insert the current time.
2. Insert the time in one of the following ways:

— In the Insert menu, select Current Time (see Figure 97)

— On the Toolbar, select the Insert section and click the = button (see Figure 98).

In the displayed insert pane, click (-} Current Time.

The data inserted is static, that is, not updated when the actual date and time change.
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4.2.8 Check grammar and spelling

MyOffice Text can automatically check texts in English and Russian for grammar and spelling

mistakes.

4.2.8.1 Check spelling

To enable and disable Check Spelling option, in the Tools menu, select
Spelling & Grammar and then check or uncheck the Check Spelling box (see Figure 99).
Enabling or disabling Check Spelling option is only applied to the current document and does

not affect other opened documents.

Tools View Share Subscription Help

Display Changes and Comments  * |m T

L]
Spelling and Grammar P+ Check Spelling
Custorn Dictionary Check Grammar
Change Language... i

Macro Editor

Compare with... (beta)

Figure 99. Tools menu

Check spelling basics:

— The spell-checking dictionary is automatically selected based on the language of the first
word in the paragraph.

— Words missing in the selected dictionary or misspelled words are underlined with a red
wavy line.

— Changing the content of a document restarts spell-checking.
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4.2.8.1.1 Correcting spelling errors

To correct a misspelled word, follow these steps:

1. Move the cursor over the misspelled word underlined with a red wavy line or select it by
right-clicking it.

2. Right-click to open the context menu.

3. In the context menu, select the correct spelling (see Figure 100).

ctnlrn
II]B stake

mistake
m stake
ms take
ms-take

Add to Dictionary

lgnaore

[} Paste Ctrl+V
Paste Text Only
Paste from Clipboard r

¢ Insert Link...

[Z Add Comment

Figure 100. Check Spelling

If no correct spelling can be suggested for the word, you'll see the No suggestions notification

in the context menu.
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4.2.8.1.2 Turn off the underline for spelling errors

A word recognized as misspelled by the application is underlined with a red wavy line.
To turn this option off for a particular word, add it in the Custom dictionary (see Section 4.2.8.2) or
in the ignore list.

To add a word in the ignore list, follow the steps below:

1. Move the cursor over the misspelled word underlined with a red wavy line or select it.

2. Right-click the word and select Ignore from the context menu.

Once finished, thered wavy underline disappears. If a word appears several times in
the document, the changes are applied to all repetitions considering the case. Such changes are saved

within one session. When the document is opened again, the Check Spelling is launched again.

If you've added a word into the ignore list by mistake, you can get back to the previous step
by selecting the Check Spelling option. Follow these steps:
1. Move the cursor over the word or select the entire word.

2. Right-click the word and select Check Spelling from the context menu.
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4.2.8.2 Custom Dictionary

To exclude words such as proper names, abbreviations, or technical terms in a text from being
considered misspelled, you can add them to the Custom Dictionary.

Before you start, make sure that the Check Spelling is on (see Section 4.2.8.1).

4.2.8.2.1 Adding words to the Custom Dictionary

The Custom Dictionary allows you to add only individual words but no word combinations.

Adding words is case-sensitive. If a word can start with a capital letter and with a lowercase
letter, add the two spellings into the dictionary.

To add a word to the Custom Dictionary directly from the text, right-click the selected text,
and then click Add to Dictionary in the shortcut menu.

To add a new word directly to the Custom Dictionary, follow the steps below:

1. Inthe Tools menu, select Custom Dictionary (see Figure 101).

Tools View Share Subscription Hel

Display Changes and Comments  *
Spelling and Grammar 4

Custom Dictionary

Figure 101. Custom Dictionary command menu option

2. In the Custom Dictionary dialog box (see Figure 102), enter the word you want to add.

3. Press or Enter.

4. Click Done to finish and close the window.
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Custom Dictionary >

‘ MyOffice] X

(Empty)

Figure 102. Custom Dictionary window
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4.2.8.2.2 Using third-party dictionaries

To extend the vocabulary available in MyOffice Text, you can use third-party dictionaries in
.dic format. In the Custom Dictionary dialog box, click Import (see Figure 102). In the opened file
manager window, select a .dic file and click Open.

When finished, the content of the dictionary will appear in your dictionary.

4.2.8.2.3 Delete words from the Custom Dictionary

If necessary, you can remove words previously added in the Custom Dictionary.

To remove a word using the Custom Dictionary menu, follow the steps below:

1. Inthe Tools menu, select Custom Dictionary (see Figure 101).

2. In the Custom Dictionary dialog box, place the cursor on the word you want to remove
from the dictionary and click Remove (see Figure 103).

3. Click Done to finish.
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Custom Dictionary >

‘ Enter a new word

MyOffice Remove

Figure 103. Remove a word from the dictionary

To delete a word directly from the text, right-click on it and click Remove from Dictionary

in the shortcut menu.
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4.2.8.3 Check Grammar

To enable or disable Check Grammar option, in the Tools menu, select
Spelling & Grammar and then check or uncheck the Check Grammar box (see Figure 104).
Enabling or disabling grammar checking applies to the current document and doesn't affect

other opened documents.

Tools View Share Subscription Help

Display Changes and Comments  * Ln S
Spelling and Grammar 4 Check Spelling

Custom Dictionary ~  Check Grammar

Figure 104. Tools menu

Grammar checking basics:

— The grammar checking language is selected automatically depending on the first letter of
the paragraph.

— The grammar checking is launched once you press Space or Enter, provided that
the sentence is complete.

— A sentence with a grammatical error is underlined with a blue wavy line.
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4.2.9 Find and replace

You can search and replace data throughout the entire content of the document, except
for footnotes (see Section 4.2.2).
If the document is opened in the View mode, only data search (without replacement)

is available.

To open the pane to find and replace data in a document, do one of the following:

— In the Command menu, select Edit > Find (see Figure 105).

Edit Insert Format Tools View Share

3 Undo Ctrl+Z
" Redo Ctrl+Y
3 Cut Ctrl+X
[] Copy Ctrl+C
[Ty Paste Ctrl+V
Paste Text Only
Paste from Clipboard 4
£ Copy Formatting Ctrl+Shift+C
Paste Formatting
Select All Ctrl+A
Find Ctrl+F

Figure 105. Find command menu option

— In the Sidebar, click ) Find and Replace (see Figure 106).

- s
It

Paragraph Styles Insert g
14 15 16 17 )

1]

Figure 106. Find and Replace button

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 113



MyOffice

—  Press Ctrl+F or Ctrl+H / ¥Cmd+F.

In the Find and Replace pane (see Figure 107) specify data search and replacement
parameters, if necessary:
1. Open the Parameters section by clicking .
2. Specify the Search area:
— Entire document: Search the entire document, including footers (see Section 4.10.2)
— Without header and footer: Search the entire document except for headers or

footers.

- Find and Replace Q

Replace Replace All

Parameters T
Search area:
© Entire document

Without header and footer
Filters:

Match whole words only
Match case when searching

Match case when replacing

Figure 107. Search parameters

3. Check the required Filters:
— Match whole words only: Find only whole words, not text that is part of another

word.
— Match case when searching: Perform the search based on uppercase and lowercase

letters in the text you are looking for.
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— Match case when replacing: Perform the replacement taking into account
the uppercase and lowercase letters in the found text. Example: You need to replace
the word agreement with the word contract in the text of the document. In this case,
the word agreement can be written with both lowercase and uppercase letters (for
example, at the beginning of a sentence). Check the box Match case when replacing
so that the word agreement with a lowercase letter is replaced by the word contract
with a lowercase letter, and the word Agreement with a capital letter is replaced by

the word Contract with a capital letter.

Case is taken into account only for the first character in the found word.

4. Collapse the Parameters section by clicking .

To find data in a document, do the following:

1. Inthe Find field, enter the data to search for (see Figure 108).

2. Click a or press Enter.

- Find and Replace Q

‘ MyOffice] X E

Replace Replace All

Figure 108. Data for search

Matches will be highlighted in the text of the document and displayed as a list in
the Find and Replace pane (see Figure 109).

You can navigate through the matches in the list in the following ways:

— By left-clicking.

— Using the + Next Match and ~ Previous Match buttons above the list.

— Using the | and 1 keys. To do this, pre-select any match by left-clicking.
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The selected match is highlighted in contrasting yellow in the list line and in the text of the

document. The total number of matches and the sequence number of the selected match is shown by

the match counter above the list.

MyOffice products fully comply with the Russian legislation and are
included in the Unified Register of Russian Programs for Electronic
Computers and Databases, and can be used by organizations of various
sizes. The company pays great attention to data protection issues. The
company's largest shareholder is Kaspersky Lab, the world leader in
information security.

MyOffice is the only Russian office software which security has been
confirmed by certificates of the Federal Service for Technical and Export
Control (FSTEC) of Russia and the Russian Ministry of Defense.
MyOffice solutions can be used for processing confidential information
at critical infrastructure facilities, as well as in information systems with
increased information security requirements. The company's products are
intended for being used on the computer and server capacities of an
organization or a trusted partner, which ensures full control over your
own data.

=» Find and Replace Q

MyOffice X E

Replace witt
Replace Replace All
Parameters '

v oA Match 1 of 3

MyOffice products fully comply with the
Russian legislation and are included in the

My Office is the only Russian office software
which security has been confirmed by

the Russian Ministry of Defense. MyOffice
solutions can be used for processing

Figure 109. Found matches

The search parameters can be changed in while you work with matches. The list of matches

is updated automatically.

To replace the matches found in the document, follow these steps:

1. Inthe Replace with line (see Figure 108), enter the data to replace or leave the field empty

if you want to delete the found match.

2. Replace the matches with one of the following methods:

— Click Replace to replace the highlighted match.

— Click Replace All to replace all matches found at the same time. In the window with

the message “Replace all matches?”, click Replace.

To close the find and replace pane, do one of the following:

— At the top of the pane, click —».

— On the Sidebar, click Q Find and Replace.

— Press Esc.
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Table 7 below shows the keyboard shortcuts you can use to quickly move between elements

in the Find and Replace pane.

Table 7. Keyboard shortcuts

Action Windows macOS
keyboard shortcuts keyboard shortcuts

Open the Find and Replace pane Ctrl+F or Ctrl+H 32 Cmd+F
Search by specified value Enter Enter
Go to the next pane element Tab Tab
Go to the previous pane element Shift+Tab 1t Shift+Tab
Expand or collapse Parameters Space Space
Select a search area or filter Space Space
Click a button Space Space
Go to the next/previous match land 7 land 1
Go to the first match in the list Home Fn + «
Go to the last match in the list End Fn+—
Close the Find and Replace pane Esc Esc
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4.2.10 Delete text

To remove one or more characters from the text, use one of the following methods:

— Place the cursor after the characters you want to delete. Delete them by pressing
Backspace (Windows) or Delete (macOS) consecutively.

— Move the cursor to the characters you want to delete. Delete them by successively

pressing Delete (Windows) or Fn+Delete (macOS).

To delete a part of a word or a word, use one of the following methods:

— Place the cursor after the part of the word or words you want to delete. When using
Windows OS, press Ctrl+Backspace, when using macOS, press $#Cmd+Delete or
~=Option+Delete.

— Place the cursor to the part of the word or words you want to delete. When working in
Windows OS, press Ctrl+Delete, when using macOS, press $#Cmd+Fn+Delete or

~Option+Fn+Delete.

To delete some text pieces, do the following:
1. Select the desired text.
2. Press Delete or Backspace (Windows) or Delete or Fn+Delete (macOS).
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4.3 Text formatting

4.3.1 Non-printable characters

Non-printable characters are the formatting marks that are used to organize the content of a
document but are not displayed when printing. They are useful when editing a document to remove
mistakenly added formatting marks, for example, double spaces in the text.

To enable the display of non-printable characters, follow these steps:

1. In the Command menu, click View and select Non-Printable Characters

(see Figure 110).

View Share Subscription Help

Ruler Ctrl+Shift+R
Non-Printable Characters

Presentation View
Zoom L4

Toolbar L4

Figure 110. Non-Printable Characters command menu option

2. On the Toolbar, select the Paragraph section and click 91 Non-Printable Characters
(see Figure 111).

=v =Z === @~

|7
L4
T
I
4
Il
i}
£
o

Paragraph

Figure 111. Non-Printable Characters button
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Non-printable characters used in MyOffice Text are specified in Table 8.

Table 8. Non-printable characters

Example of character in text Meaning
Lorem-ipsum.dolor-sit-amet,.consectetur-adipiscing-elit,-se Space
labore.et.dolore.magna.aliqua..Ut-enim.ad. minim-veniam,.

Lorem-ipsumf| Paragraph mark

dolor-sit-amet,

consectetury

Lorem - ipsum-dolor-ssit - amet,»consectetur —» Tab

» eiusmod -» temporincididunt - ut -» labore

Lorem-ipsum./ Line break

dolor-sit-amet, o
consectetur,/

=, Page break
=
— Section break
'El
Anchor:
o The table for which you have
& configured text wrapping
e Image
e Shape
T Bookmark
4.3.2 Styles

Styles allow you to quickly apply the same formatting to different parts of the text throughout
the document, for example, use styles for headings of different levels, links, etc. MyOffice Text

allows you to use the preset styles, as well as the custom styles for text styling.

4.3.2.1 Style selection

The Normal style is used by default whenever you create a new document. You can change

the text style using the Quick Actions box or the Toolbar.

To change the style using the Toolbar, follow these steps:
1. Select the part of the text you want to change a style for:
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— To change the style for a single paragraph, place the cursor in it or select the whole
paragraph.
— To change the style of multiple paragraphs, select all the paragraphs.
2. On the Toolbar, select the Styles section and select the desired style from the drop-down
list. Or click the =* button and select the desired style from the drop-down list
(see Figure 112).

AaBbCc AaBbCcl AaBbCcDi AaBbCcDc |':'|
Heading 1 Hrmine Lo i T L e L 4

4 5 AaBbCcDdEeF{GgHhIJjKkL

Morma

AaBbCcDdEeFfGgHhIiJjl

Heading 1

AaBbCcDdEeFfGgHIIJjKk

Heading 2

AaBbCcDdEeFfGgHhILJjJKkLIM

Heading 3

AaBbCcDdEeFfGgHhLJjKkLIMm

Heading 4

AaBbCcDdEeFfGgHIJTjKKLIMmN

Heading 5

+ Create New Style

Figure 112. List of styles
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To change the style using the Quick Actions box, do the following steps:
1. Select the part of the text you want to change a style for:
— To change the style for a single paragraph, place the cursor in it or select the whole
paragraph.
— To change the style of multiple paragraphs, select all the paragraphs.
2. Open the Quick Actions box in one of the following ways:

— In the Help menu, click Quick Actions (see Figure 113) or press Ctrl+/.

Help F1
Quick Actions Ctrl+/
Check for Updates...
About...

Figure 113. Quick Actions command menu option

— Press Ctrl+/ (Windows OS) or $¢ Cmd+/ (macOS).
3. Inthe Quick Actions box (see Figure 114), select the style you want to apply using one of

the following steps:
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+~ Normal
Heading 1
Heading 2
Heading 3
Heading 4
Heading 5
TITLE
Subtitle
Header and Footer

Footnote

Figure 114. Quick Actions box

—  Start typing style name in the search field. When the desired style is displayed in the
search results, left-click the style line or select the style line using the | and 1 keyboard
keys and press Enter.

— Scroll down the list of commands till the end. In the style section, select your preferred

style.
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4.3.2.2 Create a new style

MyOffice Text allows you to create a style based on the formatting of the text. You can select
the text with desired formatting or just place thecursor on it to create a style.

The new style is created with the preset name "Style 1", "Style 2", and so on.

To create a style, do the following steps:

1. Apply the formatting to a word or text (see Figure 115).

2. Select a word or fragment or place the cursor on it.

3. On the Toolbar, select the Style section and click the “*= button.
4

In the lower part of the drop-down list, click the Create New Style button.

~ = = = B= 1 ~ P
===8'% AaBbCcl AaBbCc AaBbCcl AaBbCcDi AaBbCcDc o]
. = 5= H v qJ Morma Heading 1 Hp=dline Hommdine = Hommddine = 1
raph Styles -
2 3 4 5 6 7 8 g a AaBbCcDdEeF{fGgHhIJJKkL.

MNarma
AaBbCcDdEeFfGgHhIiJjl
Heading 1

MyOffice Standard is an office suite for working with document

computers, MyOffice Standard does not require any Internet connecti  AaBbCcDdEeFfGgHhIJjKk

Heading 2
AaBbCcDdEeFfGgHIiTjKKILIM
Heading 3

AaBbCcDdEeFfGgHhLTjKKLIMm
Heading 4

AaBbCcDdEeFfGgHOIJjKKLIMmN

Heading 5

| + Create New Style

Figure 115. Create a new style
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The newly created style will appear in the drop-down list (see Figure 116).
You can create styles based on numbered headings (1., 2., 3. ...). When you create such

a style, the numbering will also be included in the style.

AaBbCcDdEeFfGgHiTjKKLIMmN

Heading 5

AABBCCDDEEFFC

AaBbCcDdEeFfGgHhIiJjKkLIMmNn

Subtitle

AaBbCcDdEeFfGgHhlJj Kk LIMmNnOoPpQ

Header and Footer

AaBbCcDdEeFfGgHhIITjKkLIMmMNnC

Footnote

AaBbCcDdEe FfGgHhIKkLIMmNnCoPpC

+ Create Mew Style

Figure 116. Custom style
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4.3.2.3 Edit a style

You can change the formatting options for any style manually. Follow these steps:
Select the text where the style is applied.

Change the style as needed (see Figure 117).

On the Toolbar, select the Style section and click the *** button.

E A

In the drop-down list, place the cursor on the current style name and click
=2 Update Style to Match Selection (see Figure 117).

The changes you make to a style are automatically applied to all text fragments where this

style is applied.

=v = === [T~ -
AaBbCcL AaBbCc AaBbCcl AaBbCcDi = Assbcendee | (]
Nie w = 4= :E[ w C” Marmal Heading 1 Hp=dinen Unoelinme 3 Lérilnd —
Paragraph Styles -
: 1 z 3 4 5 6 7 ] ] 10 11 AaBbCcDdEeFfGgHMiJjKKLIMmN
Heading 5
Title
MyOffice Standard s an office suite for working with documents, mail,
MyOffice Standard does not require any Internet connection. AaBbCcDdEeFfGgHhRIJjKkLIMmNn

Subtitle

AaBbCcDdEeFfGgHhliJjKkLIMmNnOoPpQ

Header and Footer

AaBbCcDdEeFfGgHRIIIJKkLIMmNnC
Footnote

AaBbCeDdEerFfGgHhIUKkLIMmNNOoPpC
Stylel = L\gl

+ Create New Style

Figure 117. Edit and delete style buttons
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4.3.2.4 Delete a style

You can only delete the custom styles. Follow these steps:

1. Select the text where the style is applied.

2. On the Toolbar, select the Style section and click the **= button.

3. In the drop-down list, place the cursor on the current style name and click [ Delete Style
(see Figure 117).

Once the style is deleted, the Normal style settings are applied to all text fragments formatted

in the custom style.
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4.3.3 Fonts

By default, the XO Thames font is used when creating a document in MyOffice Text

application.

To quickly change the font, do the following:

1.
2.

Select the desired text.

On the Toolbar, in the Font section (see Figure 118), click the field with the name of
the current font.

Start typing the name of the desired font. The drop-down list will display a list of fonts
matching the search conditions.

Select the desired font using the mouse or the keyboard keys:

— Click the font name with the left mouse button.

— Select the font name using the keyboard keys | and 1 and press the Enter key.

v & [ o O v| 14 v AT

Q X0 Oriel b

X0 Oniel Condensed

Figure 118. Find a font

To select a font from the full list of fonts, follow the steps below:

1.
2.

Select the desired text.

On the Toolbar, select the Font section and click + to the right of the current font name
(see Figure 119).

In the drop-down list, select the desired font using the mouse or keyboard keys:

— Left-click the font name.

— Select the font name using the keyboard keys | and 1 and press the Enter key.
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| XO Thames v] 4 v A

~
v X0 Thames e

Cormorant

PT Astra Sans

PT Astra Serif

PT Sans

PT Serif

X0 Caliburn

X0 Courser

X0 Oriel

X0 Oriel Conde nsed

X0 Tahion

Figure 119. Full list of fonts

It is recommended to use XO family fonts to preserve the formatting of the document when

opening it in other operating systems.
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4.3.4 Font size

To change the font size, do as follows:
1. Select the text you want to change the size of.
2. On the Toolbar, click the arrow + to the right of the current font size (see Figure 120).

3. In the opened list, select the desired font size.

You can also type in any size you want. Simply follow these steps:
1. On the Toolbar, select the current font size.
2. Enter the desired size. Use a dot (.) as the delimiter for fractional value. For example: 21.5.

3. Press Enter.

i XO Thames vi[1|v] A~ A

Figure 120. Selecting the font
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To increase the font size by one point, follow the steps below:

1. Inthe Format menu, select Font > Increase Font Size (see Figure 121).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space ‘é [){DThames |v]
Font * B Bod Ctrl+B
Alignment 4 T Italic Ctrl+|
Rotate Text ¥ U Underline Ctrl+U

b
Image A~ Decrease Font Size
Table »

A" Increase Font Size

Figure 121. Commands to increase and decrease font size

2. On the Toolbar, select the Font section and click A" Increase Font Size (see Figure 122).

XO Thames v 14 v | AT AT
B I UAT - Av &v
Font

Figure 122. Increase and Decrease Font Size buttons

To decrease the font size by one point, follow the steps below:
1. Inthe Format menu, select Font > Decrease Font Size (see Figure 121).

2. Onthe Toolbar, select the Font section and click & Decrease Font Size (see Figure 122).
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4.3.5 Text formatting

MyOffice Text allows you to format text differently to emphasize and distinguish it from

the rest of the document content.

Table 9 shows the text formatting options with the corresponding commands and Toolbar

buttons:

Table 9. Text formatting

Text formatting

Command
menu

Button of Font
section, Toolbar

Keyboard shortcut
(Windows)

Keyboard
shortcut
(macOS)

Bold

Format >
Font > Bold

B

Ctrl+B

¥Cmd+B

Italic

Format >
Font > Italic

Ctrl+I

$¥Cmd+I

Underline

Format >
Font >
Underline

Jan

Ctrl+U

#¥Cmd+U

ALL CAPS

Format >
Font > All
Caps

AB

Ctrl+Shift+A

{Shift+:Cmd+A

Strikethrough

Format >
Font >
Strikethrough

-

Subscript

Format >
Font >
Subscript

s X,

Ctrl+=

#¥Cmd+=

Superscript

Format >
Font >
Superscript

Ctrl+Shift+=

{Shift+3¥Cmd+=

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

132




MyOffice

4.3.6 Font color

To change the font color of text, follow these steps:

1.

Select the text for which you want to change the font color:

— To change the font color in a single word, place the cursor in the word or select

the entire word.

— To change the font color in a piece of text, select it in its entirety.

— To change the font color for text located in one cell of a table, select that cell or select

all text in that cell.

— To change the font color for text located in multiple cells, columns, or rows, select

those table elements.

— To change the font color for all text in a table, select the entire table.

To select the last color that was applied to the font, on the Toolbar, select the Font section and

click i Text Color (see Figure 123).

X0 Thames w14
B I U AB
Font

v AT AT =

ER 2- =

Theme Colors:

EEEEEE

T
Tl
I

L4

Standard Colors:
Recent Colors:
Mare Colars... ﬂ

Figure 123. Text Color button and color selection pane
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1. To select a different font color, click the arrow to the right of the & Text Color button.
2. Inthe color selection pane that opens, specify the font color in one of the following ways:
— Choose a color from one of the color sets provided.
— Specify the color code manually.

— Copy the color with an eyedropper.

4.3.6.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 123):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The font of the text will be colored in the selected color.

4.3.6.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:

1. Click More Colors (see Figure 123).

2. In the Select Color window (see Figure 124) that appears, specify the desired color as a
HEX code or in RGB format.

3. Click OK.
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Select Color X
Hex: Preview:
Red: Green: Blue:
o - o T o

Figure 124. Select Color window

The manually specified color will be added to the Recent Colors set (see Figure 123) and

checked. The color selection pane will close. The font of the text will be colored in the selected color.

4.3.6.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in

the main window's workspace (see Section 3.3.5) and apply that color to the font of the selected text.

The eyedropper is disabled in header and footer editing mode (see Section 4.10.2).

To copy a color using the eyedropper, follow these steps:

1. Click & Eyedropper (see Figure 123). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color you want to apply to the selected text. For more accurate
color selection, refer to the area to the right of the cursor. It displays the color of the pixel
that the cursor is currently hovering over.

3. Left-click the color.

The font of the selected text is colored in the specified color, and the cursor returns to its
standard appearance. The specified color is added to the Recent Colors set (see Figure 123) and
checked in the color selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.
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4.3.7 Highlight color

When working on a document, you can highlight certain text fragments in different colors
(like when you use a highlighter) to make them more visible compared to the rest of the document.

To highlight text, perform the following actions:

1. Select the text you want to highlight.

2. To select the last color you used to highlight text earlier, on the Toolbar, in the Font

section, click £ Highlight Color (see Figure 125).

3. To select a different color for text highlighting, on the Toolbar, in the Font section, click

the arrow to the right of 4 Highlight Color.

Subscription  Help

v 5 XO Thames vl 14 v AT AT = .

¢ BIUMT - AvEY =~

Font
lll III

Recent Colors:

T™
[l

4
[l

<

No Color

Figure 125. Highlight color button

4. Select the desired color in the provided palette or in the Recent Colors block. This color
block is displayed if at least one color from the palette was previously used to highlight

text. The Recent Colors block can display a total of one to eight of the most recently used

colors.
The selected color will be checked, and the text will be highlighted in this color.

To remove the highlighting of the text, perform the following actions:
1. Select the text that you want to remove highlighting from.

2. On the Toolbar, select the Font section and click the arrow to theright of

the © Highlight Color button.

3. Inthe window that opens, select No color.
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4.3.8 Alignment and spacing

You can use adjustable alignments, spacings, and indents to organize the text and separate its
elements according to your preferences.
To change these settings when you create a file, select the respective commands, and run them.

If you want to modify the existing file, select the text you want to change the settings of.
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4.3.8.1 Horizontal alignment

To align the content of the document horizontally, do the following:

1. Select the text fragment that you want to align.

2. Use one of the commands described in Table 10.

Horizontal alignment is applied within the indents specified for the paragraph being edited.

Table 10. Horizontal alignment

> Justify

Text alignment Command menu Toolbar button, Keyboard
Keyboard shortcut
Paragraph shortcut ( 0S)
section {(Windows) e
Align text left l:(}f;ltat > Alignment = Ctrl+L seCmd+L
Center text Format > Alignment = Ctrl+E seCmd+E
> Center
Align text right l:(;:;lﬁ: > Alignment = Ctrl+R Cmd+R
Justify text Format > Alignment = Ctrl+J seCmd+J

Horizontal alignment is performed within the margins specified for the paragraph being edited

(see Section 4.3.8.5).

If the text in the cell is expanded (see Section 4.3.9), the horizontal alignment is performed

according to its position: the text is moved relative to the upper and lower borders of the cell.
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4.3.8.2 Vertical alignment

Vertical alignment is only applied to the table contents. The alignment tools are displayed on
the Toolbar (see Figure 126) when the cursor is positioned in the table or the entire table or a table

element is selected.

To align text in a table vertically, follow these steps:

1. Select the element you want to align.
— To align the contents of one cell, select the cell or place the cursor in this cell.
— To align the contents of multiple cells, columns, or rows, select these elements.
— To align all the contents of a table, select the table entirely.

2. On the Toolbar, select the Paragraph section and click the T button.

3. Click one of the following buttons:

_— Align to Top: Aligns the contents along the top edge of the cell.

L
— 7 Align to Middle: Centers the contents in the cell.

— Align to Bottom: Aligns the contents along the bottom edge of the cell.

v?le\TIIv ﬁvz
EF oo | T HYE

Paragraph Table

- —_—
— W
[rpu—

me
|

1.—
— W

Figure 126. Vertical alignment tools

If the text in the cell is expanded (see Section 4.3.9), the vertical alignment is performed

according to its position: the text is moved relative to the left and right borders of the cell.
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4.3.8.3 Line spacing

Line spacing is the space between each line in a paragraph. The default spacing for all text
is 1.

MyOffice Text allows you to change the line spacing for all text, as well as for individual
paragraphs. You can use predefined line spacing options or set your own.

If you select a predefined value, the line spacing is equal to the product between the font size
and the specified value. For example, if you use 12 pt font and double line spacing for the paragraph,
the line spacing in the paragraph is 24 pt (12 pt x 2).

To set a predefined line spacing:

1. Select the text fragment you want to format.

2. On the Toolbar, select the Paragraph section and click the button which displays

the current line spacing. For example: (AR (see Figure 127).

3. In the list that expands, select a preset value.

v =Z = == @y
- Lx) AaRhcCel - AaBl
Y= — 5= ( g— Eding
2= V= S :E[ v L1 Single
Paragraph .
1 ' 1 2 Ims 115 5
v = g
s 15
12  Double
I Custom Line Spacing...

Figure 127. Line spacing
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To set a custom line spacing:

1. Select the text fragment you want to format.

2. On the Toolbar, select the Paragraph section and click the button which displays
&8

the current line spacing. For example: iR (see Figure 127).

3. In the list that expands, click Custom Line Spacing.
4. In the Custom Line Spacing window that appears (see Figure 128), set the method for
calculating the spacing manually, using one of the following parameters:

— Multiply: Sets the line spacing, which increases or reduces according to the specified
multiplier. The multiplier 1.00 corresponds to a single line spacing. Select
the multiplier greater than 1.00 to increase the spacing. For example, setting a
multiplier to 1.2 will increase the spacing by 20%. Select the multiplier of less than
1.00 to reduce the spacing. For example, setting a multiplier to 0.7 will reduce
the spacing by 30%.

— Exact: Sets a fixed spacing equal to the value specified in the field to the right.
The value is expressed in points (pt). Unlike the predefined spacing, the fixed spacing
is not changed when the font is reduced or increased.

— At Least: Sets the minimum allowed spacing equal to the value specified in the field
to the right. The value is expressed in points (pt). If the lines contain characters of
different height (for example, superscript and subscript characters) or different font
sizes, the value of the spacing between the lines is calculated automatically to fit

the larger text.

Custom Line Spacing *

H

Multiply v 1.15 "

o JEE

Figure 128. Custom Line Spacing window

5. In the field to the right, set the numeric value for the selected parameter.

6. Click OK.
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4.3.8.4 Character spacing

The character spacing allows you to set the space between the characters being entered into
the text. You can choose between Condensed, Normal or Expanded character spacing.

By default, the Normal character spacing style is applied.

The type of character spacing can be selected using the Command menu or the Toolbar.
To select the character spacing using the Command menu:

1. Select the text fragment where you want to change the character spacing.

2. In the Format menu, select Font and then Character Spacing (see Figure 129).

3. Inthe opened menu, select the desired character spacing type.

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space ‘% XO Thames vl 14 v A A+
Font * B Bod Ctrl+B
Ali t L4 i ﬁ v &
ignmen T ltalic Ctrl+1
Rotate Text Y U Underline Ctrl+U
4
Image A~ Decrease Font Size
Table 4

A" Increase Font Size

< Strikethrough

X* Superscript Ctrl+Shift+=
Xz Subscript Ctrl+=
AB All Caps Ctrl+Shift+A
Character Spacing » 4B Condensed

AB  Normal

4B Expanded

Figure 129. Format menu
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To change the character spacing using the Toolbar:

1. Select the text fragment where you want to adjust the character spacing.
2. Inthe Toolbar, select Font and click the “*=button (see Figure 130).
3. Select the desired character spacing:

- EE’: Condensed

'&f.’: Normal

-1 Expanded

% X0 Thames v 14 v AT AT

B I UMTLw Av &~
Fon XE ><i %E: AB A

_—

e

Figure 130. Selecting the character spacing
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4.3.8.5

Paragraph spacing and indents

To change the settings of one paragraph, place the cursor anywhere in that paragraph or select

the entire paragraph. To change the settings of several paragraphs, select all the paragraphs you want

to adjust.

To adjust the spacings and indents for the selected paragraphs, follow these steps:

1. On

the Toolbar, select the Paragraph section and click E[Paragraph Settings

(see Figure 131).

2. In the window that appears, enter the required numerical values for the following

parameters:

First Line: The distance from the left margin of the document to the first line of
the paragraph.

Left Indent: The distance from the left margin to the paragraph.

Right Indent: The distance from the right margin to the paragraph.

Before: The distance between the current and previous paragraph.

After: The distance between the current and next paragraph.

You can use the rulers or the Paragraph Settings window (see Section 4.11.1) to specify

the margins in the document (see Section 4.10.1).

=y = = = = [Low
— AaBbCcIl AaBbC«
l'E v | €= 4= :E'[ w q1 *'| MNormal Heading 1
Paragraph L‘x’
: 1 Paragraph Settings, in g 10
First Line 0.00 -
Left Indent 0.00 )
Right Indent 0.00 -
Befare 0.00 -
After 0.00 -

Figure 131. Paragraph settings
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To quickly increase the paragraph indent by 1.25 inches, use one of the following steps:
— In the Command menu, click Format, point to Alignment, and then «click

Increase Indent (see Figure 132).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space 1‘% XO Thames

Font » 2™ ™ ™ 1 A Dy
Alignment P = Left Ctrl+L
Rotate Text Y = Center Ctrl+E
Image » = Right Ctrl+R
Table P = lJustify Ctrl+)

*
|

= Increase Indent

€= Decrease Indent

Figure 132. Format menu

— On the Toolbar, select the Paragraph section and click “= Increase Indent

(see Figure 133).

Paragraph

Figure 133. Increase and Decrease Indent buttons

To quickly decrease the paragraph indent by 1.25 inches, use one of the following steps:
— In the Command menu, click Format, point to Alignment, and then click
Decrease Indent (see Figure 132).

—  On the Toolbar, select Paragraph and click == Decrease Indent (see Figure 133).

You can also increase the paragraph indent by 1.25 inches using Tab. To decrease
the paragraph indent, press Backspace (Windows) or Delete (macOS). If you want to change
the indent for a single paragraph, select the entire paragraph or place the cursor strictly at

the beginning of the paragraph.
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4.3.9 Rotate text

The text in the table cells can be rotated 90 degrees to the left or right.
To rotate text, do the following:
1. Specify where you want to rotate the text:
— To rotate text in a cell, select the cell, the text fragment in the cell, the whole text in
the cell, or place the cursor in it.
— To rotate text in multiple cells, columns or rows, select these table elements
(see Section 4.4.5).
— To rotate thetext in  thewhole table, select thewhole table
(see Section 4.4.6).
2. Open the text rotation sub-menu in one of the following ways:

— In the Command menu, select Format > Rotate Text (see Figure 129).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space % XO Thames | w
Font

U
Alignment » Q B I =
Rotate Text 3 A;!; MNone (0°}
Image » 21 Rotate Left 90°
Table » l& RotateRight 90°

Figure 134. Rotate Text command menu option

2
— On the Toolbar, select the Paragraph section and click ¥ Rotate Text
(see Figure 135).

=y =~ T v v Lv H
:1Ev "E"EE[V‘;}‘V CI-I-‘HHV@
Paragraph %

AR None (0

DT Rotate Left 80°

|E  Rotate Right 90°

Figure 135. Rotate Text button

3. Select the direction to rotate the text: Rotate Left 90°, Rotate right 90°.
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The command is run for all the text located in a cell. There cannot be several fragments with

different text rotation direction in one cell.

To return to the standard cell text display (0° rotation angle), follow these steps:
1. Specify these cells as described above.
2. Run the command in one of the following ways:

— In the Command menu, select Format > Rotate Text > None (0°) (see Figure 135).

e
— On the Toolbar, in the Paragraph section, click " Rotate Text. In the sub-menu

that opens, select None (0°) (see Figure 135).
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4.3.

10 Lists

MyOffice Text allows you to create bulleted and numbered lists. Each new item in bulleted

lists is marked with a bullet. In numbered lists, it is marked with a number or letter.

4.3.

10.1 Create a list

To create a list, follow the steps below:

1.

Select a part of the text you want to convert to a list. Or place the cursor on an empty line

where you want to start the list.

On the Toolbar, select the Paragraph section and click the arrow to the right

of := Bulleted List (see Figure 136) to create a bulleted list. Or click the arrow to the right

of the ."= Numbered List (see Figure 137) to create a numbered list.

In the list that expands, select a style of the list.

vy ATAT =2y = = = = I
|-— - AaRhC o
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L =] | |
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n | | i
L =] | |
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B o o | |
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| | | | " o
- - o

Figure 136. Adding a bulleted list
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Figure 137. Adding a numbered list

To quickly create a list on an empty line, use the following methods:

— To create a numbered list, type the first level symbol of the list. For example, 1. or a).
Press Space. To create a numbered list where the items on the first level are expressed in
Roman numerals, type the capital letter I and press Space.

— To quickly start the bulleted list shown on the left side of Figure 138, type *. Press Space.

Figure 138. Bulleted list

— To quickly start the bulleted list shown on the right side of Figure 138, use one of the
following methods:
e Type (-) Space.
e Type Space (-) Space.
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MyOffice Text remembers the last selected style for the bulleted and numbered list.
To quickly create a new list in the same style as the previous one, follow the instructions
below:
1. Select a part of the text you want to convert into a list or place the cursor on an empty line
where you want to start the list.
2. Onthe Toolbar, select the Paragraph section and click := Bulleted List (see Figure 136)
to create a bulleted list. Or click ;"= Numbered List (see Figure 137) to create a numbered

list.

4.3.10.2 Copy and paste a list

You can copy and paste lists from the clipboard within one document or between
MyOffice Text documents.

To copy and paste a list correctly, follow the steps below:

1. Enable the display of non-printable characters (see Section 4.3.1).

2. Select the list from the beginning rather than from the end, including the last paragraph

character.

4.3.10.3 Continue a list

You can easily continue the numbering of the previous list in the document.

Use the following steps to proceed:

1. Right-click on any element of the current list.

2. Click Continue numbering in the shortcut menu.

Once the Continue numbering command is applied, all levels of the current list inherit

the style of the previous list.
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4.3.10.4 Change the nesting level

You can change the list nesting level using the Command menu, Toolbar buttons or keyboard

shortcuts.

To change the nesting level of a list item using the Command menu or Toolbar:

1. Place the cursor anywhere in the paragraph to be changed or select the whole paragraph.

2. Change the nesting level as follows:

— To increase the nesting level: In the Command menu, click Format, point to

Alignment, and then click Increase Indent (see Figure 139). Or, on the Toolbar,

select the Paragraph section and click = Increase Indent (see Figure 140).

— To decrease the nesting level: In the Command menu, click Format, point to

Alignment, and then click Decrease Indent (see Figure 139). Or, on the Toolbar,

select the Paragraph section and click == Decrease Indent (see Figure 140).

Format Tools

Clear Formatting

Font
Alignment

Rotate Text

Image
Table

Figure 139. Increase and Decrease Indent commands
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Ctrl+)
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Figure 140. Increase and Decrease Indent buttons

To modify the nesting level using the keyboard, proceed as follows:

1. Place the cursor before the first word in the current paragraph or select the entire
paragraph.

2. Change the nesting level:
— To increase the nesting level, press Tab.

— To reduce the nesting level, press Backspace (Windows) or Delete (macOS).

To change the nesting level of the list, located in the table, use the Command menu or
the corresponding buttons on the Toolbar. Using the Tab key in a table does not change a

nesting level but move to the next table cell.

4.3.10.5 Convert a list to text

To remove list formatting, follow the steps below:

1. Select the list items you want to remove from the list.

2. On the Toolbar, select the Paragraph section and click the button which corresponds to
the current  list  type: ‘= Bulleted List or .= Numbered List
(see Figure 136 and Figure 137).

3. In the list that expands, select None.
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4.3.11 Copy and insert formatting

In MyOffice Text, you can copy the formatting from one part of a document to another:

— The formatting copied can be applied to one or multiple elements of a document.

— The formatting copied to the clipboard can also be used in MyOffice Spreadsheet.
Formatting copied to the clipboard can be used for pasting in the MyOffice Spreadsheet.

application.
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4.3.11.1 Formatting basics

Depending on the selected item, you can format:
— Paragraph

— Text

— Paragraph and text

— Cell

Table 11 specifies how the formatting is copied and applied.
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Table 11. Formatting basics

When you copy

When you insert

Result

The cursor is positioned, or
the entire paragraph
(paragraphs) is selected

The cursor is positioned

Formats the paragraph or the first
selected paragraph

A paragraph is partially selected

Text formatting

The entire paragraph
(paragraphs) is selected

Formats the paragraph and text

Several paragraphs are partially
selected

Paragraph formatting

A paragraph is partially
selected

The cursor is positioned

No formatting

A paragraph is partially selected

The entire paragraph
(paragraphs) is selected

Several paragraphs are partially
selected

Formats the text from the first
selected character

The cursor is positioned

A paragraph is partially
selected

The entire paragraph
(paragraphs) is selected (up to
the paragraph sign)

A spreadsheet cell is selected

Formats the paragraph and text in
the selected cell

Formats the text in the selected cell

Formats the paragraph and text

A spreadsheet cell is selected

A spreadsheet cell is selected

Formats the cell, paragraph, and
text

The cursor is positioned

Paragraph formatting

A paragraph is partially selected

Text formatting

The entire paragraph
(paragraphs) is selected

Formats the paragraph and text

Several paragraphs are partially
selected

Paragraph formatting

A row or column is selected

Formats the cell, paragraph, and
text

A row or column is selected

A row or column is selected

Formats the cell, paragraph, and
text from the upper left cell in
the copied row or column.

Formats the row or column
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4.3.11.2 Copy and insert formatting

You can copy the formatting using:

1.

Command menu

2. Keyboard shortcuts

3. & Copy Formatting button on the Toolbar

To copy the formatting using the Command menu or a keyboard shortcut, perform

the following actions:

1.

Select thepart of thedocument you want to copy the formatting from
(see the Table above).
Copy the formatting using one of the following methods:

— In the Edit menu, select Copy Formatting (see Figure 141).

Edit Insert Format Tools View Share

= Unde Ctrl+Z
" FRedo Ctrl+Y
o Cut Ctrl+¥
Copy Ctrl+C
[ Paste Ctrl+V
Paste Text Only
Paste from Clipboard r
£ Copy Formatting Ctrl+Shift=C
Paste Formatting Ctrl+5Shift+¥

Figure 141. Edit menu

—  Press Ctrl+Shift+C/ {iShift+3Cmd+C.

To apply the formatting to one part of the document, do the following:

— Select the part of the document you want to copy the formatting to (see the table
above).

— In the Edit menu, select Paste Formatting (see Figure 141) or press Ctrl+Shift+V/
{Shift+3Cmd+ V.

To apply the formatting to multiple elements in the document, select these elements one

by one and apply the formatting as described above.
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A

To format one element of a document using the =i Copy Formatting button, follow
these steps:
1. Select the part of the document you want to copy the formatting from (see the Table
above).
2. On the Toolbar, select the Edit section and click & Copy Formatting.
3. Select thepart of thedocument you want to copy the formatting to

(see the Table above).

Tools View Share Subscription Help
r 0O B v||& X0
r | D C Q B

Edit Font

Figure 142. Recent formatting
A

To format multiple elements of a document using the &1 Copy Formatting button, follow
these steps:
1. Select thepart of thedocument you want to copy the formatting from

(see the Table above).

2. On the Toolbar, select the Edit section and double-click = Copy Formatting.

The button will change to )

3. Select the parts of the document you want to copy the formatting to (see the Table above)

and apply the formatting one by one.

To exit the multiple elements formatting mode, do one of the following:

— On  the Toolbar, select the Edit section and click theé button.

The button will change to é

—  Press Esc.
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4.3.11.3 Formatting history

Formatting copied to the clipboard history is saved and can be applied later.

To open the formatting history, follow these steps:

1. On the Toolbar, select the Edit section and press the arrow to theright of
the & Copy formatting button (see Figure 143).

2. In the opened drop-down list, select the format you want. The most recent formatting is
on the top of the list.

3. Select the part of the document you want to copy the formatting to as described in

Section 4.3.11.1.

x D) P v fj}v XOThames |~ 14 v A” AT
O C copy text
Edit

format text

cut text

Figure 143. Recent formatting
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4.3.12 Clear custom formatting

You can apply styles or custom formatting to the text.

Style formatting is the design of text elements of the same type (titles, main text, examples,
etc.) using styles. A style is a set of formatting parameters, including font type and size, text
alignment, paragraph indents, character spacing, etc. For example, the Normal style is used as the
main text style. When you create a new document, this style is applied by default to the entire text.

Custom formatting involves the use of various formatting parameters in text fragments and
paragraphs. Custom formatting is used along with style formatting.

To clear custom formatting and keep text style formatting only, do the following:

1. Select the text you want to delete the formatting of.

2. Clear the formatting using one of the following methods:

— In the Format menu, select Clear Formatting (see Figure 144).

Format Tools View Share Subsc

Clear Formatting Ctrl+5Space

Font »
Alignment »
Rotate Text 4
Image 4
Table 4

Figure 144. Clear Formatting command menu option

— On theToolbar, select theEdit section and click <& Clear Formatting
(see Figure 145).

Edit

Figure 145. Clear formatting button

—  Press Ctrl+Space in Windows or *Ctrl+\ in macOS.
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4.4 Tables

4.4.1 Insert a table

You can insert a table using the Command menu or the Toolbar.
To insert a table using the Command menu:
1. Place the cursor where you want to insert a table.

2. In the Insert menu, select Table (see Figure 146).

Insert Format Tools  Wiew  Share

[~ Image..
Text Box

(] Shape »

EH Table...

Figure 146. Table command menu option

3. Inthe Insert Table window (see Figure 147), specify the number of columns and rows in

the future table and click OK.

Insert Table >

Figure 147. Insert Table window
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To insert a table using the Toolbar:
1. Place the cursor where you want to insert a table.

2. Insert the table in one of the following ways:

— On the Toolbar, select the Insert section and click the @ Table button
(see Figure 148). Select the number of rows and columns you want your future table

to contain and click with the left mouse button.

L LS
AaBbCcl ... [___], @ v v

Heading 3

Select Table Size

Figure 148. Table button
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— On the Toolbar, select the Insert section and click the === button (see Figure 149).

In the displayed pane, place the cursor on the @ Table button. Select the number of

rows and columns you want your future table to contain and left-click.

-7 = AaBbCcD .. [ [ (@) 5 -
&= 5= _‘E[ - C|'|' Heading 1 4
Styles 4 image.. ~
10 11 12 13 14 15 16 17 Text Box
6] Shape > Q
[==2] Table... [ >
@ Equation...
Special Characters >
'H Page Break
= Section Break
Page Numbers...
@ Header and Footer
=:  Table of Contents
Select Table Size
7 Link...
;_,] Cross-Reference...
|:] Bookmark...

Figure 149. Insert a table
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4.4.2 Insert rows

New rows are inserted above or below the specified row.

To add new rows, follow these steps:

1. Select the row above or below which you want to insert a new row. If you want to insert
more than one row, select as many rows as you want to insert in the table. For example, if
you want to insert two rows, select the two rows. To run a command, you can select rows
entirely as well as individual cells or cell ranges.

2. Insert rows in one of the following ways:

— In the Format menu, select Table > Insert Row Above or Insert Row Below

Command menu item (see Figure 150).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space é - XOThames |v| |14 |v| A- A+
Font L4
J soe AL £

Alignment » & B I U - -
Rotate Text » Font
Image »
Table ¥ ™% Insert Row Above Alt+A

& Insert Row Below Alt+B

Figure 150. Format menu

—  On the Toolbar, select the Table section and click TH Insert Row Above or
& Insert Row Below (see Figure 151).

SvEHE | ™IP|B B H
H v @ Ed ¥ o )

Table

Figure 151. Table section of the Toolbar
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— Right-click anywhere on the selected range and run the Insert Row Above or
Insert Row Below command from the context menu.
— Press Alt+A / ~ Option+A to insert a row above or Alt+B / ~= Option+B to insert a

row below.
To quickly insert a row below the desired row, do the following:

1. Select any cell in this row.

2. Press Enter.
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4.4.3 Insert columns

New columns are inserted to the left or to the right of the specified column.

To quickly add new columns, perform the following actions:

1. Select the column to the right or left of which you want to insert a new column. If you

want to insert multiple columns into your table, select the same number of columns. For

example, if you want to insert two columns into your table, select two existing columns.

You can select entire columns, a cell or cell ranges.

2. Ins

ert the columns in one of the following ways:

In the Format menu, select Table > Insert Column to the Left or Insert Column to

the Right (see Figure 169).

Format Tools View Share Subscription Help
Clear Formatting Ctrl+Space % - XOThames |v| |14 |v| A™ A+
Font 4
o ¢ B I U L&~
Alignment » -
Rotate Text 4 Fort
Image »
Table P B Insert Row Above Alt+A
& Insert Row Below Alt+B
E Insert Column to the Left Alt+L
g Insert Column to the Right Alt+R

Figure 152. Format menu

— On the Toolbar, select the Table section and click the E Insert Column to the Left

or ﬂ Insert Column to the Right (see Figure 151).

SvEHEH mIm™ G B
M v @ BEAHE < ‘

Table

Figure 153. Table section of the Toolbar
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— Right-click anywhere on the selected range and select the Insert Column to the Left
or Insert Column to the Right command from the context menu.
— Press Alt+L / ~= Option+L to insert a column to the left or Alt+R / ~= Option+R to

insert a column to the right.
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4.4.4 Edit table contents

To enter or change data in a table cell, perform the following steps:

1. Switch to cell editing mode using one of the following methods:
— To enter data in an empty cell, select it with one or two mouse clicks.
— To edit data in a cell, select it with a double-click.
— To overwrite data in a cell, select it with a single click.

2. Enter/edit data in a cell.

3. To exit cell editing mode, click anywhere in the document outside of the table.

When typing text and numbers into a cell, its width remains the same, data are transferred to
the next line inside the current cell, and the cell height may automatically increase.

When you insert an image into a table, the image is automatically scaled to the column width,
and the cell height may be increased to contain the image.

Y ou can move between the cells of the table by pressing the «<—, 1, |, — keys on the keyboard.
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4.4.5 Select cells

4.4.5.1 Select a cell

To select a cell, click on it with the left mouse button. The selected cell will be colored blue.
To select a cell in the table where the cursor is positioned, do the following:
1. Click anywhere in the document outside of the table.

2. Click the cell you want to select.

4.4.5.2 Select cell range

To select a random range of cells, use one of the following methods:

— Move the cursor to the first cell in the desired range. Hold down the left mouse button and
drag the cursor to the last cell of the range. Release the left mouse button.

— Select the first cell in the desired range. Hold down the Shift key and select the last cell

in the range.

You can select a range in any direction of rows or columns,

Some cell range selection examples are shown on Figure 154-Figure 156.

K

Tk

Figure 154. Select a horizontal cell range

]

T

‘ S —

Figure 155. Select a vertical cell range
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|

—

——

Figure 156. Select a diagonal cell range

4.4.6 Select a row or column

To select a single column or row, follow the steps below:
1. Move the mouse cursor over the upper border of a column or the left border of a row so
that the cursor takes the following form: 4 or —+.

2. Left-click.

To select multiple columns or rows, use one of the following methods:

— Move the cursor to the first column or row of the desired range as described above. Hold
down the left mouse button and drag the cursor to the last column or row of the range.
Release the left mouse button.

— Select the first column or row of the desired range as described above. Then, while

holding down the Shift key, select the last column or row of the range.
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4.4.7 Select a table

To select the entire table, do the following:
1. Move the mouse cursor over the upper left corner of the table so that the cursor takes
the following form .

2. Left-click.

If text is wrapped around the table (see Section 4.4.10.2), do the following:
1. Place the cursor on the table.

2. Click the i button displayed in the upper left corner of the table.

To deselect a table, click anywhere in the document outside of the table.
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4.4.8 Cell background color

4.4.8.1 Add the fill color to table cells

To fill cells with color, follow these steps:
1. Select the table or cell/range of cells you want to change the fill color of.

2. To color cells with the last color used for the cells fill earlier, on the Toolbar, in the Table

O

section, click == Fill Color (see Figure 157).

3. To fill the cells with a different color, click the arrow to the right of the ﬁ Fill Color
button.

4. In the color selection pane that opens, specify the cells fill color in one of the following
ways:
— Choose a color from one of the color sets provided.
— Specify the color code manually.

— Copy the color with an eyedropper.

=y = =ZE=ZEIF + 4 |:£:|§'@E'E-%@
l!E "] 11w = 3= v o !
' - By oy = No Fil

Paragraph

Theme Colors:

Standard Colors:

Recent Colors:

Mare Colors... ﬂ

Figure 157. Fill Color button and color selection pane
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4.4.8.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 157):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The cells will be colored in the selected color.

4.4.8.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:

1. Click More Colors (see Figure 157).

2. In the Select Color window (see Figure 158) that appears, specify the desired color as a
HEX code or in RGB format.

3. Click OK.

Select Color x
Hex: Preview:
Red: Green: Blue:
o - 0o - o

Figure 158. Select Color window
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The manually specified color will be added to the Recent Colors set (see Figure 157) and

checked. The color selection pane will close. The cells will be colored in the selected color.

4.4.8.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in

the main window's workspace (see Section 3.3.5) and filling the cells with this color.

The eyedropper is disabled in header and footer editing mode (see Section 4.10.2).

To copy a color using the eyedropper, follow these steps:

1. Click & Eyedropper (see Figure 157). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color in which you want to color the cells. For more accurate
color selection, refer to the area to the right of the cursor. It displays the color of the pixel
that the cursor is currently hovering over.

3. Left-click the color.

The cells are colored in the selected color, and the cursor returns to its standard appearance.
The specified color is added to the Recent Colors set (see Figure 157) and checked in the color

selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.4.8.2 Remove the fill color
To remove the cell fill, follow the steps below:
1. Select the table or cell/cell range you want to cancel the fill.

2. On the Toolbar, in the Table section, click the arrow to the right of the ﬁ Fill Color
button (see Figure 157).

3. In the color selection pane, click No Fill.
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4.4.9 Cell borders

4.4.9.1 Change border parameters

To change the border parameters for a cell/range of cells/table, follow these steps:

1. Select the table or cell/cell range whose borders need to be changed.

2. On the Toolbar, select the Table section and click the arrow to the right of the FH button
(see Figure 159).

=y = =E=E=17F + 4
I: ~ 1w = 2= E[ w ??7 « q] )
Paragraph

== / Mo Borders

Theme Colors:

HEEEEN

Standard Colors:

Recent Colors:

Maore Colors... j?

Figure 159. Border settings pane

3. Inthe border settings pane that opens, in the first settings block, specify the position of the
borders for which you want to change the parameters.

4. Inthe second block of settings, select the type of line to be applied to the specified borders.

5. In the third block of settings, specify the line color using one of the following methods:

— Choose a color from one of the color sets provided.
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— Specify the color code manually.

— Copy the color with an eyedropper.

If No Borders is selected in the first or second block of settings, cell borders are displayed
as lines of light gray color. These lines conditionally divide cells and simplify work with
the table. In this case cell borders are not displayed when printing and exporting the

document to .pdf format.

4.4.9.1.1 Choose a color from the color sets provided

In the border settings pane, you will find the following sets of colors in the third settings block
(see Figure 159):
— Theme Colors: This block contains the color palette of the current document's theme.
— Standard Colors: This block contains the colors that users most often choose when
formatting a document.
— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The cell borders will be colored
in the selected color.

To close the border parameters pane, do one of the following:

1. On the Toolbar, select the Table section and click the arrow to the right of the Hﬂ button

(see Figure 159).

2. Click a blank area of the document outside the border settings pane.

4.4.9.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:
1. Click More Colors (see Figure 159).
2. In the Select Color window (see Figure 160) that appears, specify the desired color as a

HEX code or in RGB format.
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3. Click OK.

Select Color >

Hex: Preview:

o [

Red: Green: Blue:

o - 0o - o0

Figure 160. Select Color window

The manually specified color will be added to the Recent Colors set (see Figure 159) and

checked. The border settings pane will close. The cell borders will be colored in the selected color.

4.4.9.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in

the main window's workspace (see Section 3.3.5) and apply that color to the cell borders.

The eyedropper is disabled in header and footer editing mode (see Section 4.10.2).
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To copy a color using the eyedropper, follow these steps:

1. Click & Eyedropper (see Figure 159). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color in which you want to color the cell borders. For more
accurate color selection, refer to the area to the right of the cursor. It displays the color of
the pixel that the cursor is currently hovering over.

3. Left-click the color.

The cell borders are colored in the selected color, and the cursor returns to its standard
appearance. The specified color is added to the Recent Colors set (see Figure 159) and checked in
the border settings pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.4.9.2 Apply the border style of the previous table

To quickly apply the border style of the previous table to a cell/range of cells/table, follow the
steps below:

1. Select the desired table or cell/range of cells.

2. On the Toolbar, in the Table section, click [ (see Figure 161).

L o~
- moE S B AaBbCcD
HH ~ [ E ﬂ % ._:} Mormal

Table Styles

Figure 161. Button to apply previous table border style

4.4.9.3 Delete borders

To delete the specified borders of a cell/range of cells/table, follow the steps below:

1. Select the desired table or cell/range of cells.

2. On the Toolbar, select the Table section and click the arrow to the right of the Hﬂ button
(see Figure 162).

3. In the border settings pane that opens:

— In the first block of settings, specify where you want the borders to be deleted.
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— In the second block of settings, select No Borders.

=y = E == F 4+ 4L SvomEH mEs B B
=y Iy EE=E By Sy 0 HYE By < ‘
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== / Mo Borders

Figure 162. Remove borders

4. To close the border parameters window, do one of the following:
— On the Toolbar, select the Table section and click the arrow to the right of the
FH button (see Figure 162).

— Click a blank area of the document outside the border settings pane.

4.4.10 Alignment and text wrapping

4.4.10.1 Align a table

By default, the table is aligned to the left edge of the document. The left margin is inherited
from the paragraph after which the table is located.

To change the way the table is aligned and indented, follow these steps:

1. Place the cursor in any cell of the table or select any element of the table/table as a whole.

2. Open the table settings window in one of the following ways

— In the Command menu, select Format > Table > Table Settings (see Figure 163).
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Format Tools View Share Subscription Help

Clear Formatting Ctrl+5pace % o XOThames |v| | 14 v| A™ A+
Font »
U e A o £+
Alignment 4 Q B I — - -
Rotate Text 4 ront
Image 4
Table » ™5 Insert Row Above Alt+A
& Insert Row Below Alt+B
E Insert Column to the Left Alt+L
ﬂ Insert Column to the Right Alt+R
#% Delete Row Ctrl+Alt+R
B Delete Column Ctrl+Alt+U
B8 Delete Table Alt+Shift+T
B Merge Cells Ctrl+Alt+M
B2 Split Cell Alt+Shift+M
[ Cell Size...
{@} Table Settings

Figure 163. Table Settings command menu option

— On  theToolbar, select the Tablesection and click {5 Table Settings
(see Figure 164).
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Table Styles

Figure 164. Table Settings button

— Right-click to open the context menu and run the Table Settings command.
3. In the Table Settings window (see Figure 165), select an alignment method: Align Left,
Align Center, or Align Right.
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4. If the Align Left option is selected for the table, specify the distance from the left margin

of the document to the table in the Left field.
5. Click OK.

Table Settings

Alignment Wrap text
o
== == == 000inch  C
Left: Right
Left Indent: FF'
" 0.13 inch o 0.13 inch o
0.00 inch y

Bottom:

0.00 inch "

Figure 165. Table Settings window
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4.4.10.2 Wrap text

The following restrictions apply in this version of the application:

— You cannot add an object by dragging and dropping to a table for which text wrapping is
set. You also cannot drag and drop an object from a table to another place in the document.

— Actions with objects located in table cells may be performed incorrectly.

— Tables in the headers and footers (see Section 4.10.2) cannot be wrapped in text. When
such a table is inserted into a header or footer, the text wrapping option is automatically
disabled.

— If there is a merged cell (see Section 4.4.13) in the table and a part of this cell is extended
to the next page, the data that cell contains is displayed on both pages.

— If the text in a cell does not fit vertically on a page, the text that does not fit is cropped.

To customize the table's text wrapping, follow the steps below:
1. Place the cursor in any cell of the table or select any element of the table/table as a whole.
2. Open the table setting window in one of the following ways:
— In the Command menu, select Format > Table > Table Settings (see Figure 163).
— On theToolbar, select the Tablesection and click Table Settings
(see Figure 164).
— Right-click to open the context menu and run the Table Settings command.
In the Table Settings window (see Figure 165), check the Wrap text box.
4. Specify thetable alignment method and, if necessary, Left indentation
(see Section 4.4.10.1).
5. Specify the distance from the table borders to the surrounding text Left, Right, Top, and
Bottom.
6. Click OK.

If the table spans several pages, text wrapping is applied only to the page with the last part
of the table. All the text after the table anchor is transferred to this page (see Section 4.3.1).

Y ou can quickly move a table for which you have configured text wrapping to another location
in the document. To do this:

1. Place the cursor on the table.

2. Click the i button displayed in the top left corner of the table.

3. Hold down the left mouse button and move the table to the desired location in the document.
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4.4.11 Resize a row or column

You can change the column or row size in one of the following ways:
1. Move the column/row border manually.

2. Specify the exact column/row width/height.

4.4.11.1 Resize a row or column manually

To resize one row or column manually, follow these steps:

1. Place the cursor at the border of the row or column you want to resize. The cursor turns
into a double-headed arrow.

2. Click the left mouse button and drag the cursor to the desired position of the column or
row border.

3. Release the left mouse button to fix the selected position.

The last vertical table border cannot be above the right margin of the page.

To make multiple columns or rows of a table the same size, follow the steps below:
1. Select the rows or columns you want to resize.
2. Set a single row or column to the size that you want to apply to selected rows or columns
in the table. Simply follow these steps:
— Place the cursor at the border of any row or column so it turns into a double-
headed arrow.
—  Click the left mouse button and drag the cursor to the desired position of the column
or row border.
— Release the left mouse button to fix the selected position.
The size specified for that row or column will be automatically applied to the selected rows
or columns in the table.
To make all columns or rows of a table the same size, select the table (see Section 4.4.7) and

follow the procedure described above.
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4.4.11.2 Specify the exact size

To specify the exact width for one/more columns or height for one/more rows, follow these
steps:
1. Specify the data for columns/rows:
— To change the width of one column or the height of one row, select this column/row
or select any cell that is in this column/row.
— To change the width of several columns or the height of several rows, select these
columns/rows or select any range of cells that are in these columns/rows.
2. Open the Cell Size window in one of the following ways:

— In the Command menu, select Format > Table > Cell Size (see Figure 166).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space % - XOThames |v| |14 |v| A~ A+
Font »
© B I U~ Av 2@y
Alignment 4 -
Rotate Text 4 Fort
Image ’
Table P T8 Insert Row Above Alt+A
&F Insert Row Below Alt+B
E Insert Column to the Left Alt+L
ﬂ Insert Column to the Right Alt+R
&% Delete Row Ctrl+Alt+R
ffl Delete Column Ctrl+Alt+U
B8 Delete Table Alt+5hift+T
B2 Merge Cells Ctrl+Alt+M
B Split Cell Alt+5hift+M
[ cell Size...
0% Table Settings

Figure 166. Sell Size command menu option
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— On the Toolbar, in the Table section (see Figure 167), click [| Cell Size.

SrEE BB D B |,
BE' v [ m g w {@} Y1 Normal
Table Styles

Figure 167. Cell Size button

— Right-click the selected columns/rows and run the Cell Size context menu command.
3. In the Cell Size window (see Figure 168), specify the required Column Width or
Row Height.
4. Click OK.

Cell Size >

Width

| inch

£

Height

{3

0.14 inch

Figure 168. Cell Size window
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4.4.12 Specify the exact size of the cells

To specify the exact size of one or more cells, follow these steps:
1. Select these cells.
2. Open the Cell Size window in one of the following ways:
— In the Command menu, select Format > Table > Cell Size (see Figure 166).
— On the Toolbar, in the Table section (see Figure 167), click [#| Cell Size.
— Right-click the selected cells and run the Cell Size context menu command.
3. In the Cell Size window (see Figure 168), specify the required Width and Height of
the cells and click OK.
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4.4.13 Merge cells

You can merge any number of cells in the table you are working on.

When merging multiple cells:

— The selected range will merge into a single cell.

— The merged cell will only display the contents of the upper-left cell of the selection.

— When you merge multiple cells, the resulting cell will be formatted like the upper-left cell

of the merged range.

To merge cells, select them and do one of the following:

— In the Format menu, select the Table section and then Merge Cells (see Figure 169).

Format Tools View
Clear Formatting
Font

Alignment
Rotate Text

Image
Table

Share Subscription Help

Ctrl+Space & v XO Thames |+

& B I U

¥ Font

Insert Row Abaove

Insert Row Below

Insert Column to the Left
Insert Column to the Right

¥ == Bd

Delete Row

] Delete Column
g Delete Table

E2 Merge Cells

Figure 169. Merge cells
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—  On the Toolbar, select the Table section and click = Merge Cells (see Figure 170).

SvEHE ma®m 5 @B
H v & B d ¥ o
Table

Figure 170. Merge Cells button

— Right-click the selected range of cells and choose Merge Cells context menu.

— Press Ctrl+Alt+M / ~=Option+%Cmd+M.

To split the merged cell, use the Split Cell command (see Section 4.4.14).

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 187



MyOffice

4.4.14 Split cell

Splitting cells into several rows or columns is convenient to use when you want to create
complex tables (for example, in design documentation).

The following limitations currently apply:

— You cannot split multiple cells at the same time.

— You cannot split a cell into columns and rows at the same time.

If a cell that consists of merged columns/rows (see Section 4.4.13) is selected for splitting, the
number of columns/rows into which it is split should be the divisor of the number of merged
columns/rows. For example, if a cell consists of 8 merged columns, it can be split into 1, 2, 4, or 8

columns. If a cell consists of 6 merged rows, it can be split into 1, 2, 3, or 6 rows.

To split a cell, follow these steps:
1. Select the cell.
2. Run the Split Cell command in one of the following ways:

— In the Command menu, select Format > Table > Split Cell (see Figure 171).

Format Tools WView Share Subscription Help

Clear Formatting Ctrl+Space l% XOThames |v| 14 v A~ A*
Font »
B I U~ Av &~
Alignment 4 - -
Rotate Text 4 Font
Image »
Table P T Insert Row Above Alt+A
& Insert Row Below Alt+B
E Insert Column to the Left Alt+L
ﬂ Insert Column to the Right Alt+R
&% Delete Row Ctrl+Alt+R
ffl Delete Column Ctrl+Alt+U
B8 Delete Table Alt+Shift+T
Ed Merge Cells Ctrl+Alt+M
fE Split Cell Alt+Shift+M

Figure 171. Split Cell option

—  On the Toolbar, in the Table section, click Split Cell (see Figure 172).
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Figure 172. Split Cell button

— Right-click the selected cell and choose Split Cell command from the context menu.
—  Press Alt+Shift+M / ~ Option+{ Shift+M.
3. Inthe Split Cell window (see Figure 173):
— Specify the number of columns or rows into which you want to split the selected cell.
The number can be entered manually, selected using the counter, by pressing | and
keys, or by scrolling the mouse wheel.

— Click OK.

Split Cell >

© Columns :

[

Rows

Figure 173. Split Cell window

The data from the split cell is placed in the upper left cell of the resulting range. Cells in

the range will retain the formatting of the split cell.
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4.4.15 Repeat headers on subsequent pages

Text documents may contain tables that can span multiple pages. In this case, users need to
go back to the beginning of the table to see its heading. To avoid it, display the table headings on each
page where the table is displayed.

The first row of the table or several rows of the table, including the first row, can be specified
as the header.

To repeat one or multiple rows as table headers:

1. Specify one or multiple rows which will become the table header:

— If you want to use one row, place the cursor on this row, select any cell in the row, or
select the row entirely.
— If you want to use several rows as the header, select any cell range in these rows or

select the rows entirely.

2. On the Toolbar, select the Table section and click b Repeat Header Rows
(see Figure 174).

ScvEHE BZB (B B AaBbCc = ...
H v & BEd§ o Normal

Table Styles

Figure 174. Repeat Header Rows button

If you don't want to show the headings across pages:

1. Place the cursor in any cell. Or select any cell range in the table.

2. On the Toolbar, select the Table section and click B Repeat Header Rows
(see Figure 174).
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4.4.16 Convert text into a table

You can convert text to a table using the Command menu or the Toolbar.

When you place text in a table, each paragraph is placed in a separate cell. The table is filled
with paragraphs from left to right, from top to bottom.

If you convert using the Command menu, the default table is created with three columns.
The number of table rows is determined automatically depending on the number of paragraphs in

the text.

To convert text into a table using the Command menu, do the following:

1. Use the paragraph mark to separate each fragment of text that you want to place into a
separate cell.

2. Select the entire text you want to insert into a table.

3. Inthe Command menu, select Insert > Table (see Figure 175).

Insert Format Tools Wiew  Share

Image...
Text Box
' Shape r

B Table..
Figure 175. Insert a table
If you convert text to a table using the Toolbar, you can specify the number of table columns

manually. The number of table rows is determined automatically by the number of paragraphs in

the text, regardless of the number of rows the user selected.
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To convert the text into a table using the Toolbar:

1. Use the paragraph mark to separate each fragment of text that you want to place into a
separate cell.

2. Select the entire text you want to insert into a table.

3. Expand the pane which allows to create a table in one of the following ways:

— On the Toolbar, in the Insert section, click 1 Table (see Figure 176).

Use the cursor to select the number of rows and columns to be included in the table

and left-click.

L A
AaBbCcl ... {_"].,. @ ., e

Heading 3

Select Table Size

Figure 176. Table button
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— On the Toolbar, in the Insert section, click the®*= button (see Figure 177).

In the displayed pane, place the cursor on the Table button. Select the number of

columns and rows you want your table to contain and click with the left mouse button.

Select Table Size

qr

14

AaBbCcDd

Normal

Styles
15

16

17

e H#H @ HF

ac

ac

nm o @

Q

BB 0 EE.

Image...
Text Box

Shape

Table...

Equation...

Special Characters...

Page Break
Section Break
Page Numbers...
Header and Footer

Table of Contents

Link...

Figure 177. Insert pane

4.4.17 Transform a table into text

To transform a table into text, do the following:

1. Select the table (see Section 4.4.6).
2. Cut or copy the table in one of the suggested ways (see Section 4.9.2.1).

3. Insert the data without formatting in one of the suggested ways (see Section 4.9.2.2).

The text from one row of the table is inserted in one paragraph. The tab character is used as a

separator for cell data.
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4.4.18 Delete rows or columns

To delete one or more rows or columns, use one of the following methods:

1. Select therows or columns you want to delete, or cells located within them.

Do one of the following:

— In the Format menu,

(see Figure 178).

Format Tools

Clear Formatting
Font

Alignment
Rotate Text

Image
Table

View

select Table,

Share  Subscription Help
Cirl+Space | o, XO Thames v
»
& B I U
b e
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>

P =% Insert Row Above

&5 Insert Row Below

m Insert Column to the Left
g Insert Column to the Right

## Delete Row
ffl Delete Column

Figure 178. Format menu
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— On the Toolbar, select the Table section and click theﬁ Delete Column or
@ Delete Row (see Figure 179).

SvEEH BE® B B | g
BE' v [ E ﬂ @ {%} Normall

lable Styles

Figure 179. Table section

— Right-click anywhere on the selected range and select Delete Column or Delete Row
in the context menu.

— Press Ctrl+Alt+R/ —~Option+%Cmd+R to delete one or multiple rows or
Ctrl+Alt+U / ~Option+3%Cmd+U to delete one or multiple columns.

3. Select these rows or columns entirely and press the Ctrl+- / gCmd+- combination.

4.4.19 Delete a table

To delete a table, do one of the following:
1. Select any element of the table or the table entirely. Do one of the following:

— In the Format menu, select Table and then Delete Table (see Figure 178).
— On the Toolbar, select the Table section and click 5} Delete Table (see Figure 179).

— Right-click anywhere on the table and select Delete Table in the context menu.
—  Press Alt+Shift+T / ~Option+{Shift+T.
2. Select the table entirely and press Ctrl+-/ $sCmd+-.
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4.5 Images

4.5.1 Insert an image

You insert images to a text document:

From your computer.
From Google Chrome, Firefox, Internet Explorer, and Microsoft Edge browser.
From the text and spreadsheet editors included in the Microsoft Office and LibreOffice

suites.

The supported image formats include .png, .bmp, .jpg, .jpeg, .jpe, .gif, .tiff, and .tif.

4.5.1.1 Insert an image from the computer

To insert an image from the computer, follow the steps below:

1.
2.

Place the cursor in the place of the document where you want to insert an image.
Insert an image in one of the following ways:

— In the Insert menu, select Image (see Figure 180).

Insert Format Tools Wiew  Share

Image...

Text Box

Shape r

Table...

@8 @ HE

Equation...

Page Break Ctrl=Enter

Section Break

ar IC

Figure 180. Insert menu

. . O .
— On the Toolbar, select the Insert section and click Image (see Figure 181).
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Figure 181. Image button

— On the Toolbar, select the Insert section and click the *** button (see Figure 182).

In the displayed insert pane, click @ Image.

. ﬁ;adgl?CcD v |4 [Q)v =) o
Styles @ Image... A

13 14 15 16 17 —
Text Box

(5] Shape >

Q

Figure 182. Insert pane

3. In the file manager window, select the image that you want to insert and click Open.
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4.5.1.2 Insert an image from the browser or another application

To insert an image from the browser or another application, follow the steps below:
1. Copy the image from the source.

2. Place the cursor in the place of the document where you want to insert an image.
3. Insert the image in one of the following ways:

— In the Edit menu, select Paste (see Figure 183).

Edit Insert Format Tools View  Share

2 Undo Ctrl+Z

" Redo Ctrl+¥

o Cut Ctrl+X

Copy Ctrl+C

Paste Cerl+V 2
Paste without Formatting

£ Copy Formatting Ctrl+Shift+C
Paste Formatting Ctrl+Shift+V
Select All Ctrl+A

0 Find Ctrl+F

Figure 183. Edit menu

— On the Toolbar, select the Edit section and click ﬁ Paste. Or click the arrow to

the right of the [T} Paste button and select the Paste command (see Figure 184).

File Edit Insert Format Tools View Share Subscription Help
C O @ v v X @3 & X0 Th
Q EE v @ hd (j ':._> ﬁ

Favorites File Edit

Paste

Paste Text Only

Figure 184. Insert button
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— Right-click and select Paste from the context menu.

— Use the Ctrl+V / £Cmd+V shortcut key.

If you want to insert the text and the images, copy and insert them separately.
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4.5.2 Resize an image

MyOffice Text allows you to resize an image while maintaining the proportions or without

maintaining the original aspect ratio.

Resizing is not available for images rotated at an arbitrary angle in any other text editor.

4.5.2.1 Resize an image proportionally

To quickly resize an image while keeping its proportions:

1. Select the image you want to resize.

2. Hold down the left mouse button and drag any corner sizing handle so that the image
becomes the desired size (see Figure 185).

3. Release the left mouse button to apply changes to the image size.

Figure 185. Resize image proportionally
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To resize an image and set the exact size:
1. Select the image you want to resize.
2. Open the Size and Position window in one of the following ways:

— Select Format > Image > Size and Position (see Figure 186).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space l% = In Line with Text

hd

Font

Q Clﬂ Size and Position
Alignment »
Rotate Text 4 Image
Image L4 Wrap Text »
Table »

Save Image...

Figure 186. Image sub-menu

— On the Toolbar, select the Image section and click  Size and Position

(see Figure 187).

View Share Subscription Help

% ﬁ hd é ElnLinewithText v

S C Q D‘“ Size and Position

Edit Image

Figure 187. Size and Position button

— Open the context menu by clicking with theright mouse button and select
Size and Position.
3. In the Size and Position window (see Figure 188), specify the desired width and height of
the image in the Width and Height boxes.
4. Click OK.
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Size and Position

Width: Height:

512 inches . | &2 341 inches .

Left Offset: Top Offset:

0.39 inches . 0.79 inches .

Offset is measured from the edge of the page.

Figure 188. Size and Position window
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4.5.2.2 Resize an image without keeping its proportions

To quickly resize an image without changing its proportions:

1. Select the image you want to resize.

2. Move one of thesizing handles while keeping theleft mouse button pressed
(see Figure 189):
— To change the image height, move the top or the bottom sizing handle.
— To change the image width, move the left or the right sizing handle.

3. Release the left mouse button to fix the new image size.

r
-y
<1

I

MyOffice
2 & @ @

Figure 189. Resize image without keeping its proportions

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 203



MyOffice

To resize an image and set the exact size:
1. Select the image that you want to resize.
2. Open the Size and Position window in one of the following ways:

— Select Format > Image > Size and Position (see Figure 190).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space é E In Line with Text

Font > e -
& o Size and Position

Alignment »

Rotate Text 3 Image

Image 4 Wrap Text »

Table -

Save Image...

Figure 190. Image sub-menu

3. On the Toolbar, select the Image section and click (57 Size and Position

(see Figure 191).

View Share Subscription Help

X B v 5 0= In Line with Text

O C Q DF‘ Size and Position

Edit Image

Figure 191. Size and Position button

4. In the Size and Position window, disable the option which allows to maintain the aspect

ratio automatically. Click “ Lock Aspect Ratio so that the button changes to C2.
5. Specify the desired width and height of the image in the Width and Height boxes.
6. Click OK.
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Size and Position *

Width: Height:

512 inches . G2 3.41inches .
Left Offset: Top Offset:

0.39 inches . 0.79 inches .

Offset is measured from the edge of the page.

Figure 192. Size and Position window
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4.5.3 Change image position in text

An image in the text can be positioned:

In Line with Text: The image is placed between two paragraphs of text in the usual way.
Square: The text is placed all around the image.

Top and Bottom: The text is distributed below and above the image.

In Front of Text: The image is placed in front of the text as the top layer.

Behind Text: The image is placed behind the text as the bottom layer.

By default, the image position in the text is In Line with Text. To change the position,

proceed as follows:

1.

Select the image you want to change the position of. If you want to select an image
Behind Text, place the cursor on the image and click the ® button that appears.

Display the list of possible positions in one of the following ways:

— In the Format menu, select Image > Wrap Text (see Figure 193). In the opened

sub-menu, select the desired position.

Format Tools View Share Subscription Help
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Figure 193. Format menu
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— On the Toolbar, select the Image section and click the +button to the right of

the current image position (see Figure 194).

O= InLinewith Text v (24

In Line with Text
Sguare
Top and Bottom

In Front of Text

{1/ ]

Behind Text

Figure 194. Selecting the image wrapping style

— Right-click the image and run the Wrap Text command.

3. Inthe opened sub-menu, select the desired image position.

The image positioned In Line with Text can be aligned horizontally (to the left, to the right
or to the center of the page) (see Section 4.3.8.1). If the image is not separated from the text with
paragraph indents, the selected alignment type will also be applied to the text in the paragraph where

the image is located.
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4.5.4 Move an image

You can move an image in the following ways:

— Drag while keeping the left mouse button pressed.

— Move it vertically or horizontally with the <, 1, |, — keys on the keyboard.
— Specify the left and top page indents.

4.5.4.1 Move with the mouse

To move an image with the mouse, proceed as follows:

1. Select the image you want to move.

2. Hold down the left mouse button and drag the image to the desired position in
the document.

3. Release the left mouse button to fix the new position of the image.

4.5.4.2 Move with the keyboard keys

You cannot move the image with the <, 1, |, — keys for the image being In Line with

Text position (see Section 4.5.3).

To move an image using the keyboard keys, follow these steps:
1. Select the image you want to move.
2. Move the image left/right/up/down by pressing the «—, —, 1 or | key.
The step of movement depends on the scale of the document:
— If the scale is < 200%, the step = 4 mm.
— If the scale is > 200%, the step = 1 mm.

To increase a step, move the image with keys «, 1, |, —, keeping the Shift key pressed.
In this case the movement step will be equal:
— If the scale is < 200%, the step = 4 cm.
— If the scale is > 200%, the step = 1 cm.
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4.5.4.3 Specify the left and top page indents
You can also move the image by specifying its left and top indents.

You can specify the indents for all image positions, except In Line with Text

(see Section 4.5.3).

To specify the image indents:
1. Select the image.
2. Open the Size and Position window in one of the following ways:

— Select Format > Image > Size and Position (see Figure 195).

Format Tools WView Share Subscription Help

cearromating AU I 0= In Line with Text

Font b e -
& (77 Size and Position
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Rotate Text 3 Image

Image ’ Wrap Text »

Table b

Save Image...

Figure 195. Image sub-menu

— On the Toolbar, select the Image section and click - Size and Position.

View Share Subscription Help

% [E v é 0= In Linewith Text ~

O C Q El‘ﬂ Size and Position

Edit Image

Figure 196. Size and Position button

— Open the context menu by clicking with the right mouse button and select

Size and Position.
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3.

5.

In the Size and Position window (see Figure 192), specify the desired left indent of
the image in the Left Offset box. Specify the desired top indent of the image in
the Top Offset box.

In the Size and Position window (see Figure 192), specify the desired left indent of
the image in the Left Offset box. Specify the desired top indent of the image in
the Top Offset box.

Click OK.

Size and Position >

Width: Height:

17.40 em 2 979em -
Left Offset: Top Offset:

£ 1 . 70 1 2

Figure 197. Size and Position window
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4.5.5 Save an image

The image from the document can be saved on your computer.
Follow these steps:

1. Select an image.

2. Run the save command in one of the following ways:

— Select Format > Image > Save Image (see Figure 198).

Format Tools View Share Subscription Help

Clear Formatting Ctrl+Space % E In Line with Text +

Font » e -
& "} Size and Position

Alignment >

Rotate Text » Image

Image b Wrap Text 3

Table »

LA Size and Position

Save Image...

Figure 198. Image sub-menu

— Open the context menu by right-clicking and run the Save Image command.
3. In the file manager window, select the folder to save the file to, specify the file name

and click Save.

The image is saved in the original size.

If an image has been cropped in a document using a third-party application, it is saved in

its original (pre-crop) form.
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4.5.6 Delete an image
If you want to delete an image:
1. Select the image that you want to delete. To select an image located Behind Text

(see Section 4.5.3), place the cursor on the image and click the displayed ® button.

2. Delete the image in one of the following ways:

— On the Toolbar, select the Image section and click =& Delete Image (see Figure 199).

Subscription Help

v I% 0= In Linewith Text ~ @

Q D” Size and Position

Image

Figure 199. Delete image button

— Right-click the image with the mouse and select the Delete Image command from
the context menu.

— Press Delete or Backspace.

If the image is in the In line with text position (see Section 4.5.3), it can be deleted as text

(see Section 4.2.10).
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4.6 Shapes

You can add the following types of shapes to your documents: line, rectangle, ellipse, triangle,
diamond, folded corner, star, heart, brackets, arrows, callouts, or text field. You can add shapes

anywhere in the document, except in footnotes and comments.

4.6.1 Insert a line

To insert a line into your document, follow the steps below:
1. Open the insert sub-menu in one of the following ways:

— Inthe Command menu, select Insert > Shape > Line (see Figure 200).

Insert Format Tools View Share Subscription Help

) Image.. ’~ & XO Thames MBI
Text Box )
() shape » / Lines » ./ Line -
3 Table.. ] Rectangle A Arrow
® Equation.. O Ellipse " Double Arrow
Special Characters... A Trangle
(> Diamond
= Page Break Ctrl +Enter [J Folded Corner
'= Section Break ¥ Star
# Page Numbers * O Heart
£l Header and Footer » () Brackets 4
=: Table of Contents = Arrows 4
& Link.. Ctrl+K [1 Callouts 4

=1 Cross-Reference...

[ Bookmark...

Figure 200. Insert menu
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— On the Toolbar, in the Insert section, click the === button. In the displayed insert pane,

place the cursor on the o) Shape button (see Figure 201).

= v 11 w
- - AaBbCcDd | ... HE. [2] (Q)v [Z] -
&= 5= :E[ v q Normal «
Styles @ Image... J
o . i ’ I I I 7 Text Box
Line (5] Shape |y > Q
/ / / BEH Table. N
Basic @ Equation...
I:I O A <> D Special Characters... >
'H Page Break

v O

||v|:

Section Break

Brackets

Page Numbers... >

[ j { } @ Header and Footer >
=:  Table of Contents

Arrows

I:> <j ﬁ @ I:IL"> ¢ Link..
j:‘] Cross-Reference...

@ ¢‘\:| ﬁ D m Bookmark...

Callouts AB'I Footnote by
|:| Comment

(3 O

Figure 201. Insert pane

3. In the sub-menu that opens, select the type of line to insert: line, arrow, double-sided
arrow. The cursor will look like a crosshair: +.
4. If necessary, select the type of line tips (see Section 4.6.11).
5. Add a line in one of the following ways:
— Click the left mouse button on the place where the line start point should be located. A
line with a length of 4.24 cm and an angle of 45° will be added to the document.
— Hold down the left mouse button and draw a line in the desired location of
the document. To finish drawing, release the left mouse button.

6. If necessary, edit the length and angle of the line (see Section 4.6.10).
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By default, the line is inserted before the text. Line position can be changed manually

(see Section 4.6.10).

4.6.2 Insert a shape

To insert a shape into a document:
1. Place the cursor where you want to insert the shape.
2. Display the list of shapes in one of the following ways:
— In the Command menu, select the Insert menu and click Shape (see Figure 200).
— On the Toolbar, select the Insert section and click the *** button (see Figure 201).
In the displayed insert pane, place the cursor on the o Shape button.

3. In the opened sub-menu, select the desired shape.
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4.6.3 Insert a text box

A text box is a framed text which can be easily moved within the text you are working on.
Text boxes can be used for different purposes, including for creating legends for image elements or

callout boxes with quotes from the main text to make them more visible.

To insert a text box:
1. Place the cursor where you want to insert a text box.
2. Insert the text box in one of the following ways:

— In the Insert menu, select Text Box (see Figure 202).

Insert Format Tools Wiew  Share

[=] Image...
Text Box

Figure 202. Insert menu

— On the Toolbar, select theInsert section and «click the:* button.

In the opened insert pane, click [Z] Text Box (see Figure 203).

- A A
AaBbCeD .. [H. ] (@) F .

Heading 1
Styles @ Image... ~
15 16 17 —
Text Box
6] Shape > Q
===) Table... >

Figure 203. Insert pane
3. Enter the text in the text field. The text can be formatted in the same manner as you would

format the main text in the document.

4. To deselect the text box, click anywhere in the document outside of the text box.
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4.6.4 Edit a shape

You can add the following elements to any shape, except lines:
— Text (see Section 4.2.1)

— Image (see Section 4.5)

— Equations (see Section 4.8)

— Current date and time (see Section 4.2.6)

— Link (see Section 4.2.2)

— Cross-reference (see Section 4.2.4)

— Bookmark (see Section 4.2.5)

—  Current time or date (see Section 4.2.7)

To insert a shape in one of these elements, enter the shape editing mode by double-clicking it.

To leave the shape editing mode, click anywhere in the document outside the shape.

Editing mode is not supported for shapes positioned Behind Text (see Section 4.6.10) and

for shapes rotated at any angle using third-party text editors.
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4.6.5 Fill a shape

4.6.5.1 Fill a shape with color

To fill a shape with color, follow these steps:
1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. To fill the shape with the last color used to fill it earlier, on the Toolbar, in the Shape

section, click 2 Fill Color (see Figure 204).

:— E 1 .0 _:V
: = o Y = @ AaRhCeDAT
v &= Heq

Paragraph

No Fill

Theme Colors:

H BGENEE

Standard Colors:

Recent Colors:

More Colors... p

mage:

Choose...

Figure 204. Fill Color button and color selection pane

3. To fill the shape with a different color, click the arrow to the right of the .2. Fill Color
button.

4. In the color selection pane that opens, specify the fill color of the shape in one of the
following ways:
— Choose a color from one of the color sets provided.
— Specify the color code manually.

— Copy the color with an eyedropper.
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4.6.5.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 204):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The shape will be filled with the selected color.

4.6.5.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:

1. Click More Colors (see Figure 204).

2. In the Select Color window (see Figure 205) that appears, specify the desired color as a
HEX code or in RGB format.

3. Click OK.

The manually specified color will be added to the Recent Colors set (see Figure 204) and

checked. The color selection pane will close. The shape will be filled with the selected color.
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Select Color >

Hex: Preview:

e | ([

Red: Green: Blue:

”~

79 - 129 O 189 _

Figure 205. Select Color window

4.6.5.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in

the main window's workspace (see Section 3.3.5) and filling the shape with this color.

The eyedropper is disabled in header and footer editing mode (see Section 4.10.2).

To copy a color using the eyedropper, follow these steps:

1. Click ¢ Eyedropper (see Figure 204). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color you want to fill the shape with. For more accurate color
selection, refer to the area to the right of the cursor. It displays the color of the pixel that
the cursor is currently hovering over.

3. Left-click the color.

The shape will be filled with the specified color, and the cursor returns to its standard
appearance. The specified color is added to the Recent Colors set (see Figure 204) and checked in
the color selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.
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4.6.5.2 Fill a shape with image

To fill a shape with image, do the following:

1. Select the shape with a single mouse click or double-click the shape to switch to edit mode.
2. Onthe Toolbar, select the Shape section, and click the arrow to the right of the Fill Color
button (see Figure 206).

3. In the color selection pane, in the Image block, click Choose.

= == £, Fill Color j[ O= InLinewithText v (3

Mo Fill

Paragraph

Theme Colors:

B L]

Standard Colors:

Recent Colors:

Mare Colars... ﬁ

Image:

Choose...

Figure 206. Choose button

4. Select the desired image in the file manager window and click Open.
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4.6.5.3 Remove the fill

To remove the shape fill, do the following:
1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. On the Toolbar, select the Shape section and click the arrow to theright of

the 2 Fill Color button (see Figure 207).

3. Inthe color selection pane, click No Fill.

X & Fill Color : 0= InLinewith Text v (3

No Fill

< 3 4 2 6 Theme Colors: 14

B EMEEEE

Figure 207. No Fill button
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4.6.6 Shape outline

You can define the color, thickness, and outline type for the shape.

4.6.6.1 Select the color of the shape outline

To select the color of the shape outline, follow the steps below:

1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. Onthe Toolbar, select the Shape section and click the arrow to the right of the E Outline

button (see Figure 208).

3. Inthe color selection pane that opens, specify the color of the shape outline in one of the

following ways:

— Choose a color from one of the color sets provided.

— Specify the color code manually.

— Copy the color with an eyedropper.

Paragraph

L FillColor v E Behind Text v
|: Outline Autofit
No Outline
Theme Colors:

Standard Colors:

O HEEEEM

Recent Colors:

More Colors... ﬁ

Line Weight: 1.00pt

Figure 208. Outline button and color selection pane
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4.6.6.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 208):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The shape outline will be colored in the selected color.

4.6.6.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:

1. Click More Colors (see Figure 208).

2. In the Select Color window (see Figure 209) that appears, specify the desired color as a
HEX code or in RGB format.

3. Click OK.

Select Color =

e Praview:
eyl eview:

o -

Red: Green: Blue:

79 129 189

Figure 209. Select Color window
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The manually specified color will be added to the Recent Colors set (see Figure 208) and

checked. The color selection pane will close. The shape outline will be colored in the selected color.

4.6.6.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in

the main window's workspace (see Section 3.3.5) and apply that color to the shape outline.

The eyedropper is disabled in header and footer editing mode (see Section 4.10.2).

To copy a color using the eyedropper, follow these steps:

1.

Click ¢ Eyedropper (see Figure 208). The color selection pane will close, and
the cursor will look like a crosshair for color selection.

Hover the cursor over the color you want to color the shape outline. For more accurate
color selection, refer to the area to the right of the cursor. It displays the color of the pixel
that the cursor is currently hovering over.

Left-click the color.

The shape outline is colored in the selected color, and the cursor returns to its standard

appearance. The specified color is added to the Recent Colors (see Figure 208) set and checked in

the color selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.6.6.2 Select the thickness and line type of the shape outline

To specify the thickness and type of a line for a shape outline, follow the steps below:

1.
2.

Single-click to select a shape or double-click to select a shape to enter its editing mode.
On the Toolbar, select the Shape section and click the arrow to the right of the E Outline
button (see Figure 208).

In the Line Weight field, select the desired outline thickness manually or using the
buttons.

Select the outline line type from the preset values.
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4.6.6.3 Apply outline settings of the previous shape

To quickly apply the previous shape's outline settings to a shape, follow these steps:

1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. On the Toolbar, in the Shape section, click &= Outline (see Figure 210).

& FillColor ~ T Behind Text v
== outline v Autofit ‘
Shape

Figure 210. Outline button

4.6.6.4 Delete shape outline

To delete the outline of a shape, follow the steps below:

1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. Onthe Toolbar, select the Shape section and click the arrow to the right of the .'_;. Outline
button (see Figure 211).

3. In the color selection pane, click No Outline.

— & FillColor v & Behind Text e

- = = = qr Autofit

Paragraph

No Qutline

[

Therme Colors:

Figure 211. No Outline button
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4.6.7 Line style

You can define the color, thickness, and outline type for the line.

4.6.7.1 Select a line color

To select a line color, follow these steps:

1. Select the line.

2. On the Toolbar, select the Line section and click the arrow to the right of
the E Line Style button (see Figure 212).

3. In the color selection pane that opens, specify the line color in one of the following ways:
— Choose a color from one of the color sets provided.
— Specify the color code manually.

— Copy the color with an eyedropper.

=y =EEEEn L LrEY A ) _
- |“ . |i|:| able |
— — | —
Paragraph
Mo Outline

Theme Colors:

Standard Colars:

Recent Colors:

More Colors... j?

Line Weight: 0.25pt

Figure 212. Line Style button and color selection pane
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4.6.7.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 212):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The line will be colored in the selected color.

4.6.7.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:

1. Click More Colors (see Figure 212).

2. In the Select Color window (see Figure 213) that appears, specify the desired color as a
HEX code or in RGB format.

3. Click OK.

Select Color pd

Hex: Preview:

o -

Red: Green: Blue:

79 129 189

Figure 213. Select Color window
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The manually specified color will be added to the Recent Colors set (see Figure 212) and

checked. The color selection pane will close. The line will be colored in the selected color.

4.6.7.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in

the main window's workspace (see Section 3.3.5) and apply that color to the line outline.

The eyedropper is disabled in header and footer editing mode (see Section 4.10.2).

To copy a color using the eyedropper, follow these steps:

1.

Click & Eyedropper (see Figure 212). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

Hover the cursor over the color you want to color the line. For more accurate color
selection, refer to the area to the right of the cursor. It displays the color of the pixel that
the cursor is currently hovering over.

Left-click the color.

The line is colored in the selected color, and the cursor returns to its standard appearance. The

specified color is added to the Recent Colors set (see Figure 212) and checked in the color selection

pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.6.7.2 Select the thickness and line type

To select the line thickness and type, follow these steps:

1.
2.

Select the line.

On the Toolbar, select the Line section and click the arrow to the right of
the i Line Style button (see Figure 212).

In the Line Weight section, select the desired line thickness manually or using the buttons.

Select the line type from the preset values.
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4.6.7.3 Apply the style of the previous line

To quickly apply a previous line style to a line, follow these steps:

1. Select the line.

2. On the Toolbar, in the Line section, click 4z Line Style (see Figure 214).

— 0w | 1T ] e W

Paragraph Line

Figure 214. Line Style button

4.6.7.4 Delete the line style

If necessary, you can delete the line style settings. To do this, follow these steps:
1. Select the line.
2. On the Toolbar, select the Line section and click the arrow to the right of

the m= Line Style button (see Figure 215).

3. In the color selection pane, click No Outline.

2 —

Paragraph
No Outline

[

Theme Colors:

Figure 215. No Outline button
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4.6.8 Resize a shape

You can change the height and the width of shapes proportionally or according to your
preferences.
To resize a shape proportionally, follow the steps below:
1. Select the shape you want to resize.
2. Drag a corner handle while keeping the left mouse button pressed until the shape is
the size you want (see Figure 216).

3. Release the left mouse button to fix the selected size.

g &

Figure 216. Resize a shape proportionally
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To resize a shape without keeping its proportions, follow the steps below:

1. Select the shape you want to resize.

2. Drag a side handle while keeping the left mouse button (see Figure 217):

— To change the height of the shape, move the top or bottom handle.
— To change the width of the shape, move the left or right handle.

3. Release the left mouse button to fix the selected size.

Figure 217. Resize a shape without keeping its proportions

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

232



MyOffice

4.6.9 Fit shape size to text

You can adjust the shape height to fit the text located in it (see Section 4.6.4).
Do the following actions:

1. Select the shape.

2. On the Toolbar, select the Shape section (see Figure 218) and click Autofit.

The button will change to :

InLinewith Text v (3

& FillColor » D=

ZZ Outline v Autofit

Shape

Figure 218. Autofit the shape to fit text

To cancel the action of fitting the shape to text, repeat the actions.

4.6.10 Change line length and angle

To change the length or angle of a line, follow these steps:

1. Select the line.

2. Move the cursor over the line start or end marker so that the cursor appears as follows .
3. Hold down the left mouse button and drag the marker to the desired location.

4. Release the left mouse button.

If needed, you can interrupt the movement of the marker by pressing the Esc key. The marker

will return to its original position.
4.6.11 Change arrow type

You can select the tip type for the beginning and end of the line. The selection can be made

both before drawing the line (see Section 4.6.1) and when editing the drawn line.
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To select the tip of the line, do the following:

1. On the Toolbar, select the Line section and click " Arrow Type (see Figure 219).

2. Select the left and/or right tip type from the drop-down list. If you want to remove
previously selected tips, select the left and/or right tip type — None in the first line of
the drop-down list.

3. Click~ Arrow Type once again to close the drop-down list.
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Figure 219. Arrow Type button
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4.6.12 Change shape position in text

If needed, you can change the shape position in the text. The shape can be located in the text,
in front and behind the text.
To select the shape position:

1. Select the shape whose wrapping style you want to change. To select the shape

Behind Text, place the cursor on the shape and click the 9 button that appears.
2. Display the list of possible shape positions in one of the following ways:
— If aline is selected, on the Toolbar, in the Line section, click the + button to the right
of the current line position (see Figure 220). If any other shape is selected, on
the Toolbar, in the Shape section, click the ~ button to the right of the current shape

position (see Figure 221).
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Figure 220. Select line position
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Figure 221. Select shape position

— Right-click the shape and run the Wrap Text context menu command.
3. In the opened sub-menu, select the desired position of the shape:
— In Line with Text: The shape is a part of text like a word or punctuation mark.
— Square: Text wrapping around the rectangular frame in which the shape is placed.
— Top and Bottom: Text is placed above and below the shape.
— In Front of Text: Placing the shape in front of text as a top layer.

— Behind Text: Placing the shape behind text as a bottom layer.
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4.6.13 Move a shape

You can move a shape in the following ways:

— Drag while keeping the left mouse button pressed.

— Move it strictly vertically or horizontally with the <, 1, |, — keys on the keyboard.
This method is available if the shape is in any position except the In Line with Text

position (see Section 4.6.10).

When you move a shape using the <, 1, |, — keys, the step of movement depends on the scale
of the document:

— If the scale is < 200%, the step = 4 mm.

— If the scale is > 200%, the step = 1 mm.

To increase a step, move the shape with keys «—, 1, |, —, keeping the Shift key pressed.
In this case the movement step will be equal:

— If the scale is < 200%, the step = 4 cm.

— If the scale is > 200%, the step = 1 cm.
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4.6.14 Delete a shape

To delete a shape, follow these steps:

3. Select the shape you want to delete. To select the shape Behind Text (see Section 4.6.10),

place the cursor on the shape and click the 9 button that displays.
4. Select the command to delete a shape in one of the following ways:

— If a line is selected for deletion, on the Toolbar, in the Line section, click
/u Delete Line (see Figure 222). If any other shape is selected for deletion, on

the Toolbar, in the Shape section, click Cﬂ Delete Shape (see Figure 223).

Paragraph Line

Figure 222. Delete Line button

L FillColor v O InLinewithText v | (3

== Outline v Autofit

Shape

Figure 223. Delete Shape button

— Right-click the shape and select Delete Line/Delete Shape in the context menu.

— Press Delete or Backspace.

If theshape is In Line with Text (see Section 4.6.13), it can be deleted as text
(see Section 4.2.10).
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4.7 Chart

To add a chart to your document, create it in MyOffice Spreadsheet and then copy and paste

it to the desired location in the document.

The chart is inserted as an image (see Section 4.5).
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4.8 Equations

4.8.1 Insert an equation

You can add equations to a text document. Equations are entered in the LaTeX markup

language and are automatically converted and displayed in the text in a standard (conventional) form.

To insert an equation:
1. Place the cursor where you want to insert an equation.
2. Run the Insert command in one of the following ways:

— In the Command menu, select Insert > Equation (see Figure 224).

Insert Format Tools View  Share

22
O
G
(m)

Image...
Text Box

Shape r

Table...
Equation...

Figure 224. Insert menu

— On the Toolbar, select the Insert section and click the *== button (see Figure 225).

In the displayed insert pane, click @ Equation.

AR EEE——S———
AaBbCcDdE AaBbCcDd ... @, @ ., E .

Mormal Heading 1

Styles Image... ~

4 15 16
Text Box Q

Shape ]

) [H &

Table... >

Equation... L\\F‘

D) @ H C

Special Characters... >

Figure 225. Insert pane
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3. Inthe Equation window, in the LaTeX Expression box, enter the equation written in
the LaTeX markup language. You can preview the equation in the Preview box.

4. Click OK.

Equation et

LaTeX Expression

l$ w="frac{-b~pm “=sqrt[]{b"{2}-4ac}}+{2als

b+ /I — dae

2o

Figure 226. Equation window

In the current version of the application, it is impossible to display math equations created

in Microsoft Word 2003 and 2007.
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4.8.2 Edit an equation

1. Open the equation editing window in one of the following ways:

— Select the equation by clicking the left mouse button. On the Toolbar, under

the Equation section, click OF Edit Equation (see Figure 227).

Share Subscription Help

& Bl
ol

L — W
3 —

W

Equation Paragraph

Figure 227. Edit Equation button

— Select the equation by right-clicking it. Run the Edit Equation context menu
command.
— Select the equation by double-clicking it.
2. In the Equation window (see Figure 226), in the LaTeX Expression box, edit
the equation.

3. Click OK.
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4.8.3 Resize an equation

1. Select the equation.
2. Hold down the left mouse button and drag any corner sizing handle so that the equation
becomes the desired size.

3. Release the left mouse button to fix the new equation size.

%ﬂ b+ lr:lf

w =

mfl 211 l&ﬂ

Figure 228. Resize an equation
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4.8.4 Delete an equation

1. Select an equation.
2. Run the command to delete a formula in one of the following ways:

()
— On the Toolbar, select the Equation section and click ‘@ Delete Equation
(see Figure 229).

Share Subscription Help
R

Q (g o
Equal pelete Equation FPP

w

w

Figure 229. Delete Equation button

Right-click with the button to open the context menu and click Delete Equation.

— Press Delete or Backspace.

You can also use keyboard shortcuts to delete text to remove an equation (see Section 4.2.10).
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4.9 Edit content
4.9.1 Undo and redo
4.9.1.1 Undo the last action
You can undo the last action performed on the content of a document.

To do this, use one of the following methods:

— In the Command menu, select Edit > Undo (see Figure 230).

Edit Insert Format Tools View Share

3 Undo Ctrl+Z
’ Redo Ctrl+Y
J Cut Ctrl+X
Copy Ctri+C
[Ty Paste Ctrl+V

Figure 230. Edit menu

— On the Toolbar, in the Edit section, click “3J Undo (see Figure 231).

Insert Format Tools WView Share Subss
~ -.':x:': _| ﬁ w %
=y [©9C &

File Edit

Figure 231. Undo and Redo buttons

— When working on Windows, press Ctrl+Z or Alt+Backspace, when working on macOS,

press 8Cmd+Z.

To undo several recent actions, run the undo command several times.
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4.9.1.2 Redo the result of the undone action

The undone action can be redone if necessary.

To do this, use one of the following methods:

— In the Command menu, select Edit > Redo (see Figure 230).

— On the Toolbar, in the Edit section, click ” Redo (see Figure 231).

— When working on Windows, press Ctrl+Y / Ctrl+Shift+Z / Shift+Alt+Backspace.

When working on macOS, press % Cmd+Y.

To redo the last few undone actions, run the redo command several times.
4.9.2 Clipboard

4.9.2.1 Copy or cut data

When you use the Cut command, the selected data is cut from the document and placed in
the clipboard. When copying, the selected data of the document does not change, and its copies are
placed to the clipboard.

The data copied or cut retains its formatting.

You can insert the data copied into MyOffice Text as well as into other applications, such as
MyOffice Spreadsheet.

To cut the content of the file, do the following:

1. Select the text that you want to cut.

2. Run the Cut command in one of the following ways:

— In the Command menu, click Edit and select Cut (see Figure 230).

— On the Toolbar, select the Edit section and click o Cut (see Figure 232):
— Right-click the selected text and run the Cut command.

—  Press Ctrl+X or Shift+Delete (Windows OS) or 3d8Cmd+X (macOS).

Insert Format Tools View Share Subsq
v X DB~ &
= v 9 C

File Edit

Figure 232. Cut and Copy buttons
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To copy the content, perform the following actions:

1. Select the text you want to copy.

2. Run the Copy command in one of the following ways:

In the Edit menu, select Copy (see Figure 230).

On the Toolbar, select the Edit section and click ' | Copy (see Figure 232).

Right-click the selected content and select Copy from the context menu.

Press Ctrl+C or Ctrl+Insert (Windows OS) or $Cmd+C (macOS).
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4.9.2.2 Paste the last copied or cut data

You can paste pre-copied or cut out data from the clipboard, with or without saving
the original formatting.
To paste the content while keeping the original formatting:
1. Place the cursor where you want to insert data in the document. Or select the text
(element) you want to replace with data from the clipboard.
2. Paste the content in one of the following ways:

— In the Edit menu, select Paste (see Figure 230).
— On the Toolbar, select the Edit section and click I Paste (see Figure 233).

— Onthe Toolbar, select the Edit section and click the button to the right of the I Paste
button. In the drop-down list, select Paste.

— Right-click to open the context menu and run the Paste command.

— Press Ctrl+V or Shift+Insert (Windows OS). When working on macOS, press
$Cmd+V.

Insert Format Tools View Share Subscription
— f

v X 0@y &

[51 Y (_') ('_) E| Paste

File Edit
Paste Text Only

Figure 233. Paste button

When you paste data without preserving the original formatting, only the text is pasted from
the clipboard. For example, when you paste a table, a shape with text, or a link, only the text that
these objects contain is pasted into the document. If the copied or cut fragment contains images, they
are not pasted into the document.

The style of the text to which the new text is added is applied to the text you are pasting from
the clipboard (see Section 4.3.2).
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To insert the content without keeping the initial formatting:

1. Place the cursor in the document where you want to insert data or select the text (element)

you want to replace with data from the clipboard.

2. Run the Paste command in one of the following ways:

— In the Edit menu, select Paste Text Only (see Figure 234).

Edit Insert Format

3 Undo
Redo
o Cut
3 [0 Copy
[Ty Paste

Paste Text Only

Figure 234. Edit menu

Tools
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Ctrl+C

Ctrl+V

Wiew

Share

A8l

— Onthe Toolbar, select the Edit section and click the button to the right of the ﬁ Paste

button. In the drop-down list, select Paste Text Only (see Figure 233).

— Right-click to open the context menu and run the Paste Text Only command.
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4.9.2.3 Clipboard history

In MyOffice Text, you can use the clipboard history. It can store up to ten copied or cut entries.
Each further entry overwrites the oldest existing entry.

The clipboard history works between MyOffice Text and MyOffice Spreadsheet and
vice versa.

Data from the clipboard history is pasted with the original formatting intact.

4.9.2.3.1 Paste data

To paste data from the clipboard history, do the following:

1. Place the pointer where you want to paste the data or select the text (object) you want to
replace with the data from the clipboard.

2. Open the clipboard history content in one of the following ways:

— In the Command menu, select Edit > Paste from Clipboard (see Figure 235).

Edit Insert Format Tools View Share Subscription Help
) Undo Ctrl+Z 5 XO Thame: vl [12 o] A —
C Redo Ctrl+Y _ o

Y B 1 J AB e = —
5 Cut Ctrl+X

Font Parag|
Copy Ctrl+C
Q) Paste Ctrl+V
Paste Text Only

Paste from Clipboard

»

Two households, both alike in dignity

(In fair Verona, where we lay our scene)

£ Copy Formatting Ctrl+Shift+C
Paste Formatting Clipboard History Ctrl+Alt+Shift+V
Clear
Select All Ctrl+A
Find Ctrl+F

Figure 235. Data in the clipboard history

Right-click to open the context menu and run the Paste from Clipboard command.

3. In the opened sub-menu, select data to be pasted.

For convenience, the content of the clipboard can be opened in a separate window.

To do this, do one of the following:

— In the Edit menu, select Paste from Clipboard > Clipboard History (see Figure 236).
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Edit Insert Format Tools WView Share Subscription Help
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[ Paste Ctrl+V
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Figure 236. Clipboard history management commands

— Open the context menu by right-clicking anywhere in the document and select
Paste from Clipboard > Clipboard History.

— Press Ctrl+Alt+Shift+V (Windows). When working in macOS,
press = Option+{ Shift+:% Cmd+V.

By default, the clipboard history window (see Figure 237) is placed next to the selected text
or element of the file. To change its position, drag it by the heading to the desired part of the document
while holding down the left mouse button.

To navigate through the clipboard history, the following applies:

— To move between the clipboard history elements, use the | and 1 keys.

— To insert the selected entry from the clipboard history into a specified area in a document,
left-click or press Enter.

— To switch between the document you are working on and the clipboard history, press Tab.

Click the  button at the window title to close the clipboard history.
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[T) Select text for pasting

Headway (5th edition) Upper-Intermediate Workbo...
English File Beginner 3rd Student's Book.

102 Simple English Conversation Dialogues for Begi...
English Grammar in Use

English Collocations in Use

Figure 237. Clipboard history

4.9.2.3.2 Clear the clipboard history

To clear the history of the clipboard history, follow these steps:
1. Open the clipboard history sub-menu in one of the following ways:
— In the Command menu, select Edit > Paste from Clipboard (see Figure 236).
— Open the context menu by right-clicking anywhere in the document and run
the Paste from Clipboard command.

2. In the opened sub-menu, select Clear.
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4.10 Page layout

4.10.1 Page setup

You can set the page parameters when preparing your file for printing (see Section 4.1.8).
The page parameters include:

— Page orientation

— Page Size

— Document Margins

Y ou can adjust page setup for the entire document or for its parts. For example, you can choose
the Portrait (vertical) orientation for the page with an image or table.

To adjust page setup for a part of the document, start with this:

1. Insert a section break (see Section 4.10.5) before and after the part of the document you

want to adjust the parameters of.

2. Set the cursor. Select the text, partially or entirely, in the desired part of the document.

To set the page setup, do the following:
1. Open the Page Setup window in one of the following ways:

— In the File menu, click Page Setup (see Figure 238). Or press Ctrl+Shift+P.

File Edit Insert Format Tools View

™ New Ctrl+N

MNew from Template...

[= Open.. Ctrl+0O
Open With... 4

Recent Files »

& Save Ctrl+S
Save As... F12

Autorecovery 4

Export To...

Save as Template...

Page Setup Ctrl+Shift+P

Figure 238. Page Setup command menu option
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— On the Toolbar, select the File section and click the arrow to theright of

the =) Quick Print button. In the drop-down list, click Page Setup (see Figure 239).

File Edit Insert Format Tools View Share

+ v DBy &
N =1 % s R &
Favorites
|E;] Cuick Print
& Print...

Export to POF

Page Setl.q;:lll\x3

Figure 239. Page Setup command

—  Press Ctrl+Shift+P / {iShift+3Cmd+P.

2. In the opened Page Setup window (see Figure 240), select the area to apply new
parameters:
— This Section: Apply all the subsequent changes to the selected section of
the document separated by the section breaks (see Section 4.10.5).
— Whole document: Apply all the subsequent changes to the entire document.
3. In the Orientation section, select the desired page orientation: Portrait (vertical) or
Landscape (horizontal).
4. In the Page Size drop-down list, select the size of paper to be used for printing.
5. Adjust the document margins as follows:
— To set the same margins for all pages of the document, specify their width in the Top
Margin, Bottom Margin, Left Margin, and Right Margin input boxes.
— To customize the margins for double-sided printing of a document whose pages will
be stapled together (for example, a brochure or book), select the Mirror margins
check box. This active setting means that the margins on the left pages of

the document will "mirror" the margins on the right pages of the document.
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Mirrer m argins

Figure 240. Page Setup window

In the Top Margin and Bottom Margin box, specify the width of the top and lower margins
of the document. In the Inside Margin box, specify the width of the inner margins, which are
the margins next to the binding. In the Outside Margin box, specify the width of the outer margins,

which are the margins located at the outer edge of the book or brochure.

Mirror margins can only be set for the whole document, but not for a part of it. Therefore,

this setting is active if you select Whole document from the Apply to drop-down list.

6. Click OK.
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4.10.2 Headers and footers

Headers and footers are located on each page of the document in the upper and lower margins

(see Section 4.11.1.1). Headers and footers can contain information that is not related to the main text

of the document but is of informational or design nature. For example, page numbers

(see Section 4.10.3), title of the document or its individual sections, company logo, etc.

The information placed in the headers and footers is unique for each section of the document

(see Section 4.10.5).

4.10.2.1 Configure headers and footers

To configure headers and footers, do the following:

1. Place the cursor on any page in the section (see Section 4.10.5) where you want to

customize headers or footers.

2. Switch to the header or footer editing mode using one of the following methods:

Insert

S H®

@ f
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ALY

Format Tools View  Share

Image...

Text Box

Shape »

Table...
Equation...

Special Characters...

Page Break Ctrl+Enter
Section Break

Page Numbers »
Header and Footer

Table of Contents

In the Command menu, select Insert > Header and Footer > Header / Footer

(see Figure 241).

Subscription Help

Font

Figure 241. Insert menu
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— On the Toolbar, in the Insert section, click the --= button. In the insert pane that

appears, select = Headers > Header / Footer (see Figure 242).

= -7 AaBbCcDd | ...  {Hv B4 (@) [£]

Ji= v = 3= H v C|'|' Normal
Paragraph Styles @ Image... ~
9 10 1 12 13 14 15 16 17 —t
Text Box
(5] Shape > Q
EH Table... >
@ Equation...
Special Characters... >
’H Page Break
= Section Break
Page Numbers... >
% Header @ Header and Footer >
@ Footer =:  Table of Contents
¢ Link..

Figure 242. Insert pane

— To customize the headers, move the mouse cursor to the top of the page. To customize

the footers, move the mouse cursor to the bottom of the page. When the cursor looks

like = or = , double-click with the mouse.
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3. Open the header and footer settings pane in one of the following ways:

— Below or above the footer, click Options and select Header Settings / Footer

Settings from the drop-down list (see Figure 243).

+ B - % © v & XOThames v 14 v A~ AT TT
Add @y O C & BT U~ &v &~

Favorites File Edit Font Paragraph Styles Insert ~

- =

Header Options

Header Settings

Remove Header

Page Numbers

Figure 243. Header Settings option

—  On the Sidebar, click @ Header or @ Footer (see Figure 244).
4. In the Settings pane, specify the required options (see Table 12).

File Edit Insert Format Tools Wiew Share Subscription Help
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Figure 244. Settings pane
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5. Add data to the header/footer: enter text or insert the desired object. Format

the header/footer content if necessary. If you have selected a special header/footer for

the first page and/or different headers/footers for even and odd pages, add and format

the content in each type of header/footer.

Table 12. Header and footer settings

Option

Action

Indent from the top

Indent from the bottom

Indent from the top edge of the page to the data entry line in
the header.

Indent from the bottom edge of the page to the data entry line
in the footer.

Different first page

Allows you to create unique content in headers and footers
both on the first page of the whole document and on the first
page of any of the sections.

When checked, both the header and footer of the first page
become the different ones.

When checked, the application saves the data that is entered in
the different header and footer and when checked/unchecked,
it displays/hides exactly that data.

Different even and odd pages

Applies to both header and footer at the same time.

Determining whether pages are even or odd always begins on
the first page of a document, regardless of whether there are
sections.

To quickly move from configuring the header to customizing the footer, select the footer with

a single click. The header settings pane closes, and the footer settings pane opens. You can move

from customizing the footer to customizing the header in the similar way.

The header or footer settings pane closes automatically when you exit the header and footer

editing mode. If necessary, it can be hidden manually while working with headers and footers.

To do this, proceed with one of the following:

— At the top of the pane, click = (see Figure 245).

— On the Sidebar, click @ Header or @ Footer.

Click @ Header or @ Footer again to display the pane.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 259



MyOffice

File Edit Insert Format Tools Wiew Share Subscription Help
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Figure 245. Pane management buttons

To exit header and footer editing mode, do one of the following:

Double-click the document text outside of the header and footer area.

— Click below the header or above the footer.

— Press Esc.
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4.10.2.2 Delete header and footer content

If necessary, you can delete header or footer content in the selected section of the document
(see Section 4.10.5). The following rules apply to deletion:

— If a document contains only one section, the contents of the headers and footers are
deleted throughout the document.

— If you have created a different header and/or footer for the first page, the contents of
the first page header and footer and the contents of the section footer need to be deleted
separately.

— If the section is configured with different headers and footers for even and odd pages,
the content of the headers and footers of those pages that are similar to the one selected
for deletion is deleted. For example, when you select an even-numbered page, the contents

of even-numbered page headers and footers are deleted.

To delete the contents of the headers and footers, follow the steps below:

1. Place the cursor on the page of the section where you want to delete header or footer
content. In this case:

— If the section has a different header and/or footer configured for the first page, place
the cursor on the first page to delete the header and/or footer content on the first page,
and on any other page in the section to delete the header and/or footer content on other
pages.

— If the section is configured with different headers and/or footers for even and odd
pages, place the cursor on an even page to delete header and/or footer content on even
pages, or place the cursor on an odd page to delete header and/or footer content on
odd pages in the section.

2. Switch to the header or footer editing mode using one of the following methods:

— In the Command menu, select Insert > Header and Footer > Header / Footer.
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Figure 246. Insert menu

— On the Toolbar, in the Insert section, click -=-. In the insert pane that appears, select

[ Header and Footer > Header / Footer (see Figure 260)
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Figure 247. Insert pane
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— To delete header contents, move the mouse cursor to the top of the page. To delete

footer contents, move the mouse cursor to the bottom of the page. When the cursor

changes to = or =, double-click the left mouse button.
3. Below the header or above the footer, click Options and select Remove Header /

Remove Footer from the drop-down list.

File Edit Insert Format Tools View Share Subscription Help
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Figure 248. Remove Header menu item
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4.10.3 Page numbers

The page numbers can be displayed in the document headers and footers (see Section 4.10.2).
Page numbers can be displayed in either a single header or footer, or both at the same time.

Page numbers are added and deleted within the selected section of the document
(see Section 4.10.5). In this case, the following rules apply:

— If a document contains only one section, page numbers are added and deleted throughout
the document.

— If a section has a different header and/or footer for the first page, the number on the first
page and the numbers on the other pages of the section need to be added and deleted
separately.

— If a section is configured with different headers and/or footers for even and odd pages,
the numbers on pages similar to the one selected when adding or deleting are added and

deleted. For example, if you select an even page, numbers on even-numbered pages are
added or deleted.

The page number is a text box (see Section 4.6.3).
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4.10.3.1 Insert page number

To quickly add page numbers in 1,2,3,... format, follow the steps below:

1. Place the cursor on the page of the section (see Section 4.10.5) where you want to add

page numbers. In this case:

If the section has a different header and/or footer configured for the first page
(see Section 4.10.2), place the cursor on the first page to add the number on the first
page, and on any other page in the section to add the number on other pages.

If the section is configured with different headers and/or footers for even and odd
pages, place the cursor on an even page to add numbers on even pages, or place

the cursor on an odd page to add numbers on odd pages in the section.

2. Open the insert sub-menu in one of the following ways:

In the Command menu, select Insert > Page Numbers (see Figure 249).
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Figure 249. Insert menu

On the Toolbar, in the Insert section, click ===. In the displayed insert pane, place

the cursor on the |%/ Page Numbers button (see Figure 250).
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3. Inthe sub-menu that opens, select a place to display page numbers.
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Shape

Table...

Equation...

Special Characters...

Page Break
Section Break
Page Numbers...
Header and Footer

Table of Contents

Link...
Cross-Reference...

Bookmark...

Figure 250. Insert pane

Follow the steps below to add and/or customize page numbers:

Y & @~ B

1. Place the cursor on the page of the section (see Section 4.10.5) where you want to add

and/or customize page numbers as described above.

2. Enter the edit mode for those headers and footers (see Section 4.10.2) where you want to

add and/or customize page numbers. For example, if you want to add and/or customize

page numbers in the headers, go to header editing mode. To do this, proceed with one of

the following:
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— On the Toolbar, in the Imsert section, click «:-.

[J Header and Footer > Header / Footer (see F igure 252).

In the Command menu, select Insert > Header and Footer > Header / Footer

(see Figure 251).

Insert Format

@ O ®

ENCON:

70 IC

-

LN

EE v = v 11~
v = = EHov
Paragraph
9 10 1 12
@ Header
@ Footer

Image...

Shape

Table...

Text Box

Equation...

Special Characters...

Page Break
Section Break

Page Numbers »
Header and Footer
Table of Contents

Tools View Share Subscription

Ctrl+Enter

» (5 Header
=] Footer

XO Thames

Figure 251. Insert menu
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@ Equation...
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)

Figure 252. Insert pane
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— To enter the header editing mode, move the mouse cursor to the top of the page. To

enter footer editing mode, move the mouse cursor to the bottom of the page. When

the cursor changes to — or =, double-click the left mouse button.

— If you have already added page numbers to the section, press Alt+P / ~= Option+P in
the English keyboard layout. The header or footer where the page numbers are located
will go into editing mode (see Figure 254). If page numbers are contained in both
the header and footer, the header will go into edit mode by default. The header and
footer settings pane will automatically appear on the right. Proceed to step 4.

3. Open the header and footer settings pane in one of the following ways:
— Below header or above the footer, click Options and select Page Numbers from

the drop-down list (see Figure 253).

— = v P - . — At
C O 0 - v X 0O B 8 XO Thames 14 AT A AsBbCa |
Q = v @ - a5 Q B T U - ﬁ v & o e {eader...Footer

Favorites File Edit Font Paragraph Styles Insert el
~

Q
B

Header Options

Header Settings

Remove Header

Page Numbers

Figure 253. Page Numbers menu

—  Onthe Sidebar, click @ Header or @ Footer (see Figure 254). In the header and footer

settings pane that opens, select the Page Numbers tab.
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Figure 254. Header/footer settings pane

In the header and footer settings pane, in the Page Numbers tab, specify the required
settings (see Figure 255):

— Format: Type of numbering, such as Arabic or Roman numerals.

— Alignment: Location of the number along the horizontal axis.

— Start from: The number from which the numbering starts.

Continue from previous section: Continue the numbering of the previous section.

File Edit Insert Format Tools View Share Subscription Help

coOBy By XD B~y & [omwe V[ a A = | T

A A =

@ = 8y ¢ > B I UM A-2

fifl Al
Il

q1

}
|
It

Favorites File Edit

paragraph Shape Styles Insert A

- Header Q

Settings  Page Numbers @

Format:
Header Options
12,3, .. v

=

Alignment:

Numbering:

Start from 1

© Continue from previous section

Figure 255. Page numbering pane

5. Exit header and footer editing mode in one of the following ways:

— Double-click the document text outside of the header and footer area.

— Click below the header or above the footer.

— Press Esc.

In header and footer editing mode, you can apply formatting to:
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— Text box in which the page number is located (see Section 4.6.3). For example, change
the fill (see Section 4.6.5) or outline (see Section 4.6.6) of a text box.

— Page number. For example, change the color or typeface. The page number formatting is
similar to the formatting of the main text of the document (see Section 4.3). To switch to

page number formatting, double-click to select the text box.
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4.10.3.2 Delete page numbers

To delete page numbers, follow the steps below:

1. Place the cursor on the page of the section where you want to delete page numbers. In this

case:

2. Go

If the section has a different header and/or footer configured for the first page, place
the cursor on the first page to delete the number on the first page, and on any other
page in the section to delete the number on other pages.

If the section is configured with different headers and/or footers for even and odd
pages, place the cursor on an even page to delete numbers on even pages, or place
the cursor on an odd page to delete numbers on odd pages in the section.

to the header and footer editing mode, where page numbers are displayed. For

example, if page numbers are displayed in the header, go to the header editing mode. To

do this, proceed with one of the following:

In the Command menu, select Insert > Header and Footer > Header / Footer
(see Figure 251).

On the Toolbar, in the Insert section, click =-=. In the insert pane that appears, select
[~/ Header and Footer > Header / Footer (see Figure 252).

To enter the header editing mode, move the mouse cursor to the top of the page. To

enter footer editing mode, move the mouse cursor to the bottom of the page. When

the cursor changes to or =, double-click the left mouse button.

Press Alt+P / ~= Option+P in English keyboard layout. The header or footer where
the page numbers are located will go into editing mode. If page numbers are contained
in both the header and footer, the header will go into edit mode by default.

Delete page numbers in one of the following ways:

Below header or above the footer, click Options and select Remove Page Numbers

from the drop-down list (see Figure 256).
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Figure 256. Options button
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© Continue from previous section

— Below header or above the footer, click Options and select Page Numbers from

the drop-down list (see Figure 256). In the header and footer settings pane, on

the Page Numbers tab, in the Format drop-down list, select No Page Numbers

(see Figure 257).

Header Options

Figure 257. Format drop-down list

Settings Page Numbers
Format
1,23, .. v
No Page Numbers
Vo123, ..
LILHL, ...
i, ...
ABC, ..
abg, ..
Page 1

Tof1

— Single-click to select the text box with the page number and on the Toolbar, in

the Shape section, click @ Delete Shape.
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Figure 258. Delete shape button

— Single-click to select the page number text box and press Delete or Backspace.
4. Exit header and footer editing mode in one of the following ways:

— Double-click the document text outside of the header and footer area.

— Click below the header or above the footer.

—  Press Esc.
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4.10.4 Page break

MyOffice Text automatically breaks the document into pages. You also can add custom page
breaks anywhere in the document.
Simply follow these steps:
1. Place the cursor in the place of the document where you want to start a new page.
2. Insert a page break in one of the following ways:
— In the Insert menu, click Page Break (see Figure 259).
— Press Ctrl+Enter / sCmd+Enter.

Insert Format Tools View Share

Image...
Text Box

Shape ’

Table...

Equation...

BeB#E @QHE

Special Characters...

Page Break Ctrl+Enter

A IC

Section Break

Figure 259. Insert menu
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— On the Toolbar, in the Insert section, click ==-. In the displayed insert pane, click

"~ Page Break (see Figure 260).

Y Ny 000 |
AaBbCcD .. @v @ v E .

Heading 1
Styles @ Image... ~
" i V Text Box
(5] Shape > Q
[==] Table... >
@ Equation...
Special Characters >
= Page Break
"= Section Break
@ Page Numbers...
@ Header and Footer
= Table of Contents

Figure 260. Insert pane

—  Press Ctrl+Enter.
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4.10.5 Section break

Unique page settings (see Section 4.10.1) and footers (see Section 4.10.2) can be customized
for each section of the document.

By default, a document consists of a single section. To divide a document into multiple
sections, separate them from each other with a non-printable character called a section break. For
example, to make each chapter in a document with three chapters a separate section, set a section
break after each chapter in the document.

To insert a section break, do the following:

1. Specify where you want to insert a section break:

— Place the cursor where you want to insert a section break.
— If a section break must be inserted before and after the text fragment, select this
fragment.

2. Insert the section break in one of the following ways:

— In the Insert menu, select Section Break (see Figure 259).
— On the Toolbar, in the Insert section, click ===. In the displayed insert pane,

click "= Section Break (see Figure 260).
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4.10.6 Table of contents

MyOffice Text allows you to add a table of contents that is formed from the existing headings
of the document. The heading is a fragment of text where the built-in styles for Heading 1-Heading 5
or custom styles are applied (see Section 4.3.2).

By default, a table of contents includes the headings with built-in styles applied: Heading 1,
Heading 2, and Heading 3. You can change which headings and heading levels should be included
in the table of contents at any time.

The table of contents is updated automatically and reflects both changes in the headings and

their respective page numbers.
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4.10.6.1 Apply heading styles

Make sure to apply the heading styles to the fragments that become titles of the table of
contents before inserting the table of contents. For example, if your document includes chapters,
sections, and subsections, apply the Heading 1 style to chapter headings, the Heading 2 style to
section headings, and the Heading 3 style to subsection headings.

To apply a heading style, follow the steps below:

1. Select the text or place the cursor in the text you want to use as a heading.

2. On the Toolbar, select the Styles section in one of the following ways:

— Select a heading style from the drop-down list (see Figure 261).

AaBbCcl AaBbCc AaBbCcl AaBbCcDi AaBbCcDe

Marma Heading 1 Heading 2 Heading 3 Heading 4

Styles

Figure 261. Styles section
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— Click the == button and select the heading style from the drop-down list
(see Figure 262).

AaBbCcl  AaBbCc AaBbCcl AaBbCcDi AaBbCcDe |'I‘|

Mormal Heading 1 Hp=
Styles

§ 7 : o W 1 AaBbCcDdEeFfGgHhIiJjKkL.

Mormal

AaBbCcDdEeFfGgHhIiJjl

Heading 1

AaBbCcDdEeFfGgHITjKk

Heading 2

AaBbCcDdEeFfGgHIL jJKKLIM

A
Heading 3

AaBbCcDdEeFfGgHhLJjKkLIMm

Heading 4

AaBbCcDdEeFfGgHhILTjKKLIMmN

R R
Heading 5

+ Create New Style

Figure 262. Apply style

Once the styles are applied, you can proceed with inserting the table of contents.
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4.10.6.2 Insert a table of contents

To insert a table of contents, follow the steps below:
1. Put the cursor before the place where you want to insert the table of contents.
2. Insert the table of contents in one of the following ways:

— In the Insert menu, click Table of Contents (see Figure 263).

Insert Format Tools View Share

Image...
Text Box

Shape 4

Table...

Equation...

BeEH QO

Special Characters...

1T

Page Break Ctrl+Enter

||'[

Section Break
Page Numbers 4

Header and Footer 4

i #

Table of Contents

Figure 263. Insert menu

— On the Toolbar, in the Insert section, click ===. In the displayed insert pane, click

Table of Contents (see Figure 264).
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Figure 264. Insert pane

By default, the table of contents is always separated from the rest of the document by a page
break (see Section 4.10.4). You can remove it if needed.

You need to enter the name of the table of contents manually.
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4.10.6.3 Edit a table of contents

You may perform the following actions to edit a table of contents:

Add or remove levels of the table of contents.

Hide or display page numbers in the table of contents.

To edit a table of contents, follow one of the steps below:
L.

Change the heading styles for the table of contents levels.

Left-click with the left mouse button on the table of contents. On the Toolbar, select

the Contents section and click EE':" Edit (see Figure 265).

File Edit Insert Format Tools

(SO B 5 I = v

View Share Subscription Help

X 0 @~
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~
Q
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8T 1 JOT OO 2

Figure 265. Edit button

2. Right-click the table of contents with the mouse and select Edit Table of Contents.
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The Edit Table of Contents window opens (see Figure 266).

Edit Table of Contents b4
Heading 1 v
Heading 2 -
Heading 3 v | X

+ New Level

Display page numbers

Figure 266. Edit Table of Contents window

When you have completed all necessary actions, click X or click outside the window to close

the Edit Table of Contents window.
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4.10.6.3.1 Add a new level of table of contents

You can add up to 9 levels of a table of contents headings. By default, it consists of three
levels. The first level of the table of contents comprises the headings with the Heading 1 style
applied. Heading 2 is the second level. Heading 3 is the third level.

The table of contents typically includes no more than five heading levels.
If you add a fourth and fifth level of the table of contents, they will automatically have predefined
styles of Heading 4 and Heading 5, respectively.

If you want to add more than five levels of headings to the table of contents, create custom
styles (see Section 4.3.2.2) and apply them to the desired headings (see Section 4.10.6.1). Then add

the table of contents levels that will be created from these headings.
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To add a new level of table of contents, follow the steps below:
1. Inthe Edit Table of Contents window, click + New Level (see Figure 267). A new table

of contents line will appear in the level list (see Figure 267).

Edit Table of Contents X
I Heading 1 v
2 Heading 2 v
Heading 3 v | X

+ Mew Level

(] Display page numbers

Figure 267. Add table of contents level

2. Select the headings style you want to apply to this level of the table of contents from
the drop-down list or leave the style selected by default (see Figure 268).
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Figure 268. Select style
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4.10.6.3.2 Change the headings style for the table of contents level

You can create thetable of contents levels from the headings with predefined styles
Heading 1 - Heading 5 applied, as well as from the headings with custom styles applied
(see Section 4.3.2).

To change the style of the headings that form a table of contents level, follow the steps below:

1. In the Edit Table of Contents window, on the desired line, expand the styles drop-down

list (see Figure 269).

2. Select the headings style you want to apply to this level of the table of contents from

the drop-down list.

Edit Table of Contents p 4

Heading 1 v
Normal

+ Heading 1

3 Heading 2
Heading 3
Heading 4
Heading 5
Title
Subtitle
Header and Footer
Di:

Footnote
Default Paragraph Font
Stylel

Style2

Style3

Figure 269. Select style
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4.10.6.3.3 Remove a level of table of contents

If necessary, you can reduce the number of the table of contents levels. For example, you can
convert the table of contents which consists of four levels into a table of contents of two levels.
For this purpose, you should remove the fourth and third levels of the table of contents.

You can remove the levels of the table of contents from the list, starting with the last one.

To remove the last level of the table of contents, click the * button to the right of this level in

the Edit Table of Contents window (see Figure 270).

Edit Table of Contents X
Heading 1 v
2 Heading 2 v
3 Heading 3 v
4 Heading 4 v
5 Heading 5 v !%
+ New Level
Display page numbers

Figure 270. Delete table of contents level
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4.10.6.3.4 Hide or display the page numbers

By default, for each heading of the table of contents is indicated the page number where it is
located (see Figure 271). Page numbers are calculated automatically.

To hide page numbers in the table of contents, clear the Display page numbers check box in
the Edit table of Contents (see Figure 270) window.

To return to displaying page numbers, select the check box.

4.10.6.4 Format the table of content

When you create a table of contents, the default formatting is applied. You can change the font

and paragraph properties for the table of contents, if necessary.

Formatting applies to the entire table of contents. Changing the formatting of individual

parts of the table of contents is not possible.

Formatting the table of contents is similar to formatting the main text of the document.
To format the table of contents, select it first. To do this, click the table of contents with

the left mouse button.
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4.10.6.5 Remove a table of contents

To remove a table of contents, use one of the following steps:

1. Select the table of contents with the left click. On the Toolbar, select the Contents section

and click =& Delete (see Figure 271).
2. Click the table of contents and press Delete.

3. Right-click the table of contents and then click Remove Table of Contents in the shortcut

menu (see Figure 271).

File Edit Inset Format Tools View Share Subscription Help
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Figure 271. Delete button
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4.11 View feature

4.11.1 Ruler

Rulers allow you to quickly and accurately adjust indents and margins of your document both
horizontally and vertically. You can find the horizontal ruler under the Toolbar and the vertical ruler
along the left edge of the document. By default, both rulers are displayed.

If you want to hide rulers or display previously hidden rulers, do one of the following:

1. Inthe Command menu, select View and uncheck or check the Ruler option (see Figure 272).

2. Press Ctrl+Shift+R / {iShift+3Cmd+R.

View Share Subscription Help
~  Ruler Ctrl+Shift+R

MNon-Printable Characters
Presentation View
Zoom 4

Toolbar 4

Figure 272. View menu
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4.11.1.1 Set document margins

The gray sections of the rulers are the margins width (see Figure 273 and Figure 274).

1 <HJJ'='.} 1 2

Figure 273. Left margin border

Top Margin

Figure 274. Top margin border

To change the margin size, follow the steps below:

1. Put the cursor on the ruler so the cursor turns into a double-headed arrow.

2. Hold down the left mouse button and drag the cursor to move the margin to the desired
mark.

3. Release the left mouse button to fix the position.

You can also adjust the margins using the Page Setup window (see Section 4.10.1).
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4.11.1.2 Set paragraph indents

The paragraph indent marker is a blue triangle on a horizontal ruler (see Figure 275).

2 MR AT

Figure 275. Paragraph indent marker

To change the paragraph indent, follow the steps below:
1. Hold down the left mouse button on the marker and drag it to the desired position.

2. Release the left mouse button to fix the new position.
Changing the paragraph indent also changes the first-line indent, while maintaining

the distance between them.

You can also adjust the margins using the Paragraph settings window (see Section 4.3.8.5).
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4.11.1.3 Set first-line indent

The first-line indent marker is a blue rectangle on a horizontal ruler (see Figure 276).

E 3 4 5 ]

Figure 276. First-line indent marker

To change the first-line indent, follow the steps below:

1. Hold down the left mouse button on the marker and drag it to the desired position.

2. Release the left mouse button to fix the new position.

You can also adjust the first-line indent using the Paragraph settings window

(see Section 4.3.8.5).

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 294



MyOffice

4.11.2 Zoom

By default, the scale of the document is 100%. If necessary, you can zoom it in or zoom out

using the Command menu or the Status bar.

To change the scale using the Command menu, follow the steps below:
1. Inthe View menu, select Zoom (see Figure 277).
2. In the opened list, select the desired option:

— Zoom In: Increase the current zoom by 10%.

— Zoom Out: Decrease the current zoom by 10%.

— Actual Size: Set the default zoom (100%).

View Share Subscription Help
~  Ruler Ctrl+Shift+R -
AT AT
MNon-Printable Characters

Presentation View

Zoom L4 Zoom In
Zoom Qut
Actual Size Ctrl+0

Toolbar L4

Figure 277. View menu

To change the zoom using the Status bar (see Figure 278), do one of the following:

1. With the left mouse button pressed, move the slider to the right or left to zoom in or out,
respectively.

2. Click + to zoom in or — to zoom out. In each case, the zoom increment is 10%.

3. Select the current zoom value with the cursor in the lower right corner, modify it and press
Enter to confirm.

4. Press the arrow to the right of the current zoom value and select the zoom from the drop-

down list.

Fage 1 of 4 |- ® + 100% v

Figure 278. Status bar

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 295



MyOffice

4.11.3 Presentation view

To switch to the Presentation View, in the Command menu, click View and select

Presentation View (see Figure 279).

View Share Subscription Help
~  Ruler Ctrl+Shift+R

MNon-Printable Characters

Presentation View
Zoom »
Toolbar »

Figure 279. View menu

The Presentation View (see Figure 280) allows you to use the full screen to view your
document.
To navigate through the pages of a document, use the following keys on the keyboard:
— Right arrow or Space: Go to the next page.
— Left arrow: Go to the previous page.

To exit the Presentation View, press Esc.

MyOffice Text

e Text allows fast & il

PLERES, ARyhed Bl
ormatting on all popular operating systems, Lse Comment and Track changes featuees 10 review

Figure 280. Presentation View
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4.12 Review feature
4.12.1 Changes

4.12.1.1 Track changes

The track changes mode is used to track, process, and store changes made to a document by
you or other users. To start tracking the changes, you need to enable the Track Changes mode first.
You can view and process the changes when the mode is disabled.

The mode status is saved after you save a file. The document closed with tracking changes
mode enabled will keep this property next time you open it.

To enable or disable the Track Changes mode, in the Command menu, click
Tools > Display Changes and Comments and check or uncheck the Track Changes box

(see Figure 281).

Tools View Share Subscription Help

Display Changes and Comments . Track Changes
Spelling and Grammar »
P 9 Markup Changes
Custom Dictionary _ . L
Display Document With Changes
Change Language... Display Original Document
Macro Editor Y Filter Comments
Compare with... (beta) I

Figure 281. Tools menu
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4.12.1.2 Track and view changes

You can track and view the following types of changes in the document:

— Text inserted and deleted

— Images inserted and deleted

— Links inserted, edited, and deleted

— Text formatted

— Paragraph formatted

The pane displaying changes made by all users is located to the right of the editing area.
Each user is assigned a distinguishing color.

Click the change with the mouse to view its detailed description.

The documents display changes made both in MyOffice Text and in third-party editors.
The following types of changes are supported:

— Enter and delete text

— Text formatting

— Paragraph formatting

— Insert and delete images

— Insert and delete tables and rows in tables

— Insert, edit, and delete links

Changes are marked with color and displayed in the Review pane

(see Figure 282). Changes made by different users are marked with different unique colors.
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Figure 282. Changes
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Additional color marking is applied to added and deleted rows and tables: the background of
added rows and tables is colored green; the background of deleted rows and tables is colored red

(see Figure 286).

Deleted ""

Added "

Figure 283. Color marking in tables

The following limitations apply to the current version of the application:

— In documents saved in LibreOffice Writer and then opened in MyOffice Text, changes
may not be displayed correctly.

— Changes time is incorrectly displayed in .odt documents created in MyOffice Text and
then opened in LibreOffice Writer.

— If text wrapping is configured for a table (see Section 4.4.10) and the user accepts
the deletion of text (see Section 4.12.1.4.1) that contains the anchor of that table (see
Section 4.3.1), that table is deleted along with the text.

Changes with a large amount of text are displayed in the Review pane in abbreviated form.

To view the full description of a change, click on it.
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4.12.1.3 Move between changes

To quickly move to the next change, do one of the following:

1. On the Toolbar, select the Review section and click @ Next Change or Comment
(see Figure 284).
2. Press Alt+F7.

To quickly move to the previous change, on the Toolbar, select the Review section and click

© Previous Change or Comment.
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MyOffice Text is an editor for quick and easy creation and formatting of text
documents of any complexity on Linux, Windows and macOS operating systerns.
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Figure 284. Buttons to move between changes
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4.12.1.4 Accept and reject changes

You can work with changes in the Markup Changes mode (see Section 4.12.1.5).

4.12.1.4.1 Accept changes

To accept one change, use one of the following methods:

1. In the Review pane, place the cursor over the desired change and click * Accept

(see Figure 285).
B X0 By & v @~ E o ommes v[u v A A =V =v T Tr
S 9 € TvOO «'BI U~ Av@y =v =" T .

File Edit Review Font Paragraph Styles

MyOffice Text is an editor for quick and easy creation and formatting of text . o
\4 " - Added " of any complexity’
documents of any cornplexity.

Figure 285. Accept and Reject buttons

Insert

2. In the Review pane, select the desired change and perform one of the following actions

(see Figure 286):

— In the Review pane, click ' Accept.

— On the Toolbar, select the Review section and click © Accept Change.

— On theToolbar of theReview section, click the arrow to

the © Accept Change button and select Accept Change.
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MyOffice Text is an editor for quick and easy creation and formatting of text
documents of any complexity.
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Figure 286. Accept change
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To accept all the changes in one or multiple paragraphs, select those paragraphs, then follow

one of the steps below:
1. On the Toolbar, select the Review section and click © Accept Change.
2. On the Toolbar, select the Review section and thearrow to theright of

the © Accept Change button and select Accept Change.

To accept all the changes in a document, on the Toolbar, select the Review section and click

the arrow to theright of the'@J Accept Change button. In thelist that expands, click
Accept All Changes.
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4.12.1.4.2 Reject changes

To reject one change, use one of the following steps:

1. In the Review pane, place the cursor over the desired change and click = Reject
(see Figure 285).

2. In the Review pane, select the desired change and perform one of the following actions
(see Figure 287):
— In the Review pane, click *' Reject.
— On the Toolbar, select the Review section and click ® Reject Change.

— On the Toolbar, select the Review section and click the arrow to the right of

the © Reject Change button and select Reject Change.

To reject all the changes in one or multiple paragraphs, select those paragraphs, then follow

one of the steps below:

1. On the Toolbar, select the Review section and click ® Reject Change.
2. On the Toolbar, select the Review section, click thearrow to theright of
the ® Reject Change button and select Reject Change.

To reject all the changes in a document, on the Toolbar, select the Review section and click

the arrow to theright of the'i::J Reject Change button. In thelist that expands, click

Reject All Changes.
+ XB ey & ©vBR XoThames v/ (14 [v| A" AY v = v it Tr
u =v == B q

Reject Change

Add S v 9 % TR

Favori tes File Edit Review

B I U « Av &
lont Paragraph Styles Insert
Reject All Changes |

MyOffice Text is an editor for quick and easy creation and formatting of text
documents’

Added " of any complexity”

Figure 287. Reject changes
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4.12.1.5 Markup changes

By default, all changes in the document are marked. The mode of displaying the changes

can be changed at any time. Simply follow these steps:
1. Open the list of review modes in one of the following ways:
2. In the Command menu, click Tools and select Display Changes and Comments

(see Figure 288).

Tools View Share Subscription Help

Display Changes and Comments * + Track Changes

Spelli dG »
peliing and Grammar ® Markup Changes
Custom Dicti
ustom Mictionary Display Document With Changes

Change Language... Display Original Document
Macro Editor S Filter Cormments
Compare with... (beta) [

Figure 288. Tools command menu

3. Onthe Toolbar, select the Review section and click “** Display Changes and Comments

(see Figure 289).
4. Inthe list that expands, select the desired mode:
— Markup Changes: The file contains both confirmed and unconfirmed changes.

Unconfirmed changes are marked with a color and displayed in the Review pane

(see Figure 289).
+ =) A I @y ® v [E XOThames v |14 v A” A* =y =V v Tr
ad @y O C & TvyO©O® ="B I U« 4AvE&v =v &=H8v T

Favorites File Edit Review Paragraph Styles Insert

v Markup Changes

Display Document With Changes

Display Original Document

MyOffice Text is an editor for quick and easy creation and formatting of text | @Added S —
documents of any complexity. | v comp

Figure 289. Markup Changes mode

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 304



MyOffice
— Display Document With Changes: The file contains both confirmed and

unconfirmed changes. Unconfirmed changes are not marked with a color. The Review
pane is hidden (see Figure 290).
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Figure 290. Display Document With Changes mode

Display Original Document: The file contains the confirmed changes only.

The Review pane is hidden. Files cannot be edited (see Figure 291).
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Figure 291. Display Original Document mode
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4.12.2 Comments

Comments are useful when several users are working on the document alternately. They can

share their ideas and remarks on a document as comments.

In addition, users can reply to each other's comments, thus forming discussion threads on

specific pieces of text or questions.

The following limitations are currently in place:

— Comments and discussion threads are not printed out.

— No notification when a comment or reply has been changed.

— The discussion thread can be broken and displayed as separate comments if the document
was opened and saved in a third-party text editor (except for LibreOffice Writer), in
MyOffice Text web or mobile application, in MyOffice Text desktop editor earlier than
2.7 version.

— Comments in the header and footer section (see Section 4.10.2) in .odt and .xodt file
formats only. When you save a document in .docx format, comments in the header and
footer section are automatically deleted.

— When you close a document, comments to tables for which text wrapping is set are not

saved (see Section 4.4.10.2).

Comments and discussion threads are displayed on the Review pane.

Key advantages of our products:

Elena A |
. MyQffice solutions comprise all the tools necessary for efficient teamwork. You can Today 17:34
discuss and edit documents with your colleagues from anywhere. Thanks to the track A new comment
changes and version tracking functions, all changes will be saved.
I A |
. Documents created in MyQffice apps have the same appearance no matter what device T;?ﬂnay s L

is used to display them.
Change the paragraph

. MyQffice works with all the popular Q$s and platforms, including Russian Linux-based

operating systems and Aurora OS for mobile. MyQffice also runs on hardware from Aleksandr 2 i@
MSCT Elbrus and Baikal Electronics JSC. Today 17:39
Delete this
. You decide where your data is stored. MyQffice solutions create a secure work

Figure 292. Comment and reply to it

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 306



MyOffice

4.12.2.1 Comment display mode

By default, all comments in the document are displayed. Changing the display mode for
the comments is performed in thesame way as changing thetracking changes mode

(see Section 4.12.1.5).
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4.12.2.2 Add a comment

To add a comment, follow the steps below:

1. Place the cursor where you want to add a comment or select a text you want to

comment on.

2. Switch to the comment mode in one of the following ways:

Insert Format Tools

REeHE QHO

0 JC

v

m o #

0]z o0 %

the Command menu, select

(see Figure 293).

Image...
Text Box

Shape

Table...

Equation...

Special Characters...

Page Break
Section Break
Page Numbers
Header and Footer

Table of Contents

Link...
Cross-Reference...
Bookmark...
Footnote

Comment

the Insert section and click Comment

View Share

Ctrl+Enter

Ctrl+K

Figure 293. Insert menu
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— On the Toolbar, select the Insert section and click E Comment (see Figure 294).

AaBbCcD AaBbCcl AaBbCcD ... @\. @ v E]

Marmal Heading 1 Heading 2

Styles Insert ~

Figure 294. Comment button

— On the Toolbar, select the Insert section and click the == button (see Figure 295).

In the displayed insert pane, place the cursor to the E] Comment button.

. A A
AaBbCcDd | .. [ B @) B - .

Normal
Styles B Image... ~
4 15 16 17 Text Box
6] Shape > O‘
==z) Table... >
@ Equation...
Special Characters... >
'H Page Break
'E Section Break
Page Numbers... >
@ Header and Footer >
= Table of Contents
(5/) Link...
::.:l Cross-Reference...
I Bookmark...
AR Footnote >
E] Comment

Figure 295. Insert pane
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— Right-click the selected text and select the Comment from the context menu.
3. Enter the desired text in the comment field (see Figure 296).
4. If you want to cancel entering a comment, press Esc. If you want to save the comment,
perform one of the following actions:
— In the comment field, click Save.
— Click anywhere in the document.

—  Press Ctrl+Enter / 8Cmd-+Enter.
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Key advantages of our products:

. MyQffise solutions comprise all the tools necessary for efficient teamwork. You can
discuss and edit documents with your colleagues from anywhere. Thanks to the track

Ivan
changes and version tracking functions, all changes will be saved.

Save
Documents created in MyQffice apps have the same appearance no matter what device
is used to display them.

Figure 296. Add a comment

Empty comments are deleted automatically.

Long comments are displayed in abbreviated form in the Review pane. To view the full text

of a comment, click to select it.
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4.12.2.3 Reply to a comment

The responses to the comment are displayed in chronological order. You can only reply to a
comment, adding an answer to an answer is not allowed.
To reply to a comment, do the following:
1. Select the comment to which you want to answer in one of the following ways:
— Click the comment or any other reply to the comment.
— Go to thecomment using the (=) Next Change or Comment and
@ Previous Change or Comment on the Toolbar, in the Review section
(see Figure 297).
— If the cursor is set in the Review pane, navigate to the comment using the keyboard

keys | and 1.

Subscription Help
v | & Dv ® v [

Y vl© ] -

Review

Figure 297. Buttons to move between comments

2. In the comment response field, enter the text you want to (see Figure 298).

3. If you want to cancel entering an answer, press the Esc key. If you want to save your
answer, do one of the following:
— Click Save in the reply field.
— Left-click anywhere in the document.

—  Press Ctrl+Enter / £Cmd+Enter.

Key advantages of our products:

A |
MyQffice solutions comprise all the tocls necessary for efficient teamwork. You can Today 17:34
discuss and edit documents with your colleagues from anywhere. Thanks to the track A new comment

changes and version tracking functions, all changes will be saved.

Documents created in MyQffice apps have the same appearance no matter what device
is used to display them.

MyQffice works with all the popular QSs and platforms, including Russian Linux-based
operating systems and Aurora OS for mobile. MyQffice also runs on hardware from
MSCI Elbrus and Baikal Electronics JSC.

Figure 298. Comment reply field
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Blank replies are automatically deleted.

Long comments and responses are displayed in the Review pane in abbreviated form
(see Figure 299). To display the full text of a comment and all replies to it, click the comment or any
of the replies.

If a thread contains more than two replies, it is automatically collapsed and only the first and
last replies are displayed in the Review pane. To expand the conversation, click the Show n more

replies separator.

Key advantages of our products:

. MyQffice solutions comprise all the tools necessary for efficient teamwork. You can
discuss and edit documents with your colleagues from anywhere. Thanks to the track o
changes and version tracking functlons,|a1| changes will be saved. Toda 8:58

Please add this information

. Documents created in MyQffice apps have the same appearance no matter what device

is used to display them.

Show 2 more replies

. MyQffice works with all the popular Q§s and platforms, including Russian Linux-based
operating systems and Aurora OS for mobile. MyQffice also runs on hardware from
MSECIL Elbrus and Baikal Electronics JSG.

@ Aleksandr
T 20:40

Please find the answer below

Figure 299. Thread

If the thread becomes longer than the page height when unfolded, the Review pane displays
buttons to navigate to the beginning and end of the thread to go to the beginning and end of the thread:

and
To collapse the thread, do one of the following:
— Click anywhere in the document outside of the thread.
— Click another comment or thread.
— Navigate to another comment or thread using the (=) Next Change or Comment and
(©) Previous Change or Comment buttons on the Toolbar in the Review section
(see Figure 297).

— Move to another comment or thread using the keyboard keys:

land 1.
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4.12.2.4 Move between comments or threads

To quickly move between comments and threads, use the (=) Next Change or Comment and
@ Previous Change or Comment buttons, which are located on the Toolbar, in the Review section

(see Figure 322).

4.12.2.5 Filter comments

Using filtering, you can hide or display the comments of selected reviewers in the Review
pane. To filter the comments, do the following:
1. Open the window where you can filter comments in one of the following ways:
— In the Command menu, select Tools > Display Changes and Comments >

Filter Comments (see Figure 300).

Tools View Share Subscription Help

Display Changes and Comments * + Track Changes

Spelli dG 4
pefing andrammar ® Markup Changes
Custorn Dicti
Histom Micfonary Display Document With Changes

Change Language... Display Original Document
Macro Editor % Filter Comments
Compare with... (beta) [

Figure 300. Tools menu

— On the Toolbar, in the Review section, click ? Filter Comments (see Figure 301).
— On the Toolbar, in the Review section, click thearrow to theright of

the I Filter Comments button and select Filter Comments from the drop-down list.

v & Qv ®v R
¢ Mo -

? Filter Comments

Clear Filter

Figure 301. Review section
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2. In the Filter Comments window (see Figure 302), clear the Select all check box.
3. Check the check boxes of the reviewers whose comments you want to display in
the Review pane.
4. If the list contains a large number of reviewers, use the search bar:
— Enter part or the full name of the desired reviewer in the search bar
— Check the box of the reviewer in the search results.
— Repeat steps as needed to find and check other reviewers.

5. Click OK.

Filter Comments X

Select all

Ivan Smirnov i
Olga Smirnova

Aleksandr Petrov

Figure 302. Filter Comments window

To return to displaying comments from all reviewers, do one of the following:
— On the Toolbar, under Review, click the arrow to the right of the ? Filter Comments
button and select Clear Filter from the drop-down list (see Figure 301).

— Open the Filter Comments window (see Figure 302) as described above, check

the Select all check box and click OK.

The following limitations are currently in place:
— The Delete All Comments command (see Section 4.12.2.8) deletes all comments in

the document, even if filtering is enabled.
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— The Filter Comments window does not display the names of reviewers whose comments

have been deleted.

4.12.2.6 Edit a comment or thread

To edit a comment or thread, use the following techniques:
1. Select the comment or reply in one of the following ways:

— Place the cursor on the comment field. In the upper right corner, click the # Edit

(see Figure 303).

Key advantages of our products:

Elena Ca |
. MyQffice solutions comprise all the tools necessary for efficient teamwork. You can Today 17:34 N
discuss and edit documents with your colleagues from anywhere. Thanks to the track A new comment

changes and version tracking functions, all changes will be saved.

Figure 303. Comment area

— Select the comment or thread by double-clicking it.
2. Change the comment or thread.
3. If you want to cancel the changes, press Esc. If you want to save the changes, do one of
the following:
— In the comment or thread field, click Save (see Figure 304).
— Click anywhere in the document.

—  Press Ctrl+Enter / £Cmd+Enter.

Key advantages of our products:

. MyQffise solutions comprise all the tools necessary for efficient teamwork. You can
discuss and edit documents with your colleagues from anywhere. Thanks to the track Ivan
changes and version tracking functions, all changes will be saved. Today

w

. Documents created in MyQffice apps have the same appearance no matter what device
is used to display them.

. MuQffice works with all the popular QSs and platforms, including Russian Linux-based

Figure 304. Comment field

Blank comments and replies are automatically deleted.
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4.12.2.7 Copy, cut, and insert comments or threads

You can copy comments and threads within one document or between MyOffice Text
documents.

To copy a comment or thread, select the whole commented text or the element to which they
refer. If you cut or copy a part of text, the comment or thread is not cut or copied.

Copying and pasting the commented text is performed in standard ways (see Section 4.9.2).
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4.12.2.8 Delete a comment or reply

The comment is deleted along with the replies to it.
To quickly delete a comment, hover over it and click i Delete in the upper right corner of

the comment (see Figure 305).

° MyQffice solutions comprise all the tools necessary for efficient teamwork. You can
discuss and edit documents with your colleagues from anywhere. Thanks to the track van ;@
changes and version tracking functions,lall changes will be saved. Today  18:58 b

Please add this information
. Documents created in MyQffice apps have the same appearance no matter what device

Figure 305. Delete button

To delete a comment, you can also do the following:
1. Select a comment in one of the following ways:
— Click the comment or any reply to a comment.
— Navigate to the comment using the (=) Next Change or Comment and (©) Previous

Change or Comment buttons on the Toolbar under Review (see Figure 306).

v A Qv @~ @&
¢ v-[@0o] -

Review

Figure 306. Buttons to move between comments

— With the cursor positioned in the Review pane, navigate to the comment using
the keyboard keys | and 1.

2. Delete the comment in one of the following ways:

— On the Toolbar, select the Review section and click EDelete Comment
(see Figure 307).

— On the Toolbar, select the Review section and click the arrow to theright of

the ﬁ Delete Comment button. Select Delete Comment.
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File Edit |Insert Format Tools View Share Subscription Help

o5 p

Favorites

By xD@a-[&d - ® . A . =
e v nage )| Special Characters.. v |=] Comment
P y = )
E] v (_') : o ? v @ 6 Delete Comment
File Edit Review
Delete All Comments

Presentation view allows you to use the full screen to view your document. To switch to this
mode, in the Command menu, click View > Presentation View

To navigate through the pages of a document, use the following keyboard keys:

«Right Arrow or Space to go to the next page user
Left Arrow to go to the previous page Today, 22:59

There is another method
To exit the presentation view, press Esc

Figure 307. Delete a comment

— In the top right corner, click & Delete.

Save

To delete a comment, you can also switch to the editing mode as described in Section 4.12.2.6,

delete the text of the comment entirely, and then click Save or click anywhere in the document.

Key advantages of our products:

. MyQffice solutions comprise all the tools necessary for efficient teamwork. You can
discuss and edit documents with your colleagues from anywhere. Thanks to the track Ivan
changes and version tracking functions, all changes will be saved. Today, 20:40

. Documents created in MyQffice apps have the same appearance no matter what device
is used to display them.

Figure 308. Delete a comment

To delete all comments in a document, do the following:

1.

2.

Save

On the Toolbar, select the Review section and click thearrow next to

the E Delete Comment button.

In the drop-down list, select Delete All Comments.
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To delete a reply, do the following:
1. Hover your mouse over an answer or select an answer thread using one of the following
methods:
— Click with the mouse anywhere in the thread.
— Navigate to thethread using the (3) Next Change or Comment and
() Previous Change or Comment buttons on the Toolbar in the Review section

(see Figure 306).

v A& Ov @~ B
& Y vl© Of -

Review

Figure 309. Buttons to move between comments

— With the cursor positioned in the Review pane, navigate to the thread using
the keyboard keys | and 1.
2. In the top right corner of the desired reply, click ® Delete (see Figure 310).

Ivan N |
o MyQffice works with all the popular QSs and platforms, including Russian Linux-based Today, 20:40
operating systems and Aurora OS for mobile. MyQffice also runs on hardware from Please follow the guideline
MSECI. Elbrus and Baikal Electronics JSG.
Elena s i
Today, 20:40 3

Please inform the management

Figure 310. Delete a reply

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 320



MyOffice

4.12.3 Audio comments

In the current version, listening to audio comments added using the MyOffice Documents
mobile application is available.

To play an audio comment, click Audio comment in the Review pane
(see Figure 311).

Ivan 4
. MyQffice solutions comprise all the tools necessary for efficient teamwork. You can Today, 20:40

discuss and edit documents with your colleagues from anywhere. Thanks to the track

; Audi mmen
changes and version tracking functions, all changes will be saved. Ml comment

Figure 311. Audio comment

The button is converted to the player and the recording starts playing back (see Figure 312).
When editing a document, the playback of the audio comment is not interrupted. If you want

to stop the playback, click I Pause in the Review pane or on the Status bar.

--------------------------- iPhone Yaroslava, Nov 20, 2019 Q

nd contacts on n = 00:15
pnnection.

might start

u wantWork in

ly-featuredl)se

editing and

Top-notch

ion.Support for

| into product v
[n]Piaying.. | - ° + 0 100% v

Figure 312. Listen to an audio comment

To resume playback, click » Play.

To forward or backward the recording, click the desired mark on the playback scale in
the Review pane.

Audio comments can be cut, copied, pasted and deleted similarly to text comments

(see Section 4.12.2.7 and 4.12.2.8).
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4.12.4 Compare documents

MyOffice Text allows you to compare different versions of the same text file.
The Compare with (beta) feature is supported for the following file formats: .docx, .odt, .xodt.

The following changes made to a document are available for comparison:

— Added and deleted text fragments.

— Added, deleted, and edited tables.

The following items are not available for comparison:

— Table of contents

— Header and footer content

— Images

— Footnotes

— Text and audio comments

— Page breaks and section breaks

— Text and paragraph formatting

These elements and properties are transferred from the compared copy of the document to

the comparison file without changes.

To compare documents, follow the steps below:
1. Open the document you want to compare with the original one.
2. Specify the original document. In the Command menu, click Tools and select

Compare with (beta) (see Figure 313). In the window that opens, select the desired file.

Tools View Share Subscription Helf

Display Changes and Comments  *
Spelling and Grammar »

Custom Dictionary
Change Language...

Macro Editor
Compare with... (beta)

Figure 313. Compare with command menu option
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A document with comparison results will be formed in the new application window

(see Figure 314). It contains:

— Added and deleted text fragments displaying in the tracking changes mode

(see Section 4.12.1).

— Each table whose content or structure is changed displaying as two tables: one deleted

(highlighted in red) and another one added (highlighted in green).

— Added tables highlighted in green.

— Deleted tables highlighted in red.

dwarf planet in 2006.

Chapter 1. The Solar system in which we live is home to eight planets including
Earth. The number was reduced

when Pluto was reclassified as a

Planet

Dristance, mln miles

Mercury

40

Venus

67

Earth

92

Mars

129

 Manet

Lhistance, mln miles

Mercury

&7

Venus

23

Earth

3

Mars

34

Deleted ° from rare”

Added " Far mane infiermatsan, tee Takde 1,7

Figure 314. Text comparison result

Working with a document that contains comparison results is similar to a regular document.
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4.13 Automation tools

4.13.1 Macros

A macro is a set of actions that automate repeated or time-consuming tasks in a text document.
MyOffice Text macros are written in Lua programming language.

Macros are most used for the following purposes:

— Input data

— Find and replace items throughout the text

— Delete text

Saving macros is only available:

— In .xodt and .odt files. Saving documents in .docx format, will automatically delete

the macros.

— Within the current document. To use a macro in other documents, create them directly in

these documents.
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4.13.1.1 Create a macro

To create a macro, follow these steps:

1. Inthe Tools Command menu, click Macro Editor (see Figure 315).

Tools View Share Subscription Hel

Display Changes and Comments
Spelling and Grammar »

Custom Dictionary
Change Language...

Macro Editor
Compare with... (beta)

Figure 315. Macro Editor command menu option

2. Inthe Macro Editor window that appears, click + (see Figure 316).

5 Macro Editor

+ —_
' Bun ~' [:’E':LIEI D

Output:

Figure 316. Adding a macro
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3. Enter the new macro name or keep the default name (see Figure 317). To keep the default

name, click Enter. Or click anywhere in the Macro Editor window using the mouse.

o4 Macro Editor >

Mew Su:riptI

+ —
Prin » Debug B

Output:

Figure 317. Entering the macro name
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4. In the script editing pane, enter the macro script (see Figure 318).

4 Macro Editor >

range = document:getRange () :
MNew Script atartPoz = range:getBegin():
textProp = range:getTextProperties|():

textProp.italic = true;
textProp.allCapitals = true;

range:setTextProperties (textProp);
starcPos:insertText ("HMyOffice!");

+ _ 10
.‘ Fun ? Debug C]

Output:

Figure 318. Entering the script

New macros are saved automatically.
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When you add a macro command to a document, the ® Macros button appears on
the Sidebar (see Figure 319). Clicking this button opens the macro commands pane where you can
perform the following actions:

— Find a macro (see Section 4.13.1.2).

— Run a macro (see Section 4.13.1.3).

— Open the Macro Editor window (see Section 4.13.1.4).

AaBbCcl AaBbCcD .. l__]v @ v El

Heading 1 Heading 2 L1

Insert b

Search

@

Macro 1

Macro 2

Macro 3

Figure 319. Macro pane

To close the macro commands pane, click the-* button above the search bar, or
click ® Macros on the Sidebar again.

The ® Macros button is displayed in the Sidebar if the document contains at least one macro

command.
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4.13.1.2 Find a macro

If the document contains many macro commands, perform the following steps to quickly find

the desired macro command:

1. On the Sidebar, click @ Macros (see Figure 320).

2. In the Macro pane, specify a part of the name or the whole name of the required macro
command in the search line.

The list of macro commands will display macro commands whose names satisfy the specified

search results.

I v
AaBbCcl AaBbCeD .. [H. [] (0] [Z]

Heading 1 Heading 2 1]

Insert

5 Q

‘2| x.‘

Macro 2

Figure 320. Search a macro
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4.13.1.3 Run a macro

You can run a macro command using the Macro Editor window or the macro commands

operation pane.
To run a macro command using the Macro Editor, follow these steps:

1. In the Tools menu, select Macro Editor (see Figure 321).

Tools View Share Subscription Hel

Display Changes and Comments  *
Spelling and Grammar »

Custom Dictionary
Change Language...

Macro Editor
Compare with... (beta)

Figure 321. Macro Editor command menu option

2. In the Macro Editor window, select the desired macro from the list (see Figure 322).

3. Click P Run.
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o4 Macro Editer >
range = document:getRange()

Macro 1 startPos = range:getBegin():
textProp = range:getTextProperties():

Macro 2
textProp.italic = true;

Macro 3 textProp.allCapitals = true;
range:setlextProperties (textProp);
startPos:insertText ("MvOEffice! ")

+ —_
'Run l?D{-bug D mp, T4
Output:
Figure 322. Run button
The results will be displayed in the Output pane (see Figure 323).
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=) Macro Editor >
1 range = document:getRange()
Macro 1 2 startPos = range:getBegin():
3 textProp = range:getTextProperties():
Macro 2 4
= textProp.italic = true;

Macro 3 textProp.allCapitals = true;
range:setlextProperties (textProp);
startPos:insertText ("MvOEffice! ")

+ —_

’Run ,?Debug B = n 1=

Output: Macro 2 Clear ©

Macro successfully executed

Figure 323. Macro results
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To run a macro using the macro pane, do the following:

1. On the Sidebar, click @ Macros (see Figure 324).

. 4
AaBbCcD AaBbCcl AaBbCcD ... Dv @ v E]

Meormal Heading 1 Heading 2
Styles Insert -~
T o
> Q

Search

@

Macro 1
Macro 2 > &

Macro 3

Figure 324. Macro pane

2. Run the macro in one of the following ways:
— In the macro pane, hover the mouse cursor over the macro command name and
click [* Run (see Figure 324).

— Select the macro line by double-clicking it.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 333



MyOffice

4.13.1.4 Edit a macro

To edit a macro, do the following:
1. Open the macro editing widow in one of the following ways:

— In the Command menu, select Tools > Macro Editor (see Figure 325).

Tools View Share Subscription Hel

Display Changes and Comments  *
Spelling and Grammar ’

Custom Dictionary
Change Language...

Macro Editor
Compare with... (beta)

Figure 325. Macro Editor command menu option

— On the Sidebar, click (®) Macros (see Figure 326). In the macro pane, place the cursor
over the title of the macro that you want to edit and click £ Edit.

IS W
AaBbCcI AaBbCcD .. @v @ v E

Heading 1 Heading 2

Insert .

Search

®

Macro 1
Macro 2 > &

Macro 3

Figure 326. Macro pane
2. In the Macro Editor window, select the desired macros from the list (see Figure 326).

3. Edit the script as needed.

All changes in the macro script are saved automatically.
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4.13.1.5 Debug a macro

Before you start the macro debugger, set the debugger breakpoints in the macro text.
To do this:

1. Open the macro editing window in one of the following ways:
— In the Command menu, select Tools > Macro Editor (see Figure 325).
— On the Sidebar, click ® Macros (see Figure 326). In the macro pane, place the cursor

over the title of the macro that you want to edit and click ¢’ Edit.

2. In the Edit Macros window, select the desired macro from the list (see Figure 322).

3. Set the first debugger breakpoint. To do this, click to the right of the line number where
you want to create a breakpoint. The breakpoint will be marked with the @ icon.

4. Set other breakpoints by repeating these actions.

To delete a breakpoint, click it with the mouse.

-4 Edit Macros

Mew Script

textProp = range:getTextFProperties():
textProp.italic = true;
textProp.allCapitals = true;

range  =etTextProperties({textProp) ;
startPos insertText{ "My Office!l");

Figure 327. Breakpoint

To debug a macro:
1. Click £* Debug (see Figure 328). The macro debugging process will begin. If the text of a
macro contains breakpoints, the debugging process will stop on the line that contains the first
breakpoint. If there are no breakpoints, the debugging process will stop at the first line of

the macro.
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=4 Edit Macros x>

1 range = document : getRange):
Mew Script sztartPos = range getBegini):

textProp = range . getTextProperties();
textProp.italic = trues;
textProp.allCapitals = true;

range s=etTextProperties{textFProp) ;
ztartPos: insertText ( "Mylffice! ") ;

P Run ﬂ“ Debug

Output:

Figure 328. Debug button

2. To manage the debugging steps, use the following buttons (see Figure 329):
=; : Perform one debugging step or step into the body of the function if there is one in
the current debugging position.
73 : Perform one debugging step without stepping into the body of the function.
/% : Continue executing the macro until leaving the function where the debugger is at

the current position.

While debugging, the Edit Macros window displays the following areas:

— In progress: This window will display messages while debugging.

— Calls Stack: The calls stack window.

— Variables: This window displays the values of local and global variables available at
the current macro step. If the displayed variable is a table or an array, you can view its

detailed contents by clicking the button to the left of the variable name.
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4 Edit Macros *
range = document:getRange():
Mew Script startPos = range:getBegin():
textProp = range: getTextPropertie=();
@ textProp.italic = trus;

textProp.allCapitals = trus;

range =etTextProperties{ textProp) ;

startPoz: insertText ("MyDffice! ") ;

+ f—
' Run 1? Debug . -PE Q 3*
In progress... Call Stack Variables
rnain{}#Fup:1 ocal:
Global:
textProp = (DocumentAPl TextPra
startPos = (DocurmentAPLPositior
range = (DocumentAPl.Range)
£ >
Figure 329. Debug a macro
The debugging process ends once the end of the macro has been reached.
To interrupt the debugging process, click B Break script.
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4.13.1.6 Delete a macro

To delete a macro:

1. Open the macro editing window in one of the following ways:

— In the Command menu, select Tools > Edit Macros (see Figure 330).

Tools View Share Subscription

Display Changes and Comments
Spelling and Grammar

Custom Dictionary
Change Language...

Macro Editor
Compare with... (beta)

Hel
3
3

Figure 330. Macro Editor command menu option

— On the Sidebar, click ® Macros (see Figure 331). In the macros pane, hover

the cursor over the title of the macro that you want to edit and click ° Edit.

Insert

—

ﬁ?%bf_:c]: [_}, @ v E

‘ f_'-een ch

Mew Script
Mew Script 1

Mew Script 2

b2
N

>

Q
®

Figure 331. Macro pane
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2. In the Macros Editor window, select the desired macro from the list (see Figure 322).

3. Click the — button.

a4 Edit Macros

Mew Script

-

P Rrun ,? Debug [ |

Output

kange = document  getRange();
startPos = range:.getBegin():

textProp = range . getTextProperties();

textProp.i1talic = true;
textProp.allCapitals = true:;

range:=etTextProperties{textProp) ;
ztartPoz insertText{ "HyOffice! ") ;

Figure 332. Delete a macro

4. In the opened window, confirm that you want to delete the macro.
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4.13.1.7 View VBA macro code

In MyOffice Text, it is not possible to run VBA macros created in Microsoft Word. However,

you can view the code of the VBA macros contained in the document and rewrite them in Lua.

VBA macros saved in the current Microsoft Word document are available for viewing.

To view and rewrite the VBA macro code, follow these steps:

1. Open the .docm document.

2. Select the Lua macro with the name of the VBA module that contains the desired VBA
macro. For example, if VBA macro Macrol is contained in VBA module Modulel, select
Lua macro Modulel. Do one of the following to select the Lua macro:

— In the Command menu, select Tools > Macro Editor (see Figure 330).

In the Macro Editor window (see Figure 333), select the desired Lua macro.

"4 Macro Editor X

1 |- BeeguTe Baw kog Lua 30eck
Maodulel

Module2
-- 3aMyck MakpokoMaH VBA He NoAfepkUBaSTCA

~[===[
Option Explicit

Sub RemoveExcessiveEnters()
Dim lineBreakSearchRegExp As String
lineBreakSearchRegExp = GetlLineBreakSearchRegbxp()

Selection.HomeKey Unit: =wdStory
+ - While FindNextText(lineBreakSearchRegExp, True) = True v

P Run ‘.35 Debug

DOutput:

Figure 333. Macro Editor window

— On the Sidebar, click ® Macros (see Figure 334). In the macro pane, hover your

mouse over the name of the desired Lua macro and click ¢ Edit.
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— — - T
= v = w l W [ B -
o HH [Q)v [=
llE w = 4= H w ClT L —
Insert o~

Paragraph Styles

Modulel b2

Module2

Figure 334. Macro pane

The Macro Editor window will display the code of VBA macros that are contained in
the corresponding VBA module (see Figure 333).
Rewrite the code of the required VBA macro in Lua.

4. Close the Macro Editor window.

5. Save the document in .docx format using the Save As command (see Section 4.1.9.1).

The changes made are not saved in the original .docm document.
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APPENDIX 1. KEYBOARD SHORTCUTS

This Appendix contains the keyboard shortcuts used in Windows OS (see Table 13) and macOS

(see Table 14).

On laptops, some keys are multifunctional. For example: F1-F12, Home, End, PgUp,

PgDn. When pressing these keys in MyOffice Text, you need to hold down the Fn key at

the same time.

Table 13. OS Windows shortcuts

Keyboard shortcuts Command or action
Edit the content

Ctrl+X

Shift+Delete Cut

Ctr1+C Copy

Ctrl+Insert

Ctrl+V

Shift+Insert Insert

Ctrl+S Save

F12 Save as

Ctrl+Z

Alt+Backspace Cancel the last action

Ctrl+Y

Ctrl+Shift+Z Repeat the result of the canceled action
Shift+Alt+Backspace

Ctrl+Alt+Shift+V Open the clipboard history

Backspace Delete one character to the left of the cursor
Delete Delete one character to the right of the cursor
Ctrl+Backspace Delete part of a word, word or object to the left of the cursor
Ctrl+Delete Delete part of a word, word or object to the right of the cursor
Enter Begin a new paragraph

Ctrl+Shift+Space Insert a non-breaking space

Ctrl+Shift+ - Insert a non-breaking hyphen

Ctrl+Num - Insert an en dash

Ctrl+Alt+Num - Insert an em dash

Shift+Enter Insert a line break
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Keyboard shortcuts Command or action
Insert page break (if the cursor is located in the text of

Ctel+Enter the document). | N
Save comment or reply to comment (if the cursor is in
the Review pane)

Content formatting

Ctrl+B Bold

Ctrl+I Italic

Ctrl+U Underline

Ctrl+Shift+= Superscript

Ctrl+= Subscript

Ctrl+Shift+A All caps

Ctrl+Shift+C Copy formatting

Ctrl+Shift+V Apply formatting

Ctrl+Space Clear formatting

Ctrl+L Align text to the left

Ctrl+E Center the text

Ctrl+R Align text to the right

Ctrl+J Justify the text

Select the content

Ctrl+A Select all the content of the document

Shift+Left Arrow Select one character to the left of the cursor

Shift+Right Arrow Select one character to the right of the cursor

Ctrl+Shift+Left Arrow Select one word to the left of the cursor

Ctrl+Shift+Right Arrow Select one word to the right of the cursor

Shift+Home Select the content from the cursor to the beginning of the line

Shift+End Select the content from the cursor to the end of the line

Ctrl+Shift+Arrow Up Extend the selection to the beginning of the paragraph

Ctrl+Shift+Arrow Down Extend the selection to the end of the paragraph

Shift+Arrow Up Expand selection by one row/cell upwards

Shift+Arrow Down Expand selection by one row/cell downwards

Double-click the left mouse button Select a word

Triple-click the left mouse button Select a paragraph

;léciizsrliﬁvﬂigze button and move Select the text upwards

g}é%ﬁéﬁ:gﬁﬁgﬁf dl;utton and move Select the text downwards
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Keyboard shortcuts Command or action
Move within the document

Left Arrow Move one character to the left

Right Arrow Move one character to the right
Ctrl+Left Arrow Move one word to the left

Ctrl+Right Arrow Move one word to the right

Arrow Up Move one line up

Arrow Down Move one line down

Ctrl+Arrow Up Go to the beginning of the previous paragraph
Ctrl+Arrow Down Go to the beginning of the next paragraph
Page Up One screen up

Page Down One screen down

Ctrl+End Go to the end of the document
Ctrl+Home Go to the beginning of the document
Work with tables

F2 Switch to cell editing mode

Tab or Right Arrow Select the next cell in the table

Left Arrow Select the previous cell in the table
Home Select the cell at the beginning of the row
End Select the cell at the end of the row
Arrow Up Select the cell upwards

Arrow Down Select the cell downwards

Alt+A Select a row upwards

Alt+B Select a row downwards

Alt+L Insert a column to the left

Alt+R Insert a column to the right

Ctrl+Alt+M Merge cells

Alt+Shift+M Split cell

Ctrl+Alt+R

Ctele Delete a row

Ctrl+Alt+U

Ctele Delete a column

Alt+Shift+M

Ctrle Delete a table
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Other keyboard shortcuts

Ctrl+N Create a file

Ctrl+O Open a file

Ctrl+Shift+P Open the page parameters setup page

Alt+P Open the header/footer settings pane on the Page Numbers tab
Ctrl+P Open the print preview and printing page

Ctrl+0 (zero) Set the actual page scale (100%)

Ctrl+Shift+R Hide or display rulers

Ctrl+Alt+F Insert a regular footnote

Ctrl+Alt+E Insert an endnote

Ctrl+K Insert a link

Ctrl+Shift+V Insert a link from the clipboard

Ctrl+F

Cul+H Open the search pane

Ctrl+/ Open the Quick action box

F1 Open the Help

Alt+Space Open the context menu of the active application window
Alt+F4 Close the active application window

Click the left mouse button Set the cursor in the document

Click the right mouse button Open the context menu of the selected element
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Table 14. Keyboard shortcuts in macOS

Keyboard shortcuts Command or action
Edit the content

% Cmd + X Cut

¥ Cmd + C Copy

2 Cmd +V Insert

2 Cmd + S Save

f Shift + 2Cmd + S Save as

2 Cmd +Z Cancel the last action

2¥Cmd+Y Repeat the result of the canceled action

~= Option + f Shift + 3 Cmd + V

Open the clipboard history

Delete

Delete one character to the left of the cursor

Fn + Delete

Delete one character to the right of the cursor

3 Cmd + Delete
~< Option + Delete

Delete part of a word, word or object to the left of the cursor

32 Cmd + Fn + Delete
~< Option + Fn + Delete

Delete part of a word, word or object to the right of
the cursor

» Enter

Begin a new paragraph

~= Option + {f Shift + Space

Insert a non-breaking space

3 Cmd + { Shift + -

Insert a non-breaking hyphen

~ Option + -

Insert an en dash

~= Option + { Shift + -

Insert an em dash

{} Shift + ~ Enter

Insert a line break

% Cmd + = Enter

Insert page break (If the cursor is located in the document
text)

Save comment or reply to comment (if the cursor is located
in the Review pane)

Format the content

% Cmd + B Bold

%2 Cmd + 1 Italic

®Cmd+U Underline

{ Shift + ¢ Cmd + = Superscript

% Cmd + = Subscript

{ Shift + s Cmd + A All caps

{ Shift + 3¢ Cmd + C Copy formatting

{ Shift + ¢ Cmd + V Apply formatting

A Ctrl +\ Clear formatting

% Cmd + L Align text to the left
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Keyboard shortcuts Command or action
2 Cmd + E Center the text

£ Cmd +R Align text to the right

%€ Cmd+J Justify the text

Select the content

2 Cmd + A Select all the content of the document

{t Shift + Left Arrow

Select one character to the left of the cursor

{ Shift + Right Arrow

Select one character to the right of the cursor

{t Shift + 32 Cmd + Left Arrow

Select one word to the left of the cursor

{ Shift + 3¢ Cmd + Right Arrow

Select one word to the right of the cursor

Fn +{ Shift + Left Arrow

Select the content from the cursor to the beginning of the line

Fn +1{ Shift + Right Arrow

Select the content from the cursor to the end of the line

t Shift + * Ctrl + 3¢ Cmd + Arrow Up

Extend the selection to the beginning of the paragraph

& Shift + * Ctrl + 32 Cmd + Arrow
Down

Extend the selection to the end of the paragraph

{ Shift + Arrow Up

Expand selection by one row/cell upwards

{t Shift + Arrow Down

Expand selection by one row/cell downwards

Double-click the left mouse button

Select a word

Triple-click the left mouse button

Select a paragraph

Click the left mouse button and move
the cursor upwards

Select the text upwards

Click the left mouse button and move
the cursor downwards

Select the text downwards

Move within the document

Left Arrow Move one character to the left
Right Arrow Move one character to the right
3% Cmd + Left Arrow Move one word to the left

3 Cmd + Right Arrow Move one word to the right
Arrow Up Move one line up

Arrow Down

Move one line down

3% Cmd + Up Arrow Go to the beginning of the previous paragraph
3% Cmd +Down Arrow Go to the beginning of the next paragraph
Fn + Up Arrow One screen up

Fn + Down Arrow

One screen down

Work with tables
Fn + F2 Switch to cell editing mode
Tab or Right Arrow Select the next cell in the table
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Keyboard shortcuts Command or action
Left Arrow Select the previous cell in the table

Fn + Left Arrow Select the cell at the beginning of the row
Fn + Right Arrow Select the cell at the end of the row
Arrow Up Select the cell upwards

Arrow Down

Select the cell downwards

~= Option + A Select a row upwards

~< Option + B Select a row downwards
~< Option + L Insert a column to the left
~c Option + R Insert a column to the right
~ Option + ¢ Cmd + M Merge cells

~= Option + { Shift + M Split cell

~ Option + ¥ Cmd + R
%2 Cmd + -

Delete a row

~ Option + $Cmd + U
%2 Cmd + -

Delete a column

-~ Option + { Shift + T
% Cmd + -

Delete a table

Other keyboard shortcuts
% Cmd + N Create a file
®£Cmd+ O Open a file

{ Shift + ¢ Cmd + P

Open the page parameters setup page

~ Option + P

Open the header/footer settings pane on the Page Numbers

tab

% Cmd +P

Open the print preview and printing page

38 Cmd + 0 (zero)

Set the actual page scale (100%)

{ Shift + ¢ Cmd + R

Hide or display rulers

~ Option + $Cmd + F

Insert a regular footnote

~< Option + 3 Cmd + E

Insert an endnote

% Cmd + K

Insert a link

{ Shift + ¢ Cmd + V

Insert a link from the clipboard

% Cmd + F Open the search pane

% Cmd +/ Open the Quick action box

Fn +F1 Open the Help

2 Cmd + Q Close the active application window

Click the left mouse button

Set the cursor in the document

Click the right mouse button

Open the context menu of the selected element
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