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4.10.4.1.3 Copy the color with an eyedropper.........ccccvuiveiiriiieerie e 325
4.10.4.2 Filling a shape with iMage ...........ccooveiiiiiiii e 326
4.10.4.3 Remove the fill COLOT ......oiiiiiiiiiii e 327

O LRI (P o< 1011 134T OSSR 328
4.10.5.1 Set Shape OULINE ......ccoeiiiiiiiiee e 328
4.10.5.1.1 Choose a color from the color sets provided ..........ccccocvveiiieiiiieniiieniiee e 329
4.10.5.1.2 Specify the color code manually ...........ccocoeiiiiiiiiiien e 329
4.10.5.1.3 Copy the color with an eyedropper...........ccccvveiirienieieeseee e 330
4.10.5.2 Select the thickness and line type of the shape outline............cccccoooiiiiiiiiennne 330
4.10.5.3 Apply outline settings of the previous shape...........c.cccocoeiiniiiiiiien e 331
4.10.5.4 Delete sShape OULIINE...........ccciiiiiiiiiiicce e 331
4.10.6 LNE SEYIE ..ttt r e neennnas 332
4.10.6.1 Select @ liNe COLOT.......ccuiiiieeeeee e 332
4.10.6.1.1 Choose a color from the color sets provided ...........ccccoovvriiiiiiiiiciicnee 333
4.10.6.1.2 Specify the color code manually ...........ccccceviiiiiiiiien e 333
4.10.6.1.3 Copy the color with an eyedropper.........c.covieeieiiiiesie e 334
4.10.6.2 Select the thickness and 1ine tyPe ...........ccoveiiiiniiiiicscee e 334
4.10.6.3 Apply the style of the previous line ..........ccceviiiiiiiiiiic e 335
4.10.6.4 Delete the line Style........ooieiiiiieieee e 335
4.10.7 RESIZE @ SNAPE .....viieiiecie e 336
4.10.8 Fit SNAPE SIZ8 10 tEXT ..vviviiiiiiiieitieie ettt nne e 338
4.10.9 Change line length and angle .............coooioiiiiiiii s 339
4.10.10 SelECt AITOW YD ...veveetiiiriitieiteeee sttt ettt r e esn e abe b e e n e e sneene s 339
4.10.11 MOVE @ SRAPE .....ceiiiiiiieiiceeste e 340
4.10.12 Delete @ ShAPe.....cccueiiiieiei e 341
4.11 Format SPreadSheets. ..........oiiiiiiiiiiciisese e 342
O T I ) | TSRS 342
O B B ) (L) /I TP UR PR 344
4.11.3 Text fOTTNAIIIZ ... ceveiieeiieeeseee et n e nneene s 346
O 3 ) 1L ol ] (o) (SO PR R 347
4.11.4.1 Choose a color from the color sets provided ............cccoceeiiiniienieenieseeee e 348
4.11.4.2 Specify the color code manually..........ccoccerieiiriiniiii e 348
4.11.4.3 Copy the color with an eyedropper...........ccccecvrieieeiiieie e 349
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4.11.5 Highlight COLOT ....viiiiiiicic e 350
O O AN T3 0144 1<) LSRR 352
L B Y 0 - (S <) ST PP PP PSP 353
4. 11,8 WTAD TEXE .ttt sttt b e bt b e e bt n s e b e e b e eaneenne s 356
VA B RS I O o1 Lot =) A o= T3 | T USRS 358
4.11.10 Cell fill COLOT ...uviiiiiiciice e 360
4.11.10.1 Add the fill color to table CellS.........ccoiiiiiiiiiic e 360
4.11.10.1.1 Choose a color from the color sets provided ............cccoecvvriiiieenienineinnnn, 361
4.11.10.1.2 Specify the color code manually..........ccccvrviiiiiiriiinniiniiiee e 361
4.11.10.1.3 Copy the color with an eyedropper...........cccueeiiiiinieiiniee e 362
4.11.10.2 Remove the fill COLOT .......ooiiiiiiiie e 362
41111 Cell DOTAETS ...ttt r e s eene e e 363
4.11.11.1 Change border Parameters .............ccecuereerieriereeseene e 363
4.11.11.1.1 Choose a color from the color sets provided ...........cccceviiiiiiiiiiiiieiiiinee 364
4.11.11.1.2 Specify the color code manually..........cccccooiiiiiiiiiiniiiii e 365
4.11.11.1.3 Copy the color with an eyedropper...........cccuoeiirenieiincseese e 365
4.11.11.2 Apply the last selected border Style ..........cccooceriiiiiiiiiiri e 366
4.11.11.3 Delete DOTAETS ......ccueeiieiiiieiie ettt 366
4.11.12 Copy and insert formatting...........c.ceiiriiiienieieeese e 367
4.11.12.1 Formatting DasiCs .......ueiieeiiieiiesie e 368
4.11.12.2 Copy and insert fOrmatting ..........cccocoeereirieeiie e e 370
4.11.12.3 Formatting hiStOTY ......ccviviiieiisicsieeie e 372
4.12 Edit CONEENE ...ttt e e b et e e sbe e san e e be e s neesnneenneennneanneens 373
4.12.1 UNAO QN TEAO ...ttt st ss e ne e e e nnneeneennnas 373
4.12.1.1 Undo the 1ast aCOMN .......eeiueeiiiiiie it 373
4.12.1.2 Redo the result of the undone action............ccoecerieiiiiiiiinieee e 374
4.12.2 CLPDOATA ...ttt n e nnn e ne e 375
4.12.2.1 CUt OF COPY AATA ...c.eveieeiiiiestieie et n e 375
4.12.2.2 Paste the last cut or copied data ..........ccoceerieiiniinie e 377
4.12.2.3 Insert data from the clipboard hiStory ..........cccoceeiiiiiiiiir e 380
4.12.2.3.1 TNSETE AATA...c.veeieiieiieiiiestie ettt s b e sbe e e r e e ente e nne e 380
4.12.2.3.2 Clear clipboard RiStOTY.........ccciiieriiiiiieiisee e 382

4.13 AUTOMALION TOOIS. .. ciiiiiiiiiii ettt et e e e e s be e neeenee 383
O G T 1 =T o TSRS 383
4.13.1.1 Create @ IMACTO .....veeveesieeeteesieeaiteesseeeseesseesssessseeabeesseeasessseeanseesseessseessessnsesssessnne 384
4.13.1.2 FINd @ TNACTO ...eeiieieiie ettt eesn e nn e e nnn e 390
4.13.1.3 RUN @ TNACTO ....teietieiee st iee et sttt siee st sse e et e sbeesnteesseeenbeenbeeenseenneeenes 391

T K T T L 1 4 =T o OSSP PR 395
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4.13.1.5 DEDUG @ TNACTO ...ttt 396
4.13.1.6 DEIEte @ TNACTO ....veveeiieniisiiestiete ettt ettt sbe et b e nee e 401
4.13.1.7 View VBA MACTO COUL .......ccuieiririiiiiieiisie ettt sttt 402

4.14 PrOtECT @ Il et e ne e 405
4.14.1 Protect content from Changes .........ccucviiieiiiiiie i e 405
4.14.1.1 Protect @ ShEET ......ccviiieiiiie e 405
4.14.1.2 Protect the dOCUMENt SITUCTUTE. .......coiviiiiieiie ettt 409

T T IR T U 1) 0) (o] (<o i U] 1 < PSP 412
4.14.1.4 UNprotect file SITUCTUTE .......civiiiieiiieie et 415
Appendix 1. Functions and their deScription ......c.cccusmiesssesmssmssssmssessssmsssmsssssssssesssssssssssssssans 417
SUBTOTAL FUNCHOT ..ttt me e e n e nnn e 424
Appendix 2. List of supported CUITeNCIeS......ccuuurimrmsmmmsamssssssnsssnssssmsssssssnsssnssssmsesnssssnsssnssssasas 426
Appendix 3. Keyboard ShOTtCULS ......ccciceuiemcsmmssammssmssmssssmssassssmsssssssssssssssnsssssssssssssasessssssssennsas 427
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LIST OF ABBREVIATIONS

The abbreviations used herein are specified in Table 1.

Table 1. Abbreviations and definitions

Abbreviation Definition

0S Operating system

MyOffice Text MyOffice Text. Home Edition desktop application

MyOffice Spreadsheet MyOffice Spreadsheet. Home Edition desktop application

MyOffice Presentation MyOffice Presentation. Home Edition desktop application

MyOffice Standard. MyOffice Text, MyOffice Spreadsheet, MyOffice Presentation desktop
Home Edition software applications
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1 ABOUT

1.1 General information

MyOffice Spreadsheet is an editor for creating spreadsheets, running calculations, analyzing
data, forming summary reports, and automating data processing using macro commands on

Windows and macOS operating systems.

For a detailed description of the application features, please refer to MyOffice Standard.

Home Edition. Feature list.
1.2 System requirements

For a list of software and hardware requirements, please refer to MyOffice Standard. Home

Edition. Installation Guide.
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1.3 Limitations

1.3.1 Supported file formats

Table 2 and Table 3 contain a list of formats supported by MyOffice Spreadsheet.

Table 2. Supported file formats in Windows

If you want to... Supported file formats

Open or import files xls, .xIsx, .ods, .xods, .csv, .scsv, .tsv, .tab, .txt, .xIsm, .xIsb, .xots
Save files xlsx, .ods, .xods

Export files .pdf, .pdf/a-1, .csv, .scsv, .tsv, .tab, .txt, .xlsb, .xots

Table 3. Supported file formats in macOS

If you want to... Supported file formats

Open or import files xlsx, .ods, .xods, .csv, .scsv, .tsv, .tab, .txt, .xlsm, .xots
Save files xIsx, .ods, .xods

Export files .pdf, .pdf/a-1, .csv, .scsv, .tsv, .tab, .txt, .xots

1.3.2 Supported interface languages

— English
—  French

— Russian
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2 BEFORE YOU BEGIN
2.1 Installation

For detailed description of installation of MyOffice Standard. Home Edition software, please

refer to MyOffice Standard. Home Edition. Installation Guide.
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2.2 Launch the application

2.2.1 Launch the application in Windows OS

To open MyOffice Text application installed from the Microsoft Store, click its shortcut in
the OS main menu (see Figure 1).

| MyOffice Presentation. Home Edition

a
.i MyOffice Spreadsheet. Home Edition

g MyOffice Text. Home Edition

L Type here to search ﬂ

Figure 1. MyOffice icon in the main menu of Windows OS

To open MyOffice Text application installed from https://myoffice.ru/products/ofis-dlya-

doma/, click its shortcut on the desktop (see Figure 2) or in the OS main menu (see Figure 3).

_h _| . ~—
=

WyOlilles  WyOlilles  WiyOliilies
ms‘m SDeaasne .t‘;lﬁ ‘Tliﬂ'i]i

H L Type here to search

Figure 2. MyOffice icon on Windows OS desktop
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- MyOffice Standard. Home Edition

MyOffice Presentation. Home Edition

S

|
Ii MyOffice Spreadsheet. Home Edition

a MyOffice Text. Home Edition

i"g—lv Uninstall MyOffice Standard. Home...

L Type here to search ﬁ

Figure 3. MyOffice icon in the main menu of Windows OS

2.2.2 Launch the application in macOS

To open MyOffice Text in macOS, click the MyOffice Standard. Home Edition icon in
Launchpad (see Figure 4).

Figure 4. MyOffice Standard. Home Edition icon in Launchpad

The start page will open (see Figure 5) where you can perform the following actions:

— Open MyOffice Text application. Once launched, the application automatically creates
a text file.

— Open MyOffice Spreadsheet application. Once launched, the application automatically
creates a spreadsheet file (see Section 4.1.1).

— Open MyOffice Presentation application. Once launched, the application automatically

creates a presentation file.
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® ® Welcome to MyOffice Standard. Home Edition

[
@+

MyOffice Standard. Home Edition

=  MyOffice Text. Home Edition

MyOffice Spreadsheet. Home Edition

]
! Il MyOffice Presentation. Home Edition

Figure 5. Starting page

The first time you start MyOffice Text, MyOffice Spreadsheet and MyOffice Presentation,

the applications shortcuts are automatically added to the Dock.
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2.3 License agreement

The first time you launch MyOffice Standard. Home Edition, do the following:

1.

Make sure that in the Terms of Use and Privacy Policy window (see Figure 6), in the
Region drop-down list, your region of residence is correctly selected. If necessary, select it
manually from the drop-down list.

Please carefully read the terms and conditions of the License Agreement and Privacy
Policy.

If you agree to the terms and conditions specified, please select the I accept the Terms
of Use and Privacy Policy checkbox.

If you agree with clauses 5-7 of the Privacy Policy, select the Allow to collect
anonymous statistics on app usage to improve product quality checkbox. This
checkbox is not displayed if Other is selected in the Region drop-down list.

Click Get started.

I Terms of Use and Privacy Policy X

F—. o Welcome to MyOffice!

Specify your region of residence so the Terms of Use meet the requirements of your
country.

Region:

B Russia v

MyOffice Standard. Home Edition
End User License Agreement

This license agreement (the "License Agreement") sets forth
the terms and conditions of use of the home edition of
MyOffice Standard computer software (the "Software") and is
concluded between You and New Cloud Technologies Ltd.,
which is the Rightholder of the Software.

Allow to collect anonymous statistics on app usage to improve product quality.

| accept the Terms of Use and Privacy Policy.

Get started Cancel

Figure 6. Terms of Use and Privacy Policy window
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You can disable the collection of anonymous statistics in further work with the application

if necessary. To do this, follow these steps:

1. Inthe Help menu, click About (see Figure 7).

Help F1
Quick Actions Ctrl+/
Check for Updates...
About...

Figure 7. About command menu option

2. In the About window (see Figure 8), clear the Send anonymous statistics on app usage

to improve product quality checkbox.

3. Click Clese.

About

[

MyOffice® Spreadsheet
Build 165 for Windows

MyOffice Standard. Home Edition
Version 3.1H

Terms of Use
Privacy Policy

Legal Notices

Data collection:

Send anonymous statistics on app usage
to improve product quality.

© Mew Cloud Technologies Ltd., 2013-2024

Close

Figure 8. About window
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2.4 Product activation

If you have accepted the License Agreement (see the section above), the product activation
window opens the first time you launch MyOffice Standard. Home Edition software (see Figure 10).
You can use this window to subscribe to use the product and enter the activation code.

Without activation, some functions in applications are not available and are labeled with

markers ® (see Figure 9) or icons EZ.

File Edit Insert Format Table Data Tools View
+ v % Iﬁ h &

Add % w « .‘: .“_)

Favorites File Edit

Figure 9. Function is not available

If you have an activation code, in the product activation window (see Figure 10), click

I Have an Activation Code.

Fa - .
| More features with MyOffice for home X
— ‘ﬁl - - -
| |-k subscription
Unlock all the features of MyOffice apps for working with texts,
spreadsheets, and presentations on your computer and smartphone.
2] Changes and comments [ Enhanced slide show
Markup changes, leave comments, filter your Capture your audience's attention with eye-catching
collaborator's comments pointers and the ability to highlight objects on the
screen
[El Spreadsheet protection 3@4 Formula calculation modes

Protect sheets, and the structure of your Choose between automatic and manual calculation

spreadsheet

[} CSV format support [) Document comparison
Work with spreadsheets in the convenient format Helps quickly identify what has changed in the new
with the option to select delimiters version of the file

Learn more about the subscription
Try for Free

| Have an Activation Code

Figure 10. Product activation window
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If this window has been closed, in the Subscription menu, click Activate Code

(see Figure 11).

Subscription  Help

Try for Free
Activate Code

Figure 11. Subscription menu

In the Code Activation window (see Figure 12), enter the activation code and click Activate.

Code Activation X

Enter activation code

© Activating a new code will cancel any remaining days of your
current subscription or trial period.

L]

Where can | find the code? v

Figure 12. Code Activation window

If you don't have an activation code, you can subscribe with a free 21-day period. To do this,
in the product activation window (see Figure 10), click Try for Free. If this window has been closed,
in the Subscription menu, click Try for Free (see Figure 11).

Please follow the instructions on the website to subscribe. After subscribing, an email with
an activation code will be sent to the email address you specified.

To activate the product, in the Subscription menu, click Activate Code (see Figure 11).

In the Code Activation window (see Figure 12), enter the activation code and click Activate.
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2.5 Application update

To ensure timely update of MyOffice Standard. Home Edition software installed from

https://myoffice.ru/products/ofis-dlya-doma/, it is recommended to enable automatic checking for

new versions.
To automatically check for new versions, do the following:
1. After the first launch of the MyOffice Text, MyOffice Spreadsheet and
MyOffice Presentation applications, close them and reopen either of these applications.

2. Inthe Application Update window (see Figure 13), click Check automatically.

| Check for updates automatically?

[ I
T Should we check for updates automatically? You can always
check for updates manually from the menu.

|Check automaticallyl Don't check

Figure 13. Application Update window

If you want to disable the automatic search for new versions, click the Don't check button.

You can also check for new versions manually. To do this, select Help > Check for Updates

in the Command menu (see Figure 14).

Help F1
Quick Actions Ctrl+/
Check for Updates...
About...

Figure 14. Check for Updates command menu option

The steps to update the application are described in detail in MyOffice Standard.

Home Edition. Installation Guide document.
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3 INTERFACE OVERVIEW

3.1 MyOffice Spreadsheet window

The MyOffice Spreadsheet window consists of the following elements (see Figure 15):
Command menu

Toolbar

Range field

Formula bar

Workspace

Sidebar

Sheet tabs

N e kNN -

Status bar

Command menu Toolbar

1 New Spreadsheet 1 - MyOffice Standard. Home Edition

File Edit Insert Format Table Data Tools View Share Subscription Help

+ By X lomm  elaa G %123 fF
Add [g‘] ~ - B I U AB aue i - & - - .
Favorites File Edit Font Alignment Number F... Cells Data Insert ~
Al v 2 v f Q
A B C D E F G H I ] ~
Range field Formula bar fx
— Sidebar ——@
3 &
4
5 Ex
[
7 Workspace
8
9
10
11
12
13
14
15
16
17 w
< > @)
:
R Automtic SUM 0 AVERAGE O MIN 0$Mu 0 COuNTA 0 [£] - o + 00% v
Sheet tabs Status bar

Figure 15. Main window of MyOffice Spreadsheet
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3.2 Command menu

The Command menu (see Figure 16) contains the main commands for working with

the application.

'I_ MNew Spreadsheet 1 - MyOffice Standard. Home Edition

File Edit Insert Format Table Data Tools View Share Subscription Help
Figure 16. Command menu
To quickly run these commands, you can use:
— Keyboard shortcuts (see Table 26 and Table 27) which are specified next to the

commands in the Command menu.

— Quick Actions box (see Section 3.10).
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3.3 Toolbar

The Toolbar (see Figure 17) contains tools for working with the content of the spreadsheet.

v L - 8.
vy $ % H~EH B @ P o T~

Figure 17. Toolbar

You can change the way the Toolbar is displayed as follows:
— Select the Toolbar display mode or hide the Toolbar.

— Hide or display the Toolbar titles section titles.

— Customize the Favorites section.

— Hide and display the Favorites section.
3.3.1 Change the Toolbar display mode

To change the Toolbar display mode, do the following:

1. Inthe Command menu, select View > Toolbar (see Figure 18).

Wiew Share Subscription Help

Zoom 4 )
A 1:
R1CT
(I A -
Toolbar *» & Regular
rere Compact
Hide Toolbar
D ~  Section Titles
~  Favorites

Figure 18. View command menu

2. In the sub-menu that opens, select the desired display mode:

3

— Regular: Tools are arranged in two lines; the section titles are displayed. If necessary,

the Toolbar section titles can be hidden (see Section 3.3.2).
— Compact: Tools are arranged in one line; section titles are not displayed.

— Hide Toolbar: The Toolbar is not displayed.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.
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To quickly switch between the Regular and the Compact mode, use
the ~ Collapse Toolbar (see Figure 19) / * Expand Toolbar (see Figure 20) buttons located in
the right part of the Toolbar.

TR RUY BB e
2 v 3 Fe

Data Insert

Figure 19. Compact view button

E e

Figure 20. Regular view button
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3.3.2 Hide or display section titles

In MyOffice Spreadsheet, the Toolbar (see Figure 17) has several sections. Each section
(except for the Favorites section) consists of various tools to perform the specific task. For example,
the Number Format section contains tools to edit cell formats.

The title of each section is displayed if the Toolbar display type is Regular
(see Section 3.3.1). Toolbar titles can be hidden to optimize your workspace. To do this, do
the following:

1. In the View menu, select Toolbar (see Figure 18).

2. In the sub-menu that opens, uncheck the Section Titles menu.
To display the section titles, check the menu again.

If the Toolbar is hidden or displayed in the compact form, the Section Titles menu is
disabled.

3.3.3 Hide or display sections content

Toolbar sections can be collapsed automatically (when reducing/increasing the size of

the main application window), or manually.

To collapse a Toolbar section manually, hover the cursor over its right border and click

the * button (see Figure 21).

File Edit Insert Format Table Data Tools View

+ “'" n‘fo ﬁ“" é
Add ngv 7

Favarites File Edit

-

Figure 21. Section collapse button

To display the tools of a hidden section, click it with the mouse (see Figure 22).
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File Edit Insert Format Table Data Tools

Add = v B T

Favorites File Edit I} Font

Wiew

+ |=.ﬂ w ‘x: KO Thames

A15 v x X DO By &

Figure 22. Section tools

To collapse the section, click the * button (see Figure 23).

Edit Insert Format Table Data

F-'I W ;)Q KO Thames

= w NB I U
File Edit

Figure 23. Button to display section tools
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3.3.4 Customize the Favorites

As a rule, when working with an application, certain Command menu items and Toolbar
buttons are used more often than others. These items can be added to the Favorites section of

the Toolbar so that they are always at hand.

3.3.4.1 Add an item

You can add from 1 to 14 items to Favorites.
To add a Command menu item to Favorites, follow these steps:
1. Run the add command in one of the following ways:

— If the Favorites section is empty, click the -+ Add button in it (see Figure 24).

File Edit Insert Format Table Data Tools View

+>< & v % OB~ &
Add = v S

Favorites File Edit

Figure 24. Add button

— If the Favorites section contains the added items, right-click anywhere in the section

and run the Add Action context menu command (see Figure 25).

File Edit Insert Format Table Data

+ i J‘é ﬁ
Add S 9 C
Favorites dit

Fawarits

£19 Add Action %

A B L

F |

Figure 25. Add Action command

2. Inthe window that opens (see Figure 26), select the Command menu item that you want

to add to Favorites.
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+ v ;&({D ﬁ w é KO Thames
Add = S B I U Af
Favaorites File Edit Font
C19 v | F
A |3||'u.'l action... .
4 A
1 Mew
2
3 @ Mew from Template...
4
5 = Open...
& =
- H Save
- D—; Export To..
9
10 =) Quick Print
11
12 Eé‘ Page Setup and Print
13
14
13
16 (__) Undo
7 (? Redo
18
19
o ‘;l:; Cut v
21

Figure 26. Window for adding Command menu items

To add a button from the Toolbar to Favorites, right-click on it and run the Add to Favorites

command (see Figure 27).

=
>
]
11
il
]|
-
|«
|«

Add to Favorites |

Figure 27. Add to Favorites command
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Currently, it is not possible to add Toolbar buttons that are displayed after clicking
the === button.

When added to Favorites, the button is not removed from the Toolbar section in which it

is located.

3.3.4.2 Move an item

To change the position of an item in the Favorites section, follow these steps:
1. Right-click the item to open the context menu (see Figure 28).
2. In the context menu, select the desired command:

— Move to Beginning: Make the selected item the first in the section.

— Move Left: Swap the selected and previous element.

— Move Right: Swap the selected and subsequent element.

— Move to End: Make the selected itemn the last in the section.

= vk @ v
[ IO .. =

Fa Action

¢ Move to Beginning
Move Left r

MMowve Right

Remove from Favorites

Favaorites
Add Action

Clear

L= R = T I o R, R O TS R L8 B

Figure 28. Commands to move an item
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3.3.4.3 Delete an item

To delete a Command menu item from the Favorites section, right-click it and run

the Remove from Favorites command (see Figure 28).

To remove a Toolbar button from the Favorites section, follow these steps:

1. Right-click it in the Favorites section or in the section from which it was added

(see Figure 29).

2. Run the Remove from Favorites context menu command.

AT AT
W Iﬂ} W !

BN = = = General v
_ 4 — —
Jooow %% — - — o oo oo
Remowve from Favorites |
Alignment P

Figure 29. Remove from Favorites command

3.3.4.4 Clear the section

To remove all items from the Favorites section, right-click anywhere in the section and run

the Clear context menu command (see Figure 28).
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3.3.5 Hide or display the Favorites section

By default, the Toolbar displays the Faveorites section.
To hide the section, do one of the following:
— In the Command menu, select View > Toolbar and in the sub-menu that opens uncheck

the Favorites check box (see Figure 30).

View Share Subscription Help

Zoom »
R1C1

~ 1

(.} A =T

Toolbar » e Regular

o Compact
Hide Toolbar
D ~  Section Titles

+  Favorites

Figure 30. View menu

—  If the Favorites section is empty, hover your mouse over the <+ Add button and click

in its upper-right corner (see Figure 31).

File Edit Insert Format Table Data Tools View

+>< "" ;‘Lﬁ" é
Add% = S ¢

Fawaorites File Edit

Figure 31. Favorites section

To display the section, re-select the Favorites check box in the Command menu.

The Favorites check box is locked if the Toolbar is hidden.
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3.4 Range field

The range field allows to do the following:
— Display theaddress (see Figure 32 and Section4.5.3) or name
(see Figure 33 and Section 4.5.9) of the selected cell or cell range.

— Create new names of cells/cell ranges (see Section 4.5.9.1.1).

D2D5 v | fx =B2*

A B L D E F
1 Name Per unit price Oty Price Discount  Discount price
2 ItemA 20 o 100 0,1 90
3 ItemB 36 25 900 0,2 720
4 IJtemC 48 20 960 0,1 864
5 ItemD 50 18 900.0.1 810

Figure 32. Cell range address

Price v | fx =B2%

A ] C D E F
1 Name Per unit price Oty Price Discount  Discount price
2 Item A 20 5 100 0,1 90
3 ItemB 36 25 500 0,2 720
4 ItemC 48 20 960 0,1 864
5 ItemD 50 18 500 0,1 810

Figure 33. Cell range name
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3.5 Formula bar

The  Formula  bar  displays thereal contents of  theselected  cell.

For example, A1 cell (see Figure 34) displays and contains number 1. A2 cell displays and contains

the number 2. A3 cell displays the number 3 but contains a formula whose result is 3.

A1 v | fx 1
A B C ) E
1 1|
2 2
3 3
4

Figure 34. A1 cell content on the Formula bar

A2 v | fx 2
A B C D E
1 1
2 2|
3 3
4

Figure 35. A2 cell content on the Formula bar

A3 v | fx =SUM(A1+A2)

A B C D E

Figure 36. A3 cell content on the Formula bar
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3.6 Workspace

The workspace (see Figure 37) is the active area of the sheet, within which user actions are

performed. If necessary, the boundaries of the workspace can be expanded (see Section 4.3.1).

@ |~ @ |wn e w e =

e | | [t | ot | [ [
B Exda o r@ R = 8e

[
e

Figure 37. Sidebar
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3.7 Sidebar

The Sidebar displays the following buttons (see Figure 38):

Cv
Cx

()

® + 100% v

Figure 38. Sidebar

) Find and Replace: Open the Find and Replace pane (see Section 4.4.6).

fX Insert Function: Open the Insert function pane (see Section 4.5.3).

Pivot Table: Open the pivot table settings pane (see Section 4.7). The button
is displayed when a pivot table element is selected.

® Macros: Open a pane to work with macros (see Section 4.13.1). This button
is displayed if the file contains at least one macro.

<’ Name Manager: Open the Name Manager (see Section 4.5.9).

Smart Table: Open the smart table customization pane. The button is displayed if a
smart table element or the entire smart table is selected in the document
(see Section 4.5.11.4).

Ex All Validations: Open the pane for working with cells containing data validation

(see Section 4.4.4.1).

L?l Recovered Files: Open the document backups pane (see Section 4.1.12). The button
is displayed if there is at least one unsaved copy.

= Manage Protection: Open the file protection management pane (see Section 4.14.1).
T

) Feedback: Send feedback on the application.
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3.8 Sheet tabs

The Sheet tabs (see Figure 39 and Section 4.2) are provided for navigating through

the spreadsheet sheets.

26
27
28

Sheetl Sheet? +

Figure 39. Sheet tabs
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3.9 Status bar

The Status bar displays the following data and tools:

— Icon of the selected formula recalculation mode (see Figure 40 and Section 4.5.4).
— Automatic calculation values (see Section 4.5.2).

— Tools to zoom in or out the active sheet (see Section 4.2.6).

| @ Automatic SUM 0 AVERAGE 0 MIN 0 MAX 0 COUNTA 0 [F] - o + 0 100%

v

Figure 40. Status bar
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3.10 Quick Actions box

The Quick Actions box (see Figure 42) allows you to quickly run various commands and

perform actions in MyOffice Spreadsheet (see Section 3.2).
To open the Quick Actions box, do one of the following:

— In the Command menu, select Help > Quick Actions (see ).

Help F1
Quick Actions Ctrl+/
Check for Updates...
About...

Figure 41. Quick Actions command menu option

— Press Ctrl+/ on Windows. On macQOS, press ¢ Cmd+/.

‘ f nd action...

New Ctrl+N
New from Template...

Open...

Save

Save As... 12

Autorecovery Settings

Export To...
Quick Print
Page Setup and Print

Close

Figure 42. Quick Actions box
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Use one of the following methods to select the command from the list:

— Scroll the list to the desired command using the mouse scroll wheel or the right vertical
scroll bar. Confirm the command by clicking it or pressing Enter.

— Start typing the command name in the search bar. When the desired command appears
in the search results, select it using the mouse or keyboard keys:
— Click the command line with the left mouse button.

— Select the command line with the | and 1 keyboard keys and press Enter.

Once the selection is made, the action is done, and the box closes automatically. To close

the box without selecting an action, click anywhere outside this window and press Esc.
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3.11 Application language

The default language of the MyOffice Spreadsheet application is determined by the language

of your operating system. You can change it manually if necessary.

When you change the language of MyOffice Spreadsheet, the corresponding language is
automatically selected for MyOffice Text and MyOffice Presentation.

To change the application language, follow these steps:

1. Inthe Command menu, select Tools > Change Language (see Figure 43).

Tools View Share Subscriptio

Spelling and Grammar 4

Custom Dictionary

Change Language...

Macros 4

Figure 43. Tools command menu
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2. In the window shown in Figure 44, select the desired application language from

the drop-down list and click OK.

Language Change *

Choose language:

System Default (English) v

OK Cancel

Figure 44. Language selection window

3. In the dialog box shown in Figure 45 click OK.

Language Change X

o The change will take effect after
restarting the app

Figure 45. Notification to restart the application

4. Restart the application. To do this, close all the documents currently open in

MyOffice Spreadsheet and open them again.
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4 WORK WITH MYOFFICE SPREADSHEET
4.1 Actions with files
4.1.1 New file

4.1.1.1 Create a file using File Explorer

To quickly create a file using Windows File Explorer, do the following:

1. Open the context menu by right-clicking on an empty area and click
New > [} New MyOffice Spreadsheet.

2. Specify a name for the file. By default, the file is named New MyOffice Spreadsheet.

3. To keep the name, click outside the file or press Enter.

4.1.1.2 Create a file when opening the application

A new file is created automatically when you open MyOffice Spreadsheet.

4.1.1.3 Create a file while working in the application

To create a new file while you work in MyOffice Spreadsheet, do one of the following:
— In the Command menu, select File > New (see Figure 46).

—  Press Ctrl+N / Cmd+N.

File Edit Insert Format Table Data
[ Mew Ctrl+M

Mew from Template...

[~ Open.. Ctrl+0

Figure 46. New menu
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4.1.2 Save as template

A template file fully duplicates the original file and is used as a reference for creating other
files. Templates are convenient to use if you need to create several documents which share the same
contents or formatting settings.

To create a template, follow the steps below:

1. Open the file that you want to use as a template (see Section 4.1.4).

2. Select File > Save as Template (see Figure 47).

3. In the file manager window that appears, select the template name and location.

Click Save.

File Edit Insert Format Table Dat

[ New Ctrl+N
New from Template...

[~ Open.. Ctrl+0
Recent Files 4

= Save Ctrl+S
Save As... F12
Autorecovery 4
Export To...
Save as Template...

(= Page Setup and Print Ctrl+P
Close

Figure 47. File menu
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4.1.3 New from template

To create a file from a template, follow the steps below:
1. Double-click the template you want to use in the file manager.
2. Select File > New from Template (see Figure 47). In the file manager, select

the template you want to use for your file and click Open.

This will create a new document ready for editing.
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4.1.4 Open a file

To open a file, do one of the following:
— Double-click the file using the left mouse button.
— Open MyOffice Spreadsheet. Do the following:
1. Select File > Open (see Figure 47). Or press Ctrl+0 / $Cmd+0O.

2. In the file manager, select the file you want to open and click Open.

To open a file, do one of the following:
— Double-click the file using the left mouse button.
—  When working on macOS, open the Home page (see Section 2.2.2) and follow the steps
below:
1. Click Open File.
2. In the File manager window that appears, select the desired file and click Open.
— Open MyOffice Spreadsheet. Proceed as follows:
1. Inthe File menu, click Open (see Figure 47) or press Ctrl+O / sCmd+O.
2. In the file manager, select the file you want to open and click Open.
— Open MyOffice Text and drag the document or its shortcut from the operating system file
manager window to the open application window. You can open up to 32 files at a time

by dragging and dropping them into the application window.

The document opens on the sheet where data was last saved before closing. If this sheet has
been renamed or deleted in another application, the document opens on the first sheet of

the spreadsheet.

4.1.4.1 File in .xls format

Files in .xls format are not supported on macOS.

When you open a file in .xIs format, it is automatically converted to .xlsx format

(see Figure 48).
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I New Spreadsheet 1 [Edited] - MyOffice Standard. Home Edition

O X
File Edit Insert Format Table Data Tools View Share Subscription Help
+ v Q(;. AptosNarr.. ~| 11 '~ A” AT = v 4 v 123 @
Add = B JT U « Av £v &v
Favorites File Edit Font Alignment Number F... | Cells Insert o~
(1) Document was automatically converted to a newer format OK
A1 v 2 v fx
~ Q
A B C D E F G H | J L
A
] fx
2
- &
4
Cv
< cCx
6

Figure 48. Document was converted

To save a file in .xlsx format, follow the steps described in Section 4.1.8.
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4.1.4.2 File in .xIsb format

Files in .xlsb format are not supported on macOS.

When you open a file in .xIsb format, a copy of that file in a different format is opened
(see Figure 49).

I New Spreadsheet - MyOffice Standard. Home Edition

- O X
File Edit Insert Format Table Data Tools View Share Subscription Help
+ v (><: AptosNarr.. ~| [11 |v| A= A* =v | v 123 @ FEH
Add S v B 7T U « Av 2v &v o
Favorites File Edit Font Alignment Number F. Cells Data Insert ~
Copy of the document was opened and converted to a different format. Use the "Export To" command on the File menu to save the workbook in the Close
original XLSB format.
A1 v 2 v fx
A B c D E F G H I ! K L =
F
I i
2
2 <

Figure 49. File copy

To save a copy of the file in .xIsx, .ods, or .xods format, follow the steps in Section 4.1.8.

To save a copy of the file in .xlsb format, follow the steps in Section 4.1.11. When exporting,

you can replace the original .xlIsb file with this copy of the file.
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4.1.4.3 Read-only file

If the Read only property is set for a file by the OS tools, then:

— This file is opened in the View mode.

A notification “You can only view this document” is displayed on the Toolbar
(see Figure 50).

The file is opened in the edit mode if you work with it using the WebDAYV protocol or if
it has the .xIsb extension.

In the View mode, you cannot make changes to the document or change its formatting.

If necessary, you can create a copy of this document that can be edited. To do this, click Edit a Copy
on the Toolbar.

| New Spreadsheet - MyOffice Standard. Home Edition

- O X
File Edit Insert Format Table Data Tools View Share Subscription Help
S You can only view this document Edit a Copy
Al v 2 v fx
A Q
A B C D E F G H 1 J K L
A
1 fx
2
3 <
4

Figure 50. Edit a Copy button

A copy of the document will open in a new application window. To save the file copy, follow
the steps described in Section 4.1.8.

4.1.4.4 File is being used by another application

If a file is opened for editing in another application, then:

— This file is opened in the View mode.

The Toolbar displays a notification that the document is opened in another application
(see Figure 51).
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& New Spreadsheet - MyOffice Standard. Home Edition

- O X
File Edit Insert Format Table Data Tools View Share Subscription Help
&5 v Document is not available for editing because it is in use by another application or user ~ Check Availability Edit a Copy
Al v 2 v fx

~ Q
A B c D E F G H | J K L
A

1 fx
2
: <d
4

Figure 51. Document is in use by another application

The file is opened in the Edit mode if it has an .xIsb extension or is opened in another
application, but that application has not created a lock file. For example, a file

downloaded from the Internet and opened in Microsoft Excel in the Protected View

mode will open in the Edit mode.

In the View mode, you cannot make changes to the document or change its formatting.

To edit a document, do one of the following:

Finish working with the document in another application. Then, in MyOffice
Spreadsheet, click Check Availability on the Toolbar. If working with a document in
another application is not completed, the pop-up message “Document still in use” will

be displayed (see Figure 52). If the work is completed, the document will switch to the
Edit mode.

" New Spreadsheet - MyOffice Standard. Home Edition

- O >
File Edit Insert Format Table Data Tools View Share Subscription Help
& v Document is not available for editing because it is in use by another application or user ~ Check Availability Edit a Copy
A1 v 2 fx

~ Q
A B C D E F G H | J K L
A

1 fx
2 Document is still in use
2 <
4

Figure 52. Tooltip message

Create an editable copy of the document. To do this, in MyOffice Spreadsheet, on the
Toolbar, click Edit a Copy. A copy of the document will open in a new application

window. To save the file copy, follow the steps described in Section 4.1.8.
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4.1.4.5 File is opened by another user

When you try to open a document opened by another user, a dialog box is displayed
(see Figure 53) that contains:

— Information about the user who is currently working with this document.

— Open a Copy button to create an editable copy of the document.

— Close button to finish working with the document.

The file in .xIsb format is opened in Edit mode. In the View mode, only .xlsb files

are opened, the work with which is performed via WebDAYV protocol.

Open File =

o To avoid losing the changes
made by another user, please

consider opening a copy of the
file.

About the user:

Elena Smirnova, working since
DESKTOP-LSMEQKK, 07.06.2024
12:33:01

Open a Copy Close

Figure 53. Dialog box
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4.1.5 Convert a file

MyOffice Spreadsheet allows you to import data from .csv, .scsv, .tsv, .tab, .txt files and
display them in a spreadsheet.

Follow these steps:

1. Open the file you want to import (see Section 4.1.4).

2. Inthe Convert window that appears (see Figure 54), specify the following parameters:

— Character set: A text encoding format.

— Delimiters: Characters separating the values. Each value is then placed in a separate
cell. For example, if you select the semi-colon sign (;), the values like 1;1;1 will be
placed into 3 cells. You can use the preset delimiter type from the list or specify it
manually in the Another field. You can select multiple delimiters to use from the list.

Only one character can be specified in the Another field.

Only one character can be specified in the Another field.

— String qualifier: A character that frames individual values so that they are placed in
separate cells even if they contain a delimiter. For example, if a comma is specified
as a delimiter and double quotes as a string qualifier, the fractional number "3.14"
is placed into a single cell.

— Fit Width to Content: An option to adjust the width of each column to automatically
fit the widest entry in a column. If selected, the width of each column is
automatically selected based on the content of the cell that contains the most data.

3. Click OK.
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Convert - [Import a file.csv] x

Character set:

Detect Automatically v

Delimiters:

Tab

Comma
Semicolon

Space

Vertical bar

Other

String qualifier:

Fit Width to Content

Figure 54. Import settings window

The delimiter-separated data contained in the file will be displayed in a new document in

tabular form.
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If you didn't select the Fit Width to Content option in the Convert window during the file
import (see Figure 54), the "Fit column width to the contents?" pop-up message will appear briefly

on the screen once the new file is opened (see Figure 55).

v AT AT = = = = General v ﬁ
Av v L vV § % © 0 H

Alignment Number Format Cells
H | J K L M N

Fit column width to the contents? Fit Width

Figure 55. Pop-up message

Click Fit Width to fit the width to the content or Cancel to keep the default column width.
You can save theresulting file in .xIsx, .xods, or .ods formats in theusual way

(see Section 4.1.7).
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4.1.6 Recent files

MyOffice Spreadsheet application saves a list of documents which the user has worked with

recently.
To open a file from the list, do the following:

1. Select File > Recent Files (see Figure 79).

File Edit Insert Format Table Data Tools View Share

B New SR O Thames ~ 12 w
Mew from Template...
I U « A
[~ Open.. Ctrl+0 )
Recent Files P 3 New Spreadsheet.xlsx
) Save Ctrl+s =) New Spreadsheet.xIsb
Save As... F12 Clear

Figure 56. File menu

2. In the sub-menu that appears, select the desired file.

If the list of recent files is out of date, delete it. To do this, in the Command menu,

select File > Recent Files > Clear.
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4.1.7 Open with

You can open the files you are working on in another spreadsheet application directly from
MyOffice Spreadsheet. To select the application that you want to use, in the File menu,

select Open With (see Figure 57).

This menu item is not available on macOS.

File Edit Insert Format Table Data Tools View Share

0 New Cri+N OThames « 12 |+
New from Template...
T U . A
S L

[ Open... Ctrl+0 .
Open With... » LibreOffice Calc
Recent Files > Excel

Save Ctrl+S b
Save As... F12

Figure 57. File menu

A list of available applications is created manually using the OpenWithList.ini
configuration file (for more details, see MyOffice Standard. Home Edition. Installation Guide).

The Open With command is not displayed if the configuration file does not contain data or
if the data is incorrect.

Clicking the Open With command in theFile menu will close thefile in
MyOffice Spreadsheet and open it in the application of your choice. If there are any unsaved

changes in the file when you close it, MyOffice Spreadsheet will suggest saving them.
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4.1.8 Send a file

The Send File command is not available on macOS.

In MyOffice Spreadsheet, you can email the file you are working on using the default
desktop email client.

To send a file via email, follow the steps below:

1. Select Share > Send File (see Figure 58).

Share  Subscriptio

Send File... |

Figure 58. Share menu

2. In the new message window that appears, do the following:
— Inthe To field, enter the recipient's email address.
— In the Subject field, edit the subject (if required).

— In the body of the message, type the text.
3. Send the email.
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4.1.9 Print a file

4.1.9.1 Print a file without entering MyOffice Spreadsheet

When working in Windows, you can print a document/group of documents without first
opening it in MyOffice Spreadsheet.

To do this, perform the following steps:

1. Select the desired document/group in Windows Explorer.

2. Open the context menu by right-clicking the mouse and run the Print command.

Printing is performed on the last printer used by MyOffice Spreadsheet and MyOffice Text.
If no printer was previously selected in those applications, the printer used is the one installed by
default in Windows.
During printing the following dialog boxes may be displayed:
— For a large-sized document or group of documents: the print setup window.
— For a document in which the only sheet has been deleted or all sheets have been hidden:
The window with the notification that there is no data to print.

— Notifications of damaged files and files with unsupported formats.
4.1.9.2 Print a document from MyOffice Spreadsheet

4.1.9.2.1 Select the print area

You can print:

— Selection: Specified manually,

— Print area: Specified manually or selected automatically if a print area is specified for
the document in a third-party editor.

— Sheet: Selected automatically if no selection or no printable area is specified in

the document.
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4.1.9.2.1.1 Print a selection

To print a selection, follow these steps:

1. Select the cell, cell range, rows, or columns from which you want to print data.

2. Open the context menu by right-clicking the selected cells or the titles/contents of the selected
rows/columns.

3. In the shortcut menu, select Print Selection.

The Page Setup and Print will open (see Section 4.1.9.2.2).
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4.1.9.2.1.2 Print an area

If a print area is selected on a sheet using MyOffice Spreadsheet or a third-party editor, this
print area will be automatically selected when printing the document.
In Microsoft Excel, a print area is selected using the following commands:

Page Layout > Print Area. In LibreOffice Calc, use Format > Print Ranges.

To specify a print area in the MyOffice Spreadsheet application, follow these steps:
1. Select the area you want to print on the sheet.

2. In the Format menu, select Print area > Define print area (see Figure 59).

The print area is specified separately for each sheet of the document.

Format Table Data Tools View Share Sub

»
Font ames v 12 v A
Alignment ’
Rotate Text » I Q vee i v
Number Format...

Print Area P |+ Print area borders

Save Image... Define print area

Clear print area

Figure 59. Define print area command menu option
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The borders of the selected print area are highlighted in blue (see Figure 60).

A B C D E F

1 Date Y ear Month Year-Month  [tem Sales, USD
2 |01.02.2010 2010 220202 Item 1 422656
3 |01.02.2010 2010 2 2020.2 Item 2 81343
4 |01.02.2010 2010 2 2020.2 Item 3 8853
5 |01.02.2011 2011 2 2020.2 Item 4 868818
6 |01.02.2011 2011 2 ltem b 2712371
7 01.02.2011 2011 2 [tem B

g8 01.02.2012 2012 2 Item ¥

Figure 60. Print area borders

If needed, you can hide this frame by doing the following:
1. Click Format > Print area (see Figure 61).

2. Clear the Print area borders checkbox.

Format Table Data Tools View Share Subs

v |
ji ames v 12 (v | A
Alignment »
Rotate Text » I Q e i v
Mumber Format...

Print Area P + Print area borders

Save Image... Define print area

Clear print area

Figure 61. Print area borders menu

To display the frame, select the menu again.
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To modify the print area (for example, if the selected area is not correct), follow these steps:
1. Inthe Format menu, select Print area and click Clear print area (see Figure 61).

2. Select the area once again as described above.

To print the defined area, open the Page Setup and Print window in one of the following
ways:

— Select File > Page Setup and Print (see Figure 62).

—  Press Ctrl+P / £Cmd+P.

File Edit Insert Format Table Dat

% New Ctrl+N

Mew from Template...

[~ Open.. Ctrl+0
Open With... 4

Recent Files »

&) Save Ctrl+S
Save As... F12

Autorecovery 4

Export To...

Save as Template...

(= Page Setup and Print Ctrl+P

Close

Figure 62. Page Setup and Print command menu option

The Page Setup and Print will open (see Section 4.1.12.2).
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4.1.9.2.1.3 Print the current sheet

To print the current sheet, follow these steps:
1. Make sure that a print area has not been set for this document (see Section 4.1.9.2.1.2).
2. Open the Page Setup and Print window in one of the following ways:
— In the Command menu, select File and then Page Setup and Print
(see Figure 62).
— On the Toolbar, select the File section and click the arrow to theright of
the =) Quick Print button. In the drop-down list, select Page Setup and Print
(see Figure 63).

Insert Format Table Data
v o 0 ~
B ©c

|E;] CQuick Print

& Page Setup and Print

’ N

Export to POF

Figure 63. Page Setup and Print command

—  Press Ctrl+P / Cmd+P.

The Page Setup and Print will open (see Section 4.1.9.2.2).
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4.1.9.2.2 Page Setup and Print window

The opened Page Setup and Print window (see Figure 64) contains:
— Print Setup pane

— Preview pane

If the sheet that you want to print is empty or the data resides in hidden rows or columns,
the Page Setup and Print dialog box will not open. Instead, the following notification
will appear on the screen: "No data to print. Please make sure you have at least one

page with data to print".

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 67



MyOffice

4.1.9.2.2.1 Preview a document

To control the preview, use the following buttons:

- - and : Zoom in or out the preview section.
— Fit: Set the default page zoom (100%).

- and K4 : Move to the next or previous sheet.

@ Zooming does not affect the print area. The tool is intended for a detailed preview of

a document content before printing.

You can resize the Page Setup and Print dialog box by dragging its borders.

Print Settings pane Preview pane

8 Page Setup and Print

Printer e

Samsung ML-2160 Series hd Full name Payment mvethod Status
1 Marie Andersan PayPal Dieliversd
2 Juhn Smith Credit card Dielivered
Printer Properties... 3 Oliver Williams PayFal Delivered
4 Jack Taylar PayPal Delivered
«| Print in Grayscale 5 George Davies Creddin card Delivered
& Ollivia Briwn Crerlit card Dielivered
7 Tsabella Murphy Credlit card Dieliversd
Copies: B Jessica OFCommar PayFal Dielivered
1] Alexander Evans Chasck Delivered
-~ Jamees Rioherts Cheeck Delivered
1 « | Collated 123123123 ~ Emily Wilson Credit card Dieliverad
Sophie Rodrigues Cash Dielivered
] Jenmifer Garcia Cash Deelivered
Print Area: Range: Martin ONeill Credit card Delivered
Kyle Jones PayPal Canceled
. Mason Williams Cash Dueliveered
D Entire Sheet « | All Pages v Emma ORyan FayFal Delivered
Margaret Brown Cash Delivered
Charlie Wiksan Cash Deelivered
eq. 1-3, 37 Michsel Anderson Cash Dieliversd

Do not print blank pages

Duplex Printing:

MNone M

Scale:
Fit to Page Breaks
© Custom Scale 100%

Orientation:

Save Cancel

Figure 64. Page Setup and Print dialog box
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4.1.9.2.2.2 Customize print settings

In the print settings area, you can specify the parameters listed in Table 3.

Table 4. Print settings

Option

Action

Printer

Select a printer to print the document.

Printer Properties

(Windows OS only). Open the printer settings window. The type
and composition of the window parameters depend on the printer
model selected in the field above.

The settings specified in the printer settings window are
automatically transferred to the corresponding fields of
the Page Setup and Print window.

Print in Grayscale

Print the color text and images contained in the document in
grayscale.

Copies

Set the number of copies you want to print.

Collated / Uncollated

Set the order in which pages are grouped during printing. Set
the order in which pages are grouped during printing:

— Collated: Print all pages grouped by copies (1,2,3 1,2,3 1,2,3).

— Uncollated: Print pages grouped by page numbers (1,1,1 2,2,2
3,3,3).

Print Area

Print Area (see Section 4.1.9.2.1):
— Defined Area: Print the defined area.
— Entire Sheet: Print the sheet displayed on the screen.

— Selection: Print the selected area on a sheet.

A field to enter the page
numbers or ranges to be
printed

This field is used if you want to print individual pages or page
ranges of the selected sheet/area/fragment. The pages to print can be
specified as:

— Individual page numbers. For example, 5, 10, 12.

— Page ranges where the range values are denoted using the hyphen.
For example, 1-8, 10-11.

— Pages from the beginning of the sheet/area/fragment to
the specified one are in the -<No.> format. For example, if -3
is entered in the field, then pages 1-3 will be printed.

— Pages from specified to the end of the sheet/area/fragment - in
the <No.>- format. For example, if 3- is entered in the field and
the sheet/area/fragment contains 6 pages, then pages 3-6 will be
printed.
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Option

Action

Range

This field is not available when you want to print a selection
(see Section 4.1.12.1.1). Select one of the following ranges:

— All Pages: Print all the pages of the current sheet.

— Odd Pages Only, Even Pages Only: Print the document on a printer
that doesn't support automatic double-sided printing. You can print
the front sides of all the pages, turn the printed pages over, put them
back into the printer, and print on the back sides.

Don't print blank pages

Blank pages are the pages without data, cells, objects (diagrams, images,
shapes), cells with borders (see Section 4.11.12) or filling
(see Section 4.11.10). This is a default option.

Checking/unchecking Do not print blank pages in the preview area
hides/displays blank pages and the total number of pages is reduced or
increased.

If you want to print individual pages/range of pages of the selected
sheet/area/fragment, make sure that the Do not print blank pages check
box is selected first, and then specify the pages/range of pages to be
printed, referring to the page numbering in the preview area.

Duplex Printing

Print on both sides of the paper:
— None: Print on one side of the page only.

— Long-Edge Binding: Print two sides of the page and flip the paper
along the long edge.

— Short-Edge Binding: Print two sides of the page and flip the paper
along the short edge.

Scale

The settings under the Scale section depend on the option selected in
the Print Area.

Under the Current Sheet, the Scale contains the following settings:

— Fit to Page Breaks: If page breaks are inserted into a sheet using
Microsoft Excel or LibreOffice Calc spreadsheet editor, the sheet is
broken into pages according to these breaks. If the document does not
have page breaks, the spreadsheet will be automatically scaled to fit one
printed page.

If there are no page breaks on the sheet, selecting Fit to Page
Breaks will print the entire contents on one page at a very
small scale

— Custom Scale: Change the sheet scale on the page by adjusting
the percentage value. If there are page breaks on the sheet (see
the description of the setting above) and you select the Custom
Scale, printing will be performed taking these page breaks into
account.

If there are page breaks on the sheet (see the description
of the settings above), then when you select the Custom
Scale, printing will take these page breaks into account.
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Option

Action

In the Print Area, under the Selection, the Scale contains
the following settings:

— Actual Size: Print the spreadsheet as is.

— Fit to Page: Fit the selection to a printed page.

— Fit to Width: Fit all columns of the selection to a printed page.

— Fit to Height: Fit all rows of the selection to a printed page.

Click Print to print the document or Cancel to close the window.
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4.1.9.2.2.3 Page setup

The Page Setup and Print dialog box contains the following page setup options

(see Figure 65):

— Orientation: Select Portrait (vertical) or Landscape (horizontal) page orientation.

— Paper Size: Select paper size for printing.

— Top Margin, Bottom margin, Left Margin, Right Margin: Set the distance between

the page edges and the contents.

You can save the current page setup for further printing. To save the setup and close

the window, click Save. To print the document and save the setup, click Print.

When printing a selection (see Section 4.1.9.2.1.1), the page setup is only applied to

the selection and cannot be saved for further printing sessions.

Ad (B.27511.7 inches)

0.79 inches

0.79 inches

0.79 indhes

0,79 inches
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4.1.9.2.3 Quick print

MyOffice Spreadsheet allows you to quickly print a document without using the Page Setup
and Print dialog box.

The Quick Print feature:

— Creates an instant printout and uses the default printing settings.

— Selects the last printer used. The document will be printed using the printer you last used

(if any) or the default printer.

To print a document using the Quick Print feature, do one of the following:
— On the Toolbar, select the File > = Quick Print (see Figure 66).
— On the Toolbar, select theFile section and click thearrow to theright of

the (= Quick Print button. In the drop-down list, select the Quick Print command.

File Edit Insert Format Tahle Data Tools
+ vk o~ &
Add |§3 o

Favaorites
=5 Quick Print
AA L\\)
Page Setup and Print
. =5 PageSetup 5
F|
1 Export to POF
2

Figure 66. Quick Print button
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4.1.10 Save a file

4.1.10.1 Save as

To save a new file or create a copy of the file you are working on, follow the steps below:
1. Run the saving command in one of the following ways:

— In the File menu, click Save as (see Figure 67).

File Edit Insert Format Table Dat
Y New Ctrl+N

New from Template...

[~ Open... Ctrl+0
Open With... 4
Recent Files »

Save Ctrl+S
Save As... F12

Figure 67. Save and Save As command menu options

— Onthe Toolbar, select the File section and click the arrow to the right of the I Save
button. In the drop-down list, select the Save As command (see Figure 68).
—  Press F12 for Windows. In macOS, press {Shift+sCmd+S.
2. Inthe Save As dialog box, pick or browse the folder to save the file. Enter a file name in

the File name box and select its format in the Save as type box. Click Save.

When you Save As a new file, it becomes the document you are working on.

| % @ ~ é KO Tharmes v
B I U AB T
save Font
Save As..,
_ C D E F

Figure 68. Save button
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4.1.10.2 Save

To avoid data loss due to power failure or other system malfunction, it is recommended to

save changes regularly.
To save changes in the document you are working on, do one of the following:
— Select File > Save (see Figure 57).
— On the Toolbar, select the File section and click thearrow to theright of

the I Save button. In the drop-down list, select the Save As command (see Figure 68).
— Press Ctrl+S / $sCmd+S.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 75



MyOffice

4.1.11 Export to

MyOffice Spreadsheet allows you to export files to the following formats:
— .pdf

— .pdf/a-1

—  .csV

— .tsv, .tab, .scsv

— .ixt

— xlsb

Exporting files to .xIsb format is not available when working in macQOS.

When exporting files to the .csv, .tsv, .tab, .scsv, and .txt formats:

— The file stores only the current sheet of the source file with text data. Formatting settings,
images, links, and other data are not saved.

— The .csv, .tsv, .tab and .scsv files use the semicolon (;) character as a value delimiter,

and the Tab character is used in .txt files.
When exporting to .xIsb format:

— Macros are not saved in the file (see Section 4.13.1).

— Empty cells are excluded from the sheets workspace (see Section 3.6).

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 76



MyOffice

To export a file to .pdf or .pdf/a-1, do the following steps:
1. Run the export command in one of the following ways:

— Select File > Export To (see Figure 69).

File Edit Insert Format Table Dat

[ New Ctrl+N

New from Template...

[ Open.. Ctrl+0
Open With... 4

Recent Files L4

-l Save Ctrl+S
Save As... F12

Autorecovery 4

Export To...

Save as Template...

Figure 69. Export To command menu option

— On the Toolbar, select the File section and click the arrow to the right of
the'EiJQuick Print button. In the drop-down list, select Export to PDF
(see Figure 70).

File Edit Insert Format Table Data Tools

+ hd g""; Iﬁ h .'%‘
Add EB 2 C

Favarites

(=h  Quick Print
Fagriy
Page Setup and Print
. (=% Page Setup 5
il
1 Export to PDF
2

Figure 70. Export to PDF

2. In the file manager window, select the folder where you want to export the file, specify

file name, and format and click Save.
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Specifics of exporting to .pdf and .pdf/a-1 formats:

— Links to websites remain functional in the exported file.
— Links to files and email addresses, links to location in the document (sheets, cells,

cell ranges, named ranges) are not exported.

To export a file to a different format, follow the steps below:
1. In the File menu, click Export To (see Figure 70).

2. In the file manager window, select the folder where you want to export the file, specify

file name and format, and click Save.
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4.1.12 Autorecovery of documents

By default, when working in MyOffice Spreadsheet, copies of the documents being edited
are autosaved, including documents that have never been saved by the user. If the application
crashes, when the application is reopened, the user can save the backed up documents as separate
files or replace the original documents with copies.

Backup copies of documents are saved for one month and then automatically deleted.

4.1.12.1 Configure autorecovery of documents

By default, autorecovery of documents is enabled. The data for auto-recovery is saved every
5 minutes.

To change the settings, follow these steps:

1. In the Command menu, select File > Autorecovery > Autorecovery Settings

(see Figure 71).

File Edit Insert Format Table Data Tools WView Share Subsd

() New Col+N - ko Thames |v| [12 [w| A-

B T U - A

bt

New from Template...

= Open.. Ctrl+0O
Open With... 4

Recent Files »

&) Save Ctrl+5S
Save As... F12

Autorecovery 4 Autorecovery Settings

Recovered Files
Export To...

Save as Template...

Figure 71. Autorecovery Settings command menu option

2. In the Autorecovery Settings window (see Figure 72):
— To disable or enable autorecovery of documents, uncheck or check the Save data
for recovery every box.
— To change the interval for saving document backups, specify it manually, using the
switch, the | and 7 keyboard keys or the mouse wheel. The switching step is

1 minute.
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— If you want to disable saving backups for one or more documents currently open,
check the boxes in the Don't save for following files list. This list does not show
documents that have never been manually saved.

— If you want to copy the path to the folder where the backed up copies of documents
are stored, click the 'Ll button.

3. Click Apply.

Autorecaovery Settings X
Save data for recovery every = 5 min
Don't save for following files:

Orders.xlsx

v Reportxlsx [Current]

Location:
C:/Users/user/AppData/Local/New Cloud Technologies Ltd/MyOffice/MyOffice
Spreadsheet/Restore

Apply Cancel

Figure 72. Autorecovery Settings dialog box

4.1.12.2 Document recovery

If the work with documents was finished incorrectly, then when you re-enter the application,

the dialog box shown in Figure 73 appears. Click Open in this dialog box.

Autorecovery *

Files you were working on have
been restored

Changes in these documents were not saved due to
the app crash. Open the files?

m Don't Open

Figure 73. Dialog box
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Backed up copies of documents will open in new application windows.
To save copies, follow the steps below for each copy:
1. Run the Save As command in one of the following ways:
— In the notification bar that appears below the Toolbar, click Save As

(see Figure 74).

File Edit Insert Format Table Data Tools View Share Subscription Help

=1
This file was automatically recovered. Save it to keep the data. Delete
A v o2 v fx

A B c D E F G H -

Figure 74. Save As button

— In the File menu, click Save As (see Figure 75).

File Edit Insert Format Table Dat

[ New Ctrl+N

New from Template...

[ Open... Ctrl+0
Open With... 4
Recent Files »

- Save Ctrl+5
Save As... F12

Figure 75. Save As command menu option

2. In the Save As window:

— If you want to save the copy as a separate file, select the folder where you want to
save it, specify the file type and name, and click Save.

— If you want to replace the original file with a copy, select the file and click Save.

If you want to delete a copy, click Delete in the notification bar below the Toolbar

(see Figure 76).

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 81



MyOffice

File Edit Insert Format Table Data Tools View Share Subscription Help
=1
This file was automatically recovered. Save it to keep the data. Save As...

A1 v 2 fx
. Q

Figure 76. Delete button

4.1.12.3 Recovered Files pane

If any backed up documents were not saved or deleted as described above, open

the Recovered Files pane.
To do this, proceed with one of the following:

— In the Command menu, select File > Autorecovery > Recovered Files (see Figure 77).

File Edit Insert Format Table Data Tools View Share Subs

(M New Ci+N b Thames v| (12 v A
New from Template...
B T U - A~
[~ Open.. Ctrl+0 .
I
Recent Files »
o) Save Ctrl+S
Save As... F2 [ b E
Autorecovery » Autorecovery Settings
Recovered Files
Export To...

Save as Template...

Figure 77. Recovered Files command menu option

— On the Sidebar, click [% Recovered Files (see Figure 78).
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123 B B O

Number F... Cells Data Insert ~

Figure 78. Recovered Files button

To open, save, or delete a document backup copy, follow the steps below:

1. Hover the cursor over the name of the copy (see Figure 79) and click the ‘ button.

2. In the drop-down list, select the desired command.

-» Recovered Files

A These files were recovered after the app
crash and will be stored for 30 days from
the recovery date. To keep your data, save
the necessary files.

x« Q W 2 O

Delete All

6:40 Orders.xlsx
Open
Save As...

Delete

Figure 79. Copy Management Commands
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You can also open a document backup copy by double-clicking its name in the list.

If you want to delete all copies of the documents, click Delete All (see Figure 80).

i . =* Recovered Files Q
A These files were recovered after the app '
crash and will be stored for 30 days from —
the recovery date. To keep your data, save =
the necessary files
o
Ex
cx

Figure 80. Delete All button
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4.1.13 Close a file

Once you have finished working with a file, save it (see Section 4.1.7) and close

the application window using one of the following tips:

— In the File menu, click Close (see Figure 81).

File Edit Insert Format Table Dat

[ New Ctrl+N

New from Template...

[ Open... Ctrl+0
Recent Files 4

o) Save Ctrl+5
Save As... F12
Autorecovery 4
Export To...

Save as Template...

(=) Page Setup and Print Ctrl+P

Close

Figure 81. Close command menu option

— Click * Close in the application window heading.

— Press Alt+F4 / £Cmd+Q.
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4.2 Sheets

4.2.1 Insert a sheet

By default, a new spreadsheet created in MyOffice Spreadsheet contains one sheet. You can

add as many sheets as you need manually.

To insert a sheet, do one of the following:

— In the Insert menu, click Sheet (see Figure 82).

— On the Toolbar, select the Insert section and click =*

y
Bt

@ o & QD

Image...
Text Box

Shape r

Chart k
Pivot Table...
Function... Shift+F3

Special Characters...

Link... Ctrl+K
Mote
Sheet

Current Date

Current Time

Insert  Format Table Data Tools

Figure 82. Insert menu

click [~ Sheet (see Figure 83).
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% =
™ v L—Q‘- v o -
S e T - BBEE,
=
B4 Image.. ~
Text Box
F (Y shape > - Q
fx
ol chart >
Pivot Table... <
76( Function... =Y
Special Characters... >
¢ Link..
% Note
[J  Sheet

Figure 83. Sheet button

—  Click the + button to the right of the sheet tabs (see Figure 84).

19

Flh Automatic

Figure 84. Add sheet button
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4.2.2 Rename a sheet

By default, spreadsheet sheets are sequentially named as Sheetl, Sheet2, Sheet3, etc.
To rename a sheet, perform the following actions:
1. Right-click the tab of the sheet you want to rename.

2. In the context menu, select Rename (see Figure 85).

21 Rename

2 Duplicate

23

2 Hide

25 Hide Zero Values

26

57 Protect Sheet...
< Delete

o [+

Figure 85. Context menu of a sheet

3. In the opened window (see Figure 86), enter the name of a sheet or and click OK.

Sheet name:

‘ Sheet? X ‘

Figure 86. Rename sheet

Sheet name cannot:

— Contain less than 1 and more than 31 characters.

— Contain any of the following characters: (3), (\), (), (?), (*), (D, (.
— Begin or end with a single quotation mark ().

— Repeat the name of the other sheet.
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4.2.3 Hide or unhide a sheet

To hide a sheet, do as follows:
1. Right-click the tab of the sheet you want to hide.

2. In the context menu, select Hide (see Figure 85).
To unhide hidden sheets, perform the following actions:

1. Right-click the tab of any displayed sheet.
2. In the context menu, select Unhide All (see Figure 87).

20

Rename
21 Duplicate
22
2 Hide
24 Unhide All

25

26
27 Protect Sheet...

Hide Zero Values

< Delete

Figure 87. Context menu of a sheet

4.2.4 Duplicate a sheet

MyOffice Spreadsheet allows you to duplicate any sheet of a spreadsheet, that is, to create
a copy of a sheet with all its contents.

To duplicate a sheet, perform the following actions:

1. Right-click the tab of the sheet you want to duplicate.

2. In the context menu, select Duplicate (see Figure 87).
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4.2.5 Change sheets order

In MyOffice Spreadsheet, you can change the order of sheets in the current spreadsheet.
To do this, follow the steps below:

1. Select the sheet that you want to change in order.

2. Click the left mouse button and drag the sheet to a new position on the sheet tabs.

3. Release the left mouse button to fix the selected position of the sheet.
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4.2.6 Zoom a sheet

By default, zoom is 100% when creating a spreadsheet. If necessary, you can zoom it in or
zoom out using the Command menu or the Status bar.
To change the zoom using the Command menu, do as follows:
1. In the View menu, select Zoom (see Figure 88).
2. In the opened list, select the desired option:
— Zoom In: Increase the current zoom by 10%.
— Zoom Out: Decrease the current zoom by 10%.

— Actual Size: Set the default zoom (100%).

View Share Subscription Help

Zoom 4 Zoom In
R1C1 Zoom Out
Toolbar 5 Actual Size Ctrl+0

Alignment

Figure 88. View menu

To change the zoom using the Status bar (see Figure 89), do one of the following:

—  With the left mouse button pressed, move the slider to the right or left to zoom in or out,
respectively.

— Click *to zoom in or = to zoom out. In each case, the zoom increment is 10 %.

— Select the current zoom value with the cursor in the lower right corner, modify it and
press Enter to confirm.

—  Press the arrow to the right of the current zoom value and select the zoom from the drop-

down list.

[E=d] +

@ Automatic SUM 0 AVERAGE O MIN O MAX O COUNTA 0 |— . +100% v|

Figure 89. Zooming tools
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4.2.7 Hide or display zero values

If a spreadsheet contains a lot of zero values, you might want to hide them to make you
spreadsheet easier to read. The hidden zero values are not printed.

To hide zero values on the sheet, proceed as follows:

1. Right-click the sheet tab of the sheet containing the zero values that you want to hide.

2. In the context menu of thesheet, select the Hide Zero Values check box

(see Figure 90).
= Rename
26 Duplicat
Llcate

27 :

28 Hide

29 Unhide All

20

31 " Hide fero Values

= Delete

pall >~ i

Figure 90. Context menu of a sheet

To display the previously hidden zero values on the sheet, proceed as follows:
1. Right-click the sheet tab of the sheet containing the zero values that you want to display.

2. In the context menu of the sheet, clear the Hide Zero Values check box.

4.2.8 Delete a sheet

To delete a sheet, perform the following actions:
1. Right-click the tab of the sheet you want to delete.

2. In the context menu, select Delete (see Figure 90).

When you run the command, the sheet is deleted along with the data without warning.

. If you have deleted a sheet by mistake, undo the action (see Section 4.12.1.1).
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4.3 Actions with cells, columns, and rows

4.3.1 Expand the workspace

All actions on the sheet are performed within the workspace (see Section 3.6).

By default, the workspace in a new sheet consists of 10 columns and 20 rows.

Workspace borders expand automatically if you insert more rows or columns than the current

workspace has.
To expand the workspace, do one of the following:
— Double-click a cell in a row or column in the inactive area that you want to include in
the workspace.
— Right-click the row or column heading outside the workspace in the inactive area and

select the Add rows: N or Add columns: N context menu (see Figure 91).

I

15
16
17
18
19
20
21
22
23

Add rows: 2

Figure 91. Add rows

— Select any cell in a row or column before the inactive area. To increase the workspace
by one or more columns, use Tab. To increase the workspace by one or more rows,

use Enter.
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4.3.2 Select a cell range

4.3.2.1 Select a custom cell range

To select a custom range of cells, use one of the following methods:

— Move the cursor to the first cell in the desired range. Hold down the left mouse button
and drag the cursor to the last cell of the range. Release the left mouse button.

— Select the first cell of the desired range. Hold Shift pressed and select the last cell of the

range.

You can select a range in any direction of rows or columns,

Some cell range selection examples are shown on Figure 92-Figure 94.

Figure 92. Select a horizontal cell range

Figure 93. Select a vertical cell range

—

Figure 94. Select a diagonal cell range
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4.3.2.2 Select all cells in a spreadsheet

To select all the cells that are in the workspace of the current sheet (see Section 4.2.1),
do one of the following:
— Move the mouse cursor to the upper left corner of the workspace so that the cursor looks
like % and click the left mouse button.

— In the Edit menu, click Select All (see Figure 95).

Edit Insert Format Table Data Tools Vie

= Undeo Ctrl+Z
~  Redo Crl+Y
o Cut Crl+X
Copy Ctrl+C
[y Paste Ctrl+V
Paste Values and Format Ctrl=Alt+V

Paste Values Only

Paste from Clipboard r
& Copy Formatting Ctrl+5hift+C
Paste Formatting Ctrl+Shift+V
Select All Ctrl+A
1 Find Cirl+F

Figure 95. Select a diagonal cell range

—  Press Ctrl+A / :Cmd+A.

If an element (image, shape, or diagram) is selected on the sheet, deselect the element

before selecting all cells by using the Command menu or keyboard shortcut.

When using these commands, only thecells on theactive sheet are selected.
Cells on the other sheets in the spreadsheet are not selected.

When switching to another sheet, the range remains selected.

4.3.2.3 Deselect cells

To deselect a cell range, left-click any cell in a spreadsheet.
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4.3.3 Resize cells

It is possible to resize cells in one of the following ways:
— By specifying the exact width and height of cells manually.
— Automatically match the width and height of the cells to the content.

To resize one or multiple cells, do the following:
1. Select the cells.
2. Open the Cell Size window in one of the following ways:

— In the Command menu, select Table > Cell Size (see Figure 96).

Table Data Tools View Share Subscription Help

T Insert Row Above Alt+A

&% Insert Row Below Alt+B
_ E Insert Column to the Left Alt+L
|

ﬂ Insert Column to the Right Alt+R
i

@ Delete Row

ffl Delete Column
Hide Row
Unhide Row
Hide Column

Unhide Column

B2 Merge Cells Ctrl+Alt+M
BEH Unmerge Cells Alt+Shift+M
[+ Cell Size...

Figure 96. Cell size command menu option

— On the Toolbar, select the Cells section and click 221 Cell Size (see Figure 97).

General w 2 L4 @ = O B Freeze w
P % @O q:}] HE‘ v E ﬂ % 'ﬂ'ﬁ Group
Mumber Cells

Figure 97. Cells Size button
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— Right-click the selected cells and run the context menu command Cell Size.
3. Inthe Cell Size window (see Figure 98), do one of the following:
— To specify the exact cell parameters, enter them in the Width and Height fields
manually.
— To automatically match the width and height of the cells to the content, select Adjust
automatically.

4. Click OK.

Cell Size X

O Set manually

Width

| BB o .

Height

0.53 cm w

Adjust automatically

Figure 98. Cell Size window
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4.3.4 Merge or split cells

4.3.4.1 Merge cells

You can merge any number of cells in the current spreadsheet.

When merging multiple cells:

— The selected range will merge into a single cell.

— The merged cell will only display the contents of the upper-left cell of the selection.

— When you merge multiple cells, the resulting cell will be formatted like the upper-left
cell of the merged range.

To merge cells, select them and do one of the following:

— In the Table menu, select Merge Cells (see Figure 99).

Table Data Tools View Share Subscription Help

Insert Row Above Alt+A

Insert Row Below Alt+B

s
=g
l E Insert Column to the Left Alt+L
1
ﬂ Insert Column to the Right Alt+R
=

Delete Row
Delete Column
Hide Row
Unhide Row
Hide Column

Unhide Column

£ Merge Cells Ctrl+Alt+M

Figure 99. Merge Cells command menu option
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—  On the Toolbar, select the Cells section and click FEH Merge Cells (see Figure 100).

O vIiE mE = B

Hy & B # B e

Cells

Figure 100. Merge Cells button

— Right-click the selected range of cells and choose Merge Cells context menu.

— Press Ctrl+Alt+M / ~Option+3 Cmd+M.
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4.3.4.2 Split cells

MyOffice Spreadsheet allows you to split the previously merged cells.
To split the cells, select the merged cell and do one of the following:

— Inthe Table menu, select Split Cells (see Figure 101).

Table Data Tools WView Share Subscription Help

Insert Row Above Alt+A
Insert Row Below Alt+B

Insert Column to the Left Alt+L
Insert Column to the Right Alt+R

Delete Row

= == B d

Delete Column
Hide Row
Unhide Row
Hide Column

Unhide Column

B Merge Cells Ctrl+Alt+M
£ Unmerge Cells Alt+Shift+M

Figure 101. Split Cells command menu option

—  On the Toolbar of the Cells section, click F Split Cells (see Figure 102).

CvH ma s &8
Hv & B @ § 8.

Cells

Figure 102. Split Cells button

— Right-click the selected cell and select the Split Cells option from the context menu.
—  Press Alt+Shift+M / ~Option+{ Shift+M.
The data contained in the merged cell will be placed in the upper-left cell of the resulting

range. The resulting cells will be formatted like the merged cell.
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4.3.5 Insert rows and columns

4.3.5.1 Insert columns

To quickly add one column, perform the following actions:
1. Select a cell or a column to the left or to the right of which you want to add a new column.
2. Insert a column in one of the following ways:

— In  the Table menu, select Insert Column to the Left or

Insert Column to the Right (see Figure 103).

Table Data Tools View Share Subscription Help

= Insert Row Above Alt+A
s Insert Row Below Alt+B
E Insert Column to the Left Alt+L
m Insert Column to the Right Alt+R

Figure 103. Insert Columns commands

— On the Toolbar, select the Cells section and click E Insert Column to the Left or

ﬂ Insert Column to the Right (see Figure 104).

—

SCvE mE="m B 'l
Hv & (B #H|8 e~

Cells Data

Figure 104. Buttons to insert columns

— Right-click the selected cell or heading of the selected column and select
the Insert Column to the Left or Insert Column to the Right command from
the context menu.

— To insert column to the left, press Alt+L / ~Option+L. To insert column to

the right, press Alt+R / ~Option+R.
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To add several columns, perform the following actions:

1. Select the number of columns and cells horizontally equal to the number of columns to
be inserted.

2. Insert the columns in one of the following ways:
— In  theTable menu, select Insert Column to theLeft or

Insert Column to the Right (see Figure 103).
— On the Toolbar, select the Cells section and click E Insert Column to the Left or

ﬂ Insert Column to the Right (see Figure 104).

— Right-click anywhere the selected range and select the Insert Column to the Left
or Insert Column to the Right command from the context menu.

— To insert columns to the left, press Alt+L / ~=Option+L. To insert columns to

the right, press Alt+R / ~Option+R.

To double the number of columns on the sheet, perform the following actions:
1. Select any entire row on the sheet (see Section 4.3.5.1).
2. Insert the columns in one of the following ways:
— Right-click the column heading area and select the Insert Column to the Left or
Insert Column to the Right command from the context menu.
— To insert columns to the left, press Alt+L / ~Option+L. To insert columns to

the right, press Alt+R / ~=Option+R.
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4.3.5.2 Insert rows

To quickly add one row, perform the following actions:
1. Select a cell or a row to the left or to the right of which you want to add a new row.
2. Insert the row in one of the following ways:
— In the Table menu, select Insert Row Above or Insert Row Below command menu

item (see Figure 105).

Table Data Tools View Share Subscription Help

™ Insert Row Above Alt+A
&5 Insert Row Below Alt+B

Figure 105. Insert Rows commands

—  On the Toolbar, select the Cells section and click the B8 Insert Row Above or
& Insert Row Below button (see Figure 106).

Sv i |m Z|=m By 7
Hv B B @ § o8-
Cells Data

Figure 106. Buttons to insert rows

— Right-click anywhere on the selected range and select the Insert Row Above or
Insert Row Below command from the context menu.
— To insert rows above, press Alt+A / —~Option+A. To insert rows below,

press Alt+B / ~Option+B.
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To add several rows, perform the following actions:
1. Select the number of rows and cells vertically equal to the number of rows to be inserted.
2. Insert rows in one of the ways:
— In the Table menu, select Insert Row Above or Insert Row Below command menu
item (see Figure 105).
— On theToolbar of the Cells section, click TH Insert Row Above or
& Insert Row Below (see Figure 106).
— Right-click anywhere on the selected range and select the Insert Row Above or
Insert Row Below command from the context menu.
— To insert rows above, press Alt+A / ~Option+A. To insert rows below, press
Alt+B / ~Option+B.
To double the number of rows on the sheet, perform the following actions:
1. Select any entire column on the sheet (see Section 4.2.5.1).
2. Insert rows in one of the ways:
— Right-click therow heading area and select the Insert Row Above or
Insert Row Below command from the context menu.
— To insert rows above, press Alt+A / ~Option+A. To insert rows below, press

Alt+B / ~Option+B.
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4.3.6 Select rows and columns

4.3.6.1 Select a row or a column

To select the entire row or column in spreadsheet, do one of the following:

— Hold thecursor over a row or column heading until the cursor
changes to an arrow (¥ or =+). Left-click the heading.

Click any cell in therow or column you want to select. To select a row,

press Shift+Space. To select a column, press Ctrl+Space / {Shift+:3Cmd+Space.

To select all rows containing a merged cell (see Section 4.3.4.1), select the cell and press
Shift+Space.

To select all columns containing a merged cell (see Section 4.3.4.1), select the cell and press

Ctrl+Space / tShift+:Cmd+Space.
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4.3.6.2 Select a range of rows or columns

To select a range of rows or columns, follow the steps below:

1. Hold the cursor over the heading of the first row or column that you want to select.
The cursor will change to an arrow (¥ or =+).

2. Press and hold the left mouse button and drag the cursor to the headings of the items
to be selected.

3. Release the left mouse button.

To select a range of rows or columns not included in the workspace area,
follow the steps below:
1. Hold the cursor over the heading of the first row or column that you want to select.
The cursor will change to an arrow (¥ or =+).
2. Left-click the heading to select it.
3. Hold the cursor over the heading of the last row or column that you want to select.
The cursor will change to an arrow (+ or =+). Click the heading while holding the Shift
key pressed.
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4.3.7 Hide rows and columns

4.3.7.1 Hide a row or a column

To hide rows or columns, perform the following actions:
1. Select the entire row(s) or column(s) (see Section 4.3.5.1).
2. To hide them, do one of the following:
— In the Table menu, select Hide Column or Hide Row (see Figure 107).

Table Data Tools View Share Subscription Help

T8 Insert Row Above Alt+A
& Insert Row Below Alt+B
E Insert Column to the Left Alt+L
m Insert Column to the Right Alt+R
&% Delete Row

 Delete Column
Hide Row
Unhide Row
Hide Column

Unhide Column

Figure 107. Table menu

— Right-click therow or column heading and select the Hide Column

or Hide Row command in the context menu.

Hidden rows or columns are marked in the heading as shown (see Figure 108).

A B
1 5000
6 10000
i

Figure 108. Hidden rows

Hidden rows and columns are not printed.
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4.3.7.2 Unhide rows and columns

To display a hidden column or row, follow these steps:
1. Select two rows or columns (see Section 4.3.5.1) between which there is a hidden
element.
2. Run the item display command in one of the following ways:
— Select the Command menu item Table > Unhide Column/Unhide Row
(see Figure 107).
— Right-click on the headers of the selected columns/rows and run the Show Column

or Show Row context menu command.

After running the command, all rows/columns hidden under the marker are displayed.
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4.3.8 Resize rows and columns

You can modify the size of a row or a column in one of the following ways:

— By moving the border of a cell of a row or column manually.

— By automatically selecting the size of a row or column in accordance with the size of
the contents.

— By specifying the exact width of the column or height of the row.

4.3.8.1 Resize a row or a column manually

To change the size of a single column or row, follow these steps:

1. Hover the cursor over the right border of the column header or the lower border of
the row header so that the cursor takes the form of a two-sided arrow.

2. Hold down the left mouse button and move the border to the desired position.

3. Release the left mouse button to lock the selected position.

To set the same size for multiple columns/rows, follow these steps:
1. Select the columns/rows.
2. Set the size for one column/row that you want to apply to all selected columns/rows.

To do this, proceed as follows:

— Move the cursor to the right border of the header of any column or to the lower
border of the header of any row so that the cursor takes the form of a two-sided
arrow.

— Hold down the left mouse button and move the border to the desired position.

— Release the mouse button to lock the selected position.

For theselected columns/rows, thesize specified for this column/row
will be automatically set.
To set the same size for all rows/columns in the workspace (see Section 3.6), select all cells

of the sheet (see Section 4.3.2.2) and follow the same steps.
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4.3.8.2 Autofit the width

To automatically adjust the column width based on the content of the cell with the largest

amount of data, do one of the following:

Hover the mouse cursor over the right border of the column header so that the cursor
takes the form of a two-sided arrow and double-click.

Right-click the column header and run the context menu command Fit Width to
Content.

Right-click the column header and run the Column Width context menu command.
In the Column Width window (see Figure 109), select Adjust automatically and
click OK.

Column Width >

O Set manually
Width

0.14 inch v

Adjust automatically

Figure 109. Column Width window

To automatically adjust the row height based on the content of the cell with the largest

amount of data, do one of the following:

Hover the mouse cursor over the lower border of the header so that the cursor takes
the form of a two-way arrow and double-click.

Right-click the line header and run the Fit Height to Content context menu command.
Right-click therow header and run the Row Height context menu command.
In the Row Height window (see Figure 110), select the value Adjust Automatically
and click OK.
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Row Height x

© Set manually
Height

0.14 inch

Adjust automatically

Figure 110. Row Height window

To automatically adjust the width/height of several columns/rows, follow these steps:
1. Select the required columns/rows.
2. Autofit width/height in one of the following ways:

— Hover the mouse cursor over the border between any two column/row headers in
the selected range so that the cursor takes the form of a two-sided arrow.
Double-click.

— Right-click the header of any column/row in the selected range and run the context
menu command Fit Width to Content or Fit Height to Content.

— Right-click the header of any column/row in the selected range and run the context
menu command Column Width or Row Height. In the window that opens

(see Figure 109 and Figure 110), select Adjust automatically and click OK.

For each column/row in the selected range, the width/height will be selected according to

the contents of the cell with the largest amount of data.
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4.3.8.3 Specify the exact size

To specify the exact width for one/more columns or height for one/more rows, follow these
steps:

1. Select these columns or rows.

2. Right-click the header of any column or row in the selected range and run the context
menu command Column Width or Row Height.

3. In the window that opens (see Figure 109 and Figure 110), specify the required
Column Width or Row Height.

4. Click OK.

4.3.9 Freeze rows, columns, or area

Freezing rows, columns or areas is useful if you are working with large amounts of data and
often scroll through the window. You can freeze any range of columns and rows so that they are
always visible when you move around the sheet.

The frozen element is separated from other elements in the spreadsheet with a bold line.

If you've already frozen rows or columns and want to freeze the new ones, the previous
setting for the same item will be invalidated.

In MyOffice Spreadsheet, you can freeze the following elements:

— One or multiple columns (see Figure 111): As you scroll the sheet to the right, only

the frozen columns are displayed. All the columns to the left are not displayed.

L= I < S (R = R o, (R - S B L B

— =
= =

Figure 111. Column B is frozen
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— One or multiple rows (see Figure 112): As you scroll the sheet down, only the frozen

rows are displayed. All the rows above are not displayed.

14
15
16
17
18
19

Figure 112. Row 4 is frozen

— Both rows and columns (see Figure 113): As you scroll the sheet to the right and down,
only the frozen rows and columns are displayed. All the columns to the left and rows

above are not displayed.

15
16
17
18
19
20
21
22

Figure 113. Columns B and C and rows 3 and 4 are frozen

— The area in a spreadsheet where Al is the top left cell and the bottom right cell is
specified by you.
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Figure 114. Frozen area
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4.3.9.1 Freeze columns or rows

To freeze one or multiple rows or columns, follow these steps:
1. Entirely select rows or columns you want to freeze or select any cells in these rows or
columns.
2. Freeze columns or rows in one of the following ways:
— In the Table menu, select Freeze Selected Rows and Columns (see Figure 115).
In the opened sub-menu, select Freeze Horizontally to freeze rows or Freeze
Vertically to freeze columns. Or select the Toolbar of the Table section and press
thearrow to theright of the @ Freeze Selected Rows and Columns

(see Figure 116).

Table Data Tools View Share Subscription Help

5  Insert Row Above Alt+A v L v 123
&F Insert Row Below Alt+B

W - coe

ﬁ Insert Column to the Left Alt+L
g Insert Column to the Right Alt+R

ment MNumber F...

& Delete Row
ff Delete Column G
Hide Row
Unhide Row
Hide Column

Unhide Column

Merge Cells Ctrl+Alt+M
Unmerge Cells Alt+Shift+M

B & B

Cell Size...

Wrap Text

Freeze Selected Rows and Columns 3 Freeze Horizontally
Freeze Vertically

Unfreeze All

Figure 115. Freeze Selected Rows and Columns sub-menu
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— On the Toolbar, select the Cells section and click
the B3 Freeze Selected Rows and Columns button (see Figure 116).

— On the Toolbar, select the Cells section and click the arrow to theright of
the B Freeze Selected Rows and Columns button (see Figure 116). In the opened

menu, select Freeze Horizontally to freeze rows or Freeze Vertically to freeze

columns.
SviE mBHB | rFreee v £
b |r|ﬂrl W
v
BE‘ . E ﬂ m 5| Freeze Horizontally
Cells
[ EE| Freeze Vertically
M N O B  Freeze Selected Rows and Columns

E Freeze Area

Figure 116. Freeze button
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4.3.9.2 Simultaneously freeze rows and columns

To simultaneously freeze rows and columns, follow these steps:

1. Select any number of cells located in rows or columns you want to freeze.

2. Freeze rows and columns in one of the following ways:

On the Toolbar, select the Cells section and click
the B Freeze Selected Rows and Columns button (see Figure 116).

On the Toolbar, select the Cells section and click the arrow to theright of
the B Freeze Selected Rows and Columns button. In the opened window, select
Freeze Selected Rows and Columns (see Figure 116).

Right-click the headings of theselected rows and columns and select

Freeze Selected Rows and Columns in the context menu.
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4.3.9.3 Freeze an area

To freeze an area, follow these steps:
1. Select a cell which will be the bottom right cell of the area.
2. Freeze the area in one of the following ways:
— On the Toolbar, select the Cells section and click
the B Freeze Selected Rows and Columns button (see Figure 116).
— On the Toolbar, select the Cells section and click the arrow to theright of
the B Freeze Selected Rows and Columns button. In the opened window, select

Freeze Selected Rows and Columns (see Figure 116).

4.3.9.4 Unfreeze rows and columns

To unfreeze rows and columns, do one of the following:

— In the Table menu, select Freeze Selected Rows and Columns and then Unfreeze All
(see Figure 115).

— On theToolbar, select the Cells section, click thearrow next to
the B Freeze Selected Rows and Columns button and select the Unfreeze All option
(see Figure 115) in the drop-down list.

— Right-click the heading of a row or column and select and select the Unfreeze All option

from the context menu.
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4.3.10 Group rows or columns

To group rows or columns of your choice, select them and do one of the following:

1. In the Data menu, select Group Rows or Group Columns (see Figure 117).

Data Tools View Share Subscription

Define Name...
Manage Protection 4

Refresh Pivot Table
Pivot Table Settings

Delete Pivot Table

Smart Table Settings

Group Rows

Group Columns

eon B &

Clear Grouping

Figure 117. Data menu

2. On the Toolbar, select the Cells section and click the “Q Group button
(see Figure 118).
3. On the Toolbar, select the Cells section and click the arrow to the right of the f Group

button and select Group Rows or Group Columns.

QVL::'I ™ S e B Freeee v Y/
HvE B A § (Boow] 3@

Cells
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u?n Group Columns

=
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Figure 118. Group button

4. Right-click the heading of the selected rows or columns and select Group rows or

Group columns from the context menu.
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If a range of cells is selected and not just rows or columns, then pressing the ¢f Group
button opens the Group window (see Figure 119), where you should choose which items you want

to group.

Grouping >

Group Columns

Cancel

Figure 119. Group window

The final row of each group is at the bottom of the group. The final column of the group is
the rightmost column of the group. The heading of the final row and the final column is grayed out.
You can create up to 7 levels of groups.

If necessary, you <can collapse or expand thedata in the groups.

Use the  or @ outline symbols for this purpose.

To clear the grouping, follow these steps:

1. Select a range of cells for which you want to clear the grouping.

2. Select the Data menu > Clear Grouping (see Figure 117). Or on the Toolbar, select
the Cells section and click the arrow to the right of the ¢f Group button and select

Clear Grouping (see Figure 118).

If you want to print the sheet that contains grouped columns or rows, these grouped elements

will be printed as they are displayed on the screen.
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4.3.11 Delete columns or rows

To delete one or more rows or columns, use one of the following methods:
1. Select rows or columns you want to delete, or cells located within them.
Do one of the following:

— In the Table menu, select Delete Column or Delete Row (see Figure 120).

Table Data Tools View Share Subscription Help

T Insert Row Above Alt+A
& Insert Row Below Alt+B
"B Insert Column to the Left Alt+L
|

ﬂ Insert Column to the Right Alt+R
i

# Delete Row

ffl Delete Column

Figure 120. Commands to delete columns or rows

— On the Toolbar, select the Cells section and click the % Delete Column or
@ Delete Row button (see Figure 121).

S -
v

Cells Data

™ a(wm B 7
il

[

Figure 121. Buttons to delete columns or rows

— Right-click anywhere in the selected range and use the Delete Column or
Delete Row context menu command.

2. Select these columns/rows as a whole and press Ctrl+- / 38 Cmd+-.
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4.4 Data
4.4.1 Enter data

4.4.1.1 Enter data in a cell

To enter or change data in a cell, perform the following actions:
1. Activate the edit mode in one of the following ways:

— Select an empty cell.

— Double-click the cell you want to edit.

— Select the cell you want to edit and go to the Formula bar.

2. Enter the necessary data into the cell. Use the comma sign (,) as the delimiter for

numbers.
3. Save the entered data in one of the following ways:

—  Press Enter.

~ Click @ in the right side of the Formula bar (see Figure 122).

— Select another cell on the spreadsheet.

To undo the changes you have made, do one of the following while editing:

— Click ®in the right side of the Formula bar (see Figure 122).

— Press Esc.

A1 v fx 11 20

Figure 122. Enter data and Cancel buttons
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4.4.1.2 Automatically adjust cell width

When you enter a number in a cell, the width of this cell is automatically adjusted to fit

the number.
Cells width is not adjusted in the following cases:
— The width of the column containing the cell has been previously changed in the manual
mode (see Section 4.3.8.1).
— The cell format is Text (see Section 4.4.3.1.9).
— The cell is filled with text.

4.4.1.3 Floating cell

The floating cell (see Figure 123) appears when you edit a cell and move through the current

sheet of the spreadsheet.

The cell displays the current data in the cell you were editing, so it is convenient to use when

navigating through a large amount of data in the document.

10
11 [+
12 Floating cell

13
14
15

Figure 123. Floating cell
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4.4.1.4 Fill cells automatically

MyOffice Spreadsheet allows you to automatically fill the adjacent cells. A single cell as

well as a range of cells can be selected as a sample for filling.

If a single cell with a text or numeric value is selected as a reference, its content is copied to

subsequent cells when it is autofilled.

If a cell with a formula is selected as a reference, the subsequent cells will be filled in with

data sequences calculated using the formula specified in the cell. The values are automatically

recalculated if the data in the formula cells change.

If a cell range is selected as a sample range, the subsequent cells are filled in according to

the rules described below.

The filled cells will have the same format as the sample range (see Section 4.4.3).

To automatically fill the data, follow the steps below:

1.
2.
3.

Enter the desired data in one or more adjacent cells.

Select the cells.

Move the mouse cursor over the corner handle of the selected cell so that the cursor looks
like U,

Drag the corner autofill handle over the range of cells that you want to fill in. You can

drag the corner autofill handle either vertically or horizontally.

If the range of cells to be filled exceeds the workspace boundaries (see Section 4.3.1),

the workspace expands automatically.
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4.4.1.4.1 Fill cells automatically with arithmetic sequences

In MyOffice Spreadsheet, you can fill cells with arithmetic sequences. This type of sequence

adds the difference between the previous two to each of thesubsequent values.

For example, 1, 2, 3, 4...

To autofill cells with a geometric sequence, follow the steps below:

1.
2.
3.

Enter the first 2 range values in the adjacent cells to set the reference.
Select the resulting range containing the 2 cells.

Move the mouse cursor over the corner handle of the selected cell so that the cursor looks
like O,

Drag the corner autofill handle over the range of cells that you want to fill in. You can

drag the corner autofill handle either vertically or horizontally.

4.4.1.4.2 Fill cells automatically with geometric sequences

In MyOffice Spreadsheet, you can fill cells with geometric sequences. In this sequence view,

each of the following values is multiplied by the specified progression denominator.

For example, 0.25, 0.5, 1, 2...

To autofill cells with a geometric sequence, follow the steps below:

1.
2.
3.

Enter the first 3 range values in the adjacent cells to set the reference.

Select the resulting range.

Move the mouse cursor over the corner handle of the selected cell so that the cursor looks
like U,

Drag the corner autofill handle over the range of cells that you want to fill in. You can

drag the corner autofill handle either vertically or horizontally.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 125



MyOffice

4.4.1.4.3 Reduce the data range

If necessary, you can quickly reduce the range of data resulting from autofill. When the range

is reduced, the data in the columns on the right or the rows on the bottom is deleted.

To reduce the range, follow the steps below:

1.
2.

Select the range of cells with the data resulting from the autofill.

Move the mouse cursor over the corner handle of the selected cell so that the cursor looks
like {7,

If you want to delete data in the columns on the right side of the autofill range, drag
the corner handle to the left. If you want to delete data in the rows at the bottom, drag
the corner handle upwards.

Release the left mouse button. All data will be deleted from the columns or rows excluded

from the range.

4.4.1.4.4 Autofill cells: basics

Cells can be filled automatically if two or more cells from the sample range contain

the following data:

— A series of integers, fractions, or negative numbers.

— Dates or time.

— Text and a number (with or without the delimiter). For example, Text 1, Text 2 or
Textl, Text3, Text5.

— Abbreviated (Jan-Dec) or full month names (January-December).

— Abbreviated (Mon-Sun) or full weekdays names (Monday-Sunday).

— Data validation conditions (see Section 4.4.4).

If the sample range contains cells of different formats, then, when autofilling a series,

the cells repeat the formats and follow the sequences in the order corresponding to

the sample range.

If there is a cell with text in the sample range, it will be copied when the series is

autofilled, and the other cells will follow the specified sequence.

If a cell with text is located between cells in a series that have different formats, the text

will be copied when autofilling, and cells of different formats will follow different

sequences.

If the sample range contains a merged cell, an identical merged cell is automatically

created in the autofill range that continues the specified data sequence.
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— If a merged cell partially falls into the autofill range (also due to partial hiding), the
merged cell will be split.

— Cells of General and Number formats (Number, Currency, Accounting, Fraction,
Percentage, Exponent) are considered as one sequence.

— Date and Time are unrelated formats and are considered as separate sequences.

— When autofilling dates, the sequence is calculated based on the actual calendar

difference.
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4.4.1.5 Text formatting of formulas and numbers

In some cases, a formula or number that is entered into a cell needs to be retained in its
original form. For example, display zero characters when entering the number 00056 or specify
a formula without its further use. To do this, text formatting should be applied to the cell in which
the number or formula is entered.

The formatting is applied by using a single quotation mark ().
The single quotation mark should be entered in a cell immediately before the formula or number to
be recognized as text. For example: '=SUM(B1;C1) or '00056.

The quotation mark is displayed:

— On the formula bar, when you select a cell.

— Inthe cell and on the formula bar, when you edit a cell.

If you want to cancel text formatting, delete the quotation mark in the cell.
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4.4.2 Sort and filter

With MyOffice Spreadsheet, you can sort and filter data on the spreadsheet sheet

you are working on.

4.4.2.1 Define the Sort and Filter range

To define the Sort and Filter range, follow these steps:

1. Select the range of cells that will contain all the data to be sorted and filtered.

The top line of the range, marked ~, is not involved in the filtering and sorting

process. The range cannot consist of one line.

2. On the Toolbar, select the Data section and click the? Sort and Filter button
(see Figure 124).

g
|
2

Y v v iy v

I~ 05 B (@)~
- - BB E

Data nsert

Figure 124. Sort and Filter button
The active Sort and Filter range on the sheet is as follows (see Figure 125):

— Headings of rows and columns are highlighted in green.

— A green frame appears around the range.
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4.4.2.2 Automatic detection of the Sort and Filter range

MyOffice Spreadsheet can detect the Sort and Filter range automatically if the cells
adjacent to the selected one contain data. Data in adjacent cells can be of any format.
To automatically detect the range, follow these steps:

1. Select an empty cell bordering the range.

2. On the Toolbar, select the Data section and click v Sort and Filter (see Figure 124).

4.4.2.3 Sort

When sorting, the selected values in the column are arranged in the ascending
(from A to Z) or descending (from Z to A) order.
To sort data in a column, follow these steps:
1. Click the ™ button in the upper cell of the column (see Figure 125).
2. Inthe opened sort and filter settings window, select the sorting mode:
— Ascending: Sort the data in ascending order.

— Descending: Sort the data in descending order.

A B ( D E F G H
1 No. * Education ~ Age * Gender ~ City v Ao >_a
2 1 High School 54 F Dallas Ascending Descending
3 2 Middle School 32 F Seattle
4 3 High School 33F Seattle
5 4 Elementary 31 M Seattle |

2 High School 52 F Dallas

6 High School 58 M Seattle

7 Middle School 19 F Seattle 9 dear Al
g 8 High School 43 M Seattle

10 9 Elementary 18 M Dallas @ Dallas

11 10 Middle School 20 F Seattle @ Seattle

12

13

14

15

16

17

18

19 “ Cancel

20

Figure 125. Sort and Filter settings dialog box
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4.4.2.4 Filter

Using filtering, you can hide or unhide the selected values in the column.

To filter data, follow these steps:

1.
2.
3.

Click the ~ button in the upper cell of the column to be filtered (see Figure 125).

In the opened sort and filter window, uncheck the Clear All box.

If necessary, adjust the width and/or height of the window:

— To increase/decrease the window width, move its right border to the right/left.

— To increase/decrease the window height, move its lower border down/up.

— To adjust the window width and height simultaneously, move its bottom right corner
in the desired direction.

Check the boxes with values to be displayed in the column.

If there are too many values on the list, use the search field:

— Enter the value you want to find (in full or partially). For example, to find the number
123, you can enter the numbers 12, 23 or 123 in the search field.

— Check the values to be displayed in the column in the search results.

— To find and check other values, repeat the procedure.

Click OK.

To display all the data in the column, open the Sort and Filter window once again and check

the Select All box.
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4.4.2.5 Copy and insert filtered data

After filtering, only visible data is copied from the table. Hidden data is not copied.

Copying and pasting data can be done using standard methods
(see Section 4.12.2.1 and 4.12.2.2). The copied data can be pasted in any place of the current or
other MyOffice Spreadsheet document.

4.4.2.6 Refresh the filter

If the values in the selected range have changed, you can reapply a filter to the data without
reconfiguring the filter itself. Simply follow these steps:

1. On the Toolbar, select theData section and click thearrow to theright of

the NS Sort and Filter button (see Figure 126).

2. Select the Refresh option from the drop-down menu.

A
v A
~ o~ (3 B @

Insert ~

W

ol &l

Refresh

LEE
86

Figure 126. Refresh command
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4.4.2.7 Finishing work with sorting and filtering range

To finish working with the current sorting and filtering range, on the Toolbar, in

the Data section, click v Sort and Filter (see Figure 127).

.
1 —+— "
shomme} .+ - 05 &4 @)~ -

Data Insert

Figure 127. Sort and Filter button

When you finish working with a range, only the sorting results will be displayed in

the spreadsheet. Filtering results will not be displayed.
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4.4.3 Number formats

Different formats can be applied to the numbers that are contained in the cells. The formats
affect how the numbers are displayed. For example, numbers can be represented as units of money,
percentages or fractions, time, or date. Also, some formats allow you to customize the type of
representation of negative numbers, divide groups of digits in numbers, and select the number of
digits displayed after the decimal point.

Numeric formats are important for correctly interpreting data in application operations, such

as calculations in formulas.
4.4.3.1 Types of number formats

4.4.3.1.1 General

The General format is assigned to all cells by default when the sheet is created. The General
format is universal, that is it can be used in all formulas and functions.

The following numbers in the General format are automatically displayed in scientific
notation:

— Prime numbers consisting of more than 11 characters.

— Fractional numbers in which the integer part consists of more than 11 characters.
Once these numbers are entered in the cell, they are displayed in scientific notation.

For fractional numbers in the General format, non-significant zeros in the fractional part are

not displayed.
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4.4.3.1.2 Number

The main entry format for numbers.

The following parameters can be set for the Number format:

— Displaying numbers with a thousand separator.

— The number of characters displayed after the dot (.) delimiter.

— Negative number presentation type.

These parameters can be set using the number format setting window (see Section 4.4.3.3).

You can also set the number of characters displayed after the dot (.) delimiter using the buttons on
the Toolbar (see Section 4.4.3.4).
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4.4.3.1.3 Currency

The Currency format is used to display monetary values which are supplemented by default
with a currency sign or code corresponding to the system settings of your computer (see Figure 128).

The currency sign used by default can be modified.

Al v fx 1004.12

A
1 $1,004.12]

Figure 128. Example of a number in the Currency format

To quickly convert a cell into the Currency format, perform the following actions:

1. Select a cell or a range the format of which you want to change.

2. On the Toolbar, select the Number Format section and click $ Currency

(see Figure 129).

Currency hd

$ % 0o .Dc; )

Mumber Format
Figure 129. Currency button

A cell is automatically formatted as Currency if you specify the currency code next to
the number. For example, 23.00 USD or USD 23.00. For the full list of supported currencies and

their codes, see Appendix 2. List of supported currencies.

If a cell is formatted as Text, entering the currency code will not affect the cell format.

If you select Text format for a cell, when you enter a currency code, the format of the cell

does not change.
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The following parameters can be set for the number in the Currency format:

Currency code and symbol to be entered next to the number.

The number of characters displayed after the dot (.) delimiter.

Negative number presentation type.

These parameters can be set using the number format setting window (see Section 4.4.3.3).

You can also set the number of characters displayed after the dot (.) delimiter using the buttons on
the Toolbar (see Section 4.4.2.4).
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4.4.3.1.4 Accounting

The Accounting cell format is applied to numbers used in accounting documents.
In the Accounting format, the entered number is supplemented automatically with the currency
name which corresponds to the system settings of your computer.

When you enter numbers in the Accounting format:

1. 0 (zero) in cells is automatically replaced with a hyphen (-).

2. Negative numbers in cells are put in parentheses.

On the Formula bar and in the editing mode, zeros and negative numbers are displayed

the way they were entered (see Figure 130).

Al v fx -65.85

A
1 ($ 65.85)

Figure 130. Negative number formatted as Accounting

For the number in the Accounting format, you can the currency code or symbol displayed

next to the number and specify the number of decimal places displayed after the dot (.) delimiter.

These parameters can be set using the number format setting window (see Section 4.4.3.3).
You can also set the number of characters displayed after the dot (.) delimiter using the buttons on

the Toolbar (see Section 4.4.2.4).
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4.4.3.1.5 Date, Time or Date and Time

If you enter a number in the Date, Time or Date and Time format in a cell, the cell is
automatically assigned the Date, Time or Date and Time format, respectively

(see Figure 161-Figure 133).

If necessary, date and/or time display format can be changed using the number format setting

window (see Section 4.4.3.3).

A1 v fx 18.07.2022

A
1 18.07.2022

Figure 131. Number formatted as Date

A v fx 12:25:00

A
1 12:25:00

Figure 132. Number formatted as Time

AT v fx 18.07.2022 12:25:00

A
1 18.07.2022 12:25

Figure 133. Number formatted as Date and Time

The original number corresponds to all data in the Date and Time formats.
Its starting point for all dates is December 30, 1899, whose original number is 0.
For example, the original number for the date of January 1, 1990 is 2.

The original number for data in the Date format will always be integer.
To see this number, change the cell format to General or Number.

The original number for data in the Time format will always be integer from the range of
from 0.0 to 0.999988426. To see this number, change the cell format to Number.

The original number is required in calculations. Otherwise, cells with dates and time would

be considered as text cells and could not act as arguments in formulas and functions.
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4.4.3.1.6 Percentage

This format is used to display numbers as percentages.
When applying the Percentage format, the entered number is multiplied by 100 and designated with

a percent sign (%). The initial value is displayed in the cell and supplemented with a % sign.

Al v  fx 0.253

A
1 25.30%

Figure 134. Number formatted as Percentage

To quickly convert a cell into the Percentage format, perform the following actions:
1. Select a cell or a range the format of which you want to change.
2. On the Toolbar, select the Number Format section and click % Percentage

(see Figure 135).

Percentage v g v
$ (%] © 9% H-~
Number Format Cells

Figure 135. Percentage button

For the numbers in the Percentage format, you can set the number of characters displayed
after the dot (.) delimiter using the number format setting window (see Section 4.4.3.3) or

the buttons on the Toolbar (see Section 4.4.2.4).
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4.4.3.1.7 Fraction

This format is used to display fractional numbers as ordinary fractions, that is the fractional

part is replaced by a numerator and denominator (see Figure 136).

A1 v fx 1,6789

A
1 12/3

Figure 136. Number formatted as Fraction

In the Fraction format, the numerator and denominator are calculated in two ways:
— Exact (for example, 0.5 = 1/2)
— Approximately (for example, 1.6789 = 1 2/3)
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4.4.3.1.8 Scientific

The Scientific format is used to display large numbers in a short form.

In the Scientific format, part of the entered number is replaced by E + n, where E denotes
the scientific notation (the preceding number is multiplied by 10 to the power of n). For example, in
the Scientific format the mass of the planet Earth (5,980,000,000,000,000,000,000,000 kg) is
represented as 5.98E+24, which means 5.98 multiplied by 10 to the power of twenty-four.

If the Scientific format is applied to a cell, the number in the cell is displayed in the scientific
notation regardless of how many characters it contains. At the same time, numbers that contain up
to and including 15 characters are displayed in their original form in the edit mode and on

the Formula bar.

A number in the Scientific format is displayed in a cell as follows (see Figure 137):

— The integer part, always consisting of one number.

— Delimiter of the integer and fractional parts.

— Fractional part, consisting of two digits by default. If necessary, the number of characters
after the delimiter can be increased or decreased (see Section 4.4.2.5).

— Powers of 10 expressed as E<index of power sign><index of power>.

Al v % 86052

A
1 8,70E+04

Figure 137. Number formatted as Scientific
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4.4.3.1.9 Text

To make some numbers in MyOffice Text look like text, use Text format instead of Number
or General ones.

Text format is designed to display and save data in a cell as it is entered. For example, credit
card numbers or other numeric codes that contain 16 digits or more.

In Text format, the data in the cell is aligned to the left.
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4.4.3.2 Identify cell format

By default, all cells are assigned the General format when documents are created.

To modify the format, do as follows:

1. Select a cell/range or rows/columns you want to modify the format of.

2. On the Toolbar, select the Number section and click the field displaying the current

format. Select the desired format from the drop-down list (see Figure 138).

General v L v E3 =220

D f—
A v v v D " General B v
Alignment
MNurmber
Currency
Accounting
Date
Time
Date & Time
455.36,
Percentage
Fraction
Scientific

Text

Options...

Figure 138. Identifying cell format
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4.4.3.3 Number format settings

If necessary, you can set the way the data in the cells formatted as Number, Currency,
Accounting, Date and/or Time, and Percentage are displayed.

To customize the formats, follow these steps:

1. Select the cell/range or rows/columns in which you want to adjust the data display.

2. Open the number format settings window in one of the following ways:

— In the Format menu, select Number format (see Figure 139).

Format Table Data

Font 4
Alignment »
' Rotate Text L4

Number Format...
Print Area L4

Save Image...

Figure 139. Number Format Command menu option

— On the Toolbar, select the Number Format section and display the list of available
formats and select Advanced settings (see Figure 138).
— Open the context menu by right-clicking the selected cells or the titles/content of
the selected rows/columns. Run the Number Format context menu command.
3. In the Number format window, select the format you want to customize from the list
to the left (see Figure 140).
4. Specify the parameters for the format (see the description below).

5. Click OK.
To navigate through the Number format window, use Tab (to move from left to right) or

Shift+Tab (to move from right to left). If a list is selected, use the | and 1 buttons to navigate

through it.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 145



MyOffice

4.4.3.3.1 Number format settings

You can set the following parameters for the Number format (see Figure 140):

— Use thousands separator: If this box is checked, groups of digits in numbers are
separated by a comma. For example, the number 123456.00 is displayed as 123,456.00.

— Decimal places: With this option you can increase or decrease the number of decimal
places displayed after the dot (.) delimiter. You can also set the number of characters
displayed after thedot (.) delimiter wusing the buttons on the Toolbar
(see Section 4.4.2.5).

— Negative numbers: Select the way negative numbers formatted as Number are

displayed.

Mumber Format >

Sample

General

15.00

Mumber

Curren
i Use Thousands Separator

Accounting
Decimal Places

Date & Time

Ll

2 v
Percentage

Eraction Megative Numbers

Scientific S

Text

Figure 140. Number format window
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4.4.3.3.2 Currency format settings

You can set the following parameters for the Currency format (see Figure 141):

Symbol: Currency code or symbol used next to the numbers formatted as Currency.
Decimal places: With this option you can increase or decrease the number of decimal
places displayed after the dot (.) delimiter. You can also set the number of characters
displayed after thedot (.) delimiter wusing the buttons on the Toolbar
(see Section 4.4.2.5).

Negative numbers: Select the way negative numbers formatted as Currency are

displayed.
Mumber Format ot
Sample:
General
Mumber $1 >.00
Currency Symbol:
Accounting US Dollar ($) v
Date & Time
Decimal Places:
Percentage -
2 .
Fraction
Scientific Megative Mumbers:
-100 8
Text
-100
100
(100)
(100) >

Figure 141. Currency format settings
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4.4.3.3.3 Accounting format settings

You can set the following parameters for the Accounting format (see Figure 142):

— Symbol: Currency code or symbol used next to the numbers formatted as Accounting.

— Decimal places: With this option you can increase or decrease the number of decimal
places displayed after the dot (.) delimiter. You can also set the number of characters
displayed after thedot (.) delimiter wusing the buttons on the Toolbar
(see Section 4.4.2.5).

Mumber Format X

Sample:

General

$1,012.12

Murmber
Currency Symbol:
Accounting US Dollar ($) v
Date & Time
Percentage -

g ) -
Fraction

Scientific

Text

Figure 142. Accounting format settings
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4.4.3.3.4 Date, Time or Date and Time format settings

You can set the following parameters for the cells formatted as Date, Time, and

Date and Time (see Figure 143):

— To display the Date, select the format from the Date list. In the Time list, select None.

— To display the Time, in the Date list select None. In the Time list, select the format you

want to apply.

— Todisplay Date and Time, select the formats you want to use both in the Date and Time

lists.

Mumber Format ot
Sample:

General

Number January 14, 1900

Currency Date: Time:

Accounting None ~ N

Date & Time January 14, 1900 12:00 AM

Percentage Sunday, January 14, 1900 12:00:00 AM

Fraction 01/14/1900

Scientific 01/14,/00

Text 1/14/00
14-Jan
Jan-00 v

Figure 143. Date, Time or Date and Time format settings
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4.4.3.3.5 Percentage format settings

You can set the following parameters for the cells formatted as Percentage:

Decimal places: With this option (see Figure 144), you can increase or decrease the number

of decimal places displayed after the dot (.) delimiter.

You can also set the number of characters displayed after the dot (.) delimiter using

the buttons on the Toolbar (see Section 4.4.3.4).

Mumber Format

Sample:

General

1500.00%

Mumber

Currency

Decimal Places:

Eal

Accounting 2 )
Date & Time

Percentage

Fraction

Scientific

Text

Figure 144. Percentage format settings
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4.4.3.4 Increase and decrease decimals

For the numbers in the Number, Currency, Accounting, Percentage, and Scientific format
it is possible to increase or decrease the number of characters displayed after the delimiter.

When decreasing the decimals, the last visible decimal is automatically rounded up or down
depending on the nearest value. Standard number rounding rules are applied.

You can adjust the number of decimals displayed after the dot (.) delimiter using
the following tools:

— Number format settings window (not available for the Scientific format) (see 4.4.3.3).

— Toolbar buttons.

To increase or decrease the number of characters after the delimiter using the Toolbar,

follow the steps below:
1. Select a cell or a cell range containing the numbers you want to modify.

2. To increase the number of characters after the delimiter, on the Toolbar, select
. . oo . .
the Number Format section and click = Increase Decimals (see Figure 145).

. . o Do .
To decrease the number of characters after the delimiter click = Decrease Decimals.

Percentage v O v

$ %% 0o .OC;J BH v

Mumber Format Cells

Figure 145. Increase Decimals and Decrease Decimals buttons
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4.4.4 Check data

When creating documents such as fill-in forms, it is important to make the document easy to
work with, ensure a consistent format and eliminate errors when entering information. For this
purpose, MyOffice Spreadsheet application can be configured to validate the input data for selected

cells. In such cells, the user can select a valid value from a drop-down list or enter a value directly

into the cell.

4.4.4.1 Add data validation

Before creating the validation, you can create a list of valid values in advance, or you can
enter these values in the Value Source field (see below) while creating the validation.

To create a drop-down list with valid values, follow these steps:

1. Select the cell or range of cells.

2. Open the Data Validation dialog box in one of the following ways:

o0 B &

Data Tools View Share

Define Name...
Manage Protection

Refresh Pivot Table
Pivot Table Settings

Delete Pivot Table
Smart Table Settings

Group Rows
Group Columns

Clear Grouping

Autosum
Remove Duplicates...
Calculation Mode

Refrash Data

Data Validation
See All Validations

In the Data menu, select Data Validation (see Figure 146).

Subscription

Alt+=

4

Ctrl+Shift+F5

Figure 146. Data Validation command menu option
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)
— On the Toolbar, in the Data section, click == Data validation button

(see Figure 147).

-

2 v 3

Figure 147. Data Validation button on the Toolbar

— On the Sidebar, click E§ All Validations and in the pane that appears, click
Add Validation (see Figure 148).

- All validations Q

Add Validation ch

All validations v

Cw
Cx

Data Validation

Set data validation settings to limit the values that
can be entered in a cell.

Figure 148. All Validations pane

3. On the Options tab, in the Type of Data drop-down list, select List (see Figure 149).
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Data Validation *

Parameters Input Message Error Message

'Sheet1'1A9:C10

List v Ignore blank cells

Show value list
Any value

Date

v List separated by semicolo

ot v dtel st not be used in this case

Clear All OK Cancel

Figure 149. Selection of a drop-down list

4. If you want the cell to be required to be filled in on entry, uncheck the Ignore blank

cells box. If the cell is not filled in, an error will be displayed.

5. If you do not want to use the drop-down list, uncheck the Show value list box. In this

case, the validation will be carried out after you enter a value directly into the cell, as

described in the Section 4.4.4.6.

6. Inthe Value Source field (see Figure 150), specify the values to create the list in one of

the following ways:

Enter the values directly into the field, separating them with a semicolon.
Specify the cell range manually.

Click Select Values, select the desired cells in the document, and click
Finish Selection.

Enter the name of the named range or a formula that results in a cell range.
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Data Validation =

Parameters Input Message Error Message

‘Sheet1'1A9:C10

List v Ignore blank cells

Show value list

Clear All OK Cancel

Figure 150. Selection of the value source

If you make an error when entering, follow the on-screen prompts. To clear all fields in
the window and return the window to its default view, click Clear All at the bottom of

the window (see Figure 150).

The range of the data source is to belong to a single column or row.

7. On the Input Message tab, you can enter the title and text of the tooltip with information
about the rules of working with the field (see Figure 151). If you uncheck the Show when
cell is selected box, the tooltip will not be displayed, but the title and text of the tooltip

will be retained.
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Data Validation X

Parameters Input Message Error Message

Show when cell is selected

Clear All QK Cancel

Figure 151. Input Message tab

8. Onthe Error Message tab (see Figure 151), you can configure the behavior when invalid
values are entered and the error text that explains to the user the cause of the error:

— The Message Effect section is used to set the behavior when an invalid value is

entered: Input prohibition option will not allow entering an invalid value into

the cell, Warning option will display an error message but will allow entering

a value.

— You can enter your own title and description of the error in the Title and Message

fields. If you leave the fields blank, the default text will be displayed.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 156



MyOffice

Data Validation X

Parameters Input Message Error Message

Show when invalid values are being entered
Message Effect:
© Input prohibition

Warning

Clear All OK Cancel

Figure 152. Error message tab

9. To complete adding the validation, click OK or press Enter. To cancel creating

the condition, click Cancel button or press Esc.

The values in the drop-down list are always up-to-date. For example, if there is a function
result in the source and the function's arguments change, the corresponding value in the list is
updated.

The drop-down list displays the values as they appear in the source. In a cell, the display of the
selected value is determined by the format of this cell (see Section 4.4.3). For example, if the drop-down
list contains dates, and the General or Text format is selected for the cell, then the selected date in the

cell will be converted according to the format: the date 02.02.2020 will be displayed as the value 43863.
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To validate data in Date format, a separate validation type is available. To create an input
date validation for a cell, follow these steps:
1. Select the cell or cell range for which the validation will be performed.
2. Open the Data Validation dialog box in one of the following ways:
— Inthe Data menu, select Data Validation (see Figure 146).

)
— On the Toolbar, in the Data section, click == Data validation button

(see Figure 147).

C
— On the Sidebar, click Cx All Validations and in the pane that appears, click
Add Validation (see Figure 148).

3. On the Options tab, in the Type of Data drop-down list, select Date (see Figure 153).

Data Validation X
Parameters Input Message Error Message
'Sheet1'1A9:C10
Type of Data:
{ Date v Ignore blank cells
Any value
v Date
List
Clear All OK Cancel

Figure 153. Selection of validation by date
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4. Check the Ignore blank cells box if you want the data validation cell to be left blank.

With this option checked, the following input situations are possible depending on the

selected Validation Criteria if the date fields refer to empty cells (see Table 5):

Table 5. Errors when ignoring empty cells is enabled

Criterion Start date End date Result
Between Blank Filled in Error if the value is greater than the end
date.
Filled in Blank Error if the value is less than the start
date.
Not Blank Filled in Error if the value is less than or equal
between to the end date.
Filled in Blank Error if the value is greater than or
equal to the start date.

With this checkbox cleared, the following input situations are possible if date fields refer to

empty cells (see Table 6).

Table 6. Errors when ignoring empty cells is disabled

Criterion

Start date

End date

Result

Between

Blank

Filled in

Error if the value is greater than the
end date.
The cell being edited may be blank.

Filled in

Blank

Error if the value is less than the
start date.
The cell being edited may be blank.

Blank

Blank

Error.
The cell being edited may be blank.

Not between

Blank

Filled in

Error if the value is less than the end
date.
The cell being edited may be blank.

Filled in

Blank

Error if the value is greater than the
start date.
The cell being edited may be blank.

Blank

Blank

No error.
The cell being edited may be blank.
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Criterion Start date End date Result
Error.
Equal to Blank The cell being edited may be blank.
Not equal No error.
to Blank The cell being edited may be blank.
Greater Blank No error.
than The cell being edited may be blank.
Error.
Less that Blank The cell being edited may be blank.
Greater No error.
than or Blank The cell being edited may be blank.
equal to
Less than Error.
Blank . .
or equal to The cell being edited may be blank.

5. Inthe Validation Criteria drop-down list, select a validation condition (see Table 7).

Table 7. Conditions for successful validation

Criterion Prerequisite for successful validation

Between The date shall be within the interval between the start date and the end date inclusive.
Not The date shall be beyond the interval between the start and end dates.

between

Equal to The date shall coincide with the value in the Date field.

Not equal to | The date shall not coincide with the value in the Date field.

Greater The date shall be later than the date specified in the Date field.
than

Less that The date shall be earlier than the date specified in the Date field.

Greater The date shall be later than or the same as the date specified in the Date field.
than or
equal to

Less than or | The date shall be earlier than or the same as the date specified in the Date field.
equal to
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6.

7.

In the Start Date and End Date or Date fields, enter:

— Date in any supported data display format.

— Reference a cell or range, or select cells using the Select Values button. The date

in a cell can be specified directly, using a function or a reference to another cell.
— Function (for example, =TODAY()+6).

On the Input Message tab, you can enter the title and text of the tooltip with information

about the rules of working with the field (see Figure 151). If you uncheck the Show when

cell is selected box, the tooltip will not be displayed, but the title and text of the tooltip

will be retained.

On the Error Message tab (see Figure 152), you can configure the behavior when invalid

values are entered and the error text that explains to the user the cause of the error:

— The Message Effect section is used to set the behavior when an invalid value is
entered: Input prohibition option will not allow entering an invalid value into the

cell, Warning option will display an error message but will allow entering a value.

— You can enter your own title and description of the error in the Title and Message

fields. If you leave the fields blank, the default text will be displayed.

To complete adding the validation, click OK or press Enter. To cancel creating the

condition, click Cancel button or press Esc.

When creating validation conditions, the following restrictions apply:

You cannot configure data validation for the header and total row of smart tables, pivot
table cells, and cells that already contain other validations.

Data validation can only be configured for visible cells.

MyOffice Spreadsheet also supports working with cells for which data validation is

configured in third-party editors.

Drop-down lists inserted as a control or ActiveX are not supported.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 161



MyOffice

4.4.4.2 Edit data validation

You can edit data validation using the Data Validation dialog box or All Validations pane.
To edit data validation using the Data Validation dialog box, follow these steps:
1. Select the cells that contain the validations.
2. Open the Data Validation dialog box in one of the following ways:
— Inthe Data menu, select Data Validation (see Figure 146).

)
— On the Toolbar, in the Data section, click = Data validation button

(see Figure 147).

C
— On the Sidebar, click =x All Validations and in the pane that appears, click
Add Validation (see Figure 148).

3. Change the validation parameters in the dialog box. If the Apply to all cells with the
same validation setting box is checked, the changes will be applied to all validations
with the same condition. If the box is unchecked, a validation with new conditions will
be created after editing.

4. Click OK.

To edit data validation using the All Validations pane, follow these steps:

1. On the Sidebar, click E§ All Validations.

2. In the opened list in the pane, find the validation. The cell with the selected validation
will be highlighted on the sheet.

3. Click ¢’ Edit in the line with the validation.

4. Change the validation settings in the dialog box and click OK.

4.4.4.3 Delete data validation

You can delete data validation in one of the following ways:

— Using the Data Validation dialog box.

— Using the All validations pane.

— Delete columns or rows with cells with validation (see Section 4.3.11).

— Delete the sheet containing the cells with validation (see Section 4.2.8).

— Apply autofill for cells without wvalidation to cells with wvalidation

(see Section 4.4.1.4).
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To delete data validation using the Data Validation dialog box, follow these steps:
1. Select the cell or range of cells containing the validation.
2. Open the Data Validation dialog box in one of the following ways:

— Inthe Data menu, select Data Validation (see Figure 146).

— On the Toolbar, in the Data section, click = Data validation button

(see Figure 147).

— On the Sidebar, click E§ All Validations and in the pane that appears, click
Add Validation (see Figure 148).

3. Click Clear All in the bottom of the dialog box. If you want to delete such validation
from all cells, check the Apply to all cells with the same validation settings box.

4. Click Save.

To delete data validation using the All Validations pane, follow these steps:

1. On the Sidebar, click E§ All Validations.

2. In the opened list in the pane, find the validation. The cell with the selected validation
will be highlighted on the sheet.

3. Click [ Delete in the line with the validation and confirm the deletion in the dialog box

that appears.

4.4.4.4 Actions with cells containing data validation

You can drag one or more cells with data validation to autofill cells (see Section 4.4.1.4) on
the left, right, bottom, or top.
You can cut, copy and paste cells with data validation
(see Section 4.12.2).
When you merge cells (see Section 4.3.4.1), the data validation condition is saved only from
the upper-left cell of the range.
When you split cells (see Section 4.3.4.2):
— The data validation condition is retained in the upper-left cell of the range if it was
defined for that cell before the cells were merged.
— The data validation condition is retained in each cell of the range if it has been defined
for the merged cell. If the merged cell contained a drop-down list and a value was

selected in it, it will only be retained in the upper-left cell of the range.
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If a column or row that contains cells with data validation is selected on the sheet, the cells

with data validation are copied to the new columns/rows when new columns or rows are pasted

(see Section 4.3.5).

4.4.4.5 Enter a date

If a cell is configured to validate the specified date, in such a cell, you can enter:

— Number. The application will automatically convert it to the appropriate date
(see Section 4.4.3.1.5). For example, the number 1 will be converted to the date
12/31/1899.

— The date in any supported data display format (see Section 4.4.3.3), including time
indication. For example, 07/12/2023 10:30 AM.

—  Cell reference (for example, =B1). The date in a cell can be specified directly, using a
function or a reference to another cell.

— Function (for example, =TODAY()+6). The function can be of any kind.

An error message (see Figure 155) is displayed if:
— You enter a date, a cell reference, or a function that does not comply with the validation.

— You enter text into the cell or Text format is selected for the cell (see Section 4.4.3.1.9).

To enter a date in a cell, follow the steps below:
1. Select the cell. A prompt for entering a date will be displayed above the cell, if it was
created in a third-party editor (see Figure 154).

A B C D

Full name
Birth date

Position Tooltip

Division Enter the date from 01/01/2024-02/29/2024
Department
Flight date

=~ | R W | =

Figure 154. Tooltip for entering a value

2. Enter the date in one of the ways described above.
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3. Press Enter or 0 button on the Formula bar. If the date is not entered as a reference or

function, you can also click any other cell in the sheet or any column/row header.

If the date satisfies the validation conditions, you will quit the cell editing mode. The Date
format is applied to a cell if another format was selected for the cell before entering the value (with

the exception of the Text format).

If the date does not meet the validation conditions, then (see Figure 155):
— The date is highlighted.
— The cell remains in editing mode.

— An error message is displayed.

A B C D E
1 Full name
2 Birth date
3 Position Tooltip
4 Division Enter the date from 01/01/2024-02/29/2024
5 Department
6 Flight date 03/01/2024
7
0 © Invalid Value b4
9 The entered value does not match the valid
; options defined for this cell
1

—a
pry

Figure 155. Error message

To close the error message and enter the correct date, do one of the following:
— Start entering the date. The error message will close automatically.
— Close the error message by clicking the < button at the top of the message or by pressing

Esc. Enter the date.
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4.4.4.6 Enter a value in a cell with a drop-down list

To enter a value in a cell with a drop-down list, follow these steps:
1. Select the cell. A prompt for entering a value will be displayed above the cell if it was

created in a third-party editor (see Figure 156).

A B C

Full name
Birth date
Position

Tooltip _—

Division

Select a city
Department

Office v
Work experience

W 00 =l | h (U |k W=

Figure 156. Tooltip for entering a value

2. Do one of the following:
— Expand the drop-down list (see Figure 157) and select the desired value. To work

with the drop-down list, you can use the mouse or keyboard keys (see Table 8).

A B C D

1 Full name
2 |Birth date
3 |Position Tooltip
4 [Division .

Select a city
5 |[Department
6 |Office v
7 |Work experience Moscow
8 .
9 Paris
10 Lyon
11 London
12 MNew York
13 _
14 Milan
15 Rome
16

Figure 157. Drop-down list
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— Enter the value manually. The entered value must match character by character with
the required value in the drop-down list. The case of characters is not taken into
account when entering a value. Press Enter or click the @ button on the Formula

bar or click any other cell in the sheet/header of any column/row.

If the value entered manually is incorrect, the drop-down list is automatically expanded.

The "Invalid value" error is displayed at the top of the list (see Figure 158).

A B C D E
1 |Full name
2 |Birth date
3 |Position Tooltip
4 [Division Selecta city
5 |Department .
6 |Office Madrid | | - ‘
7 |Work experience
8 O Invalid Value pd
9 The entered value does not match the
10 valid options defined for this cell
11 M
12 OSCOW
13 Paris
14 Lyon
15 London
16
17 MNew York
18 Milan
19 Rome
20 J

Figure 158. Error message

To edit the entered value, do one of the following:

— Select the correct value from the drop-down list.

— Start entering the correct value manually. The drop-down list will automatically close.

— Close the drop-down list by clicking the * button at the top of it or press Esc. Enter the

correct value manually.

If the field is intended only for entering the value manually, the error message is

displayed without a drop-down list.
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The Table 8 lists the keyboard shortcuts that are used when working with the drop-down list.

Table 8. Keyboard shortcuts

Action Windows macOS
keyboard shortcuts keyboard shortcuts

Open the list Alt+ | ~=QOption + |
Select a value |l and 1 land 1
Apply value Enter Enter
Select the first value of the list Home Fn+ «
Select the last value of the list End Fn+—
One screen down Page Down Fn+ |
One screen up Page Up Fn+1
Close the list Esc Esc

The commands One screen down and One screen up are used to quickly view long drop-

down lists. When running commands, the list scrolls to the next or previous items.
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4.4.5 Remove duplicates

If several users worked on one spreadsheet, or if it was created from several spreadsheets, it

is very likely to contain repetitive data. These data can be removed from the table automatically

using the Remove Duplicates command.

The search for duplicates in a spreadsheet or a specified range is carried out line by line.

An example is shown in the Figure 159: the rows that will be deleted if one column (left) or two

columns (right) are selected for the search are highlighted in red.

Day of the week

B

Employment

Working
Working
Working
Working
Working
MNon-working
Non-working
MNon-working
Working
MNon-working
Working
Working
Working
Non-working

Figure 159. Example of selecting rows to delete

14
15

A

Day of the week

Monday
Tuesday
Wednesday
Thursday
Friday
Saturday
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday
Sunday

B

Employment

Working
Working
Working
Working
Working
Non-working
Non-working
Non-working
Working
Non-working
Working
Working
Working
Non-working

When removing duplicates, only the first variant of the found matches is saved, the rest are

A

1

2 |Monday

3 | Tuesday

4  |Wednesday
5 |Thursday

6 |Friday

7 |Saturday

8 |Sunday

8 Monday

10 Tuesday

11 Wednesday
12 | Thursday
13 | Friday
14  Saturday
15 | Sunday

deleted.

Searching for and deleting duplicates is not carried out if:

— The selected range contains:

— An array formula.

—  Cells of the pivot table (see Section 4.7).

— A smart table or a part of it. If the range contains only smart table cells, duplicates

are searched and replaced.

— Grouped columns or rows (see Section 4.3.10): to find duplicates, you need to clear

the grouping.

— Merged cells (see Section 4.3.4): to find duplicates, each cell in the range needs to

occupy the same number of rows and columns.
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— There is a “break” between the selected cells/rows/columns/ranges. For example,
columns A and C are selected, but column B is not selected.

— The document sheet is protected (see Section 4.14.1).

If the selected range contains hidden (see Section 4.3.7.1) or filtered (see Section 4.4.2) rows
or columns, the values in them are ignored when removing duplicates. After removing duplicates,
hidden rows and columns remain hidden. In the cells of hidden rows, the values may change because
the cell data is shifted upward after the duplicates are removed.

If the selected range contains cells with data validation conditions (see Section 4.4.4) and
the values in those cells are duplicates, not only the values but also the data validation conditions
are deleted.

To remove duplicates, follow the steps below:

1. Select a range to search for and remove duplicates.

If one cell is selected, but adjacent cells contain data that meet the duplicate
search and removal conditions (see restrictions above), the application

automatically expands the range to include the adjacent cells.

2. Open the Remove Duplicates window using one of the following methods:

— In the Command menu, select Data > Remove Duplicates (see Figure 160).

Data Tools WView Share Subscription

Define Name...
Manage Protection »

Refresh Pivot Table
Pivot Table Settings
Delete Pivot Table

Smart Table Settings

Group Rows

Group Columns

0 Bo &

Clear Grouping

Autosum Alt+=

™

Remove Duplicates...

Figure 160. Remove Duplicates Command menu option
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— On the Toolbar, in the Data section, click Remove Duplicates button

(see Figure 161).

L A
Vv R O -
° o~ 5 [ (@)~

Data Insert ~

Figure 161. Remove Duplicates button

3. In the Remove Duplicates window (see Figure 162), check the With header row box,
if the selected range contains a row with column names. This line will be excluded from

the selected range.

Remove Duplicates X
Range:
With header row

Expand automatically

Columns:
Select all
Column A
Column B

Column C

Figure 162. Remove Duplicates window

4. Check the Expand automatically box if you want to include data adjacent to the selected
range in the search range that meets the duplicate search and removal conditions (see

the restrictions above).
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5. In the Columns area, if necessary, uncheck the columns that you want to exclude from
the selected range.
6. Click OK.
When duplicates are successfully deleted, a pop-up message will be displayed: “N duplicate
values found and removed. M unique values remain.”
If there are no duplicates in the selected range, a pop-up message “No duplicates found” will

be displayed.
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4.4.6 Links

You can add a link to a web page, an email address, a sheet of the current document, or

another file to your document.

4.4.6.1 Insert a link to a web page or email address

MyOffice Spreadsheet recognizes and makes active links that start with www, http, https,

ftp, and email addresses.
Examples of the links:
— www.website.ru
— https://website.com
— http://website.ru
—  ftp://192.100.0.0
— mailto:user@domain.ru

— user.name@domain.com

A link such as mailto:user@domain.ru may also contain a subject line, the text of the email,
and email addresses for sending copy and blind copy. For example:
mailto:user@domain.ru?subject=This % 20is % 20the % 20subject&cc=user2@domain.ru&bod
y=This%20is % 20the%20body.

To avoid errors when you click links, it is recommended to specify the protocol in

the URL. For example, http://website.ru.

The link can be displayed in the document as follows:

— URL: For example, http://www.website.ru.

— Text: For example, link.

To add a link to your document as a URL, follow these steps:
1. Copy the link from the source.
2. Switch to the edit mode of the cell where you want to insert the link.

3. Insert the link and press Space or Enter.
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To add a text link to a document, follow these steps:

1. Copy the link from the source.

2. Specify the place to insert the link in one of the following ways:

To link the entire text

in a cell, select this cell.

To format a single word in the cell text as a link, place the cursor in the word or select

the entire word.

To format a part of the text in a cell as a link, select the entire text part.

To insert a word or text with a link to an empty cell, select the cell or place the cursor

in it.

3. Insert the link in one of the following ways:

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

In the Command menu, select Insert > Link (see Figure 163).

Insert Format Table Data Tools

@ H®

Y 0 =
B » &8 &

©Omn URPS

Image...
Text Box

Shape

Chart
Pivot Table...
Function... Shift+F3

Special Characters...

Link... Ctrl+K
MNote
Sheet

Current Date

Current Time

Figure 163. Insert menu

On the Toolbar, in the Insert section, click --= (see Figure 164). In the insert pane that

appears, click ¢7/ Link.

Right-click to open the context menu and run the Insert Link command.

Press Ctrl+K / $ Cmd+K.
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o~ B3 B4 (@)~ =

2 v e}

Data @ Image... ~
Text Box

M N (Y Shape > A Q
fx

|]|]|] Chart 5
Pivot Table... E
j& Function... E;
Special Characters... 3
@ Link..

Figure 164. Insert pane

4. In the Insert Link window, on the Web Page or File tab (see Figure 165):
— If the URL field is not filled in, insert a link into it. By default, the link copied from

the source during the first step is automatically inserted in the URL field.

Insert Link X

Web Page or File Place in This Document

Text:

C:/Users/user/Downloads/New Document.doc

Address:

C:/Users/user/Downloads/New Document.doox X Choose File...

Recent Files:
Orders xlsx ~
New Spreadsheet.xlsx

New Spreadsheet.xlsb

New Document.docx

&)
@ New Presentation 1.xodp
v |
v ]

New Document.doc

Figure 165. Insert Link window
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— Ifthe Text field is not filled in, enter the text that will be displayed instead of the link.
By default, text from the selected cell or the text selected in the cell or the word on

which the cursor is placed is automatically inserted into the Text field.

— Click OK.

When you save an .ods document in .xlsx format in a cell that contains multiple links at

the same time, only the first link remains functional.

4.4.6.2 Insert a link to a place in the document

To help you navigate through particularly long documents, you can also create links to a
specific place in the document, for example, to a cell, a range of cells, or a named range.

A link to a place in a document may contain the following elements:

— Sheet name. For example, Sheet 2.

— Name of the sheet with the cell or range address. For example, 'Sheet 2''A3:A6.

— Name of the named range. For example, Range 1.

— Any other text. For example, see here.

To create a link to a place in the document, follow the steps below:
1. Specify the place to insert the link in one of the following ways:
— To create a link with the sheet name and cell address / range, select an empty cell or,

if the cell is not empty, place the cursor in the desired cell position.

— To add a word or text with a link to an empty cell, select the cell or place the cursor
in it.

— To format all text contained in a cell as a link, select the cell.

— To format a single word in the cell text as a link, place the cursor in the word or select

the entire word.
— To format a part of the text in a cell as a link, select the entire text part.

2. Insert the link in one of the following ways:

— In the Command menu, select Insert > Link (see Figure 163).

— On the Toolbar, in the Insert section, click “=*. In the insertion pane that appears,

click the ¢’ Link button (see Figure 164).

— Right-click to open the context menu and execute the Insert Link command.
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—  Press Ctrl+K / ¢ Cmd + K.

3. Inthe Insert Link window, select the Place in This Document tab (see Figure 166).

Insert Link b4

Web Page or File Place in This Document

Text:

Cell or Range:

O sheet Named range
Sheet1
Pivot table 2
data

Pivot table 1

Cancel

Figure 166. Insert Link window. Place in This Document tab

4. To insert a link to a sheet, make sure the Sheet radio button is selected (see ) and choose
the desired sheet from the list.

5. To insert a link to a cell or range in the Cell or Range field, enter the cell/range address
manually. Or click to select the required cells in the document itself, then click
again to insert the address into the field.

6. To insert a named range reference, click the Named range radio button and select the

desired range from the list below (see Figure 167).
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Insert Link X

Web Page or File Place in This Document

Text:

Cell or Range:

Sheet © Named range

oK Cancel

Figure 167. Insert a link to Named range

7. Inthe Text field:
— If the field displays the sheet name and the selected range and you want to create a

link with the sheet name, leave the content of the field unchanged.

— If the field displays the sheet name and the selected range but you want to specify

the link text, enter the required text manually.

— If the field is filled with text from the selected cell or text selected in the cell, or a
word on which the cursor is positioned, edit this text if necessary or leave it

unchanged.

8. Click OK.

When you save an .ods document in .xIsx format in a cell that contains multiple links at

2 the same time, only the first link remains functional.
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4.4.6.3 Insert a link to a file

You can insert a link to a file that is located on the current computer or in a network folder
into your document. The link can reference a file of any format.

The link can be displayed in the document as follows:

— Paths to the file. For example, C:\Users\User\Documents\File.xIsx (Windows) or

/Users/User/Downloads/File.xIsx (macQOS).

— Text: For example, link to the file. You can specify the text of the link either in the cell

or in the link insertion window.

To add a link to a file in your document, follow these steps:
1. Specify the place to insert the link in one of the following ways:
— To link the entire text in a cell, select this cell.
— To format a single word in the cell text as a link, place the cursor in the word or select
the entire word.
— To format a part of the text in a cell as a link, select the entire text part.
— To insert a word or text with a link to an empty cell, select the cell or place the cursor
in it.
2. Insert the link in one of the following ways:

— In the Command menu, select Insert > Link (see Figure 168).

Insert Format Table Data Tools
B4 Image...

Text Box
5 Shape »

Chart 4
Pivot Table...
Function... Shift+F3

® » A S

Special Characters...

Link... Ctrl+K
MNote
Sheet

Current Date

OB OO0 S

Current Time

Figure 168. Insert menu
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— On the Toolbar, in the Insert section, click === (see Figure 169). In the insert pane that
appears, click the 7’ Link button.

I
? E.E'v @vm [T
v B8 &4 (@)~ &=,

Seq =

Data 4 Image.. A
Text Box

M N &)  shape |~ Q

fx

olp  chart >
Pivot Table... &
j& Function... E;(’
Special Characters... >
¢  Link..

Figure 169. Insert pane

— Right-click to open the context menu and run the Insert Link command.
— Press Ctrl+K / 8Cmd+K.
3. Inthe Insert Link window, on the Web Page or File tab, (see Figure 170) select the file
to which you want to insert a link using one of the following methods:
— Select a file from the Recent Files list. This list displays the 50 most recent files that
were opened in the MyOffice Spreadsheet, MyOffice Text, and MyOffice
Presentation applications.

— Select the file using the File manager. To do this, click Choose File.
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F 1%
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Insert Link

Web Page or File Place in This Document

Text:

Address:

C:/Users/user/Downloads/Mew Document.docx
Recent Files:

E  Ordersxlsx

ﬂ MNew Spreadsheet.x|sx

&) New Spreadsheetxlsh

Mew Presentation 1.xodp

New Document.docx

[ New Document.doc

X Choose File...

Cancel

L Y

Figure 170. Insert Link window

the same time, only the first link remains functional.

4.4.6.4 Quick link insertion

You can quickly add a link to a web page, email address, or file to the typed text.

the word on which the cursor is placed is automatically inserted into the Text field.

Click OK.

If you want the link to be displayed as text and the Text field is not filled in, enter

the required text. By default, text from the selected cell or the text selected in the cell or

When you save an .ods document in .xIsx format in a cell that contains multiple links at

For quick insertion, the following types of links to local and network files are supported:

file:///C:\Users\User\Documents\File.xlsx
smb://192.168.1.1/Files/File.xIsx
ftp://Guest@127.0.0.1/share/FTP/File.xlsx
sftp://Guest@127.0.0.1/share/FTP/File.xlsx
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The supported types of web page links and email addresses are described in the section
above.

To quickly add a link to typed text, follow these steps:

1. Copy the link.

2. Specify the place to insert the link in one of the following ways:

— To link the entire text in a cell, select this cell.

— To format a single word in the cell text as a link, place the cursor in the word or select

the entire word.
— To format a part of the text in a cell as a link, select the entire text part.

3. Press Ctrl+Shift+V / 3¢ Cmd+1{ Shift+V.

4.4.6.5 Go to the link

To follow the link, click it while holding down the Ctrl / 8Cmd pressed.

Web links are opened in the default browser used in the OS.

Files are opened in MyOffice Spreadsheet, MyOffice Text and MyOffice Presentation
applications. If the file format is not supported, the file is opened in the application that is used by
default in the OS to work with files of the corresponding format.

When you click the link to an email address, it opens the default email client in your OS.
This software automatically creates a new email, into which the data specified in the link is copied.

When you click a link to a sheet, the corresponding sheet of the current document is opened.

4.4.6.6 Copy a link

To copy a link, right-click it and in the Context menu, select Copy Link URL.

4.4.6.7 Edit a link

To edit a link, follow the steps below:
1. Specify a link to edit:
— If a cell contains only a link, select that cell or place the cursor on the link, or select
part of the link/the entire link.
— If the cell contains more than just a link, place the cursor on the link or select part of
the link/the entire link.
2. Open the link editing window in one of the following ways:

— In the Command menu, select Insert > Link (see Figure 168).
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— On the Toolbar, in the Insert section, click === (see Figure 169). In the insert pane that
appears, click the 7’ Link button.
— Right-click to open the context menu and run the Edit Link command.
— Press Ctrl+K / #Cmd+K.
3. Inthe Edit Link (see Figure 171) window, make the desired changes.
4. Click OK.

Edit Link pat
Web Page or File Place in This Document

Text:

C:/Users/user/Downloads/New Spreadsheet.xlsx X

Address:

C:/Users/user/Downloads/New Spreadsheet.xlsx X Choose File...

Recent Files:
[ % | CeopaHan Tabamuaz(en). xlsx
Orders xlsx

New Spreadsheet.xlsx

B B B

New Spreadsheet.xIsb

New Presentation 1.xodp

New Document.docx

Delete Link Cancel

Figure 171. Edit Link window

4.4.6.8 Delete a link

The link can be deleted using the edit window or the context menu. The link is deleted
without the text that contains it.
To delete a link using the edit window, follow these steps:
1. Specify the link to delete:
— If a cell contains only a link, select that cell or place the cursor on the link, or select
part of the link/the entire link.
— If the cell contains more than just a link, place the cursor on the link or select part of

the link/the entire link.
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2. Open the link editing window in one of the following ways:
— In the Command menu, select Insert > Link (see Figure 168).
— On the Toolbar, in the Insert section, click === (see Figure 169). In the insert pane that
appears, click ¢/ Link.
— Right-click to open the context menu and run the Edit Link command.
— Press Ctrl+K / % Cmd+K.
3. Inthe Edit Link window (see Figure 171), click the Remove Link button.

To delete a link using the context menu, follow these steps:
1. Specify the link to delete as described above.

2. Right-click to open the context menu and run the Delete Link command.

To delete multiple links at the same time, follow these steps:
1. Select the cells that contain the link data.

2. Right-click to open the context menu and run the Delete Links command.

If you want to delete the link along with the text that contains it, follow these steps:
1. Specify the link to delete:
— If a cell contains only a link, select that cell or switch to cell editing mode and select
the entire link.
— If the cell contains more than just a link, switch to the cell editing mode and select
the entire link.

2. Press Delete or Backspace.
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4.4.6.9 Keyboard shortcuts for moving between window elements

The Table 9 below shows the keyboard shortcuts you can use to quickly move between

elements in the Insert/Edit Link window.

Table 9. Keyboard shortcuts

Action Windows macOS
keyboard shortcuts keyboard shortcuts

Open the window Ctrl+K % Cmd+K
Go to the next window element Tab Tab
Go to the previous window element Shift+Tab {r Shift+Tab
Open the selected tab Space Space
Click Select File or OK Space Space
Click OK regardless of which window element is _
currently selected Enter ~ Enter
Go to the next/previous file in the Recent Files list land 7 land 1
Go to the first file in the Recent files list Home Fn+ «
Go to the last file in the Recent files list End Fn+—
Select a file in the Recent files list Space Space
Close the window Esc Esc
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4.4.7 Notes

You can add notes to the cells of a spreadsheet. When you edit a document in collaboration
(see Section 4.12.2), you can share comments with colleagues using notes without affecting
the content of the document. Cells with notes are marked with a triangle in the top right corner of

a cell (see Figure 172).

Figure 172. Cell with a note
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4.4.7.1 Add a note

Each note is attached to one cell. The name of the user who created the note is automatically
added to the note.

To create a note, follow the steps below:

1. Add a note using one of the following methods:

— Left-click a cell to select it. In the Insert menu, select Note (see Figure 173).

Insert Format Table Data Tools
] Image..
Text Box
) Shape »
Chart »

Pivot Table...
Function... Shift+F3

B % 8 =

Special Characters...

Link... Ctrl+K
Mote
Sheet

Current Date

@ Mm O %

Current Time

Figure 173. Insert menu
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— Select the cell. On the Toolbar, select the Insert section and click **. In the opened

insert pane, select [5 Note (see Figure 174).

280 . BB

Data Image...

Text Box

& O B

Shape

Chart

=
[—]
=

Pivot Table...

Function...

® > &5

Special Characters...

Link...

&
[T:B] Note

Figure 174. Insert pane

Cv
CX

— Right-click a cell to select it and select Add Note in the context menu.
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2. In the note window (see Figure 175):
— Edit and format the username as needed.

— Enter the note text.

' John Smith:

W o~ h | W o=

Figure 175. Notes window

3. Press Esc or click outside the cell to finish and close the note.

4.4.7.2 Edit or delete a note

You can edit and delete both your own notes and those of other users in the document.
To edit a note, use the following guidelines:
1. Click the cell to open the note.
2. Activate the edit mode in one of the following ways:
— Right-click a cell and select Edit Note. The cursor will be set on the first paragraph
of the note.
— Place the cursor in the desired position manually.
3. [Edit the text of the note and, if necessary, the username.
4. Press Esc or click outside the cell to finish and close the Note.
To delete a note, right-click the cell containing the note and select Delete Note in

the command menu.
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4.4.8 Special characters

Special characters are characters that are not present on the keyboard. This includes
mathematical operators, dingbats, arrows, currency signs. Such symbols can be inserted using

the special characters quick insert pane or the Special Characters window.

4.4.8.1 Special characters quick insert pane

To open the Special Characters quick insert pane, do one of the following:

— On  theToolbar, in thelInsert section (seeFigure 176), click

Special Characters.

= . !
E‘bhutomatlc A4 r_s Refresh Data U ii
di- B B @ -
|_=' Whaole Document L\\S :
Insert © ® P % p v §
v % — @wm Y ° A
p Q R S T
# = + - ® = =
Mon-Breaking Space Ctrl+Shift+5pace
Man-Breaking Hyphen Ctrl=5hift+(-)
En Dash Ctrl+MNumi-)
Mare Characters...

Figure 176. Special Characters button

— On the Toolbar, in the Insert section, click =:=. In the insert pane that appears, hover

the mouse cursor over the [ Special Characters button (see Figure 177).
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Data @ Image... ~
E Text Box
K L M N &  Shape > | Q
olp chart >
Pivot Table... &
:’LX Function... E;
- Q Special Characters... >
© ® P % p V8 P
2 Link...
Vo % — mw Y ° A ¢ n
[% Mote
# &= + - X = =
D Sheet
Non-Breaking Space Ctrl+Shift+Space Current Date
Non-Breaking Hyphen Ctrl+Shift+(-) @ Current Time
En Dash Ctrl+MNum(-)
More Characters...

Figure 177. Insert pane

To insert a special character, do one of the following:

— Select a character from a set of preset characters. As you work with the application,
the preset characters change to characters added to the document by the user using
the Special Characters window (see Section 4.5.2). When the mouse cursor hovers

over a character, the name of the font selected for it is displayed.

When inserting, the font of the document text is applied to the character.
However, if the font of the text does not support this character, then the font

selected by the user is used.

— Select Non-Breaking Space, Non-Breaking Hyphen, or En Dash if you want to

insert the appropriate character.
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4.4.8.2 Special characters window

To open the Special Characters window, do one of the following:

1. Inthe command menu, select Insert > Special Characters (see Figure 178).

Insert Format Table Data Tools

E4 Image...
Text Box
) Shape b

oo Chart »
1 Pivot Table...

#% Function... Shift+F3
Special Characters...

Figure 178. Special characters menu

— On the Toolbar, in the Insert section, click Special Characters button

(see Figure 179). In the quick insert special characters pane, select More Characters.

R v © —

- - B B @ - .
© ® P % pu Vv 8§
Y. % — mw Y ° A

o}

# = + + x < >
Non-Breaking Space Ctrl+Shift+5pace
Non-Breaking Hyphen Ctrl+Shift+(-)
En Dash Ctrl+MNumi(-)

More Characters...

Figure 179. More Characters option
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— On the Toolbar, in the Insert section, click -=- (see Figure 180). In the pane that appears,

click the ] Special Characters button.

.

? Eg Y LEQ‘ v T
> v 3 = ol A @)y b,
h “c

Data @ Image... ~
[T1  TextBox

M N (9 Shape N ~ Q

fx

ilo chart N
Pivot Table... &
j[x Function... E;
Special Characters... >

Figure 180. Special Characters button

— On the Toolbar, in the Insert section, click === (see Figure 181). In the pane that appears,
hover the mouse over the arrow to theright of thel*Special Characters button.

In the quick insert special characters pane, select More Characters.

I:::jl:l @" EV ? Egv @v
Ev egv Zv@ E

oo~ s B4 (@~ &=,

Data @ Image... ~
Text Box
K L M N & shape y | Al Q
ol chart >
Pivot Table... &
. Cv
j[X Function... =
Q Special Characters... >
© ® P % p v 8 P
2 Link
Vo % — mw Y ° A | C MR
[ Note
S = + - x < 2
D Sheet
Non-Breaking Space Ctrl+Shift+Space Current Date
Non-Breaking Hyphen Ctrl+Shift+(-) ® Current Time
En Dash Ctrl+Numi(-)
More Characters...

Figure 181. More Characters option
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The Special Characters window (see Figure 182) contains the following tools:

Special Characters
XO Thames v Number forms v VULGAR FRACTION ONE
. THIRD
1//5 2)/3 l/é % % % Unicode: U+2153
Jda A [ X - V o | = =z
= 1/3
- 9
o XO Thames
F € 2 T b m P Ko Them
L % g Y
r
v 1/ V£
3 3 3
vV & O % >
Iz Vs 1
Close window after inserting a character Cancel

Figure 182. Special Characters window

— Drop-down list for selecting the font of the special character.

— Drop-down list for selecting the group and category of the character. If the font does not

support the characters of a category group or category, it is not displayed in the list.

Categories are separated from each other by a line.
— The name of the highlighted character.
— The code of the selected character in the Unicode system.
— The typeface of the selected character.

The font of the selected character.

—  Other typefaces of the selected character.
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To insert a special character using the Special Characters window, follow these steps:
1. Select the font of the special character. You can select it in the same way as you would
select a font in the main application window (see Section 4.11.1).
2. Select a character category. You can select it in the same way as selecting a special
character font.
3. Place the cursor in the position of the document where you want to insert the character.
4. Insert the character in one of the following ways:
— Select the character by double-clicking.
— Select the character with one click and click Insert.

— Select the character with one click and press Enter or Space.

If you want the window to close automatically, check the Close window after inserting

a character box.
To close the Special Characters window manually, click Cancel or the x button in
the window header.
To insert a character from the Special Characters window, follow these steps:
1. Place the cursor in the place of the document where you want to insert the character.
2. Insert the character in one of the following ways:
— Select the character by double-clicking.
— Select the character with one click and click Insert.

— Select a character with one mouse click and press Enter or Space.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 195



MyOffice

4.4.9 Current date or time

You can quickly insert the current date or time anywhere in a document.
To insert the current date, follow these steps:

1. Select the place where you want to insert the date.

2. Run the insert command in one of the following ways:

— In the Insert menu, select Current Date (see Figure 183).

Insert  Format Table Data Tools
[ Image...
Text Box
) Shape r
Chart »

Pivot Table...
Function... Shift+F3

B » 8 &

Special Characters...

Link... Ctrl+K
Maote
Sheet

Current Date

0B OF %

Current Time

Figure 183. Insert menu

— On the Toolbar, select the Insert section and click - (see Figure 184).

In the displayed insert pane, click f5] Current Date.
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& Link..
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Figure 184. Insert pane

To insert the current time in the document:
1. Place the cursor where you want to insert the current time.
2. Run the insert command in one of the following ways:
— In the Insert menu, select Current Time (see Figure 183).
— On the Toolbar, select the Insert section and click - (see Figure 184).

In the displayed insert pane, click (© Current Time.

The data inserted is static, that is will not be updated when the actual date and time change.
4.4.10 Check grammar and spelling

MyOffice Spreadsheet can automatically check texts in English and in Russian for grammar

and spelling mistakes.
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4.4.10.1 Check spelling

To enable and disable and enable Check Spelling, in the Tools menu, select
Spelling and Grammar and then Check Spelling (see Figure 185).
Enabling or disabling Check Spelling is only applied to the current document and does not

affect other opened documents.

Tools View Share Subscription Help

Spelling and Grammar * + Check Spelling

Custom Dictionary Check Grammar

BB =e- v &
Change Language-... -
Macros 4

Figure 185. Tools menu

Check spelling basics:

— The spell-checking dictionary is automatically selected based on the language of the first
character in the cell.

— Words missing in the selected dictionary or misspelled words are underlined with a red
wavy line.

— Changing the contents of a document restarts spell-checking.
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4.4.10.1.1 Correct errors

If an error is found in a word, correct it. To do this, follow the steps below:

1. Place the mouse cursor on the word or select the word that is underlined with a red wavy
line (see Figure 186).

2. Right-click the word directly in the cell or in the formula line.

3. From the context menu, choose the correct spelling of the word.

If there are no correct spellings for the selected word, the context menu displays

No suggestions.

fx errorr
A B C D
1 |EITQIL |
3 error
3 Errors
4 Errorr
5 borrower
]
7 Add to Dictionary
g lgnore
9
0 [y Paste Ctrl+V
1 Paste Value Ctrl+Alt+Y
12 Paste Unformatted Text
E 7 Insert Link...
14

Figure 186. Correct an error
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4.4.10.1.2 Turn off the underline for spelling errors

A word recognized as misspelled by the application is underlined with a red wavy line.
To turn this option off for a particular word, add it in the Custom dictionary (see Section 4.4.5.2)
or in the ignore list.

To add a word in the ignore list, follow the steps below:

1. Move the cursor over the misspelled word underlined with a red wavy line or select it.

2. Right-click the word directly in the cell or on the Formula bar.

3. Inthe context menu, select Ignore (see Figure 186).

Once finished, the red wavy underline disappears. If a word appears several times in
the document, the changes are applied to all repetitions taking into account the case. Such changes
are saved within one session. When the document is opened again, the Check Spelling is launched
again.

If you have added a word into the ignore list by mistake, you can get back to the previous
step by selecting the Check Spelling option. Follow these steps:

1. Move the cursor over the word or select the word.

2. Right-click the word directly in the cell or on the Formula bar.

3. In the context menu, select Check Spelling.
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4.4.10.2 Custom dictionary

To exclude words such as proper names, abbreviations, or technical terms in a text from
being considered misspelled, you can add them to the Custom Dictionary.

Before you start, make sure that the Check Spelling is on (see Section 4.4.10.1).

4.4.10.2.1 Adding words to the dictionary

The Custom Dictionary allows you to add only individual words. You cannot add word

combinations to the Custom Dictionary.

Adding words is case-sensitive. If a word can start with a capital letter and with a lowercase

letter, add the two spellings into the dictionary.

To add a word to the Custom Dictionary directly from the text, follow the steps below:

1. Move the cursor over the word that you want to add to the dictionary or select the word.
2. Right-click the word directly in the cell or on the Formula bar.

3. In the context menu, select Add to Dictionary (see Figure 186).

To add a new word directly to the Custom Dictionary, follow the steps below:

1. In the Tools menu, select Custom Dictionary (see Figure 187).

Tools View Share Subscript

Spelling and Grammar
Custom Dictionary

Change Language...
Macros >

Figure 187. Tools menu

2. In the Custom Dictionary dialog menu (see Figure 188), enter the word you want
to add.
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[®] Custom Dictionary *

‘ MyOfﬁce| X

(Empty)

Figure 188. Custom Dictionary window

3. Click or press Enter.

4. Click Done to finish and close the window.
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4.4.10.2.2 Using third-party dictionaries

To extend the vocabulary available in MyOffice Spreadsheet, you can use third-party
dictionaries in .dic format. Simply follow these steps:
1. In the Custom Dictionary dialog box, click Import (see Figure 188).

2. In the opened file manager window, select a .dic file and click Open.

When finished, the contents of the dictionary will appear in your dictionary.
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4.4.10.2.3 Delete words from the dictionary

If necessary, you can remove words previously added in the Custom Dictionary.

To remove a word using the Custom Dictionary menu, follow the steps below:

1. In the Tools menu, select Custom Dictionary (see Figure 187).

2. Inthe Custom Dictionary dialog box (see Figure 189) place the cursor on the word you

want to remove from the dictionary and click Remove.

® | Custom Dictionary *

MyOffice Remove

Figure 189. Custom Dictionary window

3. Click Done to finish.

To remove a word without using the Custom Dictionary window, follow the steps below:
1. Place the cursor over the word you want to remove or select this word.
2. Right-click the word directly in the cell or on the Formula bar.

3. In the context menu, select Remove from Dictionary.
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4.4.10.3 Grammar checking

To enable or disable grammar checking, in the Tools menu, select Spelling and Grammar

and then Check grammar (see Figure 190).

Enabling or disabling grammar checking applies to the current document and does not affect

other opened documents.

Tools View Share Subscription Help

Spelling and Grammar ~ *

Custorn Dictionary
Change Language...

Macros »

Check Spelling

+ Check Grammar

B = o v °

Figure 190. Tools menu

Grammar checking basics:

— The grammar checking language is selected automatically depending on the first letter

of the cell.

— The grammar checking is launched when the Space bar is pressed, or the Enter key is

pressed, provided that the sentence is completed.

— A sentence with a grammar mistake is underlined with a blue wavy line both in the cell

and on the Formula bar.

— Formulas and values are not checked.
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4.4.11 Find and replace data

If the document is opened in the View mode, only data search (without replacement) is

available.

To open the pane to find and replace data in a document, do one of the following:

— In the Command menu, select Edit > Find (see Figure 191).

Edit Insert Format Table Data Tools Vi

) Undo Ctrl+Z

< Redo Ctrl+Y

3 Cut Ctrl+X

Copy Ctrl+C

[Ty Paste Ctrl+V
Paste Values and Format Ctri+Alt+V
Paste Values Only
Paste from Clipboard 4

£ Copy Formatting Ctrl+Shift+C
Paste Formatting Ctrl+Shift+V
Select All Ctrl+A
Find Ctrl+F

Figure 191. Find comment menu option

— On the Sidebar, click . Find and Replace (see Figure 192).

20 BB
Insert ~
o P Q R 2 Q
x
&
Cwv
Cx

Figure 192. Find and Replace button
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—  Press Ctrl+F or Ctrl1+H / #Cmd+F.

In the Find and Replace pane (see Figure 193), specify the parameters for searching and
replacing data:
1. Specify the data Search area:
— Current sheet: Perform a search on the currently open sheet.

— Al Sheets: Perform a search through all sheets of the document.

: , A -» Find and Replace Q
E
fx
s,
N
Cv
CX

Parameters

b Search does not include formulas

© Current sheet
All Sheets

Match whole words only
Match case when searching

Match case when replacing

Figure 193. Search parameters

2. If necessary, check the required Filters:

— Match whole words only: Find only whole words/values, not data that is part of
other words/values.

— Match case when searching: Perform the search taking into account uppercase and
lowercase letters in the text you are looking for.

— Match case when replacing: Perform the replacement taking into account the
uppercase and lowercase letters in the found text. Example: You need to replace the
word agreement with the word contract in the text of the document. In this case, the

word agreement can be written with both lowercase and uppercase letters
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(for example, at the beginning of a sentence). Check the box Match case when
replacing so that the word agreement with a lowercase letter is replaced by the word
contract with a lowercase letter, and the word Agreement with a capital letter is

replaced by the word Contract with a capital letter.

Case is taken into account only for the first character in the found word.

To find the data in the document, follow these steps:

1. Inthe Find field, enter the data to search for (see Figure 194).

2. Click the E button or press Enter.

=» Find and Replace

j card| X E

< 2 Replace Replace All

Figure 194. Data for search

The matches found will be highlighted in the document (see Figure 195).
Use the ¢ > buttons below the search and replace bars (see Figure 194) to navigate through
the cells with matches found. The selected match will be highlighted in the document with

a contrasting yellow color (see Figure 195).

Search parameters (see Figure 193) can be changed while you are working with matches.

The search results are updated automatically.
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Figure 195. Matches found

To replace matches found in the document, follow the steps below:

1. Inthe Replace with bar (see Figure 194), enter the data to replace or leave the field blank
if you want to delete the found match.

2. Replace the matches with one of the following methods:
— Click Replace to replace the highlighted match.

— Click Replace All to replace all matches found simultaneously.

You cannot replace a part of the found value or a part of the found result of a formula
A calculation. The value or the result of a formula calculation can only be replaced in its

entirety.

To close the Find and Replace pane, do one of the following:

— At the top of the pane, click —%.
— On the Sidebar, click G'\ Find and Replace.

—  Press Esc.
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4.4.12 Delete data

To delete one or more characters in a cell, use one of the following methods:

— Place the cursor after the characters you want to delete. If you are working in Windows,
delete characters by pressing Backspace as many times as needed, if you are working in
macOS, delete them by pressing Delete.

— Place the cursor before the characters you want to delete. If you are working in Windows,
delete characters by pressing Delete as many times as needed, if you are working in

macOS, delete them by successively using Fn+Delete shortcut.

To delete a word or its part in a cell, do one of the following:

— Place the cursor after a word or word part that you want to delete. When working in
Windows, press Ctrl+Backspace, when working in macOS, use #Cmd+Delete or
~~Option+Delete shortcut.

— Place the cursor before a word or word part that you want to delete. When working in
Windows, press Ctrl+Delete, when working in macOS, use $Cmd+Fn+Delete or

~~Option+Fn+Delete shortcut.

To delete some text in a cell, do the following:
1. Select the desired text.
1. When working in Windows, press Delete or Backspace, when working in macOS, press

Delete or use Fn+Delete shortcut.

To clear the content of the cell, do the following:
1. Select the cell or range to be cleared of data.
2. When working in Windows, press Delete or Backspace, when working in macOS, press

Delete.

In case filters are applied or columns or rows are manually hidden, only the contents of

visible cells are cleared.
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4.5 Formulas and functions

Formula: Any expression in a cell that starts with an equal sign (=).
Formulas can contain functions, values, cell names, and operators.
Function: A predefined formula in MyOffice Spreadsheet that needs arguments to calculate

correctly. For a complete list of functions, see Appendix 1. Functions and their description.

4.5.1 Formulas and functions basics

— Formulas always begin with an equal sign (=).

— The equal sign can be followed by functions, constants, cell references, operators, and
other elements.

— All opening and closing brackets must be in sync.

— The mandatory arguments of functions must be specified.

— The constants should not contain a dollar sign (8).

In Windows, if "." is selected in the Customize Format window, in Decimal symbol

field, use "," instead of ";" as the separator of values in functions in MyOffice Spreadsheet

application.

For CELL and INFO functions enter text parameters in English, enclosing them in double
quotation marks and using the semicolon "5 delimiter. For example,

=CELL("contents";A2), =INFO("'system").

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 211



MyOffice

4.5.2 Order of operations in a formula

If a formula contains several operations, MyOffice Spreadsheet will perform calculations

based on the following order of operations:

Operations enclosed in parentheses are performed first:

— The order of operations depends on their priority (see Table 10).

— Operations in the nested parentheses are performed first.

If a formula contains parentheses that are not essential in the calculation, they will be
deleted automatically. For example, the formula =SUM(1+(2¥5)+1) will be
automatically transformed into =SUM(1+2%5+1).

Operations outside the parentheses are performed according to their precedence.
Operations with the same precedence are performed from left to right, except for
the exponentiation ("), which is performed from right to left. Example: = 24”2 =2"16
= 65,536
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If you combine several operators in a single formula, MyOffice Spreadsheet performs

the operations in the order shown in Table 10.

Table 10. Operator precedence

Priority Operator Meaning
1 Range
2 Space
3 % Percentage
4 + Unary plus
- Unary minus
Unary space
5 A Exponentiation
6 * Multiplication
/ Division
7 + Addition
- Subtraction
8 & Concatenation
9 Comparison operators:
= Equal to
> Greater than
< Less than
>= Greater than or equal to
<= Less than or equal to
<> Not equal to

4.5.3 Referencing cells and cell ranges

Referencing is linking to cells or ranges for further use in calculations.

There are three types of references:

— Relative: This type of references changes when copying or auto-filling. By default, all

references in the editor are relative.

— Absolute: This type of reference does not change when copying or auto-filling.

Therefore, they should be used for formulas that have constant values, such as interest

rates.

— Mixed: This type of reference allows you to combine both absolute and relative

references. For example, the B$5, D$12 reference the row number remains the same, but

the column name may change.
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4.5.3.1 A1 cell reference style

The A1 reference style (see Table 11) is used in MyOffice Spreadsheet by default.

In the A1 reference style, the cell address consists of a column letter name and a numeric
row name. For example: Al, C12, G37, ND185 etc.

When creating a sheet, the workspace contains:

— 20 rows numbered from 1 to 20

— 10 columns named from A to J

When you expand the workspace, new columns continue single-letter naming followed by
two-letter naming: AA, AB, AC, then BA, BB, BC, etc.

If the two-letter combinations end, the columns will be given three-letter names.

When you add rows to a table, the new items continue to be numbered.

Table 11. Absolute and relative references in the Al reference style
Relative reference Al

Absolute reference $AS1 (the column and row are not changed during copying)

Mixed references $A1 (the column is not changed during copying)

AS1 (the row is not changed during copying)
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4.5.3.2 R1C1 cell reference style

To enable the R1C1 reference style, in the View command menu, select R1C1

(see Figure 196).

View Share  Sul

Zoom g
R1C1
Toolbar »

Figure 196. View menu
In the R1C1 style, both columns and rows are denoted by numbers (see Table 4).
The address of a cell is determined using the formula RnCm, where:

— R is arow character, and n is a row number.

— Cis a column character, and m is a column number.

For example, the name of D5 cell in the R1C1 style is R5C4.
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Table 12. Absolute and relative references in the R1C1 reference style

Absolute reference

R3C2 (an absolute reference to a cell at the intersection of row 3 and
column 2)

R3 (an absolute reference to row 3)

C2 (an absolute reference to column 2)

Relative reference

RC (a relative reference to the current cell)
R[-2] (a relative reference to the row located 2 rows above the current row)

C[3] (a relative reference to the column located 3 columns to the right of
the current column)

Mixed references

RC5 (a reference to a cell in the current row in column 5)

RCJ[-5] (a reference to a cell located in the current row 5 columns to the left
of the current cell)

R3C[2] (a reference to a cell located in row 3, 2 columns to the right of
the current cell)

R[3]C[-2] (a reference to a cell located 3 rows below and 2 columns to
the left of the current cell)

R[-3]C]2] (a reference to a cell located 3 rows above and 2 columns to
the right of the current cell)

If a spreadsheet

contains absolute references when switching from the Al to

R1C1 reference style, they will remain absolute afterwards.
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4.5.3.3 Cell range reference

The reference to a cell range is defined by referencing its two corner cells:
— Starting cell: The upper-left cell of the range.
— End cell: The lower-right cell of the range.

The starting and end cells are separated by the colon (:) sign. For example: B4:D6
(see Section 4.6.4).

If the R1C1 style is selected for cells referencing, in some cases you do not need to use
the (z) range operator. For instance, if you want to reference the range of all cells of one row, you
can only specify a reference to this row (that is the R1 reference refers to the range of all cells of

the first row).
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4.5.4 Recalculation of formulas

Calculation is the process of calculating formulas and then displaying the values of the
results in cells. Formulas are usually recalculated automatically when the values in the cells on
which they depend change. This is a standard procedure when opening/closing a file and editing it.

If there are many formulas in a document, their automatic recalculation can make opening
and working with the document difficult. To speed up work with such documents,

MyOffice Spreadsheet provides a mode in which formula recalculation is done upon user request.

Table 13. Recalculation modes

Automatic recalculation mode Manual recalculation mode

— When a user opens and saves a document,

When you open a document and change the

only the outdated formula values are associated cells, no formulas are automatically
recalculated. recalculated.

— When you work with a document, formulas | — When you work with a document, formulas are
are recalculated if the associated cells have recalculated only when you carry out manual
been changed. operations on the cells that contain them.

— Manual recalculation of outdated formula values is
available in the entire document, on the sheet, and in
selected cells.

— When saving a document, recalculation of outdated
formula values is performed only if the Before
Saving box is checked.

Outdated values in formulas are irrelevant data that were calculated in the past but are no
longer relevant. They may occur as a result of data entry errors, errors in formulas and functions,
data type mismatches, changes in table structure, errors in macros, or synchronization problems.

MyOffice Spreadsheet stores information about the presence of such cells within the file itself.

When formulas are recalculated, references to data from external documents are not updated.

To update them, follow the steps described in Section 4.5.10.3.

4.5.4.1 Select formula recalculation mode

By default, the automatic mode of formula recalculation is selected in the document.
To switch the mode, do one of the following:
1. Open the mode selection sub-menu in one of the following ways:

— In the Command menu, select Data > Calculation Mode (see Figure 197).
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Data

po B &

™M

Tools View Share

Define Name...
Manage Protection

Refresh Pivot Table
Pivot Table Settings

Delete Pivot Table
Smart Table Settings

Group Rows
Group Columns

Clear Grouping

Autosum

Remove Duplicates...
Calculation Mode
Refresh Data

Subscription  Help

11 | w

Pl A o

Alt+=
»  ® Automatic
Ctrl+Shift+F5 Manual
Calculate

3

AT A

£

Data Validation
See All Malidations

Figure 197. Calculation mode sub-menu

— On the Toolbar, in the Data section, click the button depicting the current

recalculation mode. For example, F‘a (see Figure 198).

SvE @y By V-2 By O
BE‘ v = v °ﬁ hd z h @ Lﬁé Automatic
Cells Data

E.‘ Manual

N

Figure 198. Recalculation modes

2. In the sub-menu that opens, select the desired formula recalculation mode: Automatic

or Manual.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

219



MyOffice

The icon of the selected mode is displayed in the Status bar (see Figure 199).

E

|F‘; Automatic| SUM 0 AVERAGE 0 MIN 0 MAX 0 COUNTA 0 m =

+

W

Figure 199. Status bar

4.5.4.2 Recalculation of formulas in automatic mode

In automatic mode, only outdated formula values are recalculated when opening a document.

If you want to force recalculate all formulas in the document, press Ctrl+Shift+F9 /

{ Shift+s Cmd+F9.

4.5.4.3 Recalculate formulas manually

You can manually recalculate outdated formula values in the entire document, on an open

sheet, or in selected cells.

To recalculate outdated formula values in the entire document, do one of the following:

— In the Command menu,

Whole Document (see Figure 200).

Data Tools View Share

Define Name...
Manage Protection

Refresh Pivot Table
Pivot Table Settings
Delete Pivot Table
Smart Table Settings
Group Rows

Group Columns

o Be &

Clear Grouping

7 Autosum

Remove Duplicates...

Calculation Mode
i Refresh Data

Data Validation
See All Validations

Subscription

Alt+=

»

Ctrl+Shift+F5

Help

nv AT AT = 4
AV v o
Alignment
B C
Automatic
® Manual
Calculate » + Before Saving

Whole Document
Sheet
Selected Cells

Number F...

F3
Shift+F9

Figure 200. Commands to recalculate outdated formula values manually
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— On the Toolbar, in the Data section, click the recalculation area selection button and

select ©2 Whole Document from the drop-down list (see Figure 201).

.0 w — I:Ill'_lf w E W '_| [_u '

sy v T3 B

vy 3 B

Hv & s

Cells Data

S

Before Saving

3l

._
Qd Q

Whole Document H

Sheet

i

Selected Cells

Figure 201. Commands to recalculate outdated formula values manually

—  Press F9.

To recalculate outdated formula values on a sheet currently open, do one of the following:

— Inthe Command menu, select Data > Calculation Mode > Calculate > Calculate Sheet
(see Figure 200).

— On the Toolbar, in the Data section, click the recalculation area selection button and
select &c: Calculate Sheet from the drop-down list (see Figure 201).

— Right-click the sheet tab and run the Calculate Sheet command from the context menu

(see Figure 202).
19
20 Rename
21 Duplicate
=2 Hide
23
24 Hide Zero Values
25 Protect Sheet...
26
57 Calculate Sheet Shift+F9
<! Delete
:
=]
iy Manual

Figure 202. Calculate Sheet command
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—  Press Shift+F9 / {+ Shift+F9.

To recalculate outdated formula values in one or more selected cells, do one of the following:

— In the Command menu, select Data > Calculation Mode > Calculate > Calculate
Selected Cells (see Figure 200).

— On the Toolbar, in the Data section, click the recalculation area selection button and
select 22 Calculate Selected Cells from the drop-down list (see Figure 201).

— Right-click the selected cells and choose Calculate Selected Cells command from

the context menu.
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4.5.4.4 Recalculate formulas when saving a document

When the user saves the document, recalculation of outdated formula values is carried out if
the Before Saving box is checked.

In Automatic mode, the Before Saving box is always checked and locked.

In Manual mode, the Before Saving box is checked by default. If you want to uncheck
the box, do one of the following:

— In the Command menu, select Data > Calculation Mode > Calculate and uncheck

the Before Saving box (see Figure 203).

Data Tools View Share Subscription Help

Define Name... 1
Manage Protection 4 A
o -

Refresh Pivot Table Alignment NumberF.
Pivot Table Settings

Delete Pivot Table
Smart Table Settings

Group Rows

Group Columns

en Be &

Clear Grouping

> Autosum Alt+=

Remove Duplicates...
Calculation Mode 4 Automatic
3 Refresh Data Ctrl+Shift+F5 | ® Manual
Calculate *» « Before Saving

Whole Document F9
See All Validations Sheet Shift+F9

Data Validation

Selected Cells

Figure 203. Before Saving checkbox

— On the Toolbar, in the Data section, click the recalculation area selection button and

uncheck the Before Saving box (see Figure 204).

By V-=3v B O —
@ roa B L EEDL

Data
Before Saving

Whole Document H 1

Sheet

i P BN

Selected Cells

Figure 204. Before Saving checkbox
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4.5.5 Automatic calculation

If you select a range of cells, MyOffice Spreadsheet automatically calculates 5 of the most
used functions and displays the results in the Status bar (see Figure 205):

— SUMM: Calculates the sum of all numbers in the selected range.

— AVERAGE: Calculates the average value of all numbers in the selected range.

— MIN: Displays the smallest value among all the numbers in the selected range.

— MAX: Displays the highest value among all the numbers in the selected range.

— COUNTA: Displays the number of values in the selected range. Numerical and text

values are considered.

To configure the list of available functions, follow these steps:

1. In the Status bar, click the button.
2. In the opened list, check the boxes of the functions that will be displayed in

the Status bar.

SUM
[ AVERAGE
MM
MAX

COUNTA

SUM 0 AVERAGE 0 MIM O MAX 0 COUNTA 0 L

Figure 205. Selecting the displayed functions
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4.5.6 Insert functions

For a complete list of functions in MyOffice Spreadsheet, see Appendix 1. Functions and

their description.

You can enter a function directly into a cell, on the Formula bar, or using the Insert function

pane.

To enter a function in a cell or using the Formula bar, follow these steps:

1. Select the cell in which you want to enter a function.

2. On the Formula bar or in the cell, type an equal sign (=).

3. Start typing the name of the function to display a list of available functions

(see Figure 206).

4. Select the desired function from the list provided using the mouse or keyboard keys:

— Select the function in the list by clicking it.

— Select the function using the | and 1 buttons and press Enter.

Al w Fx =sum
A 5
1 =sum
Fu
2
3 Fu
4
5 Fu
- F
7
B Fu
9
Fu
10
11 Fu
12
13

SUM

SUMIF
SUMIES
SUMPRODUCT
SUMSQ
SUMX2MY2
SUMX2PY2

SUMXMY 2

Figure 206. List of functions
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5. Detailed information about the function is available. To display it, click the -~ button to
the right of the function’s name in the tooltip box (see Figure 207).

Move the tooltip box with the description with the left mouse button pressed.

AT v fx =sum( o0
A B C D E F
=sum( | Hx

SUMivaluel, [value2, ..])

T R R

Figure 207. Description of a function

6. Enter function arguments.

In Windows, if "." is selected in the Customize Format window, in Decimal symbol

field, use "," instead of ";" as the separator of values in functions in MyOffice Spreadsheet

application.

7. To finish, click the (] button on the Formula bar or press Enter. To cancel, click

the > button on the Formula bar or press Esc.

To enter a function using the Insert function pane, follow these steps:
1. Select the cell in which you want to enter a function.
2. Expand the Insert function pane in one of the following ways:

— In the Insert menu, select Function (see Figure 208).

Insert Format Table Data Tools
Image...
Text Box
1 Shape 4

ili  Chart »
Pivot Table...
Function... Shift+F3

B 5 B

Special Characters...

Figure 208. Insert menu
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— On the Formula bar, click fx (see Figure 209).

A1 v | fx

Figure 209. fx button

— On the Toolbar, select the Insert section and click ***. In the displayed insert pane,

select 7 Function (see Figure 210).

.

? Eg v Fe‘ h -
oo 05 B (@)~ &=
2 v @ E2 v
Data @ Image... ~
Text Box
F (? Shape > ~ Q
fx
olp  chart >
{7  PivotTable.. 0
jf)( Function... =
Special Characters... >

Figure 210. Insert menu

— On the Sidebar, click the fX Insert Function button (see Figure 210).
—  Press Shift+F3.
3. Find the required function in one of the following ways:
— Enter part of the function name/the whole name in the search field. Below is a list of
functions that meet the search conditions.
— Select the group that the function belongs to. For example, the SUM function is
included in the Math & Trig group.

— Find the function in one of the following groups:
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e All: Contains all the functions supported by MyOffice Spreadsheet.
¢ Recent: Contains the last 10 functions entered by the user.

e Most popular: Contains a fixed list of 10 frequently used functions.

N > Insert Function Q
| Finc | [
Al > ~| ABS . &
C
Recent > ACQOS =
Most popular  ? ACOSH
Financial > ACQOT
Date and time  ? ADDRESS
Math and trig  ? AND
Statistical > | AREAS -
ABS(value)

Returns the absolute value of a number.

value
A number which absolute value to be
returned.

Figure 211. Insert function pane

4. Select the required function.
5. If necessary, check out the function summary at the bottom of the Insert function pane.
6. To insert a function into a cell, do one of the following:

— Click Insert.

— Select the function by double-clicking.

— Press Enter.

7. Enter the arguments of the function.
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In Windows, if "." is selected in the Customize Format window, in Decimal symbol

field, use "," instead of ";" as the separator of values in functions in MyOffice Spreadsheet

application.

8. To finish entering the function, click the & button on the Formula bar or press Enter.
To cancel entering a function, click the % button on the Formula bar or press Esc.
9. To close the Insert function pane, do one of the following:
— In the Command menu, select Insert > Function (see Figure 208).
— On the Formula bar, click fx (see Figure 209).
— On the Toolbar, in the Insert section, click “**. In the insert pane that appears, click

the > Function button (see Figure 210).

— On the Sidebar, click fx Insert Function (see Figure 211).
— Click the =* button at the top of the Insert function pane (see Figure 211).
— Press Shift+F3.

When working with numeric data, you often need to carry out typical operations on it and
output the result in a separate cell, for example, to calculate the sum or display the average value for
selected columns or rows. For this purpose, it is convenient to use the Autosum operation.
The operation allows you to use five popular data processing functions: SUM, MIN, MAX,
AVERAGE, COUNT.

Autosum recognizes the cell range with numeric data and substitutes it into the function.
The cells selected before the operation will determine where the result of the calculation will be
output and what range of data will be used. For example, to calculate the sum for a column, you can:

— Select an empty cell below the column. The result will be inserted into this cell.

— Select the entire column. The result will be inserted into the empty cell under the column

closest to the range.

— Select a cell range if you want to use only part of the cells in the calculation. The result

will be inserted into the empty cell under the column closest to the range.

It is important to take into account the following:
— If the range contains several cells with the results of the same function, only such cells
will be automatically included in the range. This is convenient when any subtotals have

already been calculated in the column, and the final total will be their sum.
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— If an empty cell next to an area with numbers is selected, all numbers after the nearest
cell with text, an empty cell, or a cell with the same function will automatically be

included in the range (see Figure 212).

A B A B A B

1 1 1 1 1 1

2 2 2 2 2 2

3 3 3 3 3 5

4 4 4 6

5 Text 5 4 5 4

6 5 6 5 6 5]

7 6 7 6 7 6

8 7 8 7 8 7

o [=SUM(A6:A3) | o [~SUM(A5:AS) | g [=SUM(A5:A8) |
1n 1n 10

Figure 212. Examples of automatic range detection
when selecting a single cell

— If a cell range, column or row is selected, the function will include all data after the cell

with the same function (see Figure 213).

A B
1 1
2 2
3 3
4 6
5 4
6 |Text
7
8 7
g |=SUM(A5:A8) |

i |

Figure 213. Example of automatic range detection
when selecting a cell range

To enter a function using the Autosum operation, follow the steps below:
1. Select an empty cell next to the data, a column, row, or cell range.

2. Run the Autosum operation in one of the following ways:
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— Click 2~ Autosum in the Formula bar or in the Data section of the Toolbar
(see Figure 214 and Figure 215). The SUM function will be used. If you want to use
another function, click the arrow to the right of the button and select the desired

function from the drop-down list.

File Edit Insert Format Table Data
n v X B B>
Add &> S ¢

Favorites File Edit

A18D18 ~ |2 |+ 19,068

Figure 214. Autosum on the Formula bar

LSvEH &Sy By Ve =3vy Bv O
Hy® =« v v @ & )

Cells Data

Figure 215. Autosum on the Toolbar

— In the Data menu, select Autosum (see Figure 216).

Data Tools View Share Subscription

Define Name...
Manage Protection L4

Refresh Pivot Table
Pivot Table Settings

Delete Pivot Table
Smart Table Settings

Group Rows

Group Columns

eoo B &

Clear Grouping

Autosum Alt+=

™

Figure 216. Autosum in the Command menu

— Press Alt+=/ ~= Option+=.
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When you select an operation from the Command menu, Quick Actions box, or by using

a keyboard shortcut, only the SUM function can be used.

3. If necessary, edit the function arguments or add additional ones to them.
4. To finish entering the function, click the " button in the Formula bar or press Enter.

To cancel entering a function, click the %" button in the Formula bar or press Esc.

Only visible cells of the range are included in the calculation. The maximum possible

number of arguments when using Autosum is 255.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 232



MyOffice

4.5.7 Replace a formula with its result

For your convenience you can replace a formula or a part of a formula in a cell with its result.
Simply follow these steps:
1. Select the formula or a part of the formula directly in the cell or on the Formula bar.
A tooltip appears above the selected part of the formula or above the formula itself,
which contains the calculated value.
2. Press Alt+F9 / ~=Option+F9 to replace formula, fully or partially, with the calculated

value.

4.5.8 Copy and insert formulas

If necessary, you can cut or copy formulas from one cell/row/column and paste the final
value of these formulas into another cell/row/column without the formulas themselves.

To cut or copy a formula, do the following:

1. Select the cell, cell range, rows, or columns from which you want to cut or copy formulas.

2. Copy a formula in the usual way (see Section 4.12.2.1).

To insert the result of formula calculation without the original formatting:
1. Select where you want to enter the resulting value of the formula.

— [If theclipboard contains data from a single cell/row/column, select
the cell/row/column where you want to paste the data.

— If the clipboard contains a range of cells/rows/columns, select the appropriate size
range, or select the cell/row/column where you want to paste the contents of the first
cell/row/column in the range.

2. To insert the result of a formula calculation without the original formatting, do one of
the following:

— In the Edit menu, select Paste Values Only (see Figure 217).
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Edit Insert Format Table Data Tools Wie

= Undo Ctrl+Z

i  Redo Ctrl+Y

o Cut Ctrl+X

Copy Ctrl+C

[T Paste Ctrl=V
Paste Values and Format Ctrl=Alt+V
Paste Values Only

2 Copy Formatting Ctrl+5hift+C
Paste Formatting Ctrl+5Shift=V
Select All Crl=A

1 Find Ctrl+F

Figure 217. Edit menu

— On the Toolbar, select the Edit section and click the arrow to theright of

the [ Paste button. In the drop-down list, select Paste Values Only
(see Figure 218).

File Edit Insert Format Table Data Tools View Share Subscription

+ v X & Calibri

Add = 9 C o o ) AB

Paste Values and Format

Favorites File Edit

C23 v 2 v fx

Paste Values Only

141

Figure 218. Paste Values Only command

— Open the context menu of the cell by right-clicking and run the Paste Values Only

command.
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To paste the result of a formula calculation while preserving the original formatting, do one

of the following:

Select the Edit > Paste Values and Format Command menu item (see Figure 217).
On the Toolbar, under Edit, click the arrow to the right of the Ea Paste button and
choose Paste Values and Format from the drop-down list (see Figure 205).

Open thecontext menu of thecell by right-clicking and run
the Paste Values and Format command.

Press Ctrl+Alt+V / ~Option+3 Cmd+V.
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4.5.9 Names in formulas and functions

When you work with large data sets, you can give names to frequently used cells, cell ranges,
constants, and formulas. Names are used in formulas and functions and make them easier to write
and understand.

For example, the function =SUM(Sales) is entered and understood more easily than
the function =SUM(D2; D20).

Names are divided into two types:

— Defined: Names that the user manually assigned to cells, ranges, constants, and

formulas.

— Table: The names of tables that have tabular formatting style applied in Microsoft Excel

(also called "smart" tables). Smart table names are automatically created in

Microsoft Excel.

In addition, names are varied by their area of application:
— Gloebal: Can be used on any spreadsheet sheet.

— Local: Can be used only on the sheet on which they were set.

The following interface elements are used to work with names:

— Range field: The field is located to the left of the Formula bar (see Figure 219). You can
expand the range field if necessary. To do this, move the cursor to the right border of
the field so that it looks like a bidirectional arrow, and while keeping the left mouse

button pressed, move the field boundary to the right.

Al v | fx

T R

Figure 219. Range field
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— Name Manager: It opens when you click the & Name Manager button on the Sidebar

(see Figure 220).

Teyavy By O
.- Yy
o~ 83 B4 @)~ -
> v 3 B v
Data Insert

- Name Manager

Define Name

All names

=SUM(MyData)

Use names instead of references to make
formulas more readable

Figure 220. Name Manager
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4.5.9.1 Define name

The name may contain the following elements:

Letters

Digits (cannot be used at the beginning of the name)
Symbols

_ (underscore)

\ (backslash)

. (dot) (cannot be used at the beginning of the name)

The name can be set using the range field (quick way) or using the Name Manager.

4.5.9.1.1 Define name with range field

You can use a range field to name a cell or a range of cells. The name specified using

the range field is global.

To specify a name using a range field, do the following:

1. Select the cell or range of cells to specify a name.

2. Enter a name in the range field.
Discount v~ fx 0.1

A B c D E i
1 Item Unit price |Qty Price Discount Discount price |
2 |ltem A 20 5 25 0.1 22.5
3 |Item B 36 25 61 0.2 48.8
4 |Item C 48 20 68 0.1 61.2
5 |ltemD 50 18 68| 0.1} 61.2
Figure 221. Create a name using the range field
3. To save the name, press Enter. If you want to delete the data you entered when creating

the name, press Esc.
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4.5.9.1.2 Define name using Name Manager

You can use the Name Manager to name a cell, a range of cells, a constant, or a formula.

To define a name using the Name Manager, do the following:

1. If you want to name a cell or a range of cells, select them on the sheet. If you want to
name a constant or formula, skip this step.

2. Open the Name Manager in one of the following ways:

— In the Command menu, select Data > Define Name (see Figure 222).

Data Tools View Share Subscription

Define Mame...

Manage Protection ’

Figure 222. Define Name command menu command

— Right-click the selected cell or cell range to open the context menu and run
the Define Name command.

— On the Sidebar, click the < Name Manager button. In the Name Manager, click
Define Name (see Figure 223).

~ = Name Manager Q
Define Name fx
Finc
Cw
— CX
All names v  T= ~
=SUM(MyData)

Figure 223. Define Name button
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3. Inthe Name Manager, specify the data to create the name (see Figure 224):
— In the Name field, specify the name of the cell/range/constant/formula or leave
the default name. The default name is [Name_n], where n is the ordinal number of

the named item.

~ > Name Manager Q
Define Name fx
Cv
— CX
Name_1 X
='Sheet1'1$C%23 X
All Sheets v

Figure 224. Create a name using the Name Manger

— If a name is created for a cell/range, a reference to the cell/range selected in
the first step is automatically generated in the Reference field. If necessary,
the reference can be edited manually, or you can select another cell/range on
the sheet with the mouse so that the reference will be edited automatically. If a
name is created for a constant or formula, enter the desired constant/formula

manually in the Reference field.
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References to cells and cell ranges are displayed as absolute by default. You

can convert them to relative ones manually.

— In the drop-down list specify where the name will be used: on all sheets of
the spreadsheet or on a specific sheet.

4. Click the Done button or press Enter.

The created name appears in the Name Manager list (see Figure 225).

~ > Name Manager Q
Define Name £
Cv
— Cx
All names v = v
& Name_1
'Sheet1'1$C$23

Figure 225. Name created in the Name Manager
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4.5.9.2 Find a name

The name can be found using the range field or the Name Manager.

The search is not case-sensitive.

4.5.9.2.1 Find using the range field

To quickly find a name, do the following:

1. Click the range field.

2. Start typing the desired name. The names that match the search conditions will appear in
the drop-down list (see Figure 226).

3. Select the desired name using the mouse or the keyboard keys:
— Left-click the name with the mouse.

— Select the name using the | and 1 keys and press Enter.

| cnst| ™ | fx
<) Cost ~'Sheet?'1$C38..
7 Cost_per_item ='Sheet?'1$G315

Manage Defined Mames

Figure 226. Quick name search

To view the entire list of names and select the desired name from it, follow these steps:

1. Expand the entire list of names. To do this, in therange field, click the~ button
(see Figure 227).

2. Select the desired name in the list using the mouse or the keyboard keys:
— Left-click the name with the mouse.

— Select the name using the | and 1 keys and press Enter.
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| G12 ‘E§| Fx
<) Cost ='Sheet2'1$C$8. .
) Cost_per_item ='Sheet2'1$G115
& Delivery ='Sheet2'1$C311
<) Discount ='Sheet2'1$GS$10
Manage Defined Mames
0

Figure 227. Name list

If the selected name belongs to a cell/range, that cell/range is highlighted in the spreadsheet.

If the selected name belongs to a constant or formula, the Name Manager opens and
automatically selects a line for that name.

If the name of a cell/cell range/constant/formula is selected in the cell editing mode, it is

entered in the cell as the value of the formula/function (see Section below).
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4.5.9.2.2 Find using the Name Manager

Open the Name Manager in one of the following ways:

— On the Sidebar, click <’ Name Manager button (see Figure 228).

o A - Name Manager Q
Define Name fx
Cwv
= Cx
Global: all sheets v = v

J Cost_per_item
='Sheet2'13G515

J Delivery
='Sheet215C511

<7 Discount
="'Sheet2'15G510

J Name 1
='Sheet2 15A51

Figure 228. Name Manager

— In the range field, click v and select Manage Defined Names (see Figure 229).
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[ E14 v A
) Cost ='Sheet2'1$C$8...
¢’ Cost_per_item ='Sheet219G415
& Delivery ='Sheet?'1$C$11
) Discount ='Sheet2'1$G$10
Manage Defined Mames I})
10

Figure 229. Manage Defined Names

The Name Manager displays a complete list of names that the current spreadsheet contains
(see Figure 228). Use the search bar and filter/sorting tools to quickly search through the list.

To search a name using the search bar, do the following:

1. Set the cursor in the search bar.

2. Start entering the desired name or a link/constant/formula to which the name has been

assigned (see Figure 230).

A - Name Manager

Define Mame

Q » 0O

cost s ‘
) o
_ Cx
Global: all sheets w = w
) Cost

='Sheet2'15C58:5D5%9

¢’ Cost_per_item
='Sheet2'15G$15

Figure 230. Search bar
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As you enter data for the search, the list of names will be reduced to values that match

the search conditions.

To filter the list, do the following:
1. Click the All names field (see Figure 231).
2. In the drop-down list, specify which name group should be displayed in the list:

Defined names: Names created manually by the user.

— Table names: Smart table names.

Global: all sheets: Names that can be used on any spreadsheet sheet.

- Name Manager Q
Define Mame i":)(
Cv
_ Cx
All names \!'} = v
" All names

Defined names

make
Table names

Local: current sheet

Global: all sheets

Figure 231. All names field
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To select the list sorting type, do the following:

1. Click T= (see Figure 232).

2. Select the sorting type:
— Name (A-Z): Sorting by the value specified in the Name field (in ascending order).
— Name (Z-A): Sorting by the value specified in the Name field (in descending order).
— Reference (A-Z): Sorting by the value specified in the Reference field (in ascending

order).

— Reference (Z-A): Sorting by thevalue specified in the Reference field

(in descending order).

- Name Manager Q
Define Name fx
o
— Cx
Defined names v ‘T_: i
" Mame (A-7)
) Cost Name (Z-A)
='Sheet1'15A
Reference (A-7)
& Cost_per_itei Reference (7-A)
="Sheet1'13 A

Figure 232. Selecting the sorting type

To see which cell/range corresponds to which name, select that name in the list.

The cell/range will be highlighted in the spreadsheet.
If the name of a cell/cell range/constant/formula is selected in the cell editing mode, it is

entered in the cell as the value of the formula/function (see Section below).
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4.5.9.3 Enter the name in a formula or function

Formulas and functions that contain names of cells/cell ranges/constants/formulas are
entered as usual.

Names in formulas or functions can be entered as follows:

— Manually

— Using the range field

— Using the Name Manager

To enter the name manually, do the following:

1. Start typing the name (see Figure 233). The drop-down list will display the names which
correspond to the search parameters.

2. Select the name using the mouse or the keyboard keys:
— Left-click the name with the mouse.

— Select the name using the | and 1 keys and press Enter.

F2 v fx =D2-(d
A B C ] E F G H
1 |Item Per unit pr14 Quantity I_]i'{}t_:g _______ Discount |Discount price
> [em A 20 5| 25 0.1=D2-(d|
3 |ltem B 36 25 61 0.2 B "
4 |ltem C 48 20 68 0.1 < Discount
5 |ltem D 50 18 68 01 . i
6 ————————— ¢ Discount_price
7 # DATE
g
9 Fx DATEVALUE

Figure 233. Enter names manually

To enter a name using a range field, search for it as described in Section 4.5.9.2.1

(see the example in Figure 234).
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di v fx =D2-(d
D E F

¢’ Discount N = NMnct31$H$25 |

I_I_'F_“_:"_! _______ Discount |Discmmt price
< Discount_price =Mncr3i$HS2s |5 25| 0.1=D2-(d

5 B1 0.2

0 68 0.1

Manage Defined Names 8 68 0.1

Figure 234. Entering name using the range field

To enter the name using the Name Manager, do the following:

1. Perform the name search as described in Section 4.5.9.2.2.

2. Select a name with the mouse or keyboard keys (see Figure 235):
— Select the name with a double-click.

— Select the name with the | and 1 keys and press Enter.

Global all sheets

F2 “ fu =Dpy o0
_ R i =+ Mamie Manager
2 £ [} E F ] H
1 hHem Per wnif price Cuantity st Discount  Discounted mte
2 |heml 653 3344 45 12=02%
i hem2 3987 33 B3 12
4 hem3 2455 a7 M 13 ik
i hamd 3 5 o8 5
&

o

="Sheetd THGE10

Figure 235. Enter name using Name Manager

The selected name will be substituted in the formula/function. If the name belongs to

a cell/range, the cell/range will be highlighted in the spreadsheet.

If necessary, you can enter a local name from another sheet into a formula/function. To do

this, select it in the range field or in the Name Manager or manually enter a reference

like 'Sheet Name'!MyName. For example: 'Sheet2''Name_8.
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4.5.9.4 View name properties

To view the name properties, do the following:
1. Open the Name Manager in one of the following ways:
— On the Sidebar, click @ Name Manager button (see Figure 236).

— In therange field, click ¥ and run the Manage Defined Range command

(see Figure 236).
|. Cc:rst| vll Fx
¢ Cost ='Sheet1'134%
¢ Cost_per_item —'Sheet]'144%

Manage Defined Names Ik

Figure 236. Manage Defined Names command

2. In the Name Manager, place the cursor on the desired name and click the v Expand

button (see Figure 237).
= Name Manager Q
Define Name fx
&
Finc
Cw
— CX
All names v [ 1= ~
<) Name_1 v

='Sheet1'$C$23
¢ Name_2
‘Sheet1'13C$23
Figure 237. Expand button

If the name belongs to a cell/range, the cell/range will be highlighted in the spreadsheet.
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The Name Manager displays the properties of the selected name (see Figure 238). The text
in the Name and Reference fields can be copied if necessary.

To hide the name properties, click Collapse.

- Name Manager Q
Define Name fx

Fin
Cv
Cx

All names b = v

|

='Sheet1'1$C%23
|| Collapse

¢ Name_2

'Sheet1'1$C%23

Figure 238. Name properties
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4.5.9.5 Delete a name

You can delete names created manually. Deleting names of smart tables is not possible.
To delete a name, do the following:

1. Open the Name Manager in one of the following ways:

— On the Sidebar, click & Name Manager button (see Figure 237).
— Inthe range field, click the ~ button and run the Manage Defined Names command
(see Figure 236).
2. In the Name Manager, place the cursor on the desired name and click the v+ Expand

button (see Figure 237).

3. Click w Delete (see Figure 238).
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4.5.10 Reference to data in another document

In the formulas and functions of the current document, you can refer to data from one or

more external documents.

The following restrictions apply in this version of the application:

The current and external documents must be saved in .xlsx, .ods or .xods format.

The current and external documents must be local, that is, they must be stored directly
on your computer.

The creation of references to cells and cell ranges of an external document is supported.
The use of structured references (see Section 4.5.11), as well as references to cell names and
ranges, is not allowed (see Section 4.5.9).

The reference that is entered manually into the cell with the name (see Section 4.5.9)

must be absolute.

You can create a reference to data from an external document in one of the following ways:

Open an external document and select the desired cell or range of cells with a mouse
click.

Enter the reference manually without opening an external document.

4.5.10.1 Create a reference with a mouse click

To create a reference to data from an external document in a formula or function of

the current document by clicking the mouse, follow these steps:

1.

Open a document that will contain a formula or function with a reference, and an external
document to which data you want to create a reference. If the external document was
opened earlier, make sure that all the changes you made are saved in it (see Section 4.1.8).
In the current document, select the cell where you want to enter a formula or function.
On the Formula bar or directly in the cell, enter the = sign and start typing the formula
or function.

Navigate to the external document and select the sheet whose cell or range of cells you
want to refer to.

Select the desired cell or range of cells on the sheet. The Formula bar of the external and
current document displays the entered formula or function from the current document.
If necessary, the formula/function can be edited both in the current and in an external

document.
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6. Go to the current document, finish entering the function or formula and click

the @ button on the Formula bar or press Enter.

4.5.10.2 Enter the reference manually

To manually create a reference to data from an external document in a formula or function of
the current document, enter a string of the following type: "path[name.extension]Sheet'!Cell where:
— path: the path to the external document, which can be specified as:

— Relative path: The path to the external document described relative to the base directory
of the source document. Example: ../Subfolder/External document.xlsx.

— Absolute path: The path to the document described from the root of the logical disk
(the root of the installed operating system).
Example: C:/Users/Username/Downloads/Subfolder/External document.xlsx.

— The absolute path to the external document using the file scheme (URI scheme). Example:
file:///C:/Users/Username/Downloads/Subfolder/External document.xlsx.

— name.extension: The name and extension of the external file.

For example: External document.xlsx.

— Sheet: The name of the sheet in the external document. Example: Sheetl.
— Cell: The address of a cell or range of cells in an external document. For example: Al

or A1:A10.

Examples for Windows OS
In example below, the document document.xlsx located in the base directory
C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in

the same directory.

Relative path to external | ../external.xlsx
document

Absolute path to C:/Users/Username/Downloads/external.xlsx
external document

The absolute path to the | file:///C:/Users/Username/Downloads/external.xlsx
external document using
the file scheme (URI
scheme)

Formula with relative ="[external.xlsx]Sheet 1'!A1+A1
reference

Function with absolute =SUM('file:///C:/Users/Username/Downloads/[external.xlsx]|Sheet1''A1: A10)
reference
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In example below, the document document.xlsx located in the base directory
C:/Users/Username/Downloads/ refers to data from an external document external.xlsx located in

a nested directory C:/Users/Username/Downloads/Subfolder/.

Relative path to external document ../Subfolder/external.xIsx

Absolute path to external document C:/Users/Username/Downloads/Subfolder/external . xIsx

The absolute path to the external file:///C:/Users/Username/Downloads/Subfolder/external .xIsx

document using the file scheme (URI

scheme)

Formula with relative reference ='Subfolder/[external.xlsx]Sheet1'!A1+Al

Function with absolute reference =SUM('file:///C:/Users/Username/Downloads/Subfolder/
[external.xlsx]Sheet1''A1:A10)

In example below, the document document.xlsx located in the base directory
C:/Users/Username/Downloads/ refers to data from an external document external.xIsx located in

another directory — D:/Documents/SomeFolder/.

Relative path to external document D:/Documents/SomeFolder/external.xlsx

Absolute path to external document D:/Documents/SomeFolder/external.xlsx

The absolute path to the external document | file:///D:/Documents/SomeFolder/external.xIsx
using the file scheme (URI scheme)

Formula with relative reference ='D:/Documents/SomeFolder/[external.xlsx
]Sheet1''A1+A1

Function with absolute reference =SUM('file:///D:/Documents/SomeFolder/[external.xIsx]

Sheet1'!A1:A10)
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Examples for macOS
In example below, the document document.xlsx located in the base directory
/Users/Username/Downloads/ refers to data from an external document external.xlsx located in

the same directory.

Relative path to external document ../external.xlsx
Absolute path to external document /Users/Username/Downloads/external.xIsx
The absolute path to the external document file:///Users/Username/Downloads/external .xIsx

using the file scheme (URI scheme)

Formula with relative reference ='[external.xlsx]Sheet 1''A1+A1

Function with absolute reference =SUM('file:///Users/Username/Downloads/
[external.xlsx]Sheet1'!A1:A10)

In example below, the document document.xlsx located in the base directory
/Users/Username/Downloads/ refers to data from an external document external.xlsx located in

a nested directory /Users/Username/Downloads/Subfolder/.

Relative path to external document ../Subfolder/external.xIsx

Absolute path to external document /Users/Username/Downloads/Subfolder/external.xlsx

The absolute path to the external document | file:///Users/Username/Downloads/Subfolder/external.xlsx
using the file scheme (URI scheme)

Formula with relative reference ='Subfolder/[external.xlsx]Sheet1'!A1+A1

Function with absolute reference =SUMC('file:////Users/Username/Downloads/Subfolder/
[external.xlsx]Sheet1''A1:A10)

In example below, the document document.xlsx located in the base directory
/Users/Username/Downloads/ refers to data from an external document external.xlsx located in

another directory, /Volumes/USB_flash/SomeFolder/.

Relative path to external document /Volumes/USB_flash/SomeFolder/external.xIsx

Absolute path to external document /Volumes/USB_flash/SomeFolder/external.xIsx

The absolute path to the external document | file:///Volumes/USB_flash/SomeFolder/external.xlsx
using the file scheme (URI scheme)

Formula with relative reference ='../Volumes/USB_flash/SomeFolder/[external.xlsx]
Sheet1'!A1+A1

Function with absolute reference ='file:///Volumes/USB_flash/SomeFolder/[external.xlsx]
Sheet1'!A1:A10)
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4.5.10.3 Update data

Since the data in the external document may change, it is recommended to periodically

update the reference to this data in the current document.

To update the references after opening the current document, click the Refresh Data button

in the notification line “Linked documents might have changed. Refresh this document to get

the latest data” (see Figure 239). This line is displayed under the Toolbar.

The application will recalculate formulas and functions taking into account new values from

an external document.

T New Spreadsheet 1 - MyOffice Standard. Home Edition
File Edit Insert Format Table Data Tools View Share Subscription Help

+ B v £><3 XOThames ~ (12 |~ A- A = =
Add G ~ B T U - Ao £

= - i e V?‘" h E) son
Favorites File Edit Font Alignment Number F. Cells Data Insert ~
Linked documents might have changed. Refresh this document to get the latest data. Refresh Data Close
A v 7 ~ fx Categoryl
e

Figure 239. Refresh Data button

== w B 65

If the document is not available, the notification line "Linked documents are unavailable.

The spreadsheet uses the last saved data." Click Clese in this line (see Figure 240).

1 New Spreadsheet 1 - MyOffice Standard. Home Edition

File Edit |Insert Format Table Data Tools View Share Subscription Help

+ v (><j XOThames ~ (12 v A” A+ = = = =
Add S~ B I U - A v £ o Lov ®v

123 HH 1

Favorites File Edit Font Alignment Number F... | Cells Data

Linked documents are unavailable. The spreadsheet uses the last saved data.

Al v v K Category 1

Figure 240. Close button

To update the data when working with a document, do one of the following:

— In the Command menu, select Data > Refresh Data (see Figure 241).
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Data Tools View Share Subscription

Define Name...
Manage Protection »

Refresh Pivot Table
Pivot Table Settings
Delete Pivot Table
Smart Table Settings
Group Rows

Group Columns

o0 Be &

Clear Grouping

3 Autosum Alt+=
Remove Duplicates...
Calculation Mode »
i Refresh Data Ctrl+Shift+F5

Figure 241. Refresh Data command menu option

— On the Toolbar, in the Data section, click S Refresh Data (see Figure 242).

T -2 B

> @ B - & 9 @ -~

Data Insert

Figure 242. Refresh Data button

—  Press Ctrl+Shift+F5 / Shift+Cmd+F5.

Error #REF! displayed in cells if:
— When creating a reference, the external document specified in the reference is
unavailable (or the specified sheet does not exist in it), and there are no previously
A saved values for it.
— When uploading a document, there are no saved values for the external document

specified in the reference (the data was not received when creating the reference).
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4.5.11 Structured references

You can use structured references with the so-called

"smart" tables. These are

Microsoft Excel spreadsheets to which the table formatting is applied.

By default, "smart" tables are named as Table 1, Table 2 etc., and consist of the following

elements:
— Heading line

— Data area

Result line

4.5.11.1 Use structured references

Formulas with structured references do not operate with cells or range references, but with

the names of the table and columns of the table, as well as the names of table areas.

Below are examples of common and structured references.

Table 14. Reference examples

Description Regular Structured reference
reference

Reference to cell range of the Sales =SUM(B2:B8) =SUM(Tablel[Sales])
column in Table 1
Reference to the data area in Table 2 =SUM(A2:C8) =SUM(Table2[#Data])

B9 v  fx =SUM(Tablel[Sales]) C9 v fx =SUM(Table2[#Data])

A A B C
I Tiemn =| Sales [~] 1 e =|Mosmw =|Nuvgulud [~ |
2 |Oranges 42768 2 |Oranges 42768 11752
3 |Aubergines 1400, 3 |Aubergines 1400 102608
4 |Bananas 20755| 4 |Bananas 20755 69565
5 |Cookies 17850| 5 | Cookies 17850 21482
& |Pasta 26180 6 |Pasta 26120 930
7 |Pears 56606 7 |Pears 56606 13356
& |Zucchini 4884| 8 |Zucchini 4884 4230
9 | 170443 9 394490/
10 10
Figure 243. Structured reference
Structured references can be used both in the table and outside of it.
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If the formula with the structured reference is located directly in the table, you do not need
to specify the name of the table in this reference. If the table name is specified in the link for any
reason, it is automatically deleted when you enter the formula. For example, the formula
=SUM(Tablel[Sales]) will be automatically replaced with =SUM([Sales]).

If a formula with a structured reference is located outside the table, the name of the table
must be specified.

To find out the name of a table, select any cell in it. The table name will appear on
the Toolbar, under the Table section (see Figure 244).

To copy a table name, select it by clicking it.

ST

Tablel

Data Table

Figure 244. Table name

4.5.11.2 Structured reference syntax

Structured references can refer to the following table data:

Table 15. References

Reference Description

#All The whole table, including the heading line and the result line (if any)
#Headings The heading line only

#Data Data lines only

#Totals Result line only

@Column name
OR

@

OR

#This row

Cell at the intersection of the current row and the specified column (implicit
intersection).

The #This row reference will automatically change to @.

Examples of structured references can be found below.
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Table 16. Structural reference examples

Entire table Data only Headings only Results only

Table Tablel[#All] | Tablel Tablel[#Headings] | Tablel[#Totals]
Tablel

Tablel[#Data]
Column N | Tablel[[#All], | Tablel[N] Tablel[[#Headings], | Tablel[[#Totals],[N]]

[N]] [N]]

Tablel[[#Data],[N]]
Columns | Tablel[[#All], | Tablel[[N]:[M]] Tablel[[#Headings], | Tablel[[#Totals],[N]:[M]]
from [N]:[M]] [N]:[M]]
NtoM

Tablel[[#Data],[N]:[M]]

4.5.11.3 Enter a structural reference in a formula

Formulas that contain structured references are entered in standard ways.

To specify the name of a "smart table" in a formula, follow these steps:

1.

Start typing the table title. A drop-down list will show the names of all "smart" tables

that are contained in the document.

11

12 :sum{tab|
13

14 EH Table1
15

Figure 245. List of “smart” tables

2. Select the name of the desired table using the mouse or the keyboard:

— Click the table title with the left mouse button.

— Select the table title using the | and 1 keys and press Enter.

The name of the table will be entered in the formula.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

261




MyOffice

To enter the column name or a reference to the table area (for example, #Totals or @),
do the following:
1. Enter the [ (left square bracket) symbol. The drop-down list will display the column
names and the references to the table areas.
2. Select the desired element from the list using the mouse or the keyboard:
— Left-click the element name with the mouse.

— Select the element line using the | and 1 keys and press Enter.

The selected element will be added to the formula.

12

13

14 =Table1]|
15

16 i@ - This Row
L Itemn

18

19 Sales

20 #Al

21

22 #Data

23

24 #Headers
el #Totals
26

v

Figure 246. List of column names and data references

If an argument (e.g., [#Headings]) is entered correctly into a formula, it is highlighted in

color, and the table highlights the range to which it refers (for example, the heading line).
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4.5.11.4 Work with “smart” tables

"Smart" tables are displayed in the MyOffice Spreadsheet app the same way they were saved
in Microsoft Excel. For example, if the result line was disabled in Microsoft Excel, MyOffice
Spreadsheet displays the table without the result line. Enabling or disabling table areas and filtering
using the headings is not supported in MyOffice Spreadsheet.

When working with a smart table, you can perform the following operations:

— Edit column names. Column names are automatically updated in the structured references of
the table.

— Insert rows and columns between existing rows and columns (but not at the end of the table).

— Copy smart tables and paste them into the same document. Copied tables are automatically
given a unique name. In all structured references, the name of the original table is

automatically replaced by the name of the copied table.
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4.5.11.5 Calculated columns

If you want to add a column where all cells contain the same formula to a table, create
a calculated column. You can use any column in the table that does not contain data to create
a calculated column.

To make a column calculated, type the desired formula in any cell of that column and press
Enter.

All cells in the column will automatically be filled with the formula you entered.

The following rules apply to the calculated columns:

— If you edit a formula in any cell of a calculated column, the same formula editing is
automatically performed in the remaining cells of that column.

— If the data in a column is partially deleted or regular data is entered instead of a formula,
the column ceases to be calculated (formula changes cease to apply to the whole
column).

— If the column consistency is restored manually (all cells contain the same formula again),

the column becomes calculated again.
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4.5.11.6 Automatic expansion of ““smart” tables

"Smart" tables are automatically expanded when you enter data in adjacent cells located in
the column to the right of the "smart" table. If there is no result line in the table, auto-expansion is
also performed when you enter data in the adjacent cells located in the row following the last table
Tow.

Data can be entered:

— Manually. If a formula is entered in an adjacent column, that column becomes calculated

(see Section 4.5.11.5).

— From the clipboard. The automatic expansion is performed when data is inserted to
the left/bottom of the table or when data is inserted simultaneously in both the table and
adjacent cells.

— By means of automatic filling of the cells (see Section 4.4.1.4) where the reference cell

is one or multiple cells of the "smart table".

The automatic expansion of "smart" tables has the following limitations:
— The automatic expansion area should not contain any data.

— The data inserted does not overlap with another "smart" table.

The current version of the application does not support the automatic expansion of smart
tables when autofilling cells (see Section 4.4.1.4):
— If a table cell with a structured reference is selected as a reference cell.

— If a cell in the table heading line is selected as a reference cell.
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4.5.11.7 Smart tables customization

When working with several smart tables on the same sheet, you can distinguish them by

applying different styles and formatting. To do this, follow these steps:

1. Select a cell of the smart table. The [*) Smart Table section will open in the Sidebar
(see Figure 247).

= Smart Table

Table Style:
[ _[_]_]
Mone @ ——=— == ===== W
C'
Cx
Display: Alternate Colors:
Headers For rows
Total For columns

Figure 247. Smart Table pane

2. In the Table Style field, select one of the most recently used styles or click ¥ to view
all available styles in the collection. The collection contains 60 styles and 1 additional
style which is intended to reset the formatting.

3. In the Display field, enable or disable the display of the header and total.

4. In the Alternate Colors field, enable or disable alternating dark and light shades for

column and row colors.

Display and color alternation options affect both the appearance of the table

and the styles in the collection.

You can reset a style applied to a table in several ways:
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— By selecting the style intended for formatting reset. This style is labeled with the word
None in the Table Style field (see Figure 247).

— From the style collection window by clicking Clear at the bottom of this window

(see Figure 248).

Custom:

Figure 248. Clear button in the style collection
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4.6 Calculation operators

4.6.1 Arithmetic operators

Arithmetic operators (see Table 17) perform basic operations with numbers in the Number,

Date, and Time formats.

If the value cannot be converted to a number, the operation will result in an error #VALUE!.

Table 17. Arithmetic operators

Operator Meaning Example
+ Addition =6+7
- Subtraction =B12-B3
Negation -45
* Multiplication =86%*34
/ Division =36/3
A Exponentiation =D8"2
% Percentage 76%

To calculate the root of a number, use the following formula:

=M*(1/N)

where M is the number you want to find the root of, and N is the root index.

For example, this formula =36"(1/2) extracts the square root of 36.
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4.6.2 Comparison operators

Comparison operators (see Table 18) compare two values. You can compare any type of

data, including numbers, dates, and character strings.

The comparison result can either be:

— TRUE: The expression is true.
— FALSE: The expression is false.

Table 18. Comparison operators

Operator Meaning Example
= Equal to =6=6
> Greater than =9>17
< Less than =A2<C3
>= Greater than or equal to =0>=6
<= Less than or equal to =P12<=7
<> Not equal to =3<>4
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4.6.3 Text concatenation operator

The Text concatenation operator (see Table 19) combines data from text cells into one string.

Table 19. Text concatenation operator

Operator

Description

Example

&

Connects strings from two or more than
two cells to produce one continuous
sequence of characters

Cells: A2 (My) and A3
(Office)

Formula: =A2&A3
Result: MyOffice

To combine data from 3 or more cells, use a text operator before each new cell address.
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4.6.4 Reference operators

Reference operators (see Table 20) describe references to cell ranges. Use these operators to

refer to both the cells in the current sheet and cells in other sheets in the same spreadsheet.

Table 20. Reference operators

Operator Description Example

A range operator.

Creates a reference to a range of cells. The =SUM(B2:C4)

operator is placed between the first and the last (see Figure 203)

cell of the range.
=SUM(A1:B1:C4:D4) — in this

The operator can be used to combine cell example, the sum of all cells

ranges. In this case it returns the range between | between and including Al and D4

the upper left and lower right cells, including | is calculated.

these cells. (see Figure 204)

Space Intersection operator.
Creates a reference to the cells located at =SUM(A2:C4 B2:D4)
the intersection of the specified ranges. (see Figure 205)
'sheetname'! Creates a reference to a cell or range of cells in | =SUM(B2+'Sheet2''B2)

another sheet of the current document.
=SUM(B2:C4+'Sheet2''B2:C4)
(see Figure 206)

'sheetname Creates a reference to the same cell on several | =SUM('January_2019:
n:sheetname m'! | sheets of the current document December_2019'!'A1) — in this

(a 3D reference). example, the sum of all A1l cells
on all sheets within the specified
range is calculated.

When entering formulas, select the desired cell range (see Section 4.2.1) to avoid entering it

manually.
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cé v fx =SUM(B2:C4) D6 v fx =SUM(A1:BI: )

15 2 2

36

S . T I ST
—
=]

S - T ST

Figure 249. Range operator

D6 v  fx =SUM(AZ2:C4 )
A B C D

1

2 3 2 4
3 3 2 4
4 3 2 4
5 q
6 9|
7

Figure 250. Intersection operator

C6 v fx =SUM(B2:C4+ )
A B C D

1

2 1 2

3 1 2

4 1 2

3

] 18|

7

Figure 251. Operator referencing cells on another sheet
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4.7 Pivot tables

4.7.1 Create a pivot table

A pivot table is a tool that allows you to present data from an ordinary flat table in a form
that is easy to analyze.
Pivot tables allow you:
— To quickly place data from the source table columns into the pivot table columns and
rows and swap them around.
— To perform calculations.

— To filter data.

To create a pivot table, create a source table first, which is a flat table with the required data.
When preparing the source table, it is recommended to consider the following requirements:
— The columns in the source table must have headings.

— It is recommended to use data in one format within one column of the table

(see Section 4.4.3). For example, only in General format or only in Date format.

You can create a pivot table on a new sheet or on the sheet you are working on.
To create a pivot table:
1. Select one of the following elements required to create a pivot table:
— A range of data in the source table which will be used as the basis of the future pivot

table. The range of data should be selected with the column headings.

The range cannot consist of one line. The first range line cannot contain empty

cells.

— A cell on the sheet you are working on which should be inserted in the pivot table.
This cell will become the upper left cell of the table. The selected cell should not

contain any data.

It is highly recommended to leave at least two blank lines above the pivot

table for filters (see Section 4.7.3).
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2. Open the pivot table creating window in one of the following ways:

— In the Command menu, select Insert > Pivot Table (see Figure 252).

Insert Format Table Data Tools
] Image..
Text Box
) Shape »
Chart »

Pivot Table...
Function... Shift+F3

B » 5 =

Special Characters...

Link... Ctrl+K
Mote
Sheet

Current Date

M OF %

Current Time

Figure 252. Pivot table command menu

[T ]
— Onthe Toolbar, in the Insert section (see Figure 253), click the Pivot Table.

reoer B O B>
v T L I
E W @ c

Data Insert

Figure 253. Pivot table button

— On the Toolbar, in the Insert section, click *** (see Figure 254). In the displayed
insert pane, click the [[-] Pivot Table.
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]
g
0
2

™ v o Y r~ _ T (o ey
ol ~ Q)

Data @ Image... A
E] Text Box
M N ¢ & shape > Q
fx
[ﬂ] Chart ’
17 Pivot Table... &
__"L-X, Function... EY
Special Characters... >
¢%?  Link...

Figure 254. Insert pane

3. Inthe Create Pivot Table window (see Figure 255), do the following:
— If you selected a cell to insert the pivot table in the first step, specify the range of
source table data from which to create the pivot table in the Data Source field.
— If a data range was selected in the first step, specify where the table will be inserted:

e New sheet: Insert the table in a new sheet. The new sheet will be created
automatically. By default, the new sheet will be named Pivot table <No.>, where
No. is the number of the pivot table in the document you are working on.
If needed, you can edit the sheet name (see Section 4.2.2).

e Existing sheet: Insert the table on the sheet that is currently displayed on
the screen. In the Specify a destination cell box, enter the address of the cell
where you want the top left cell of the pivot table to be located. There must be at
least two blank lines above the initial cell to place filters (see Section 4.7.3).

4. Click OK.
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Create Pivot Table X

Data Source:

‘Sheet1'1AT:A2 >

Insert table to:
© New sheet

Existing sheet

Figure 255. Create Pivot Table window
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4.7.2 Open the pivot table settings pane

You can configure the pivot table by using the pane that contains the following tabs:
— Constructor: Use this tab to select the structure (layout) of the pivot table.

— Options: This tab contains the pivot table parameters.

The pivot table settings pane opens automatically when you select any cell in the pivot table
and collapses automatically when you select any cell outside the pivot table.

You can also open and collapse the pivot table settings pane manually.

If you close the pane manually, the pane will not open or close automatically until the

next time you open the application.

To collapse the pane manually, do one of the following:

— At the top of the pane, click =.

— On the Sidebar, click Pivot Table.

To open the pane manually, do the following:
1. Select the entire range or one/several cells from the range of the pivot table.
2. Open the pane in one of the following ways:

— In the Data menu, click Pivot Table Settings (see Figure 256).

Data Tools Miew Share Subscription

Define Name...
Manage Protection »

Refresh Pivot Table
Pivot Table Settings
Delete Pivot Table

Figure 256. Data menu

— On the Toolbar, in the Pivot Table section, click ‘% Pivot Table Settings
(see Figure 257).
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G Refresh @

{E‘}Se'tting; ﬂv @ |:v

Pivot Table Insert ~

Figure 257. Settings button

— On the Sidebar, click Pivot Table (see Figure 258).

BE v G Refresh 222}

i~ {5 B9 (@)~

0@ v {@} Settings
Pivot Table Insert ~
§ N = Pivot Table Q
Constructor Options Fx
fa)

Available Fields: Filters:
Date 0
Division Co
Cx

Manager

Nomenclature

Sales Columns:
Net cost
Gross profit

Rows: Values:

Figure 258. Pivot table configuration pane

— Right-click to open the context menu and run the Pivot Table Settings command.
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4.7.3 Define the structure of the pivot table

By default, a pivot table does not contain data because its structure is not defined
(see Figure 259). To define the structure, use the Constructor tab in the pivot table settings pane

(see Section 4.7.2).

A3 v X

n > Pivot Table Q

A B c D
|
1 Constructor Options fx
2 ~
3 Available Fields: Filters: i
[}
4 No fields
5 Date @
6 Grand Total
Division
7 Cv
CxX

2 Manager
&
10 Nomenclature
n Columns:
2 Sales
13 Met cost
14
15 Gross profit
16
17
18
19 Rows: Values:
20
21
2

Figure 259. Pivot Table

The Constructor tab includes the following sections:

— Available Fields: This section includes the list of all selected columns of the initial table
(the fields). To set the structure of the pivot table, add the fields from the Available
Fields section to the Rows, Columns, Values, and Filters sections (see an example in

the Figure 260).
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A3 v Xov fx
~ > Pivot Table Q
A B c D
p
1 Division (All Items) v Constructor Options x
2 ~
3 Column Labels [- ] Available Fields: Filters:
4 Bicycles
[ Row Labels B Sum of Gross profi Sum of Sales Sum of Net cost Date Division 0
6 Dobryakov 45762.711864 15254237288 106779.66102 o
7 llinskaya 892372.88136 2974576.2712 2082203.3898 cy
8 Ivanov 7627.1186441 25423.728814 17796610169
9 Okhlobystin
10 Petrov 312711.86441 1042372.8814 729661.01695
1 Siderov 716949.15254 2389830.5085 1672881.3559 Columns:
12 Grand Total 1975423.7288 6584745.7627 4609322.0339
i
:
16
7
8
L) Rows: Values:
20
~
21 Manager Sum of Gross p...
2
23 © Sum v
< > @)
No additi...
Sheet1 Pivot table 2 data Pivot table 1 + "
[ Automatic SUM 0 AVERAGE 0 MIN 0 MAX 0 COUNTA 0 [£] - 3 +00% v

Figure 260. Pivot table example

— Rows: Add the fields which will become the headings of the pivot table rows to this

section (see Figure 261).

A B C D

r|
1 Division Promotion Depz ¥ ment
2
3 Column Labels B
4 Bicycles
B Row Labels M Sum of Gross profi Sum of Sales Sum of Net cost
& Dobryakov 45762.711864 152542.37288 106779.66102
7 Okhlobystin
& Sidorowv 716949.15254 2389830.5085 1672881.3559
9 Grand Total 762711.86441 2542372.8814 1779661.0169

Figure 261. Row names

— Columns: Add the fields which will become the headings of the pivot table columns to

this section (see Figure 262).
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A B C D
|
T Division Promotion Depe T ment
2
3 Column Labels qj
4 Bicycles
LB Row Labels ﬂ Sum of Sales Sum of Net cost Sum of Gross profit
& Dobryakov 152542.37288 106779.66102 45762.711864
7 Okhlobystin
8 Sidorov 2389830.5085 1672881.3559 716949.15254
9 Grand Total 2542372.8814 1779661.0169 762711.86441
10
Figure 262. Column names
— Values: Add the fields whose values will be used for calculations to this section
(see Figure 263).
A B C D
|

1T Division Promaotion Depz ¥ ment
2
3 Column Labels B
4 Bicycles
LB Row Labels ﬂ Sum of Sales Sum of Net cost Sum of Gross profit
& Dobryakov 152542.37288 106779.66102 45762.711864
7 Okhlobystin
8 Sidorov 2389830.5085 1672881.3559 716949.15254 |
9 Grand Total 2542372.8814 1779661.0169 762711.86441

Figure 263. Values
— Filters: If necessary, add the fields that will be used to filter data in the pivot table to

this section (see Figure 264). Filters allow you to set the level of detail of the data and

change the way the table looks.
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(All ltems) A

key: By value key: By condition

Cnlumn Labels

85 ‘ Find ‘

Sum of Sales

Clear All

Bicycles
Clothes
847.45762712 Other

@ sk

Tents

847.45762712

Wood planks

Figure 264. Filter

4.7.3.1.1 Add fields

Fields from the Available Fields section can be added to the Rows and Values sections
manually or automatically. If fields are added automatically, they are allocated between the Rows
and Values areas according to the data type:

— If a field contains text values, it will be moved to the Rows section.

— If a field contains numeric values, it will be moved to the Values section.

To automatically distribute fields between the Rows and Values sections, follow these steps
for each of these fields:
1. In the Available Fields section, hover the cursor over the title of the field which needs
to be moved to the Rows or Values sections (see Figure 265).

2. Click + Add.
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Available Fields: Filters:
Date
Division
Manager

Nomenclature

[ 1 Columns:
Sales -~ ’

J

MNet cost Add

Gross profit

Figure 265. Add Button

To add fields to the Rows and Values sections manually, drag and drop them into the

appropriate sections while holding down the left mouse button, or do the following for each field:

1. Inthe Available Fields section, hover the cursor over the field which needs to be moved

to the Rows or Values sections (see Figure 266).

2. Click : More.

3. Inthe menu that appears, select the section in which you want to add the field.

Available Fields: Filters:
Date
Division
Manager
Nomenclature

[ ] Columns:
Sales + ’

Add to Filters
Add to Columns
Add to Rows

Add to Values

Values:

Rename

Figure 266. More button
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Calculated fields created in a third-party application can only be moved to the Values

section.

Adding fields from the Available Fields section to other sections is done manually, similar

to adding fields to the Rows and Values sections.

4.7.3.1.2 Moving a field from one section to another

Moving fields from one section to another is done manually, similar to adding fields from

the Available Fields section to the other section in the Constructor (see Section 4.7.3.1.1).

4.7.3.1.3 Change the field order in a section

In any section other than the Available Fields section, you can change the order of the fields

in the list. The position of the field in the list determines the position of the corresponding field in

the pivot table.

To change the position of a field relative to other fields in the list, drag it to the desired

location in the list while holding down the left mouse button, or do the following:

1. Hover the mouse cursor on the field and click : More (see Figure 267).

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

Available Fields: Filters:
Date
|‘.Division
|'.Manager
Move to Beginning
Move Up Columns:

Move Down

Move to End

Move to Values

Move to Columns
Values:

Move to Filters

|
Rename

Nomen... E

Net cost

5

Gross profit

Figure 267. More button
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2. In the drop-down menu, select the desired command:
— Move to Beginning: Move the field to the beginning of the list.
— Move Up: Swap the selected field and the previous field.
— Move Down: Swap the selected filed and the next field.
— Move to End: Move the field to the end of the list.

The drop-down menu commands depend on the position of the selected field in the list.

4.7.3.1.4 Rename a field

You can rename any field in the pivot table if needed.

You may not use formulas or functions as names, or repeat existing field names in

the pivot table.

To rename a field, follow the steps below:
1. Hover the mouse cursor on the field and click : More.
2. From the drop-down menu, select Rename.

3. Inthe Rename dialog box, specify the name of the field and click OK.

The name of the field in the Constructor tab will change. When you hover the mouse cursor

over a field, a tooltip with its current and original name will be displayed.

4.7.3.1.5 Edit the function in the Values section

The function for data calculation for a field added to the Values section is selected
automatically.
— If a field contains numeric data, the Sum function is selected.

— If a field contains text data, the Count function is selected.

To use another function for the data in this field, do the following:
1. In the Values section, expand the drop-down list of functions available for this field
(see Figure 268).

2. Select the desired function from the drop-down list.
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Constructor Options fx

——
Division v Sum

Manager Count
Nomenclature
Count Numbers

Sales =

— Average
Net cost
Gross profit Max

Min
Product
Rows: Va
Division StdDev o
Manager Sum v ‘

MNomenclature

No addition...

Met cost

Gross profit

Figure 268. List of functions

For calculated fields created in a third-party application, the Sum function is

automatically selected. No other data calculation function is available.

4.7.3.1.6 Delete a pivot table field

To delete a field from any section of the pivot table, do one of the following:

— Hover the mouse cursor over the title of this field and click [l Remove (see Figure 269).

Rows: Values:
Division |0 Sum of Division
Manager Sum A

MNomenclature No addition...

Met cost

Gross profit

Figure 269. Delete button
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— Hold down the left mouse button and drag the field from the current area to the Available

Fields section.

To delete a field from all areas of the pivot table to which it is added, do the following:

1. In the Available Fields section, hover the cursor over the title of the field
(see Figure 270).

2. Click — Remove from Pivot Table.

-» Pivot Table

Constructor Options
Available Fields: Filters:
Date
. n
‘thbn
> ;
{Manager —

‘ Nomenclature

Figure 270. Remove from Pivot Table button
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4.7.4 Customize the pivot table parameters

To configure the pivot table parameters, use the Options tab in the Pivot Table Settings pane

(see Figure 271).

- Pivot Table Q
Constructor Options fx
Data Source: & —

15

'data'lA1:G27 (] |

Q

Pivot Table Layout:

mnn
X<

Compact v

Grand Totals

Show totals:

For columns

For rows

Subtotals
Display
Location:

Under the group v

Captions:

Empty Cells @)

Figure 271. Options tab
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4.7.4.1.1 Edit data source

If you want to edit the data source of the pivot table, follow these steps:
1. Place the cursor in the Data Source box. The source table tab will open in the document
and the value in the Data Source box will be available for editing (see Figure 272).

The specified data range will be highlighted in the source table in color.

- Pivot Table

2 0O

Constructor Options
-~
(T 1
Data Source: | J]
'data'lA1:G27 (] ‘ b
Pivot Table Layout: Cv
CX
Compact v

Figure 272. Edit data source

2. Edit the value in the Data Source field and click the @ button or press Enter.

4.7.4.1.2 Select the pivot table layout

From the Pivot Table Layout drop-down list, you can select one of the following layouts:

— Compact: Data for all fields in the Rows area is displayed in the first column of the
pivot table in a hierarchical manner (see Figure 273). The greater the nesting level of a
field in the Rows area, the greater the indentation of its data in the first column of the

table. The Compact layout is used for pivot tables by default.
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Line names * Sum by Sales field
© sales Department
©@ ivanov
Bicycles 25423.728814
Ivanov Total 25423,728814
[ ] llinskaya
Bicycles 2974576.2712
Wood planks 2733050.8475
Tents 47457627119
Other 5084.7457627
llinskaya Total 5760169.4915
@ Petrov
Bicycles 1042372.8814
Wood planks 1588983.0508
Ski 1250847.4576
Tents 136440.67797
Other 847.45762712
Petrov Total 4019491.5254
Sales Department Total 9805084.7458

Figure 273. Compact layout

— Tabular: Data of each field from the Rows area is displayed in a separate column.
The column names correspond to the field names (see Figure 274). The column names

correspond to the field names.

Sum of Gross profit

Division [ - | W ELET--1d Bl Nomenclature [ Sales
o © Dobryakov © Bicycles 152,542
Bicycles Total
© clothes 135,593

Clothes Total
© wood planks 63,559
1,292,373
Wood planks Total
Dobryakov Total
© Okhlobystin @ Wood planks 508,475
Wood planks Total

Okhlobystin Total
© sidorov ] Bicycles 50,847
2,338,983
Bicycles Total
© ski 152,542
Ski Total
© Tents 100,847
106,780
Tents Total
© Wood planks 1,461,864
1,567,797

Wood planks Total
Sidorov Total

Figure 274. Tabular layout
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— Outline: Data of fields are arranged as in the Tabular layout, with each column

displaying data one row lower than the previous one (see Figure 275).

Division - WELET-C1 ﬂ Nomenclature - Sales v
o
(-] Dobryakav
(] Bicycles
152,542
Bicycles Total
© Clothes
135,593
Clothes Total
© wood planks
63,559
1,292,373
Wood planks Total
Dobryakov Total
© oOkhlobystin
© wood planks
508,475

Wood planks Total
Okhlobystin Total

Figure 275. Outline layout

4.7.4.1.3 Customize the display of grand totals

By default, the last row of the pivot table displays column totals, and the last column displays
row totals.

To hide or redisplay column grand totals, use one of the following methods:

— On the Options tab, in the Grand Totals section, uncheck or check the For columns

box (see Figure 276).
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- Pivot Table

Constructor Options

Data Source:

‘data'lA1:G27

Pivot Table Layout:

Qutline v

Grand Totals

Show totals:

For columns

For rows

Figure 276. Totals in table options

— Right-click any cell in the pivot table to open the context menu and select Show Grand
Totals (see Figure 277). In the sub-menu that opens, uncheck or check the For columns

box.

Copy Ctrl+C

Show Grand Totals » + ForColumns
+* For Rows

Print Selection...

Define Mame-...
Collapse or Expand »

Refresh Pivot Table
Pivot Table Settings
Delete Pivot Table

Figure 277. Enable/disable grand totals using the context menu

To hide or redisplay row totals, use one of the following methods:

— On the Options tab, in the Grand Totals section, uncheck or check the For rows box
(see Figure 276).

— Right-click any cell in the pivot table to open the context menu and select Show Grand
Totals (see Figure 277). In the sub-menu that opens, uncheck or check the For rows

box.
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4.7.4.1.4 Customize the display of subtotals

In the pivot table, you can:

— Display/hide subtotals for each data group.

— Change where subtotals are displayed if you selected Compact or Outline layout for the
pivot table. In a table with the Tabular layout, subtotals are always displayed under the
data group.

To hide or display subtotals, in the Subtoetals section, uncheck or check the Display box

(see Figure 278).

- Pivot Table
Constructor Options

Grand Totals

Show totals:

For columns

For rows

Subtotals
Display
Location:

Under the group v

Figure 278. Subtotals section
In the Location drop-down list (see Figure 278), select a location to display subtotals:

— Under the group: A line of Header_group Total type is displayed under each data
group (see Figure 279).
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Manager

Dobryakov Tatal

B2 Nomenclature Bl Gross profit [~ |

o Bicycles
45,763
Bicycles Total
© Clothes
33,898
Clothes Total
© wood planks
19,068
387,712

Wood planks Total

Figure 279. Subtotals under the group

— In the group title: Subtotals are displayed in rows with data group titles

(see Figure 280).

Manager B2 nomenclature Bl Sum of Net cost

Bicycles
Clothes
Wood planks

Bicycles
Other

Tents

Wood planks

Bicycles

Wood planks

Bicycles
Other

Ski

Tents

Wood planks

762.71186441

Figure 280. Subtotals in the group header

4.7.4.1.5 Edit captions

In the Captions section, you can edit the names of some columns and rows of the pivot table,

as well as specify the text that appears in empty cells or cells with errors.
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No formula or function may be used as a caption.

The Captions section contains the following boxes:

— Empty Cells: Text to display in empty cells of the pivot table.

— Errors: Text to display in cells that contain errors in calculations.

— Grand Total: The name of the row and column with the grand totals.

— Values: This field is not used in the current version of the application.

— Rows: The name of rows in the pivot table with a compact layout.

— Columns: The name of columns in the pivot table with a compact layout.

If there is no value in the field, enter a value manually and press Enter.

If there is a value in the field, delete it manually or by clicking the > button. Then enter the

desired value and press Enter.

4.7.5 Collapse or expand the elements of pivot table

You can change the level of detail in the pivot table by collapsing and expanding the content
of grouped rows and columns. For example, in the table, you can collapse rows grouped by region

of sale or by product group (see Figure 281).

Manager ﬂ Net cost n Sum of Net cost

o 44,492
101,695
106,780 106779.66102
904,661

o 1,525
3,051
13,347
22,246
587,288 587288.13559
800,847
1,112,288
1,494,915 1494915.2542

Figure 281. Example of grouping in the pivot table
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In pivot tables created or edited in LibreOffice Calc, the row/column collapse/expand

buttons and commands may be missing or may not work properly.

To collapse or expand all grouped rows or columns in the pivot table, follow these steps:
1. Open the context menu by right-clicking any cell in the pivot table and select Collapse
or Expand.

2. In the sub-menu that opens, select the desired command.

To collapse or expand a single group of rows or columns in the pivot table, do one of the
following:
— To collapse a single row/column group, click the @ button to the left of its header, to
expand it, click the ** button.
— Open the context menu by right-clicking the cell with the row/column group header and

select Collapse or Expand.

4.7.6 Refresh a pivot table

A pivot table needs to be refreshed in the following cases:

— When you work with the document, the data on which the pivot table was created has
changed in the source table.

— MyOffice Spreadsheet opens a document with a pivot table created in a third-party
editor.

— MyOffice Spreadsheet opens a document with a pivot table that contains irrelevant data.

To refresh a pivot table, follow these steps:
1. Select the entire range or one/several cells from the range of the pivot table.
2. Refresh the table in one of the following ways:

— In the Data menu, click Refresh Pivot Table (see Figure 282).

Data Tools View Share Subscription

Define Name...
Manage Protection 4

Refresh Pivot Table

Figure 282. Data menu
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— On the Toolbar, in the Pivot Table section, click GRefresh Pivot Table

(see Figure 283).

“ Refresh @ N
{g Settings M v Iﬁ @ ‘_| v ees

Pivot Table Insert

Figure 283. Update button

— Right-click to open the context menu and run the Refresh Pivot Table command.

— If you created the pivot table in a third-party application, in the Pivot Table settings
pane, on the Constructor tab, click the Update button, which is displayed below the

message: “The source data has changed. Please update to load the latest data.”

(see Figure 284).
-» Pivot Table
Constructor Options

@ Thesource data has changed. Please
refresh to load the latest data.

Update

Figure 284. Update button
— If the pivot table contains irrelevant data, in the Pivot Table settings pane, on the

Constructor tab, click the Refresh button, which is displayed below the message:

“Data may be outdated. Please refresh the pivot table.”
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4.7.7 Delete a pivot table

To delete a pivot table, do the following:

1. Select all the entire range or one or multiple cells from the pivot table range.

2. Run the delete command in one of the following ways:

— In the Command menu, select Data > Delete Pivot Table (see Figure 285).

Data Tools View Share Extensions

Define Name...
Manage Protection 4

Refresh Pivot Table
Pivot Table Settings
Delete Pivot Table

Figure 285. Data menu

— On the Toolbar, in the Pivot Table section, click @Delete Pivot Table
(see Figure 286).

G Refresh @

jollo ~ A (Q)v -
{ﬁ:fSEttings o
Pivot Table Insert ~

Figure 286. Delete Pivot Table button

— Right-click the context menu and run the Delete Pivot Table command.

— Press Delete.
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4.8 Charts

4.8.1 Insert a chart

MyOffice Spreadsheet allows you to create and edit various charts.
To create a chart, do the following:

1. Select a range to be used to create a chart.

2. Insert a chart in one of the following ways:

— In the Insert menu, select Chart (see Figure 287).

Insert Format Table Data Tools Wiew Share Subs

&1 Image... Calibri
Text Box
) Shape » B I

Chart 4
Pivot Table...
Function... Shift+F3

Column »
Bar ’
Line »
Area 4

Pie

® » &

Special Characters...

G «P 2

Link... Ctrl+K
MNote

Sheet

Current Date

Qm YFD

Current Time

Figure 287. Insert menu
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— On the Toolbar, select the Insert section and click m Chart (see Figure 288).

-
o~ {5 &4 Qv - .

V@ v
2 v @ B
Data

v

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

e (2 [EE

Bar

= [=

Line

=
[ |

Area

e [=

Pie

&

F kI [m

®

Figure 288. Chart button
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— On the Toolbar (see Figure 289),

In the displayed insert pane, click alll Chart.

v

= v

2 v (3

Data

Bar

=

Line

=

22

3
]

ER

=

PRI

& H B

® & e

N]

A

('\

@B 9

select the Insert section and click

o~ &3 B4 (@) & .

Image...
Text Box

Shape

Chart
Pivot Table...
Function...

Special Characters...

Link...
MNote

Sheet

Current Date

Current Time

Figure 289. Insert menu

3. In the opened menu, select the desired chart type.
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The new chart is placed in the middle of the visible area of a spreadsheet.
The data used to create the chart are highlighted on the spreadsheet with the colors of

the chart series (see Figure 290).

A B C D E F G H
1 |Chart1 4.2 2.4 2
2 |Chart 2 2.5 4.4 2
3 |Chart 3 3.5 1.8 3
4 |Chart4 4.5 2.8 5
5
. ¢ P P
7 5
8
¢ 4
10
11
12 3
13
14 2
is ¢ ¢
16 1
17
18 0
19 Chart 1 Chart 2 Chart 3 Chart 4
20
21
2 [ Series] [ Series? [ Series 3
23
24 I & .

Figure 290. Chart
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4.8.2 Change chart type

If you want to modify the type of the chart, select it first. On the Toolbar, select the Chart
section and click the button which corresponds to the desired type of chart:

T} Column: Click this button to transform your chart into the Column chart or change
the current type of the Column chart (see Figure 291).

Share  Subscription Help
“_I v E v e' @ Se
Il_l Column

|=_= Stacked Column

|28 100% Stacked Column

Figure 291. Column chart

_ = Bar: Click this button to transform your chart into the Bar chart or change the current
type of the Bar chart (see Figure 292).

Share  Subscription Help

e v [= v« @ Settings
1 seug e
all S TR

ar
Chart

Insert
== Stacked Bar

|=  100% Stacked Bar

Figure 292. Bar chart
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— @ Pie Chart: Click this button to transform your chart into the Pie Chart.

— |EArea: Click this button to transform your chart into the Area chart or change

the current type of the Area chart (see Figure 293).

Chart

|i_l v IE v @ &b settings
|_f>< ~ [IL;—EQ @'& Delete

IE Area
IE Stacked Area

|&  100% Stacked Area

Figure 293. Area chart
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To transform the current chart type to the Line chart or change the current Line chart type,

click thelﬁLine button and select the desired Line chart type from the drop-down list
(see Figure 294).

Line

Stacked Line

100% Stacked Line

Line with Markers

Stacked Line with Markers

RO RN R

100% Stacked Line with Markers

Figure 294. Line chart
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4.8.3 Change data range

You can change the data range used as the source data for your chart. The chart will be
updated accordingly based on the new data range.
To change a range, perform the following actions:
1. Select the chart you want to edit.
2. By holding down the left mouse button, move the corner marker of the data range that
was used to build the chart. The range corner marker can be moved in any direction:
right, left, up, down.

3. Release the left mouse button to fix the new range.

You can also modify values in the cells used as the source data for your chart. The chart will

be updated accordingly based on the new data in the chart legend.

4.8.4 Change chart size

To resize a chart, left-click it and drag the sizing handle as needed (see Figure 295):
— To change the height, use the top and bottom sizing handles.
— To change the width, use the right and left sizing handles.

— To change the height and width proportionally, use the corner sizing handles.
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® @ g
5
4
3
2

® ¢
1
o

Chart 1 Chart 2 Chart 3 Chart 4
) Series1 [ Series2 [ Series 3
i S o

Figure 295. Resize a chart

4.8.5 Move a chart

The chart can be moved in the following ways:

— Drag and drop by holding the left mouse button.

— Move strictly vertically or horizontally with the «—, 1, |, — keys on the keyboard.

When you move the chart with <, 1, |, — keys, the chart movement step depends on
the document scale:

— If the scale is < 200%, the step = 4 mm.

— If the scale is > 200%, the step = 1 mm.

To increase the step, move the chart using the <, 1, | key while holding the Shift key
pressed. In this case the movement step will be equal:

— If the scale < 200%, the step = 4 cm.

— If the scale > 200%, the step = 1 cm.
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4.8.6 Customize a chart

To customize your chart, use the following guidelines:
1. Select the chart you want to customize.

2. Open the Chart Settings window in one of the following ways:

— On the Toolbar, select the Chart section and click i Settings (see Figure 296).

— Right-click the chart and select Chart Settings in the context menu.

Share Subscription Help
e v |= v @ {@} Settings
\z v |E v @b Delete

Chart

Figure 296. Settings button

The opened Chart Settings displays the following menus (see Figure 297):

Chart Settings b4

Range:

M8:N12 X K

Title:

Data Series:

© Columns Rows

Labels:
In the first row

In the first column

Figure 297. Chart Settings window
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— Range: Change the chart data range.
— Title: Specify the chart title.
— Data Series: Specify the way the initial data is plotted in a chart (by columns or rows).

— Labels: Specify the position of chart labels (first column and/or first row).
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4.8.7 Copy, cut or insert a chart

You can copy or cut and paste a chart:
— Within one MyOffice Spreadsheet document.

— Into another MyOffice Spreadsheet document: the chart is inserted without the data

it is based on.

— Into MyOffice Text document or MyOffice Presentation: the chart is inserted as

an image.
You can cut, copy and paste using standard methods.

4.8.8 Delete a chart

To delete a chart, do the following:
1. Select the chart.

2. Delete a chart in one of the following ways:

— On the Toolbar, select the Chart section and click Mﬁ Delete (see Figure 298).

Share  Subscription Help
|l_lv E v e @Settings

|ﬁ v \E v ||l"b Delete

Chart

Figure 298. Delete button

— Right-click the chart and click Delete Chart (see Figure 296).

— Press Delete or Backspace.
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4.9 Images

You can insert the following images to a document:

— From your computer.

— From Google Chrome, Firefox, Internet Explorer, and Microsoft Edge browser.

— From the text and spreadsheet editors that are a part of the Microsoft Office and

LibreOffice suites.

The supported image formats include .png, .bmp, .jpg, .jpeg, .jpe, .gif, .tiff, and .tif.
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4.9.1 Insert an image

4.9.1.1 Insert an image from your computer

To insert an image from a computer, follow the steps below:

1. Place your cursor where you want to insert the image.

2. Insert an image in one of the following ways:

— In the Insert menu, select Image (see Figure 299).

— On the Toolbar, select the Insert section (see Figure 300) and click @ Image.

! [ <]
> v 3
Data

b4

Insert  Format Table Data Tools

[
o

allo
id

2]

@m 9F %

Image...
Text Box

Shape r

Chart k
Pivot Table...
Function... Shift+F3

Special Characters...

Link... Ctrl+K
Mote
Sheet

Current Date

Current Time

B v &
i

Figure 299. Insert menu

oo~ {5 |

Insert

Figure 300. Insert menu
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— Onthe Toolbar, select the Insert section and click =*+. In the displayed pane, click [ Image

(see Figure 301).

— E‘é v =
Z v @ [
Data
W N

3. In the file manager window, select the image you want to insert and click Open.
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Figure 301. Insert pane
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4.9.1.2 Insert an image from the browser or another application

To insert an image from the browser or another application, follow the steps below:
1. Copy the image from the source.

2. Place your cursor where you want to insert the image.

3. Insert the image in one of the following ways:

— In the Edit menu, select Paste (see Figure 302).

Edit Insert Format Table Data Tools

3 Undo Ctrl+Z

" Redo Ctrl+Y

& Cut Ctrl+X

Copy Ctrl+C

[ Paste Cirl+V
Paste Value Cri+Alt+V
Paste without Fermatting

£ Copy Formatting Ctrl+5Shift=C
Paste Formatting Ctrl+Shift+V
Select All Ctrl+A

0 Find Ctrl+F

Figure 302. Edit menu

— On the Toolbar, select the Edit section and click I Paste. In the drop-down list,
select Paste (see Figure 303).

Data Tools View Share Subscription

% XO Thames ~
[E Paste I~

Paste Values and Format

Paste Values Only

Figure 303. Paste button

— Right-click and select Paste from the context menu.

—  Press Ctrl+V / Cmd+V.
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4.9.2 Resize an image

You can resize the image proportionally or according to your preferences.

To resize an image proportionally, follow the steps below:

1. Select the image you want to resize.

2. Drag a corner handle while keeping the left mouse button pressed until the image is
the size you want (see Figure 304).

3. Release the left mouse button to fix the selected size.

Figure 304. Resize an image proportionally

To resize an image without keeping its proportions, follow the steps below:
1. Select the image you want to resize.
2. Drag a side handle while keeping the left mouse button pressed:
— To change the height of the image, move the top or bottom handle.
— To change the width of the image, move the left or right handle.

3. Release the left mouse button to fix the selected size.

Figure 305. Resize an image without keeping its proportions
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4.9.3 Move an image

The image can be moved in the following ways:

— Drag it by holding the left mouse button.

— Move strictly vertically or horizontally with the «, 1, |, — keys.

When you move the image with «—, 1, |, — keys, the movement step depends on
the document scale:

— If the scale is < 200%, the step = 4 mm.

— If zoom is > 200%, the step = 1 mm.

To increase a step, move the image with keys «—, 1, |, —, holding the Shift key pressed.
In this case the movement step will be equal to the following:

— If scale is < 200%, the step = 4 cm.

— If scale > 200%, the step = 1 cm.
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4.9.4 Save an image

The image from the document can be saved on your computer.
Follow these steps:

1. Select an image.

2. Run the save command in one of the following ways:

— Select Format > Save Image (see Figure 306).

Format Table Data

. Font 4
Alignment ’
i Rotate Text »

Mumber Format...

Print Area L4

Save Image...

Figure 306. Save Image Command menu option
— Open the context menu by right-clicking and run the Save Image command.
3. Inthe file manager window, select the folder to save the file to, specify the file name and

click Save.

The image is saved in the original size.

If an image has been cropped in a document using a third-party application, it is saved

in its original (pre-crop) form.
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4.9.5 Delete an image

To delete an image, do the following:
1. Select the image that you want to delete.
2. Select a command to delete an image in one of the following ways:

— On the Toolbar, under the Image section (see Figure 307), click ~# Delete Image.

Insert Format Table Data Tools View Share Sub
v e I £
= v S C )

File Edit Image

Figure 307. Delete Image button

— Right-click the image and select Delete Image from the context menu.

— Press Delete or Backspace.
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4.10 Shapes

You can add the following types of shapes to your documents: line, rectangle, ellipse,

triangle, diamond, folded corner, star, heart, brackets, arrows, callouts, or text field.

4.10.1 Insert a line

To insert a line into a document, do the following:
1. Open the Insert sub-menu using one of the following methods:

— In the Command menu, select Insert > Shape > Lines (see Figure 308).

Insert Format Table Data Tools View Share Subscription Help

Image...

& % XO Thames v 12 v
Text Box A
G Shape » / Lines » / Line
iy Chart y | Rectangle 7 Arrow
Pivot Table... O Ellipse /' Double Arrow
# Function... Shiftepz | LS Tangle . :
Special Characters... < Diamend
[} Folded Corner
¢ Link... Ctrl+K ¥7 Star
D Note <7 Heart
() Sheet [ ] Brackets 3
5] Current Date > Arrows ’
(O Current Time [1 Callouts 3

Figure 308. Insert menu

— On the Toolbar, in the Insert section, click ===. In the insert pane that appears, hover

the mouse cursor over the () Shape button (see Figure 309).
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L
& v v ? == LE\V N
- e blo v B &4 (@)~ &=

®. . Y3 =

Data @ Image... ~
Text Box
M Lines @ Shape > Q
fx
S S oy Chart >
Basic 7 Pivot Table.. @
jgﬂ Function... Cv
C
0O A O D "
Special Characters... >
ﬁ Q ¢ Link..
Brackets % Note
[ ] { } D Sheet
Arrows @ Current Date
‘::> <:: ﬁ @ [}D ® Current Time
Fod & D
Callouts

Figure 309. Insert pane

2. In the sub-menu that opens, select the type of line to insert: line, arrow, double-sided
arrow. The cursor will look like a crosshair .
3. If needed, select the arrow type (see Section 4.10.10).
4. Add a line in one of the following ways:
— Click the left mouse button on the place where the line start point should be located.
A line with a length of 4.24 cm and an angle of 45° will be added to the document.
— Hold down the left mouse button and draw a line in the desired location of
the document. To finish drawing, release the left mouse button.

5. If needed, edit the length and the angle of the line (see Section 4.10.9).
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4.10.2 Insert a shape

To insert a shape, do the following:
1. Select the position on the sheet where you want to insert a shape.
2. Display the list of shapes in one of the following ways:
— In the Insert menu, select Shape (see Figure 308).
— On the Toolbar, select the Insert section and click “**. In the displayed pane,
click ) Shape (see Figure 309).

3. Inthe opened sub-menu, select the desired shape.

You can add text or a link to a shape.
Follow these steps:
1. Double-click the shape to enter the editing mode.
2. Add text or a link to the shape:
— Enter the text manually. The text can be formatted in the same manner as you would

format the main text in the document.

=T - - RS R W, B S FE B (% R

Figure 310. Entering text

— Add a link to the shape as described in Section 4.4.6.1.
3. Click anywhere outside the shape to leave the editing mode.

Editing mode is not currently supported for shapes turned at a custom angle in third-

party spreadsheet editors.
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4.10.3 Insert a text box

A text box is framed text that can be moved and placed anywhere on the current sheet.
To insert a text box, do the following:

1. Select the place on the sheet where you want to insert a text box.

2. Select the insert command in one of the following ways:

— In the Insert menu, select Text Box (see Figure 311).

Insert  Format Table Data

Image...
Text Box

Figure 311. Insert command menu

— On the Toolbar, select the Insert section and click === (see Figure 312).

In the displayed pane, click [Z] Text Box.
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Figure 312. Text Box button

3. Enter the desired text in the text box. If necessary, you can add a link to the text
(see Section 4.4.3.1). Formatting the text in the text field is similar to formatting
the main text of the document.

4. To deselect a text box, click anywhere on the sheet outside the text box.
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4.10.4 Fill a shape

You can fill the inner area of a shape, except lines, with colors or images.

4.10.4.1 Fill a shape with color

To fill a shape with color, follow these steps:
1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. To fill the shape with the last color used to fill it earlier, on the Toolbar, in the Shape

section, click the ﬁ Fill Color button (see Figure 313).
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Figure 313. Fill Color button and color selection pane

3. To fill the shape with a different color, click the arrow to the right of the 2, Fill Color
button.

4. In the color selection pane that opens, specify the fill color of the shape in one of the
following ways:
— Choose a color from one of the color sets provided.
— Specify the color code manually.

— Copy the color with an eyedropper.
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4.10.4.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 313):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The shape will be filled with the selected color.

4.10.4.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code
manually:
1. Click More Colors (see Figure 313).
2. In the Select Color window (see Figure 314) that appears, specify the desired color as a
HEX code or in RGB format.
3. Click OK.

The manually specified color will be added to the Recent Colors set (see Figure 313) and

checked. The color selection pane will close. The shape will be filled with the selected color.
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Hex: Preview:

Red: Green: Blue:

79 129 189

Figure 314. Select Color window

4.10.4.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in
the main window's workspace (see Section 3.6) and filling the shape with this color.

To copy a color using the eyedropper, follow these steps:

1. Click ¢ Eyedropper (see Figure 313). The color selection pane will close, and
the cursor will look like a crosshair for color selection.

2. Hover the cursor over the color you want to fill the shape with. For more accurate color
selection, refer to the area to the right of the cursor. It displays the color of the pixel that
the cursor is currently hovering over.

3. Left-click the color.

The shape will be filled with the specified color, and the cursor returns to its standard
appearance. The specified color is added to the Recent Colors set (see Figure 313) and checked in
the color selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.
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4.10.4.2 Filling a shape with image

To fill a shape with an image, follow these steps:

1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. On the Toolbar, select the Shape section and click the arrow to the right of

the 3 Fill Color button (see Figure 315).

3. In the color selection pane, in the Image block, click Choose.
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Figure 315. Choose button

4. Inthe File manager window, select the desired image and click Open.
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4.10.4.3 Remove the fill color

To remove the shape fill, follow the steps below:
1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. On the Toolbar, select the Shape section and click the arrow to the right of

the 3 Fill Color button (see Figure 316).

3. In the color selection pane, click No Fill.
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Figure 316. No Fill button

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 327



MyOffice

4.10.5 Shape outline

You can define the color, thickness, and outline type for the shape.

4.10.5.1 Set shape outline

To select the color of the shape outline, follow the steps below:

1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. On the Toolbar, select the Shape section and click the arrow to the right of the
E Outline button (see Figure 317).

3. Inthe color selection pane that opens, specify the color of the shape outline in one of the
following ways:
— Choose a color from one of the color sets provided.

— Specify the color code manually.

— Copy the color with an eyedropper.

T v L FillColor v [1] Autofit () 0
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Line Weight: 0.25pt 3

Figure 317. Outline button and color selection pane
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4.10.5.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 317):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The shape outline will be colored in the selected color.

4.10.5.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code
manually:
1. Click More Colors (see Figure 317).
2. In the Select Color window (see Figure 318) that appears, specify the desired color as a
HEX code or in RGB format.
3. Click OK.

Select Color X

Hex: Preview:

o |

Green: Blue:

55 . 96 . 146

Figure 318. Select Color window
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The manually specified color will be added to the Recent Colors set (see Figure 317) and

checked. The color selection pane will close. The shape outline will be colored in the selected color.

4.10.5.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in
the main window's workspace (see Section 3.6) and apply that color to the shape outline.

To copy a color using the eyedropper, follow these steps:

1. Click ¢ Eyedropper (see Figure 317). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color you want to color the shape outline. For more accurate
color selection, refer to the area to the right of the cursor. It displays the color of the pixel
that the cursor is currently hovering over.

3. Left-click the color.

The shape outline is colored in the selected color, and the cursor returns to its standard
appearance. The specified color is added to the Recent Colors (see Figure 317) set and checked in
the color selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.10.5.2 Select the thickness and line type of the shape outline

To specify the thickness and type of a line for a shape outline, follow the steps below:

1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. On the Toolbar, select the Shape section and click the arrow to the right of the
E Outline button (see Figure 317).

3. In the Line Weight field, select the desired outline thickness manually or using the
buttons.

4. Select the outline line type from the preset values.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 330



MyOffice

4.10.5.3 Apply outline settings of the previous shape

To quickly apply the previous shape's outline settings to a shape, follow these steps:

1. Single-click to select a shape or double-click to select a shape to enter its editing mode.

2. On the Toolbar, in the Shape section, click &= Outline (see Figure 319).

£ FillColor v [1] Autofit ()

=) Qutline

Shape

Figure 319. Outline button

4.10.5.4 Delete shape outline

To delete the outline of a shape, follow the steps below:
1. Single-click to select a shape or double-click to select a shape to enter its editing mode.
2. On the Toolbar, select the Shape section and click the arrow to the right of the

a= Outline button (see Figure 320).

3. Inthe color selection pane, click No Outline.
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Figure 320. No Outline button
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4.10.6 Line style

You can define the color, thickness, and outline type for the line.

4.10.6.1 Select a line color

To select a line color, follow these steps:

1. Select the line.

2. On the Toolbar, select the Line section and click the arrow to the right of
the E Line Style button (see Figure 321).

3. Inthe color selection pane that opens, specify the line color in one of the following ways:
— Choose a color from one of the color sets provided.

— Specify the color code manually.

— Copy the color with an eyedropper.

r_./'j Arrow Type /ti

== LineStyle

No Outline

Therne Colors:

Standard Colors:

0 ]

Recent Colors:

More Colors... ﬁ

Line Weight: 0.25pt

Figure 321. Line Style button and color selection pane
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4.10.6.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 321):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The line will be colored in the selected color.

4.10.6.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:

1. Click More Colors (see Figure 321).

2. In the Select Color window (see Figure 322) that appears, specify the desired color as a
HEX code or in RGB format.

3. Click OK.

Select Color X

Hex: Preview:

o

Red: Green: Blue:

55 9 . 146

Figure 322. Select Color window
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The manually specified color will be added to the Recent Colors set (see Figure 321) and

checked. The color selection pane will close. The line will be colored in the selected color.

4.10.6.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in
the main window's workspace (see Section 3.6) and apply that color to the line outline.

To copy a color using the eyedropper, follow these steps:

1. Click ¢ Eyedropper (see Figure 321). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color you want to color the line. For more accurate color
selection, refer to the area to the right of the cursor. It displays the color of the pixel that
the cursor is currently hovering over.

3. Left-click the color.

The line is colored in the selected color, and the cursor returns to its standard appearance.
The specified color is added to the Recent Colors set (see Figure 321) and checked in the color
selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.10.6.2 Select the thickness and line type

To specify the line thickness and type, follow these steps:
1. Select the line.

2. On the Toolbar, select the Line section and click the arrow to the right of

3. In the Line Weight section, select the desired line thickness manually or using
the buttons.

4. Select the line type from the preset values.
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4.10.6.3 Apply the style of the previous line

To quickly apply a previous line style to a line, follow these steps:

1. Select the line.

2. On the Toolbar, in the Line section, click == Line Style (see Figure 323).

Share Subscription Help
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Figure 323. Line Style button

4.10.6.4 Delete the line style

If necessary, you can delete the line style settings. To do this, follow these steps:
1. Select the line.

2. On the Toolbar, select the Line section and click the arrow to the right of

3. In the color selection pane, click No Outline.
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Figure 324. No Outline button
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4.10.7 Resize a shape

You can resize the height and the width of a shape proportionally or according to your
preferences.
To resize a shape proportionally, follow the steps below:
1. Select the shape you want to resize.
2. Drag a corner handle while keeping the left mouse button pressed until the shape is
the size you want (see Figure 325).

3. Release the left mouse button to fix the selected size.

%
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Figure 325. Resize a shape proportionally
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To resize a shape without keeping its proportions, follow the steps below:

1. Select the shape you want to resize.

2. Drag a side handle while keeping the left mouse button (see Figure 326):

— To change the height of the shape, move the top or bottom handle.
— To change the width of the shape, move the left or right handle.

3. Release the left mouse button to fix the selected size.
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Figure 326. Resize a shape without keeping its proportions
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4.10.8 Fit shape size to text

You can fit the shape height to match the text inside this shape.
To do this:

1. Select the shape.
2. On the Toolbar, select the Shape section (see Figure 327) and click (2] Autofit.

The button will change to :

O Fill Color v Autofit| (3

= Qutline w

Shape

Figure 327. Autofit button

To cancel the autofit, perform the same procedure once again.
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4.10.9 Change line length and angle

To change the length or angle of a line, follow these steps:

1.

2
3.
4

Select the line.
Move the cursor over a line start or end marker so that the cursor appears as follows .

Hold down the left mouse button and drag the marker to the desired location.

. Release the left mouse button.

If necessary, you can stop moving the marker by pressing Esc. The marker will return to its

original position.

4.10.10 Select arrow type

You can select the tip type for the beginning and end of the line. The selection can be made either

before drawing the line (see Section 4.10.1) or when editing the drawn line.

To select the arrow type, do the following:

1.
2.

On the Toolbar, in the Line section, click " Arrow Type (see Figure 328).

Select the left and/or right tip type from the drop-down list. If you want to remove
previously selected tips, select the left and/or right tip type — None in the first line of
the drop-down list.

Click the =" Arrow Type button once again to close the drop-down list.
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Figure 328. Arrow Type button
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4.10.11 Move a shape

The shape can be moved in the following ways:

— Drag the shape by holding the left mouse button.

— Move the shape strictly vertically or horizontally with the <, 1, |, — keys on

the keyboard.

When you move a shape with <, 1, |, — keys, the movement step depends on the document
scale:

— If the scale is < 200%, the step = 4 mm.

— If the scale is > 200%, the step = 1 mm.

To increase a step, move the figure with keys «, 1, |, —, holding the Shift key pressed.
In this case the movement step will be as follows:

— If the scale is < 200%, the step = 4 cm.

— If the scale is > 200%, the step = 1 cm.
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4.10.12 Delete a shape

To delete a shape, follow these steps:

1. Select the shape you want to delete.

2. Delete the shape using one of the following methods:

— If you selected a line, on the Toolbar, select the Line section and

click /n Delete Line (see Figure 329). If you want to delete a shape other than

the line, on the Toolbar, select the Shape section, click @Delete Shape

(see Figure 330).
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Figure 329. Delete Line button

£ FillColor v [1] Autofit | ()

=5 Qutling w

Shape

Figure 330. Delete Shape button

Right-click the shape and select Delete Line/Delete Shape in the context menu.

— Press Delete or Backspace.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 341



MyOffice

4.11 Format spreadsheets

When files are created, the standard formatting is applied to their elements. To change
the default formatting, select the respective commands and run them. If you want to modify

the existing file, you need to select the fragment you want to apply the new formatting to first.

4.11.1 Font

By default, when creating a document in MyOffice Spreadsheet, the XO Thames font is used.
To quickly change the font, follow these steps:
1. Specify the text for which you want to change the font:
— To change the font for all the text located in a cell, select this cell.
— To change the font for a text fragment located in a cell, switch to the cell editing
mode and select this fragment.
— To change the font in one word, switch to the cell editing mode and place the cursor
on this word or select it entirely.
2. On the Toolbar, in the Font section (see Figure 331), click on the field with the name of
the current font.
3. Start typing the name of the desired font. The drop-down list will display a list of fonts
that match the search criteria.
4. Select the desired font using the mouse or keyboard keys:
— Left-click the font name.

— Select the font name using the keyboard keys | and 1 and press Enter.

Share Subscription Help
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Figure 331. Font search

To select a font from the full list of fonts, follow these steps:

1. Specify the text for which you want to change the font as described above.
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2. On the Toolbar, in the Font section, click the arrow * to the right of the name of
the current font (see Figure 332).

3. In the drop-down list, select the desired font using the mouse or keyboard keys:
— Left-click the font name.

— Select the font name using the keyboard keys | and 1 and press Enter.

Share Subscription Help
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Figure 332. Full list of fonts

It is recommended to use the fonts of the XO family in order to preserve the formatting of

the document when it is opened in other operating systems.
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4.11.2 Font size

To change the font size, do as follows:
1. On the Toolbar, select the Font section and click the arrow + to the right of the current
font name (see Figure 333).

2. Inthe opened list, select the desired font size.

Share Subscription Help
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Figure 333. Selecting the font size

You can also type in any size you want. Simply follow these steps:

1. On the Toolbar, select the Font section and select the current font size.

2. Enter the desired size. Use a dot (.) as thedelimiter for fractional value.
For example, 21.5

3. Press Enter.
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To increase the font size by one point, follow the steps below:

— In the Format menu, select Font and then select Increase Font Size (see Figure 334).

Format Table Data Tools View Share Subscription Help

Font * B Bold Ctrl+B
Alignment » T Italic Ctrl+
Rotate Text * U Underline Ctrl+U

Mumber Format...
Print Area g

A~ Decrease Font Size

A*Y Increase Font Size

Figure 334. Increase and Decrease Font Size options

— On theToolbar, select theFont section (see Figure 335) and click

AT Increase Font Size.

File Edit Insert Format Table Data Tools WView Share Subscription Help

+ v (><) XO Thames v 12 vl|AT AT
Add =Y B T UMT « Av £
Favorites File Edit Font

Figure 335. Buttons to increase and decrease the font size

To decrease the font size by one point, follow the steps below:
— In the Format menu, select Font and then select Decrease Font Size (see Figure 334).

— On the Toolbar, select the Font section and click A Decrease Font Size

(see Figure 335).
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4.11.3 Text formatting

Text formatting within a cell in MyOffice Spreadsheet allows you to distinguish different

parts of your text and make the data on your spreadsheets more visible.

The table below shows the text formatting options with the corresponding commands and

toolbar buttons.

Table 21. Text formatting

Text formatting Command menu Toolbar button, Keyboard Keyboard
Font section shortcut shortcut
(Windows) (macOS)
Bold Format > Font > B Ctrl+B % Ctrl+B
Bold
Italic Format > Font > T Ctrl+I #Ctrl+]
Italic
Underline Format > Font > U Ctrl+U 8 Ctrl+U
Underline —
ALL CAPS Format > Font > AB Ctrl+Shift+A {Shift+3 Cmd+A
All Caps
. Format > Font > _—
& Strikethrough B - -
Subscript S1gN Format > Font > I Ctrl+= FHCmd+=
Subscript
Superscript sign Format > Font > sen > W Ctrl+Shift+= fShift+ 38 Cmd+=
Superscript
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4.11.4 Font color

To change the font color of text, follow these steps:

1. Specify the text for which you want to change the font color:

— To change the font color for all the text located in a cell, select that cell or select all

text in that cell.

— To change the font color for a text fragment located in a cell, switch to the cell editing

mode and select this fragment.

— To change the font color in one word, switch to the cell editing mode and place the

cursor on this word or select it entirely.

2. To select the last color that was applied to the font, on the Toolbar, select the Font section and

click i Text Color (see Figure 336).

3. To select a different font color, click the arrow to the right of the i Text Color button.
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Figure 336. Text Color button and color selection pane

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

347



MyOffice

4. Inthe color selection pane that opens, specify the font color in one of the following ways:
— Choose a color from one of the color sets provided.
— Specity the color code manually.

— Copy the color with an eyedropper.

4.11.4.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 336):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The font of the text will be colored in the selected color.

4.11.4.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code
manually:
1. Click More Colors (see Figure 336).
2. In the Select Color window (see Figure 337) that appears, specify the desired color as a
HEX code or in RGB format.
3. Click OK.

The manually specified color will be added to the Recent Colors set (see Figure 336) and
checked. The color selection pane will close. The font of the text will be colored in the selected

color.
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Figure 337. Select Color window

4.11.4.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in

the main window's workspace (see Section 3.6) and apply that color to the font of the selected text.

The eyedropper is disabled when working with notes (see Section 4.4.7).

To copy a color using the eyedropper, follow these steps:

1. Click & Eyedropper (see Figure 336). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color you want to apply to the selected text. For more accurate
color selection, refer to the area to the right of the cursor. It displays the color of the pixel
that the cursor is currently hovering over.

3. Left-click the color.

The font of the selected text is colored in the specified color, and the cursor returns to its
standard appearance. The specified color is added to the Recent Colors set (see Figure 336) and
checked in the color selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.
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4.11.5 Highlight color

When you are working on a document, you can highlight certain portions of text in different

colors (as if they were highlighted with a marker) to make them more prominent against the rest of

the document.
To highlight text in color, do the following
1. Specify the desired text:
— To color the entire text in a cell, select the cell.

— To color a piece of text located in a cell, switch to the cell editing mode and select

that piece of text.

— To color a single word, switch to cell editing mode and place the cursor on that word

or select the entire word.

2. To select the last color you used to highlight text earlier, on the Toolbar, in the Font

section, click © Highlight Color (see Figure 338).

3. To select a different color for text highlighting, on the Toolbar, in the Font section, click

the arrow to the right of £ Highlight Color.

Subscription  Help

12 v AT AF = General

AvEYM L vy § %

ber Forr

lll v IIII '

Recent Colors:

m

No Color

Figure 338. Highlight color selection

4. Select the desired color in the provided palette or in the Recent Colors section. This
block is displayed if at least one color from the palette was previously used to highlight

text. The block can display a total of one to eight of the most recently used colors.
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The selected color will be checked, and the text will be highlighted in this color.

To remove the highlighting of the text, perform the following actions:
1. Select the text that you want to remove highlighting from.

2. On the Toolbar, select the Font section and click the arrow to theright of

the £ Highlight Color button (see Figure 338).

3. In the window that opens, select No Color.
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4.11.6 Alignment

Data in cells can be aligned horizontally and vertically.

To align data horizontally, use one of the commands described in the table below.

Table 22. Horizontal alignment

Position in cell Command menu Toolbar button, Keyboard Keyboard
Alignment shortcut shortcut
section (Windows) (macOS)

Align left Format > Alignment > = Ctrl+L »Ctrl+L
Left

Center Format > Alignment > = Ctrl+E % Ctrl+E
Center

Align right Format > Alignment > = Ctrl+R 2 Ctrl+R
Right

Justify Format > Alignment > = Ctrl+J e Ctrl+J
Justify

To align data vertically, use one of the commands described in the table below:

Table 23. Vertical alignment

Position in cell Command menu Toolbar button in
the Alignment
section
Align to Top Format > Alignment > Top T
Align to Middle Format > Alignment > Middle %
Align to Bottom Format > Alignment > Bottom R
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4.11.7 Rotate text

Text in cells can be rotated by any angle ranging from —90 to 90 degrees.

You can specify the rotation angle using the Command menu or the Toolbar.
To specify the rotation angle using the Command menu, do as follows:

1. Select the row/column or the cell/cell range you want to rotate the text in.

2. Inthe Command menu, select Format and then Text rotation (see Figure 339).

Format Table Data Tools View Share Subscription Help

C
Font ames v (12 v AT AT
Alignment 3
Rotate Text ¥ AEB None (0°) i v £«
Number Format... <[ Rotate Left 90°
Print Area » l%& Rotate Right 90°

1A Vertical Text
Save Image... F

v Rotate Left 45°
J¢ Rotate Right 45°

m—

Custom Angle ’ 80°
75°

45°
30°
15°

-15°

Figure 339. Format menu
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3. In the opened sub-menu, do the following:
— To rotate the text, select the desired rotation angle from the list of preset values.

— To position the text vertically, run the Vertical Text command.

To rotate text or change the orientation of text using the Toolbar, follow these steps:

1. Select the row/column, cell range, or cell in which the desired text is located.

2
2. On the Toolbar, in the Alignment section, click ¥ Rotate Text (see Figure 340).

- AT = = = = General v
£ v i v V‘%}}'V 5 $ ofﬂ 00 _']_:]
Alignmen
ﬂ% MNone (07)

QT Rotate Left 90°
|&  Rotate Right 90°
LA Vertical Text
vf% Rotate Left 45°

J6  Rotate Right 45°

Custom Angle = 0° v

Figure 340. Rotate Text button

1. In the opened sub-menu, do the following:
— To rotate the text by 45° or 90° to the left or right, run the corresponding command.
— To specify a different angle of rotation, enter the desired value manually in
the Custom Angle field or click the ~ button and select a value from the drop-down
list.

— To position the text vertically, select Vertical Text.

The rotation or orientation applies to all text in a cell. You cannot have multiple pieces

of text with different rotation angles or orientations in the same cell.
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To return to the default text display (horizontal position, 0° angle), follow these steps:
1. Select the row/column, cell range, or cell in which the desired text is located.
2. Run the command in one of the following ways:

— In the Command menu, select Format > Rotate Text > None (0°) (see Figure 339).

)
— On the Toolbar, in the Alignment section, click ¥ Rotate Text. In the opened

sub-menu, select None (0°) (see Figure 340).
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4.11.8 Wrap text

In MyOffice Spreadsheet, you can wrap text within cells to make it easier to view and edit.

By default, the text in a cell is on one line. If the cell contains a large piece of text, specify
that the text in that cell should be word-for-word. The application will place the text on multiple
lines, taking into account the width of the column in which the cell is located. If you change
the width of the column, the text in the cell will be moved again.

To wrap text, do the following:

1. Select the row/column, cell range, or cell in which you want to wrap text.

2. Run the Wrap Text command in one of the following ways:

— In the Table menu, select Wrap Text (see Figure 341).

Table Data Tools View Share Subscription Help

TR Insert Row Above Alt+A
& Insert Row Below Alt+B

Insert Column to the Left Alt+L
Insert Column to the Right Alt+R

b

E

@ Delete Row

ffl Delete Column
Hide Row
Unhide Row
Hide Calumn

Unhide Column

bEed Merge Cells Ctrl+Alt+M
EH Unmerge Cells Alt+Shift+M
Cell Size...

Wrap Text

Figure 341. Wrap Text command menu option
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— On the Toolbar, select the Alignment section and click o Wrap Text

(see Figure 342).
= = = = General v
i v \‘??f; ~ E, $ ':yn 00 _DI:):I
Alignment Mumber Format

Figure 342. Alignment section

To unwrap the text, run one of above commands again.
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4.11.9 Character spacing

The character spacing is a distance between the characters in the text. You can choose

between Condensed, Normal and Expanded character spacing.

The examples of various character spacings are shown in Figure 343.

F G H I ] K
Condensed character spacing 1234567890
Normal character spacing 1234567890
Expanded character spacing 1234567890

Figure 343. Character spacing examples

The type of character spacing can be selected using the Command menu or the Toolbar.

To change the character spacing using the Command menu, follow these steps:

1.

Select the text or cell in which you want to change the character spacing:

— If you want to change the character spacing for a single word, select or place
the cursor in the word.

— If you want to change the character spacing for part of the text in a cell, select
the text.

— If you want to change the character spacing for text located in one or more cells,
select those cells.

— If the character spacing needs to be changed for text located in one or more
rows/columns, select the rows/columns.

In the Format menu, select Font > Character Spacing (see Figure 344).

In the opened sub-menu, select the desired character spacing type.
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Format Table Data Tools

Font * B
Alignment YT
Rotate Text LY
Number Format... A
Print Area » A
Save Image... .
}{2
Xa
AB

View Share

Bold
Italic

Underline

Decrease Font Size

Increase Font Size

Strikethrough
Superscript
Subscript

All Caps

Character Spacing

Subscription  Help

Ctrl+B -
Ctrl+l
Ctrl+U

Ctrl+Shift+=
Ctrl+=

Ctrl+Shift+A

» AB Condensed

AR Normal

AB  Expanded

Figure 344. Format menu

To change the character spacing using the Toolbar, do the following:

1. Select the text or cells where you want to change the character spacing as described

above.

2. Inthe Toolbar, select the Font section and click the *** button (see Figure 345).

3. Select the desired character spacing type:

A : Condensed
B : Normal

2B, Expanded

B I

KO Thames

U AB

fort X, X* 48

v AT AT
Av £

Figure 345. Select the character spacing
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4.11.10 Cell fill color

4.11.10.1 Add the fill color to table cells

To fill cells with color, follow these steps:
1. Select the cell or range of cells whose fill color you want to change.

2. To color cells with the last color used for the cells fill earlier, on the Toolbar, in the Cells
section, click i Fill Color (see Figure 346).

3. To fill the cells with a different color, click the arrow to the right of the E Fill Color
button.

4. In the color selection pane that opens, specify the cells fill color in one of the following
ways:
— Choose a color from one of the color sets provided.
— Specify the color code manually.

— Copy the color with an eyedropper.

General b |2 :I Q = & . B Freeze
W

P G.r"c: oo Qo
- No Fill

Mumber Format

Theme Colors:

Standard Colors:
Recent Colors:
More Colors... ﬂ

Figure 346. Fill Color button and color selection pane
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4.11.10.1.1 Choose a color from the color sets provided

The following colors sets are available in the color selection pane (see Figure 346):

— Theme Colors: This block contains the color palette of the current document's theme.

— Standard Colors: This block contains the colors that users most often choose when
formatting a document.

— Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color
model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The color selection pane will

close. The cells will be colored in the selected color.

4.11.10.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code manually:

1. Click More Colors (see Figure 346).

2. In the Select Color window (see Figure 347) that appears, specify the desired color as
a HEX code or in RGB format.

3. Click OK.

Hex: Preview:

ed: Green: Blue:

o - o - o0

Figure 347. Select Color window
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The manually specified color will be added to the Recent Colors set (see Figure 346) and

checked. The color selection pane will close. The cells will be colored in the selected color.

4.11.10.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in
the main window's workspace (see Section 3.6) and filling the cells with this color.

To copy a color using the eyedropper, follow these steps:

1. Click ¢ Eyedropper (see Figure 346). The color selection pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color in which you want to color the cells. For more accurate
color selection, refer to the area to the right of the cursor. It displays the color of the pixel
that the cursor is currently hovering over.

3. Left-click the color.

The cells are colored in the selected color, and the cursor returns to its standard appearance.
The specified color is added to the Recent Colors set (see Figure 346) and checked in the color
selection pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.11.10.2 Remove the fill color
To remove the cell fill, follow the steps below:
1. Select the cell or cell range you want to cancel the fill.

2. On the Toolbar, in the Cells section, click the arrow to the right of the ﬁ Fill Color
button (see Figure 346).
3. Inthe window that appears, click No Fill.
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4.11.11 Cell borders

4.11.11.1 Change border parameters

By default, when you create a document, there are no borders between cells. The grid visible
on the sheet conventionally separates cells one from another to make working with data easier and
is not displayed when printing.

To add borders to cells or change settings previously applied to borders, follow these steps:

1. Select the desired cell or range of cells.

2. On the Toolbar, select the Cells section and click the arrow to the right of

the H Cell Borders button (see Figure 348).

General @ = & o= B Freeze
P 9% 00 00 j[ [H] E ﬂ % ©f Group v

Number Format

= / Mo Borders

Theme Colors:

EEENEE

Standard Colors:

Recent Colors:

Mare Colors... ﬁ

Figure 348. Border settings pane
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In the border settings pane that opens, in the first settings block, specify the position of
the borders for which you want to change the parameters.

In the second block of settings, select the type of line to be applied to the specified
borders.

In the third block of settings, specify the line color using one of the following methods:
— Choose a color from one of the color sets provided.

— Specity the color code manually.

— Copy the color with an eyedropper.

4.11.11.1.1 Choose a color from the color sets provided

The following colors sets are available in the border settings pane (see Figure 348):

Theme Colors: This block contains the color palette of the current document's theme.
Standard Colors: This block contains the colors that users most often choose when
formatting a document.

Recent Colors: This block contains up to the last ten colors that you selected when
formatting the document earlier. The Recent Colors set is displayed if you have selected

at least one color.

Hovering the mouse cursor over any color displays the value of that color in the RGB color

model. For example, RGB 192,80,77.

Left-click a color to select it.

The color will be added to the Recent Colors set and checked. The cell borders will be

colored in the selected color.

To close the border parameters pane, do one of the following:

On the Toolbar, select the Cells section and click the arrow to the right of
the HH Cell Borders button (see Figure 348).

Click a blank area of the document outside the border settings pane.
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4.11.11.1.2 Specify the color code manually

If you do not find the appropriate color in the listed color sets, specify the color code
manually:
1. Click More Colors (see Figure 348).
2. In the Select Color window (see Figure 349) that appears, specify the desired color as
a HEX code or in RGB format.
3. Click OK.

Hex: Preview:

ded: Green: Blue:

o - o - o0

Figure 349. Select Color window

The manually specified color will be added to the Recent Colors set (see Figure 348) and

checked. The border settings pane will close. The cell borders will be colored in the selected color.

4.11.11.1.3 Copy the color with an eyedropper

You can use the eyedropper to simultaneously copy a color from a text or object located in
the main window's workspace (see Section 3.6) and apply that color to the cell borders.

To copy a color using the eyedropper, follow these steps:

1. Click &' Eyedropper (see Figure 348). The border settings pane will close, and the
cursor will look like a crosshair for color selection.

2. Hover the cursor over the color in which you want to color the cell borders. For more
accurate color selection, refer to the area to the right of the cursor. It displays the color
of the pixel that the cursor is currently hovering over.

3. Left-click the color.
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The cell borders are colored in the selected color, and the cursor returns to its standard
appearance. The specified color is added to the Recent Colors set (see Figure 348) and checked in

the border settings pane.

If you want to disable the eyedropper without selecting a color, press Esc.

4.11.11.2 Apply the last selected border style

To quickly apply the last selected border style to a cell or range of cells, follow these steps:
1. Select the desired cell or range of cells.

2. On the Toolbar, in the Cells section, click EE| Cell Borders (see Figure 350).

D
CvE mE®s B. ¥
Hiv B B @ B <Bv 3

Cells Data

Figure 350. Button to apply previous table border style

4.11.11.3 Delete borders

To delete specified cell or cell range borders, follow the steps below:
1. Select the desired cell or range of cells.
2. On the Toolbar, select the Cells section and click the arrow to the right of
the [ Cell Borders button (see Figure 351).
3. In the border settings pane that opens:
— In the first block of settings, specify where you want the borders to be deleted.
— In the second block of settings, select No Borders.
4. To close the border parameters pane, do one of the following:
— On the Toolbar, select the Cells section and click the arrow to the right of
the EH Cell Borders button.

— Click a blank area of the sheet outside the border settings pane.
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/ Mo Borders

Figure 351. Remove borders

4.11.12 Copy and insert formatting

In MyOffice Spreadsheet, you can copy the formatting from one part of a document to

another. The formatting copied can be applied:
— Once (to one text fragment)

— Multiple time (to multiple text fragment one by one)

The formatting copied to the clipboard can also be used in MyOffice Text.
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4.11.12.1 Formatting basics

Depending on the selected item, you can format:
— Paragraph

—  Text

— Paragraph and text

— Cell

Table 24 specifies how the formatting is copied and applied.
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Table 24. Formatting basics

When you copy

When you insert

Result

The cursor is positioned, or
the entire paragraph
(paragraphs) is selected

The cursor is positioned

Formats the paragraph or the first
selected paragraph

A paragraph is partially selected

Formats the text

The entire paragraph
(paragraphs) is selected

Formats the paragraph and text

Several paragraphs are partially
selected

Formats the paragraph

A paragraph is partially
selected

The cursor is positioned

No formatting

A paragraph is partially selected

The entire paragraph
(paragraphs) is selected

Several paragraphs are partially
selected

Formats the text from the first
selected character

The cursor is positioned

A paragraph is partially
selected

The entire paragraph
(paragraphs) is selected (up to
the paragraph sign)

A spreadsheet cell is selected

Formats the paragraph and text in
the selected cell

Formats the text in the selected cell

Formats the paragraph and text

A spreadsheet cell is selected

A spreadsheet cell is selected

Formats the cell, paragraph, and
text

The cursor is positioned

Formats the paragraph

A paragraph is partially selected

Formats the text

The entire paragraph
(paragraphs) is selected

Formats the paragraph and text

Several paragraphs are partially
selected

Formats the paragraph

A row or column is selected

Formats the cell, paragraph, and
text

A row or column is selected

A row or column is selected

Formats the cell, paragraph, and
text from the upper left cell in
the copied row or column.

Formats the row or column

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

369



MyOffice

4.11.12.2 Copy and insert formatting

You can copy the formatting using:
— Command menu

— Keyboard shortcut
The é button on the Toolbar.

To copy the formatting using the command menu or a keyboard shortcut, perform
the following actions:
1. Select thepart of thedocument you want to copy the formatting from
(see the Table above).
2. Copy the formatting using one of the following methods:

— In the Edit menu, select Copy Formatting (see Figure 352).

Edit Insert Format Table Data Tools Vie

= Undo Ctrl+Z
~  Redo Ctrl+Y
o Cut Ctrl+X
Copy Ctrl+C
[[y Paste Ctrl+V
Paste Values and Format Ctri+Alt+V

Paste Values Only

Paste from Clipboard r
£ Copy Formatting Ctrl+5hift+C
Paste Formatting Ctrl+5Shift+V
Select All Ctrl+A
! Find Ctrl+F

Figure 352. Edit menu

—  Press Ctrl+Shift+C / {tShift+3%Cmd+C.
3. To apply the formatting to one part of the document, do the following:
— Select thepart of thedocument you want to copy the formatting to
(see the Table above).
— Inthe Edit menu, select Paste Formatting (see Figure 352) or press Ctrl+Shift+V /
{Shift+%Cmd+V.
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4. To apply the formatting to multiple elements in the document, select these elements one

by one and apply the formatting as described above.

AL

To format one element of a document using the = Copy Formatting button, follow these
steps:
1. Select thepart of thedocument you want to copy the formatting from

(see the Table above).

2. Onthe Toolbar, select the Edit section and double-click the & Copy Formatting button
(see Figure 353).

3. Select the part of the document you want to copy the formatting to (see the Table above).

File Edit Insert Format Table Data Tools View

+ By x o6~ [
Add S v 2O

Favarites File Edit

Figure 353. Edit menu
To format multiple elements of a document using the & Copy Formatting button, follow
these steps:
1. Select the part of the document you want to copy the formatting from (see the table

above).

2. Onthe Toolbar, select the Edit section and double-click the & Copy Formatting button.

The button will change to o)

3. Select the parts of the document you want to copy the formatting to one by one

(see the Table above) and apply the formatting.

To exit the multiple elements formatting mode, follow these steps:

1. On the Toolbar, select the Edit section and click the é button. The button will change
AL

to =0,

2. Press Esc.
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4.11.12.3 Formatting history

Formatting copied to the clipboard history is saved and can be applied later.

To open the formatting history, follow these steps:

I. On the Toolbar, select the Edit section and click thearrow to theright of
the & Copy Formatting button.

2. In the opened drop-down list, select the format you want (see Figure 354). The most
recent formatting is on the top of the list.

3. Select the part of the document you want to copy the formatting to as described in

Section 4.11.12.1.

Table Data Tools View Share Subscription Help

0 v XO Thames v 12 v
c 154.5

x 1543 11.44

Figure 354. Recent formatting
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4.12 Edit content

4.12.1 Undo and redo

4.12.1.1 Undo the last action

You can undo the last action performed on the content of a document.

To do this, use one of the following methods:

— In the Command menu, select Edit > Undo (see Figure 355).

Edit Inset Format Table Data Tools Vig

“ Undo Ctrl+Z
’ Redo Ctrl+Y
9 Cut Ctrl+X
Copy Ctrl+C
[Ty Paste Ctrl+V

Figure 355. Edit menu

—  On the Toolbar, in the Edit section, click "2 Undo (see Figure 356).

File Edit Insert Format Table Data Tools Wiew
+ v X D &
Add & v S C

Favorites File Edit

Figure 356. Undo and Redo buttons

— When working on Windows, press Ctrl+Z or Alt+Backspace, when working on

macOS, press 8Cmd+Z.

To undo several recent actions, run the undo command several times.
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4.12.1.2 Redo the result of the undone action

The undone action can be redone if necessary.

To do this, use one of the following methods:

— In the Command menu, select Edit > Redo (see Figure 355).

—  On the Toolbar, in the Edit section, click C Redo (see Figure 357).

— When working on Windows, press Ctrl+Y / Ctrl+Shift+Z / Shift+Alt+Backspace.

When working on macOS, press % Cmd+Y.

To redo the last few undone actions, run the redo command several times.
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4.12.2 Clipboard

4.12.2.1 Cut or copy data

When you use the Cut command, the selected content is removed from the document and
placed to the clipboard. When copying, the selected contents of the document do not change, and
their copies are placed to the clipboard.

The content copied or cut retains its formatting.

You can insert the data copied or cut into MyOffice Spreadsheet, as well as into other

applications, such as MyOffice Text.

f If you want to cut or copy data that contains an object (such as a shape or image), cut, or
copy the data and the object separately.

To cut data, follow these steps:

1. Select the object you want to cut, or the cell, cell range, rows, or columns you want to
cut the content from.

2. Run the cutting command in one of the following ways:
— In the Edit menu, select Cut (see Figure 355).
— On the Toolbar, select the Edit section and click % Cut (see Figure 357).

File Edit Insert Format Table Data Tools View

+ "" J‘L ﬁ" é
Add E]v 7

Favorites File Edit

Figure 357. Cut and Copy buttons

— Right-click the selected object, cells, or the titles/contents of the selected
rows/columns to open the context menu. Run the Cut context menu command.

— Press Ctrl+X or Shift+Delete (Windows OS). In macOS, press ssCmd+X.
To copy data, follow these steps:

1. Select the object you want to copy, or the cell, cell range, rows, or columns you want to

copy the content from.
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2. Select the copy command in one of the following ways:
— In the Edit menu, select Copy (see Figure 355).
— On the Toolbar, select the Edit section and click the | Copy (see Figure 357).
— Right-click the selected object, cells, or the titles/contents of the selected
rows/columns to open the context menu. Run the Copy context menu command.

—  Press Ctrl+C or Ctrl+Insert (Windows). In macOS, press 36 Cmd+C.

The copied cells, rows, or columns are highlighted by a dashed line frame. The frame
automatically disappears when the copied data is pasted again.

If you want to remove the dotted frame manually, press the Esc key.
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4.12.2.2 Paste the last cut or copied data

Pre-copied or cut out data in the clipboard is available for inserting. If you have copied or

cut a range of cells/rows or columns, the inserted data will be of the same size.

A Inserting data into non-empty cells or ranges deletes the previous data without warning.

You can paste data from the clipboard with or without saving the original formatting.

To insert the content while keeping its original formatting:

1. Place the cursor where you want to insert the data:

If theclipboard contains data from a single cell/row/column, select
the cell/row/column where you want to paste the data.

If the clipboard contains a range of cells/rows/columns, select the appropriate size
range, or select the cell/row/column where you want to paste the contents of the first
cell/row/column in the range.

If the clipboard contains an object, select the cell to align the upper left corner of

the object to.

2. Paste the content in one of the following ways:

Select Edit > Paste (see Figure 355).

On the Toolbar, select the Edit section and click IE Paste (see Figure 358).
On the Toolbar, select the Edit section and click the arrow to theright of

theﬁ Paste button. In the drop-down list, select the Paste command

(see Figure 358).

Insert Format Table Data Tools View Share Subscription

hd % lI:‘_W @3 ,% v XO Thames

= v o C U AB
Iﬁ Paste I~
File Edit
Paste Values and Format
v o2 v fx
Paste Values Only
A B E

Figure 358. Paste button
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— Open the context menu by right-clicking the selected cells or the titles/content of
the selected rows/columns. Run the Paste context menu command.

— Press Ctrl+V or Shift+Insert (Windows). In macOS, press Cmd+V.

The following rules apply when pasting data without preserving the original formatting:

— Only the text is pasted from the clipboard. For example, when you paste a shape with
text or a link, only the text that these objects contain is pasted into the document.

— If theclipboard contains a formula, only theresult of the formula is pasted

(see Section 4.5.8).

To insert the data without the original formatting, follow these steps:
1.  Specify where you want to paste the data:

— If theclipboard contains data from a single cell/row/column, select
the cell/row/column where you want to paste the data.

— If the clipboard contains a range of cells/rows/columns, select the appropriate size
range, or select the cell/row/column where you want to paste the contents of the first
cell/row/column in the range.

— If the clipboard contains a text object, select the cell into which you want to paste
the text.

2. Run the paste command in one of the following ways:

— Select Edit > Paste Values Only (see Figure 359).

Edit Insert Format Table Data Tools Vie|

3 Undo Ctrl=Z

" Redo Ctrl+Y

o Cut Ctrl+X

Copy Ctrl=C

[fy Paste Ctrl=V
Paste Values and Format Ctrl+Alt+W
Paste Values Only
Paste from Clipboard 4

& Copy Formatting Ctrl+5Shift=C
Paste Formatting Ctrl+Shift+V
Select All Ctrl+A

) Find Ctrl+F

Figure 359. Edit menu
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— On the Toolbar, select the Edit section and click the arrow to theright of

the I Paste button. In the drop-down list, select the Paste Values Only command
(see Figure 358).

— Right-click the selected cells or the content of the selected rows or columns to open

the context menu. In the context menu, select Paste Values Only.
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4.12.2.3 Insert data from the clipboard history

The clipboard history is available in MyOffice Spreadsheet. It can simultaneously store up

to ten copied or cut entries. Each next entry will take the place of the oldest one in the history.

The clipboard history works between MyOffice Spreadsheet and MyOffice Text and vice

versa.

Data from the expanded clipboard is pasted with the original formatting intact.

4.12.2.3.1 Insert data

To insert data from the clipboard history, do the following:

1. Specify where you want to insert the data:

— If the clipboard

contains

data from

the same cell/row/column, select

the cell/row/column where you want to paste the data.

— If the clipboard contains a range of cells/rows/columns, select the appropriate size

range, or select the cell/row/column in which to paste the contents of the first

cell/row/column in the range.

— If the clipboard contains an object, select the cell to align the upper left corner of the

object to.

2. Open the clipboard history in one of the following ways:

— In the Command

(see Figure 360).

Edit Insert

<) Undo
Redo

rl-

Cut

Copy
Paste

& O K

Paste Values and Format
Paste Values Only
Paste from Clipboard

£ Copy Formatting

Paste Formatting
Select All

Find

Format Table

menu,

Data Tools View

Ctrl+Z
Ctrl+Y

Ctrl+X
Ctrl+C
Ctrl+V
Ctrl+Alt+V

»

Ctrl+Shift+C
Ctrl+Shift+V

Ctrl+A

Ctrl+F

select

Edit > Paste from Clipboard

Share Subscription Help

XO Thames v 12 | w
BIUMT -~ &
Font

D E F
11.44

154.3

Clipboard History Ctrl+Alt+Shift+V

Clear

Figure 360. Data in the clipboard history
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— Open the context menu by right-clicking the selected cells or the titles/content of
the selected rows/columns. Select the Paste from Clipboard context menu
command.

3. In the opened sub-menu, select the data you want to paste.

For convenience, the contents of the clipboard can be opened in a separate window.
To do this, perform one of the following actions:
— In the Command menu, select Edit > Paste from Clipboard > Clipboard History
(see Figure 361).
— Open the context menu by right-clicking any cell or any row/column headers/contents.
Run the context menu command Paste from Clipboard > Clipboard History.

— Press Ctrl+Alt+Shift+V / ~=Option+{Shift+%Cmd+V.

Edit Insert Format Table Data Tools View Share Subscription Help

3 Undo Ctrl+Z XO Thames vl (12 v
' Redo Ctrl+Y
- BIUMT - &
3 Cut Ctrl+X
1 Font
Copy Ctrl+C
Ty Paste Ctrl+V
Paste Values and Format Ctrl+Alt+V D E F
1
Paste Values Only
Paste from Clipboard 4 11.44
154.3
£ Copy Formatting Ctrl+Shift+C
Paste Formatting Ctrl+Shift+V Clipboard History Ctrl+Alt+Shift+V
Clear
Select All Ctrl+A
Find Ctrl+F

Figure 361. Clipboard history commands

By default, the clipboard history window (see Figure 362) is positioned next to
the highlighted or last highlighted cell (for example, if a column is highlighted). To change the

window's position, drag it by the title bar while holding down the left mouse button.
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[ Select text for pasting

rmanth
year
Total
505
Balance
2011

2013

Figure 362. Clipboard history

How to navigate the clipboard history:

— To move through the clipboard entries, use the | and 1 keys.

— To paste the selected entry from the clipboard to the specified place of the document,
click the left mouse button or press the Enter key.

— To switch between the document and the clipboard history, use the Tab key.

— To close the clipboard history window, click the : button in its header.

4.12.2.3.2 Clear clipboard history

To clear the history of the clipboard history, follow these steps:
1. Open the clipboard history sub-menu in one of the following ways:
— In the Command menu, select Edit > Paste from Clipboard
(see Figure 359).
— Open the context menu by right-clicking any cell or any row/column
headers/contents. Select the Paste from Clipboard context menu command.

2. In the opened sub-menu, click Clear.
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4.13 Automation tools

4.13.1 Macros

A macro is a set of actions that automate repeated or time-consuming tasks in a text
document.

MyOffice Spreadsheet macros are written in Lua programming language.

Macros are most used for the following purposes:

— Adding a formula to a cell.

— Adding text to a cell.

— Find and replace items throughout the text.

— Delete text.

Macro commands can only be saved within the current document. If you want to use similar

macro commands in another document, create them directly in the other document.
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4.13.1.1 Create a macro

You can create a macro in one of the following ways:
1. Record a sequence of actions that a macro command should consist of.

2. Enter the macro text manually.

To record a macro, do the following:
1. Inthe Tools menu, select Macros > Record Macro (beta) (see Figure 363).

2. Run the sequence of actions that a macro command should consist of.

In the current version of the application, not all user actions are available for recording.
When you perform an action that cannot be recorded, the "Action cannot be recorded"

message pops up on the screen.

Tools View Share Subscription Help

i b
Spelling and Grammar 12 A AF
Custom Dictionary

Change Language... -
Macros r Macro Editor
Record Macro (beta)
C p) r r G

Figure 363. Record Macro command (beta)

3. Finish the recording process in one of the following ways:

— In the Tools command menu, select Macros > Stop Recording (see Figure 364).

Tools View Share Subscription Help

i 4
Spelling and Grammar vl [12 [v]
Custom Dictionary
B T .. A
Change Language... -
Macros 4 Macro Editor
Stop Recording
C D E F

Figure 364. Stop Recording command menu option

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 384



MyOffice

—  On the Status bar, click [ Stop Recording (see Figure 365).

22
23

[l

F‘a Automatic

@ Stop Recording

4. Inthe opened dialog box (see Figure 366), specify the macro name and click OK.

Figure 365. Stop Recording button

MName:

‘ Untitled

d

Figure 366. Dialog box

If the macro has been successfully saved, the following pop-up message will be displayed

on the screen: “""Macro_name'" macro saved.”
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To enter the macro text manually, do the following:
1. In the Tools command menu, select Macros > Macro Editor (see Figure 363).

2. In the Macro Editor window, click the + button (see Figure 371).

=d Macro Editor >

+ —
Prn » Debug [ |

Output:

Figure 367. Macro Editor command
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3. Enter the macro name or keep the default name (see Figure 372). To keep the name,

press Enter or click anywhere on the macro editor area with the mouse.

5 Macro Editor >

Lntitled

+ —_—
Pruin »Debug B

Output:

Figure 368. Entering the macro name

4. Enter the macro script (see Figure 369).
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= Macro Editor x
range = document:getRange():
Seript 1 atartPos = range:getBegin():
Script 2 textProp = range:getTextProperties():
textProp.italic = true;
textProp.allfapitals = true;
range:setlextProperties (textProp)
g ata:tPos:i:‘.se:t?extt":-:'_'.?f:"_:.&|. w1 8
+
’ Run 3? Debug C]
Output:
Figure 369. Entering the macro script
The script will be saved automatically.
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When a macro has been added to a document, the Sidebar will display the ® Macros button
(see Figure 374). Clicking this button opens the Macro pane where you can perform the following
actions:
— Find a macro (see Section 4.13.1.2)
— Run a macro (see Section 4.13.1.3)

— Open the Macro Editor (see Section 4.13.1.1).

mE®m B V-2 By O
Ed ¥ ¢y *va@d &

Data Insert ~

~ > Macros

Q
®

Untitled
Untitled 1 )
Untitled 2 Cv

Figure 370. Macro pane

To close the Macro Editor pane, click the = button above the search line, or click
® Macros on the Sidebar once again.

The ® Macros button is displayed on the Sidebar if the document contains at least one

macro.
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4.13.1.2 Find a macro

If a file contains multiple macros and that you need to find a specific macro, do the following:
1. On the Sidebar, click @ Macros (see Figure 371).
2. In the macros pane, specify the macro title in full or partially.

The list of macros will display the macros matching the search request.

- Macros Q
2 X fe
Macro 2 ®

&

Figure 371. Search the macro

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 390



MyOffice

4.13.1.3 Run a macro

You can run a macro command using the macro editor or the Macro pane.
To run a macro command using the macro editor, follow these steps:

1. Inthe Command menu, click Tools > Macros > Macro Editor (see Figure 372).

Tools View Share Subscription Help

i 4
Spelling and Grarmmar vl [12 [v] A= At
Custom Dictionary
B T Ao ©.
Change Language... -
Macros r Macro Editor
Record Macro (beta)
C D F F G

Figure 372. Macro Editor menu
2. In the Edit Macros window that appears, select the macro from the list

(see Figure 373).
3. Click ® Run.
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=) Edit Macros >
range = document: getRange():
Mew Script startPoz = range:getBegin():
. textProp = range . getTextPropertie=s();
New Script 1 textProp.italic = true:
textProp.allCapitals = true;
Mew Script 2
range: =etTextProperties{textProp) ;
Ve (T eru B startPos:insertText( "HyOfficel ")
+
P Run 1? Debug [ |
Cutput:
Figure 373. Run button
The results are displayed in the Output pane (see Figure 374).
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=) Edit Macros >
range = document:getFange();
Mew Script startPoz = range:getBegini):
. textProp = range:getTextProperties():
New Script 1 textProp.italic = true;
textProp.allCapitals = true;
Mew Script 2
range: setTextPropertie=s( textProp)
New Script 3 startPos: insertText{ "HyOffice! ") ;
+ f—
P rRun 1? Debug [ |
Output: Mew Script Clear ®
The macro has been succes=fully completed.
Figure 374. Macro results
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To run a macro using the Macro pane:

1. On the Sidebar, click @ Macros (see Figure 375).

maE®E Ey T3 By O
Ed ¥ 6. v 3 =

Data Insert ~

~ - Macros

Untitled b 7

Untitled 1 )

Untitled 2 Cv
Cx

Figure 375. Macro pane

2. Run the macro in one of the following ways:
— In the Macro pane, place the cursor over the macro title and click [* Run
(see Figure 375).
— Select the line of the macro by double-clicking it.
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4.13.1.4 Edit a macro

To edit a macro, do the following:
1. Open the window where you can edit a macro in one of the following ways:

— In the Command menu, click Tools > Macros > Macro Editor (see Figure 376).

Tools  View Share Subscription Help

i 3
Spelling and Grammar vl [12 [v] A- A+
Custom Dictionary
B T Ao £
Change Language... -
Macros 4 Macro Editor

Record Macro (beta)
C D F F G

Figure 376. Tools command menu

— On the Sidebar, click ® Macros (see Figure 377). In the macro pane, place

the cursor over the title of the macro that you want to edit and click ¢ Edit.

maE®m By V3 By O
Ed¥ ey a3 &

Data Insert ~

) A - Macros Q
Eeaa-c-'- ] A

Untitled g @

Untitled 1 0

Untitled 2 Cv

Cx

Figure 377. Macro pane

2. In the Edit Macros window, select the desired macros from the list (see Figure 373).

3. Make the changes to the script.

All changes made to the script are saved automatically.
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4.13.1.5 Debug a macro

Before you start the macro debugger, set the debugger breakpoints in the macro text.
To do this:

1. Open the macro editing window in one of the following ways:
— In the Command menu, click Tools > Edit Macros (see Figure 376).
— On the Sidebar, click ® Macros (see Figure 377).
2. In the Macros Editor window, select the desired macro from the list (see Figure 378).

In the Macro pane, hover your mouse over the name of the macro command you want to
edit and click £ Edit.

3. Set the first debugger breakpoint. To do this, click to the right of the line number where you
want to create a breakpoint. The breakpoint will be marked with the @ icon.

4. Set other breakpoints by repeating these actions.

To delete a breakpoint, click it with the mouse.
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J Edit Macros

~ ® range = document:getRange();

Mew Script startPo= = range:getBegin():
. textProp = range: getTextPropertie=();

New Script 1 textProp.italic = true:
textProp.allCapitals = true;

Mew Script 2
range: =etTextProperties{textProp)

(e v 9 startPos:insertText( "HyOfficdl ")

+ f—

P Run 1? Debug [ |

Output:

Figure 378. Breakpoint

To debug a macro, do the following:

1. Click & Debug (see Figure 379). The macro debugging process will begin. If the text of a
macro contains breakpoints, the debugging process will stop on the line that contains
the first breakpoint. If there are no breakpoints, the debugging process will stop at the first

line of the macro.
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=) Edit Macros >

® range = document:getRange():

Mew Script startPos = range:getBegini):
. textProp = range . getTextPropertie=s();

New Script 1 textProp.italic = true:
textProp.allCapitals = true;

Mew Script 2
range: =etTextProperties{textProp) ;

Ve (T eru B v 9 startPos:insertText( "HyOfficel ")

+ —_

P Run 1? Debug [ |

Cutput:

Figure 379. Debug button
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To manage the debugging steps, use the following buttons (see Figure 380):
= : Perform one debugging step or step into the body of the function if there is one in
the current debugging position.
=} : Perform one debugging step without stepping into the body of the function.
= : Continue executing the macro until leaving the function where the debugger is at

the current position.

While debugging, the Macros Editor window displays the following areas:

— In progress: This window will display messages while debugging.

— Calls Stack: The calls stack window.

— Variables: This window displays the values of local and global variables available at
the current macro step. If the displayed variable is a table or an array, you can view its

detailed contents by clicking the button to the left of the variable name.
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=) Edit Macros >
@ range = document:getRange():
Mew Script 2@ =startPos = range:getBegin():
. textProp = range . getTextPropertie=s();
New Script 1 textProp.italic = true:
textProp.allCapitals = true;
Mew Script 2
range: =etTextProperties{textProp) ;
Ve (T eru B startPos:insertText ("HyDifice!");
+ —_—
P Run 2 Debug B = s
In progress... Call Stack Variakles
rnain(jFupl ocal:
Global:
range = [DocumentAPl.Range)
Figure 380. Debug a macro
The debugging process ends once the end of the macro has been reached.
To interrupt the debugging process, click the B Break script button.
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4.13.1.6 Delete a macro

To delete a macro:
1. Open the macro editing window in one of the following ways:

— In the Command menu, click Tools > Edit Macros (see Figure 381).

Tools View Share Subscription Help

i 2

Spelling and Grammar vl [12 [v] A~ At
Custom Dictionary

BT w Av £
Change Language... -
Macros 4 Macro Editor

Record Macro (beta)
C D F F G

Figure 381. Tools menu

— On the Sidebar, click @ Macros (see Figure 382). In the macro pane, place

the cursor over the title of the macro that you want to delete and click & Edit.

mE®w BEY T3S By O
BEd ¥ B @3 &=

Data Insert ~
~ - Macros Q
L M

Eea-'c-" ‘ fx

Untitled b2 @

Untitled 1 (9

Untitled 2 Cwv

Cx

Figure 382. Macro pane

2. In the Macros Editor window, select the desired macro from the list (see Figure 383).

3. Click the — button.
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=) Edit Macros >
~ 1@ zrangse = document :getRange(): ~
Mew Script ¥ =tartPos = range:getBegin():
. textProp = range:getTextProperties(]
New Script 1 textProp.italic = true;
W textProp.allCapitals = true:;
W
— B S I S e L S i ey T e L T
+ +£ >

P Run ,n,* Debug

Output:

Figure 383. Delete a macro

4. In the opened window, confirm that you want to delete the macro.

4.13.1.7 View VBA macro code

In MyOffice Spreadsheet application, you cannot run VBA macros created in
Microsoft Excel. However, you can view the code of VBA macros contained in the document and

rewrite them in Lua.

You can only view VBA macros saved in This spreadsheet.

To view and rewrite the VBA macro code, follow these steps:

1. Open the .xIsm or .xlsb file.

2. Select the Lua macro with the name of the VBA module that contains the desired VBA
macro. For example, if VBA macro Macrol is contained in VBA module Modulel,
select Lua macro Modulel. To select the Lua macro, do one of the following:

— In the Command menu, select Tools > Macros > Macro Editor
(see Figure 381). In the Edit Macros window (see Ommboka! UcTOYHHUK CCHUIKH

He HalifeH.), select the desired Lua macros.
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] Edit Macros ¢

@ Global CFlag As Boolean
Modulel
Sub MakeNumberFarmat()
Meodule? : Dim whb As Workbook
Dim ws As Worksheet

+ —
P Rrun ?Dehug[:]@?‘rﬂlﬁ

Qutput

Figure 384. Edit Macros window

— On the Sidebar, click (5) Macros (see Figure 385). In the Macro pane, place

the cursor on the desired Lua macro and click # Edit.

mao®m B V-R[3Iv By O
BEd ¥ 6 “v@m =

Data Insert ~

) e - Macros Q
[ |Sea.rd‘ ] x

Untitled b2z ®

Untitled 1 @

Untitled 2 Cv

Figure 385. Macro pane
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The Edit Macros pane will display the VBA macros code in the respective VBA module
(see Figure 384).

3. Rewrite the code of the desired VBA macros in Lua language.

4. Close the macro editor window.

5. Save thefile in  the.xlsx format using theSave as command

(see Section 4.1.10.1)

The changes made will not be saved in the initial .xlsm or .xlsb file.
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4.14 Protect a file

4.14.1 Protect content from changes

MyOffice Spreadsheet allows to protect the following elements:
— Sheet: Users will not be able to edit all or protected sheet cells.
— Document structure: Users will not be able to add, delete, move, rename, duplicate, hide

sheets or display hidden sheets.

4.14.1.1 Protect a sheet

You can protect all or selected cells on the sheet from changes in the workspace
(see Section 3.6). By default, MyOffice Spreadsheet protects all cells.
To protect the contents of a sheet, follow these steps:
1. Click the sheet tab with the mouse.
2. Open the Manage Protection pane in one of the following ways:
— In the Command menu, select Data > Manage Protection > Protect Sheet

(see Figure 386).

Data Tools View Share Subscription Help

Define Name... [ vl 2 |v A f:\+ = =
Manage Protection » Protect Sheet...

Refresh Pivot Table Protect Spreadsheet Structure... ) .
Pivot Table Settings [

Figure 386. Protect Sheet menu
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22
23
24

— Right-click the sheet tab and run the Protect Sheet context menu command

(see Figure 387).

Hide Zero Values
Protect Sheet... »

Delete

Sheet1 Sheet?2 m +

Figure 387. Context menu of a sheet

. If you want to protect all cells of the workspace, do not uncheck the Locked for changes

box on the Sheet tab (see Figure 388).

. If you need to specify the cells that users will be able to edit after installing protecting

the sheet:
—  Select these cells.

— Uncheck the Locked for changes box.

. If you want users to see only the result of the formula calculation in the protected cells

and on the Formula bar:
— Select these cells.

— Check the Formulas not displayed box.
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SvE @y BY B
H - o2

Cells Data Insert ~

]

, - Manage Protection Q
Sheet  Spreadsheet Structure fx
Cell properties N
Locked for changes \E’
Formulas not displayed Cv
Cx
Allowed actions v
Password (optional) A

>
Protect Sheet @)

Figure 388. Manage Protection pane

6. Expand the Allowed actions section (see Figure 389) and specify what actions users are

allowed to perform with protected cells.
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- Manage Protection Q
Sheet  Spreadsheet Structure fx
My

Allowed actions A @
Allow all users to do the following: &'
With cells o
Select locked cells CX

Format cells
With columns

Insert columns

Format columns

Delete columns
With rows

Insert rows

Format rows

Delete rows
On sheet

Insert links

Sort data

Filter data

Insert and edit objects "

BT

Figure 389. Allowed action section

7. If you need to set a password to remove protection from the sheet, expand the section

Password (optional) (see Figure 390), enter the password and confirm it.
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8. Click Protect Sheet.

Password (optional) ~

Password:

| z

Confirm Password:

&

Protect Sheet

Figure 390. Password (optional) section

9. Close the Manage Protection pane in one of the following ways:

— At the top of the pane, click = (see Figure 392).
—  On the Sidebar, click = Manage Protection (see Figure 392).

When working with a file in Microsoft Excel and LibreOffice Calc applications, sheet

protection settings are not applied to cells located outside the workspace (see Section 3.6).

4.14.1.2 Protect the document structure

To protect the document structure, follow these steps:
1. Open the Manage Protection pane. To do this, in the Command menu, select Data >

Manage Protection > Protect the document structure (see Figure 391).
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Data Tools View Share Subscription Help

Define Name... | . 2 v A” A+ ::
Manage Protection » Protect Sheet...
Protect Spreadsheet Structure...

I rrrrerrr

Refresh Pivot Table

Figure 391. Protect Sheet menu

2. Inthe Manage Protection pane, select the Spreadsheet Structure tab (see Figure 392):
— If necessary, set a password to unprotect the document structure.

— Click Protect Structure.
3. Close the Manage Protection pane in one of the following ways:

— In the upper part of the pane, click =.
— On the Sidebar, click (= Manage Protection.
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£v= @ B
H v v ©of v .
Cells Data

~ -» Manage Protection

Sheet Spreadsheet Structure

i Protect the spreadsheet structure to keep

the number and order of sheets

Password (optional) A
Password:
| ®|
Confirm Password:
s}

>
Protect Structure

Figure 392. Manage Protection pane
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4.14.1.3 Unprotect a sheet

If the sheet is protected from editing, the sheet tab displays the @ icon (see Figure 393) is

displayed on the sheet tab. You may need to enter a password to unprotect the sheet.

31
32
i3

Sheet?  Sheet @ +

Figure 393. Sheet protected from editing

To remove protection from a sheet, do the following:
1. Click the sheet tab.
2. Open the Manage Protection pane in of the following ways:
— In the Command menu, select Data > Manage Protection > Unprotect Sheet

(see Figure 394).

Data Tools View Share Subscription Help

Define Name... |_

Gen

Manage Protection » Unprotect Sheet...
Protect Spreadsheet Structure...

Refresh Pivot Table

Figure 394. Unprotect Spreadsheet menu
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— Right-click the sheet tab and use the Unprotect Sheet context menu command

(see Figure 395).

Rename

Duplicate
Hide
Hide Zero Values

Unprotect Sheet...

Sheet1 @ Delete

Figure 395. Context menu of the sheet

3. Inthe Manage Protection pane, select the Sheet tab and do the following:
— If thesheet is password-protected, enter the password, and click Unprotect

(see Figure 396).

, A > Manage Protection Q
Sheet  Spreadsheet Structure fx

Cv

Cx

Protected Sheet

To unprotect the sheet, enter the password.

Password:

..ooo| (s24] l

Unprotect

Figure 396. Manage Protection pane
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— If the sheet is not password-protected, click Unprotect (see Figure 397).
4. To close the Manage Protection pane, do one of the following:

— In the upper part of the pane, click =.
—  On the Sidebar, click (= Manage Protection.

;A - Manage Protection Q
Sheet Spreadsheet Structure fx

| .

Cx

Protected Sheet

To edit cells, unprotect the sheet.

Unprotect

Figure 397. Unprotected sheet

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 414



MyOffice

4.14.1.4 Unprotect file structure

If the document structure is protected from editing, an icon & is displayed to the right of

the sheet tabs (see Figure 398). You may be required to enter a password to remove the protection.

15
16
17

10

Sheet1 Sheet2 m G

Figure 398. Data command menu

To remove protection from the document structure, do the following:
1. Open the Manage Protection pane. To do this, in the Command menu, select

Data > Manage Protection > Unprotect Sheet (see Figure 398).

Data Tools View Share Subscription Help

Define Name... l+

Manage Protection » Protect Sheet...
Unprotect Spreadsheet Structure...

Refresh Pivot Table

Figure 399. Sheet command menu

2. In the Manage Protection pane, select the Spreadsheet Structure pane and
do the following:
— If the document structure is password-protected, enter the password, and click

Unprotect (see Figure 400).
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;oA -> Manage Protection Q
Sheet  Spreadsheet Structure Fx

Cwv

CX

Protected Structure

To unprotect the spreadsheet structure,
enter the password.

Password:

.oo| &

Figure 400. Manage Protection pane

— If thedocument structure is not password-protected, click Unprotect
(see Figure 401).
3. To close the Manage Protection pane, do one of the following:

— In the upper part of the pane, click =.
— On the Sidebar, click = Manage Protection.

, A - Manage Protection Q
Sheet  Spreadsheet Structure fx

CX

Protected Structure

To be able to manage the sheets, unprotect
the spreadsheet structure.

Unprotect

Figure 401. Unprotected spreadsheet structure
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APPENDIX 1. FUNCTIONS AND THEIR DESCRIPTION

Function

Description

Financial

COUPPCD(settlement, maturity,
frequency, [day count convention])

Returns the numeric date value of the last coupon date before
the settlement date of a security.

DOLLARDE(fractional price, unit)

Converts a dollar value expressed as a fraction into a decimal
number.

DOLLARFR(decimal price, unit)

Converts a dollar value expressed as a decimal number into a
fractional number.

IRR(cashflow amounts, [rate_guess])

Calculates the internal rate of return on an investment based on
regular cash flows which include both payments and incomes.

NPV(discount, cashflowl, [cashflowZ, ...])

Returns the numeric value which is the net present value of an
investment depending on a series of periodic cash flows and a
discount rate.

PMT(rate, number of payments,
present_value, [future value],
[end or beginning])

Returns the periodic payment for an annuity based on constant
periodic payments and a constant interest rate.

PV(rate, number of periods,
payment_per period, [future value],
[end or beginning])

Returns the present value of an investment based on periodic
payments and a constant interest rate.

Time and date

DATE(year, month, day)

Creates a date from the specified year, month, and day.

DATEVALUE(date_string)

Transforms the provided date string in a known format to a
numeric date value.

DAY (date)

Returns the day of the month that a specific date falls on, in
numeric format.

EDATE(start_date; months)

Returns the numeric value of a date which falls a specified
number of months before or after another date.

EDATE(start_date; months)

Returns the date representing the last day of the month which
falls a specified number of months before or after another date.

HOUR(time) Extracts the hour component from a given time value.
ISOWEEKNUM(date) Returns the ISO week number (from 1 to 54) for a given date.
MINUTE(time) Extracts the minute component from a given time value.
MONTH(date) EE::;ESC tfl:)er rrrrllglth of the year the specific date falls in, in
NOW() Returns the current date and time as a timestamp value.
TODAY() Returns the current date in number format.

YEAR(date) Returns the year specified by a given date.

Math and trigonometry

ABS(value) Returns the absolute value of a number. The result of calculation

is always a positive number.

© New Cloud Technologies Ltd., 2013-2024. All rights reserved.

417




MyOffice

Function Description
ACOS(value) Calculates the arccosine, that is the inverse cosine of a given
number, and returns an angle expressed in radians.
ACOSH(value) Calculates the inverse hyperbolic cosine for a number.
Calculates the arccotangent, that is the inverse cotangent of a
ACOT(value) given number, and returns an angle, in radians, between 0 (zero)
and m.
ASIN(value) Calculates the arcsine, that is thg inverse sine of a given number,
and returns an angle expressed in radians.
Calculates the arctangent, that is the inverse tangent of a given
ATAN(value) number, and returns an angle, in radians, between -Pi/2 and Pi/2.
Returns the arctangent of an angle between the x-axis and a
ATAN2(x, y) segment starting from the origin (0,0) and ending at a specific
Y. point defined by the coordinate pair (x,y). The resulted value is
expressed in radians.
ATANH(value) Calculates the inverse hyperbolic tangent for a number.
COSH(value) Calculates the hyperbolic cosine for a real number.
COTH(angle) Calculates the hyperbolic cotangent of a number.
Calculates the cosecant of a number and returns the result in
CSClangle) radians.
CSCH(angle) Calculates. the hyperbohc cosecant of a number and returns
the result in radians.
DEGREES(angle) Converts an angle value in radians to the equivalent value in
degrees.
EXP(exponent) Returns the e number (~2.718) raised to a supplied power.
FACTDOUBLE(value) Returns the double factorial of a number.
INT (value) Rounds a number down to the nearest integer.
LN(value) Returns the logarithm of a number to base e (~2.718) which is

known as the natural logarithm.

LOG(value, [base])

Returns the logarithm of a number with respect to a given base.

LOG10(value)

Returns the base-10 logarithm of a given number.

PI()

Returns the pi value rounded to 14 decimal places.

POWER (base, exponent)

Returns the result of raising a number to a power.

PRODUCT((factorl, [factor2, ...])

Returns the product of supplied arguments.

QUOTIENT (dividend, divisor)

Divides a number by another one and returns a value without a
reminder.

RAND()

Returns a random decimal number between 0 and 1, excluding
the boundary values.

ROUND(value, places)

Rounds a number to a certain number of digits according to
standard rounding rules.

ROUNDDOWN(value, places)

Rounds a number down to a certain number of decimal places.

ROUNDUP(value, places)

Rounds a number up to a certain number of digits.
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Function Description

SEC(angle) Returns the secant of an angle, in radians.

SECH(angle) Returns the hyperbolic secant of an angle.

SINH(value) Returns the hyperbolic sine of a number.

SQRT(value) Returns the positive square root of a number.

SQRTPI(value) Returns the square root of the pi constant (3.14159265358979)

multiplied by a given number.

SUBTOTAL (function_code, rangel,
[rangeZ, ...])

Uses another function (SUMM, PRODUCT, etc.) to calculate
the subtotal for a set of numbers.

For more details, see Section
SUBTOTAL function.

SUBTOTAL (function_code, rangel,
[rangeZ, ...])

Uses another function to calculate a subtotal for a vertical range
of cells.

SUM(value 1, [value 2; ...])

Returns the result of adding series of numbers, and/or cells.

SUMIF(range, criterion, [sum_range])

Returns the sum of a range of values matching a certain criterion.

SUMIFS(sum_range, criteria_rangel,
criterionl, [criteria_rangeZ2, criterion2, ...])

Returns the sum of a range of values matching multiple criteria.

SUMPRODUCT (array1, [array?2, ...])

Multiplies ranges or arrays together and returns the sum of
products.

SUMSQ(valuel, [value2, ...])

Returns the sum of the squares of numbers.

TANH(value)

Returns the hyperbolic tangent of a number.

Statistical

AVERAGE(valuel, [valueZ, ...])

Returns the average of numbers in a dataset, ignoring text.

COUNT (valuel, [valueZ, ...])

Returns the count of numeric values in a supplied dataset.

COUNTA(valuel, [value2, ...])

Looks through a given dataset and returns the number of cells
containing any type of information.

COUNTBLANK((range)

Returns the count of empty and blank cells in a given range or
array.

COUNTIF(range, criterion)

Returns the number of times cell values meet a certain criterion.

COUNTIFS(criteria_rangel, criterionl,
[criteria_range2, criterion2, ...])

Returns the number of cells that meet multiple criteria.

F.DIST(x, freedom_degreesl,
freedom_degrees2, cumulative)

Calculates the left-tailed F probability distribution (degree of
diversity) for two data sets with a given x.

F.DIST.RT(x, freedom_degreesl,
freedom_degrees?2)

Calculates the right-tailed F probability distribution (degree of
diversity) for two data sets with a given x.

FISHER(value)

Returns the Fisher transformation for a given value.

LARGE(data, n)

Arranges a given numeric dataset in descending order and returns
a value depending on its relative position where the largest value
takes the first position.

LINEST(known data_y, [known_ data_x],
[calculate_b], [stats])

Calculates parameters of the linear trend based on the least-
squares method.

MAX(valuel, [value2, ...])

Retrieves the maximum number from a numeric dataset.
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Function

Description

MIN(valuel, [valueZ, ...])

Retrieves the minimum number from a numeric dataset.

NORM.DIST(x, mean, standard_deviation,
cumulative)

Returns the normal distribution function for the specified values
of the arithmetic mean and the standard deviation.

RANK.EQ(value, data, [is_ascending])

Arranges numeric values in ascending or descending order and
determines the rank position of a specified value in a dataset. For
duplicate values, a rank of the first value is assigned.

SMALL(data, n)

Arranges a given numeric dataset in ascending order and returns a
value based on its relative position where the smallest value takes
the first position.

STDEV.S(valuel, [value2, ...])

Calculates the standard deviation based on a sample.

VAR(valuel, [valueZ, ...])

Calculates the variance based on a given sample.

VARA(valuel, [valueZ, ...])

Calculates the variance based on a sample, treating text values as
0 (zero).

VARPA(valuel, [valueZ, ...])

Analyzes data in a range and returns the variance of that data
range. Text and logical values are considered.

Lookup and reference

ADDRESS(row, column,
[absolute relative mode],
[use al notation], [sheet])

Returns the cell location in a spreadsheet based on specified row
and column numbers.

AREAS(reference)

Returns the number of areas in a reference or a range. An area is
considered as a separate cell reference or a range of cells.

CHOOSE(index, choicel, [choice2, ...])

Retrieves the value from a dataset based on its position number.

COLUMN([cell_reference])

Returns the column number of a specified cell.

COLUMNS(range)

Returns the count of columns in a range or an array.

HLOOKUP(search_key, range, index,
[match_type])

Evaluates the first row of a range for a search value and returns a
value which is located in a different row but in the same column.

HYPERLINK(url, [link_label])

Creates a link in a cell of a spreadsheet.

INDEX (reference, [row], [column])

Returns the element of an array or range, specified by its row and
column position.

INDIRECT (cell reference as_string,
[is Al notation])

Returns the content of the reference which can be a cell or a
string.

LOOKUP(search key, search range,
[result range]) (1)

LOOKUP(search key, search result array)
)

Looks through a row or a column for a key and returns the cell
value in a result range located in the same position as a search
row or column.

Looks through multiple rows or columns for a key and returns a
value of the cell located in the correspondent position of the same
search rows or columns. To search for a key across a single row
or column, specify the result range value as the third argument.

MATCH(search_key, range, [search_type])

Allows finding a specified item in the defined range of cells by a
desired search type. The function returns the item index (that is a
position number of the item in an array), not the item itself.
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Function

Description

OFFSET(cell_reference, offset rows,
offset_columns, [height], [width])

Returns a cell or a range of cells shifted by a specified number of
rows and columns from the initial cell reference.

ROW([cell reference])

Returns the number of the row where a cell is specified.

ROWS(range)

Returns the count of rows in a range or an array.

VLOOKUP(search_key, range, index,
[match_type])

Searches down the first column of a range for the first matching
key and returns the corresponding value from another column.

Database

DSUM(database, field, criteria)

Calculates the sum of database values matching the specified
criteria.

Text

ASC (string)

Converts a text encoded in a double byte character set (DBCS) to
a text in a single byte character set (SBCS). In the spreadsheet
editor, the function is only used for the backward compatibility
with documents containing text encoded in DBCS.

CLEAN(text)

Removes non-printable characters from a given string.

CODE(string)

Returns the Unicode numeric value of the first character in a
given string.

CONCATENATE(stringl, [string?2, ...])

Joins separate entries into a single string.

DBCS(string)

Converts a text from ASCII to DBCS and backwards. In
the spreadsheet editor, the function is only used for the backward

compatibility with documents containing text encoded in either
ASCII or DBCS.

EXACT(string1, string2)

Checks whether two strings are identical and, if so, returns
TRUE.

FIND(search_for, text to search,
[starting_at])

Returns the position at which a string is first found within text
(case sensitive).

FINDB(search for, text to search,
[starting_at])

Returns the position at which a string is first found within text
counting double letters as two characters.

JIS(string)

Converts a text from ASCII to DBCS and backwards. In

the spreadsheet editor, the function is only used for the backward
compatibility with documents containing text encoded in either
ASCII or DBCS.

LEFT(string, [number of characters])

Returns a substring from the beginning of a specified string.

LEFTB(string, [number of characters])

Returns a substring from the beginning of a specified string based
on the supplied number of characters.

LEN(text) Returns the length of the specified string.
LENB(text) Returns the count of characters in the supplied string.
LOWER (text) Finds uppercase letters in a given string to convert them to

lowercase.

MID(string, starting_at, extract length)

Returns a segment of a string.

MIDB(string, starting_at, extract length)

Returns a segment of a string based on the specified number of
bites.
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Function

Description

PROPER(text to capitalize)

Capitalizes the first letter of every word in a specified string.

RIGHT (string, [number of characters])

Returns the rightmost character or characters of a given string.

RIGHTB(string, [number of characters])

Returns the rightmost character or characters of a given string
based on the specified number of bites.

SEARCH(search for, text to_search,
[starting_at])

Returns the starting position of a string within a text.

SEARCHB(search_for, text to search,
[starting_at])

Returns the position at which a string is first found within text
counting double letters as two characters.

SUBSTITUTE(text _to_search, search_for,
replace_with, [occurrence_number])

Replaces a specific string with another one in a text.

TEXT (value, format)

Converts a numeric value into a text value according to a
specified format.

Removes all spaces in the specified string, except the single

TRIM(text) spaces between words.
UNICODE(string) Ret.urns thtle Unicode numeric value of the first character in
a given string.
UPPER (text) Converts all lowercase letters in a specified string to uppercase.
Logic

AND(logical expressionl,
[logical expressionZ, ...])

Returns TRUE if all the supplied tests are successful, and FALSE
if at least one fails.

FALSE()

Returns the FALSE logical value.

IF(logical expression, value_if true,
[value if false])

Returns one value if the result of a logical test is TRUE and
another if it is FALSE.

IFERROR(value, value_if error)

Returns the first argument if it is not an error value, and
the second argument if a given value is an error.

IFNA(value, value_if na)

Returns the first argument if it is not #N/A, otherwise, returns
the second argument.

OR(logical expressionl,
[logical expression2, ...])

Returns TRUE if any of the specified logical tests is successful,
and FALSE if all logical tests fail.

SWITCH(expression, valuel, result1,
[valueZ, result?, ...], [default])

Evaluates a list of expressions and returns the value
corresponding to the first expression in the list.

TRUE()

Returns the TRUE logical value.

Information

CELL(info_type, [reference])

Returns the requested data about a particular cell.

INFO(info_type)

Returns the requested information relating to the user’s operating
system and the data processing environment.

Checks whether a referenced cell is empty, and if so, returns

ISBLANK(value) the TRUE logical value.
ISERR(value) Returns TRUE if a given value is an error other than #N/A.
ISERROR((value) Returns TRUE if a given value is an error.
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Function Description

ISEVEN(value) Checks whether a value is an even number and, if so, returns
TRUE.
Checks whether a value is either FALSE or TRUE and returns

ISLOGICAL(value) TRUE on any of them.

ISNA(value) Checks whether a value is the #N/A error and, if so, returns
TRUE.

ISNUMBER((value) Checks whether a given value is a number.

ISODD(value) Checks whether a value is an odd number and, if so, returns
TRUE.

ISREF(value) Returns TRUE if a supplied value is a valid cell reference.

ISTEXT (value) Checks whether a given value is textual.

NA() Returns the #N/A error which stands for "value is not available".

Engineering

COMPLEX(real _number, Creates a complex number based on specified real and imaginary

imaginary number, [suffix]) components.

IMABS(complex number) Returns the absolute value of a complex number.
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SUBTOTAL function

Syntax

SUBTOTAL(function code, rangel, [rangeZ2, ...])

Description

Uses another function (SUMM, PRODUCT, etc.) to calculate the subtotal for a set of

numbers.

Function_code: The numeric code of the function to be used to calculate the subtotal

(see Table 25). Use codes 1-11 to include manually hidden cells in the count, or 101-111 to exclude

them. Cells hidden using a filter are always excluded.

Table 25. Numeric codes

Function_code Function_code Function
(Include hidden values) (Exclude hidden values)

1 101 AVERAGE
2 102 COUNT

3 103 COUNTA
4 104 MAX

5 105 MIN

6 106 PRODUCT
7 107 STDEV

8 108 STDEVP

9 109 SUM
10 110 VAR
11 111 VARP

rangel: The first range or array over which to calculate a subtotal.

[range2; ...]: Additional ranges or arrays over which to calculate subtotals. This parameter

is optional.
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Example:

=SUBTOTAL(9, B2:B5): Calculate the sum of values in cells B2:B5, considering

the values in the cells hidden manually.

=SUBTOTAL(109, B2:B5): Calculate thesum of values in cells B2:B5, without

considering the values in the cells hidden manually.

A

Item
Apples
Oranges
Bananas

= on | B W | =

Bb v

fx =SUBTOTAL(9, B2:B5)
B C
Cost
100
100
100
400

Figure 402. Function use examples

Bb v

A

Item
Apples
Oranges
Bananas

= o b P | =

fx =SUBTOTAL(109, E2:E5)

Cost

E

100
100
100
300

C D

Figure 403. Function use examples

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 425



MyOffice

APPENDIX 2. LIST OF SUPPORTED CURRENCIES

Currency name Currency code
Azerbaijani manat AZN
Armenian dram AMD
Belarusian ruble BYN
Bulgarian lev BGN
Brazilian real BRL
Won KRW
Hryvnia UAH
Danish krone DKK
US dollar uUSD
Euro EUR
Zloty PLN
Yen JPY
Indian rupee INR
Moldovan leu MDL
Turkmenistan new manat T™T
Norwegian krone NOK
Russian ruble RUB
Romanian leu RON
Rand ZAR
Som KGS
Somoni TJS
Tenge KzZT
Turkish lira TRY
Uzbekistani som UzZS
Forint HUF
Pound sterling GBP
Czech koruna CZK
Swedish krona SEK
Swiss franc CHF
Yuan Renminbi CNY
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APPENDIX 3. KEYBOARD SHORTCUTS

This appendix contains the keyboard shortcuts used in Windows OS (see Table 26) and

macOS (see Table 27).

On laptops, some keys are multifunctional. For example: F1-F12, Home, End, PgUp,

PgDn. When pressing these keys in MyOffice Spreadsheet, you need to hold Fn down at

the same time.

Table 26. Windows shortcuts

Keyboard shortcuts Command or action
Edit the content

Ctrl+X

Shift+Delete cut

Ctrl+C Copy

Ctrl+Insert

Ctrl+V

Shift+Insert Insert

Ctrl+Alt+V Insert values and format

Ctrl+S Save

F12 Save as

Ctrl+2 Cancel the last action

Ctrl+Y Repeat the result of the canceled action
Ctrl+Alt+Shift+Z Open the clipboard history

Backspace Delete one character to the left of the cursor
Delete Delete one character to the right of the cursor
Ctrl+Backspace Delete part of a word or the entire word to the left of the cursor
Ctrl+Delete E);lse(‘ii part of a word or the entire word to the right of the
Alt+Enter Begin a new paragraph

Ctrl+Shift+Space Insert a non-breaking space

Ctrl+Shift+ — Insert a non-breaking hyphen

Ctrl+Num — Insert an en dash

Ctrl+Alt+Num — Insert an em dash

Content formatting

Ctrl+B Bold

Ctrl+I Italic
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Keyboard shortcuts Command or action
Ctrl+U Underline

Ctrl+Shift+= Superscript

Ctrl+= Subscript

Ctrl+Shift+A All caps

Ctrl+Shift+C Copy formatting

Ctrl+Shift+V Apply formatting

Ctrl+L Align the cell content to the left
Ctrl+E Center the cell content

Ctrl+R Align the cell content to the right
Ctrl+J Justify the cell content

Move throughout the workspace

Page Up One screen up

Page Down One screen down

Ctrl+Home Go to the first workspace cell (A1 cell)
Ctrl+End Go to the last workspace cell

Actions with cells, rows, and columns

F2 Switch to cell editing mode
Alt+A Select a row upwards
Alt+B Select a row downwards
Alt+L Insert a column to the left
Alt+R Insert a column to the right
Ctrl+Alt+M Merge cells

Alt+Shift+M Split cells

Ctrl+- Delete a row or a column

Select cells, rows, and columns

Arrow Up

Select the cell upwards

Arrow Down

Select the cell downwards

Tab or Right Arrow Select the next cell

Left Arrow Select the previous cell

Home Select the cell at the beginning of the row

End Select the cell at the end of the row

Shift+Space Select a row

Ctrl+Space Select a column

Ctrl+Shift+Home Create a selection area from the selected cell to the first cell of
the workspace (cell A1)

Ctrl+Shift+ End Create a selection area from the selected cell to the last cell of

the workspace

© New Cloud Technologies Ltd., 2013-2024. All rights reserved. 428




MyOffice

Keyboard shortcuts Command or action
Select all cells in the sheet workspace

Ctrl+A

Shift+Arrow Up Expand the selection by one cell upwards

Shift+Arrow Down

Expand the selection by one cell downwards

Select text in the edited cell *

Shift+Left Arrow

Select one character to the left of the cursor

Shift+Right Arrow

Select one character to the right of the cursor

Ctrl+ Shift+Left Arrow

Select one word to the left of the cursor

Ctrl+ Shift+Right Arrow

Select one word to the right of the cursor

Shift+Home

Select the content from the cursor to the beginning of the line

Shift+End

Select the content from the cursor to the end of the line

Ctrl+ Shift+Arrow Up

Extend the selection to the beginning of the paragraph

Ctrl+ Shift+Arrow Down

Extend the selection to the end of the paragraph

Shift+Arrow Up

Expand the selection by one row/cell upwards

Shift+Arrow Down

Expand the selection by one row/cell downwards

Double-click the left mouse button

Select a word

Triple-click the left mouse button

Select a paragraph

Click the left mouse button and move
the cursor upwards

Select the text upwards

Click the left mouse button and move
the cursor downwards

Select the text downwards

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select the cell

by double-clicking or pressing F2.

Move within the text in the edited cell *

Left Arrow

Move one character to the left

Right Arrow Move one character to the right
Ctrl+Left Arrow Move one word to the left
Ctrl+Right Arrow Move one word to the right
Arrow Up Move one line up

Arrow Down

Move one line down

Ctrl+Arrow Up

Go to the beginning of the previous paragraph

Ctrl+Arrow Down

Go to the beginning of the next paragraph

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select the cell

by double-clicking or pressing F2.

Paboma ¢ ggopmynamu u gynxuuamu

Alt+F9

Replace the formula (entirely or partially) with its calculated
value
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Keyboard shortcuts Command or action

F9 Recalculate formulas in the entire document

Shift+F9 Recalculate formulas on the sheet

Ctrl+Shift+F9 Force recalculate formulas

Ctrl+Shift+F5 Update references to data in external documents

Other keyboard shortcuts

Ctrl+N Create a file

Ctrl+O Open a file

Ctrl+P Open the window for previewing and setting page and printing

parameters of the document

Ctrl+0 (zero)

Set the actual page scale (100%)

Ctrl+K Insert a link
Ctrl+F

Open the search pane
Ctrl+H
Shift+F3 Open the Inset function pane
Ctrl+/ Open the Quick action box
F1 Open the Help

Click the right mouse button

Open the context menu of the selected element

Alt+Space

Open the context menu of the active application window

Alt+F4

Close the active application window
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Table 27. Keyboard shortcuts in macOS

Keyboard shortcuts Command or action
Edit the content

% Cmd + X Cut

% Cmd + C Copy

®Cmd+V Insert

~= Option + $Cmd + V Insert values and format

$Cmd + S Save

{ Shift + 2 Cmd + S Save as

$Cmd + Z Cancel the last action

®Cmd+Y Repeat the result of the canceled action

~ Option + f Shift + 3 Cmd + Z

Open the clipboard history

Delete

Delete one character to the left of the cursor

Fn + Delete

Delete one character to the right of the cursor

3 Cmd + Delete
~< Option + Delete

Delete part of a word or the entire word to the left of the
cursor

32 Cmd + Fn + Delete

~= Option + Fn + Delete

Delete part of a word or the entire word to the right of the
cursor

~c Option + 7 Enter

Begin a new paragraph

~= Option + 1 Shift + Space

Insert a non-breaking space

3 Cmd + {t Shift + —

Insert a non-breaking hyphen

~= Option + -

Insert an en dash

~= Option + {I Shift + —

Insert an em dash

Content formatting

% Cmd + B Bold

$Cmd + 1 Italic

®Cmd+U Underline

{ Shift + ¢ Cmd + = Superscript

% Cmd + = Subscript

{ Shift + ¢ Cmd + A All caps

{ Shift + ¢ Cmd + C Copy formatting
{ Shift + ¢ Cmd +V Apply formatting

% Cmd + L Align the cell content to the left
% Cmd + E Center the cell content

% Cmd + R Align the cell content to the right
%6 Crmd + J Justify the cell content
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Keyboard shortcuts

Command or action

Move within the workspace

Fn + Arrow Up

One screen up

Fn + Arrow Down

One screen down

Fn + 3 Cmd + Left Arrow

Go to the first workspace cell (A1 cell)

Fn + 3 Cmd + Right Arrow

Go to the last workspace cell

Actions with cells, rows, and columns

Fn+F2 Switch to cell editing mode
~< Option + A Select a row upwards

~< Option + B Select a row downwards

~< Option + L Insert a column to the left
~ Option + R Insert a column to the right
~ Option + ¥ Cmd + M Merge cells

~c Option + { Shift + M Split cells

% Cmd + —

Delete a row or a column

Select cells, rows, and columns

Arrow Up

Select the cell upwards

Arrow Down

Select the cell downwards

Tab or Right Arrow

Select the next cell

Left Arrow

Select the previous cell

Fn + Left Arrow

Select the cell at the beginning of the row

Fn + Right Arrow

Select the cell at the end of the row

© Shift +Space

Select a row

f Shift + 3¢ Cmd + Space

Select a column

{ Shift + Fn + ¥ Cmd + Left Arrow

Create a selection area from the selected cell to the first cell
of the workspace (cell A1)

{t Shift + Fn + 3 Cmd + Left Arrow

Create a selection area from the selected cell to the last cell
of the workspace

% Cmd+ A

Select all cells in the sheet workspace

f Shift + Arrow Up

Expand the selection by one cell upwards

{t Shift + Arrow Down

Expand the selection by one cell downwards

Select text in the edited cell*

{t Shift + Left Arrow

Select one character to the left of the cursor

f Shift + Right Arrow

Select one character to the right of the cursor

{ Shift + ¢ Cmd + Left Arrow

Select one word to the left of the cursor

f Shift + ss Cmd + Right Arrow

Select one word to the right of the cursor

Fn +1t Shift + Left Arrow

Select the content from the cursor to the beginning of
the line
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Keyboard shortcuts

Command or action

Fn +{ Shift + Right Arrow

Select the content from the cursor to the end of the line

ft Shift + * Ctrl + $¢ Cmd + Arrow Up

Extend the selection to the beginning of the paragraph

{ Shift + * Ctrl + ¢ Cmd + Arrow Down

Extend the selection to the end of the paragraph

{ Shift + Arrow Up

Expand the selection by one table row/cell upwards

{t Shift + Arrow Down

Expand the selection by one row/cell downwards

Double-click the left mouse button

Select a word

Triple-click the left mouse button

Select a paragraph

Click the left mouse button and move
the cursor upwards

Select the text upwards

Click the left mouse button and move
the cursor downwards

Select the text downwards

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select
the cell by double-clicking or pressing F2.

Move within the text in the edited cell*

Left Arrow

Move one character to the left

Right Arrow

Move one character to the right

% Cmd + Left Arrow

Move one word to the left

3 Cmd + Right Arrow

Move one word to the right

Arrow Up

Move one line up

Arrow Down

Move one line down

% Cmd + Arrow Up

Go to the beginning of the previous paragraph

32 Cmd + Arrow Down

Go to the beginning of the next paragraph

* These keyboard shortcuts are used when editing data in a table cell. To switch to edit mode, select
the cell by double-clicking or pressing F2.

Paboma ¢ popmyaamu u ynkuuamu

~c Option + F9

Replace the formula (entirely or partially) with its calculated

N P

F9

Recalculate formulas in the entire document

{ Shift + F9

Recalculate formulas on the sheet

{ Shift + 3¢ Cmd + F9

Force recalculate formulas

© Shift + 3¢ Cmd + F5

Update references to data in external documents

Other keyboard shortcuts

% Cmd + N Create a file

% Cmd + O Open a file

% Cmd + P Open the window for previewing and setting page and

printing parameters of the document

3 Cmd + 0 (zero)

Set the actual page scale (100%)

% Cmd + K

Insert a link
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Keyboard shortcuts Command or action
% Cmd + F Open the search pane

2 Cmd +/ Open the Quick action box

Fn+F1 Open the Help

Click the right mouse button

Open the context menu of the selected element

% Cmd + Q

Close the active application window
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